why PowerPC project build status do not update ?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

why PowerPC project build status do not update ?

Normand
Hi there,

I noticed this morning on PowerPC (1) project that many ruby packages are failing as needing ruby 2.3 rpm
I do not see progress of the status in the web ui page during the day.

Why is there no progress on the build results status ?

If I try to build locally the rubygem-gem2rpm package, then I am able to build locally other failing ruby packages.
I do not know if this is that is feasible/acceptable in the PowerPC project.


(1) https://build.opensuse.org/project/show/openSUSE:Factory:PowerPC
===
Build finished, but repository publishing is disabled ppc64 succeeded: 8586 failed: 307 unresolvable: 23 disabled: 11 excluded: 200
Build finished, but repository publishing is disabled ppc64le succeeded: 8575 failed: 300 unresolvable: 24 disabled: 10 excluded: 218
===


--

Michel Normand

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: why PowerPC project build status do not update ?

Andreas Schwab-2
Normand <[hidden email]> writes:

> I noticed this morning on PowerPC (1) project that many ruby packages are failing as needing ruby 2.3 rpm

There appears to be something wrong with the ruby macros, probably an
inconsistency beween the obs view and the rpm view.  I haven't been able
to find out what's going wrong here so far.

Andreas.

--
Andreas Schwab, SUSE Labs, [hidden email]
GPG Key fingerprint = 0196 BAD8 1CE9 1970 F4BE  1748 E4D4 88E3 0EEA B9D7
"And now for something completely different."
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: why PowerPC project build status do not update ?

Normand


On 08/06/2016 16:54, Andreas Schwab wrote:

> Normand <[hidden email]> writes:
>
>> I noticed this morning on PowerPC (1) project that many ruby packages are failing as needing ruby 2.3 rpm
>
> There appears to be something wrong with the ruby macros, probably an
> inconsistency beween the obs view and the rpm view.  I haven't been able
> to find out what's going wrong here so far.
>
> Andreas.
>

Is there an OBS scheduler log associated to the PowerPC ppc64le arch ?
and do I have a way to access it ?

--
Michel Normand

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: why PowerPC project build status do not update ?

Normand
In reply to this post by Andreas Schwab-2

On 08/06/2016 16:54, Andreas Schwab wrote:

> Normand <[hidden email]> writes:
>
>> I noticed this morning on PowerPC (1) project that many ruby packages are failing as needing ruby 2.3 rpm
>
> There appears to be something wrong with the ruby macros, probably an
> inconsistency beween the obs view and the rpm view.  I haven't been able
> to find out what's going wrong here so far.
>
> Andreas.
>

Andreas,
There is something strange in the log of rubygem-gem2rpm in OBS (1)
The osc build process is retrieving  ruby* versions  2.1 and 2.2
while the version 2.3 is already available (as per log extract (2))

Do you have a suggestion on how to investigate ?


On the other and If I try a local osc build in my own ppc64le
then I do not have such failure.


=== (1) about OBS failing log:
https://build.opensuse.org/package/live_build_log/openSUSE:Factory:PowerPC/rubygem-gem2rpm/standard/ppc64le
$grep -E 'cumulate.*ruby' rubygem_gem2rpm_obs_ppc64le_failure.log
[   14s] [74/118] cumulate libruby2_1-2_1-2.1.9-1.3
[   14s] [75/118] cumulate libruby2_2-2_2-2.2.5-1.2
[   15s] [114/118] cumulate ruby-common-2.1-9.3
[   15s] [115/118] cumulate ruby2.1-stdlib-2.1.9-1.3
[   15s] [116/118] cumulate ruby2.2-stdlib-2.2.5-1.2
[   15s] [117/118] cumulate ruby2.1-2.1.9-1.3
[   15s] [118/118] cumulate ruby2.2-2.2.5-1.2
===
[   17s] error: Failed build dependencies:
[   17s]        ruby2.3 is needed by rubygem-gem2rpm-0.10.1-9.4.ppc64le
[   17s]
[   17s] build89 failed "build rubygem-gem2rpm.spec" at Wed Jun  8 14:57:47 UTC 2016.
===

=== ruby2.3 already available in OBS:
(2) https://build.opensuse.org/package/live_build_log/openSUSE:Factory:PowerPC/ruby2.3/standard/ppc64le
[  668s] ... saving built packages
[  668s] RPMS/noarch/ruby2.3-doc-ri-2.3.1-1.2.noarch.rpm
[  668s] RPMS/ppc64le/ruby2.3-devel-extra-2.3.1-1.2.ppc64le.rpm
[  668s] RPMS/ppc64le/ruby2.3-debugsource-2.3.1-1.2.ppc64le.rpm
[  668s] RPMS/ppc64le/libruby2_3-2_3-2.3.1-1.2.ppc64le.rpm
[  668s] RPMS/ppc64le/ruby2.3-2.3.1-1.2.ppc64le.rpm
[  668s] RPMS/ppc64le/ruby2.3-devel-2.3.1-1.2.ppc64le.rpm
[  668s] RPMS/ppc64le/ruby2.3-stdlib-2.3.1-1.2.ppc64le.rpm
[  668s] RPMS/ppc64le/ruby2.3-debuginfo-2.3.1-1.2.ppc64le.rpm
[  668s] RPMS/ppc64le/ruby2.3-tk-2.3.1-1.2.ppc64le.rpm
[  668s] RPMS/ppc64le/ruby2.3-doc-2.3.1-1.2.ppc64le.rpm
[  668s] RPMS/ppc64le/ruby2.3-stdlib-debuginfo-2.3.1-1.2.ppc64le.rpm
[  668s] RPMS/ppc64le/libruby2_3-2_3-debuginfo-2.3.1-1.2.ppc64le.rpm
[  668s] RPMS/ppc64le/ruby2.3-tk-debuginfo-2.3.1-1.2.ppc64le.rpm
[  668s] SRPMS/ruby2.3-2.3.1-1.2.src.rpm
[  668s] OTHER/_statistics
[  668s] OTHER/rpmlint.log
[  668s]
[  668s] build88 finished "build ruby2.3.spec" at Wed Jun  8 00:07:25 UTC 2016.
===

=== (3) no failure if local osc build
$grep -E 'cumulate.*ruby' rubygem_gem2rpm_abanc_passed.log
[   15s] [68/118] cumulate libruby2_2-2_2-2.2.5-1.2
[   15s] [69/118] cumulate libruby2_3-2_3-2.3.1-1.2
[   16s] [92/118] cumulate ruby2.2-stdlib-2.2.5-1.2
[   16s] [93/118] cumulate ruby2.3-stdlib-2.3.1-1.2
[   17s] [112/118] cumulate ruby-common-2.1-9.3
[   17s] [116/118] cumulate ruby2.2-2.2.5-1.2
[   17s] [117/118] cumulate ruby2.3-2.3.1-1.2
===
[   64s] ... saving built packages
[   64s] RPMS/ppc64le/ruby2.2-rubygem-gem2rpm-0.10.1-0.ppc64le.rpm
[   64s] RPMS/ppc64le/ruby2.3-rubygem-gem2rpm-doc-0.10.1-0.ppc64le.rpm
[   64s] RPMS/ppc64le/ruby2.3-rubygem-gem2rpm-0.10.1-0.ppc64le.rpm
[   64s] RPMS/ppc64le/ruby2.2-rubygem-gem2rpm-doc-0.10.1-0.ppc64le.rpm
[   64s] SRPMS/rubygem-gem2rpm-0.10.1-0.src.rpm
[   64s] OTHER/rpmlint.log
[   64s]
[   64s] abanc finished "build rubygem-gem2rpm.spec" at Thu Jun  9 08:05:41 UTC 2016.
===


--
Michel Normand

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]