weird build problem related to QT and cmake

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

weird build problem related to QT and cmake

Mathias Homann-2
Hi,

I have a package, home:lemmy04/stellarium, that lately fails to build
with this:

[   67s] CMake Error at CMakeLists.txt:335 (MESSAGE):
[   67s]   Found Qt5: /usr/lib64/qt5/bin/qmake (found unsuitable version "..",
[   67s]   required is "5.3.0")


My project uses KDE:Qt5 and aggregates cmake from devel:tools:building.

Any ideas?

Cheers
MH

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: weird build problem related to QT and cmake

Luigi Baldoni
Mathias Homann-2 wrote
I have a package, home:lemmy04/stellarium, that lately fails to build
with this:

[   67s] CMake Error at CMakeLists.txt:335 (MESSAGE):
[   67s]   Found Qt5: /usr/lib64/qt5/bin/qmake (found unsuitable version "..",
[   67s]   required is "5.3.0")


My project uses KDE:Qt5 and aggregates cmake from devel:tools:building.

Any ideas?
Due to changes to Qt5 you need to do something like
sed -e 's/Qt5Core_VERSION_STRING/Qt5Core_VERSION/g' -i CMakeLists.txt

Regards
Loading...