v0.50 RC1 of smart Package Manger now available

classic Classic list List threaded Threaded
20 messages Options
Reply | Threaded
Open this post in threaded view
|

v0.50 RC1 of smart Package Manger now available

Basil Chupin
RC1 of v0.50 of smart is now available for testing (it's working OK
here, BTW).

To install the copy prepared by Pascal Bleser, from command line as root:

smart update guru && smart install

smart update

smart install smart-gui smart-ksmarttray smart-addons


The first line will remove the current copy of smart, the rest will
install the RC1.

Cheers.

--
"If the terrier and the bariffs are torn down, this economy will grow."

                                         George W. Bush  January 2000


--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

PerfectReign
On Tuesday 07 November 2006 19:26, Basil Chupin wrote:

> RC1 of v0.50 of smart is now available for testing (it's working OK
> here, BTW).
>
> To install the copy prepared by Pascal Bleser, from command line as root:
>
> smart update guru && smart install
>
> smart update
>
> smart install smart-gui smart-ksmarttray smart-addons
>
>
> The first line will remove the current copy of smart, the rest will
> install the RC1.
>
> Cheers.

Thank you, I tried this.

I got the following:

For the first two items, I get, "channels have no new packages."

For the third, I get...

sith:/home/kai # smart install smart-gui smart-ksmarttray smart-addons
Loading cache...
Updating cache...               ########################################
[100%]

warning: smart-gui-0.42-14.guru.suse101@i686 is already installed
warning: smart-ksmarttray-0.42-14.guru.suse101@i686 is already installed
warning: smart-addons-0.42-14.guru.suse101@i686 is already installed
Computing transaction...

--
kai ponte
www.perfectreign.com

--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Basil Chupin
Kai Ponte wrote:

> On Tuesday 07 November 2006 19:26, Basil Chupin wrote:
>> RC1 of v0.50 of smart is now available for testing (it's working OK
>> here, BTW).
>>
>> To install the copy prepared by Pascal Bleser, from command line as root:
>>
>> smart update guru && smart install
>>
>> smart update
>>
>> smart install smart-gui smart-ksmarttray smart-addons
>>
>>
>> The first line will remove the current copy of smart, the rest will
>> install the RC1.
>>
>> Cheers.
>
> Thank you, I tried this.
>
> I got the following:
>
> For the first two items, I get, "channels have no new packages."
>
> For the third, I get...
>
> sith:/home/kai # smart install smart-gui smart-ksmarttray smart-addons
> Loading cache...
> Updating cache...               ########################################
> [100%]
>
> warning: smart-gui-0.42-14.guru.suse101@i686 is already installed
> warning: smart-ksmarttray-0.42-14.guru.suse101@i686 is already installed
> warning: smart-addons-0.42-14.guru.suse101@i686 is already installed
> Computing transaction...


Well I didn't get these error messages but I did check in the Manager
what was and what wasn't installed and....

I have just posted a message in the [hidden email] list about this (do
you subscribe to that list?) and advised that the 'old' - ie, 0.42* -
version is still installed but that the RC1 is shown as being
*available* for installation. The instructions (the above 3 lines) which
Pascal posted to install the RC1 don't appear to be doing what was meant
for them to do and I am now waiting for Pascal to respond to my message.

If you subscribe to [hidden email] list then watch for the answer there
otherwise I'll post it here when Pascal responds.

Cheers.


--
"If the terrier and the bariffs are torn down, this economy will grow."

                                         George W. Bush  January 2000


--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Basil Chupin
Basil Chupin wrote:

> Kai Ponte wrote:
>> On Tuesday 07 November 2006 19:26, Basil Chupin wrote:
>>> RC1 of v0.50 of smart is now available for testing (it's working OK
>>> here, BTW).
>>>
>>> To install the copy prepared by Pascal Bleser, from command line as
>>> root:
>>>
>>> smart update guru && smart install
>>>
>>> smart update
>>>
>>> smart install smart-gui smart-ksmarttray smart-addons
>>>
>>>
>>> The first line will remove the current copy of smart, the rest will
>>> install the RC1.
>>>
>>> Cheers.
>>
>> Thank you, I tried this.
>> I got the following:
>>
>> For the first two items, I get, "channels have no new packages."
>>
>> For the third, I get...
>>
>> sith:/home/kai # smart install smart-gui smart-ksmarttray smart-addons
>> Loading cache...
>> Updating cache...              
>> ######################################## [100%]
>>
>> warning: smart-gui-0.42-14.guru.suse101@i686 is already installed
>> warning: smart-ksmarttray-0.42-14.guru.suse101@i686 is already installed
>> warning: smart-addons-0.42-14.guru.suse101@i686 is already installed
>> Computing transaction...
>
>
> Well I didn't get these error messages but I did check in the Manager
> what was and what wasn't installed and....
>
> I have just posted a message in the [hidden email] list about this (do
> you subscribe to that list?) and advised that the 'old' - ie, 0.42* -
> version is still installed but that the RC1 is shown as being
> *available* for installation. The instructions (the above 3 lines) which
> Pascal posted to install the RC1 don't appear to be doing what was meant
> for them to do and I am now waiting for Pascal to respond to my message.
>
> If you subscribe to [hidden email] list then watch for the answer there
> otherwise I'll post it here when Pascal responds.

OK, the answer from Pascal is that there is slight error in the last
line :-) .

The 3 lines to be executed to install the 0.50 RC1 should read:

smart update guru && smart install smart-beta

smart update

smart install smart-beta-gui smart-beta-ksmarttray smart-beta-addons


NOW it installed everything correctly :-) .

Cheers.



--
"If the terrier and the bariffs are torn down, this economy will grow."

                                         George W. Bush  January 2000


--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

PerfectReign
On Tuesday 07 November 2006 23:31, Basil Chupin wrote:
> Basil Chupin wrote:
<snip>
> > If you subscribe to [hidden email] list then watch for the answer there
> > otherwise I'll post it here when Pascal responds.

On that list, but need to switch my email over to this one. :P

>
> OK, the answer from Pascal is that there is slight error in the last
> line :-) .
>
> The 3 lines to be executed to install the 0.50 RC1 should read:
>
> smart update guru && smart install smart-beta
>
> smart update
>
> smart install smart-beta-gui smart-beta-ksmarttray smart-beta-addons
>
>
> NOW it installed everything correctly :-) .
>

Thank you!

Got it!

--
kai ponte
www.perfectreign.com

--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Bruce A. Mallett
In reply to this post by Basil Chupin

Basil Chupin wrote:

>
> OK, the answer from Pascal is that there is slight error in the last
> line :-) .
>
> The 3 lines to be executed to install the 0.50 RC1 should read:
>
> smart update guru && smart install smart-beta
>
> smart update
>
> smart install smart-beta-gui smart-beta-ksmarttray smart-beta-addons

I did this and get:

Installing packages (1):
  smart-beta-0.50rc1-2.guru.suse101@i686

Removing packages (2):
  smart-0.42-14.guru.suse101@i686          
smart-gui-0.42-14.guru.suse101@i686

473.8kB of package files are needed. 243.1kB will be freed.

Confirm changes? (Y/n): Y

Fetching packages...
->
http://ftp.gwdg.de/pub/linux/misc/.../smart-beta-0.50rc1-2.guru.suse101.i686.rpm
smart-beta-0.50rc1-2.guru.suse1..
############################################# [100%]


Committing transaction...
Preparing...                    
############################################# [  0%]
   1:Removing smart-gui          
############################################# [ 33%]
   2:Removing smart              
############################################# [ 66%]
   3:Installing smart-beta      
############################################# [100%]


# smart update
Traceback (most recent call last):
  File "/usr/bin/smart", line 194, in ?
    main(sys.argv[1:])
  File "/usr/bin/smart", line 164, in main
    initDistro(ctrl)
  File "/usr/lib/python2.4/site-packages/smart/__init__.py", line 145,
in initDistro
    execfile(distrofile, {"ctrl": ctrl, "iface": iface,
  File "/usr/lib/smart/distro.py", line 25, in ?
    for history in mirrors_history:
TypeError: iteration over non-sequence


 # smart install smart-beta-gui smart-beta-ksmarttray smart-beta-addons
Traceback (most recent call last):
  File "/usr/bin/smart", line 194, in ?
    main(sys.argv[1:])
  File "/usr/bin/smart", line 164, in main
    initDistro(ctrl)
  File "/usr/lib/python2.4/site-packages/smart/__init__.py", line 145,
in initDistro
    execfile(distrofile, {"ctrl": ctrl, "iface": iface,
  File "/usr/lib/smart/distro.py", line 25, in ?
    for history in mirrors_history:
TypeError: iteration over non-sequence


Which does not look so good to me.


--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Pete Connolly
On Wednesday 08 November 2006 18:48, Bruce A. Mallett wrote:

> I did this and get:
>
> # smart update
> Traceback (most recent call last):
>   File "/usr/bin/smart", line 194, in ?
>     main(sys.argv[1:])
>   File "/usr/bin/smart", line 164, in main
>     initDistro(ctrl)
>   File "/usr/lib/python2.4/site-packages/smart/__init__.py", line 145,
> in initDistro
>     execfile(distrofile, {"ctrl": ctrl, "iface": iface,
>   File "/usr/lib/smart/distro.py", line 25, in ?
>     for history in mirrors_history:
> TypeError: iteration over non-sequence
>
>
>  # smart install smart-beta-gui smart-beta-ksmarttray smart-beta-addons
> Traceback (most recent call last):
>   File "/usr/bin/smart", line 194, in ?
>     main(sys.argv[1:])
>   File "/usr/bin/smart", line 164, in main
>     initDistro(ctrl)
>   File "/usr/lib/python2.4/site-packages/smart/__init__.py", line 145,
> in initDistro
>     execfile(distrofile, {"ctrl": ctrl, "iface": iface,
>   File "/usr/lib/smart/distro.py", line 25, in ?
>     for history in mirrors_history:
> TypeError: iteration over non-sequence
>
>
> Which does not look so good to me.

Hi Bruce

Getting the exact same here, I'm afraid.  10.1 with all updates.  Had a quick
look, but don't understand enough to debug it, I'm afraid.

Cheers

Pete

--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Patrick Shanahan
* Pete Connolly <[hidden email]> [11-08-06 20:06]:
> Getting the exact same here, I'm afraid.  10.1 with all updates.  Had
> a quick look, but don't understand enough to debug it, I'm afraid.

Something to try:
  rm /var/lib/smart/channels
  rm /var/lib/smart/cache
smart update  

then try your upgrade as before.
--
Patrick Shanahan                        Registered Linux User #207535
http://wahoo.no-ip.org                        @ http://counter.li.org
HOG # US1244711         Photo Album:  http://wahoo.no-ip.org/gallery2

--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Bruce A. Mallett
Patrick Shanahan wrote:

> * Pete Connolly <[hidden email]> [11-08-06 20:06]:
>  
>> Getting the exact same here, I'm afraid.  10.1 with all updates.  Had
>> a quick look, but don't understand enough to debug it, I'm afraid.
>>    
>
> Something to try:
>   rm /var/lib/smart/channels
>   rm /var/lib/smart/cache
> smart update  
>
> then try your upgrade as before.
>  
Thanks for the suggestion Patrick, but I get the same thing.

--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Basil Chupin
In reply to this post by Bruce A. Mallett
Bruce A. Mallett wrote:

> Basil Chupin wrote:
>> OK, the answer from Pascal is that there is slight error in the last
>> line :-) .
>>
>> The 3 lines to be executed to install the 0.50 RC1 should read:
>>
>> smart update guru && smart install smart-beta
>>
>> smart update
>>
>> smart install smart-beta-gui smart-beta-ksmarttray smart-beta-addons
>
> I did this and get:

[pruned]

> # smart update
> Traceback (most recent call last):
>   File "/usr/bin/smart", line 194, in ?
>     main(sys.argv[1:])
>   File "/usr/bin/smart", line 164, in main
>     initDistro(ctrl)
>   File "/usr/lib/python2.4/site-packages/smart/__init__.py", line 145,
> in initDistro
>     execfile(distrofile, {"ctrl": ctrl, "iface": iface,
>   File "/usr/lib/smart/distro.py", line 25, in ?
>     for history in mirrors_history:
> TypeError: iteration over non-sequence

[pruned]

> Which does not look so good to me.


BTW, you're not trying to install it on the 10.2 beta1 are you? (There
will be a 10.2 source created in a few hours.)

When I switched on this morning, smart "went away" and upgraded to beta
*-3 so not only did I have no problems in installing it but it also
works OK.

I suggest that you try again and see if the problem is still there. If
it is then I suggest you post your problem in the smart mail list where
Pascal 'resides' as well as all the developers and you'll get an answer
very quickly.

Cheers.


--
"If the terrier and the bariffs are torn down, this economy will grow."

                                         George W. Bush  January 2000


--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

PerfectReign
In reply to this post by Basil Chupin
On Tuesday 07 November 2006 22:59, Basil Chupin wrote:
<snip>

>
> If you subscribe to [hidden email] list then watch for the answer there
> otherwise I'll post it here when Pascal responds.

> OK, the answer from Pascal is that there is slight error in the last
> line :-) .
>
> The 3 lines to be executed to install the 0.50 RC1 should read:
>
> smart update guru && smart install smart-beta
>
> smart update
>
> smart install smart-beta-gui smart-beta-ksmarttray smart-beta-addons



Basil:


Thank you! That worked perfectly. I ran the three lines tonight (had to wait
to get home) and they ran fine. I then restarted SMART and it did some update
for me.

Looks like RC1 is good on my machine. I'll keep up with information.


kai ponte
www.perfectreign.com

--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Basil Chupin
Kai Ponte wrote:

> On Tuesday 07 November 2006 22:59, Basil Chupin wrote:
> <snip>
>
>> If you subscribe to [hidden email] list then watch for the answer there
>> otherwise I'll post it here when Pascal responds.
>
>> OK, the answer from Pascal is that there is slight error in the last
>> line :-) .
>>
>> The 3 lines to be executed to install the 0.50 RC1 should read:
>>
>> smart update guru && smart install smart-beta
>>
>> smart update
>>
>> smart install smart-beta-gui smart-beta-ksmarttray smart-beta-addons
>
>
>
> Basil:
>
>
> Thank you! That worked perfectly. I ran the three lines tonight (had to wait
> to get home) and they ran fine. I then restarted SMART and it did some update
> for me.
>
> Looks like RC1 is good on my machine. I'll keep up with information.

Good!

But don't forget to run 'SuSEconfig --module persmissions' so that
smarttray will work for you as user. (You do have that special fix in
place, don't you?)

Cheers.

--
"If the terrier and the bariffs are torn down, this economy will grow."

                                         George W. Bush  January 2000


--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Bruce A. Mallett
In reply to this post by Basil Chupin

Basil Chupin wrote:

>
> BTW, you're not trying to install it on the 10.2 beta1 are you? (There
> will be a 10.2 source created in a few hours.)
>
> When I switched on this morning, smart "went away" and upgraded to
> beta *-3 so not only did I have no problems in installing it but it
> also works OK.
>
> I suggest that you try again and see if the problem is still there. If
> it is then I suggest you post your problem in the smart mail list
> where Pascal 'resides' as well as all the developers and you'll get an
> answer very quickly.
Oops, maybe I'm wrong .. is this a 10.2 thing?  I am doing it under 10.1.
Thanks for the suggestion.

    - Bruce


--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Basil Chupin
Bruce A. Mallett wrote:

> Basil Chupin wrote:
>> BTW, you're not trying to install it on the 10.2 beta1 are you? (There
>> will be a 10.2 source created in a few hours.)
>>
>> When I switched on this morning, smart "went away" and upgraded to
>> beta *-3 so not only did I have no problems in installing it but it
>> also works OK.
>>
>> I suggest that you try again and see if the problem is still there. If
>> it is then I suggest you post your problem in the smart mail list
>> where Pascal 'resides' as well as all the developers and you'll get an
>> answer very quickly.
> Oops, maybe I'm wrong .. is this a 10.2 thing?  I am doing it under 10.1.
> Thanks for the suggestion.

Halt! Stop! :-) :-) .

It *IS* a 10.1 "thing".

But there *will* be a RC1 for 10.2 and by now there should be one
because when I posted my message Pascal stated that he will have one for
10.2 "in a few" hours.

What I suggested is that you run the (correct) 3 lines again because
there are no problems with installing RC1 of 0.50 for SUSE 10.1.

Cheers.


--
"If the terrier and the bariffs are torn down, this economy will grow."

                                         George W. Bush  January 2000


--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Pete Connolly
In reply to this post by Bruce A. Mallett
On Thursday 09 November 2006 01:30, Bruce A. Mallett wrote:

> Patrick Shanahan wrote:
> > * Pete Connolly <[hidden email]> [11-08-06 20:06]:
> >> Getting the exact same here, I'm afraid.  10.1 with all updates.  Had
> >> a quick look, but don't understand enough to debug it, I'm afraid.
> >
> > Something to try:
> >   rm /var/lib/smart/channels
> >   rm /var/lib/smart/cache
> > smart update
> >
> > then try your upgrade as before.
>
> Thanks for the suggestion Patrick, but I get the same thing.

Same here, alas.  I'll have a look at the smart list and see if I can find any
pointers.

Thanks

Pete

--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Bruce A. Mallett
In reply to this post by Basil Chupin

Basil Chupin wrote:
> Bruce A. Mallett wrote:
>> Oops, maybe I'm wrong .. is this a 10.2 thing?  I am doing it under
>> 10.1.
>> Thanks for the suggestion.
>
> Halt! Stop! :-) :-) .
>
> It *IS* a 10.1 "thing".
LOL!  :)

>
> But there *will* be a RC1 for 10.2 and by now there should be one
> because when I posted my message Pascal stated that he will have one
> for 10.2 "in a few" hours.
>
> What I suggested is that you run the (correct) 3 lines again because
> there are no problems with installing RC1 of 0.50 for SUSE 10.1.
Unfortunately things are now hosed sufficiently that smart won't run
enough to do the 3 lines.  Pete is probably in the same situation as am
I.  So I've now tried to back up to the older smart package.

I did:
   rpm -qa | egrep -i smart

and that shows only "smart-beta-0.50rc1-2.guru.suse101" as being
installed.  So I uninstalled that (had to unlock it) and then
re-installed 0.41.  Once 0.41 was reinstalled I went to an su console and:

smart update guru && smart install smart-beta
  <success>
smart update
  <success>
smart install smart-beta-gui smart-beta-ksmarttray smart-beta-addons

SUCCESS!!!

So Pete .. try that .. it may work for you too.

          - Bruce



--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Basil Chupin
Bruce A. Mallett wrote:
> Basil Chupin wrote:
>> Bruce A. Mallett wrote:
>>> Oops, maybe I'm wrong .. is this a 10.2 thing?  I am doing it under
>>> 10.1.
>>> Thanks for the suggestion.
>> Halt! Stop! :-) :-) .
>>
>> It *IS* a 10.1 "thing".
> LOL!  :)

Hey, the '10.1 "thing"' is no laughing matter you know.

>> But there *will* be a RC1 for 10.2 and by now there should be one
>> because when I posted my message Pascal stated that he will have one
>> for 10.2 "in a few" hours.
>>
>> What I suggested is that you run the (correct) 3 lines again because
>> there are no problems with installing RC1 of 0.50 for SUSE 10.1.
> Unfortunately things are now hosed sufficiently that smart won't run
> enough to do the 3 lines.  Pete is probably in the same situation as am
> I.  So I've now tried to back up to the older smart package.
>
> I did:
>    rpm -qa | egrep -i smart
>
> and that shows only "smart-beta-0.50rc1-2.guru.suse101" as being
> installed.  So I uninstalled that (had to unlock it) and then
> re-installed 0.41.  Once 0.41 was reinstalled I went to an su console and:
>
> smart update guru && smart install smart-beta
>   <success>
> smart update
>   <success>
> smart install smart-beta-gui smart-beta-ksmarttray smart-beta-addons
>
> SUCCESS!!!


"Wonderful!", as Dr. Zoidberg would say.

Now that you have zapped whatever you had installed and (re)installed
the 0.50 RC1 I wonder if you also wiped your original list of channels
and may now have to add again any that you previously added yourself?
Just wondering...

Cheers.


--
"If the Iranians were to have a nuclear weapon
they could proliferate."

              George W. Bush     21 March 2006


--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Patrick Shanahan
* Basil Chupin <[hidden email]> [11-09-06 10:20]:
> Now that you have zapped whatever you had installed and (re)installed
> the 0.50 RC1 I wonder if you also wiped your original list of
> channels and may now have to add again any that you previously added
> yourself?  Just wondering...

If you didn't remove /var/lib/smart/config, you will retain the
channels.
--
Patrick Shanahan                        Registered Linux User #207535
http://wahoo.no-ip.org                        @ http://counter.li.org
HOG # US1244711         Photo Album:  http://wahoo.no-ip.org/gallery2

--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Bruce A. Mallett
In reply to this post by Basil Chupin
Basil Chupin wrote:
> "Wonderful!", as Dr. Zoidberg would say.
>
> Now that you have zapped whatever you had installed and (re)installed
> the 0.50 RC1 I wonder if you also wiped your original list of channels
> and may now have to add again any that you previously added yourself?
> Just wondering...
Nope .. the old channels survived!  Amazing is it not?

--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: v0.50 RC1 of smart Package Manger now available

Pete Connolly
In reply to this post by Bruce A. Mallett
On Thursday 09 November 2006 14:33, Bruce A. Mallett wrote:

> Basil Chupin wrote:
> > Bruce A. Mallett wrote:
> >> Oops, maybe I'm wrong .. is this a 10.2 thing?  I am doing it under
> >> 10.1.
> >> Thanks for the suggestion.
> >
> > Halt! Stop! :-) :-) .
> >
> > It *IS* a 10.1 "thing".
>
>
> I did:
>    rpm -qa | egrep -i smart
>
> and that shows only "smart-beta-0.50rc1-2.guru.suse101" as being
> installed.  So I uninstalled that (had to unlock it) and then
> re-installed 0.41.  Once 0.41 was reinstalled I went to an su console and:
>
> smart update guru && smart install smart-beta
>   <success>
> smart update
>   <success>
> smart install smart-beta-gui smart-beta-ksmarttray smart-beta-addons
>
> SUCCESS!!!
>
> So Pete .. try that .. it may work for you too.

Excellent, I'm back in business following those steps.  Thanks for the help
Bruce.

Cheers

Pete

--
Check the headers for your unsubscription address
For additional commands send e-mail to [hidden email]
Also check the archives at http://lists.suse.com
Please read the FAQs: [hidden email]