trouble with HiDPI scaling after last TW update

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

trouble with HiDPI scaling after last TW update

nicholas cunliffe
after last update of TW (running kde plasma), icon sizing, control (icons),
fonts etc have all gone haywire (icons e.g. system settings/yast are miniscule
+ many others, fonts in dolphin look awfull, bizare sizing between standard
and directory font). I checked configs against diff of backup and all settings
are the same. Having spent the last hour tweaking there are some things that
cannot be fixed (control icons e.g. close window).

I have belatedly come to the conclusion something has gone wrong with global
scaling (set to 2X), anybody else with similiar issue?
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: trouble with HiDPI scaling after last TW update

Peter Suetterlin
nicholas wrote:
> after last update of TW (running kde plasma), icon sizing, control (icons),
> fonts etc have all gone haywire (icons e.g. system settings/yast are miniscule
> + many others, fonts in dolphin look awfull, bizare sizing between standard
> and directory font). I checked configs against diff of backup and all settings
> are the same. Having spent the last hour tweaking there are some things that
> cannot be fixed (control icons e.g. close window).
>
> I have belatedly come to the conclusion something has gone wrong with global
> scaling (set to 2X), anybody else with similiar issue?

Not here (running on a 210dpi laptop).  No change to before.
Maybe the dpi value reported by the X-server has changed (for whatever
reason)?
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: trouble with HiDPI scaling after last TW update

nicholas cunliffe
On Tuesday, 20 June 2017 12:44:44 CEST Peter Suetterlin wrote:
> Maybe the dpi value reported by the X-server has changed (for whatever
> reason)?

thanks, whilst following your tip i rolled back to get reported DPI -> same as
default. HOWEVER after restarting to default snapshot, graphics where
glitching terribly, BUT all sizes back to normal. With a few prayers to the
almightly and another restart everything is back to normal! (i had checked
rebooting before this to no avail, there are some strange demons lurking
around).

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: trouble with HiDPI scaling after last TW update

Michal Hlaváč
In reply to this post by nicholas cunliffe
Can confirm, that there is some problem.
After changing Scale Display settings to 1x and after logout/login KDE
applications looks scaled and good. e.g. firefox and chromium are not scaled.
When I set Scale Display to e.g. 1.6x then fonts in okular looks bad, images
preview is bad and also qt web engine (e.g. kmail body preview or akregator)
looks also bad.

And it started after some font changes in systemsettings5

m.

On pondelok, 19. júna 2017 16:24:35 CEST nicholas wrote:

> after last update of TW (running kde plasma), icon sizing, control (icons),
> fonts etc have all gone haywire (icons e.g. system settings/yast are
> miniscule + many others, fonts in dolphin look awfull, bizare sizing
> between standard and directory font). I checked configs against diff of
> backup and all settings are the same. Having spent the last hour tweaking
> there are some things that cannot be fixed (control icons e.g. close
> window).
>
> I have belatedly come to the conclusion something has gone wrong with global
> scaling (set to 2X), anybody else with similiar issue?
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: trouble with HiDPI scaling after last TW update

nicholas cunliffe
On Wednesday, 21 June 2017 11:23:38 CEST Michal Hlavac wrote:

> Can confirm, that there is some problem.
> After changing Scale Display settings to 1x and after logout/login KDE
> applications looks scaled and good. e.g. firefox and chromium are not
> scaled. When I set Scale Display to e.g. 1.6x then fonts in okular looks
> bad, images preview is bad and also qt web engine (e.g. kmail body preview
> or akregator) looks also bad.
>
> And it started after some font changes in systemsettings5
>
> m.
>
if i understand your statement? - non integer scaling in plasma was (is?) a
known problem/disaster, try setting to 1X or 2X and then use force DPI
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Loading...