repair system with dev mapper and lvm

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

repair system with dev mapper and lvm

ErikNRC
My dell precision 390 has a intel raid controller and I never fully
understood how this work with linux but it seems that the device mapper
and lvm are necessary to use the raid controller. Otherwise the two
drives show as /dev/sda and /dev/sdb. Normally, they show as a single in
/dev/mapper/...
However when I boot beta2 and launch repair, I never figured out a way
to get the dev/mapper working, the tool only tries to repair and mount
the /dev/sda and /dev/sdb. Is there any way to enable device mapper and
lvm on the repair?

Thanks,

Erik.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: repair system with dev mapper and lvm

Jiri Suchomel
On po 12. května 2008, Putrycz, Erik wrote:
> My dell precision 390 has a intel raid controller and I never fully
> understood how this work with linux but it seems that the device mapper
> and lvm are necessary to use the raid controller. Otherwise the two
> drives show as /dev/sda and /dev/sdb. Normally, they show as a single in
> /dev/mapper/...
> However when I boot beta2 and launch repair, I never figured out a way
> to get the dev/mapper working, the tool only tries to repair and mount
> the /dev/sda and /dev/sdb. Is there any way to enable device mapper and
> lvm on the repair?

The short answer is that it is currently not possible.
If time permits, the repair support for LVM/RAIDs may be enhanced in some
future versions.

Jiri


--
Jiri Suchomel

SUSE LINUX, s.r.o.                            e-mail: [hidden email]
Lihovarská 1060/12                            tel: +420 284 028 960
190 00 Praha 9, Czech Republic                http://www.suse.cz
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: repair system with dev mapper and lvm

Mike Veltman

> > drives show as /dev/sda and /dev/sdb. Normally, they show as a single in
> > /dev/mapper/...
> > However when I boot beta2 and launch repair, I never figured out a way
> > to get the dev/mapper working, the tool only tries to repair and mount
> > the /dev/sda and /dev/sdb. Is there any way to enable device mapper and
> > lvm on the repair?

Last time that I needed it I just used the rescue cd/dvd/pxeboot and
after login started /etc/init.d/boot.lvm

Have fun. Mike
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]