problems with php web gallery

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

problems with php web gallery

Patrick Shanahan-2

My external sata drive case expired taking down my photo gallery,
gallery2, until I receive a replacement case (ordered).

I am trying to temporarily use a php gallery, http://sye.dk/sfpg/,
which appears quick and easy but the index.php file shows nothing
when accessed.  I put:

  file:  p.php
  <?php
  phpinfo();
  ?>

into the same directory and it access fine.
  http://wahoo.no-ip.org/~pat/sfpg/p.php

  http://wahoo.no-ip.org/~pat/sfpg/index.php  yields a blank screen in
  firefox and a 500 error in quzilla

the php test script, sfpg_test.php also shows blank or 500 error.

subject index.php and sfpg_test.php are available to view:
  http://wahoo.no-ip.org/~pat/index.phph
  http://wahoo.no-ip.org/~pat/sfpg_test.phph

I assume I have missed something basic.... :^(

thanks for any help or suggestions for a different quick/dirty fix.

--
(paka)Patrick Shanahan       Plainfield, Indiana, USA      HOG # US1244711
http://wahoo.no-ip.org        Photo Album: http://wahoo.no-ip.org/gallery2
http://en.opensuse.org                           openSUSE Community Member
Registered Linux User #207535                    @ http://linuxcounter.net
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: problems with php web gallery

Martin Helm
Quickly tested now on my local apache, works just fine, do you have
php5-gd installed?
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: problems with php web gallery

Patrick Shanahan-2
* Martin Helm <[hidden email]> [08-19-12 19:24]:
> Quickly tested now on my local apache, works just fine, do you have
> php5-gd installed?

yes, tks   php5-gd-5.3.6.201105141637-74.1.x86_64

system is 11.2 evergreen and apache2 does work,
  http://wahoo.no-ip.org/~pat/Butterflies/
contains a old jalbum

ps: jalbum as added pop-up adverts to their *free* software.

--
(paka)Patrick Shanahan       Plainfield, Indiana, USA      HOG # US1244711
http://wahoo.no-ip.org        Photo Album: http://wahoo.no-ip.org/gallery2
http://en.opensuse.org                           openSUSE Community Member
Registered Linux User #207535                    @ http://linuxcounter.net
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: problems with php web gallery

Martin Helm
Am 20.08.2012 01:56, schrieb Patrick Shanahan:

> * Martin Helm <[hidden email]> [08-19-12 19:24]:
>> Quickly tested now on my local apache, works just fine, do you have
>> php5-gd installed?
> yes, tks   php5-gd-5.3.6.201105141637-74.1.x86_64
>
> system is 11.2 evergreen and apache2 does work,
>   http://wahoo.no-ip.org/~pat/Butterflies/
> contains a old jalbum
>
> ps: jalbum as added pop-up adverts to their *free* software.
>
Anything usefull which ends up in /var/log/apache2/error_log when you
get the server error with the php script?
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: problems with php web gallery

Patrick Shanahan-2
* Martin Helm <[hidden email]> [08-19-12 20:45]:

> Am 20.08.2012 01:56, schrieb Patrick Shanahan:
> > * Martin Helm <[hidden email]> [08-19-12 19:24]:
> >> Quickly tested now on my local apache, works just fine, do you have
> >> php5-gd installed?
> > yes, tks   php5-gd-5.3.6.201105141637-74.1.x86_64
> >
> > system is 11.2 evergreen and apache2 does work,
> >   http://wahoo.no-ip.org/~pat/Butterflies/
> > contains a old jalbum
> >
> > ps: jalbum as added pop-up adverts to their *free* software.
> >
> Anything usefull which ends up in /var/log/apache2/error_log when you
> get the server error with the php script?

access_log shows:

192.168.1.1 - - [19/Aug/2012:20:54:43 -0400] "GET /~pat/sfpg/index.php
HTTP/1.1" 500 - "http://wahoo.no-ip.org/~pat/sfpg/index.php" "Mozilla/5.0
(X11; Linux x86_64) AppleWebKit/534.34 (KHTML, like Gecko) QupZilla/1.3.1
Safari/534.34"

192.168.1.1 - - [19/Aug/2012:20:54:57 -0400] "GET /~pat/sfpg/index.php
HTTP/1.1" 500 - "http://wahoo.no-ip.org/~pat/sfpg/index.php" "Mozilla/5.0
(X11; Linux x86_64) AppleWebKit/534.34 (KHTML, like Gecko) QupZilla/1.3.1
Safari/534.34"

and error_log shows:

[Sun Aug 19 20:54:43 2012] [error] [client 192.168.1.1] PHP Warning:
/Unknown: failed to open stream: Permission denied in Unknown on line 0,
/referer: http://wahoo.no-ip.org/~pat/sfpg/index.php

[Sun Aug 19 20:54:43 2012] [error] [client 192.168.1.1] PHP Fatal error:
/Unknown: Failed opening required '/home/pat/public_html/sfpg/index.php'
/(include_path='.:/usr/share/php5:/usr/share/php5/PEAR') in Unknown on
/line 0, referer: http://wahoo.no-ip.org/~pat/sfpg/index.php

[Sun Aug 19 20:54:57 2012] [error] [client 192.168.1.1] PHP Warning:
/Unknown: failed to open stream: Permission denied in Unknown on line 0,
/referer: http://wahoo.no-ip.org/~pat/sfpg/index.php

[Sun Aug 19 20:54:57 2012] [error] [client 192.168.1.1] PHP Fatal error:
/Unknown: Failed opening required '/home/pat/public_html/sfpg/index.php'
/(include_path='.:/usr/share/php5:/usr/share/php5/PEAR') in Unknown on
/line 0, referer: http://wahoo.no-ip.org/~pat/sfpg/index.php


which unfortunately means nothing to me.  The first line of index.php is:

<?php

nothing above, and that looks *correct* to me....

tks,

--
(paka)Patrick Shanahan       Plainfield, Indiana, USA      HOG # US1244711
http://wahoo.no-ip.org        Photo Album: http://wahoo.no-ip.org/gallery2
http://en.opensuse.org                           openSUSE Community Member
Registered Linux User #207535                    @ http://linuxcounter.net
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: problems with php web gallery

Cristian Rodríguez-2
El 19/08/12 21:02, Patrick Shanahan escribió:

> * Martin Helm <[hidden email]> [08-19-12 20:45]:
>> Am 20.08.2012 01:56, schrieb Patrick Shanahan:
>>> * Martin Helm <[hidden email]> [08-19-12 19:24]:
>>>> Quickly tested now on my local apache, works just fine, do you have
>>>> php5-gd installed?
>>> yes, tks   php5-gd-5.3.6.201105141637-74.1.x86_64
>>>
>>> system is 11.2 evergreen and apache2 does work,
>>>   http://wahoo.no-ip.org/~pat/Butterflies/
>>> contains a old jalbum
>>>
>>> ps: jalbum as added pop-up adverts to their *free* software.

No such thing as free lunch my friend.. ;)

> [Sun Aug 19 20:54:43 2012] [error] [client 192.168.1.1] PHP Warning:
> /Unknown: failed to open stream: Permission denied in Unknown on line 0,
> /referer: http://wahoo.no-ip.org/~pat/sfpg/index.php

that means the files are not readable to the webserver.. checkout the
permissions of the files as well if mod_userdir is loaded.

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: problems with php web gallery

Patrick Shanahan-2
* Cristian Rodríguez <[hidden email]> [08-19-12 22:11]:
> El 19/08/12 21:02, Patrick Shanahan escribió:
> >>> ps: jalbum as added pop-up adverts to their *free* software.
>
> No such thing as free lunch my friend.. ;)

yes  :^(

> > [Sun Aug 19 20:54:43 2012] [error] [client 192.168.1.1] PHP Warning:
> > /Unknown: failed to open stream: Permission denied in Unknown on line 0,
> > /referer: http://wahoo.no-ip.org/~pat/sfpg/index.php
>
> that means the files are not readable to the webserver.. checkout the
> permissions of the files as well if mod_userdir is loaded.

It is configured for all in /etc/apache2/mod_userdir.conf and ~<user> is
accessable and info.php,
  <?php
  phpinfo();
  ?>
works in the same subdirectory as the index.php that fails.  I assume this
indicates a working mod_userdir ???

tks,
--
(paka)Patrick Shanahan       Plainfield, Indiana, USA      HOG # US1244711
http://wahoo.no-ip.org        Photo Album: http://wahoo.no-ip.org/gallery2
http://en.opensuse.org                           openSUSE Community Member
Registered Linux User #207535                    @ http://linuxcounter.net
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: problems with php web gallery

Martin Helm
Am 20.08.2012 13:32, schrieb Patrick Shanahan:
> It is configured for all in /etc/apache2/mod_userdir.conf and ~<user>
> is accessable and info.php, <?php phpinfo(); ?> works in the same
> subdirectory as the index.php that fails. I assume this indicates a
> working mod_userdir ??? tks,
Nope, what I guess which fails for you is not that the php script cannot
be read, but that the images the php script tires to read fail.
Where are the images located and what rights are set on them?
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: problems with php web gallery

Patrick Shanahan-2
* Martin Helm <[hidden email]> [08-20-12 07:46]:
> Am 20.08.2012 13:32, schrieb Patrick Shanahan:
> >It is configured for all in /etc/apache2/mod_userdir.conf and ~<user> is
> >accessable and info.php, <?php phpinfo(); ?> works in the same
> >subdirectory as the index.php that fails. I assume this indicates a
> >working mod_userdir ??? tks,
> Nope, what I guess which fails for you is not that the php script cannot be
> read, but that the images the php script tires to read fail.
> Where are the images located and what rights are set on them?

After all that, appears it requires *world* writable directories/files and
is now working.

But I cannot get the directory images and descriptions working.  Also exif
dates don't show.

tks much,
--
(paka)Patrick Shanahan       Plainfield, Indiana, USA      HOG # US1244711
http://wahoo.no-ip.org        Photo Album: http://wahoo.no-ip.org/gallery2
http://en.opensuse.org                           openSUSE Community Member
Registered Linux User #207535                    @ http://linuxcounter.net
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: problems with php web gallery

Philipp Thomas-3
On Mon, 20 Aug 2012 18:45:20 -0400, Patrick Shanahan
<[hidden email]> wrote:

>After all that, appears it requires *world* writable directories/files and
>is now working.

I'd immediate drop something that requires such things.

Philipp
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: problems with php web gallery

Martin Helm
Am 21.08.2012 20:28, schrieb Philipp Thomas:
> On Mon, 20 Aug 2012 18:45:20 -0400, Patrick Shanahan
> <[hidden email]> wrote:
>
>> After all that, appears it requires *world* writable directories/files and
>> is now working.
> I'd immediate drop something that requires such things.
>
> Philipp
None of my directories or files is world writable and the index.php they
provide still works. Of course the apache process needs to be able to
read the files.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: problems with php web gallery

Patrick Shanahan-2
In reply to this post by Philipp Thomas-3
* Philipp Thomas <[hidden email]> [08-21-12 14:30]:
> On Mon, 20 Aug 2012 18:45:20 -0400, Patrick Shanahan
> <[hidden email]> wrote:
>
> >After all that, appears it requires *world* writable directories/files and
> >is now working.
>
> I'd immediate drop something that requires such things.

Guess I would also, but I mis-spoke.  Requires world *readable*...., not
writable.

--
(paka)Patrick Shanahan       Plainfield, Indiana, USA      HOG # US1244711
http://wahoo.no-ip.org        Photo Album: http://wahoo.no-ip.org/gallery2
http://en.opensuse.org                           openSUSE Community Member
Registered Linux User #207535                    @ http://linuxcounter.net
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: problems with php web gallery

Martin Helm
Am 21.08.2012 22:24, schrieb Patrick Shanahan:
> Guess I would also, but I mis-spoke. Requires world *readable*....,
> not writable.

It needs to be readable by wwwrun:www. What's so special about that?
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]