openSUSE Leap 42.2 dependency problems

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

openSUSE Leap 42.2 dependency problems

Marcin Bajor
Hi,
I have a project
https://build.opensuse.org/package/show/home:rawtherapee/rawtherapee-unstable
and 2 problems with dependencies:
x86_64 - "have choice for libasan3 >= 6.1.1+r238085-1.12 needed by gcc6:
libasan3 libasan3-gcc6"
i586 - "nothing provides bzr needed by obs-service-tar_scm, nothing provides
git-core needed by obs-service-tar_scm, nothing provides subversion needed by
obs-service-tar_scm"

Repositories are configured in the same way as for openSUSE Leap 42.1 and 42.3
(works fine).

Should I use other repositories or it is OBS issue?

<project name="home:rawtherapee">
...
<repository name="openSUSE_Leap_42.3">
    <path project="openSUSE:Leap:42.3" repository="standard"/>
    <path project="openSUSE:Leap:42.3:Update" repository="standard"/>
    <path project="openSUSE:Tools" repository="openSUSE_42.3"/>
    <arch>i586</arch>
    <arch>x86_64</arch>
  </repository>
  <repository name="openSUSE_Leap_42.2">
    <path project="openSUSE:Leap:42.2" repository="standard"/>
    <path project="openSUSE:Leap:42.2:Update" repository="standard"/>
    <path project="openSUSE:Tools" repository="openSUSE_42.2"/>
    <arch>x86_64</arch>
    <arch>i586</arch>
  </repository>
  <repository name="openSUSE_Leap_42.1">
    <path project="openSUSE:Leap:42.1" repository="standard"/>
    <path project="openSUSE:Leap:42.1:Update" repository="standard"/>
    <path project="openSUSE:Tools" repository="openSUSE_42.1"/>
    <arch>i586</arch>
    <arch>x86_64</arch>
  </repository>
..
</project>

Best Regards
Marcin Bajor

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: openSUSE Leap 42.2 dependency problems

Dave Plater lst


On 16/01/2018 15:02, Marcin Bajor wrote:
> x86_64 - "have choice for libasan3 >= 6.1.1+r238085-1.12 needed by gcc6:
> libasan3 libasan3-gcc6"
> i586 - "nothing provides bzr needed by obs-service-tar_scm, nothing provides
> git-core needed by obs-service-tar_scm, nothing provides subversion needed by
> obs-service-tar_scm"
The best solution for libasan3 is #!BuildIgnore: libasan3 in the spec
file, an even better solution would be to use gcc5 for both Leap:42.1 and 3.
Leap i586 isn't official and unresolvable conditions are normal. If you
really want to build i586 you need to build the missing dependencies as
well.
Dave P
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: openSUSE Leap 42.2 dependency problems

Olaf Hering-2
In reply to this post by Marcin Bajor
Am Tue, 16 Jan 2018 14:02:02 +0100
schrieb Marcin Bajor <[hidden email]>:

>     <path project="openSUSE:Leap:42.2" repository="standard"/>

Remove this line. Its is already available via the :Update and Tools repository. This line overrides the used gcc.

Olaf

attachment0 (201 bytes) Download Attachment