livecd-kde build problem

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

livecd-kde build problem

Ben NG
Hi All

I'm trying to build this configuration :
/usr/share/openSUSE-kiwi/livecd-kde which is provide by
kiwi-config-openSUSE but it failed

I have : Nov-10 19:36:41 <1> : kiwi version v5.03.37
GIT Commit: b9036be6baf1717dd00de2dafe75bab772fc9af9

it seams to have conflicts in package, do you have any ideas to resolve ?

Thank you

logs
-------------------------------------------


kiwi --build /usr/share/openSUSE-kiwi/livecd-kde --destdir /home/benng/build/


Nov-10 19:16:35 <1> : Description provides no MD5 hash, check
Nov-10 19:16:35 <1> : Reading image description [Prepare]...
Nov-10 19:16:35 <1> : Removing old root directory
'/home/benng/build/build/image-root'
                                                            done
Nov-10 19:16:35 <1> : Set root log:
/home/benng/build/build/image-root.7948.screenrc.log...

   done
Nov-10 19:16:35 <1> : Setting up package manager: zypper

                                       done
Nov-10 19:16:36 <1> : Setting RPM doc exclusion to: false

                                       done
Nov-10 19:16:36 <1> : Creating default template files for new root
system
                                           done
Nov-10 19:16:36 <1> : Importing build keys...

                                       skipped
Nov-10 19:16:36 <2> : Can't find build keys on host system

                                       skipped
Nov-10 19:16:36 <1> : Adding bootstrap zypper service:
http:__download.opensuse.org_distribution_12.2_repo_oss
                                                       done
Nov-10 19:16:36 <1> : Adding bootstrap zypper service:
http:__download.opensuse.org_repositories_openSUSE:_12.2:_Live_standard
                                                      done
Nov-10 19:16:37 <1> : Initializing image system on:
/home/benng/build/build/image-root
                                                          done
Nov-10 19:19:10 <1> : Mounting required file systems

                                       done
Nov-10 19:19:10 <1> : Setting RPM doc exclusion to: false

                                       done
Nov-10 19:19:10 <1> : Updating chroot zypper service:
http:__download.opensuse.org_distribution_12.2_repo_oss
                                                        done
Nov-10 19:19:10 <1> : Updating chroot zypper service:
http:__download.opensuse.org_repositories_openSUSE:_12.2:_Live_standard
                                                       done
Nov-10 19:19:10 <1> : Installing image packages...

                                       failed
[*** log excerpt follows, screen ***]
 Solution 1: Following actions will be done:
  deinstallation of branding-basedonopensuse-12.2-3.3.1.x86_64
  deinstallation of systemd-presets-branding-basedonopensuse-12.2-3.3.1.x86_64
 Solution 2: do not install package-lists-openSUSE-KDE-cd-12.2-21.1.x86_64
 Solution 3: break package-lists-openSUSE-KDE-cd-12.2-21.1.x86_64 by
ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c): c
+ ECODE=4
+ echo 4
+ exit 4
[*** end ***]
Nov-10 19:19:11 <1> : Removing zypper service(s):
http:__download.opensuse.org_distribution_12.2_repo_oss
http:__download.opensuse.org_repositories_openSUSE:_12.2:_Live_standard
   done
Nov-10 19:19:11 <3> : Image installation failed

                                       failed
[*** log excerpt follows, last significant bytes ***]
 + PBL_SKIP_BOOT_TEST=1
 + trap clean INT TERM
 + export ZYPP_MODALIAS_SYSFS=/tmp
 + ZYPP_MODALIAS_SYSFS=/tmp
 + export YAST_IS_RUNNING=true
 + YAST_IS_RUNNING=true
 + export ZYPP_CONF=/var/cache/kiwi/zypper/zypp.conf.7948
 + ZYPP_CONF=/var/cache/kiwi/zypper/zypp.conf.7948
 + SPID=9134
 + wait 9134
 + chroot /home/benng/build/build/image-root zypper --non-interactive
--no-gpg-checks --reposd-dir /var/cache/kiwi/zypper/repos --cache-dir
/var/cache/kiwi/zypper --config
/var/cache/kiwi/zypper/zypper.conf.7948 install
--auto-agree-with-licenses --no-recommends aaa_base
gfxboot-branding-openSUSE package-lists-openSUSE-KDE-cd pam pam-config
pam-modules patch tar udev yast2-live-installer zypper
 Loading repository data...
 Reading installed packages...
 'aaa_base' is already installed.
 No update candidate for 'aaa_base-12.2-2.11.1.x86_64'. The highest
available version is already installed.
 'udev' is already installed.
 No update candidate for 'udev-182-4.14.1.x86_64'. The highest
available version is already installed.
 'pam' is already installed.
 No update candidate for 'pam-1.1.5-3.2.2.x86_64'. The highest
available version is already installed.
 'zypper' is already installed.
 No update candidate for 'zypper-1.7.3-1.2.2.x86_64'. The highest
available version is already installed.
 'pam-modules' is already installed.
 No update candidate for 'pam-modules-12.1-11.5.1.x86_64'. The highest
available version is already installed.
 'pam-config' is already installed.
 No update candidate for 'pam-config-0.80-2.1.2.x86_64'. The highest
available version is already installed.
 Resolving package dependencies...

 Problem: package-lists-openSUSE-KDE-cd-12.2-21.1.x86_64 requires
branding-openSUSE, but this requirement cannot be provided
   uninstallable providers:
branding-openSUSE-12.2-11.6.15.noarch[http:__download.opensuse.org_distribution_12.2_repo_oss]
  Solution 1: Following actions will be done:
   deinstallation of branding-basedonopensuse-12.2-3.3.1.x86_64
   deinstallation of systemd-presets-branding-basedonopensuse-12.2-3.3.1.x86_64
  Solution 2: do not install package-lists-openSUSE-KDE-cd-12.2-21.1.x86_64
  Solution 3: break package-lists-openSUSE-KDE-cd-12.2-21.1.x86_64 by
ignoring some of its dependencies

 Choose from above solutions by number or cancel [1/2/3/c] (c): c
 + ECODE=4
 + echo 4
 + exit 4
 Nov-10 19:19:11 <1> : EXEC [rm -f
/home/benng/build/build/image-root/screenrc.smart*]
 Nov-10 19:19:11 <1> : EXEC [rm -f
/home/benng/build/build/image-root/screenrc.ctrls]
    failed
 Nov-10 19:19:11 <1> : Removing zypper service(s):
http:__download.opensuse.org_distribution_12.2_repo_oss
http:__download.opensuse.org_repositories_openSUSE:_12.2:_Live_standard
 Nov-10 19:19:11 <1> : EXEC [chroot
"/home/benng/build/build/image-root" bash -c "zypper --non-interactive
--no-gpg-checks --reposd-dir /var/cache/kiwi/zypper/repos --cache-dir
/var/cache/kiwi/zypper --config
/var/cache/kiwi/zypper/zypper.conf.7948 removerepo
http:__download.opensuse.org_distribution_12.2_repo_oss 2>&1"]
 Nov-10 19:19:11 <1> : EXEC [chroot
"/home/benng/build/build/image-root" bash -c "zypper --non-interactive
--no-gpg-checks --reposd-dir /var/cache/kiwi/zypper/repos --cache-dir
/var/cache/kiwi/zypper --config
/var/cache/kiwi/zypper/zypper.conf.7948 removerepo
http:__download.opensuse.org_repositories_openSUSE:_12.2:_Live_standard
2>&1"]
    done
 Nov-10 19:19:11 <1> : Release package manager lock
 Nov-10 19:19:11 <1> : EXEC [rm -f /var/lock/kiwi-init.lock]
 Nov-10 19:19:11 <3> : Image installation failed
    failed
 [*** end ***]
Nov-10 19:19:11 <3> : KIWI exited with error(s)

                                       done
Nov-10 19:19:11 <1> : Complete logfile at:
/home/benng/build/build/image-root.log

done
Nov-10 19:19:11 <1> : Removing zypper service:
http:__download.opensuse.org_distribution_12.2_repo_oss
Nov-10 19:19:11 <1> : Removing zypper service:
http:__download.opensuse.org_repositories_openSUSE:_12.2:_Live_standard
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: livecd-kde build problem

Matthew Ehle
>>>> Ben NG <[hidden email]> 11/12/2012 6:23 AM >>>
>Hi All
>
>I'm trying to build this configuration :
>/usr/share/openSUSE-kiwi/livecd-kde which is provide by
>kiwi-config-openSUSE but it failed

Please post this to the forums (http://forums.opensuse.org).  The wiki mailing list is not an appropriate place for such questions.
 
-Matt



smime.p7s (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: livecd-kde build problem

Rajko M.
On Mon, 12 Nov 2012 08:49:17 -0700
"Matthew Ehle" <[hidden email]> wrote:
...
> Please post this to the forums (http://forums.opensuse.org).  The
> wiki mailing list is not an appropriate place for such questions.

Taking a problem at hand, it would be probably better to seek help on
SUSEstudio forums, which Ben already did on Nov 10:
http://susestudio.com/forum

Problem is that no one responded.

> -Matt


--
Regards, Rajko.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]