is there missing bootstrap for rust build on PowerPC ring1

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

is there missing bootstrap for rust build on PowerPC ring1

Normand
in PowerPC ring1 project (1) rust is not buildable because of unresolvable:
"nothing provides rust <= 1.23.0, nothing provides rust >= 1.22.1,
nothing provides rust-std <= 1.23.0, nothing provides rust-std >= 1.22.1"

and the job history confirm there was no previous build in this project.

But the rust builds correctly for ppc64le in related devel project (2)

So I assume there is a need for some bootstrap or agregate in the ring1
project, but I do not know how to do that.

Any suggestion ?


(1)
https://build.opensuse.org/package/show/openSUSE:Factory:PowerPC:Rings:1-MinimalX/rust#
(2) https://build.opensuse.org/package/show/devel:languages:rust/rust

--
Michel Normand

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: is there missing bootstrap for rust build on PowerPC ring1

Dominique Leuenberger / DimStar
On Thu, 2018-01-18 at 16:41 +0100, Normand wrote:

> in PowerPC ring1 project (1) rust is not buildable because of unresolvable:
> "nothing provides rust <= 1.23.0, nothing provides rust >= 1.22.1,
> nothing provides rust-std <= 1.23.0, nothing provides rust-std >= 1.22.1"
>
> and the job history confirm there was no previous build in this project.
>
> But the rust builds correctly for ppc64le in related devel project (2)
>
> So I assume there is a need for some bootstrap or agregate in the ring1
> project, but I do not know how to do that.
>
> Any suggestion ?
Thanks for noticing. Rust and Cargo recently moved from ring2 to ring1,
but I failed to aggegate the binaries in PowerPC:Rings:1-MinimalX

This has now been corrected

Cheers,
Dominique

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: is there missing bootstrap for rust build on PowerPC ring1

John Paul Adrian Glaubitz
In reply to this post by Normand
On 01/18/2018 04:41 PM, Normand wrote:
> in PowerPC ring1 project (1) rust is not buildable because of unresolvable:
> "nothing provides rust <= 1.23.0, nothing provides rust >= 1.22.1, nothing provides rust-std <= 1.23.0, nothing provides rust-std >= 1.22.1"

Ah, this is ppc64el, not powerpc. I was already confused because I know that rustc
is currently broken on powerpc, but it works fine on ppc64 and ppc64el [1].

Adrian

> [1] https://buildd.debian.org/status/package.php?p=rustc&suite=sid
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]