extremely weird font behaviour with plasma / KDE from KDE: buildservice repos

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

extremely weird font behaviour with plasma / KDE from KDE: buildservice repos

Mathias Homann-2
Hi,

let me show you two screenshots:
https://gyazo.com/f204d96be954a6f8b522947736bfd0b7 
https://gyazo.com/0bae79574db7bccf4620557966ceab51 

The first shows my font settings in KDE / Plasma: pretty straighforward,
everything is set to Segoe UI 12 Pt, except fixed width which is Consolas
12Pt.

The second one is where it gets funny:
it shows part of my desktop and three application windows.
Observe how my desktop, and one of the apps, actually uses the font settings
from my control center, but the other two apps dont!

The app that does was built in my own OBS repo, the two apps that don't are
from KDE:Frameworks5.

Any ideas how to fix that?
My guess is that somehow Frameworks5 or even Qt5 uses a different, possibly
broken, libfreetype, to build, but it is not published.

Cheers
MH


--
Mathias Homann
Mathias.Homann@openSUSE:.org
irc: [Lemmy] @ freenode, ircnet
obs: lemmy04
keybase: https://keybase.io/lemmy 
gpg key fingerprint: 8029 2240 F4DD 7776 E7D2 C042 6B8E 029E 13F2 C102



--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: extremely weird font behaviour with plasma / KDE from KDE: buildservice repos

Mathias Homann-2
> Any ideas how to fix that?
> My guess is that somehow Frameworks5 or even Qt5 uses a different, possibly
> broken, libfreetype, to build, but it is not published.


Looking at the changes in KDE:Qt5.14... I'm not 100% sure but I think
the start of this behaviour was just after Qt 5.14 appeared in the repo,
or right after the three patches for QTBUG-80982 came in.


I also think the behaviour is depending on DPI of your display, my main
machine has 81DPI and it is very noticeable, my laptop has 100DPI and it
doen't really show at all.

On the other hand it also seems to break mouse click events at least in
some apps, in kontact I can't click on anything inside the client area
(folders in kmail, for example).


Cheers

MH


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: extremely weird font behaviour with plasma / KDE from KDE: buildservice repos

Felix Miata-3
In reply to this post by Mathias Homann-2
Mathias Homann composed on 2020-01-11 10:10 (UTC+0100):

> https://gyazo.com/f204d96be954a6f8b522947736bfd0b7 
> https://gyazo.com/0bae79574db7bccf4620557966ceab51 

Please upload only to http://susepaste.org/ or any other site that doesn't require
scripting enabled and/or a "supported" web browser. Sites that dictate which
browsers we use or how they are configured should not be supported.
--
Evolution as taught in public schools is religion, not science.

 Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***  http://fm.no-ip.com/
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: extremely weird font behaviour with plasma / KDE from KDE: buildservice repos

Mathias Homann-2
How do I log in on susepaste.org?

Am 11.01.2020 um 11:00 schrieb Felix Miata:
> Mathias Homann composed on 2020-01-11 10:10 (UTC+0100):
>
>> https://gyazo.com/f204d96be954a6f8b522947736bfd0b7 
>> https://gyazo.com/0bae79574db7bccf4620557966ceab51 
> Please upload only to http://susepaste.org/ or any other site that doesn't require
> scripting enabled and/or a "supported" web browser. Sites that dictate which
> browsers we use or how they are configured should not be supported.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: extremely weird font behaviour with plasma / KDE from KDE: buildservice repos

Mathias Homann-2
In reply to this post by Felix Miata-3
Am Samstag, 11. Januar 2020, 11:00:08 CET schrieb Felix Miata:
> Mathias Homann composed on 2020-01-11 10:10 (UTC+0100):
> > https://gyazo.com/f204d96be954a6f8b522947736bfd0b7
> > https://gyazo.com/0bae79574db7bccf4620557966ceab51
>
> Please upload only to http://susepaste.org/ or any other site that doesn't
> require scripting enabled and/or a "supported" web browser. Sites that
> dictate which browsers we use or how they are configured should not be
> supported.

susepaste.org is not listed under "publish" or "export" in the KDE screenshot
tool, so please name the ones **from that list** that are acceptable to you.


--
Mathias Homann
Mathias.Homann@openSUSE:.org
irc: [Lemmy] @ freenode, ircnet
obs: lemmy04
keybase: https://keybase.io/lemmy 
gpg key fingerprint: 8029 2240 F4DD 7776 E7D2 C042 6B8E 029E 13F2 C102



--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: extremely weird font behaviour with plasma / KDE from KDE: buildservice repos

Mathias Homann-2
In reply to this post by Felix Miata-3
Am Samstag, 11. Januar 2020, 11:00:08 CET schrieb Felix Miata:
> Mathias Homann composed on 2020-01-11 10:10 (UTC+0100):



https://susepaste.org/15752907
https://susepaste.org/15411838

the second one is the one that shows the weird behaviour. the apps in the
screenshot are, starting top left going clockwise:
digikam from my own OBS repo
kontact from KDE:Frameworks5
Firefox from the mozilla: repo
gwenview from KDE:Frameworks5.

Just compare the menus and you see what i'm talking about.


--
Mathias Homann
Mathias.Homann@openSUSE:.org
irc: [Lemmy] @ freenode, ircnet
obs: lemmy04
keybase: https://keybase.io/lemmy 
gpg key fingerprint: 8029 2240 F4DD 7776 E7D2 C042 6B8E 029E 13F2 C102



--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: extremely weird font behaviour with plasma / KDE from KDE: buildservice repos

Fabian Vogt-2
In reply to this post by Mathias Homann-2
Hi,

Am Samstag, 11. Januar 2020, 10:29:06 CET schrieb Mathias Homann:
> > Any ideas how to fix that?
> > My guess is that somehow Frameworks5 or even Qt5 uses a different, possibly
> > broken, libfreetype, to build, but it is not published.
>
>
> Looking at the changes in KDE:Qt5.14... I'm not 100% sure but I think
> the start of this behaviour was just after Qt 5.14 appeared in the repo,
> or right after the three patches for QTBUG-80982 came in.

Looks like https://bugs.kde.org/show_bug.cgi?id=415421. No complete fix known
so far. You can set QT_AUTO_SCREEN_SCALE_FACTOR=0 for now, but it might break
with Qt 5.14.1 again when the bug got fixed...
https://bugzilla.opensuse.org/show_bug.cgi?id=1160624 is a downstream report.

Cheers,
Fabian

> I also think the behaviour is depending on DPI of your display, my main
> machine has 81DPI and it is very noticeable, my laptop has 100DPI and it
> doen't really show at all.
>
> On the other hand it also seems to break mouse click events at least in
> some apps, in kontact I can't click on anything inside the client area
> (folders in kmail, for example).
>
>
> Cheers
>
> MH
>
>
>




--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: extremely weird font behaviour with plasma / KDE from KDE: buildservice repos

Mathias Homann-2

Am 11.01.2020 um 14:27 schrieb Fabian Vogt:

> Hi,
>
> Am Samstag, 11. Januar 2020, 10:29:06 CET schrieb Mathias Homann:
>>> Any ideas how to fix that?
>>> My guess is that somehow Frameworks5 or even Qt5 uses a different, possibly
>>> broken, libfreetype, to build, but it is not published.
>>
>> Looking at the changes in KDE:Qt5.14... I'm not 100% sure but I think
>> the start of this behaviour was just after Qt 5.14 appeared in the repo,
>> or right after the three patches for QTBUG-80982 came in.
> Looks like https://bugs.kde.org/show_bug.cgi?id=415421. No complete fix known
> so far. You can set QT_AUTO_SCREEN_SCALE_FACTOR=0 for now, but it might break
> with Qt 5.14.1 again when the bug got fixed...
> https://bugzilla.opensuse.org/show_bug.cgi?id=1160624 is a downstream report.



where / how do I set that, just as a shell variable before I start the
session? /etc/profile.d/ comes to mind.



Cheers

MH

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: extremely weird font behaviour with plasma / KDE from KDE: buildservice repos

Fabian Vogt-2
Hi,

Am Samstag, 11. Januar 2020, 14:35:23 CET schrieb Mathias Homann:

>
> Am 11.01.2020 um 14:27 schrieb Fabian Vogt:
> > Hi,
> >
> > Am Samstag, 11. Januar 2020, 10:29:06 CET schrieb Mathias Homann:
> >>> Any ideas how to fix that?
> >>> My guess is that somehow Frameworks5 or even Qt5 uses a different, possibly
> >>> broken, libfreetype, to build, but it is not published.
> >>
> >> Looking at the changes in KDE:Qt5.14... I'm not 100% sure but I think
> >> the start of this behaviour was just after Qt 5.14 appeared in the repo,
> >> or right after the three patches for QTBUG-80982 came in.
> > Looks like https://bugs.kde.org/show_bug.cgi?id=415421. No complete fix known
> > so far. You can set QT_AUTO_SCREEN_SCALE_FACTOR=0 for now, but it might break
> > with Qt 5.14.1 again when the bug got fixed...
> > https://bugzilla.opensuse.org/show_bug.cgi?id=1160624 is a downstream report.
>
> where / how do I set that, just as a shell variable before I start the
> session? /etc/profile.d/ comes to mind.

You can put it into ~/.config/plasma-workspace/env/scale.sh:
export QT_AUTO_SCREEN_SCALE_FACTOR=0

Cheers,
Fabian

> Cheers
>
> MH
>
>




--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: extremely weird font behaviour with plasma / KDE from KDE: buildservice repos

Mathias Homann-2
Am Samstag, 11. Januar 2020, 14:42:26 CET schrieb Fabian Vogt:

> Hi,
>
> Am Samstag, 11. Januar 2020, 14:35:23 CET schrieb Mathias Homann:
> > Am 11.01.2020 um 14:27 schrieb Fabian Vogt:
> > > Hi,
> > >
> > > Am Samstag, 11. Januar 2020, 10:29:06 CET schrieb Mathias Homann:
> > >>> Any ideas how to fix that?
> > >>> My guess is that somehow Frameworks5 or even Qt5 uses a different,
> > >>> possibly
> > >>> broken, libfreetype, to build, but it is not published.
> > >>
> > >> Looking at the changes in KDE:Qt5.14... I'm not 100% sure but I think
> > >> the start of this behaviour was just after Qt 5.14 appeared in the
> > >> repo,
> > >> or right after the three patches for QTBUG-80982 came in.
> > >
> > > Looks like https://bugs.kde.org/show_bug.cgi?id=415421. No complete fix
> > > known so far. You can set QT_AUTO_SCREEN_SCALE_FACTOR=0 for now, but it
> > > might break with Qt 5.14.1 again when the bug got fixed...
> > > https://bugzilla.opensuse.org/show_bug.cgi?id=1160624 is a downstream
> > > report.>
> > where / how do I set that, just as a shell variable before I start the
> > session? /etc/profile.d/ comes to mind.
>
> You can put it into ~/.config/plasma-workspace/env/scale.sh:
> export QT_AUTO_SCREEN_SCALE_FACTOR=0

That fixed the font issues - but it turns out that my issues with akregator
are unleated.

anyway, thanks a bucket! what's the best place to set that globally?
/etc/profile.d/000-QT_FONT_SCALE_FIX.sh ?

Cheers
MH

--
Mathias Homann
Mathias.Homann@openSUSE:.org
irc: [Lemmy] @ freenode, ircnet
obs: lemmy04
keybase: https://keybase.io/lemmy 
gpg key fingerprint: 8029 2240 F4DD 7776 E7D2 C042 6B8E 029E 13F2 C102



--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: extremely weird font behaviour with plasma / KDE from KDE: buildservice repos

Fabian Vogt-2
Hi,

Am Samstag, 11. Januar 2020, 15:10:50 CET schrieb Mathias Homann:

> Am Samstag, 11. Januar 2020, 14:42:26 CET schrieb Fabian Vogt:
> > Hi,
> >
> > Am Samstag, 11. Januar 2020, 14:35:23 CET schrieb Mathias Homann:
> > > Am 11.01.2020 um 14:27 schrieb Fabian Vogt:
> > > > Hi,
> > > >
> > > > Am Samstag, 11. Januar 2020, 10:29:06 CET schrieb Mathias Homann:
> > > >>> Any ideas how to fix that?
> > > >>> My guess is that somehow Frameworks5 or even Qt5 uses a different,
> > > >>> possibly
> > > >>> broken, libfreetype, to build, but it is not published.
> > > >>
> > > >> Looking at the changes in KDE:Qt5.14... I'm not 100% sure but I think
> > > >> the start of this behaviour was just after Qt 5.14 appeared in the
> > > >> repo,
> > > >> or right after the three patches for QTBUG-80982 came in.
> > > >
> > > > Looks like https://bugs.kde.org/show_bug.cgi?id=415421. No complete fix
> > > > known so far. You can set QT_AUTO_SCREEN_SCALE_FACTOR=0 for now, but it
> > > > might break with Qt 5.14.1 again when the bug got fixed...
> > > > https://bugzilla.opensuse.org/show_bug.cgi?id=1160624 is a downstream
> > > > report.>
> > > where / how do I set that, just as a shell variable before I start the
> > > session? /etc/profile.d/ comes to mind.
> >
> > You can put it into ~/.config/plasma-workspace/env/scale.sh:
> > export QT_AUTO_SCREEN_SCALE_FACTOR=0
>
> That fixed the font issues - but it turns out that my issues with akregator
> are unleated.

You mean this?

> On the other hand it also seems to break mouse click events at least in
> some apps, in kontact I can't click on anything inside the client area
> (folders in kmail, for example).

I haven't heard of an issue like that, when did it start?

> anyway, thanks a bucket! what's the best place to set that globally?
> /etc/profile.d/000-QT_FONT_SCALE_FIX.sh ?

/etc/xdg/plasma-workspave/env/scale.sh should do it as well.

Cheers,
Fabian

> Cheers
> MH


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: extremely weird font behaviour with plasma / KDE from KDE: buildservice repos

gumb
In reply to this post by Mathias Homann-2
On 11/01/2020 14:22, Mathias Homann wrote:

> Am Samstag, 11. Januar 2020, 11:00:08 CET schrieb Felix Miata:
>> Mathias Homann composed on 2020-01-11 10:10 (UTC+0100):
>
>
>
> https://susepaste.org/15752907
> https://susepaste.org/15411838
>
> the second one is the one that shows the weird behaviour. the apps in the
> screenshot are, starting top left going clockwise:
> digikam from my own OBS repo
> kontact from KDE:Frameworks5
> Firefox from the mozilla: repo
> gwenview from KDE:Frameworks5.
>
> Just compare the menus and you see what i'm talking about.

One of the apps that doesn't have your preferred settings is Firefox.
This will derive its settings from the GTK Application Style in System
Settings, not the main Font settings. I can't tell what the second app
that doesn't conform is.

gumb
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: extremely weird font behaviour with plasma / KDE from KDE: buildservice repos

gumb
On 11/01/2020 19:02, gumb wrote:

> On 11/01/2020 14:22, Mathias Homann wrote:
>> Am Samstag, 11. Januar 2020, 11:00:08 CET schrieb Felix Miata:
>>> Mathias Homann composed on 2020-01-11 10:10 (UTC+0100):
>>
>>
>>
>> https://susepaste.org/15752907
>> https://susepaste.org/15411838
>>
>> the second one is the one that shows the weird behaviour. the apps in the
>> screenshot are, starting top left going clockwise:
>> digikam from my own OBS repo
>> kontact from KDE:Frameworks5
>> Firefox from the mozilla: repo
>> gwenview from KDE:Frameworks5.
>>
>> Just compare the menus and you see what i'm talking about.
>
> One of the apps that doesn't have your preferred settings is Firefox.
> This will derive its settings from the GTK Application Style in System
> Settings, not the main Font settings. I can't tell what the second app
> that doesn't conform is.

Sorry I just saw you detailed the four apps. Well I don't know why the
other one doesn't conform.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]