dependencies of PolicyKit-lang and kupdateapplet-packagekit

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

dependencies of PolicyKit-lang and kupdateapplet-packagekit

Sven Burmeister
Hi!

I had to manually remove the package PolicyKit-kde-lang because it complained
about PolicyKit 0.2 not being available in any repo. Did anyone else see that
and does that mean that the whatever package replaced PolicyKit is missing an
obsolete for the lang package?

Second conflict I get with zypper dup is kupdateapplet-
packagekit-0.9.0-3.1.x86_64 complaining that there is no PackageKit >= 0.5.1.

I have the KDE4:Factory, community and playground repo.

Sven
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: dependencies of PolicyKit-lang and kupdateapplet-packagekit

Bugzilla from mdb@cs.unm.edu
On Wed, 23 Sep 2009 08:37:54 +0200, Sven Burmeister wrote
> I had to manually remove the package PolicyKit-kde-lang because it
> complained about PolicyKit 0.2 not being available in any repo. Did
> anyone else see that

Yes, the same thing happened to me as well.

--
Marc Benstein

--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: dependencies of PolicyKit-lang and kupdateapplet-packagekit

Tony-181

On 09/23/2009 11:46 AM, Marc Benstein wrote:

> On Wed, 23 Sep 2009 08:37:54 +0200, Sven Burmeister wrote
>  
>> I had to manually remove the package PolicyKit-kde-lang because it
>> complained about PolicyKit 0.2 not being available in any repo. Did
>> anyone else see that
>>    
> Yes, the same thing happened to me as well.
>
> --
> Marc Benstein
>
>  
+1

I have same issue
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: dependencies of PolicyKit-lang and kupdateapplet-packagekit

Bruno Friedmann-2
Tony wrote:

> On 09/23/2009 11:46 AM, Marc Benstein wrote:
>> On Wed, 23 Sep 2009 08:37:54 +0200, Sven Burmeister wrote
>>  
>>> I had to manually remove the package PolicyKit-kde-lang because it
>>> complained about PolicyKit 0.2 not being available in any repo. Did
>>> anyone else see that
>>>    
>> Yes, the same thing happened to me as well.
>>
>> --
>> Marc Benstein
>>
>>  
> +1
>
> I have same issue
+1
Same thing here

--

     Bruno Friedmann

--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: dependencies of PolicyKit-lang and kupdateapplet-packagekit

Dirk Hartmann-5
In reply to this post by Tony-181
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

I've also had the same issue, but kdebase4-workspace obsoletes
PolicyKit-kde because it was integrated into this package. When you run
the following command you will see the following result:

rpm -q kdebase4-workspace --obsoletes | grep PolicyKit-kde
PolicyKit-kde <= 0.2.0


and the query on kdebase4-workspace gives:

rpm -q kdebase4-workspace --provides | grep PolicyKit-kde
PolicyKit-kde = 0.2.0


So this is nothing to worry about. PolicyKit-kde-lang is provided by
bundle-lang-kde-* now.

Hope this helps

Dirk

Am 23.09.2009 20:20, Tony schrieb:

> On 09/23/2009 11:46 AM, Marc Benstein wrote:
>> On Wed, 23 Sep 2009 08:37:54 +0200, Sven Burmeister wrote
>>  
>>> I had to manually remove the package PolicyKit-kde-lang because it
>>> complained about PolicyKit 0.2 not being available in any repo. Did
>>> anyone else see that
>>>    
>> Yes, the same thing happened to me as well.
>>
>> --
>> Marc Benstein
>>
>>  
> +1
>
> I have same issue
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org

iEYEARECAAYFAkq6ajIACgkQpe6IqAWV9x82uACePvOAxrfevO+JYP5l/OHTMfcf
LCUAn3a6ZAypUXivIMBSa3xUVRvAIWOn
=tegG
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: dependencies of PolicyKit-lang and kupdateapplet-packagekit

Sven Burmeister
Am Mittwoch, 23. September 2009 20:34:26 schrieb Dirk Hartmann:
> rpm -q kdebase4-workspace --obsoletes | grep PolicyKit-kde
> PolicyKit-kde <= 0.2.0

> So this is nothing to worry about. PolicyKit-kde-lang is provided by
> bundle-lang-kde-* now.

But if PolicyKit-kde is obsoleted PolicyKit-kde-lang has to be obsoleted as
well by whatever package provides the replacement or by none if no replacement
is needed.

Sven
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: dependencies of PolicyKit-lang and kupdateapplet-packagekit

Mathias Homann
Am Donnerstag, 24. September 2009 08:19:36 schrieb Sven Burmeister:

> Am Mittwoch, 23. September 2009 20:34:26 schrieb Dirk Hartmann:
> > rpm -q kdebase4-workspace --obsoletes | grep PolicyKit-kde
> > PolicyKit-kde <= 0.2.0
> >
> > So this is nothing to worry about. PolicyKit-kde-lang is provided by
> > bundle-lang-kde-* now.
>
> But if PolicyKit-kde is obsoleted PolicyKit-kde-lang has to be obsoleted as
> well by whatever package provides the replacement or by none if no
>  replacement is needed.
>

there's more to this:

seems that KDE4:Factory (KDE 4.3.1 containing kupdateapplet and such
essentials) builds against openSUSE:Factory now, kupdateapplet-packagekit now
requires PackageKit >= 0.5.1 which is only in openSUSE:Factory 0.o
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]