can't install kmail5 in openSuse_13.2

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

can't install kmail5 in openSuse_13.2

Martin Koller
Hi,

just wanted to upgrade 13.2 to use latest KF5 based KDE-PIM following
https://en.opensuse.org/KDE_repositories#Updated_KDE_Applications_only

I added all 4 repos
http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_13.2/
http://download.opensuse.org/repositories/KDE:/Applications/openSUSE_13.2/
http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_13.2/
http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.2/

and when I try to install kmail5, I get an error:

Problem: nothing provides libQt5Core.so.5(Qt_5.6.1_PRIVATE_API)(64bit) needed by akonadi-server-16.04.3-45.3.x86_64
 Solution 1: do not install kmail5-16.04.3-66.4.x86_64
 Solution 2: do not install kmail5-16.04.3-66.4.x86_64
 Solution 3: break akonadi-server-16.04.3-45.3.x86_64 by ignoring some of its dependencies

What's wrong ?

--
Best regards/Schöne Grüße

Martin
A: Because it breaks the logical sequence of discussion
Q: Why is top posting bad?

()  ascii ribbon campaign - against html e-mail
/\                        - against proprietary attachments

Geschenkideen, Accessoires, Seifen, Kulinarisches: www.lillehus.at
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: can't install kmail5 in openSuse_13.2

Wolfgang Bauer
Am Montag, 1. August 2016, 15:44:04 schrieb Martin Koller:
> What's wrong ?

akonadi-server 16.04 fails to build with Qt 5.7, and therefore still requires
Qt 5.6.1 which is not available in KDE:Qt5 any more.

This build failure is fixed in 16.08, which will have the RC released on
Thursday (so it doesn't really make sense to add a patch any more).

For now, you could try to "break" akonadi-server by ignoring the dependency
i.e. Solution 3.
AFAIK this only affects the sqlite backend which is not used by default.
(maybe we should split it out into a separate package to avoid this strict Qt
version dependency for the main package...)

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: can't install kmail5 in openSuse_13.2

Robin Klitscher-2
On 02/08/16 02:43, Wolfgang Bauer wrote:

> Am Montag, 1. August 2016, 15:44:04 schrieb Martin Koller:
>> What's wrong ?
>
> akonadi-server 16.04 fails to build with Qt 5.7, and therefore still requires
> Qt 5.6.1 which is not available in KDE:Qt5 any more.
>
> This build failure is fixed in 16.08, which will have the RC released on
> Thursday (so it doesn't really make sense to add a patch any more).
>
> For now, you could try to "break" akonadi-server by ignoring the dependency
> i.e. Solution 3.
> AFAIK this only affects the sqlite backend which is not used by default.
> (maybe we should split it out into a separate package to avoid this strict Qt
> version dependency for the main package...)
>

On invoking upgrade of digikam packages in Yast2 from 4.14.0 to 5.0.0  I
get a whole series of conflicts based around akonadi-server 15.x =>
16.04.  This appears to be similar to the OP's report for kmail5.

Can I assume this is indeed the case?

Tks

--
Robin K
Wellington "Harbour City"
New Zealand
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: can't install kmail5 in openSuse_13.2

Wolfgang Bauer
Am Dienstag, 2. August 2016, 10:24:20 CEST schrieb Robin Klitscher:
> On invoking upgrade of digikam packages in Yast2 from 4.14.0 to 5.0.0  I
> get a whole series of conflicts based around akonadi-server 15.x =>
> 16.04.  This appears to be similar to the OP's report for kmail5.

Digikam 5.0.0 is not available for 13.2 in and repo maintained by the KDE
team.
So, what openSUSE version are you using, and what repos?

Also, what actual conflict errors are you getting?
Without knowing this, any reply can only be guessing.

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: can't install kmail5 in openSuse_13.2

Robin Klitscher-2
On 03/08/16 07:33, Wolfgang Bauer wrote:

> Am Dienstag, 2. August 2016, 10:24:20 CEST schrieb Robin Klitscher:
>> On invoking upgrade of digikam packages in Yast2 from 4.14.0 to 5.0.0  I
>> get a whole series of conflicts based around akonadi-server 15.x =>
>> 16.04.  This appears to be similar to the OP's report for kmail5.
>
> Digikam 5.0.0 is not available for 13.2 in and repo maintained by the KDE
> team.
> So, what openSUSE version are you using, and what repos?
>
> Also, what actual conflict errors are you getting?
> Without knowing this, any reply can only be guessing.
>

Sorry; I should have been clearer, or at least more complete.

It's Leap 42.1, fully current.

The enabled repo for digikam 5.0.0 is .../KDE:/Extra/openSUSE_Leap_42.1/

Without repeating the entire error list (two pages) the leading stanza
starts off with

"libKF5AkonadiWidgets5-16.04.3-47.4.x86_64 requires akonadi-server, but
this requirement cannot be provided  uninstallable providers:
akonadi-server-16.04.3-47.4.x86_64[KDE5_Applications]"

There are then a number of references to akonadi-server-15.x.x; and it
offers "do not install digikam-5.0.0-147.3.x86_64" as one of the options.

Then there are six further stanzas, typically like this:

"kaddressbook-4.14.10-3.10.x86_64 requires akonadi-runtime >= 1.13.0,
but this requirement cannot be provided"

and each of these similarly has "do not install
digikam-plugin-color-5.0.0-147.3.x86_64 [or some other element of
digikam 5]" as an option.

I know little about the mysteries of all this, but I deduce that the
difficulty originates with the versioning of akonadi-server rather than
with digikam 5.  But please accept that I only raised the question in
hoping that a solution was in the pipeline.  IOW, please don't lose any
sleep over it ...

Regards,

Robin




--
Robin K
Wellington "Harbour City"
New Zealand
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]