building with gcc48

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

building with gcc48

scalpel4k
Hi OBS experts,

I have a little problem with one package that needs to be built with gcc48. However, when I specify that requirement in the spec file I end up with a conflict, because allegedly another version of libgcc_sl1 is already installed (from gcc47).

Does anybody know how I can get around this conflict?

thanks for your help
Michi
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: building with gcc48

Dmitriy Perlow
scalpel4k <[hidden email]> писал(а) в своём письме Sat, 06 Apr 2013  
18:15:48 +0300:

> I have a little problem with one package that needs to be built with  
> gcc48. However, when I specify that requirement in the spec file I end  
> up with a conflict, because allegedly another version of libgcc_sl1 is  
> already installed (from gcc47).
>
> Does anybody know how I can get around this conflict?

Hi. Try to find what requires libgcc_sl1 and rebuild it with gcc48.

--
Dmitriy DA(P).DarkneSS Perlow / Linux x64
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: building with gcc48

Dinar Valeev
In reply to this post by scalpel4k
On Sat, Apr 6, 2013 at 5:15 PM, scalpel4k <[hidden email]> wrote:
> Hi OBS experts,
>
> I have a little problem with one package that needs to be built with gcc48. However, when I specify that requirement in the spec file I end up with a conflict, because allegedly another version of libgcc_sl1 is already installed (from gcc47).
>
T
> Does anybody know how I can get around this conflict?
Try to set %define gcc_version 48 to your project config
> thanks for your help
> Michi
> --
> To unsubscribe, e-mail: [hidden email]
> To contact the owner, e-mail: [hidden email]
>
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: building with gcc48

scalpel4k
the tip with the project config set me on the right track, thanks.
In the end the Preinstall: tag did the trick.

On Saturday 06 Apr 2013 18:14:14 Dinar Valeev wrote:

> On Sat, Apr 6, 2013 at 5:15 PM, scalpel4k <[hidden email]> wrote:
> > Hi OBS experts,
> >
> > I have a little problem with one package that needs to be built with gcc48. However, when I specify that requirement in the spec file I end up with a conflict, because allegedly another version of libgcc_sl1 is already installed (from gcc47).
> >
> T
> > Does anybody know how I can get around this conflict?
> Try to set %define gcc_version 48 to your project config
> > thanks for your help
> > Michi
> > --
> > To unsubscribe, e-mail: [hidden email]
> > To contact the owner, e-mail: [hidden email]
> >
>
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]