alternative "Requires:" - how?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

alternative "Requires:" - how?

Werner Flamme
Hi,

I want to provide a package, DokuWiki. This package requires PHP Version
5.6 or later.

To produce a package realizing this requirement, I tried

Requires: (php5 >= 5.6 or php7)

which I read on <http://rpm.org/user_doc/boolean_dependencies.html> as a
way to do this.

But OBS told me that Requires: are not allowed to start with "(", so I
replaced it by

Requires: php5 >= 5.6 or php7

and now zypper tells me that "nothing provides or needed by
DokuWiki-2017.02.19e-9.1.noarch" :)

So, how can I set alternatives for "Requires:"?

Well, for this package I can set

Requires: php >= 5.6
Requires: mod_php_any >= 5.6

but is there a more general solution as described for rpm4 three years ago?

Werner

--



smime.p7s (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: alternative "Requires:" - how?

Bruno Friedmann-2
On vendredi, 25 août 2017 10.55:22 h CEST Werner Flamme wrote:
> Requires: mod_php_any >= 5.6

I would avoid this kind of requires, as it imply that you need to have
apache2-prefork (which its stated obsolete by upstream) and also make the use
of the package hard to anybody that run php with other httpd engine like nginx
and or use apache2-event with php-fpm


--

Bruno Friedmann
 Ioda-Net Sàrl www.ioda-net.ch
 Bareos Partner, openSUSE Member, fsfe fellowship
 GPG KEY : D5C9B751C4653227
 irc: tigerfoot


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: alternative "Requires:" - how?

Cristian Rodríguez-2
In reply to this post by Werner Flamme


El 25-08-2017 a las 5:55, Werner Flamme escribió:

> But OBS told me that Requires: are not allowed to start with "(",

The OBS is wrong ..most likely it is not aware that rpm spec language
supports this feature..it is not your fault. fill a bug report.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: alternative "Requires:" - how?

Neal Gompa
On Sat, Aug 26, 2017 at 11:52 AM, Cristian Rodríguez
<[hidden email]> wrote:

>
>
> El 25-08-2017 a las 5:55, Werner Flamme escribió:
>
>> But OBS told me that Requires: are not allowed to start with "(",
>
> The OBS is wrong ..most likely it is not aware that rpm spec language
> supports this feature..it is not your fault. fill a bug report.
> --
> To unsubscribe, e-mail: [hidden email]
> To contact the owner, e-mail: [hidden email]
>

perl-BSSolv needs to be upgraded to latest version built with newest
git master libsolv with complex deps enabled. That should allow it to
understand rich deps syntax correctly.

--
真実はいつも一つ!/ Always, there's only one truth!
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]