What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|

What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

doiggl
Hello,
What needs to be changed in specfiles [1] to allow 64 bit modules to be
used instead of 32 bit ones [using opensuse x86_64 system to install on] ?
usimg opensuse 13.x
Thank you.
--Glenn

# uname -a
Linux test.site 3.10.1-3.g0cd5432-desktop #1 SMP PREEMPT Fri Jul 19
14:39:31 UTC 2013 (0cd5432) x86_64 x86_64 x86_64 GNU/Linux

Thank you.
--Glenn

# rpm -ivhU bugzilla-4.5.1-30.1.noarch.rpm
error: Failed dependencies:
        perl-Email-MIME >= 1.816 is needed by bugzilla-4.5.1-30.1.noarch
        perl-Email-MIME-Modifier >= 1.442 is needed by
bugzilla-4.5.1-30.1.noarch

# rpm -ivhU bugzilla-4.5.1-30.1.noarch.rpm
error: Failed dependencies:
        perl-Email-MIME >= 1.816 is needed by bugzilla-4.5.1-30.1.noarch
        perl-Email-MIME-Modifier >= 1.442 is needed by
bugzilla-4.5.1-30.1.noarch
       
[1]specfiles:
https://build.opensuse.org/package/view_file/home:doiggl/bugzilla/bugzilla.spec?expand=1
https://build.opensuse.org/package/view_file/home:doiggl/perl-Email-MIME-Modifier/perl-Email-MIME-Modifier.spec?expand=1

Packages:
https://build.opensuse.org/package/show/home:doiggl/bugzilla
https://build.opensuse.org/package/show/home:doiggl/perl-Email-MIME-Modifier

Source rpms built:
http://ftp5.gwdg.de/pub/opensuse/repositories/home:/doiggl/openSUSE_13.2/src/bugzilla-4.4.8-30.1.src.rpm
http://download.opensuse.org/repositories/home:/doiggl/openSUSE_Factory/src/perl-Email-MIME-1.926-2.1.src.rpm

64 bit opensuse perl modules installed
#####################################

# rpm -qa |grep -i perl |sort
perl-5.18.1-2.1.11.x86_64
perl-AppConfig-1.66-103.1.2.noarch
perl-Bootloader-0.711-1.1.x86_64
perl-Config-Crontab-1.33-6.3.noarch
perl-Crypt-SmbHash-0.12-154.3.x86_64
perl-DBI-1.628-2.1.4.x86_64
perl-Data-Dump-1.22-1.2.noarch
perl-Digest-HMAC-1.03-16.3.noarch
perl-Digest-MD4-1.9-1.3.x86_64
perl-Digest-SHA1-2.13-15.4.x86_64
perl-Email-Date-Format-1.004-2.1.2.noarch
perl-Email-Simple-2.201-2.1.2.noarch
perl-Encode-Locale-1.03-5.4.noarch
perl-File-Listing-6.04-5.3.noarch
perl-HTML-Parser-3.69-16.5.x86_64
perl-HTML-Tagset-3.20-69.3.noarch
perl-HTML-Tidy-1.54-3.4.x86_64
perl-HTTP-Cookies-6.01-5.3.noarch
perl-HTTP-Daemon-6.01-5.3.noarch
perl-HTTP-Date-6.02-5.4.noarch
perl-HTTP-Message-6.02-10.3.noarch
perl-HTTP-Negotiate-6.01-5.3.noarch
perl-IO-Socket-SSL-1.953-1.2.noarch
perl-LWP-MediaTypes-6.02-5.3.noarch
perl-LWP-Protocol-https-6.04-1.1.noarch
perl-MIME-Types-1.34-6.1.2.x86_64
perl-Net-DBus-1.0.0-6.6.x86_64
perl-Net-HTTP-6.06-1.3.noarch
perl-Net-LibIDN-0.12-12.4.x86_64
perl-Net-SSLeay-1.55-1.1.x86_64
perl-NetxAP-0.02-718.3.x86_64
perl-Parse-RecDescent-1.967009-5.3.x86_64
perl-Pod-POM-0.28-2.1.2.noarch
perl-SNMP-5.7.2-9.8.1.x86_64
perl-Template-Toolkit-2.25-2.1.2.x86_64
perl-Term-ReadKey-2.30-10.1.4.x86_64
perl-Text-Wrapper-1.04-1.2.noarch
perl-Tie-IxHash-1.23-1.2.noarch
perl-TimeDate-1.20-22.3.noarch
perl-URI-1.60-5.4.noarch
perl-WWW-RobotRules-6.02-5.3.noarch
perl-X11-Protocol-0.56-10.3.x86_64
perl-X500-DN-0.29-104.2.x86_64
perl-XML-LibXML-2.0019-1.3.x86_64
perl-XML-NamespaceSupport-1.11-19.3.x86_64
perl-XML-Parser-2.41-19.5.x86_64
perl-XML-SAX-0.99-20.3.x86_64
perl-XML-SAX-Base-1.08-6.7.noarch
perl-XML-SAX-Expat-0.50-1.2.noarch
perl-XML-Simple-2.20-1.2.noarch
perl-XML-Twig-3.44-1.3.noarch
perl-XML-Writer-0.623-1.2.noarch
perl-XML-XPath-1.13-97.3.x86_64
perl-XML-XPathEngine-0.14-1.2.noarch
perl-base-5.18.1-2.1.11.x86_64
perl-gettext-1.05-161.4.x86_64
perl-libwww-perl-6.05-1.2.noarch
yast2-perl-bindings-3.0.1-3.1.x86_64

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

Dominique Leuenberger / DimStar
On Mon, 2015-03-30 at 21:51 +1100, [hidden email] wrote:
> Hello,
> What needs to be changed in specfiles [1] to allow 64 bit modules to
> be
> used instead of 32 bit ones [using opensuse x86_64 system to install
> on] ?
> usimg opensuse 13.x
> Thank you.
> --Glenn

I don't think you need anything to be changed... 'noarch' means that
the package does not contain binary, arch-dependent files (which is
common for perl packages; it's an interpreted language and the same
files are used on i586 as well as x86_64).

What you're missing is that the two additional perl modules, your
package relies on, are not available to be installed yet. SO you will
have to package them too (or maybe you can find them in OBS)

Cheers,
Dominique
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

doiggl
On Mon, 30 Mar 2015 13:36:31 +0200, Dominique Leuenberger / DimStar
<[hidden email]> wrote:

> On Mon, 2015-03-30 at 21:51 +1100, [hidden email] wrote:
>> Hello,
>> What needs to be changed in specfiles [1] to allow 64 bit modules to
>> be
>> used instead of 32 bit ones [using opensuse x86_64 system to install
>> on] ?
>> usimg opensuse 13.x
>> Thank you.
>> --Glenn
>
> I don't think you need anything to be changed... 'noarch' means that
> the package does not contain binary, arch-dependent files (which is
> common for perl packages; it's an interpreted language and the same
> files are used on i586 as well as x86_64).
>
> What you're missing is that the two additional perl modules, your
> package relies on, are not available to be installed yet. SO you will
> have to package them too (or maybe you can find them in OBS)
>
> Cheers,
> Dominique

Hello
Which [missing] rpms are you referring to ?

These ones built got built:
http://download.opensuse.org/repositories/home:/doiggl/openSUSE_13.2/noarch/bugzilla-4.4.8-30.1.noarch.rpm
http://download.opensuse.org/repositories/home:/doiggl/openSUSE_Factory/noarch/perl-Email-MIME-1.926-2.1.noarch.rpm


Sourced from:
https://build.opensuse.org/package/binaries/home:doiggl/bugzilla?repository=openSUSE_13.2
https://build.opensuse.org/package/binaries/home:doiggl/perl-Email-MIME-Modifier?repository=openSUSE_Factory

Thanks
--Glenn
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

Jason Craig-4
On 03/30/2015 07:56 AM, [hidden email] wrote:

> On Mon, 30 Mar 2015 13:36:31 +0200, Dominique Leuenberger / DimStar
> <[hidden email]> wrote:
>> On Mon, 2015-03-30 at 21:51 +1100, [hidden email] wrote:
>>> Hello,
>>> What needs to be changed in specfiles [1] to allow 64 bit modules to
>>> be
>>> used instead of 32 bit ones [using opensuse x86_64 system to install
>>> on] ?
>>> usimg opensuse 13.x
>>> Thank you.
>>> --Glenn
>>
>> I don't think you need anything to be changed... 'noarch' means that
>> the package does not contain binary, arch-dependent files (which is
>> common for perl packages; it's an interpreted language and the same
>> files are used on i586 as well as x86_64).
>>
>> What you're missing is that the two additional perl modules, your
>> package relies on, are not available to be installed yet. SO you will
>> have to package them too (or maybe you can find them in OBS)
>>
>> Cheers,
>> Dominique
>
> Hello
> Which [missing] rpms are you referring to ?
>

It's saying

> # rpm -ivhU bugzilla-4.5.1-30.1.noarch.rpm
> error: Failed dependencies:
>         perl-Email-MIME >= 1.816 is needed by bugzilla-4.5.1-30.1.noarch
>         perl-Email-MIME-Modifier >= 1.442 is needed by
> bugzilla-4.5.1-30.1.noarch

so the missing RPMs are "perl-Email-MIME" with a version >= 1.816 and
"perl-Email-MIME-Modifier" >= 1.442. I would find what build service
repository those are in and use zypper (it's more user friendly than
directly using rpm) to install them and bugzilla.

--
Jason Craig
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

Jason Craig-3
In reply to this post by doiggl
On 03/30/2015 07:56 AM, [hidden email] wrote:

> On Mon, 30 Mar 2015 13:36:31 +0200, Dominique Leuenberger / DimStar
> <[hidden email]> wrote:
>> On Mon, 2015-03-30 at 21:51 +1100, [hidden email] wrote:
>>> Hello,
>>> What needs to be changed in specfiles [1] to allow 64 bit modules to
>>> be
>>> used instead of 32 bit ones [using opensuse x86_64 system to install
>>> on] ?
>>> usimg opensuse 13.x
>>> Thank you.
>>> --Glenn
>>
>> I don't think you need anything to be changed... 'noarch' means that
>> the package does not contain binary, arch-dependent files (which is
>> common for perl packages; it's an interpreted language and the same
>> files are used on i586 as well as x86_64).
>>
>> What you're missing is that the two additional perl modules, your
>> package relies on, are not available to be installed yet. SO you will
>> have to package them too (or maybe you can find them in OBS)
>>
>> Cheers,
>> Dominique
>
> Hello
> Which [missing] rpms are you referring to ?

It's saying

 > # rpm -ivhU bugzilla-4.5.1-30.1.noarch.rpm
 > error: Failed dependencies:
 >         perl-Email-MIME >= 1.816 is needed by bugzilla-4.5.1-30.1.noarch
 >         perl-Email-MIME-Modifier >= 1.442 is needed by
 > bugzilla-4.5.1-30.1.noarch

so the missing RPMs are "perl-Email-MIME" with a version >= 1.816 and
"perl-Email-MIME-Modifier" >= 1.442. I would find what build service
repository those are in and use zypper (it's more user friendly than
directly using rpm) to install them and bugzilla.

--
Jason Craig
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

gregfreemyer
--
Greg Freemyer


On Mon, Mar 30, 2015 at 11:15 AM, Jason Craig <[hidden email]> wrote:

> On 03/30/2015 07:56 AM, [hidden email] wrote:
>>
>> On Mon, 30 Mar 2015 13:36:31 +0200, Dominique Leuenberger / DimStar
>> <[hidden email]> wrote:
>>>
>>> On Mon, 2015-03-30 at 21:51 +1100, [hidden email] wrote:
>>>>
>>>> Hello,
>>>> What needs to be changed in specfiles [1] to allow 64 bit modules to
>>>> be
>>>> used instead of 32 bit ones [using opensuse x86_64 system to install
>>>> on] ?
>>>> usimg opensuse 13.x
>>>> Thank you.
>>>> --Glenn
>>>
>>>
>>> I don't think you need anything to be changed... 'noarch' means that
>>> the package does not contain binary, arch-dependent files (which is
>>> common for perl packages; it's an interpreted language and the same
>>> files are used on i586 as well as x86_64).
>>>
>>> What you're missing is that the two additional perl modules, your
>>> package relies on, are not available to be installed yet. SO you will
>>> have to package them too (or maybe you can find them in OBS)
>>>
>>> Cheers,
>>> Dominique
>>
>>
>> Hello
>> Which [missing] rpms are you referring to ?
>
>
> It's saying
>
>> # rpm -ivhU bugzilla-4.5.1-30.1.noarch.rpm
>> error: Failed dependencies:
>>         perl-Email-MIME >= 1.816 is needed by bugzilla-4.5.1-30.1.noarch
>>         perl-Email-MIME-Modifier >= 1.442 is needed by
>> bugzilla-4.5.1-30.1.noarch
>
> so the missing RPMs are "perl-Email-MIME" with a version >= 1.816 and
> "perl-Email-MIME-Modifier" >= 1.442. I would find what build service
> repository those are in and use zypper (it's more user friendly than
> directly using rpm) to install them and bugzilla.

perl-Emai-MIME is easily found via:  http://software.opensuse.org/search

http://software.opensuse.org/search?utf8=%E2%9C%93&q=perl-Email-MIME&search_devel=false&search_unsupported=false&baseproject=openSUSE%3A13.2

If follow the links you find it is devel:languages:perl and is new
enough to meet the dependency.  Glenn, you just need to branch a copy
of the D:L:P version to your relevant home project / sub-project.

 perl-Email-MIME-Modifier is not found, so I'm assuming it is not
packaged.  So you will need to package that in OBS as a first step.

Greg
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

doiggl
In reply to this post by Jason Craig-3
On Mon, 30 Mar 2015 09:15:55 -0600, Jason Craig <[hidden email]>
wrote:

> On 03/30/2015 07:56 AM, [hidden email] wrote:
>> On Mon, 30 Mar 2015 13:36:31 +0200, Dominique Leuenberger / DimStar
>> <[hidden email]> wrote:
>>> On Mon, 2015-03-30 at 21:51 +1100, [hidden email] wrote:
>>>> Hello,
>>>> What needs to be changed in specfiles [1] to allow 64 bit modules to
>>>> be
>>>> used instead of 32 bit ones [using opensuse x86_64 system to install
>>>> on] ?
>>>> usimg opensuse 13.x
>>>> Thank you.
>>>> --Glenn
>>>
>>> I don't think you need anything to be changed... 'noarch' means that
>>> the package does not contain binary, arch-dependent files (which is
>>> common for perl packages; it's an interpreted language and the same
>>> files are used on i586 as well as x86_64).
>>>
>>> What you're missing is that the two additional perl modules, your
>>> package relies on, are not available to be installed yet. SO you will
>>> have to package them too (or maybe you can find them in OBS)
>>>
>>> Cheers,
>>> Dominique
>>
>> Hello
>> Which [missing] rpms are you referring to ?
>
> It's saying
>
>  > # rpm -ivhU bugzilla-4.5.1-30.1.noarch.rpm
>  > error: Failed dependencies:
>  >         perl-Email-MIME >= 1.816 is needed by
bugzilla-4.5.1-30.1.noarch

>  >         perl-Email-MIME-Modifier >= 1.442 is needed by
>  > bugzilla-4.5.1-30.1.noarch
>
> so the missing RPMs are "perl-Email-MIME" with a version >= 1.816 and
> "perl-Email-MIME-Modifier" >= 1.442. I would find what build service
> repository those are in and use zypper (it's more user friendly than
> directly using rpm) to install them and bugzilla.
>
> --
> Jason Craig

Hello,
The rpms got built:


Architecture: x86_64

    _buildenv
    bugzilla-4.4.8-35.1.noarch.rpm
    bugzilla-4.4.8-35.1.src.rpm
    rpmlint.log


Architecture: x86_64

    _buildenv
    perl-Email-MIME-1.926-2.1.noarch.rpm
    perl-Email-MIME-1.926-2.1.src.rpm
    rpmlint.log

Locations:
http://download.opensuse.org/repositories/home:/doiggl/openSUSE_Factory/noarch/bugzilla-4.4.8-35.1.noarch.rpm
http://download.opensuse.org/repositories/home:/doiggl/openSUSE_Factory/noarch/perl-Email-MIME-1.926-2.1.noarch.rpm

- next I added the repo to zypper and refresh

# zypper ar -f -c
http://download.opensuse.org/repositories/home:/doiggl/openSUSE_Factory
myTestBuilds
Adding repository 'myTestBuilds' .......[done]
Repository 'myTestBuilds' successfully added
Enabled: Yes
Autorefresh: Yes
GPG check: Yes
URI:
http://download.opensuse.org/repositories/home:/doiggl/openSUSE_Factory

# zypper ref
Repository 'LibreOffice' is up to date.
Repository 'myTestBuilds' is up to date.
Repository 'repo-non-oss' is up to date.
Repository 'repo-oss' is up to date.
Repository 'repo-update' is up to date.
Repository 'repo-update-13.1-non-oss' is up to date.
Repository 'server:monitoring' is up to date.
All repositories have been refreshed.



# try to install bugzilla and perl-Email-MIME on x86_64 platform.

# zypper in bugzilla
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: bugzilla-4.4.8-35.1.noarch requires perl-Email-MIME-Modifier >=
1.442, but this requirement cannot be provided
  uninstallable providers: perl-Email-MIME-1.926-2.1.noarch[myTestBuilds]
 Solution 1: do not install bugzilla-4.4.8-35.1.noarch
 Solution 2: do not install bugzilla-4.4.8-35.1.noarch                    
                                                     
 Solution 3: break bugzilla-4.4.8-35.1.noarch by ignoring some of its
dependencies                                                        
                                                                         
                                                                         
       
Choose from above solutions by number or cancel [1/2/3/c] (c):            
                                                                         
               
#                                                      

# zypper in perl-Email-MIME
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: perl-Email-MIME-1.926-2.1.noarch requires
perl(:MODULE_COMPAT_5.20.1), but this requirement cannot be provided
  uninstallable providers: perl-5.20.1-129.2.i586[myTestBuilds]
                   perl-5.20.1-134.3.x86_64[myTestBuilds]
 Solution 1: do not install perl-Email-MIME-1.926-2.1.noarch
 Solution 2: do not install perl-Email-MIME-1.926-2.1.noarch
 Solution 3: break perl-Email-MIME-1.926-2.1.noarch by ignoring some of
its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c):
#


Seems to want 32 bit perl(:MODULE_COMPAT_5.20.1).

I use 64 bit perl installed and 64 bit perl modules.

# rpm -qa | grep -i perl |sort
perl-5.18.1-2.1.11.x86_64
.
.

Back to Question:
What needs to be changed in specfiles [1] to allow 64 bit modules to be
used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

--Thanks Glenn

[1]specfiles:
https://build.opensuse.org/package/view_file/home:doiggl/bugzilla/bugzilla.spec?expand=1
https://build.opensuse.org/package/view_file/home:doiggl/perl-Email-MIME-Modifier/perl-Email-MIME-Modifier.spec?expand=1

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

Dominique Leuenberger / DimStar
On Tue, 2015-03-31 at 17:25 +1100, [hidden email] wrote:

>
> Seems to want 32 bit perl(:MODULE_COMPAT_5.20.1).
>
> I use 64 bit perl installed and 64 bit perl modules.
>
> # rpm -qa | grep -i perl |sort
> perl-5.18.1-2.1.11.x86_64
> .
> .
>
> Back to Question:
> What needs to be changed in specfiles [1] to allow 64 bit modules to
> be
> used instead of 32 bit ones [using opensuse x86_64 system to install
> on] ?

Still the wrong question - look at what is requested and what you
provide:

Problem: perl-Email-MIME-1.926-2.1.noarch requires
perl(:MODULE_COMPAT_5.20.1), but this requirement cannot be provided
  uninstallable providers: perl-5.20.1-129.2.i586[myTestBuilds]
                   perl-5.20.1-134.3.x86_64[myTestBuilds]

vs

# rpm -qa | grep -i perl |sort
perl-5.18.1-2.1.11.x86_64

=> it asks for perl 5.20.1, you provide 5.18.1; I'd say you do not
provide a sufficient new version of perl.

and the one provided in 'myTestBuilds' is not being accepted because
there is likely a lot of other stuff that would need to be removed on
your system.

So you should ask yourself the question: why are you adding a new
version of perl into your repository?

Cheers,
Dominique
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

doiggl
Hello,

Rpms built:
##########
http://mirrors1.kernel.org/opensuse/factory/repo/oss/suse/x86_64/perl-5.20.1-3.1.x86_64.rpm
http://download.opensuse.org/repositories/home:/doiggl/openSUSE_Factory/noarch/bugzilla-4.4.8-35.1.noarch.rpm
http://download.opensuse.org/repositories/home:/doiggl/openSUSE_Factory/noarch/perl-Email-MIME-1.926-2.1.noarch.rpm

Add repos:
#########
zypper ar -f -c  http://mirrors1.kernel.org/opensuse/factory/repo/oss/   
                 FactoryLatestOss
zypper ar -f -c
http://download.opensuse.org/repositories/home:/doiggl/openSUSE_Factory/   
myTestBuilds

# zypper ar -f -c  http://mirrors1.kernel.org/opensuse/factory/repo/oss/ 
                   FactoryLatestOss
Adding repository 'FactoryLatestOss'
..........................................................[done]
Repository 'FactoryLatestOss' successfully added
Enabled: Yes
Autorefresh: Yes
GPG check: Yes
URI: http://mirrors1.kernel.org/opensuse/factory/repo/oss/

# zypper ar -f -c
http://download.opensuse.org/repositories/home:/doiggl/openSUSE_Factory/   
myTestBuilds
Adding repository 'myTestBuilds'
..............................................................[done]
Repository 'myTestBuilds' successfully added
Enabled: Yes
Autorefresh: Yes
GPG check: Yes
URI:
http://download.opensuse.org/repositories/home:/doiggl/openSUSE_Factory/

# zypper ref
Repository 'FactoryLatestOss' is up to date.
Repository 'myTestBuilds' is up to date.
Repository 'repo-non-oss' is up to date.
Repository 'repo-oss' is up to date.
Repository 'repo-update' is up to date.
Repository 'repo-update-13.1-non-oss' is up to date.
All repositories have been refreshed.

Install options bugzilla
-------------------------

See [1] for full listing

my observations:
----------------

- Did not find newer perl-5.20.1-3.1.x86_64.rpm

Question:
--------

What simple option todo next to resolve/install process?

Thank you
--Glenn

[1]full listing


# zypper install bugzilla
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: bugzilla-4.4.8-35.1.noarch requires perl-Email-MIME-Modifier >=
1.442, but this requirement cannot be provided
  uninstallable providers: perl-Email-MIME-1.926-2.1.noarch[myTestBuilds]
 Solution 1: deinstallation of yast2-fingerprint-reader-3.0.0-1.2.x86_64
 Solution 2: do not install bugzilla-4.4.8-35.1.noarch
 Solution 3: do not install bugzilla-4.4.8-35.1.noarch
 Solution 4: break bugzilla-4.4.8-35.1.noarch by ignoring some of its
dependencies

Choose from above solutions by number or cancel [1/2/3/4/c] (c): 1
Resolving dependencies...
Resolving package dependencies...

Problem: bugzilla-4.4.8-35.1.noarch requires perl-Email-MIME-Modifier >=
1.442, but this requirement cannot be provided
  uninstallable providers: perl-Email-MIME-1.926-2.1.noarch[myTestBuilds]
 Solution 1: Following actions will be done:
  deinstallation of yast2-tv-3.0.0-1.2.noarch
  deinstallation of yast2-sound-3.0.0-1.2.x86_64
 Solution 2: Following actions will be done:
  deinstallation of yast2-packager-3.0.1-1.1.x86_64
  deinstallation of yast2-inetd-3.0.0-1.2.noarch
  deinstallation of yast2-iscsi-client-3.0.0-1.2.noarch
  deinstallation of yast2-metapackage-handler-3.0.0-1.2.noarch
  deinstallation of libksuseinstall1-4.10.97-1.2.x86_64
  deinstallation of patterns-openSUSE-yast2_basis-13.1-10.1.x86_64
  deinstallation of autoyast2-installation-3.0.0-1.2.noarch
  deinstallation of yast2-add-on-3.0.0-1.2.noarch
  deinstallation of yast2-online-update-3.0.0-1.2.noarch
  deinstallation of yast2-bootloader-3.0.1-1.1.x86_64
  deinstallation of yast2-country-3.0.0-1.2.x86_64
  deinstallation of yast2-installation-3.0.3-1.1.noarch
  deinstallation of yast2-update-3.0.0-1.2.x86_64
  architecture change of libkde4-4.11.5-488.2.x86_64 to
libkde4-4.14.6-1.1.i586
  install libkde4-4.14.6-1.1.i586 despite the inferior architecture
  deinstallation of yast2-backup-3.0.0-1.2.noarch
  architecture change of kdebase4-runtime-4.11.5-482.6.x86_64 to
kdebase4-runtime-14.12.3-1.1.i586
  install kdebase4-runtime-14.12.3-1.1.i586 despite the inferior
architecture
  deinstallation of patterns-openSUSE-yast2_install_wf-13.1-10.1.x86_64
  deinstallation of yast2-tune-3.0.1-1.1.x86_64
  deinstallation of yast2-restore-3.0.0-1.2.noarch
  deinstallation of yast2-online-update-frontend-3.0.0-1.2.noarch
  architecture change of libkdcraw22-4.10.97-1.2.x86_64 to
libkdcraw22-4.11.5-298.1.i586
  install libkdcraw22-4.11.5-298.1.i586 despite the inferior architecture
  architecture change of libkcompactdisc4-4.10.97-1.2.x86_64 to
libkcompactdisc4-14.12.3-1.1.i586
  architecture change of libkcddb4-4.10.97-1.2.x86_64 to
libkcddb4-14.12.3-1.1.i586
  install libkcompactdisc4-14.12.3-1.1.i586 despite the inferior
architecture
  install libkcddb4-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of ark-4.10.97-1.2.x86_64 to ark-14.12.3-1.1.i586
  install ark-14.12.3-1.1.i586 despite the inferior architecture
  install libkerfuffle4-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of bluedevil-1.3.1-2.5.x86_64 to
bluedevil-2.1.1-1.1.i586
  install bluedevil-2.1.1-1.1.i586 despite the inferior architecture
  install libbluedevil2-2.1-1.1.i586 despite the inferior architecture
  architecture change of choqok-1.3-6.4.x86_64 to choqok-1.5-1.1.i586
  install choqok-1.5-1.1.i586 despite the inferior architecture
  install libqoauth1-1.0.1-22.2.i586 despite the inferior architecture
  architecture change of dolphin-4.10.97-1.2.x86_64 to
dolphin-4.11.5-474.8.i586
  install dolphin-4.11.5-474.8.i586 despite the inferior architecture
  architecture change of k3b-2.0.2-28.8.x86_64 to k3b-2.0.3-2.2.i586
  install k3b-2.0.3-2.2.i586 despite the inferior architecture
  architecture change of kactivities4-4.10.97-1.2.x86_64 to
kactivities4-4.13.3-5.3.i586
  install kactivities4-4.13.3-5.3.i586 despite the inferior architecture
  architecture change of kcalc-4.10.97-1.2.x86_64 to
kcalc-14.12.3-1.1.i586
  install kcalc-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of kcharselect-4.10.97-1.2.x86_64 to
kcharselect-14.12.3-1.1.i586
  install kcharselect-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of kcolorchooser-4.10.97-1.2.x86_64 to
kcolorchooser-14.12.3-1.1.i586
  install kcolorchooser-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of kde4-kgreeter-plugins-4.10.97-1.2.x86_64 to
kde4-kgreeter-plugins-4.11.17-2.1.i586
  install kde4-kgreeter-plugins-4.11.17-2.1.i586 despite the inferior
architecture
  architecture change of kde4-print-manager-4.10.97-1.2.x86_64 to
kde4-print-manager-14.12.3-1.1.i586
  install kde4-print-manager-14.12.3-1.1.i586 despite the inferior
architecture
  architecture change of kdeartwork4-screensaver-4.10.97-1.2.x86_64 to
kdeartwork4-screensaver-14.12.3-1.1.i586
  install kdeartwork4-screensaver-14.12.3-1.1.i586 despite the inferior
architecture
  install libkexiv2-11-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of kdebase4-libkonq-4.10.97-1.2.x86_64 to
kdebase4-libkonq-4.11.5-474.8.i586
  install kdebase4-libkonq-4.11.5-474.8.i586 despite the inferior
architecture
  architecture change of kdebase4-nsplugin-4.10.97-1.2.x86_64 to
kdebase4-nsplugin-14.12.3-1.1.i586
  install kdebase4-nsplugin-14.12.3-1.1.i586 despite the inferior
architecture
  architecture change of kdebase4-workspace-ksysguardd-4.10.97-1.2.x86_64
to kdebase4-workspace-ksysguardd-4.11.17-2.1.i586
  install kdebase4-workspace-ksysguardd-4.11.17-2.1.i586 despite the
inferior architecture
  architecture change of
kdebase4-workspace-liboxygenstyle-4.10.97-1.2.x86_64 to
kdebase4-workspace-liboxygenstyle-4.11.17-2.1.i586
  install kdebase4-workspace-liboxygenstyle-4.11.17-2.1.i586 despite the
inferior architecture
  architecture change of konqueror-4.10.97-1.2.x86_64 to
konqueror-4.11.5-474.8.i586
  install konqueror-4.11.5-474.8.i586 despite the inferior architecture
  architecture change of konqueror-plugins-4.10.97-1.2.x86_64 to
konqueror-plugins-4.11.5-474.8.i586
  install konqueror-plugins-4.11.5-474.8.i586 despite the inferior
architecture
  install libtidy-0_99-0-1.0.20100204cvs-20.2.i586 despite the inferior
architecture
  architecture change of libakonadi4-4.10.97-1.2.x86_64 to
libakonadi4-4.14.6-1.1.i586
  install libakonadi4-4.14.6-1.1.i586 despite the inferior architecture
  architecture change of libkdepim4-4.10.97-1.2.x86_64 to
libkdepim4-4.14.6-1.1.i586
  install libkdepim4-4.14.6-1.1.i586 despite the inferior architecture
  architecture change of libkdepimlibs4-4.10.97-1.2.x86_64 to
libkdepimlibs4-4.14.6-1.1.i586
  install libkdepimlibs4-4.14.6-1.1.i586 despite the inferior architecture
  architecture change of libkonq5-4.10.97-1.2.x86_64 to
libkonq5-4.11.5-474.8.i586
  install libkonq5-4.11.5-474.8.i586 despite the inferior architecture
  architecture change of NetworkManager-kde4-libs-0.9.0.9-1.2.x86_64 to
NetworkManager-kde4-libs-0.9.0.10-2.8.1.i586
  architecture change of NetworkManager-openvpn-kde4-0.9.0.9-1.2.x86_64 to
NetworkManager-openvpn-kde4-0.9.0.10-2.8.1.i586
  architecture change of NetworkManager-pptp-kde4-0.9.0.9-1.2.x86_64 to
NetworkManager-pptp-kde4-0.9.0.10-2.8.1.i586
  architecture change of NetworkManager-vpnc-kde4-0.9.0.9-1.2.x86_64 to
NetworkManager-vpnc-kde4-0.9.0.10-2.8.1.i586
  architecture change of akonadi-4.10.97-1.2.x86_64 to
akonadi-4.14.6-1.1.i586
  install akonadi-4.14.6-1.1.i586 despite the inferior architecture
  install kdepim4-4.14.6-1.1.i586 despite the inferior architecture
  install libgrantlee_gui0-0.4.0-3.2.i586 despite the inferior
architecture
  architecture change of amarok-2.7.90-1.3.x86_64 to
amarok-2.8.0-14.1.i586
  install amarok-2.8.0-14.1.i586 despite the inferior architecture
  install liblastfm1-1.0.8-3.2.i586 despite the inferior architecture
  install libloudmouth-1-0-1.4.3-24.1.i586 despite the inferior
architecture
  install libmtp9-1.1.8-1.1.i586 despite the inferior architecture
  install libmygpo-qt1-1.0.7-5.2.i586 despite the inferior architecture
  install libmysqld18-5.5.33-3.84.i586 despite the inferior architecture
  install libtag-extras1-1.0.1-22.2.i586 despite the inferior architecture
  architecture change of apper-0.8.0-10.4.x86_64 to
apper-0.8.1-11.7.1.i586
  install apper-0.8.1-11.7.1.i586 despite the inferior architecture
  architecture change of digikam-3.2.0-3.4.x86_64 to
digikam-4.8.0-1.2.i586
  install digikam-4.8.0-1.2.i586 despite the inferior architecture
  architecture change of gwenview-4.10.97-1.2.x86_64 to
gwenview-4.14.3-1.2.i586
  install gwenview-4.14.3-1.2.i586 despite the inferior architecture
  architecture change of kaddressbook-4.10.97-1.2.x86_64 to
kaddressbook-4.14.6-1.1.i586
  install kaddressbook-4.14.6-1.1.i586 despite the inferior architecture
  architecture change of kdebase4-openSUSE-13.1-3.15.x86_64 to
kdebase4-openSUSE-13.2-6.63.i586
  install kdebase4-openSUSE-13.2-6.63.i586 despite the inferior
architecture
  architecture change of
kdebase4-workspace-branding-openSUSE-13.1-3.15.x86_64 to
kdebase4-workspace-branding-openSUSE-13.2-6.63.i586
  install kdebase4-workspace-branding-openSUSE-13.2-6.63.i586 despite the
inferior architecture
  install kdebase4-workspace-4.11.17-2.1.i586 despite the inferior
architecture
  install cln-1.3.4-1.2.i586 despite the inferior architecture
  install libqimageblitz4-0.0.6-13.2.i586 despite the inferior
architecture
  architecture change of kdenetwork4-filesharing-4.10.97-1.2.x86_64 to
kdenetwork4-filesharing-14.12.3-1.1.i586
  install kdenetwork4-filesharing-14.12.3-1.1.i586 despite the inferior
architecture
  architecture change of kdepasswd-4.10.97-1.2.x86_64 to
kdepasswd-14.12.3-1.1.i586
  install kdepasswd-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of kdepim4-4.10.97-1.2.x86_64 to
kdepim4-4.14.6-1.1.i586
  architecture change of kdepim4-runtime-4.10.97-1.2.x86_64 to
kdepim4-runtime-4.14.6-1.1.i586
  install kdepim4-runtime-4.14.6-1.1.i586 despite the inferior
architecture
  install libkfbapi1-1.0-6.2.i586 despite the inferior architecture
  install libkolab0-0.5.3-3.2.i586 despite the inferior architecture
  architecture change of kdepimlibs4-4.10.97-1.2.x86_64 to
kdepimlibs4-4.14.6-1.1.i586
  install kdepimlibs4-4.14.6-1.1.i586 despite the inferior architecture
  architecture change of kdialog-4.10.97-1.2.x86_64 to
kdialog-14.12.3-1.1.i586
  install kdialog-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of kdm-4.10.97-1.2.x86_64 to kdm-4.11.17-2.1.i586
  install kdm-4.11.17-2.1.i586 despite the inferior architecture
  architecture change of kdnssd-4.10.97-1.2.x86_64 to
kdnssd-14.12.3-1.1.i586
  install kdnssd-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of keditbookmarks-4.10.97-1.2.x86_64 to
keditbookmarks-14.12.3-1.1.i586
  install keditbookmarks-14.12.3-1.1.i586 despite the inferior
architecture
  architecture change of kgamma-4.10.97-1.2.x86_64 to
kgamma-14.12.3-1.1.i586
  install kgamma-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of kget-4.10.97-1.2.x86_64 to kget-14.12.3-1.1.i586
  install kget-14.12.3-1.1.i586 despite the inferior architecture
  install libktorrent5-1.3.1-7.2.i586 despite the inferior architecture
  architecture change of kgpg-4.10.97-1.2.x86_64 to kgpg-14.12.3-1.1.i586
  install kgpg-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of kio_audiocd-4.10.97-1.2.x86_64 to
kio_audiocd-14.12.3-1.1.i586
  install kio_audiocd-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of kio_iso-2.4.0~beta3-3.9.x86_64 to
kio_iso-2.4.0~beta3-8.1.i586
  install kio_iso-2.4.0~beta3-8.1.i586 despite the inferior architecture
  architecture change of kio_kamera-4.10.97-1.2.x86_64 to
kio_kamera-14.12.3-1.1.i586
  install kio_kamera-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of kio_mtp-0.75-1.5.x86_64 to kio_mtp-0.75-5.2.i586
  install kio_mtp-0.75-5.2.i586 despite the inferior architecture
  architecture change of kipi-plugins-3.2.0-3.4.x86_64 to
kipi-plugins-4.8.0-1.2.i586
  install kipi-plugins-4.8.0-1.2.i586 despite the inferior architecture
  install libkvkontakte1-1.0.0-10.2.i586 despite the inferior architecture
  install libmediawiki1-4.8.0-1.2.i586 despite the inferior architecture
  architecture change of kmag-4.10.97-1.2.x86_64 to kmag-14.12.3-1.1.i586
  install kmag-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of kmahjongg-4.10.97-1.2.x86_64 to
kmahjongg-14.12.3-1.1.i586
  install kmahjongg-14.12.3-1.1.i586 despite the inferior architecture
  install libkdegames6-14.12.3-1.1.i586 despite the inferior architecture
  install libkmahjongglib4-14.12.3-1.1.i586 despite the inferior
architecture
  architecture change of kmail-4.10.97-1.2.x86_64 to kmail-4.14.6-1.1.i586
  install kmail-4.14.6-1.1.i586 despite the inferior architecture
  architecture change of kmines-4.10.97-1.2.x86_64 to
kmines-14.12.3-1.1.i586
  install kmines-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of kmix-4.10.97-1.2.x86_64 to kmix-14.12.3-1.1.i586
  install kmix-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of kmousetool-4.10.97-1.2.x86_64 to
kmousetool-14.12.3-1.1.i586
  install kmousetool-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of knotes-4.10.97-1.2.x86_64 to
knotes-4.14.6-1.1.i586
  install knotes-4.14.6-1.1.i586 despite the inferior architecture
  architecture change of kompare-4.10.97-1.2.x86_64 to
kompare-4.11.5-98.1.i586
  install kompare-4.11.5-98.1.i586 despite the inferior architecture
  architecture change of kontact-4.10.97-1.2.x86_64 to
kontact-4.14.6-1.1.i586
  install kontact-4.14.6-1.1.i586 despite the inferior architecture
  architecture change of konversation-1.5~rc1-2.5.x86_64 to
konversation-1.5.1-3.4.3.i586
  install konversation-1.5.1-3.4.3.i586 despite the inferior architecture
  architecture change of kopete-4.10.97-1.2.x86_64 to
kopete-14.12.3-1.1.i586
  install kopete-14.12.3-1.1.i586 despite the inferior architecture
  install libgadu3-1.12.1-1.1.i586 despite the inferior architecture
  install libmeanwhile1-1.0.2-136.2.i586 despite the inferior architecture
  architecture change of korganizer-4.10.97-1.2.x86_64 to
korganizer-4.14.6-1.1.i586
  install korganizer-4.14.6-1.1.i586 despite the inferior architecture
  architecture change of kpat-4.10.97-1.2.x86_64 to kpat-14.12.3-1.1.i586
  install kpat-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of krdc-4.10.97-1.2.x86_64 to krdc-14.12.3-1.1.i586
  install krdc-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of kreversi-4.10.97-1.2.x86_64 to
kreversi-14.12.3-1.1.i586
  install kreversi-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of krfb-4.10.97-1.2.x86_64 to krfb-4.11.5-99.1.i586
  install krfb-4.11.5-99.1.i586 despite the inferior architecture
  architecture change of kruler-4.10.97-1.2.x86_64 to
kruler-14.12.3-1.1.i586
  install kruler-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of kscreen-1.0.1-1.2.x86_64 to
kscreen-1.0.71-3.3.i586
  install kscreen-1.0.71-3.3.i586 despite the inferior architecture
  install libkscreen1-1.0.5-1.2.i586 despite the inferior architecture
  architecture change of ksnapshot-4.10.97-1.2.x86_64 to
ksnapshot-14.12.3-1.1.i586
  install ksnapshot-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of ksshaskpass-0.5.3-14.5.x86_64 to
ksshaskpass-0.5.3-19.1.i586
  install ksshaskpass-0.5.3-19.1.i586 despite the inferior architecture
  architecture change of ksudoku-4.10.97-1.2.x86_64 to
ksudoku-14.12.3-1.1.i586
  install ksudoku-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of ktorrent-4.3.1-3.9.x86_64 to
ktorrent-4.3.1-10.1.i586
  install ktorrent-4.3.1-10.1.i586 despite the inferior architecture
  architecture change of kvkbd-0.6-22.9.x86_64 to kvkbd-0.7.2-3.2.i586
  install kvkbd-0.7.2-3.2.i586 despite the inferior architecture
  architecture change of kwalletmanager-4.10.97-1.2.x86_64 to
kwalletmanager-14.12.3-1.1.i586
  install kwalletmanager-14.12.3-1.1.i586 despite the inferior
architecture
  architecture change of kwebkitpart-1.3.2-1.5.x86_64 to
kwebkitpart-1.3.3-5.1.i586
  install kwebkitpart-1.3.3-5.1.i586 despite the inferior architecture
  architecture change of kwin-4.10.97-1.2.x86_64 to kwin-4.11.17-2.1.i586
  install kwin-4.11.17-2.1.i586 despite the inferior architecture
  architecture change of plasma-addons-lancelot-4.10.97-1.2.x86_64 to
plasma-addons-lancelot-4.14.3-3.2.i586
  install plasma-addons-lancelot-4.14.3-3.2.i586 despite the inferior
architecture
  architecture change of kate-4.11.5-456.7.x86_64 to kate-4.14.3-1.3.i586
  install kate-4.14.3-1.3.i586 despite the inferior architecture
  architecture change of kdebase4-workspace-4.10.97-1.2.x86_64 to
kdebase4-workspace-4.11.17-2.1.i586
  architecture change of
kdebase4-workspace-plasma-calendar-4.10.97-1.2.x86_64 to
kdebase4-workspace-plasma-calendar-4.11.17-2.1.i586
  install kdebase4-workspace-plasma-calendar-4.11.17-2.1.i586 despite the
inferior architecture
  architecture change of kdelibs4-4.11.5-488.2.x86_64 to
kdelibs4-4.14.6-1.1.i586
  architecture change of kdelibs4-core-4.11.5-488.2.x86_64 to
kdelibs4-core-4.14.6-1.1.i586
  install kdelibs4-core-4.14.6-1.1.i586 despite the inferior architecture
  architecture change of kwrite-4.11.5-456.7.x86_64 to
kwrite-4.14.3-1.3.i586
  install kwrite-4.14.3-1.3.i586 despite the inferior architecture
  architecture change of flash-player-kde4-11.2.202.451-110.1.x86_64 to
flash-player-kde4-11.2.202.451-110.1.i586
  install flash-player-kde4-11.2.202.451-110.1.i586 despite the inferior
architecture
  architecture change of libkdegames6-4.10.97-1.2.x86_64 to
libkdegames6-14.12.3-1.1.i586
  architecture change of libkerfuffle4-4.10.97-1.2.x86_64 to
libkerfuffle4-14.12.3-1.1.i586
  architecture change of libkexiv2-11-4.10.97-1.2.x86_64 to
libkexiv2-11-14.12.3-1.1.i586
  architecture change of libkfbapi1-1.0-1.4.x86_64 to
libkfbapi1-1.0-6.2.i586
  architecture change of libkgapi2-2-2.0.1-2.3.x86_64 to
libkgapi2-2-2.2.0-3.2.i586
  architecture change of libkipi11-4.10.97-1.2.x86_64 to
libkipi11-14.12.3-1.1.i586
  architecture change of libkmahjongglib4-4.10.97-1.2.x86_64 to
libkmahjongglib4-14.12.3-1.1.i586
  architecture change of libkscreen-1.0.1-1.2.x86_64 to
libkscreen-1.0.5-1.2.i586
  install libkscreen-1.0.5-1.2.i586 despite the inferior architecture
  architecture change of libktexteditor-4.11.5-456.7.x86_64 to
libktexteditor-4.14.3-1.3.i586
  install libktexteditor-4.14.3-1.3.i586 despite the inferior architecture
  architecture change of libkvkontakte1-1.0.0-6.4.x86_64 to
libkvkontakte1-1.0.0-10.2.i586
  architecture change of libnepomukwidgets4-4.10.97-1.2.x86_64 to
libnepomukwidgets4-4.14.3-1.2.i586
  architecture change of libkgeomap1-3.2.0-3.4.x86_64 to
libkgeomap2-4.8.0-1.2.i586
  architecture change of libktorrent5-1.3.1-3.7.x86_64 to
libktorrent5-1.3.1-7.2.i586
  architecture change of libreoffice-kde4-4.1.0.4-2.2.x86_64 to
libreoffice-kde4-4.4.1.2-2.3.i586
  install libreoffice-kde4-4.4.1.2-2.3.i586 despite the inferior
architecture
  install libreoffice-4.4.1.2-2.3.i586 despite the inferior architecture
  architecture change of mozilla-kde4-integration-0.6.4-3.5.x86_64 to
mozilla-kde4-integration-0.6.4-7.1.i586
  install mozilla-kde4-integration-0.6.4-7.1.i586 despite the inferior
architecture
  architecture change of plasma-addons-4.10.97-1.2.x86_64 to
plasma-addons-4.14.3-3.2.i586
  install plasma-addons-4.14.3-3.2.i586 despite the inferior architecture
  architecture change of plasmoid-folderview-4.10.97-1.2.x86_64 to
plasmoid-folderview-14.12.3-1.1.i586
  install plasmoid-folderview-14.12.3-1.1.i586 despite the inferior
architecture
  architecture change of plasmoid-networkmanagement-0.9.0.9-1.2.x86_64 to
plasmoid-networkmanagement-0.9.0.10-2.8.1.i586
  architecture change of plasmoid-quickaccess-0.8.1-22.4.x86_64 to
plasmoid-quickaccess-0.8.1-23.1.1.i586
  install plasmoid-quickaccess-0.8.1-23.1.1.i586 despite the inferior
architecture
  architecture change of polkit-kde-agent-1-0.99.0-18.2.x86_64 to
polkit-kde-agent-1-0.99.0-22.1.i586
  install polkit-kde-agent-1-0.99.0-22.1.i586 despite the inferior
architecture
  architecture change of sweeper-4.10.97-1.2.x86_64 to
sweeper-14.12.3-1.1.i586
  install sweeper-14.12.3-1.1.i586 despite the inferior architecture
  architecture change of nepomuk-core-4.11.5-137.3.x86_64 to
nepomuk-core-4.14.3-1.3.i586
  architecture change of okular-4.11.5-150.1.x86_64 to
okular-14.12.3-1.1.i586
  install okular-14.12.3-1.1.i586 despite the inferior architecture
  install libdjvulibre21-3.5.27-1.1.i586 despite the inferior architecture
  install libspectre1-0.2.7-8.3.i586 despite the inferior architecture
  architecture change of konsole-4.10.97-1.2.x86_64 to
konsole-4.11.5-446.1.i586
  install konsole-4.11.5-446.1.i586 despite the inferior architecture
  deinstallation of yast2-mail-3.0.0-1.2.noarch
  deinstallation of yast2-sudo-3.0.0-1.2.noarch
  architecture change of libkolab0-0.4.2-3.1.x86_64 to
libkolab0-0.5.3-3.2.i586
  architecture change of libqalculate5-0.9.7-14.4.x86_64 to
libqalculate5-0.9.7-18.2.i586
  architecture change of libclucene-contribs-lib1-2.3.3.4-10.3.x86_64 to
libclucene-contribs-lib1-2.3.3.4-14.2.i586
  architecture change of libdjvulibre21-3.5.25.3-2.1.3.x86_64 to
libdjvulibre21-3.5.27-1.1.i586
  architecture change of libgrantlee_core0-0.3.0-3.4.x86_64 to
libgrantlee_core0-0.4.0-3.2.i586
  architecture change of libgrantlee_gui0-0.3.0-3.4.x86_64 to
libgrantlee_gui0-0.4.0-3.2.i586
  architecture change of libhyphen0-2.8.6-3.3.x86_64 to
libhyphen0-2.8.8-1.1.i586
  architecture change of libkscreen1-1.0.1-1.2.x86_64 to
libkscreen1-1.0.5-1.2.i586
  architecture change of liblangtag1-0.5.1-1.3.x86_64 to
liblangtag1-0.5.4-3.2.i586
  architecture change of liblastfm1-1.0.7-1.4.x86_64 to
liblastfm1-1.0.8-3.2.i586
  architecture change of liblensfun0-0.2.7-2.4.x86_64 to
liblensfun0-0.2.7-3.1.2.i586
  architecture change of libloudmouth-1-0-1.4.3-20.14.x86_64 to
libloudmouth-1-0-1.4.3-24.1.i586
  architecture change of libmtp9-1.1.6-1.3.x86_64 to
libmtp9-1.1.8-1.1.i586
  architecture change of libmygpo-qt1-1.0.7-1.4.x86_64 to
libmygpo-qt1-1.0.7-5.2.i586
  architecture change of libmysqld18-5.5.33-2.2.x86_64 to
libmysqld18-5.5.33-3.84.i586
  install libmysqld18-5.5.33-3.84.i586 (with vendor change)
    openSUSE  -->  obs://build.opensuse.org/home:doiggl
  architecture change of libopencv2_4-2.4.6.1-2.2.x86_64 to
libopencv2_4-2.4.9-4.1.i586
  architecture change of libpgf6-6.12.24-4.3.x86_64 to
libpgf6-6.14.12-3.2.i586
  architecture change of libqoauth1-1.0.1-17.3.x86_64 to
libqoauth1-1.0.1-22.2.i586
  architecture change of libspectre1-0.2.7-4.1.2.x86_64 to
libspectre1-0.2.7-8.3.i586
  architecture change of libtag-extras1-1.0.1-18.3.x86_64 to
libtag-extras1-1.0.1-22.2.i586
  architecture change of libvncclient0-0.9.9-6.6.x86_64 to
libvncclient0-0.9.10-2.1.i586
 Solution 3: Following actions will be done:
  deinstallation of libyui-qt-pkg5-2.42.11-1.2.x86_64
  deinstallation of libyui-ncurses-pkg5-2.44.4-1.2.x86_64
 Solution 4: do not install bugzilla-4.4.8-35.1.noarch
 Solution 5: do not install bugzilla-4.4.8-35.1.noarch
 Solution 6: break bugzilla-4.4.8-35.1.noarch by ignoring some of its
dependencies

Choose from above solutions by number or cancel [1/2/3/4/5/6/c] (c): c
#
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

Jason Craig-3
On 03/31/2015 08:06 AM, [hidden email] wrote:
What version of OpenSUSE is installed? You are adding repos and packages
built for the "Factory" version (basically test version), while I
suspect that you do not have "Factory" installed on your computer.

--
Jason Craig
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

David Haller-4
In reply to this post by gregfreemyer
Hello,

On Mon, 30 Mar 2015, Greg Freemyer wrote:
[..]

>perl-Emai-MIME is easily found via:  http://software.opensuse.org/search
>
>http://software.opensuse.org/search?utf8=%E2%9C%93&q=perl-Email-MIME&search_devel=false&search_unsupported=false&baseproject=openSUSE%3A13.2
>
>If follow the links you find it is devel:languages:perl and is new
>enough to meet the dependency.  Glenn, you just need to branch a copy
>of the D:L:P version to your relevant home project / sub-project.
>
> perl-Email-MIME-Modifier is not found, so I'm assuming it is not
>packaged.  So you will need to package that in OBS as a first step.

It is PART of perl-Email-MIME. Generally: DO NOT USE
Requires/BuildRequires like perl-ANYTHING, but always use
perl(ANYTHING) unless you absolutely need to and know what you're
doing.

-dnh

--
"I can't go on meeting you like this"               -- a TeX message
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

David Haller-4
In reply to this post by doiggl
Hello,

On Mon, 30 Mar 2015, [hidden email] wrote:
>What needs to be changed in specfiles [1] to allow 64 bit modules to be
>used instead of 32 bit ones [using opensuse x86_64 system to install on] ?
>usimg opensuse 13.x

Nothing. You need to fix your requires and add some required
perl-Modules. I've everything here:

https://build.opensuse.org/project/show/home:dnh:doiggl:bugzilla

BTW: the 13.1 RPM of bugzilla comes up with this:

Requires
Symbol                    Provided by
perl(Date::Format) >= 2.21 perl-TimeDate
perl(File::Spec) >= 0.84 perl-base-32bit perl-base
perl(Email::Send) >= 2.00 perl-Email-Send
perl(Template)            perl-Template-Toolkit
perl(CGI) >= 2.93        perl
apache                    apache2
perl-base >= 5.8.1        perl-base
perl(CGI) >= 5.8.1        perl
perl(DBI) >= 1.41        perl-DBI
perl(Email::MIME) >= 1.816 perl-Email-MIME
perl(Email::MIME::Modifier)... perl-Email-MIME
perl(Template::Toolkit) >= ... perl-Template-Toolkit

HTH,
-dnh

--
Man kann einer Katze nichts beibringen, die haben ihren eigenen
Willen. Es ist offensichtlich, daß die Katze an Rechner interessiert
ist. Richte ihr einen eigenen Account ein.             -- Rene Riech
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

doiggl
In reply to this post by Jason Craig-3

>> Rpms built:
>> ##########
>>
http://mirrors1.kernel.org/opensuse/factory/repo/oss/suse/x86_64/perl-5.20.1-3.1.x86_64.rpm
>>
http://download.opensuse.org/repositories/home:/doiggl/openSUSE_Factory/noarch/bugzilla-4.4.8-35.1.noarch.rpm
>>
http://download.opensuse.org/repositories/home:/doiggl/openSUSE_Factory/noarch/perl-Email-MIME-1.926-2.1.noarch.rpm
>>
>> Add repos:
>> #########
>> zypper ar -f -c  http://mirrors1.kernel.org/opensuse/factory/repo/oss/
>>                   FactoryLatestOss
>
> What version of OpenSUSE is installed? You are adding repos and packages

> built for the "Factory" version (basically test version), while I
> suspect that you do not have "Factory" installed on your computer.
>
> --
> Jason Craig
What version of OpenSUSE is installed?
13.1x
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

doiggl
# I did the following.
Install worked.
Thanks
--Glenn


# zypper ar -f -c
http://download.opensuse.org/repositories/home:/dnh:/doiggl:/bugzilla/openSUSE_13.1/
dnhRepo
Adding repository 'dnhRepo'
............................................................................................................................................................................................[done]
Repository 'dnhRepo' successfully added
Enabled: Yes
Autorefresh: Yes
GPG check: Yes
URI:
http://download.opensuse.org/repositories/home:/dnh:/doiggl:/bugzilla/openSUSE_13.1/

# zypper ref
Repository 'FactoryLatestOss' is up to date.
Retrieving repository 'dnhRepo' metadata
...............................................................................................................................................................................[done]
Building repository 'dnhRepo' cache
....................................................................................................................................................................................[done]
Repository 'repo-non-oss' is up to date.
Repository 'repo-oss' is up to date.
Retrieving repository 'repo-update' metadata
...........................................................................................................................................................................[done]
Building repository 'repo-update' cache
................................................................................................................................................................................[done]
Repository 'repo-update-13.1-non-oss' is up to date.
Repository 'server:monitoring' is up to date.
All repositories have been refreshed.

# zypper  in bugzilla
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW packages are going to be installed:
  bugzilla perl-Email-Address perl-Email-MIME perl-Email-MIME-ContentType
perl-Email-MIME-Encodings perl-Email-MessageID perl-Email-Send
perl-Return-Value

8 new packages to install.
Overall download size: 181.4 KiB. After the operation, additional 369.7
KiB will be used.
Continue? [y/n/?] (y): n

# zypper  in bugzilla
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW packages are going to be installed:
  bugzilla perl-Email-Address perl-Email-MIME perl-Email-MIME-ContentType
perl-Email-MIME-Encodings perl-Email-MessageID perl-Email-Send
perl-Return-Value

8 new packages to install.
Overall download size: 181.4 KiB. After the operation, additional 369.7
KiB will be used.
Continue? [y/n/?] (y): n

##
# zypper info  bugzilla
Loading repository data...
Reading installed packages...


Information for package bugzilla:
---------------------------------
Repository: dnhRepo
Name: bugzilla
Version: 4.4.8-37.1
Arch: noarch
Vendor: obs://build.opensuse.org/home:dnh
Installed: No
Status: not installed
Installed Size: 0 B
Summary: Bugzilla server side software
Description:
Bugzilla is server software (a bug tracking tool) designed to help you
manage software development. It requires a database engine installed (in
this host or another one) - either MySQL, PostgreSQL or Oracle.




/home/smart-info/channels # zypper in bugzilla
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW packages are going to be installed:
  bugzilla perl-Email-Address perl-Email-MIME perl-Email-MIME-ContentType
perl-Email-MIME-Encodings perl-Email-MessageID perl-Email-Send
perl-Return-Value

8 new packages to install.
Overall download size: 181.4 KiB. After the operation, additional 369.7
KiB will be used.
Continue? [y/n/?] (y): y
Retrieving package perl-Email-MIME-ContentType-1.017-4.1.noarch          
                                                                         
                                 (1/8),  15.2 KiB ( 26.3 KiB unpacked)
Retrieving: perl-Email-MIME-ContentType-1.017-4.1.noarch.rpm
...............................................................................................................................................[done
(1.2 KiB/s)]
Retrieving package perl-Email-MIME-Encodings-1.315-4.1.noarch            
                                                                         
                                 (2/8),  14.5 KiB ( 24.7 KiB unpacked)
Retrieving: perl-Email-MIME-Encodings-1.315-4.1.noarch.rpm
.............................................................................................................................................................[done]
Retrieving package perl-Return-Value-1.302-9.1.x86_64                    
                                                                         
                                 (3/8),  19.6 KiB ( 36.9 KiB unpacked)
Retrieving: perl-Return-Value-1.302-9.1.x86_64.rpm
.........................................................................................................................................................[done
(3.0 KiB/s)]
Retrieving package perl-Email-Address-1.899-2.4.1.noarch                  
                                                                         
                                 (4/8),  33.8 KiB (109.1 KiB unpacked)
Retrieving: perl-Email-Address-1.899-2.4.1.noarch.rpm
..................................................................................................................................................................[done]
Retrieving package perl-Email-MessageID-1.402-11.1.2.noarch              
                                                                         
                                 (5/8),  15.7 KiB ( 28.1 KiB unpacked)
Retrieving: perl-Email-MessageID-1.402-11.1.2.noarch.rpm
...............................................................................................................................................................[done]
Retrieving package perl-Email-Send-2.198-9.1.x86_64                      
                                                                         
                                 (6/8),  39.5 KiB ( 74.0 KiB unpacked)
Retrieving: perl-Email-Send-2.198-9.1.x86_64.rpm
..........................................................................................................................................................[done
(36.2 KiB/s)]
Retrieving package perl-Email-MIME-1.925-2.1.noarch                      
                                                                         
                                 (7/8),  38.1 KiB ( 70.6 KiB unpacked)
Retrieving: perl-Email-MIME-1.925-2.1.noarch.rpm
..........................................................................................................................................................[done
(18.5 KiB/s)]
Retrieving package bugzilla-4.4.8-37.1.noarch                            
                                                                         
                                   (8/8),   5.1 KiB (    0 B unpacked)
Retrieving: bugzilla-4.4.8-37.1.noarch.rpm
.............................................................................................................................................................................[done]
(1/8) Installing: perl-Email-MIME-ContentType-1.017-4.1
................................................................................................................................................................[done]
(2/8) Installing: perl-Email-MIME-Encodings-1.315-4.1
..................................................................................................................................................................[done]
(3/8) Installing: perl-Return-Value-1.302-9.1
..........................................................................................................................................................................[done]
(4/8) Installing: perl-Email-Address-1.899-2.4.1
.......................................................................................................................................................................[done]
(5/8) Installing: perl-Email-MessageID-1.402-11.1.2
....................................................................................................................................................................[done]
(6/8) Installing: perl-Email-Send-2.198-9.1
............................................................................................................................................................................[done]
(7/8) Installing: perl-Email-MIME-1.925-2.1
............................................................................................................................................................................[done]
(8/8) Installing: bugzilla-4.4.8-37.1
..................................................................................................................................................................................[done]


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: What needs to be changed in specfiles to allow 64 bit modules to be used instead of 32 bit ones [using opensuse x86_64 system to install on] ?

David Haller-4
Hello,

On Wed, 01 Apr 2015, [hidden email] wrote:
># I did the following.
>Install worked.
>Thanks

Told you so.

># zypper ar -f -c
>http://download.opensuse.org/repositories/home:/dnh:/doiggl:/bugzilla/openSUSE_13.1/
>dnhRepo
>Adding repository 'dnhRepo'
[..]
># zypper ref
># zypper in bugzilla

I won't keep that repo though! Much less maintain it. I give you
2 weeks before I delete it[1].

Read the whole thread again, read the error messages, "grok" what I
did and why. Reproduce in your project. Feel free to ask how to handle
"breakages" like this with perl-Email-Send
https://build.opensuse.org/package/show/home:dnh:doiggl:bugzilla/perl-Email-Send

Yes, I think I know why there's the "unresolvable" (educated guess,
comes with the experience), but try yourself first!

[@others: don't tell him!]

Anyway, as I wrote before: I think you need some more basics first,
some more RPM basics, some OBS, some build stuff like gcc/make etc.
before you tackle more complex packages. First of all: learn to read
error messages better. Weeding out the relevant ones from the warnings
is not always easy, we all know that. And it can be _VERY_ tedious if
you don't have the experience yet, to scan better for the relevant
stuff.

You're making progress, but I think you should concentrate on small,
easy packages. Actually, bugzilla with the load of a few small perl
packages should be a nice challenge with the headstart we gave you.
Now, just try to maintain that for a bit, understand why and what and
how my stuff worked, and how the "unresolved" problem with
perl-Email-Send can be "fixed". Please DON'T tackle more packages for
the time being.

Let's first get you on a more solid footing, eh?

-dnh

[1] if you need to travel or get sick, pipe up

--
"It matters little how we die, so long as we die better men than we imagined
we could be -- and no worse than we feared."
     -- "Drago Museveni, CY 8451"; Andromeda - 3x10 -- The Unconquerable Man
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]