Version-agnostic Qt python dependencies

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Version-agnostic Qt python dependencies

todd rme
Due to the high degree of API compatibility, a lot of python and
python3 packages that use Qt don't care which particular Qt package
they get.  They work equally well with pyqt4, pyqt5, and pyside.

I think that for these packages it would be worthwhile having a
generic dependency that could work with any of these packages.
Perhaps something like "Provides:  python-qt-any" (and a corresponding
python 3 package).

What does anyone else think?
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]