VMWare Player installation problems - "Unable to install vmnet"

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

VMWare Player installation problems - "Unable to install vmnet"

AV-15
Hi,

trying to install vmware player
VMware-Player-4.0.2-591240.x86_64.bundle in Opensuse 12.1 Tumbleweed
with kernel-desktop 3.2.7-9.1.x86_64. Get error "Unable to install
vmnet". Full output is:

# vmware-modconfig --console --install-all

Stopping VMware services:
   VMware Authentication Daemon                                        done
   VM communication interface socket family                            done
   Virtual machine communication interface                             done
   Virtual machine monitor                                             done
   Blocking file system                                                done
Using 2.6.x kernel build system.
make: Įeinama į aplanką "/tmp/vmware-root/modules/vmmon-only"
make -C /lib/modules/3.2.7-9-desktop/build/include/.. SUBDIRS=$PWD
SRCROOT=$PWD/. \
  MODULEBUILDDIR= modules
make[1]: Įeinama į aplanką "/usr/src/linux-3.2.7-9-obj/x86_64/desktop"
  CC [M]  /tmp/vmware-root/modules/vmmon-only/linux/driverLog.o
  CC [M]  /tmp/vmware-root/modules/vmmon-only/linux/driver.o
  CC [M]  /tmp/vmware-root/modules/vmmon-only/linux/hostif.o
  CC [M]  /tmp/vmware-root/modules/vmmon-only/common/memtrack.o
  CC [M]  /tmp/vmware-root/modules/vmmon-only/common/apic.o
  CC [M]  /tmp/vmware-root/modules/vmmon-only/common/vmx86.o
  CC [M]  /tmp/vmware-root/modules/vmmon-only/common/cpuid.o
  CC [M]  /tmp/vmware-root/modules/vmmon-only/common/task.o
  CC [M]  /tmp/vmware-root/modules/vmmon-only/common/hashFunc.o
  CC [M]  /tmp/vmware-root/modules/vmmon-only/common/comport.o
  CC [M]  /tmp/vmware-root/modules/vmmon-only/common/phystrack.o
  CC [M]  /tmp/vmware-root/modules/vmmon-only/vmcore/moduleloop.o
  LD [M]  /tmp/vmware-root/modules/vmmon-only/vmmon.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /tmp/vmware-root/modules/vmmon-only/vmmon.mod.o
  LD [M]  /tmp/vmware-root/modules/vmmon-only/vmmon.ko
make[1]: Išeinama iš aplanko "/usr/src/linux-3.2.7-9-obj/x86_64/desktop"
make -C $PWD SRCROOT=$PWD/. \
  MODULEBUILDDIR= postbuild
make[1]: Įeinama į aplanką "/tmp/vmware-root/modules/vmmon-only"
make[1]: "postbuild" atnaujinti nereikia.
make[1]: Išeinama iš aplanko "/tmp/vmware-root/modules/vmmon-only"
cp -f vmmon.ko ./../vmmon.o
make: Išeinama iš aplanko "/tmp/vmware-root/modules/vmmon-only"
Built vmmon module
Using 2.6.x kernel build system.
make: Įeinama į aplanką "/tmp/vmware-root/modules/vmnet-only"
make -C /lib/modules/3.2.7-9-desktop/build/include/.. SUBDIRS=$PWD
SRCROOT=$PWD/. \
  MODULEBUILDDIR= modules
make[1]: Įeinama į aplanką "/usr/src/linux-3.2.7-9-obj/x86_64/desktop"
  CC [M]  /tmp/vmware-root/modules/vmnet-only/driver.o
  CC [M]  /tmp/vmware-root/modules/vmnet-only/hub.o
  CC [M]  /tmp/vmware-root/modules/vmnet-only/userif.o
  CC [M]  /tmp/vmware-root/modules/vmnet-only/netif.o
  CC [M]  /tmp/vmware-root/modules/vmnet-only/bridge.o
  CC [M]  /tmp/vmware-root/modules/vmnet-only/filter.o
  CC [M]  /tmp/vmware-root/modules/vmnet-only/procfs.o
  CC [M]  /tmp/vmware-root/modules/vmnet-only/smac_compat.o
  CC [M]  /tmp/vmware-root/modules/vmnet-only/smac.o
  CC [M]  /tmp/vmware-root/modules/vmnet-only/vnetEvent.o
  CC [M]  /tmp/vmware-root/modules/vmnet-only/vnetUserListener.o
/tmp/vmware-root/modules/vmnet-only/filter.c:60:16: error:
'THIS_MODULE' undeclared here (not in a function)
/tmp/vmware-root/modules/vmnet-only/netif.c: In function 'VNetNetIfSetup':
/tmp/vmware-root/modules/vmnet-only/netif.c:134:7: error: unknown
field 'ndo_set_multicast_list' specified in initializer
/tmp/vmware-root/modules/vmnet-only/netif.c:134:7: warning:
initialization from incompatible pointer type [enabled by default]
/tmp/vmware-root/modules/vmnet-only/netif.c:134:7: warning: (near
initialization for 'vnetNetifOps.ndo_validate_addr') [enabled by
default]
make[4]: *** [/tmp/vmware-root/modules/vmnet-only/filter.o] Error 1
make[4]: *** Waiting for unfinished jobs....
make[4]: *** [/tmp/vmware-root/modules/vmnet-only/netif.o] Error 1
/tmp/vmware-root/modules/vmnet-only/userif.c: In function
'VNetCsumCopyDatagram':
/tmp/vmware-root/modules/vmnet-only/userif.c:520:3: error:
incompatible type for argument 1 of 'kmap'
/usr/src/linux-3.2.7-9/include/linux/highmem.h:48:21: note: expected
'struct page *' but argument is of type 'const struct <anonymous>'
/tmp/vmware-root/modules/vmnet-only/userif.c:523:3: error:
incompatible type for argument 1 of 'kunmap'
/usr/src/linux-3.2.7-9/include/linux/highmem.h:54:20: note: expected
'struct page *' but argument is of type 'const struct <anonymous>'
make[4]: *** [/tmp/vmware-root/modules/vmnet-only/userif.o] Error 1
make[3]: *** [_module_/tmp/vmware-root/modules/vmnet-only] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Išeinama iš aplanko "/usr/src/linux-3.2.7-9-obj/x86_64/desktop"
make: *** [vmnet.ko] Error 2
make: Išeinama iš aplanko "/tmp/vmware-root/modules/vmnet-only"
Unable to install vmnet


Please help!

BR,

Audrius
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: VMWare Player installation problems - "Unable to install vmnet"

Per Jessen-2
AV wrote:

> Hi,
>
> trying to install vmware player
> VMware-Player-4.0.2-591240.x86_64.bundle in Opensuse 12.1 Tumbleweed
> with kernel-desktop 3.2.7-9.1.x86_64. Get error "Unable to install
> vmnet". Full output is:
>
>   CC [M]  /tmp/vmware-root/modules/vmnet-only/vnetUserListener.o
> /tmp/vmware-root/modules/vmnet-only/filter.c:60:16: error:
> 'THIS_MODULE' undeclared here (not in a function)

I think the above is the problem - I ran into something similar with
iscsitarget just recently.  I had to amend each source module
with "include <linux/module.h>".  As far as I can tell, something in
module management/building was changed in kernel 3.2.0.



--
Per Jessen, Zürich (5.2°C)

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: VMWare Player installation problems - "Unable to install vmnet"

AV-15
Thank you for answer. But I am not advanced user myself... How can I
fix this problem... could you provide some solution or suggestions but
in simple terms :).

BR,

Audrius

On Mon, Feb 27, 2012 at 1:25 PM, Per Jessen <[hidden email]> wrote:

> AV wrote:
>
>> Hi,
>>
>> trying to install vmware player
>> VMware-Player-4.0.2-591240.x86_64.bundle in Opensuse 12.1 Tumbleweed
>> with kernel-desktop 3.2.7-9.1.x86_64. Get error "Unable to install
>> vmnet". Full output is:
>>
>>   CC [M]  /tmp/vmware-root/modules/vmnet-only/vnetUserListener.o
>> /tmp/vmware-root/modules/vmnet-only/filter.c:60:16: error:
>> 'THIS_MODULE' undeclared here (not in a function)
>
> I think the above is the problem - I ran into something similar with
> iscsitarget just recently.  I had to amend each source module
> with "include <linux/module.h>".  As far as I can tell, something in
> module management/building was changed in kernel 3.2.0.
>
>
>
> --
> Per Jessen, Zürich (5.2°C)
>
> --
> To unsubscribe, e-mail: [hidden email]
> To contact the owner, e-mail: [hidden email]
>
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: VMWare Player installation problems - "Unable to install vmnet"

Per Jessen-2
AV wrote:

> Thank you for answer. But I am not advanced user myself... How can I
> fix this problem... could you provide some solution or suggestions but
> in simple terms :).
>
> BR,
>
> Audrius

Hi Audrius

You're using Tumbleweed, that's advanced stuff.  :-)
I don't think there is a simple way to fix it.  An alternative might be
to use an older openSUSE, perhaps just plain 12.1 instead of
Tumbleweed.


/Per

--
Per Jessen, Zürich (6.9°C)

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: VMWare Player installation problems - "Unable to install vmnet"

AV-15
On Mon, Feb 27, 2012 at 3:16 PM, Per Jessen <[hidden email]> wrote:

> AV wrote:
>
>> Thank you for answer. But I am not advanced user myself... How can I
>> fix this problem... could you provide some solution or suggestions but
>> in simple terms :).
>>
>> BR,
>>
>> Audrius
>
> Hi Audrius
>
> You're using Tumbleweed, that's advanced stuff.  :-)
> I don't think there is a simple way to fix it.  An alternative might be
> to use an older openSUSE, perhaps just plain 12.1 instead of
> Tumbleweed.
>

That is what I am thinking about :-). And I do not think that vmware
workstation will work in my system... Am I right?

BR,

Audrius
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: VMWare Player installation problems - "Unable to install vmnet"

Per Jessen-2
AV wrote:

> On Mon, Feb 27, 2012 at 3:16 PM, Per Jessen <[hidden email]> wrote:
>> AV wrote:
>>
>>> Thank you for answer. But I am not advanced user myself... How can I
>>> fix this problem... could you provide some solution or suggestions
>>> but in simple terms :).
>>>
>>> BR,
>>>
>>> Audrius
>>
>> Hi Audrius
>>
>> You're using Tumbleweed, that's advanced stuff.  :-)
>> I don't think there is a simple way to fix it.  An alternative might
>> be to use an older openSUSE, perhaps just plain 12.1 instead of
>> Tumbleweed.
>>
>
> That is what I am thinking about :-). And I do not think that vmware
> workstation will work in my system... Am I right?

With your current system+kernel, not without fixing the module sources,
no.



--
Per Jessen, Zürich (7.8°C)

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: VMWare Player installation problems - "Unable to install vmnet"

Markus Koßmann-3
In reply to this post by AV-15
Am Montag, 27. Februar 2012, 12:51:05 schrieb AV:

> Hi,
>
> trying to install vmware player
> VMware-Player-4.0.2-591240.x86_64.bundle in Opensuse 12.1 Tumbleweed
> with kernel-desktop 3.2.7-9.1.x86_64. Get error "Unable to install
> vmnet". Full output is:
>
> # vmware-modconfig --console --install-all
>
> Stopping VMware services:
>    VMware Authentication Daemon                                        done
>    VM communication interface socket family                            done
>    Virtual machine communication interface                             done
>    Virtual machine monitor                                             done
>    Blocking file system                                                done
> Using 2.6.x kernel build system.
> make: Įeinama į aplanką "/tmp/vmware-root/modules/vmmon-only"
> make -C /lib/modules/3.2.7-9-desktop/build/include/.. SUBDIRS=$PWD
> SRCROOT=$PWD/. \
>   MODULEBUILDDIR= modules
> make[1]: Įeinama į aplanką "/usr/src/linux-3.2.7-9-obj/x86_64/desktop"
>   CC [M]  /tmp/vmware-root/modules/vmmon-only/linux/driverLog.o
>   CC [M]  /tmp/vmware-root/modules/vmmon-only/linux/driver.o
>   CC [M]  /tmp/vmware-root/modules/vmmon-only/linux/hostif.o
>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/memtrack.o
>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/apic.o
>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/vmx86.o
>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/cpuid.o
>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/task.o
>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/hashFunc.o
>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/comport.o
>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/phystrack.o
>   CC [M]  /tmp/vmware-root/modules/vmmon-only/vmcore/moduleloop.o
>   LD [M]  /tmp/vmware-root/modules/vmmon-only/vmmon.o
>   Building modules, stage 2.
>   MODPOST 1 modules
>   CC      /tmp/vmware-root/modules/vmmon-only/vmmon.mod.o
>   LD [M]  /tmp/vmware-root/modules/vmmon-only/vmmon.ko
> make[1]: Išeinama iš aplanko "/usr/src/linux-3.2.7-9-obj/x86_64/desktop"
> make -C $PWD SRCROOT=$PWD/. \
>   MODULEBUILDDIR= postbuild
> make[1]: Įeinama į aplanką "/tmp/vmware-root/modules/vmmon-only"
> make[1]: "postbuild" atnaujinti nereikia.
> make[1]: Išeinama iš aplanko "/tmp/vmware-root/modules/vmmon-only"
> cp -f vmmon.ko ./../vmmon.o
> make: Išeinama iš aplanko "/tmp/vmware-root/modules/vmmon-only"
> Built vmmon module
> Using 2.6.x kernel build system.
> make: Įeinama į aplanką "/tmp/vmware-root/modules/vmnet-only"
> make -C /lib/modules/3.2.7-9-desktop/build/include/.. SUBDIRS=$PWD
> SRCROOT=$PWD/. \
>   MODULEBUILDDIR= modules
> make[1]: Įeinama į aplanką "/usr/src/linux-3.2.7-9-obj/x86_64/desktop"
>   CC [M]  /tmp/vmware-root/modules/vmnet-only/driver.o
>   CC [M]  /tmp/vmware-root/modules/vmnet-only/hub.o
>   CC [M]  /tmp/vmware-root/modules/vmnet-only/userif.o
>   CC [M]  /tmp/vmware-root/modules/vmnet-only/netif.o
>   CC [M]  /tmp/vmware-root/modules/vmnet-only/bridge.o
>   CC [M]  /tmp/vmware-root/modules/vmnet-only/filter.o
>   CC [M]  /tmp/vmware-root/modules/vmnet-only/procfs.o
>   CC [M]  /tmp/vmware-root/modules/vmnet-only/smac_compat.o
>   CC [M]  /tmp/vmware-root/modules/vmnet-only/smac.o
>   CC [M]  /tmp/vmware-root/modules/vmnet-only/vnetEvent.o
>   CC [M]  /tmp/vmware-root/modules/vmnet-only/vnetUserListener.o
> /tmp/vmware-root/modules/vmnet-only/filter.c:60:16: error:
> 'THIS_MODULE' undeclared here (not in a function)
> /tmp/vmware-root/modules/vmnet-only/netif.c: In function 'VNetNetIfSetup':
> /tmp/vmware-root/modules/vmnet-only/netif.c:134:7: error: unknown
> field 'ndo_set_multicast_list' specified in initializer
> /tmp/vmware-root/modules/vmnet-only/netif.c:134:7: warning:
> initialization from incompatible pointer type [enabled by default]
> /tmp/vmware-root/modules/vmnet-only/netif.c:134:7: warning: (near
> initialization for 'vnetNetifOps.ndo_validate_addr') [enabled by
> default]
> make[4]: *** [/tmp/vmware-root/modules/vmnet-only/filter.o] Error 1
> make[4]: *** Waiting for unfinished jobs....
> make[4]: *** [/tmp/vmware-root/modules/vmnet-only/netif.o] Error 1
> /tmp/vmware-root/modules/vmnet-only/userif.c: In function
> 'VNetCsumCopyDatagram':
> /tmp/vmware-root/modules/vmnet-only/userif.c:520:3: error:
> incompatible type for argument 1 of 'kmap'
> /usr/src/linux-3.2.7-9/include/linux/highmem.h:48:21: note: expected
> 'struct page *' but argument is of type 'const struct <anonymous>'
> /tmp/vmware-root/modules/vmnet-only/userif.c:523:3: error:
> incompatible type for argument 1 of 'kunmap'
> /usr/src/linux-3.2.7-9/include/linux/highmem.h:54:20: note: expected
> 'struct page *' but argument is of type 'const struct <anonymous>'
> make[4]: *** [/tmp/vmware-root/modules/vmnet-only/userif.o] Error 1
> make[3]: *** [_module_/tmp/vmware-root/modules/vmnet-only] Error 2
> make[2]: *** [sub-make] Error 2
> make[1]: *** [all] Error 2
> make[1]: Išeinama iš aplanko "/usr/src/linux-3.2.7-9-obj/x86_64/desktop"
> make: *** [vmnet.ko] Error 2
> make: Išeinama iš aplanko "/tmp/vmware-root/modules/vmnet-only"
> Unable to install vmnet
>
> Did you try the patches for vmware available at
<http://weltall.heliohost.org/wordpress/2012/01/26/vmware-workstation-8-0-2-
player-4-0-2-fix-for-linux-kernel-3-2-and-3-3/> ?

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: VMWare Player installation problems - "Unable to install vmnet"

AV-15
Thank you!!! I found only previous patch and that did not work... All
compiled without error now. Just have to download images and try to
use player. Hope that it will work nicely on SUSE. Thank you again!

BR,

Audrius

On Mon, Feb 27, 2012 at 7:02 PM, Markus Koßmann <[hidden email]> wrote:

> Am Montag, 27. Februar 2012, 12:51:05 schrieb AV:
>> Hi,
>>
>> trying to install vmware player
>> VMware-Player-4.0.2-591240.x86_64.bundle in Opensuse 12.1 Tumbleweed
>> with kernel-desktop 3.2.7-9.1.x86_64. Get error "Unable to install
>> vmnet". Full output is:
>>
>> # vmware-modconfig --console --install-all
>>
>> Stopping VMware services:
>>    VMware Authentication Daemon                                        done
>>    VM communication interface socket family                            done
>>    Virtual machine communication interface                             done
>>    Virtual machine monitor                                             done
>>    Blocking file system                                                done
>> Using 2.6.x kernel build system.
>> make: Įeinama į aplanką "/tmp/vmware-root/modules/vmmon-only"
>> make -C /lib/modules/3.2.7-9-desktop/build/include/.. SUBDIRS=$PWD
>> SRCROOT=$PWD/. \
>>   MODULEBUILDDIR= modules
>> make[1]: Įeinama į aplanką "/usr/src/linux-3.2.7-9-obj/x86_64/desktop"
>>   CC [M]  /tmp/vmware-root/modules/vmmon-only/linux/driverLog.o
>>   CC [M]  /tmp/vmware-root/modules/vmmon-only/linux/driver.o
>>   CC [M]  /tmp/vmware-root/modules/vmmon-only/linux/hostif.o
>>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/memtrack.o
>>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/apic.o
>>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/vmx86.o
>>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/cpuid.o
>>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/task.o
>>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/hashFunc.o
>>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/comport.o
>>   CC [M]  /tmp/vmware-root/modules/vmmon-only/common/phystrack.o
>>   CC [M]  /tmp/vmware-root/modules/vmmon-only/vmcore/moduleloop.o
>>   LD [M]  /tmp/vmware-root/modules/vmmon-only/vmmon.o
>>   Building modules, stage 2.
>>   MODPOST 1 modules
>>   CC      /tmp/vmware-root/modules/vmmon-only/vmmon.mod.o
>>   LD [M]  /tmp/vmware-root/modules/vmmon-only/vmmon.ko
>> make[1]: Išeinama iš aplanko "/usr/src/linux-3.2.7-9-obj/x86_64/desktop"
>> make -C $PWD SRCROOT=$PWD/. \
>>   MODULEBUILDDIR= postbuild
>> make[1]: Įeinama į aplanką "/tmp/vmware-root/modules/vmmon-only"
>> make[1]: "postbuild" atnaujinti nereikia.
>> make[1]: Išeinama iš aplanko "/tmp/vmware-root/modules/vmmon-only"
>> cp -f vmmon.ko ./../vmmon.o
>> make: Išeinama iš aplanko "/tmp/vmware-root/modules/vmmon-only"
>> Built vmmon module
>> Using 2.6.x kernel build system.
>> make: Įeinama į aplanką "/tmp/vmware-root/modules/vmnet-only"
>> make -C /lib/modules/3.2.7-9-desktop/build/include/.. SUBDIRS=$PWD
>> SRCROOT=$PWD/. \
>>   MODULEBUILDDIR= modules
>> make[1]: Įeinama į aplanką "/usr/src/linux-3.2.7-9-obj/x86_64/desktop"
>>   CC [M]  /tmp/vmware-root/modules/vmnet-only/driver.o
>>   CC [M]  /tmp/vmware-root/modules/vmnet-only/hub.o
>>   CC [M]  /tmp/vmware-root/modules/vmnet-only/userif.o
>>   CC [M]  /tmp/vmware-root/modules/vmnet-only/netif.o
>>   CC [M]  /tmp/vmware-root/modules/vmnet-only/bridge.o
>>   CC [M]  /tmp/vmware-root/modules/vmnet-only/filter.o
>>   CC [M]  /tmp/vmware-root/modules/vmnet-only/procfs.o
>>   CC [M]  /tmp/vmware-root/modules/vmnet-only/smac_compat.o
>>   CC [M]  /tmp/vmware-root/modules/vmnet-only/smac.o
>>   CC [M]  /tmp/vmware-root/modules/vmnet-only/vnetEvent.o
>>   CC [M]  /tmp/vmware-root/modules/vmnet-only/vnetUserListener.o
>> /tmp/vmware-root/modules/vmnet-only/filter.c:60:16: error:
>> 'THIS_MODULE' undeclared here (not in a function)
>> /tmp/vmware-root/modules/vmnet-only/netif.c: In function 'VNetNetIfSetup':
>> /tmp/vmware-root/modules/vmnet-only/netif.c:134:7: error: unknown
>> field 'ndo_set_multicast_list' specified in initializer
>> /tmp/vmware-root/modules/vmnet-only/netif.c:134:7: warning:
>> initialization from incompatible pointer type [enabled by default]
>> /tmp/vmware-root/modules/vmnet-only/netif.c:134:7: warning: (near
>> initialization for 'vnetNetifOps.ndo_validate_addr') [enabled by
>> default]
>> make[4]: *** [/tmp/vmware-root/modules/vmnet-only/filter.o] Error 1
>> make[4]: *** Waiting for unfinished jobs....
>> make[4]: *** [/tmp/vmware-root/modules/vmnet-only/netif.o] Error 1
>> /tmp/vmware-root/modules/vmnet-only/userif.c: In function
>> 'VNetCsumCopyDatagram':
>> /tmp/vmware-root/modules/vmnet-only/userif.c:520:3: error:
>> incompatible type for argument 1 of 'kmap'
>> /usr/src/linux-3.2.7-9/include/linux/highmem.h:48:21: note: expected
>> 'struct page *' but argument is of type 'const struct <anonymous>'
>> /tmp/vmware-root/modules/vmnet-only/userif.c:523:3: error:
>> incompatible type for argument 1 of 'kunmap'
>> /usr/src/linux-3.2.7-9/include/linux/highmem.h:54:20: note: expected
>> 'struct page *' but argument is of type 'const struct <anonymous>'
>> make[4]: *** [/tmp/vmware-root/modules/vmnet-only/userif.o] Error 1
>> make[3]: *** [_module_/tmp/vmware-root/modules/vmnet-only] Error 2
>> make[2]: *** [sub-make] Error 2
>> make[1]: *** [all] Error 2
>> make[1]: Išeinama iš aplanko "/usr/src/linux-3.2.7-9-obj/x86_64/desktop"
>> make: *** [vmnet.ko] Error 2
>> make: Išeinama iš aplanko "/tmp/vmware-root/modules/vmnet-only"
>> Unable to install vmnet
>>
>> Did you try the patches for vmware available at
> <http://weltall.heliohost.org/wordpress/2012/01/26/vmware-workstation-8-0-2-
> player-4-0-2-fix-for-linux-kernel-3-2-and-3-3/> ?
>
> --
> To unsubscribe, e-mail: [hidden email]
> To contact the owner, e-mail: [hidden email]
>
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]