Upgrading to 42.3 experience - packman

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrading to 42.3 experience - packman

Carlos E. R.-2
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


Hi,

I'm right now in the process of upgrading one of my machines from 42.2 to
42.3 (DVD offline method). Ahead of the procedure I edited the repos URL
to point to the 42.3 version, and did a "zypper ref" to verify that the
URL were correct.

However, when actually running the upgrade, YaST is complaining that it
can not find the files:

(hand copied)

http://packman.inode.at/suse/openSUSE_Leap_42.3
file
./Essentials/x86_64/libavfilter....rpm


I have to hit "Skip", maybe hundreds of times. There is no chance to edit
the url, see what is happening and solve it.

- --
Cheers

  Carlos E. R.
  (from 42.2 x86_64 "Malachite" at Telcontar)


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAlpp5nYACgkQtTMYHG2NR9W3IQCeIpBsn1o+XCbYESJtSX7Au6LU
FKsAnj5/cZFqPAVyqBR2tKym8lURAU+S
=tdIu
-----END PGP SIGNATURE-----

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to 42.3 experience - packman

Dave Plater lst


On 25/01/2018 16:15, Carlos E. R. wrote:

> Hi,
>
> I'm right now in the process of upgrading one of my machines from 42.2
> to 42.3 (DVD offline method). Ahead of the procedure I edited the repos
> URL to point to the 42.3 version, and did a "zypper ref" to verify that
> the URL were correct.
>
> However, when actually running the upgrade, YaST is complaining that it
> can not find the files:
>
> (hand copied)
>
> http://packman.inode.at/suse/openSUSE_Leap_42.3
> file
> ./Essentials/x86_64/libavfilter....rpm
>
>
> I have to hit "Skip", maybe hundreds of times. There is no chance to
> edit the url, see what is happening and solve it.
>
> - -- Cheers
>
>      Carlos E. R.
Try
http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.3/
That works for me and it was given via yast comunity repositories.
Dave P

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to 42.3 experience - packman

Knurpht-openSUSE
In reply to this post by Carlos E. R.-2
Op donderdag 25 januari 2018 15:15:11 CET schreef Carlos E. R.:

> Hi,
>
> I'm right now in the process of upgrading one of my machines from 42.2 to
> 42.3 (DVD offline method). Ahead of the procedure I edited the repos URL
> to point to the 42.3 version, and did a "zypper ref" to verify that the
> URL were correct.
>
> However, when actually running the upgrade, YaST is complaining that it
> can not find the files:
>
> (hand copied)
>
> http://packman.inode.at/suse/openSUSE_Leap_42.3
> file
> ./Essentials/x86_64/libavfilter....rpm
>
>
> I have to hit "Skip", maybe hundreds of times. There is no chance to edit
> the url, see what is happening and solve it.
>
> --
> Cheers
>
>   Carlos E. R.
>   (from 42.2 x86_64 "Malachite" at Telcontar)

Did you also use the
--no-allow-vendor-change option ? That should stop the moving to openSUSE-repo
for the Packman installed packages.

--
Gertjan Lettink, a.k.a. Knurpht

openSUSE Board Member
openSUSE Forums Team



--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to 42.3 experience - packman

Carlos E. R.-2
In reply to this post by Dave Plater lst
On 2018-01-25 15:41, Dave Plater wrote:

>
>
> On 25/01/2018 16:15, Carlos E. R. wrote:
>> Hi,
>>
>> I'm right now in the process of upgrading one of my machines from 42.2
>> to 42.3 (DVD offline method). Ahead of the procedure I edited the
>> repos URL to point to the 42.3 version, and did a "zypper ref" to
>> verify that the URL were correct.
>>
>> However, when actually running the upgrade, YaST is complaining that
>> it can not find the files:
>>
>> (hand copied)
>>
>> http://packman.inode.at/suse/openSUSE_Leap_42.3
>> file
>> ./Essentials/x86_64/libavfilter....rpm
>>
>>
>> I have to hit "Skip", maybe hundreds of times. There is no chance to
>> edit the url, see what is happening and solve it.

> Try
> http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.3/
> That works for me and it was given via yast comunity repositories.

It is impossible to change once the upgrade from *DVD* has started.

Anyway, I just tried with Firefox on another computer and it works.

I switched to a terminal on the upgrading system, which this instant is
running from DVD/USB stick installation media, so the available programs
are minimal: there is no web browser to try, but ping to that server works.

I found the problem!

I located the YaST log. YaST is looking now
"mjpegtools-2.0.0-19.6.x86_64.rpm", whereas the server now has
"mjpegtools-2.0.0-19.7.x86_64.rpm"

The server has updated content while I was running the upgrade :-/

And it is impossible to go back in YaST and tell it to refresh.

--
Cheers / Saludos,

                Carlos E. R.
                (from 42.2 x86_64 "Malachite" at Telcontar)


signature.asc (188 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to 42.3 experience - packman

Carlos E. R.-2
In reply to this post by Knurpht-openSUSE
On 2018-01-25 15:45, Knurpht - Gertjan Lettink wrote:

> Op donderdag 25 januari 2018 15:15:11 CET schreef Carlos E. R.:
>> Hi,
>>
>> I'm right now in the process of upgrading one of my machines from 42.2 to
>> 42.3 (DVD offline method). Ahead of the procedure I edited the repos URL
>> to point to the 42.3 version, and did a "zypper ref" to verify that the
>> URL were correct.
>>
>> However, when actually running the upgrade, YaST is complaining that it
>> can not find the files:
>>
>> (hand copied)
>>
>> http://packman.inode.at/suse/openSUSE_Leap_42.3
>> file
>> ./Essentials/x86_64/libavfilter....rpm
>>
>>
>> I have to hit "Skip", maybe hundreds of times. There is no chance to edit
>> the url, see what is happening and solve it.

> Did you also use the
> --no-allow-vendor-change option ? That should stop the moving to openSUSE-repo
> for the Packman installed packages.

It is YaST, *DVD* upgrade. No zypper, no options. And nothing can be
changed once it starts.

It is trying to upgrade packman from packman, anyway.

[...]

See my other post, I found the reason.

--
Cheers / Saludos,

                Carlos E. R.
                (from 42.2 x86_64 "Malachite" at Telcontar)


signature.asc (188 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to 42.3 experience - packman

Dave Plater lst
In reply to this post by Carlos E. R.-2


On 25/01/2018 17:21, Carlos E. R. wrote:

> On 2018-01-25 15:41, Dave Plater wrote:
>>
>>
>> On 25/01/2018 16:15, Carlos E. R. wrote:
>>> Hi,
>>>
>>> I'm right now in the process of upgrading one of my machines from 42.2
>>> to 42.3 (DVD offline method). Ahead of the procedure I edited the
>>> repos URL to point to the 42.3 version, and did a "zypper ref" to
>>> verify that the URL were correct.
>>>
>>> However, when actually running the upgrade, YaST is complaining that
>>> it can not find the files:
>>>
>>> (hand copied)
>>>
>>> http://packman.inode.at/suse/openSUSE_Leap_42.3
>>> file
>>> ./Essentials/x86_64/libavfilter....rpm
>>>
>>>
>>> I have to hit "Skip", maybe hundreds of times. There is no chance to
>>> edit the url, see what is happening and solve it.
>
>> Try
>> http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.3/
>> That works for me and it was given via yast comunity repositories.
>
> It is impossible to change once the upgrade from *DVD* has started.
>
> Anyway, I just tried with Firefox on another computer and it works.
>
> I switched to a terminal on the upgrading system, which this instant is
> running from DVD/USB stick installation media, so the available programs
> are minimal: there is no web browser to try, but ping to that server works.
>
> I found the problem!
>
> I located the YaST log. YaST is looking now
> "mjpegtools-2.0.0-19.6.x86_64.rpm", whereas the server now has
> "mjpegtools-2.0.0-19.7.x86_64.rpm"
>
> The server has updated content while I was running the upgrade :-/
>
> And it is impossible to go back in YaST and tell it to refresh.
>
I usually update from dvd (flash drive) without any repos enabled. My
update from 42.2 to 42.3 I changed all repos to 42.3 and did a zypper
dup --no-allow-vendor-change and it succeeded without error.
Dave P

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to 42.3 experience - packman

Knurpht-openSUSE
Op donderdag 25 januari 2018 17:02:22 CET schreef Dave Plater:

> On 25/01/2018 17:21, Carlos E. R. wrote:
> > On 2018-01-25 15:41, Dave Plater wrote:
> >> On 25/01/2018 16:15, Carlos E. R. wrote:
> >>> Hi,
> >>>
> >>> I'm right now in the process of upgrading one of my machines from 42.2
> >>> to 42.3 (DVD offline method). Ahead of the procedure I edited the
> >>> repos URL to point to the 42.3 version, and did a "zypper ref" to
> >>> verify that the URL were correct.
> >>>
> >>> However, when actually running the upgrade, YaST is complaining that
> >>> it can not find the files:
> >>>
> >>> (hand copied)
> >>>
> >>> http://packman.inode.at/suse/openSUSE_Leap_42.3
> >>> file
> >>> ./Essentials/x86_64/libavfilter....rpm
> >>>
> >>>
> >>> I have to hit "Skip", maybe hundreds of times. There is no chance to
> >>> edit the url, see what is happening and solve it.
> >>
> >> Try
> >> http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.3/
> >> That works for me and it was given via yast comunity repositories.
> >
> > It is impossible to change once the upgrade from *DVD* has started.
> >
> > Anyway, I just tried with Firefox on another computer and it works.
> >
> > I switched to a terminal on the upgrading system, which this instant is
> > running from DVD/USB stick installation media, so the available programs
> > are minimal: there is no web browser to try, but ping to that server
> > works.
> >
> > I found the problem!
> >
> > I located the YaST log. YaST is looking now
> > "mjpegtools-2.0.0-19.6.x86_64.rpm", whereas the server now has
> > "mjpegtools-2.0.0-19.7.x86_64.rpm"
> >
> > The server has updated content while I was running the upgrade :-/
> >
> > And it is impossible to go back in YaST and tell it to refresh.
>
> I usually update from dvd (flash drive) without any repos enabled. My
> update from 42.2 to 42.3 I changed all repos to 42.3 and did a zypper
> dup --no-allow-vendor-change and it succeeded without error.
> Dave P
Same experiences here.
@Carlos: was the vendor change to Packman *ever* done ?

--
Gertjan Lettink, a.k.a. Knurpht

openSUSE Board Member
openSUSE Forums Team



--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to 42.3 experience - packman

Carlos E. R.-2
On 2018-01-25 17:51, Knurpht - Gertjan Lettink wrote:
> Op donderdag 25 januari 2018 17:02:22 CET schreef Dave Plater:
>> On 25/01/2018 17:21, Carlos E. R. wrote:


>>> I found the problem!
>>>
>>> I located the YaST log. YaST is looking now
>>> "mjpegtools-2.0.0-19.6.x86_64.rpm", whereas the server now has
>>> "mjpegtools-2.0.0-19.7.x86_64.rpm"
>>>
>>> The server has updated content while I was running the upgrade :-/
>>>
>>> And it is impossible to go back in YaST and tell it to refresh.
>>
>> I usually update from dvd (flash drive) without any repos enabled. My
>> update from 42.2 to 42.3 I changed all repos to 42.3 and did a zypper
>> dup --no-allow-vendor-change and it succeeded without error.
Before booting the install DVD I edited all extra repos to point to the
42.3 versions. This saves time and trouble, when YaST finds installed
packages that are not in the OSS repo.

The DVD-upgrade procedure does the equivalent of
"--no-allow-vendor-change". Remember, it is YaST running from the DVD.

This procedure works very well on Leap.

> Same experiences here.
> @Carlos: was the vendor change to Packman *ever* done ?

Yes, of course it was.

The problem, as I posted before, was that the packman repository was
itself updated while I was running the upgrade, in the half an hour
between YaST refreshing the repo data, me ticking the options in YaST,
and finally doing the upgrade run.

It was not all the packman rpms, only a portion. For example, kodi
packages were upgraded without problems, I saw them flash by.

--
Cheers / Saludos,

                Carlos E. R.
                (from 42.2 x86_64 "Malachite" at Telcontar)


signature.asc (188 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to 42.3 experience - packman

Dave Howorth-3
On Thu, 25 Jan 2018 19:17:46 +0100
"Carlos E. R." <[hidden email]> wrote:

> On 2018-01-25 17:51, Knurpht - Gertjan Lettink wrote:
> > Op donderdag 25 januari 2018 17:02:22 CET schreef Dave Plater:  
> >> On 25/01/2018 17:21, Carlos E. R. wrote:  
>
>
> >>> I found the problem!
> >>>
> >>> I located the YaST log. YaST is looking now
> >>> "mjpegtools-2.0.0-19.6.x86_64.rpm", whereas the server now has
> >>> "mjpegtools-2.0.0-19.7.x86_64.rpm"
> >>>
> >>> The server has updated content while I was running the upgrade :-/
> >>>
> >>> And it is impossible to go back in YaST and tell it to refresh.  
> >>
> >> I usually update from dvd (flash drive) without any repos enabled.
> >> My update from 42.2 to 42.3 I changed all repos to 42.3 and did a
> >> zypper dup --no-allow-vendor-change and it succeeded without
> >> error.  
>
> Before booting the install DVD I edited all extra repos to point to
> the 42.3 versions. This saves time and trouble, when YaST finds
> installed packages that are not in the OSS repo.
>
> The DVD-upgrade procedure does the equivalent of
> "--no-allow-vendor-change". Remember, it is YaST running from the DVD.
>
> This procedure works very well on Leap.
>
> > Same experiences here.
> > @Carlos: was the vendor change to Packman *ever* done ?  
>
> Yes, of course it was.
>
> The problem, as I posted before, was that the packman repository was
> itself updated while I was running the upgrade, in the half an hour
> between YaST refreshing the repo data, me ticking the options in YaST,
> and finally doing the upgrade run.
>
> It was not all the packman rpms, only a portion. For example, kodi
> packages were upgraded without problems, I saw them flash by.

I think that's part of the point of download-in-advance or
download-only isn't it?

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to 42.3 experience - packman

Carlos E. R.-2
On 2018-01-25 22:03, Dave Howorth wrote:
> On Thu, 25 Jan 2018 19:17:46 +0100 "Carlos E. R." <> wrote:


>> The problem, as I posted before, was that the packman repository was
>> itself updated while I was running the upgrade, in the half an hour
>> between YaST refreshing the repo data, me ticking the options in YaST,
>> and finally doing the upgrade run.
>>
>> It was not all the packman rpms, only a portion. For example, kodi
>> packages were upgraded without problems, I saw them flash by.
>
> I think that's part of the point of download-in-advance or
> download-only isn't it?
Again, I'm using the DVD-upgrade method.

Boot the DVD, choose "upgrade installed system".

There is no option to download in advance anything. This is not zypper.
I'm not running any "zypper" command. It is a GUI, a variant of YaST
with no desktop, kiosk mode alike. Very similar to the installation
system GUI, but for upgrades.

--
Cheers / Saludos,

                Carlos E. R.
                (from 42.2 x86_64 "Malachite" at Telcontar)


signature.asc (188 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to 42.3 experience - packman

Dave Howorth-3
On Thu, 25 Jan 2018 22:13:37 +0100
"Carlos E. R." <[hidden email]> wrote:

> On 2018-01-25 22:03, Dave Howorth wrote:
> > On Thu, 25 Jan 2018 19:17:46 +0100 "Carlos E. R." <> wrote:  
>
>
> >> The problem, as I posted before, was that the packman repository
> >> was itself updated while I was running the upgrade, in the half an
> >> hour between YaST refreshing the repo data, me ticking the options
> >> in YaST, and finally doing the upgrade run.
> >>
> >> It was not all the packman rpms, only a portion. For example, kodi
> >> packages were upgraded without problems, I saw them flash by.  
> >
> > I think that's part of the point of download-in-advance or
> > download-only isn't it?  
>
> Again, I'm using the DVD-upgrade method.
>
> Boot the DVD, choose "upgrade installed system".
>
> There is no option to download in advance anything. This is not
> zypper. I'm not running any "zypper" command. It is a GUI, a variant
> of YaST with no desktop, kiosk mode alike. Very similar to the
> installation system GUI, but for upgrades.

Well yes, so I think either you need to file an enhancement request or
switch your upgrade method to avoid the problem in future. I was just
pointing out that there is a solution to your problem.

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to 42.3 experience - packman

Carlos E. R.-2
On 2018-01-26 00:41, Dave Howorth wrote:

> On Thu, 25 Jan 2018 22:13:37 +0100
> "Carlos E. R." <> wrote:
>
>> On 2018-01-25 22:03, Dave Howorth wrote:
>>> On Thu, 25 Jan 2018 19:17:46 +0100 "Carlos E. R." <> wrote:  
>>
>>
>>>> The problem, as I posted before, was that the packman repository
>>>> was itself updated while I was running the upgrade, in the half an
>>>> hour between YaST refreshing the repo data, me ticking the options
>>>> in YaST, and finally doing the upgrade run.
>>>>
>>>> It was not all the packman rpms, only a portion. For example, kodi
>>>> packages were upgraded without problems, I saw them flash by.  
>>>
>>> I think that's part of the point of download-in-advance or
>>> download-only isn't it?  
>>
>> Again, I'm using the DVD-upgrade method.
>>
>> Boot the DVD, choose "upgrade installed system".
>>
>> There is no option to download in advance anything. This is not
>> zypper. I'm not running any "zypper" command. It is a GUI, a variant
>> of YaST with no desktop, kiosk mode alike. Very similar to the
>> installation system GUI, but for upgrades.
>
> Well yes, so I think either you need to file an enhancement request or
> switch your upgrade method to avoid the problem in future. I was just
> pointing out that there is a solution to your problem.
No, there is not. That enhancement is not feasible in the short/medium
term, nor is switching upgrade method.

Anyhow, download in advance would also fail in this case, because
between repodata download, and package download there was half an an
hour or less in between. The actual download is instant, I have a very
fast Internet. If the repository download changes in that interval the
only thing to do, even with download in advance, is full restart of the
procedure.

The same thing can happen with zypper, if you take half an hour to
decide things and the repo changes before you give the "go ahead".

There is nothing to do to enhance the situation.


Except repositories delaying the actual delete of packages two hours
after giving the command.

--
Cheers / Saludos,

                Carlos E. R.
                (from 42.2 x86_64 "Malachite" at Telcontar)


signature.asc (188 bytes) Download Attachment