Upgrading 42.2 to 42.3

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrading 42.2 to 42.3

Dave Howorth-3
I'm upgrading 42.2 to 42.3 and following instructions at
https://doc.opensuse.org/release-notes/x86_64/openSUSE/Leap/42.3/
Specifically I'm looking at section 2.2.2 and going through the steps
there. I do have an '@' subvolume. There is no /var/cache.old at step 6.
When I try to perform step 7 I see:

# rm -rf /mnt/var/cache.old/
rm: cannot remove '/mnt/var/cache.old/': Operation not permitted


Does anybody know what the problem is?

Cheers, Dave

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Upgrading 42.2 to 42.3

Dave Howorth-3
On Wed, 10 Jan 2018 15:36:15 +0000
Dave Howorth <[hidden email]> wrote:

> I'm upgrading 42.2 to 42.3 and following instructions at
> https://doc.opensuse.org/release-notes/x86_64/openSUSE/Leap/42.3/
> Specifically I'm looking at section 2.2.2 and going through the steps
> there. I do have an '@' subvolume. There is no /var/cache.old at step
> 6. When I try to perform step 7 I see:
>
> # rm -rf /mnt/var/cache.old/
> rm: cannot remove '/mnt/var/cache.old/': Operation not permitted

Ah, I have a bit more idea what's going on.

It looks like I already had a /var/cache subvolume. I now have:

# btrfs subvolume list / | grep cache
ID 1083 gen 441982 top level 257 path @/var/cache.old
ID 1540 gen 441982 top level 257 path @/var/cache
# ls -a /var/cache/
.  ..
# ls -a /mnt/var/cache.old/
.  ..
# ls -a /mnt/var/cache/
.           apache2   dirmngr     krb5rcache  lightdm   zypp
..          apparmor  fontconfig  ldconfig    man       zypper
PackageKit  cups      gio-2.0     libx11      susehelp

What's my next step?

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]