Unable to force lower version of package

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Unable to force lower version of package

Till Dörges
Hello all,

I'm running a private OBS 2.7 instance.

For one of my projects A I have this in my meta configuration:

--- snip ---
  <repository name="openSUSE_Leap_42.2">
    [...]
    <path project="openSUSE.org:Leap:42.2:Update" repository="standard"/>
    <path project="openSUSE.org:Leap:42.2" repository="standard"/>
    <arch>x86_64</arch>
  </repository>
--- snap ---

A package B in project A has one BuildRequires, which in turn pulls in another
package C (via Requires).

Now C has a requires for a standard Leap 42.2 package D but with a version constraint.


The required version of D is present in the Leap 42.2 repo. The version in the Leap
42.2 update repo is too high (from /srv/obs/log/scheduler_x86_64.log):

--- snip ---
2017-05-10 20:28:59: looking at low prio A/openSUSE_Leap_42.2 (0/0/0/0/42)
  - A/openSUSE_Leap_42.2
    scanning repo A/openSUSE_Leap_42.2...
    sorting 1 packages
      - B (spec)
        unresolvable:
            nothing provides D < 2.1.3 needed by C
--- snap ---



If I change the above meta configuration to

--- snip ---  <repository name="openSUSE_Leap_42.2">
    [...]
    <path project="openSUSE.org:Leap:42.2" repository="standard"/>
    <arch>x86_64</arch>
  </repository>
--- snap ---

package B builds fine.


But I'd like to use the RPMs from the update repository. How would I have to
configure that? Or how can I track down this dependency issue?



Thanks and regards -- Till
--
Dipl.-Inform. Till Dörges                  [hidden email]
                                  Tel. +49 - 40 - 244 2407 - 14
                                  Fax  +49 - 40 - 244 2407 - 24
PRESENSE Technologies GmbH            Sachsenstr. 5, D-20097 HH
Geschäftsführer/Managing Directors       AG Hamburg, HRB 107844
Till Dörges, Jürgen Sander               USt-IdNr.: DE263765024

             Wir sind wieder auf dem BSI IT-Sicherheitskongress
                                        16.-18. Mai 2017 – Bonn
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to force lower version of package

Michael Schroeder-4
On Wed, May 10, 2017 at 08:52:34PM +0200, Till Dörges wrote:

> I'm running a private OBS 2.7 instance.
>
> For one of my projects A I have this in my meta configuration:
>
> --- snip ---
>   <repository name="openSUSE_Leap_42.2">
>     [...]
>     <path project="openSUSE.org:Leap:42.2:Update" repository="standard"/>
>     <path project="openSUSE.org:Leap:42.2" repository="standard"/>
>     <arch>x86_64</arch>
>   </repository>
> --- snap ---
>
> A package B in project A has one BuildRequires, which in turn pulls in another
> package C (via Requires).
>
> Now C has a requires for a standard Leap 42.2 package D but with a version constraint.
>
>
> The required version of D is present in the Leap 42.2 repo. The version in the Leap
> 42.2 update repo is too high (from /srv/obs/log/scheduler_x86_64.log):
>
> --- snip ---
> 2017-05-10 20:28:59: looking at low prio A/openSUSE_Leap_42.2 (0/0/0/0/42)
>   - A/openSUSE_Leap_42.2
>     scanning repo A/openSUSE_Leap_42.2...
>     sorting 1 packages
>       - B (spec)
>         unresolvable:
>             nothing provides D < 2.1.3 needed by C
> --- snap ---

Yes, that's pretty much by design. A workaround would be to pull
the old D package into your current project with an aggregate, but
that would mean that new D is no longer available, so I don't know if
that helps you.

Cheers,
  Michael.

--
Michael Schroeder                                   [hidden email]
SUSE LINUX GmbH,           GF Jeff Hawn, HRB 16746 AG Nuernberg
main(_){while(_=~getchar())putchar(~_-1/(~(_|32)/13*2-11)*13);}
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to force lower version of package

Till Dörges
Am 11.05.2017 um 10:41 schrieb Michael Schroeder:

>> The required version of D is present in the Leap 42.2 repo. The version in the Leap
>> 42.2 update repo is too high (from /srv/obs/log/scheduler_x86_64.log):
>>
>> --- snip ---
>> 2017-05-10 20:28:59: looking at low prio A/openSUSE_Leap_42.2 (0/0/0/0/42)
>>   - A/openSUSE_Leap_42.2
>>     scanning repo A/openSUSE_Leap_42.2...
>>     sorting 1 packages
>>       - B (spec)
>>         unresolvable:
>>             nothing provides D < 2.1.3 needed by C
>> --- snap ---
> Yes, that's pretty much by design. A workaround would be to pull
> the old D package into your current project with an aggregate, but
> that would mean that new D is no longer available, so I don't know if
> that helps you.

Well, at least not a local error. ;-)

I need to force the version because the more recent D breaks another package. And
while debugging the problem I still would like OBS to generated a usable set of RPMs.

Is there any documentation how to use/set up aggregate? A quick search through
http://openbuildservice.org/files/manuals/obs-reference-guide.pdf came up empty.

Thanks -- Till
--
Dipl.-Inform. Till Dörges                  [hidden email]
                                  Tel. +49 - 40 - 244 2407 - 14
                                  Fax  +49 - 40 - 244 2407 - 24
PRESENSE Technologies GmbH            Sachsenstr. 5, D-20097 HH
Geschäftsführer/Managing Directors       AG Hamburg, HRB 107844
Till Dörges, Jürgen Sander               USt-IdNr.: DE263765024

             Wir sind wieder auf dem BSI IT-Sicherheitskongress
                                        16.-18. Mai 2017 – Bonn
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to force lower version of package

Michael Schroeder-4
On Thu, May 11, 2017 at 10:50:19AM +0200, Till Dörges wrote:
> Is there any documentation how to use/set up aggregate? A quick search through
> http://openbuildservice.org/files/manuals/obs-reference-guide.pdf came up empty.

https://en.opensuse.org/openSUSE:Build_Service_Tips_and_Tricks contains
examples.

Cheers,
  Michael.

--
Michael Schroeder                                   [hidden email]
SUSE LINUX GmbH,           GF Jeff Hawn, HRB 16746 AG Nuernberg
main(_){while(_=~getchar())putchar(~_-1/(~(_|32)/13*2-11)*13);}
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Loading...