Tumbleweed problems: yast module not found, zypper dup fails

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Tumbleweed problems: yast module not found, zypper dup fails

Jörn Dreyer
Hi ,

I have currently a problem with my Tumbleweed instalation. If I start the yast
module to
install/remove software I get an error message:

Failed to load Module 'Pacvkages' due to: Failed to load Module
'SpaceCalculation' due to:
cannot load such file -- storage
Caller: /usr/lib64/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in
'require'

If I try to run 'zypper dup' I get the following warning:

Problem: libopenssl-1_0_0-devel-1.0.2n-1.2.x86_64 conflicts with libopenssl-
devel > 1.0.2n
provided by libopenssl-devel-1.1.0g-1.1.noarch


Which probably comes from the installation of Skype.

How to resolve those problems?

Regards,

Jörn



--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Tumbleweed problems: yast module not found, zypper dup fails

Dominique Leuenberger / DimStar
On Thu, 2018-02-01 at 11:33 +0100, Jörn Dreyer wrote:
> Problem: libopenssl-1_0_0-devel-1.0.2n-1.2.x86_64 conflicts with libopenssl-
> devel > 1.0.2n
> provided by libopenssl-devel-1.1.0g-1.1.noarch

I recommend to first uninstall libopenssl-1_0_0-devel

No application should require the devel package for runtime; and unless
you plan on building own code linked against openssl 1.0, you don't
need this package on your system. (and if you do want to do that:
reconsider :) )

cheers
Dominique

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Tumbleweed problems: yast module not found, zypper dup fails

H.Merijn Brand
On Thu, 01 Feb 2018 11:39:22 +0100, Dominique Leuenberger / DimStar
<[hidden email]> wrote:

> On Thu, 2018-02-01 at 11:33 +0100, Jörn Dreyer wrote:
> > Problem: libopenssl-1_0_0-devel-1.0.2n-1.2.x86_64 conflicts with libopenssl-
> > devel > 1.0.2n
> > provided by libopenssl-devel-1.1.0g-1.1.noarch  
>
> I recommend to first uninstall libopenssl-1_0_0-devel

I use it to build SSL related XS modules in perl5
I use it to build claws-mail from git
I use it to ...
I use it a lot.

I think that anyone building SSL related stuff on a development sytem
will require libopenssl-devel

> No application should require the devel package for runtime;

That is true

> and unless you plan on building own code linked against openssl 1.0,
> you don't need this package on your system. (and if you do want to do
> that: reconsider :) )

considered, reconsidered and left in place :)

> cheers
> Dominique

--
H.Merijn Brand  http://tux.nl   Perl Monger  http://amsterdam.pm.org/
using perl5.00307 .. 5.27   porting perl5 on HP-UX, AIX, and openSUSE
http://mirrors.develooper.com/hpux/        http://www.test-smoke.org/
http://qa.perl.org   http://www.goldmark.org/jeff/stupid-disclaimers/

attachment0 (484 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Tumbleweed problems: yast module not found, zypper dup fails

Dominique Leuenberger / DimStar
On Thu, 2018-02-01 at 11:58 +0100, H.Merijn Brand wrote:

> On Thu, 01 Feb 2018 11:39:22 +0100, Dominique Leuenberger / DimStar
> <[hidden email]> wrote:
>
> > On Thu, 2018-02-01 at 11:33 +0100, Jörn Dreyer wrote:
> > > Problem: libopenssl-1_0_0-devel-1.0.2n-1.2.x86_64 conflicts with libopenssl-
> > > devel > 1.0.2n
> > > provided by libopenssl-devel-1.1.0g-1.1.noarch  
> >
> > I recommend to first uninstall libopenssl-1_0_0-devel
>
> I use it to build SSL related XS modules in perl5
> I use it to build claws-mail from git
> I use it to ...
> I use it a lot.
>
> I think that anyone building SSL related stuff on a development sytem
> will require libopenssl-devel
libopenssl-devel yes, libopenssl-1_0-_0-devel no!

Tumbleweed has moved to openSSL 1.1 last year

Cheers
Dominique

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Tumbleweed problems: yast module not found, zypper dup fails

Jörn Dreyer
Hi,

after allowing 'zypper dup' to remove the obolete libopenssl-1_0_0-
devel-1.0.2n-1.2.x86_64, everything works again.

Thanks for the help

Jörn

Am Donnerstag, 1. Februar 2018, 12:00:20 CET schrieb Dominique Leuenberger /
DimStar:

> On Thu, 2018-02-01 at 11:58 +0100, H.Merijn Brand wrote:
> > On Thu, 01 Feb 2018 11:39:22 +0100, Dominique Leuenberger / DimStar
> >
> > <[hidden email]> wrote:
> > > On Thu, 2018-02-01 at 11:33 +0100, Jörn Dreyer wrote:
> > > > Problem: libopenssl-1_0_0-devel-1.0.2n-1.2.x86_64 conflicts with
> > > > libopenssl- devel > 1.0.2n
> > > > provided by libopenssl-devel-1.1.0g-1.1.noarch
> > >
> > > I recommend to first uninstall libopenssl-1_0_0-devel
> >
> > I use it to build SSL related XS modules in perl5
> > I use it to build claws-mail from git
> > I use it to ...
> > I use it a lot.
> >
> > I think that anyone building SSL related stuff on a development sytem
> > will require libopenssl-devel
>
> libopenssl-devel yes, libopenssl-1_0-_0-devel no!
>
> Tumbleweed has moved to openSSL 1.1 last year
>
> Cheers
> Dominique


--
Dr. Joern Dreyer
HIBEF DAQ + Controls
Institut für Strahlenphysik
Helmholtz-Zentrum Dresden - Rossendorf e.V
Abt. FWKH                Tel: +49 351 260 3263
                                   FAX: +49 351 260 3700
01314 Dresden        eMail: [hidden email]

Helmholtz-Zentrum Dresden - Rossendorf e.V (HZDR)
Bautzner Landstraße 400, 01328 Dresden
Vorstand: Prof. Dr. Dr. h. c. Roland Sauerbrey, Dr. Ulrich Breuer
Vereinsregister: VR 1693 beim Amtsgericht Dresden


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Tumbleweed problems: yast module not found, zypper dup fails

H.Merijn Brand
In reply to this post by Dominique Leuenberger / DimStar
On Thu, 01 Feb 2018 12:00:20 +0100, Dominique Leuenberger / DimStar
<[hidden email]> wrote:

> On Thu, 2018-02-01 at 11:58 +0100, H.Merijn Brand wrote:
> > On Thu, 01 Feb 2018 11:39:22 +0100, Dominique Leuenberger / DimStar
> > <[hidden email]> wrote:
> >  
> > > On Thu, 2018-02-01 at 11:33 +0100, Jörn Dreyer wrote:  
>  [...]  
> > >
> > > I recommend to first uninstall libopenssl-1_0_0-devel  
> >
> > I use it to build SSL related XS modules in perl5
> > I use it to build claws-mail from git
> > I use it to ...
> > I use it a lot.
> >
> > I think that anyone building SSL related stuff on a development sytem
> > will require libopenssl-devel  
>
> libopenssl-devel yes, libopenssl-1_0-_0-devel no!
Oh sorry, yes, so true!

$ rpm -qa | grep -i openssl | grep devel
libopenssl-devel-1.1.0g-1.1.noarch
libopenssl-1_1_0-devel-1.1.0g-5.1.x86_64

> Tumbleweed has moved to openSSL 1.1 last year
>
> Cheers
> Dominique

--
H.Merijn Brand  http://tux.nl   Perl Monger  http://amsterdam.pm.org/
using perl5.00307 .. 5.27   porting perl5 on HP-UX, AIX, and openSUSE
http://mirrors.develooper.com/hpux/        http://www.test-smoke.org/
http://qa.perl.org   http://www.goldmark.org/jeff/stupid-disclaimers/

attachment0 (484 bytes) Download Attachment