Tumbleweed - Review of the week 2017/49

classic Classic list List threaded Threaded
18 messages Options
Reply | Threaded
Open this post in threaded view
|

Tumbleweed - Review of the week 2017/49

Dominique Leuenberger / DimStar
Dear Tumbleweed users and hackers,

The last month of the year is upon us (at least if we focus solely on
the general use of the Gregorian calendar). And the first week was a
strong one for Tumbleweed with 5 snapshots released to the public
(1201, 1202, 1203, 1204 and 1205).

The interesting changes in those snapshots were:

  * MariaDB 10.2.10
  * Poppler 0.61.1
  * Flatpak 0.10.1 and flapak-builder 0.10.5
  * Mesa 17.2.6
  * Libvirt 3.10.0
  * Linux Kernel 4.14.3
  * A lot more python2->python3 conversions
  * suse_version has been changed to 1550 (On Dec 1st, 2017)

For the ones that don’t know yet, the python2 -> python3 switches are
especially of interest to SLE/Leap 15. Minimizing the support surface
for python2 in favor of python3 will lead to a much stronger,
supportable product for the future. As Tumbleweed is the leading and
trendsetting product, it is but natural that we get those changes as
well.

The year might slowly come to an end, but our developers are full of
energy, as all the preparation work implies:

  * RPM 4.14 – with some new rich dependencies, and some
(unfortunately?) stricter syntax handling of the spec files. This is
leading to quite some build failures in Staging:A already.
  * Qt 5.9.3
  * Linux Kernel 4.14.4
  8 KDE Applications 17.12.0
  * Tomcat 9.0.2
  * LibreOffice 6.0
  * The YaST Team’s Libstorage-NG implementation

Cheers,
Dominique

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Tumbleweed - Libreoffice 6.0 (a beta1 really?)

Bruno Friedmann-2
>   * Qt 5.9.3
>   * Linux Kernel 4.14.4
>   8 KDE Applications 17.12.0
>   * Tomcat 9.0.2
>   * LibreOffice 6.0
>   * The YaST Team’s Libstorage-NG implementation

I'm quite surprized about having Loo 6 as it is a beta1
http://www.libreoffice.org/download/download/?type=rpm-x86_64&version=6.0.0&lang=fr

I'm afraid with the incoming of qt5 integration, quite a big number of bugs
will be discovered, but those should be handled in our devel repo no ?

May be I'm just wrong, and no sorry I've not a timeframe to pre-test all
of what we produce on obs myself ;-)

--

Bruno Friedmann
 Ioda-Net Sàrl www.ioda-net.ch
 Bareos Partner, openSUSE Member, fsfe fellowship
 GPG KEY : D5C9B751C4653227
 irc: tigerfoot


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Tumbleweed - Libreoffice 6.0 (a beta1 really?)

Dominique Leuenberger / DimStar
On Fri, 2017-12-08 at 18:04 +0100, Bruno Friedmann wrote:

> >   * Qt 5.9.3
> >   * Linux Kernel 4.14.4
> >   8 KDE Applications 17.12.0
> >   * Tomcat 9.0.2
> >   * LibreOffice 6.0
> >   * The YaST Team’s Libstorage-NG implementation
>
> I'm quite surprized about having Loo 6 as it is a beta1
> http://www.libreoffice.org/download/download/?type=rpm-x86_64&version
> =6.0.0&lang=fr
>
> I'm afraid with the incoming of qt5 integration, quite a big number
> of bugs
> will be discovered, but those should be handled in our devel repo no
> ?
>
> May be I'm just wrong, and no sorry I've not a timeframe to pre-test
> all
> of what we produce on obs myself ;-)
This is the decision of the maintainer in agreement with the users.
When I asked Tom, he explicitly said 'it it passes openQA, it is ok'

So far I can't say much there yet, I did not even get it to build in
Stagings yet :)

Cheers
Dominique

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Tumbleweed - Libreoffice 6.0 (a beta1 really?)

Bruno Friedmann-2
On vendredi, 8 décembre 2017 18.14:01 h CET Dominique Leuenberger / DimStar
wrote:

> On Fri, 2017-12-08 at 18:04 +0100, Bruno Friedmann wrote:
> > >   * Qt 5.9.3
> > >   * Linux Kernel 4.14.4
> > >   8 KDE Applications 17.12.0
> > >   * Tomcat 9.0.2
> > >   * LibreOffice 6.0
> > >   * The YaST Team’s Libstorage-NG implementation
> >
> > I'm quite surprized about having Loo 6 as it is a beta1
> > http://www.libreoffice.org/download/download/?type=rpm-x86_64&version
> > =6.0.0&lang=fr
> >
> > I'm afraid with the incoming of qt5 integration, quite a big number
> > of bugs
> > will be discovered, but those should be handled in our devel repo no
> > ?
> >
> > May be I'm just wrong, and no sorry I've not a timeframe to pre-test
> > all
> > of what we produce on obs myself ;-)
>
> This is the decision of the maintainer in agreement with the users.
> When I asked Tom, he explicitly said 'it it passes openQA, it is ok'

Yeah but how it will work on real gpu is the crash question :-)
But then let see what will happen. Typical case of having a multiversion would
please everybody.

> So far I can't say much there yet, I did not even get it to build in
> Stagings yet :)
Good news :-)


--

Bruno Friedmann
 Ioda-Net Sàrl www.ioda-net.ch
 Bareos Partner, openSUSE Member, fsfe fellowship
 GPG KEY : D5C9B751C4653227
 irc: tigerfoot


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Tumbleweed - Libreoffice 6.0 (a beta1 really?)

tomtomme
Am 08.12.2017 um 18:31 schrieb Bruno Friedmann:

> On vendredi, 8 décembre 2017 18.14:01 h CET Dominique Leuenberger / DimStar
> wrote:
>> On Fri, 2017-12-08 at 18:04 +0100, Bruno Friedmann wrote:
>>>>    * Qt 5.9.3
>>>>    * Linux Kernel 4.14.4
>>>>    8 KDE Applications 17.12.0
>>>>    * Tomcat 9.0.2
>>>>    * LibreOffice 6.0
>>>>    * The YaST Team’s Libstorage-NG implementation
>>>
>>> I'm quite surprized about having Loo 6 as it is a beta1
>>> http://www.libreoffice.org/download/download/?type=rpm-x86_64&version
>>> =6.0.0&lang=fr
>>>
>>> I'm afraid with the incoming of qt5 integration, quite a big number
>>> of bugs
>>> will be discovered, but those should be handled in our devel repo no
>>> ?
>>>
>>> May be I'm just wrong, and no sorry I've not a timeframe to pre-test
>>> all
>>> of what we produce on obs myself ;-)
>>
>> This is the decision of the maintainer in agreement with the users.
>> When I asked Tom, he explicitly said 'it it passes openQA, it is ok'
>
> Yeah but how it will work on real gpu is the crash question :-)
> But then let see what will happen. Typical case of having a multiversion would
> please everybody.
>
>> So far I can't say much there yet, I did not even get it to build in
>> Stagings yet :)
> Good news :-)
>

I also would favour to wait for 6.0. We had early LibreOffice RCs the
last times and they were pretty buggy. Some of them were pretty annoying
to work with. For example copy paste in impress was broken, I always had
to copy things two times to be able to paste them. This vanished only
with the .2 point release.

And I wonder where the "in agreement with the users" comes from. We had
a hand full of users (me also) complain here about those early releases
the last times too. Are we to few? Not vocal enough? What are we
expected to do?
I wonder also why libreoffice devs / users may want this. Whats their
reasoning to release it so early? AFAIK LibreOffice is the only big
player that does this in Tumbleweed.

However this plays out. Thanks for the great work. Tumbleweed is still
my go to daily distro.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Tumbleweed - Libreoffice 6.0 (a beta1 really?)

Bjoern Voigt
In reply to this post by Bruno Friedmann-2
Bruno Friedmann wrote:
> I'm quite surprized about having Loo 6 as it is a beta1
> http://www.libreoffice.org/download/download/?type=rpm-x86_64&version=6.0.0&lang=fr
that's why I always install Libreoffice directly from www.libreoffice.org.
The Tumbleweed Libreoffice packages are often too new (6.0.0 Beta 1
currently) and the Leap Libreoffice packages are a bit old
(5.3.5.2 currently).

Greetings,
Björn

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Tumbleweed - Libreoffice 6.0 (a beta1 really?)

Dominique Leuenberger / DimStar
On Fri, 2017-12-08 at 21:57 +0100, Bjoern Voigt wrote:

> Bruno Friedmann wrote:
> > I'm quite surprized about having Loo 6 as it is a beta1
> > http://www.libreoffice.org/download/download/?type=rpm-x86_64&versi
> > on=6.0.0&lang=fr
>
> that's why I always install Libreoffice directly from www.libreoffice
> .org.
> The Tumbleweed Libreoffice packages are often too new (6.0.0 Beta 1
> currently) and the Leap Libreoffice packages are a bit old
> (5.3.5.2 currently).
This is inaccurate - the Tumbleweed packages for LO are at version
5.4.3.2...

Version 6.0 beta is only in the devel project so far - and there is no
being sorry for people opting to add this on their machines, is there?

Cheers
Dominique

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Tumbleweed - Libreoffice 6.0 (a beta1 really?)

Bruno Friedmann-2
In reply to this post by Bruno Friedmann-2
On samedi, 9 décembre 2017 00.25:02 h CET Thorsten Behrens wrote:

> Bruno Friedmann wrote:
> > I'm afraid with the incoming of qt5 integration, quite a big number
> > of bugs will be discovered, but those should be handled in our devel
> > repo no ?
>
> For the avoidance of doubt - the kde5/qt5 work in LibreOffice is
> currently in very early stages. I would caution everyone not to expect
> anything production-ready for 6.0 (nor recommend any maintainer to
> enable it).
>
> Cheers,
>
> -- Thorsten

Thanks for the clarification. A good way to test my patience :-)

--

Bruno Friedmann
 Ioda-Net Sàrl www.ioda-net.ch
 Bareos Partner, openSUSE Member, fsfe fellowship
 GPG KEY : D5C9B751C4653227
 irc: tigerfoot


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Kernel build failure with rpm 4.14 [was: Tumbleweed - Review of the week 2017/49]

Jiri Slaby-6
In reply to this post by Dominique Leuenberger / DimStar
On 12/08/2017, 05:20 PM, Dominique Leuenberger / DimStar wrote:
>   * RPM 4.14 – with some new rich dependencies, and some
> (unfortunately?) stricter syntax handling of the spec files. This is
> leading to quite some build failures in Staging:A already.

Michal,

could you look into the kernel failure, please?

From:
https://build.opensuse.org/package/live_build_log/openSUSE:Factory:Staging:A/kernel-default/standard/x86_64

> [ 5283s] + /usr/lib/rpm/find-debuginfo.sh -j6 -n --build-id-seed 4.14.3-5.1 --unique-debug-suffix -4.14.3-5.1.x86_64 --unique-debug-src-base kernel-default-4.14.3-5.1.x86_64 --run-dwz --dwz-low-mem-die-limit 10000000 --dwz-max-die-limit 50000000 -S debugsourcefiles.list /home/abuild/rpmbuild/BUILD/kernel-default-4.14.3
> [ 5283s] *** ERROR: --build-id-seed (unique build-ids) and -n (do not recompute build-id) cannot be used together
> [ 5283s] error: Bad exit status from /var/tmp/rpm-tmp.F5SjN1 (%install)

thanks,
--
js
suse labs


signature.asc (871 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Tumbleweed - Libreoffice 6.0 (a beta1 really?)

Mykola Krachkovsky
In reply to this post by tomtomme
пʼятниця, 8 грудня 2017 р. 20:54:49 EET tomtomme написано:
> I also would favour to wait for 6.0. We had early LibreOffice RCs the
> last times and they were pretty buggy. Some of them were pretty annoying
> to work with. For example copy paste in impress was broken, I always had
> to copy things two times to be able to paste them. This vanished only
> with the .2 point release.
LibreOffice is unstable anyway, RC or not. There are cases when RC is more
stable than some release version. Current Tumbleweed's LibreOffice Writer
5.4.3.2 crashed for me yesterday and crashed whole X with itself. So, can't
see any serious problem with RC if it will pass openQA.

> And I wonder where the "in agreement with the users" comes from. We had
> a hand full of users (me also) complain here about those early releases
> the last times too. Are we to few? Not vocal enough? What are we
> expected to do?
IMHO, there is no actual polls, so absence of a lot of cries like "OMG, IT
DOESN'T WORK" is fine to accept as agreement.

> I wonder also why libreoffice devs / users may want this. Whats their
> reasoning to release it so early? AFAIK LibreOffice is the only big
> player that does this in Tumbleweed.
Maybe it is good to have additional repository for "not officially stable but ok
for use", but it would be too much work for maintainers, I think.

--
Kind regards,
Mykola Krachkovsky
--
Найкращі побажання,
Микола Крачковський

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Tumbleweed - Review of the week 2017/49

Mykola Krachkovsky
In reply to this post by Dominique Leuenberger / DimStar
пʼятниця, 8 грудня 2017 р. 18:20:58 EET Dominique Leuenberger / DimStar
написано:
>   * MariaDB 10.2.10
And MySQL-Workbench doesn't connect to MySQL servers anymore (at least 5.5 and
5.7) with error "Unsupported option provided to mysql_options()". Sad.

> The year might slowly come to an end, but our developers are full of
> energy, as all the preparation work implies:
> …
>   * Qt 5.9.3
As there is Qt 5.10 already maybe it's better to spend time on Qt 5.10 and
don't waste for 5.9.3? Though there is lesser expected problems from 5.9.3 as
it a bugfix update…


--
Kind regards,
Mykola Krachkovsky
--
Найкращі побажання,
Микола Крачковський

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Tumbleweed - Review of the week 2017/49

Cristiano Guadagnino
Hi Mykola

On 11/12/2017 11:47, Mykola Krachkovsky wrote:
>
>>    * MariaDB 10.2.10
> And MySQL-Workbench doesn't connect to MySQL servers anymore (at least 5.5 and
> 5.7) with error "Unsupported option provided to mysql_options()". Sad.
You're too behind with your MySQL-Workbench release.
I have v6.3 here and it connects without problems (and mostly works
correctly), though it issues a warning.

Cris

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: MySQL Worckbench error (was: Tumbleweed - Review of the week 2017/49)

Mykola Krachkovsky
вівторок, 12 грудня 2017 р. 09:47:35 EET Cristiano Guadagnino написано:

> Hi Mykola
>
> On 11/12/2017 11:47, Mykola Krachkovsky wrote:
> >>    * MariaDB 10.2.10
> >
> > And MySQL-Workbench doesn't connect to MySQL servers anymore (at least 5.5
> > and 5.7) with error "Unsupported option provided to mysql_options()".
> > Sad.
> You're too behind with your MySQL-Workbench release.
> I have v6.3 here and it connects without problems (and mostly works
> correctly), though it issues a warning.
>
> Cris
I have MySQL Workbench 6.3.9 from repositories. Noted there is 6.3.10 on site.
Will try to update repos. What version are you using? Are your local libraries
MariaDB and you are connecting to MySQL (not MariaDB) server?

--
Kind regards,
Mykola Krachkovsky
--
Найкращі побажання,
Микола Крачковський

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: MySQL Worckbench error (was: Tumbleweed - Review of the week 2017/49)

Erwin Van de Velde
Hi,

I can confirm the issue in the latest TW version: 6.3.9-2.4,
connecting to a Percona MySQL database.

Kind regards,
Erwin

On Tue, Dec 12, 2017 at 11:34 AM, Mykola Krachkovsky <[hidden email]> wrote:

> вівторок, 12 грудня 2017 р. 09:47:35 EET Cristiano Guadagnino написано:
>> Hi Mykola
>>
>> On 11/12/2017 11:47, Mykola Krachkovsky wrote:
>> >>    * MariaDB 10.2.10
>> >
>> > And MySQL-Workbench doesn't connect to MySQL servers anymore (at least 5.5
>> > and 5.7) with error "Unsupported option provided to mysql_options()".
>> > Sad.
>> You're too behind with your MySQL-Workbench release.
>> I have v6.3 here and it connects without problems (and mostly works
>> correctly), though it issues a warning.
>>
>> Cris
> I have MySQL Workbench 6.3.9 from repositories. Noted there is 6.3.10 on site.
> Will try to update repos. What version are you using? Are your local libraries
> MariaDB and you are connecting to MySQL (not MariaDB) server?
>
> --
> Kind regards,
> Mykola Krachkovsky
> --
> Найкращі побажання,
> Микола Крачковський
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: MySQL Worckbench error (was: Tumbleweed - Review of the week 2017/49)

Mykola Krachkovsky
вівторок, 12 грудня 2017 р. 14:41:02 EET Erwin Van de Velde написано:
> I can confirm the issue in the latest TW version: 6.3.9-2.4,
> connecting to a Percona MySQL database.
I've updated to 6.3.10 in [1] but it still says the same error.

[1] https://download.opensuse.org/repositories/home:/NickLion:/java/
openSUSE_Tumbleweed/

--
Kind regards,
Mykola Krachkovsky
--
Найкращі побажання,
Микола Крачковський

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: MySQL Worckbench error (was: Tumbleweed - Review of the week 2017/49)

Daniele Granata
2017-12-12 16:59 GMT+01:00 Mykola Krachkovsky <[hidden email]>:

> вівторок, 12 грудня 2017 р. 14:41:02 EET Erwin Van de Velde написано:
>> I can confirm the issue in the latest TW version: 6.3.9-2.4,
>> connecting to a Percona MySQL database.
> I've updated to 6.3.10 in [1] but it still says the same error.
>
> [1] https://download.opensuse.org/repositories/home:/NickLion:/java/
> openSUSE_Tumbleweed/
>
> --
> Kind regards,
> Mykola Krachkovsky

Hi Mykola
this is because the bug is most likely to reside in the new
mariadb-connector-c not in mysql-workbench.

Cheers
--
Daniele
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: MySQL Worckbench error

Cristiano Guadagnino
In reply to this post by Mykola Krachkovsky
Hi Mykola!

On 12/12/2017 16:59, Mykola Krachkovsky wrote:
> I've updated to 6.3.10 in [1] but it still says the same error.
>
> [1] https://download.opensuse.org/repositories/home:/NickLion:/java/
> openSUSE_Tumbleweed/

After the latest round of Tumbleweed updates I get the error as well.
I'm on MySQL-Workbench 6.3.9 build 10690321 CE (64 bits) Community.
MySQL Workbench has not changed, so it must be a problem in some
supporting library.

Cris

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: MySQL Worckbench error (was: Tumbleweed - Review of the week 2017/49)

Mykola Krachkovsky
In reply to this post by Daniele Granata
вівторок, 12 грудня 2017 р. 19:15:44 EET Daniele Granata написано:

> 2017-12-12 16:59 GMT+01:00 Mykola Krachkovsky <[hidden email]>:
> > вівторок, 12 грудня 2017 р. 14:41:02 EET Erwin Van de Velde написано:
> >> I can confirm the issue in the latest TW version: 6.3.9-2.4,
> >> connecting to a Percona MySQL database.
> >
> > I've updated to 6.3.10 in [1] but it still says the same error.
> >
> > [1] https://download.opensuse.org/repositories/home:/NickLion:/java/
> > openSUSE_Tumbleweed/
> >
> > --
> > Kind regards,
> > Mykola Krachkovsky
>
> Hi Mykola
> this is because the bug is most likely to reside in the new
> mariadb-connector-c not in mysql-workbench.
>
> Cheers
Hi Daniele,
I also believe it somewhere in MySQL Workbench/MariaDB libraries cooperation.
Because 6.3.9 with older libraries worked fine and connection from Qt code to
same server with the same credentials works fine with current libraries.


--
Kind regards,
Mykola Krachkovsky
--
Найкращі побажання,
Микола Крачковський

signature.asc (499 bytes) Download Attachment