Thumbleweed zypper dup asks for downgrades

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

Thumbleweed zypper dup asks for downgrades

Sunny_bg
Hi,
I have been using Tumbleweed for months now, but I haven't updated in
the last few weeks.

Today, after zypper ref, zypper dup --from Tumbleweed, besides all the
packages which need upgrade, and few changing vendor to Tumbleweed, 89
were marked for downgrade??? It shows 143 packages to upgrade.

at the same time zypper up shows 168 packages to upgrade - much more
than tumbleweed.

Is this normal?

--
Svetoslav Milenov (Sunny)

Artificial Intelligence is no match for natural stupidity.
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Thumbleweed zypper dup asks for downgrades

gregkh
On Fri, Aug 05, 2011 at 08:55:41AM -0500, Sunny wrote:
> Hi,
> I have been using Tumbleweed for months now, but I haven't updated in
> the last few weeks.
>
> Today, after zypper ref, zypper dup --from Tumbleweed, besides all the
> packages which need upgrade, and few changing vendor to Tumbleweed, 89
> were marked for downgrade??? It shows 143 packages to upgrade.

That sounds wierd, are you sure you have only the tumbleweed repo
enabled, plus the "stock" 11.4 ones (updates, base)?

> at the same time zypper up shows 168 packages to upgrade - much more
> than tumbleweed.
>
> Is this normal?

Sometimes downgrades happen, when something goes wrong and we need to
"downgrade" back to the 11.4 versions of packages.  But that's really
only happened once, when I botched the first major KDE update.  It
shouldn't still be happening now.

Can you post a list of the repos that you have (output of 'zypper lr -d'
is good)?

thanks,

greg k-h
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Thumbleweed zypper dup asks for downgrades

Sunny_bg
On Fri, Aug 5, 2011 at 9:55 AM, Greg KH <[hidden email]> wrote:
> Sometimes downgrades happen, when something goes wrong and we need to
> "downgrade" back to the 11.4 versions of packages.  But that's really
> only happened once, when I botched the first major KDE update.  It
> shouldn't still be happening now.
>
> Can you post a list of the repos that you have (output of 'zypper lr -d'
> is good)?
>

Thanks Greg,

the output of zypper lr is weird to be placed in an email, that's why
I put the zypper ref output:

sudo zypper ref
Retrieving repository 'Tumbleweed' metadata [done]
Building repository 'Tumbleweed' cache [done]
Retrieving repository 'Mozilla' metadata [done]
Building repository 'Mozilla' cache [done]
Repository 'openSUSE-11.4-Non-Oss' is up to date.
Repository 'openSUSE-11.4-Oss' is up to date.
Retrieving repository 'openSUSE-11.4-Update' metadata [done]
Building repository 'openSUSE-11.4-Update' cache [done]
All repositories have been refreshed.

sudo zypper dup --from Tumbleweed
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

The following NEW package is going to be installed:
  libldb1

The following packages are going to be upgraded:
  aaa_base aaa_base-extras akonadi-runtime akregator alsa
bootsplash-branding-openSUSE cifs-utils filesystem gpg2 gpg2-lang
gstreamer-0_10-plugin-gnomevfs
  gstreamer-0_10-plugins-base gstreamer-0_10-plugins-base-lang
gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-lang hugin
insserv iproute2 iptables
  kaddressbook kate kde4-filesystem kde4-l10n-de
kdeartwork4-screensaver kdeartwork4-weatherwallpapers
kdenetwork4-filesharing kdepim4 kdepim4-runtime
  kdepim4-wizards kdnssd kernel-desktop kernel-desktop-devel
kernel-devel kernel-firmware kget kmail knotes kompare kontact kopete
korganizer krdc krfb
  libakonadiprotocolinternals1 libao4 libao-plugin4-esd libao-plugins4
libasound2 libassuan0 libgpgme11 libgpod4 libgpod-tools
libgstapp-0_10-0
  libgstinterfaces-0_10-0 libgudev-1_0-0 libjack0 libkdepim4 libpulse0
libpulse-browse0 libpulse-mainloop-glib0 libqt4 libqt4-qt3support
libqt4-sql libqt4-sql-mysql
  libqt4-sql-sqlite libqt4-x11 libQtWebKit4 libreoffice
libreoffice-base libreoffice-base-drivers-mysql
libreoffice-base-extensions libreoffice-calc
  libreoffice-calc-extensions libreoffice-components libreoffice-draw
libreoffice-draw-extensions libreoffice-filters
libreoffice-filters-optional
  libreoffice-help-de libreoffice-help-en-US libreoffice-impress
libreoffice-impress-extensions libreoffice-kde4 libreoffice-l10n-de
libreoffice-l10n-extras
  libreoffice-libs-core libreoffice-libs-extern libreoffice-libs-gui
libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-ure libreoffice-writer
  libreoffice-writer-extensions libsmbclient0 libsndfile libtalloc2
libtdb1 libtevent0 libudev0 libupower-glib1 libwbclient0 marble
marble-data mc mkinitrd openvpn
  plasma-addons plasma-addons-marble plasma-theme-aya
polkit-default-privs preload preload-kmp-desktop procps pulseaudio
pulseaudio-esound-compat
  pulseaudio-module-bluetooth pulseaudio-module-jack
pulseaudio-module-lirc pulseaudio-module-x11
pulseaudio-module-zeroconf pulseaudio-utils python-kde4 python-qt4
  samba samba-client samba-krb-printing samba-winbind screen udev
upower vim vim-base vim-data vorbis-tools vorbis-tools-lang

The following packages are going to be downgraded:
  ark bluedevil bluedevil-lang btrfsprogs choqok digikam digikam-lang
dolphin gwenview kaffeine kcalc kcharselect kcolorchooser
kde4-kgreeter-plugins kdebase4
  kdebase4-libkonq kdebase4-nsplugin kdebase4-openSUSE
kdebase4-runtime kdebase4-runtime-branding-openSUSE kdebase4-session
kdebase4-workspace
  kdebase4-workspace-branding-openSUSE kdebase4-workspace-ksysguardd
kdebase4-workspace-liboxygenstyle kdegames4
kdegames4-carddecks-default
  kdegames4-carddecks-other kdegraphics4 kdelibs4
kdelibs4-branding-openSUSE kdelibs4-core kdemultimedia4 kdepasswd
kdepimlibs4 kdesvn kdialog kdm
  kdm-branding-openSUSE keditbookmarks kfind kgamma kgpg kio_audiocd
kio_kamera kio_sysinfo kio_sysinfo-branding-openSUSE kipi-plugins
kipi-plugins-acquireimage
  kipi-plugins-lang kmag kmahjongg kmines kmix kmousetool konqueror
konqueror-plugins konsole kpat kreversi kruler kscd ksnapshot ksudoku
kwalletmanager kwin kwrite
  libakonadi4 libepub0 libexiv2-10 libkcddb4 libkcompactdisc4
libkdcraw9 libkde4 libkdecore4 libkdegames4 libkdepimlibs4 libkexiv2-9
libkipi8 libkonq5 libksane0
  libksuseinstall1 libsvnqt6 okular oxygen-icon-theme
oxygen-icon-theme-large oxygen-icon-theme-scalable python-kdebase4
sweeper

The following package is going to change vendor:
  libassuan0  openSUSE -> obs://build.opensuse.org/openSUSE:Tumbleweed


136 packages to upgrade, 89 to downgrade, 1 new, 1 to change vendor.

And this is only zypper up:

sudo zypper up
Loading repository data...
Reading installed packages...

The following package updates will NOT be installed:
  libassuan0 libfreebl3 libldb0 libsoftokn3 MozillaFirefox
MozillaFirefox-branding-openSUSE MozillaFirefox-translations-common
mozilla-kde4-integration mozilla-nspr
  mozilla-nss mozilla-nss-certs MozillaThunderbird

The following NEW package is going to be installed:
  libldb1

The following packages are going to be upgraded:
  aaa_base aaa_base-extras akonadi-runtime akregator alsa bind-libs
bind-utils bootsplash-branding-openSUSE cifs-utils cron cronie
filesystem gimp gimp-help-browser
  gimp-plugins-python gpg2 gpg2-lang gstreamer-0_10-plugin-gnomevfs
gstreamer-0_10-plugins-base gstreamer-0_10-plugins-base-lang
gstreamer-0_10-plugins-good
  gstreamer-0_10-plugins-good-lang hugin icedtea-web insserv iproute2
iptables kaddressbook kate kde4-filesystem kde4-l10n-de
kdeartwork4-screensaver
  kdeartwork4-weatherwallpapers kdenetwork4-filesharing kdepim4
kdepim4-runtime kdepim4-wizards kdnssd kernel-desktop
kernel-desktop-devel kernel-devel
  kernel-firmware kget kmail knotes kompare kontact kopete korganizer
krdc krfb libakonadiprotocolinternals1 libao4 libao-plugin4-esd
libao-plugins4 libapr1
  libapr-util1 libasound2 libfreetype6 libgimp-2_0-0 libgimpui-2_0-0
libgpgme11 libgpod4 libgpod-tools libgstapp-0_10-0
libgstinterfaces-0_10-0 libgudev-1_0-0
  libjack0 libkdepim4 libpulse0 libpulse-browse0
libpulse-mainloop-glib0 libqt4 libqt4-qt3support libqt4-sql
libqt4-sql-mysql libqt4-sql-sqlite libqt4-x11
  libQtWebKit4 libreoffice libreoffice-base
libreoffice-base-drivers-mysql libreoffice-base-extensions
libreoffice-calc libreoffice-calc-extensions
  libreoffice-components libreoffice-draw libreoffice-draw-extensions
libreoffice-filters libreoffice-filters-optional libreoffice-help-de
libreoffice-help-en-US
  libreoffice-impress libreoffice-impress-extensions libreoffice-kde4
libreoffice-l10n-de libreoffice-l10n-extras libreoffice-libs-core
libreoffice-libs-extern
  libreoffice-libs-gui libreoffice-mailmerge libreoffice-math
libreoffice-pyuno libreoffice-ure libreoffice-writer
libreoffice-writer-extensions libsmbclient0
  libsndfile libsnmp25 libsoup-2_4-1 libtalloc2 libtdb1 libtevent0
libudev0 libupower-glib1 libwbclient0 libxml2 libzypp marble
marble-data mc mdadm mkinitrd
  MozillaFirefox MozillaFirefox-translations-common openvpn
permissions plasma-addons plasma-addons-marble plasma-theme-aya
polkit-default-privs preload
  preload-kmp-desktop procps pulseaudio pulseaudio-esound-compat
pulseaudio-module-bluetooth pulseaudio-module-jack
pulseaudio-module-lirc pulseaudio-module-x11
  pulseaudio-module-zeroconf pulseaudio-utils python-kde4 python-qt4
python-satsolver samba samba-client samba-krb-printing samba-winbind
satsolver-tools screen
  snmp-mibs sysvinit sysvinit-tools telnet udev udisks upower vim
vim-base vim-data vorbis-tools vorbis-tools-lang zypper

164 packages to upgrade, 1 new.

I also disabled the Mozilla repository, did zypper ref, and then
zypper dup --from Tumbleweed, and it shows the same number of packages
to be upgraded and downgrades, as it was before, so looks like the
Mozilla repo has nothing to do with that:

sudo zypper ref
Repository 'Tumbleweed' is up to date.
Repository 'openSUSE-11.4-Non-Oss' is up to date.
Repository 'openSUSE-11.4-Oss' is up to date.
Repository 'openSUSE-11.4-Update' is up to date.
All repositories have been refreshed.

--
Svetoslav Milenov (Sunny)

Artificial Intelligence is no match for natural stupidity.
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Thumbleweed zypper dup asks for downgrades

gregkh
On Fri, Aug 05, 2011 at 11:30:13AM -0500, Sunny wrote:

> On Fri, Aug 5, 2011 at 9:55 AM, Greg KH <[hidden email]> wrote:
> > Sometimes downgrades happen, when something goes wrong and we need to
> > "downgrade" back to the 11.4 versions of packages.  But that's really
> > only happened once, when I botched the first major KDE update.  It
> > shouldn't still be happening now.
> >
> > Can you post a list of the repos that you have (output of 'zypper lr -d'
> > is good)?
> >
>
> Thanks Greg,
>
> the output of zypper lr is weird to be placed in an email, that's why
> I put the zypper ref output:

Why is it "wierd"?  It's what we need here.

> sudo zypper ref
> Retrieving repository 'Tumbleweed' metadata [done]
> Building repository 'Tumbleweed' cache [done]
> Retrieving repository 'Mozilla' metadata [done]
> Building repository 'Mozilla' cache [done]

What is this repo for?

> Repository 'openSUSE-11.4-Non-Oss' is up to date.
> Repository 'openSUSE-11.4-Oss' is up to date.
> Retrieving repository 'openSUSE-11.4-Update' metadata [done]
> Building repository 'openSUSE-11.4-Update' cache [done]
> All repositories have been refreshed.
>
> sudo zypper dup --from Tumbleweed

Don't do that, just do a simple 'zypper dup' please.

> Loading repository data...
> Reading installed packages...
> Computing distribution upgrade...
>
> The following NEW package is going to be installed:
>   libldb1
>
> The following packages are going to be upgraded:
>   aaa_base aaa_base-extras akonadi-runtime akregator alsa
> bootsplash-branding-openSUSE cifs-utils filesystem gpg2 gpg2-lang
> gstreamer-0_10-plugin-gnomevfs
>   gstreamer-0_10-plugins-base gstreamer-0_10-plugins-base-lang
> gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-lang hugin
> insserv iproute2 iptables
>   kaddressbook kate kde4-filesystem kde4-l10n-de
> kdeartwork4-screensaver kdeartwork4-weatherwallpapers
> kdenetwork4-filesharing kdepim4 kdepim4-runtime
>   kdepim4-wizards kdnssd kernel-desktop kernel-desktop-devel
> kernel-devel kernel-firmware kget kmail knotes kompare kontact kopete
> korganizer krdc krfb
>   libakonadiprotocolinternals1 libao4 libao-plugin4-esd libao-plugins4
> libasound2 libassuan0 libgpgme11 libgpod4 libgpod-tools
> libgstapp-0_10-0
>   libgstinterfaces-0_10-0 libgudev-1_0-0 libjack0 libkdepim4 libpulse0
> libpulse-browse0 libpulse-mainloop-glib0 libqt4 libqt4-qt3support
> libqt4-sql libqt4-sql-mysql
>   libqt4-sql-sqlite libqt4-x11 libQtWebKit4 libreoffice
> libreoffice-base libreoffice-base-drivers-mysql
> libreoffice-base-extensions libreoffice-calc
>   libreoffice-calc-extensions libreoffice-components libreoffice-draw
> libreoffice-draw-extensions libreoffice-filters
> libreoffice-filters-optional
>   libreoffice-help-de libreoffice-help-en-US libreoffice-impress
> libreoffice-impress-extensions libreoffice-kde4 libreoffice-l10n-de
> libreoffice-l10n-extras
>   libreoffice-libs-core libreoffice-libs-extern libreoffice-libs-gui
> libreoffice-mailmerge libreoffice-math libreoffice-pyuno
> libreoffice-ure libreoffice-writer
>   libreoffice-writer-extensions libsmbclient0 libsndfile libtalloc2
> libtdb1 libtevent0 libudev0 libupower-glib1 libwbclient0 marble
> marble-data mc mkinitrd openvpn
>   plasma-addons plasma-addons-marble plasma-theme-aya
> polkit-default-privs preload preload-kmp-desktop procps pulseaudio
> pulseaudio-esound-compat
>   pulseaudio-module-bluetooth pulseaudio-module-jack
> pulseaudio-module-lirc pulseaudio-module-x11
> pulseaudio-module-zeroconf pulseaudio-utils python-kde4 python-qt4
>   samba samba-client samba-krb-printing samba-winbind screen udev
> upower vim vim-base vim-data vorbis-tools vorbis-tools-lang
>
> The following packages are going to be downgraded:
>   ark bluedevil bluedevil-lang btrfsprogs choqok digikam digikam-lang
> dolphin gwenview kaffeine kcalc kcharselect kcolorchooser
> kde4-kgreeter-plugins kdebase4
>   kdebase4-libkonq kdebase4-nsplugin kdebase4-openSUSE
> kdebase4-runtime kdebase4-runtime-branding-openSUSE kdebase4-session
> kdebase4-workspace
>   kdebase4-workspace-branding-openSUSE kdebase4-workspace-ksysguardd
> kdebase4-workspace-liboxygenstyle kdegames4
> kdegames4-carddecks-default
>   kdegames4-carddecks-other kdegraphics4 kdelibs4
> kdelibs4-branding-openSUSE kdelibs4-core kdemultimedia4 kdepasswd
> kdepimlibs4 kdesvn kdialog kdm
>   kdm-branding-openSUSE keditbookmarks kfind kgamma kgpg kio_audiocd
> kio_kamera kio_sysinfo kio_sysinfo-branding-openSUSE kipi-plugins
> kipi-plugins-acquireimage
>   kipi-plugins-lang kmag kmahjongg kmines kmix kmousetool konqueror
> konqueror-plugins konsole kpat kreversi kruler kscd ksnapshot ksudoku
> kwalletmanager kwin kwrite
>   libakonadi4 libepub0 libexiv2-10 libkcddb4 libkcompactdisc4
> libkdcraw9 libkde4 libkdecore4 libkdegames4 libkdepimlibs4 libkexiv2-9
> libkipi8 libkonq5 libksane0
>   libksuseinstall1 libsvnqt6 okular oxygen-icon-theme
> oxygen-icon-theme-large oxygen-icon-theme-scalable python-kdebase4
> sweeper
>
> The following package is going to change vendor:
>   libassuan0  openSUSE -> obs://build.opensuse.org/openSUSE:Tumbleweed
>
>
> 136 packages to upgrade, 89 to downgrade, 1 new, 1 to change vendor.
>
> And this is only zypper up:
>
> sudo zypper up
> Loading repository data...
> Reading installed packages...
>
> The following package updates will NOT be installed:
>   libassuan0 libfreebl3 libldb0 libsoftokn3 MozillaFirefox
> MozillaFirefox-branding-openSUSE MozillaFirefox-translations-common
> mozilla-kde4-integration mozilla-nspr
>   mozilla-nss mozilla-nss-certs MozillaThunderbird
>
> The following NEW package is going to be installed:
>   libldb1
>
> The following packages are going to be upgraded:
>   aaa_base aaa_base-extras akonadi-runtime akregator alsa bind-libs
> bind-utils bootsplash-branding-openSUSE cifs-utils cron cronie
> filesystem gimp gimp-help-browser
>   gimp-plugins-python gpg2 gpg2-lang gstreamer-0_10-plugin-gnomevfs
> gstreamer-0_10-plugins-base gstreamer-0_10-plugins-base-lang
> gstreamer-0_10-plugins-good
>   gstreamer-0_10-plugins-good-lang hugin icedtea-web insserv iproute2
> iptables kaddressbook kate kde4-filesystem kde4-l10n-de
> kdeartwork4-screensaver
>   kdeartwork4-weatherwallpapers kdenetwork4-filesharing kdepim4
> kdepim4-runtime kdepim4-wizards kdnssd kernel-desktop
> kernel-desktop-devel kernel-devel
>   kernel-firmware kget kmail knotes kompare kontact kopete korganizer
> krdc krfb libakonadiprotocolinternals1 libao4 libao-plugin4-esd
> libao-plugins4 libapr1
>   libapr-util1 libasound2 libfreetype6 libgimp-2_0-0 libgimpui-2_0-0
> libgpgme11 libgpod4 libgpod-tools libgstapp-0_10-0
> libgstinterfaces-0_10-0 libgudev-1_0-0
>   libjack0 libkdepim4 libpulse0 libpulse-browse0
> libpulse-mainloop-glib0 libqt4 libqt4-qt3support libqt4-sql
> libqt4-sql-mysql libqt4-sql-sqlite libqt4-x11
>   libQtWebKit4 libreoffice libreoffice-base
> libreoffice-base-drivers-mysql libreoffice-base-extensions
> libreoffice-calc libreoffice-calc-extensions
>   libreoffice-components libreoffice-draw libreoffice-draw-extensions
> libreoffice-filters libreoffice-filters-optional libreoffice-help-de
> libreoffice-help-en-US
>   libreoffice-impress libreoffice-impress-extensions libreoffice-kde4
> libreoffice-l10n-de libreoffice-l10n-extras libreoffice-libs-core
> libreoffice-libs-extern
>   libreoffice-libs-gui libreoffice-mailmerge libreoffice-math
> libreoffice-pyuno libreoffice-ure libreoffice-writer
> libreoffice-writer-extensions libsmbclient0
>   libsndfile libsnmp25 libsoup-2_4-1 libtalloc2 libtdb1 libtevent0
> libudev0 libupower-glib1 libwbclient0 libxml2 libzypp marble
> marble-data mc mdadm mkinitrd
>   MozillaFirefox MozillaFirefox-translations-common openvpn
> permissions plasma-addons plasma-addons-marble plasma-theme-aya
> polkit-default-privs preload
>   preload-kmp-desktop procps pulseaudio pulseaudio-esound-compat
> pulseaudio-module-bluetooth pulseaudio-module-jack
> pulseaudio-module-lirc pulseaudio-module-x11
>   pulseaudio-module-zeroconf pulseaudio-utils python-kde4 python-qt4
> python-satsolver samba samba-client samba-krb-printing samba-winbind
> satsolver-tools screen
>   snmp-mibs sysvinit sysvinit-tools telnet udev udisks upower vim
> vim-base vim-data vorbis-tools vorbis-tools-lang zypper
>
> 164 packages to upgrade, 1 new.
>
> I also disabled the Mozilla repository, did zypper ref, and then
> zypper dup --from Tumbleweed, and it shows the same number of packages
> to be upgraded and downgrades, as it was before, so looks like the
> Mozilla repo has nothing to do with that:
>
> sudo zypper ref
> Repository 'Tumbleweed' is up to date.
> Repository 'openSUSE-11.4-Non-Oss' is up to date.
> Repository 'openSUSE-11.4-Oss' is up to date.
> Repository 'openSUSE-11.4-Update' is up to date.
> All repositories have been refreshed.

It looks sane, I'd try the 'zypper dup' on its own, and then just accept
the update and see what happens.  I don't know why you have such a big
kde downgrade, that is odd, but things happen...

greg k-h
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Thumbleweed zypper dup asks for downgrades

Sunny_bg
On Fri, Aug 5, 2011 at 11:40 AM, Greg KH <[hidden email]> wrote:
>
> Why is it "wierd"?  It's what we need here.
>

>> sudo zypper dup --from Tumbleweed
>
> Don't do that, just do a simple 'zypper dup' please.
>

sudo zypper dup
root's password:
Warning: You are about to do a distribution upgrade with all enabled
repositories. Make sure these repositories are compatible before you
continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

The following NEW packages are going to be installed:
  libldb1 openSUSE-release-ftp

The following packages are going to be upgraded:
  aaa_base aaa_base-extras akonadi-runtime akregator alsa bind-libs
bind-utils bootsplash-branding-openSUSE cifs-utils cron cronie
filesystem gimp gimp-help-browser
  gimp-plugins-python gpg2 gpg2-lang gstreamer-0_10-plugin-gnomevfs
gstreamer-0_10-plugins-base gstreamer-0_10-plugins-base-lang
gstreamer-0_10-plugins-good
  gstreamer-0_10-plugins-good-lang hugin icedtea-web insserv iproute2
iptables kaddressbook kate kde4-filesystem kde4-l10n-de
kdeartwork4-screensaver
  kdeartwork4-weatherwallpapers kdenetwork4-filesharing kdepim4
kdepim4-runtime kdepim4-wizards kdnssd kernel-desktop
kernel-desktop-devel kernel-devel
  kernel-firmware kget kmail knotes kompare kontact kopete korganizer
krdc krfb libakonadiprotocolinternals1 libao4 libao-plugin4-esd
libao-plugins4 libapr1
  libapr-util1 libasound2 libassuan0 libfreetype6 libgimp-2_0-0
libgimpui-2_0-0 libgpgme11 libgpod4 libgpod-tools libgstapp-0_10-0
libgstinterfaces-0_10-0
  libgudev-1_0-0 libjack0 libkdepim4 libldb0 libpulse0
libpulse-browse0 libpulse-mainloop-glib0 libqt4 libqt4-qt3support
libqt4-sql libqt4-sql-mysql
  libqt4-sql-sqlite libqt4-x11 libQtWebKit4 libreoffice
libreoffice-base libreoffice-base-drivers-mysql
libreoffice-base-extensions libreoffice-calc
  libreoffice-calc-extensions libreoffice-components libreoffice-draw
libreoffice-draw-extensions libreoffice-filters
libreoffice-filters-optional
  libreoffice-help-de libreoffice-help-en-US libreoffice-impress
libreoffice-impress-extensions libreoffice-kde4 libreoffice-l10n-de
libreoffice-l10n-extras
  libreoffice-libs-core libreoffice-libs-extern libreoffice-libs-gui
libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-ure libreoffice-writer
  libreoffice-writer-extensions libsmbclient0 libsndfile libsnmp25
libsoup-2_4-1 libtalloc2 libtdb1 libtevent0 libudev0 libupower-glib1
libwbclient0 libxml2 libzypp
  marble marble-data mc mdadm mkinitrd MozillaFirefox
MozillaFirefox-translations-common MozillaThunderbird openvpn
permissions plasma-addons plasma-addons-marble
  plasma-theme-aya polkit-default-privs preload preload-kmp-desktop
procps pulseaudio pulseaudio-esound-compat pulseaudio-module-bluetooth
pulseaudio-module-jack
  pulseaudio-module-lirc pulseaudio-module-x11
pulseaudio-module-zeroconf pulseaudio-utils python-kde4 python-qt4
python-satsolver samba samba-client
  samba-krb-printing samba-winbind satsolver-tools screen snmp-mibs
sysvinit sysvinit-tools telnet udev udisks upower vim vim-base
vim-data vorbis-tools
  vorbis-tools-lang zypper

The following packages are going to be downgraded:
  ark bluedevil bluedevil-lang btrfsprogs choqok digikam digikam-lang
dolphin grantlee gwenview kaffeine kcalc kcharselect kcolorchooser
kde4-kgreeter-plugins
  kdebase4 kdebase4-libkonq kdebase4-nsplugin kdebase4-openSUSE
kdebase4-runtime kdebase4-runtime-branding-openSUSE kdebase4-session
kdebase4-workspace
  kdebase4-workspace-branding-openSUSE kdebase4-workspace-ksysguardd
kdebase4-workspace-liboxygenstyle kdegames4
kdegames4-carddecks-default
  kdegames4-carddecks-other kdegraphics4 kdelibs4
kdelibs4-branding-openSUSE kdelibs4-core kdemultimedia4 kdepasswd
kdepimlibs4 kdesvn kdialog kdm
  kdm-branding-openSUSE keditbookmarks kfind kgamma kgpg kio_audiocd
kio_kamera kio_sysinfo kio_sysinfo-branding-openSUSE kipi-plugins
kipi-plugins-acquireimage
  kipi-plugins-lang kmag kmahjongg kmines kmix kmousetool konqueror
konqueror-plugins konsole kpat kreversi kruler kscd ksnapshot ksudoku
kwalletmanager kwin kwrite
  libakonadi4 libepub0 libexiv2-10 libkcddb4 libkcompactdisc4
libkdcraw9 libkde4 libkdecore4 libkdegames4 libkdepimlibs4 libkexiv2-9
libkipi8 libkonq5 libksane0
  libksuseinstall1 libsvnqt6 okular oxygen-icon-theme
oxygen-icon-theme-large oxygen-icon-theme-scalable python-kdebase4
sweeper

The following packages are going to change vendor:
  btrfsprogs
obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
  grantlee
obs://build.opensuse.org/KDE:Unstable -> openSUSE
  kdebase4-openSUSE
obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
  kdebase4-runtime-branding-openSUSE
obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
  kdebase4-workspace-branding-openSUSE
obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
  kdelibs4-branding-openSUSE
obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
  kdesvn
obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
  kdm-branding-openSUSE
obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
  kio_sysinfo
obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
  kio_sysinfo-branding-openSUSE
obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
  libassuan0                            openSUSE ->
obs://build.opensuse.org/openSUSE:Tumbleweed
  libldb0
obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
  libsvnqt6
obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
  MozillaThunderbird
obs://build.opensuse.org/mozilla -> openSUSE


167 packages to upgrade, 90 to downgrade, 2 new, 14  to change vendor.

>
> It looks sane, I'd try the 'zypper dup' on its own, and then just accept
> the update and see what happens.  I don't know why you have such a big
> kde downgrade, that is odd, but things happen...

So, yeah, looks like its kde downgrade:

rpm -qa | grep kdebase4-openSUSE
kdebase4-openSUSE-11.4-121.6.x86_64


--
Svetoslav Milenov (Sunny)

Artificial Intelligence is no match for natural stupidity.
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Thumbleweed zypper dup asks for downgrades

gregkh
On Fri, Aug 05, 2011 at 11:48:17AM -0500, Sunny wrote:
> The following packages are going to change vendor:
>   btrfsprogs
> obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
>   grantlee
> obs://build.opensuse.org/KDE:Unstable -> openSUSE
>   kdebase4-openSUSE

You have other repos installed other than Tumbleweed and the base 11.4
repos.  Don't do that and expect things to work.  Disable all of them
and you should be fine.

greg k-h
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Thumbleweed zypper dup asks for downgrades

Sunny_bg
On Fri, Aug 5, 2011 at 12:00 PM, Greg KH <[hidden email]> wrote:

> On Fri, Aug 05, 2011 at 11:48:17AM -0500, Sunny wrote:
>> The following packages are going to change vendor:
>>   btrfsprogs
>> obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
>>   grantlee
>> obs://build.opensuse.org/KDE:Unstable -> openSUSE
>>   kdebase4-openSUSE
>
> You have other repos installed other than Tumbleweed and the base 11.4
> repos.  Don't do that and expect things to work.  Disable all of them
> and you should be fine.
>

Everything else besides Tumbleweed and the openSuse repos are disabled.

If you think about KDE:Unstable, it was not supported for awhile, and
was disabled long ago.

Still, it's strange, even if in the past I have installed something
from that repo, that now it wants to change vendor to the main repo,
and not to Tumbleweed one, where I think more recent versions should
exist.

Anyway, I'll downgrade next week and see how it goes.

Thanks for the help


--
Svetoslav Milenov (Sunny)

Artificial Intelligence is no match for natural stupidity.
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Thumbleweed zypper dup asks for downgrades

Ken Schneider - openSUSE
On 08/05/2011 04:26 PM, Sunny pecked at the keyboard and wrote:

> On Fri, Aug 5, 2011 at 12:00 PM, Greg KH<[hidden email]>  wrote:
>> On Fri, Aug 05, 2011 at 11:48:17AM -0500, Sunny wrote:
>>> The following packages are going to change vendor:
>>>    btrfsprogs
>>> obs://build.opensuse.org/openSUSE:Tumbleweed ->  openSUSE
>>>    grantlee
>>> obs://build.opensuse.org/KDE:Unstable ->  openSUSE
>>>    kdebase4-openSUSE
>>
>> You have other repos installed other than Tumbleweed and the base 11.4
>> repos.  Don't do that and expect things to work.  Disable all of them
>> and you should be fine.
>>
>
> Everything else besides Tumbleweed and the openSuse repos are disabled.
>
> If you think about KDE:Unstable, it was not supported for awhile, and
> was disabled long ago.
>
> Still, it's strange, even if in the past I have installed something
> from that repo, that now it wants to change vendor to the main repo,
> and not to Tumbleweed one, where I think more recent versions should
> exist.

What are the priorities of the repos? The one with the highest priority
will allways win the battle.

>
> Anyway, I'll downgrade next week and see how it goes.
>
> Thanks for the help
>
>


--
Ken Schneider
SuSe since Version 5.2, June 1998
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Thumbleweed zypper dup asks for downgrades

Sunny_bg
On Fri, Aug 5, 2011 at 3:36 PM, Ken Schneider - openSUSE
<[hidden email]> wrote:
> On 08/05/2011 04:26 PM, Sunny pecked at the keyboard and wrote:
>
> What are the priorities of the repos? The one with the highest priority will
> allways win the battle.
>

All are at 99. Should I change some?

Thanks

--
Svetoslav Milenov (Sunny)

Artificial Intelligence is no match for natural stupidity.
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Thumbleweed zypper dup asks for downgrades

John Andrews (swerdna)
On 08/09/2011 10:36 PM, Sunny wrote:

> On Fri, Aug 5, 2011 at 3:36 PM, Ken Schneider - openSUSE
> <[hidden email]>  wrote:
>> On 08/05/2011 04:26 PM, Sunny pecked at the keyboard and wrote:
>>
>> What are the priorities of the repos? The one with the highest priority will
>> allways win the battle.
>>
>
> All are at 99. Should I change some?
>
> Thanks
>
This thread:
http://forums.opensuse.org/english/get-technical-help-here/tumbleweed/463744-new-packages-tumbleweed-how-do-i-get-know-about-them-post2372531.html#post2372531
and in particular post #48 should be of interest.
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Thumbleweed zypper dup asks for downgrades

Malcolm-31
On Tue, 09 Aug 2011 22:52:12 +1000
"John Andrews (swerdna)" <[hidden email]> wrote:

> >>
> >> What are the priorities of the repos? The one with the highest
> >> priority will allways win the battle.
> >>
> >
> > All are at 99. Should I change some?
> >
> > Thanks
> >
> This thread:
> http://forums.opensuse.org/english/get-technical-help-here/tumbleweed/463744-new-packages-tumbleweed-how-do-i-get-know-about-them-post2372531.html#post2372531
> and in particular post #48 should be of interest.
Hi
That should be post #24 ;)

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
up 8:22, 3 users, load average: 0.21, 0.18, 0.15
GPU GeForce 8600 GTS Silent - Driver Version: 280.13


--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Thumbleweed zypper dup asks for downgrades

gregkh
In reply to this post by Sunny_bg
On Tue, Aug 09, 2011 at 07:36:18AM -0500, Sunny wrote:
> On Fri, Aug 5, 2011 at 3:36 PM, Ken Schneider - openSUSE
> <[hidden email]> wrote:
> > On 08/05/2011 04:26 PM, Sunny pecked at the keyboard and wrote:
> >
> > What are the priorities of the repos? The one with the highest priority will
> > allways win the battle.
> >
>
> All are at 99. Should I change some?

If they are all the same, it should be fine.  Are you having problems
with it that way right now?

greg k-h
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Thumbleweed zypper dup asks for downgrades

Sunny_bg
On Tue, Aug 9, 2011 at 8:42 AM, Greg KH <[hidden email]> wrote:

>> All are at 99. Should I change some?
>
> If they are all the same, it should be fine.  Are you having problems
> with it that way right now?
>

Just checked - still says 89 packages to be downgraded.

One of the packages it wants to downgrade is kdebase4. So I pulled
zypper info for it:

Information for package kdebase4:

Repository: @System
Name: kdebase4
Version: 4.6.5-5.1
Arch: x86_64
Vendor: obs://build.opensuse.org/openSUSE:Tumbleweed
Installed: Yes
Status: up-to-date

So, most probably some other package is making it to downgrade.

How do I investigate to see which one requires lower version of kdebase4?

Cheers

--
Svetoslav Milenov (Sunny)

Artificial Intelligence is no match for natural stupidity.
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Thumbleweed zypper dup asks for downgrades

gregkh
On Thu, Aug 11, 2011 at 08:20:23AM -0500, Sunny wrote:

> On Tue, Aug 9, 2011 at 8:42 AM, Greg KH <[hidden email]> wrote:
>
> >> All are at 99. Should I change some?
> >
> > If they are all the same, it should be fine.  Are you having problems
> > with it that way right now?
> >
>
> Just checked - still says 89 packages to be downgraded.
>
> One of the packages it wants to downgrade is kdebase4. So I pulled
> zypper info for it:
>
> Information for package kdebase4:
>
> Repository: @System
> Name: kdebase4
> Version: 4.6.5-5.1
> Arch: x86_64
> Vendor: obs://build.opensuse.org/openSUSE:Tumbleweed
> Installed: Yes
> Status: up-to-date
>
> So, most probably some other package is making it to downgrade.
>
> How do I investigate to see which one requires lower version of kdebase4?

I think you should just allow it to downgrade, as it will go to the
4.6.5-4.1 release, which is still just fine.

If after doing this, you still have problems, please let us know.

greg k-h
--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]