[TW] too many packages "depend" on hack-fonts

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[TW] too many packages "depend" on hack-fonts

Felix Miata-3
# zypper ll | grep hack
#
# zypper up
23 new to be installed:
...
hack-fonts
...
1311 to be upgraded
N
# zypper al hack-fonts
# zypper up
202 updates will not be installed
8 new to be installed
1115 to be upgraded (mostly baloo*, breeze*, libKF5*, libQt5, plasma*, etc.)

How can a hard dependency on any specific ttf fonts package be justified?
--
"Wisdom is supreme; therefore get wisdom. Whatever else you
get, get wisdom." Proverbs 4:7 (New Living Translation)

 Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***  http://fm.no-ip.com/
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [TW] too many packages "depend" on hack-fonts

Wolfgang Bauer
Am Dienstag, 3. Juli 2018, 01:08:48 schrieb Felix Miata:

> # zypper ll | grep hack
> #
> # zypper up
> 23 new to be installed:
> ...
> hack-fonts
> ...
> 1311 to be upgraded
> N
> # zypper al hack-fonts
> # zypper up
> 202 updates will not be installed
> 8 new to be installed
> 1115 to be upgraded (mostly baloo*, breeze*, libKF5*, libQt5, plasma*, etc.)
>
> How can a hard dependency on any specific ttf fonts package be justified?

This topic again?

AFAICT, there's just *one* package that requires hack-fonts:
$ rpm -e --test hack-fonts
error: Failed dependencies:
        hack-fonts is needed by (installed) plasma5-integration-
plugi-5.13.2-1.1.x86_64

The reason for this is that "Hack" is the default monospace font in a Plasma5
environment.

If it's not installed, there would be a fallback to any other font, which
might not even be a monospaced one (which would in turn break konsole, e.g.).

It's only getting pulled in by plasma5-workspace in the end though.

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [TW] too many packages "depend" on hack-fonts

Wolfgang Bauer
Am Donnerstag, 5. Juli 2018, 23:18:33 schrieb Wolfgang Bauer:
> AFAICT, there's just *one* package that requires hack-fonts:
> $ rpm -e --test hack-fonts
> error: Failed dependencies:
>         hack-fonts is needed by (installed) plasma5-integration-
> plugi-5.13.2-1.1.x86_64
And as I obviously made a copy/paste error, here's another try:

wolfi@amiga:~/klinkstatus> rpm -e --test hack-fonts
error: Failed dependencies:
        hack-fonts is needed by (installed) plasma5-integration-
plugin-5.13.2-1.1.x86_64
wolfi@amiga:~/klinkstatus>

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [TW] too many packages "depend" on hack-fonts

Anton Aylward-2
On 05/07/18 05:31 PM, Wolfgang Bauer wrote:

> Am Donnerstag, 5. Juli 2018, 23:18:33 schrieb Wolfgang Bauer:
>> AFAICT, there's just *one* package that requires hack-fonts:
>> $ rpm -e --test hack-fonts
>> error: Failed dependencies:
>>         hack-fonts is needed by (installed) plasma5-integration-
>> plugi-5.13.2-1.1.x86_64
> And as I obviously made a copy/paste error, here's another try:
>
> wolfi@amiga:~/klinkstatus> rpm -e --test hack-fonts
> error: Failed dependencies:
>         hack-fonts is needed by (installed) plasma5-integration-
> plugin-5.13.2-1.1.x86_64
> wolfi@amiga:~/klinkstatus>
>
main:~ # rpm -e --test plasma5-integration-plugin
error: Failed dependencies:
        plasma5-integration-plugin is needed by (installed)
frameworkintegration-plugin-5.32.0-1.1.x86_64
        plasma5-integration-plugin = 5.9.4 is needed by (installed)
plasma5-integration-plugin-lang-5.9.4-4.6.1.noarch
main:~ # rpm -e --test frameworkintegration-plugin
error: Failed dependencies:
        frameworkintegration-plugin is needed by (installed)
plasma5-workspace-5.8.7-11.1.x86_64
main:~ # rpm -e --test plasma5-workspace
error: Failed dependencies:
        plasma5-workspace >= 5.5.5 is needed by (installed)
plasma5-mediacenter-5.5.5-9.1.x86_64
        plasma5-workspace is needed by (installed)
sddm-theme-openSUSE-42.1.1-235.1.noarch
        plasma5-workspace is needed by (installed)
patterns-openSUSE-kde_plasma-20170518-6.1.x86_64
        plasma5-workspace = 5.8.7 is needed by (installed)
plasma5-workspace-lang-5.8.7-11.1.noarch
        plasma5-workspace >= 5.8.7 is needed by (installed)
plasma5-desktop-5.8.7.1-3.1.x86_64
        plasma5-workspace >= 5.8.7 is needed by (installed)
plasma5-workspace-branding-openSUSE-42.1.1-19.1.noarch
        plasma5-workspace >= 5.8.7 is needed by (installed)
plasma5-session-5.8.7-2.1.noarch
main:~ #

SDDM-Theme ???

If I try setting my login to SDDM I get the SDDM themed login prompt but it
fails to log me in
sysconfig/displaymanager-## Path:       Desktop/Display manager
sysconfig/displaymanager-## Description:        settings to generate a proper
displaymanager config
sysconfig/displaymanager:## Type:
string(kdm,xdm,gdm,wdm,entrance,console,lightdm,sddm)
       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
sysconfig/displaymanager-## Default:    ""
sysconfig/displaymanager-#
sysconfig/displaymanager-# Here you can set the default Display manager
(kdm/xdm/gdm/wdm/entrance/console).
sysconfig/displaymanager-# all changes in this file require a restart of the
displaymanager
sysconfig/displaymanager-#
sysconfig/displaymanager-DISPLAYMANAGER="kdm"
                                         ^^^  this works
                                                as does gdm,lightdm
                                                but not sddm



--
But it doesn't have to be this way. We can do things better. We need to stop
doing business as usual and start focusing on end-to-end quality. Security needs
to be built in from the start -- not slapped on after the fact.
        -- Gene Spafford, at the 23rd National Information Systems Security Conference
in October 2000
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [TW] too many packages "depend" on hack-fonts

Felix Miata-3
Anton Aylward composed on 2018-07-05 22:28 (UTC-0400):

> Wolfgang Bauer wrote:

>> Wolfgang Bauer composed:

>>> AFAICT, there's just *one* package that requires hack-fonts:
>>> $ rpm -e --test hack-fonts
>>> error: Failed dependencies:
>>>         hack-fonts is needed by (installed) plasma5-integration-
>>> plugi-5.13.2-1.1.x86_64
>> And as I obviously made a copy/paste error, here's another try:

>> wolfi@amiga:~/klinkstatus> rpm -e --test hack-fonts
>> error: Failed dependencies:
>>         hack-fonts is needed by (installed) plasma5-integration-
>> plugin-5.13.2-1.1.x86_64
>> wolfi@amiga:~/klinkstatus>

> main:~ # rpm -e --test plasma5-integration-plugin
> error: Failed dependencies:
>         plasma5-integration-plugin is needed by (installed)
> frameworkintegration-plugin-5.32.0-1.1.x86_64
>         plasma5-integration-plugin = 5.9.4 is needed by (installed)
> plasma5-integration-plugin-lang-5.9.4-4.6.1.noarch
> main:~ # rpm -e --test frameworkintegration-plugin
> error: Failed dependencies:
>         frameworkintegration-plugin is needed by (installed)
> plasma5-workspace-5.8.7-11.1.x86_64
> main:~ # rpm -e --test plasma5-workspace
> error: Failed dependencies:
>         plasma5-workspace >= 5.5.5 is needed by (installed)
> plasma5-mediacenter-5.5.5-9.1.x86_64
>         plasma5-workspace is needed by (installed)
> sddm-theme-openSUSE-42.1.1-235.1.noarch
>         plasma5-workspace is needed by (installed)
> patterns-openSUSE-kde_plasma-20170518-6.1.x86_64
>         plasma5-workspace = 5.8.7 is needed by (installed)
> plasma5-workspace-lang-5.8.7-11.1.noarch
>         plasma5-workspace >= 5.8.7 is needed by (installed)
> plasma5-desktop-5.8.7.1-3.1.x86_64
>         plasma5-workspace >= 5.8.7 is needed by (installed)
> plasma5-workspace-branding-openSUSE-42.1.1-19.1.noarch
>         plasma5-workspace >= 5.8.7 is needed by (installed)
> plasma5-session-5.8.7-2.1.noarch
> main:~ #

> SDDM-Theme ???

> If I try setting my login to SDDM I get the SDDM themed login prompt but it
> fails to log me in
> sysconfig/displaymanager-## Path:       Desktop/Display manager
> sysconfig/displaymanager-## Description:        settings to generate a proper
> displaymanager config
> sysconfig/displaymanager:## Type:
> string(kdm,xdm,gdm,wdm,entrance,console,lightdm,sddm)
>        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> sysconfig/displaymanager-## Default:    ""
> sysconfig/displaymanager-#
> sysconfig/displaymanager-# Here you can set the default Display manager
> (kdm/xdm/gdm/wdm/entrance/console).
> sysconfig/displaymanager-# all changes in this file require a restart of the
> displaymanager
> sysconfig/displaymanager-#
> sysconfig/displaymanager-DISPLAYMANAGER="kdm"
>                                          ^^^  this works
> as does gdm,lightdm
> but not sddm

I've linked this thread to the 2 year old bug I forgot about:
http://bugzilla.opensuse.org/show_bug.cgi?id=992519
onerous font package requirements
--
"Wisdom is supreme; therefore get wisdom. Whatever else you
get, get wisdom." Proverbs 4:7 (New Living Translation)

 Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***  http://fm.no-ip.com/
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [TW] too many packages "depend" on hack-fonts

Carlos E. R.-2
In reply to this post by Anton Aylward-2
On 2018-07-06 04:28, Anton Aylward wrote:

> SDDM-Theme ???
>
> If I try setting my login to SDDM I get the SDDM themed login prompt but it
> fails to log me in
> sysconfig/displaymanager-## Path:       Desktop/Display manager

Remember that this method does not work in Leap 15 and I assume it
neither does on TW, and this thread is about TW.

Instead, you have to use "update-alternatives".

--
Cheers / Saludos,

                Carlos E. R.
                (from 42.3 x86_64 "Malachite" at Telcontar)


signature.asc (188 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [TW] too many packages "depend" on hack-fonts

Wolfgang Bauer
In reply to this post by Anton Aylward-2
Am Donnerstag, 5. Juli 2018, 22:28:59 schrieb Anton Aylward:
> main:~ # rpm -e --test plasma5-integration-plugin
> error: Failed dependencies:

Yes, as I already mentioned, plasma5-integration-plugin is required by
plasma5-workspace, one of the main packages of Plasma5 (it contains
plasmashell e.g.).

And plasma5-integration-plugin is necessary to have Qt5 applications (and KF5
applications therefore) to actually use and respect Plasma5's theme/style
settings, which include having "Hack" as default monospace font.

> SDDM-Theme ???

The breeze-openSUSE SDDM theme (in sddm-theme-openSUSE) is based on KDE's
upstream breeze theme (contained in plasma5-workspace).
And it won't work without plasma5-workspace being installed.

SDDM itself ships with a few other themes though, that don't require Plasma5
to be installed.

You can set the theme to be used in /etc/sddm.conf, or in a custom file in
/etc/sddm.conf.d/.

> If I try setting my login to SDDM I get the SDDM themed login prompt but it
> fails to log me in
> ...
> sysconfig/displaymanager-DISPLAYMANAGER="kdm"
>                                          ^^^  this works
> as does gdm,lightdm
> but not sddm

As has been mentioned by Carlos meanwhile, /etc/sysconfig/displaymanager's
DISPLAYMANAGER setting is not respected anymore on Tumbleweed and Leap 15.0.

If it does influence the displaymanager, you are obviously still using Leap
42.x or earlier.

But as I understand it, your problem is that you cannot login if you use sddm?

You'd need to be more specific.
In particular, does it only happen with Plasma5 or any other session as well?
(IceWM should be installed by default as well)

Better start a new thread about this though.
This is unrelated to this one in any case.

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]