[TW] Kdenlive badly broken..

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[TW] Kdenlive badly broken..

Daniele
Hi guys, I don't know since when but know, Kdenlive is almost unseable.
Lots of segfault.
There's a problem with filters/effects.
To reproduce: add simple img then add Crop and trasform->Trasform. As
soon I try to change effects properties, segfault.
Same with Position and Zoom and others..

The upstream version (appimage) is working fine !

Any hints ?

Thanks,
Daniele.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [TW] Kdenlive badly broken..

Wolfgang Bauer
Am Montag, 21. Mai 2018, 20:07:32 CEST schrieb Daniele:
> There's a problem with filters/effects.
> To reproduce: add simple img then add Crop and trasform->Trasform. As
> soon I try to change effects properties, segfault.
> Same with Position and Zoom and others..

Hm, doesn't seem to crash here.
What backtrace do you get?

Do you maybe have the option "Use GPU processing" enabled in the Playback
settings?
Try to disable it, AFAIK it can make things unstable.

Kind Regards,
Wolfgang



--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [TW] Kdenlive badly broken..

Daniele
Il 22/05/2018 11:19, Wolfgang Bauer ha scritto:
> Am Montag, 21. Mai 2018, 20:07:32 CEST schrieb Daniele:
>> There's a problem with filters/effects.
>> To reproduce: add simple img then add Crop and trasform->Trasform. As
>> soon I try to change effects properties, segfault.
>> Same with Position and Zoom and others..
>
> Hm, doesn't seem to crash here.
> What backtrace do you get?

https://paste.opensuse.org/40232635 (without debug symbol)
>
> Do you maybe have the option "Use GPU processing" enabled in the Playback
> settings?
> Try to disable it, AFAIK it can make things unstable.
Nope.
I don't use kdenlive since the beginning of January, no problem at that
time :)

Thanks,
Daniele.


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [TW] Kdenlive badly broken..

Wolfgang Bauer
Am Dienstag, 22. Mai 2018, 18:28:19 schrieb Daniele:
> Il 22/05/2018 11:19, Wolfgang Bauer ha scritto:
> > What backtrace do you get?
>
> https://paste.opensuse.org/40232635 (without debug symbol)

It crashes in libmlt, the backtrace looks the same as the one in
https://bugs.kde.org/show_bug.cgi?id=394275 .

So it's apparently caused by a change in mlt 6.8.0. TW doesn't have that yet,
but libmlt has been updated about 2 weeks ago to a git snapshot shortly before
the release to be able to build the latest shotcut version...
* Sun May 06 2018 [hidden email]
- Update to 6.6.0+git20180502 to enable shotcut 18.05 to build.

Should be fixed in kdenlive 18.04.2 (to be released in two weeks) it seems,
I'll have a look tomorrow if I can find the fix and add it to our package.

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [TW] Kdenlive badly broken..

Daniele
Il 22/05/2018 23:59, Wolfgang Bauer ha scritto:

> Am Dienstag, 22. Mai 2018, 18:28:19 schrieb Daniele:
>> Il 22/05/2018 11:19, Wolfgang Bauer ha scritto:
>>> What backtrace do you get?
>>
>> https://paste.opensuse.org/40232635 (without debug symbol)
>
> It crashes in libmlt, the backtrace looks the same as the one in
> https://bugs.kde.org/show_bug.cgi?id=394275 .
>
> So it's apparently caused by a change in mlt 6.8.0. TW doesn't have that yet,
> but libmlt has been updated about 2 weeks ago to a git snapshot shortly before
> the release to be able to build the latest shotcut version...
> * Sun May 06 2018 [hidden email]
> - Update to 6.6.0+git20180502 to enable shotcut 18.05 to build.
>
> Should be fixed in kdenlive 18.04.2 (to be released in two weeks) it seems,
> I'll have a look tomorrow if I can find the fix and add it to our package.
>
> Kind Regards,
> Wolfgang
>
Thanks !

Daniele.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [TW] Kdenlive badly broken..

Wolfgang Bauer
In reply to this post by Wolfgang Bauer
Am Dienstag, 22. Mai 2018, 23:59:58 schrieb Wolfgang Bauer:
> I'll have a look tomorrow if I can find the fix and add it to our package.

Wasn't hard to find, an update is on the way to Tumbleweed:
https://api.opensuse.org/request/show/611493

You can install the package from here for now if you want:
https://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Applications/openSUSE_Factory/

Btw, I was able to reproduce the crash meanwhile, but not with the "Transform"
effect and only with changing *certain* properties. E.g. changing the
background color in "Rotate and Shear" or "Position and Zoom" made it crash
here, or adding the "Box Blur" effect (as mentioned in the bug report)
triggered the crash right away.
The patch indeed fixed all these crashes for me.

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [TW] Kdenlive badly broken..[FIXED]

Daniele
Il 23/05/2018 11:44, Wolfgang Bauer ha scritto:

> Am Dienstag, 22. Mai 2018, 23:59:58 schrieb Wolfgang Bauer:
>> I'll have a look tomorrow if I can find the fix and add it to our package.
>
> Wasn't hard to find, an update is on the way to Tumbleweed:
> https://api.opensuse.org/request/show/611493
>
> You can install the package from here for now if you want:
> https://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Applications/openSUSE_Factory/
>
> Btw, I was able to reproduce the crash meanwhile, but not with the "Transform"
> effect and only with changing *certain* properties. E.g. changing the
> background color in "Rotate and Shear" or "Position and Zoom" made it crash
> here, or adding the "Box Blur" effect (as mentioned in the bug report)
> triggered the crash right away.
> The patch indeed fixed all these crashes for me.

Yep, fixed !!

Thanks for the quick fix !!

Daniele.

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]