Slow website

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Slow website

Robert Xu
Hi all,

Why does openbuildservice.org connect to beans.opensuse.org?
Not only does the request time out, it also slows down the overall
loading of the page...


--
Robert Xu :: protocol.by/rxu
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Slow website

Stephan Kulow-3
On 02.05.2013 02:42, Robert Xu wrote:
> Hi all,
>
> Why does openbuildservice.org connect to beans.opensuse.org?
To count the visitors and what they are doing with the site - otherwise
we have no base to improve upon.

> Not only does the request time out, it also slows down the overall
> loading of the page...
>
It works fine here and the call is supposed to be async, e.g. not block
the browser. Please verify that using some web developer tools.

Greetings, Stephan

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Slow website

Srinidhi B
 >>> On 02/5/2013 at 12:56 PM, Stephan Kulow <[hidden email]> wrote:
> On 02.05.2013 02:42, Robert Xu wrote:
> > Hi all,
> >
> > Why does openbuildservice.org connect to beans.opensuse.org?
> To count the visitors and what they are doing with the site - otherwise
> we have no base to improve upon.
>

Actually, I've been observing this "slowness" myself - not just with openbuildservice.org, but with software.opensuse.org too. Content loads correctly, but the page doesn't finish loading. Fetching of piwik.js takes a long time before finishing / aborting - not always.

> > Not only does the request time out, it also slows down the overall
> > loading of the page...
> >
> It works fine here and the call is supposed to be async, e.g. not block
> the browser. Please verify that using some web developer tools.
>

I was about to share the details from Firebug, but found this:

$ wget -S  http://beans.opensuse.org/piwik/piwik.js
--2013-05-02 13:34:14--  http://beans.opensuse.org/piwik/piwik.js
Resolving beans.opensuse.org (beans.opensuse.org)... 195.135.221.152, 2001:67c:2178:8::21
Connecting to beans.opensuse.org (beans.opensuse.org)|195.135.221.152|:80... failed: Connection timed out.
Connecting to beans.opensuse.org (beans.opensuse.org)|2001:67c:2178:8::21|:80... failed: Network is unreachable.

Probably web server issue on beans.o.o - I'm able to ping beans.o.o.

Srinidhi.

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Slow website

Stephan Kulow-3
On 02.05.2013 10:12, Srinidhi B wrote:

>  >>> On 02/5/2013 at 12:56 PM, Stephan Kulow <[hidden email]> wrote:
>> On 02.05.2013 02:42, Robert Xu wrote:
>>> Hi all,
>>>
>>> Why does openbuildservice.org connect to beans.opensuse.org?
>> To count the visitors and what they are doing with the site - otherwise
>> we have no base to improve upon.
>>
>
> Actually, I've been observing this "slowness" myself - not just with openbuildservice.org, but with software.opensuse.org too. Content loads correctly, but the page doesn't finish loading. Fetching of piwik.js takes a long time before finishing / aborting - not always.
>
>>> Not only does the request time out, it also slows down the overall
>>> loading of the page...
>>>
>> It works fine here and the call is supposed to be async, e.g. not block
>> the browser. Please verify that using some web developer tools.
>>
>
> I was about to share the details from Firebug, but found this:
>
> $ wget -S  http://beans.opensuse.org/piwik/piwik.js
> --2013-05-02 13:34:14--  http://beans.opensuse.org/piwik/piwik.js
> Resolving beans.opensuse.org (beans.opensuse.org)... 195.135.221.152, 2001:67c:2178:8::21
> Connecting to beans.opensuse.org (beans.opensuse.org)|195.135.221.152|:80... failed: Connection timed out.
> Connecting to beans.opensuse.org (beans.opensuse.org)|2001:67c:2178:8::21|:80... failed: Network is unreachable.
>
> Probably web server issue on beans.o.o - I'm able to ping beans.o.o.
>
That's an issue, but if a failing beans is causing a problem we have
another one: the async calls do not work.

Greetings, Stephan



--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]