Select postgresql-devel in Leap42.2

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Select postgresql-devel in Leap42.2

Thomas Andrejak
Hello,

I have a package that is in unresolvable state because of this message :

have choice for postgresql-devel needed by libpreludedb-devel:
postgresql-devel postgresql94-devel postgresql93-devel

I don't know the full process but can someone select one
postgresql-devel for Leap42.2 ?

https://build.opensuse.org/project/show/openSUSE:Leap:42.2:Staging:adi:12

Thanks

Regards

Thomas
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Select postgresql-devel in Leap42.2

Darin Perusich-3
It really depends on which version of postgresql you want to support,
the default being pg94. Having said that I would think that given both
pg93 and pg94 are available your libpreludedb should support both
versions of the database, otherwise if someone is using pg93 and wants
to use prelude in conjunction with it the libraries will not be
available. The same would be case if/when pg95 and pg96 become
available, which they already are for those leveraging the
server:database:postgresql repository.

For the purposes of defining a choice, someone may want to add
'postgresql-devel' to the Prefer: in the Project Config, libpreludedb
is not throwing a choice error so I couldn't say why prelude-manager
is.

While it's too late for 42.2, if you want to see how we've built PG
extensions to support multiple version of PG take a look at packages
like orafce, plr, pgfincore, pgaudit, etc, in the project repo
https://build.opensuse.org/project/show/server:database:postgresql.
--
Later,
Darin


On Tue, Sep 27, 2016 at 4:03 AM, Thomas Andrejak
<[hidden email]> wrote:

> Hello,
>
> I have a package that is in unresolvable state because of this message :
>
> have choice for postgresql-devel needed by libpreludedb-devel:
> postgresql-devel postgresql94-devel postgresql93-devel
>
> I don't know the full process but can someone select one
> postgresql-devel for Leap42.2 ?
>
> https://build.opensuse.org/project/show/openSUSE:Leap:42.2:Staging:adi:12
>
> Thanks
>
> Regards
>
> Thomas
> --
> To unsubscribe, e-mail: [hidden email]
> To contact the owner, e-mail: [hidden email]
>
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Select postgresql-devel in Leap42.2

Thomas Andrejak
I'm asking because of what you point out : libpreludedb is OK so
prelued-manager should be but I can't figured out why.

Prelude-manager is where all prelude modules are connected so it is
important to add it to 42.2 because all other prelude modules are in
42.2

I will look after your link but if someone can help me, it would be great :)

Regards

Thomas

2016-09-27 15:03 GMT+02:00 Darin Perusich <[hidden email]>:

> It really depends on which version of postgresql you want to support,
> the default being pg94. Having said that I would think that given both
> pg93 and pg94 are available your libpreludedb should support both
> versions of the database, otherwise if someone is using pg93 and wants
> to use prelude in conjunction with it the libraries will not be
> available. The same would be case if/when pg95 and pg96 become
> available, which they already are for those leveraging the
> server:database:postgresql repository.
>
> For the purposes of defining a choice, someone may want to add
> 'postgresql-devel' to the Prefer: in the Project Config, libpreludedb
> is not throwing a choice error so I couldn't say why prelude-manager
> is.
>
> While it's too late for 42.2, if you want to see how we've built PG
> extensions to support multiple version of PG take a look at packages
> like orafce, plr, pgfincore, pgaudit, etc, in the project repo
> https://build.opensuse.org/project/show/server:database:postgresql.
> --
> Later,
> Darin
>
>
> On Tue, Sep 27, 2016 at 4:03 AM, Thomas Andrejak
> <[hidden email]> wrote:
>> Hello,
>>
>> I have a package that is in unresolvable state because of this message :
>>
>> have choice for postgresql-devel needed by libpreludedb-devel:
>> postgresql-devel postgresql94-devel postgresql93-devel
>>
>> I don't know the full process but can someone select one
>> postgresql-devel for Leap42.2 ?
>>
>> https://build.opensuse.org/project/show/openSUSE:Leap:42.2:Staging:adi:12
>>
>> Thanks
>>
>> Regards
>>
>> Thomas
>> --
>> To unsubscribe, e-mail: [hidden email]
>> To contact the owner, e-mail: [hidden email]
>>
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Select postgresql-devel in Leap42.2

Thomas Andrejak
I can't find out why .... If someone can help me :)

what is the best way ? Do I have to update the ".spec" of
prelude-manager to force pg9.4 ?

Thanks

Thomas

2016-09-27 18:15 GMT+02:00 Thomas Andrejak <[hidden email]>:

> I'm asking because of what you point out : libpreludedb is OK so
> prelued-manager should be but I can't figured out why.
>
> Prelude-manager is where all prelude modules are connected so it is
> important to add it to 42.2 because all other prelude modules are in
> 42.2
>
> I will look after your link but if someone can help me, it would be great :)
>
> Regards
>
> Thomas
>
> 2016-09-27 15:03 GMT+02:00 Darin Perusich <[hidden email]>:
>> It really depends on which version of postgresql you want to support,
>> the default being pg94. Having said that I would think that given both
>> pg93 and pg94 are available your libpreludedb should support both
>> versions of the database, otherwise if someone is using pg93 and wants
>> to use prelude in conjunction with it the libraries will not be
>> available. The same would be case if/when pg95 and pg96 become
>> available, which they already are for those leveraging the
>> server:database:postgresql repository.
>>
>> For the purposes of defining a choice, someone may want to add
>> 'postgresql-devel' to the Prefer: in the Project Config, libpreludedb
>> is not throwing a choice error so I couldn't say why prelude-manager
>> is.
>>
>> While it's too late for 42.2, if you want to see how we've built PG
>> extensions to support multiple version of PG take a look at packages
>> like orafce, plr, pgfincore, pgaudit, etc, in the project repo
>> https://build.opensuse.org/project/show/server:database:postgresql.
>> --
>> Later,
>> Darin
>>
>>
>> On Tue, Sep 27, 2016 at 4:03 AM, Thomas Andrejak
>> <[hidden email]> wrote:
>>> Hello,
>>>
>>> I have a package that is in unresolvable state because of this message :
>>>
>>> have choice for postgresql-devel needed by libpreludedb-devel:
>>> postgresql-devel postgresql94-devel postgresql93-devel
>>>
>>> I don't know the full process but can someone select one
>>> postgresql-devel for Leap42.2 ?
>>>
>>> https://build.opensuse.org/project/show/openSUSE:Leap:42.2:Staging:adi:12
>>>
>>> Thanks
>>>
>>> Regards
>>>
>>> Thomas
>>> --
>>> To unsubscribe, e-mail: [hidden email]
>>> To contact the owner, e-mail: [hidden email]
>>>
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Select postgresql-devel in Leap42.2

Thomas Andrejak
Hello,

I did the work in this SR : https://build.opensuse.org/request/show/430480

Before it is too late for Leap42.2, is it possible to accept this SR ?

Thanks

Regards

Thomas

2016-09-29 7:44 GMT+02:00 Thomas Andrejak <[hidden email]>:

> I can't find out why .... If someone can help me :)
>
> what is the best way ? Do I have to update the ".spec" of
> prelude-manager to force pg9.4 ?
>
> Thanks
>
> Thomas
>
> 2016-09-27 18:15 GMT+02:00 Thomas Andrejak <[hidden email]>:
>> I'm asking because of what you point out : libpreludedb is OK so
>> prelued-manager should be but I can't figured out why.
>>
>> Prelude-manager is where all prelude modules are connected so it is
>> important to add it to 42.2 because all other prelude modules are in
>> 42.2
>>
>> I will look after your link but if someone can help me, it would be great :)
>>
>> Regards
>>
>> Thomas
>>
>> 2016-09-27 15:03 GMT+02:00 Darin Perusich <[hidden email]>:
>>> It really depends on which version of postgresql you want to support,
>>> the default being pg94. Having said that I would think that given both
>>> pg93 and pg94 are available your libpreludedb should support both
>>> versions of the database, otherwise if someone is using pg93 and wants
>>> to use prelude in conjunction with it the libraries will not be
>>> available. The same would be case if/when pg95 and pg96 become
>>> available, which they already are for those leveraging the
>>> server:database:postgresql repository.
>>>
>>> For the purposes of defining a choice, someone may want to add
>>> 'postgresql-devel' to the Prefer: in the Project Config, libpreludedb
>>> is not throwing a choice error so I couldn't say why prelude-manager
>>> is.
>>>
>>> While it's too late for 42.2, if you want to see how we've built PG
>>> extensions to support multiple version of PG take a look at packages
>>> like orafce, plr, pgfincore, pgaudit, etc, in the project repo
>>> https://build.opensuse.org/project/show/server:database:postgresql.
>>> --
>>> Later,
>>> Darin
>>>
>>>
>>> On Tue, Sep 27, 2016 at 4:03 AM, Thomas Andrejak
>>> <[hidden email]> wrote:
>>>> Hello,
>>>>
>>>> I have a package that is in unresolvable state because of this message :
>>>>
>>>> have choice for postgresql-devel needed by libpreludedb-devel:
>>>> postgresql-devel postgresql94-devel postgresql93-devel
>>>>
>>>> I don't know the full process but can someone select one
>>>> postgresql-devel for Leap42.2 ?
>>>>
>>>> https://build.opensuse.org/project/show/openSUSE:Leap:42.2:Staging:adi:12
>>>>
>>>> Thanks
>>>>
>>>> Regards
>>>>
>>>> Thomas
>>>> --
>>>> To unsubscribe, e-mail: [hidden email]
>>>> To contact the owner, e-mail: [hidden email]
>>>>
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Select postgresql-devel in Leap42.2

Dominique Leuenberger / DimStar
On Thu, 2016-10-06 at 07:46 +0200, Thomas Andrejak wrote:
> Hello,
>
> I did the work in this SR : https://build.opensuse.org/request/show/4
> 30480
>
> Before it is too late for Leap42.2, is it possible to accept this SR
> ?

This has been accepted to openSUSE:Leap:42.2 by now.

Cheers,
Dominique

signature.asc (169 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Select postgresql-devel in Leap42.2

gregfreemyer
On Thu, Oct 6, 2016 at 10:12 AM, Dominique Leuenberger / DimStar
<[hidden email]> wrote:

> On Thu, 2016-10-06 at 07:46 +0200, Thomas Andrejak wrote:
>> Hello,
>>
>> I did the work in this SR : https://build.opensuse.org/request/show/4
>> 30480
>>
>> Before it is too late for Leap42.2, is it possible to accept this SR
>> ?
>
> This has been accepted to openSUSE:Leap:42.2 by now.


Thomas,

Assuming that is the last building block for the Prelude SIEM,
congratulations on getting that in Leap 42.2

FYI: I have suricata now in server:monitoring.  Darin Perusich is
working on getting it to build for SLE12 in that project.  Mostly
linking in the packages it is dependent on that aren't part of  SLE12.

For others, suricata is a IPS/IDS/Network Monitor that uses libprelude
to communicate from the sensors on the various servers back to the
main oversight server.  Maybe it will end up in Factory/Leap 42.3/SLE
SP2 eventually.  For now it is new server:monitoring.

Greg
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Select postgresql-devel in Leap42.2

Thomas Andrejak
In reply to this post by Dominique Leuenberger / DimStar
Thanks !

Regards

Thomas

2016-10-06 16:12 GMT+02:00 Dominique Leuenberger / DimStar
<[hidden email]>:

> On Thu, 2016-10-06 at 07:46 +0200, Thomas Andrejak wrote:
>> Hello,
>>
>> I did the work in this SR : https://build.opensuse.org/request/show/4
>> 30480
>>
>> Before it is too late for Leap42.2, is it possible to accept this SR
>> ?
>
> This has been accepted to openSUSE:Leap:42.2 by now.
>
> Cheers,
> Dominique
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]