Problems with yast2

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with yast2

Markus Koßmann-3
After updating my factory  installation yesterday evening  " yast2 sw_single"
fails with:
 635 Error while creating client module sw_single

y2log shows
[...]
2007-12-11 19:38:23 <1> linux-n04x(5049) [wfm] Y2WFMComponent.cc(import):698
Y2WFMComponent::import (SlideShow)
2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
clients/sw_single.ycp:21 Loading module 'Language' failed
2007-12-11 19:38:23 <3> linux-n04x(5049) [libycp] Import.cc(import):97 No
matching component found
2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
clients/sw_single.ycp:21 Import 'Language' failed...
2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
clients/sw_single.ycp:21 Could not create its namespace
2007-12-11 19:38:23 <3> linux-n04x(5049) [libycp] Bytecode.cc(readFile):1161
Caught invalid bytecode in '/usr/share/YaST2/modul            
es/SlideShow.ybc'
2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
clients/sw_single.ycp:21 Loading module 'SlideShow' failed
2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
clients/sw_single.ycp:21 Import 'SlideShow' failed...
2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
clients/sw_single.ycp:21 Could not create its namespace
2007-12-11 19:38:23 <3> linux-n04x(5049) [libycp] Bytecode.cc(readFile):1161
Caught invalid bytecode in '/usr/share/YaST2/modul            
es/PackageCallbacks.ybc'
007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter] clients/sw_single.ycp:23
Loading module 'SlideShow' failed
2007-12-11 19:38:23 <3> linux-n04x(5049) [Parser] clients/sw_single.ycp:23
Can't load module 'SlideShow'.
[...]
2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
clients/sw_single.ycp:43 Loading module 'Packages' failed
2007-12-11 19:38:23 <3> linux-n04x(5049) [Parser] clients/sw_single.ycp:43
Can't load module 'Packages'.
2007-12-11 19:38:23 <3> linux-n04x(5049) [Parser] clients/sw_single.ycp:139
Unknown namespace 'SlideShow'. Missing 'import'?
2007-12-11 19:38:23 <3> linux-n04x(5049) [Parser] clients/sw_single.ycp:139
syntax error, unexpected SCANNER_ERROR
2007-12-11 19:38:23 <1> linux-n04x(5049) [wfm] Y2CCWFM.cc(createInLevel):148
Parsing finished
2007-12-11 19:38:23 <3> linux-n04x(5049) [liby2]
genericfrontend.cc(print_error):635 Error while creating client module
sw_single

Known problem or should I write a bug report ? Is there a workaround ?
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problems with yast2

Lukas Ocilka
Markus Koßmann wrote:

> After updating my factory  installation yesterday evening  " yast2 sw_single"
> fails with:
>  635 Error while creating client module sw_single
>
> y2log shows
> [...]
> 2007-12-11 19:38:23 <1> linux-n04x(5049) [wfm] Y2WFMComponent.cc(import):698
> Y2WFMComponent::import (SlideShow)
> 2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
> clients/sw_single.ycp:21 Loading module 'Language' failed
> 2007-12-11 19:38:23 <3> linux-n04x(5049) [libycp] Import.cc(import):97 No
> matching component found
> 2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
> clients/sw_single.ycp:21 Import 'Language' failed...
> 2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
> clients/sw_single.ycp:21 Could not create its namespace
> 2007-12-11 19:38:23 <3> linux-n04x(5049) [libycp] Bytecode.cc(readFile):1161
> Caught invalid bytecode in '/usr/share/YaST2/modul            
> es/SlideShow.ybc'
It seems to show two different problems:

* Loading module 'Language' failed
  Import.cc(import):97 No matching component found

  - yast2-country has been split into two packages recently
    (yast2-country and yast2-country-data). Language.ycp is newly in
    yast2-country-data.
  - Make sure you have yast2-country-data package installed.
  - (Wrong dependencies in some YaST RPM?)
  - If you have updated yast2-country to a new verson, Language.ycp
    probably got deleted.

* Caught invalid bytecode in SlideShow.ybc

  - Probably old yast2-packager (SlideShow is part of it). You need to
    update that package too.
  - Maybe caused be the very same mistake by wrong RPM dependencies.

You can still use 'zypper' to update your packages when YaST is broken :)

Bye
Lukas

PS: Adding yast-devel into Cc:


signature.asc (262 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [yast-devel] Re: Problems with yast2

Jiri Suchomel
On st 12. prosince 2007, Lukas Ocilka wrote:

> Markus Koßmann wrote:
> > After updating my factory  installation yesterday evening  " yast2
> > sw_single" fails with:
> >  635 Error while creating client module sw_single
> >
> > y2log shows
> > [...]
> > 2007-12-11 19:38:23 <1> linux-n04x(5049) [wfm]
> > Y2WFMComponent.cc(import):698 Y2WFMComponent::import (SlideShow)
> > 2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
> > clients/sw_single.ycp:21 Loading module 'Language' failed
> > 2007-12-11 19:38:23 <3> linux-n04x(5049) [libycp] Import.cc(import):97 No
> > matching component found
> > 2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
> > clients/sw_single.ycp:21 Import 'Language' failed...
> > 2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
> > clients/sw_single.ycp:21 Could not create its namespace
> > 2007-12-11 19:38:23 <3> linux-n04x(5049) [libycp]
> > Bytecode.cc(readFile):1161 Caught invalid bytecode in
> > '/usr/share/YaST2/modul
> > es/SlideShow.ybc'
>
> It seems to show two different problems:
>
> * Loading module 'Language' failed
>   Import.cc(import):97 No matching component found
>
>   - yast2-country has been split into two packages recently
>     (yast2-country and yast2-country-data). Language.ycp is newly in
>     yast2-country-data.
>   - Make sure you have yast2-country-data package installed.
>   - (Wrong dependencies in some YaST RPM?)
>   - If you have updated yast2-country to a new verson, Language.ycp
>     probably got deleted.

It would be strange: yast2-country-data is required by yast2-country, so I
don't expect such problem since the time both packages are available on the
installation sources.
Do you have both packages installed?

Jiri

--
Jiri Suchomel

SUSE LINUX, s.r.o.                            e-mail: [hidden email]
Lihovarská 1060/12                            tel: +420 284 028 960
190 00 Praha 9, Czech Republic                http://www.suse.cz
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problems with yast2 and zypper was: Problems with yast2

Markus Koßmann-3
In reply to this post by Lukas Ocilka
Am Mittwoch, 12. Dezember 2007 schrieb Lukas Ocilka:
[...]

>
> It seems to show two different problems:
>
> * Loading module 'Language' failed
>   Import.cc(import):97 No matching component found
>
>   - yast2-country has been split into two packages recently
>     (yast2-country and yast2-country-data). Language.ycp is newly in
>     yast2-country-data.
>   - Make sure you have yast2-country-data package installed.
>   - (Wrong dependencies in some YaST RPM?)
>   - If you have updated yast2-country to a new verson, Language.ycp
>     probably got deleted.
>
> * Caught invalid bytecode in SlideShow.ybc
>
>   - Probably old yast2-packager (SlideShow is part of it). You need to
>     update that package too.
>   - Maybe caused be the very same mistake by wrong RPM dependencies.
>
> You can still use 'zypper' to update your packages when YaST is broken :)
>
Unfortunately today a "zypper up -t package" has decided to destroy itself  on
that installation.

This is the output of "zypper up -t package"  before I did enter 'y'  (problem
marked):
The following packages are going to be upgraded:
  apparmor-docs desktop-data-SuSE gnome-doc-utils gnome2-user-docs
gnucash-docs
inst-source-utils kdelibs3-devel-doc latex2html-pngicons
libqt4-devel-doc-data
manufacturer-PPDs oxygen-icon-theme oxygen-icon-theme-scalable release-notes
suse-build-key xdg-utils ImageMagick ImageMagick-devel LibVNCServer
OpenOffice_org-Quickstarter a2ps alsa-plugins apparmor-parser aqbanking
aqbanking-lang avahi avahi-compat-mDNSResponder-devel blktrace bluez-utils
bootsplash-theme-SuSE cdrkit-cdrtools-compat coreutils cryptsetup ddd
desktop-file-utils device-mapper dmraid dvd+rw-tools evms evms-gui
filesystem filters
foomatic-filters freetype genisoimage gftp gftp-lang gitk git-email git-core
gltt
gnome-mag gstreamer010-plugins-bad gstreamer010-plugins-ugly gtkmm2 gtkspell
gwenview icedax iproute2 iptables kaffeine kcm_gtk kde4-kmahjongg
kde4-kmines kde4-kpat
kde4-kreversi kde4-ksudoku kdeartwork3-kscreensaver kdeartwork3-xscreensaver
kdegames3 kdegames3-card kdegames4 kdelibs3 kdelibs3-32bit
kdelibs3-default-style
kdelibs3-default-style-32bit kdelibs3-devel kdelibs3-arts kdelibs3-doc
kdelibs4
kdelibs4-core kdemultimedia3 kdemultimedia3-CD kdemultimedia3-arts
kdemultimedia3-mixer kdenetwork3 kdenetwork3-InstantMessenger
kdenetwork3-news
kdenetwork3-vnc kdepimlibs4 kdeutils3 kdetv kernel-default kernel-source
kerry
kio_beagle kio_slp kio_iso kio_ipodslave knights konversation kpartx krecord
ksudoku
ktorrent kwin-decor-suse2 libMagick10 libMagick++10 libWand10 libakode
libakode-devel
libavahi-client3 libavahi-devel libavahi-common3 libavahi-core5
libavahi-glib-devel
libavahi-glib1 libavahi-ui0 libdjvulibre15 libdns_sd libkde4 libkdecore4
libkdegames4
libkdepimlibs4 libkexiv2 libkipi0 libopensc2 libopenct1 libqscintilla2-2
libqimageblitz-devel libqimageblitz4 libqt4 libqt4-dbus-1 libqt4-devel
libqt4-devel-doc libqt4-qt3support libqt4-sql libqt4-sql-mysql
libqt4-sql-postgresql libqt4-sql-unixODBC libqt4-sql-sqlite libqt4-x11
libsoprano4
libsoprano-devel lilo lvm2 metacity metacity-lang mozilla-nss
mozilla-nss-32bit
mpt-status multipath-tools openct opensc openssh openssh-askpass orca parted
pcsc-lite
pessulus pessulus-lang pstoedit python-opengl qtcurve-gtk2
qtcurve-gtk2-32bit
qtcurve-kde resmgr rsync sabayon sabayon-lang skencil splashy strigi
strigi-devel
suspend tix wodim wpa_supplicant xlockmore yast2-core yast2-xml yauap zenity
zsh

The following packages are going to be REMOVED:
  hal-resmgr libzypp gnome-main-menu gnome-utils brasero evolution
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
cups-backends k3b
gnome-pilot pm-utils gnome-vfs2 gnome-applets libnjb banshee hal-palm
gstreamer010-plugins-good libipoddevice0 hal NetworkManager-gnome
gnome-media
libgphoto2 totem cups-autoconfig libipoddevice kdebase3-SuSE totem-plugin
kpowersave
sax2 kdebase3 gnome-volume-manager evolution-pilot NetworkManager
gnome-python-desktop nautilus-cd-burner gnome-mount hal-devel kio_sysinfo
NetworkManager-kde hwinfo sysconfig bluez-gnome gnome-power-manager
control-center2
gimp

Overall download size: 316.6 M. After the operation, 192.3 M will be freed.
Continue? [yes/no]:


How to fix that problem ?  I allready tried to mount that instalation to /mnt  
on a working 10.3 installation and use the zypper -R /mnt up -t package.
But zypper insisted to use the repos configured for 10.3.  
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problems with yast2

Bugzilla from jpr@novell.com
In reply to this post by Lukas Ocilka

On Wed, 2007-12-12 at 12:34 +0100, Lukas Ocilka wrote:

> Markus Koßmann wrote:
> > After updating my factory  installation yesterday evening  " yast2 sw_single"
> > fails with:
> >  635 Error while creating client module sw_single
> >
> > y2log shows
> > [...]
> > 2007-12-11 19:38:23 <1> linux-n04x(5049) [wfm] Y2WFMComponent.cc(import):698
> > Y2WFMComponent::import (SlideShow)
> > 2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
> > clients/sw_single.ycp:21 Loading module 'Language' failed
> > 2007-12-11 19:38:23 <3> linux-n04x(5049) [libycp] Import.cc(import):97 No
> > matching component found
> > 2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
> > clients/sw_single.ycp:21 Import 'Language' failed...
> > 2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
> > clients/sw_single.ycp:21 Could not create its namespace
> > 2007-12-11 19:38:23 <3> linux-n04x(5049) [libycp] Bytecode.cc(readFile):1161
> > Caught invalid bytecode in '/usr/share/YaST2/modul            
> > es/SlideShow.ybc'

I *think* this is a problem with yast-gtk only atm because of the mod-ui
rewrite.

-JP
--
JP Rosevear <[hidden email]>
Novell, Inc.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]