Problems with Xen workers

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with Xen workers

Stefan Seyfried
Hi,

in my private OBS instance (running 2.8.2), I'm seeing strange build issues on my OBS worker running with Xen. The other
worker running with KVM does not show the problem.
Most of the time it is testsuites failing.

Example of a jemalloc build:

[   55s] === test/unit/pages ===
[   55s] test_pages_huge:test/unit/pages.c:13: Failed assertion: (jet_pages_huge(pages, ((size_t)(1U << 12)))) ==
(false) --> true != false: Unexpected pages_huge() result
[   55s] test_pages_huge:test/unit/pages.c:15: Failed assertion: (jet_pages_nohuge(pages, ((size_t)(1U << 12)))) ==
(false) --> true != false: Unexpected pages_nohuge() result
[   55s] test_pages_huge: fail
[   55s] --- pass: 0/1, skip: 0/1, fail: 1/1 ---

The same test passes if the build is on the KVM worker.

Another issue was the test case of the obs-server package failing to connect to localhost:5000 (?) with something like
"address family not supported". Sorry, I did not copy the message back then before I changed the _constraints to force
the build onto the KVM host.
Both failing builds are for SLES12-SP2, in the obs-server case I'd personally suspect kernel-obs-build being broken for
Xen (missing a module), but for the jemalloc case I'm a bit stumped.

Is openSUSE still using Xen workers at all? (if not, I'd just switch my xen worker to KVM and be done with it. I'm not
really interested in encountering errors nobody else is seeing because no one is using that code ;-)

Best regards,
--
Stefan Seyfried

"For a successful technology, reality must take precedence over
 public relations, for nature cannot be fooled." -- Richard Feynman
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problems with Xen workers

Stefan Seyfried
Obviously, this was too much text.

So This time, let's make it a short question: does the build.opensuse.org infrastructure still use Xen workers?

[ ] Yes
[ ] No


On 05.09.2017 13:09, Stefan Seyfried wrote:
> Hi,
>
> in my private OBS instance (running 2.8.2), I'm seeing strange build issues on my OBS worker running with Xen. The other
> worker running with KVM does not show the problem.
> Most of the time it is testsuites failing.--
Stefan Seyfried

"For a successful technology, reality must take precedence over
 public relations, for nature cannot be fooled." -- Richard Feynman
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problems with Xen workers

Andreas Schwab
On Sep 08 2017, Stefan Seyfried <[hidden email]> wrote:

> So This time, let's make it a short question: does the build.opensuse.org infrastructure still use Xen workers?

Not according to osc workerinfo.

Andreas.

--
Andreas Schwab, [hidden email]
GPG Key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276 4ED5
"And now for something completely different."
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problems with Xen workers

Stefan Seyfried
Am 08.09.2017 um 11:28 schrieb Andreas Schwab:
> On Sep 08 2017, Stefan Seyfried <[hidden email]> wrote:
>
>> So This time, let's make it a short question: does the build.opensuse.org infrastructure still use Xen workers?
>
> Not according to osc workerinfo.

Thanks. In this case, I'll also get off that dead horse ;-)
--
Stefan Seyfried

"For a successful technology, reality must take precedence over
 public relations, for nature cannot be fooled." -- Richard Feynman
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]