Quantcast

Problem with latest "zypper dup --no-allow-vendor-change -l"

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problem with latest "zypper dup --no-allow-vendor-change -l"

ianseeks-4
Hi

I ran this after the new snapshot announcement, is this a problem?
zypper ref went fine but i got these messages on the "dup"

Warning: You are about to do a distribution upgrade with all enabled
repositories. Make sure these repositories are compatible before you continue.
See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
18 Problems:
Problem: kcoreaddons-lang-5.32.0-134.1.noarch requires kcoreaddons = 5.32.0,
but this requirement cannot be provided
Problem: kdoctools-lang-5.32.0-132.1.noarch requires kdoctools = 5.32.0, but
this requirement cannot be provided
Problem: libKF5Auth5-lang-5.32.0-125.1.noarch requires libKF5Auth5 = 5.32.0,
but this requirement cannot be provided
Problem: libKF5Codecs5-lang-5.32.0-112.1.noarch requires libKF5Codecs5 =
5.32.0, but this requirement cannot be provided
Problem: libKF5Completion5-lang-5.32.0-113.1.noarch requires libKF5Completion5
= 5.32.0, but this requirement cannot be provided
Problem: libKF5ConfigCore5-lang-5.32.0-133.1.noarch requires libKF5ConfigCore5 =
5.32.0, but this requirement cannot be provided
Problem: libKF5DBusAddons5-lang-5.32.0-107.1.noarch requires libKF5DBusAddons5
= 5.32.0, but this requirement cannot be provided
Problem: libKF5DNSSD5-lang-5.32.0-97.1.noarch requires libKF5DNSSD5 = 5.32.0,
but this requirement cannot be provided
Problem: libKF5I18n5-lang-5.32.0-139.1.noarch requires libKF5I18n5 = 5.32.0,
but this requirement cannot be provided
Problem: libKF5ItemViews5-lang-5.32.0-106.1.noarch requires libKF5ItemViews5 =
5.32.0, but this requirement cannot be provided
Problem: libKF5JobWidgets5-lang-5.32.0-111.1.noarch requires libKF5JobWidgets5
= 5.32.0, but this requirement cannot be provided
Problem: libKF5Notifications5-lang-5.32.0-124.1.noarch requires
libKF5Notifications5 = 5.32.0, but this requirement cannot be provided
Problem: libKF5Pty5-lang-5.32.0-102.1.noarch requires libKF5Pty5 = 5.32.0, but
this requirement cannot be provided
Problem: libKF5Solid5-lang-5.32.0-118.1.noarch requires libKF5Solid5 = 5.32.0,
but this requirement cannot be provided
Problem: libKF5SonnetCore5-lang-5.32.0-122.1.noarch requires libKF5SonnetCore5
= 5.32.0, but this requirement cannot be provided
Problem: libKF5UnitConversion5-lang-5.32.0-107.1.noarch requires
libKF5UnitConversion5 = 5.32.0, but this requirement cannot be provided
Problem: libKF5WidgetsAddons5-lang-5.32.0-121.1.noarch requires
libKF5WidgetsAddons5 = 5.32.0, but this requirement cannot be provided
Problem: libKF5WindowSystem5-lang-5.32.0-130.1.noarch requires
libKF5WindowSystem5 = 5.32.0, but this requirement cannot be provided

Problem: kcoreaddons-lang-5.32.0-134.1.noarch requires kcoreaddons = 5.32.0,
but this requirement cannot be provided
  uninstallable providers: kcoreaddons-5.32.0-134.1.i586[Frameworks5]
                   kcoreaddons-5.32.0-134.1.x86_64[Frameworks5]
 Solution 1: install kcoreaddons-5.32.0-134.1.x86_64 (with vendor change)
  openSUSE  -->  obs://build.opensuse.org/KDE
 Solution 2: install kcoreaddons-lang-5.31.0-1.1.noarch (with vendor change)
  obs://build.opensuse.org/KDE  -->  openSUSE
 Solution 3: break kcoreaddons-lang-5.32.0-134.1.noarch by ignoring some of
its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c]
(c):


Regards

Ian
--
opensuse:tumbleweed:20170316
Qt: 5.7.1
KDE Frameworks: 5.31.0
KDE Plasma: 5.9.2
kwin 5.9.3
kmail2 5.4.3
akonadiserver 5.4.3
Kernel:  4.10.3-1-default
Nouveau:  1.0.13_2.2

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem with latest "zypper dup --no-allow-vendor-change -l"

Luca Beltrame
Il giorno Mon, 20 Mar 2017 15:53:59 +0000
ianseeks <[hidden email]> ha scritto:

> Hi
>
> I ran this after the new snapshot announcement, is this a problem?
> zypper ref went fine but i got these messages on the "dup"

Don't use KDE:Frameworks5 at the moment, we just imported KF 5.32 and a
lot of stuff is still broken.

attachment0 (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem with latest "zypper dup --no-allow-vendor-change -l"

ianseeks-4
On Monday, 20 March 2017 15:59:36 GMT Luca Beltrame wrote:

> Il giorno Mon, 20 Mar 2017 15:53:59 +0000
>
> ianseeks <[hidden email]> ha scritto:
> > Hi
> >
> > I ran this after the new snapshot announcement, is this a problem?
> > zypper ref went fine but i got these messages on the "dup"
>
> Don't use KDE:Frameworks5 at the moment, we just imported KF 5.32 and a
> lot of stuff is still broken.
Ok thanks. Any ETA for KF5 3.2 being unbroken? :o)

--
opensuse:tumbleweed:20170316
Qt: 5.7.1
KDE Frameworks: 5.31.0
KDE Plasma: 5.9.2
kwin 5.9.3
kmail2 5.4.3
akonadiserver 5.4.3
Kernel:  4.10.3-1-default
Nouveau:  1.0.13_2.2

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem with latest "zypper dup --no-allow-vendor-change -l"

Luca Beltrame
Il giorno Mon, 20 Mar 2017 16:20:16 +0000
ianseeks <[hidden email]> ha scritto:

> Ok thanks. Any ETA for KF5 3.2 being unbroken? :o)

Normally there's no need to use the KDE devel projects (unless you're
crazy as me and run off the Unstable projects), submissions are made to
TW fairly quickly.

I just submitted KF 5.32 to TW, for instance.


--
Luca Beltrame - KDE Forums team
GPG key ID: A29D259B

attachment0 (499 bytes) Download Attachment
Loading...