Per package Prefer definitions

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Per package Prefer definitions

Dinar Valeev
Hi,

I have a case:
conflict for provider of libgcc_s1 >= 5.1.1+r224716-2.3 needed by
gcc5, (provider libgcc_s1-gcc5 is conflicted by installed libgcc_s1)

I need to Prefer libgcc_s1-gcc5 but for a single package. Is it possible?

Project is defaulting to gcc4.8 but gcc5 is available as well. The reason I need
gcc5 for particular package is gcc-go.

Thanks,
Dinar
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Per package Prefer definitions

Dmitriy Perlow
Dinar Valeev <[hidden email]>  Wed, 05 Aug 2015 00:07:27 +0300:

> Hi,
>
> I have a case:
> conflict for provider of libgcc_s1 >= 5.1.1+r224716-2.3 needed by
> gcc5, (provider libgcc_s1-gcc5 is conflicted by installed libgcc_s1)
>
> I need to Prefer libgcc_s1-gcc5 but for a single package. Is it possible?
>
> Project is defaulting to gcc4.8 but gcc5 is available as well. The  
> reason I need
> gcc5 for particular package is gcc-go.
>
> Thanks,
> Dinar

Hello, k0da.

No way:  
http://lists.opensuse.org/archive/opensuse-packaging/2014-12/msg00053.html 
=(

--
Best regards,
Dmitriy DA(P).DarkneSS Perlow @ Linux x64
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Per package Prefer definitions

Dinar Valeev
On Wed, Aug 5, 2015 at 5:53 AM, Dmitriy Perlow <[hidden email]> wrote:

> Dinar Valeev <[hidden email]>  Wed, 05 Aug 2015 00:07:27 +0300:
>
>
>> Hi,
>>
>> I have a case:
>> conflict for provider of libgcc_s1 >= 5.1.1+r224716-2.3 needed by
>> gcc5, (provider libgcc_s1-gcc5 is conflicted by installed libgcc_s1)
>>
>> I need to Prefer libgcc_s1-gcc5 but for a single package. Is it possible?
>>
>> Project is defaulting to gcc4.8 but gcc5 is available as well. The reason
>> I need
>> gcc5 for particular package is gcc-go.
>>
>> Thanks,
>> Dinar
>
>
> Hello, k0da.
>
> No way:
> http://lists.opensuse.org/archive/opensuse-packaging/2014-12/msg00053.html
> =(
I fixed it by:
Preinstall: !libgcc_s1 libgcc_s1-gcc5
>
> --
> Best regards,
> Dmitriy DA(P).DarkneSS Perlow @ Linux x64
> --
> To unsubscribe, e-mail: [hidden email]
> To contact the owner, e-mail: [hidden email]
>
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Per package Prefer definitions

Andreas Schwab-2
Dinar Valeev <[hidden email]> writes:

> I fixed it by:
> Preinstall: !libgcc_s1 libgcc_s1-gcc5

This is a project-wide setting, so all packages in this project will be
built with libgcc_s1-gcc5 instead of libgcc_s1.

Andreas.

--
Andreas Schwab, SUSE Labs, [hidden email]
GPG Key fingerprint = 0196 BAD8 1CE9 1970 F4BE  1748 E4D4 88E3 0EEA B9D7
"And now for something completely different."
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Per package Prefer definitions

Michael Schroeder-4
In reply to this post by Dinar Valeev
On Tue, Aug 04, 2015 at 11:07:27PM +0200, Dinar Valeev wrote:
> Hi,
>
> I have a case:
> conflict for provider of libgcc_s1 >= 5.1.1+r224716-2.3 needed by
> gcc5, (provider libgcc_s1-gcc5 is conflicted by installed libgcc_s1)
>
> I need to Prefer libgcc_s1-gcc5 but for a single package. Is it possible?

Not without modifying the spec file. You need to add a

BuildRequires: libgcc_s1-gcc5

line to it.

Cheers,
  Michael.

--
Michael Schroeder                                   [hidden email]
SUSE LINUX GmbH,           GF Jeff Hawn, HRB 16746 AG Nuernberg
main(_){while(_=~getchar())putchar(~_-1/(~(_|32)/13*2-11)*13);}
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Per package Prefer definitions

Dinar Valeev
On Wed, Aug 5, 2015 at 2:38 PM, Michael Schroeder <[hidden email]> wrote:

> On Tue, Aug 04, 2015 at 11:07:27PM +0200, Dinar Valeev wrote:
>> Hi,
>>
>> I have a case:
>> conflict for provider of libgcc_s1 >= 5.1.1+r224716-2.3 needed by
>> gcc5, (provider libgcc_s1-gcc5 is conflicted by installed libgcc_s1)
>>
>> I need to Prefer libgcc_s1-gcc5 but for a single package. Is it possible?
>
> Not without modifying the spec file. You need to add a
>
> BuildRequires: libgcc_s1-gcc5
That still wouldn't eliminate Preinstall: libgcc_s1 in that case I'm
getting rpm conflict at preinstall stage

>
> line to it.
>
> Cheers,
>   Michael.
>
> --
> Michael Schroeder                                   [hidden email]
> SUSE LINUX GmbH,           GF Jeff Hawn, HRB 16746 AG Nuernberg
> main(_){while(_=~getchar())putchar(~_-1/(~(_|32)/13*2-11)*13);}
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Per package Prefer definitions

Normand
In reply to this post by Andreas Schwab-2

On 05/08/2015 12:33, Andreas Schwab wrote:

> Dinar Valeev <[hidden email]> writes:
>
>> I fixed it by:
>> Preinstall: !libgcc_s1 libgcc_s1-gcc5
>
> This is a project-wide setting, so all packages in this project will be
> built with libgcc_s1-gcc5 instead of libgcc_s1.
>
> Andreas.
>

Does current thread status means we will not be able to build docker for PowerPC in Leap ?
Today as per (1) docker package is in unresolvable state.

(1) https://build.opensuse.org/package/show/openSUSE:Leap:42.1:Ports/docker
"conflict for provider of libgcc_s1 > 5.2.1+r226025-3.5 needed by gcc5
provider libgcc_s1-gcc5 conflicted with installed libgcc_s1"


--
Michel Normand

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]