OBS: nothing provides this-is-only-for-build-envs

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

OBS: nothing provides this-is-only-for-build-envs

Linux Kamarada
Hi, everyone! Again, I'm talking about OBS...

I am moving to the next generation KIWI (https://suse.github.io/kiwi/), but when
I try to build, I get unresolvable:

nothing provides this-is-only-for-build-envs needed by libsystemd0-mini, nothing
provides this-is-only-for-build-envs needed by systemd-mini

Googling, I found this message:

https://lists.opensuse.org/opensuse-buildservice/2016-03/msg00003.html

> Add these lines to your prjconf:

> Ignore: systemd-mini:this-is-only-for-build-envs
> Ignore: libsystemd0-mini:this-is-only-for-build-envs
> Ignore: udev-mini:this-is-only-for-build-envs
> Ignore: libudev-mini1:this-is-only-for-build-envs

I did it:

https://build.opensuse.org/project/prjconf/home:livesuse:dev

Without success. The image does not rebuild. It keeps unresolvable.

Any ideas?

Here is the image:

https://build.opensuse.org/package/show/home:livesuse:dev/LiveSUSE-Leap-KDE

Thank you in advance!


Antonio
The Linux Kamarada Project
https://kamarada.github.io/


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: OBS: nothing provides this-is-only-for-build-envs

Stephan Kulow-3
Am 03.12.2017 um 03:58 schrieb Linux Kamarada:

> Hi, everyone! Again, I'm talking about OBS...
>
> I am moving to the next generation KIWI (https://suse.github.io/kiwi/), but when
> I try to build, I get unresolvable:
>
> nothing provides this-is-only-for-build-envs needed by libsystemd0-mini, nothing
> provides this-is-only-for-build-envs needed by systemd-mini
>
> Googling, I found this message:
>
> https://lists.opensuse.org/opensuse-buildservice/2016-03/msg00003.html
>
>> Add these lines to your prjconf:
>>  
>> Ignore: systemd-mini:this-is-only-for-build-envs
>> Ignore: libsystemd0-mini:this-is-only-for-build-envs
>> Ignore: udev-mini:this-is-only-for-build-envs
>> Ignore: libudev-mini1:this-is-only-for-build-envs
>
This is to ignore it for normal package builds - for product builds this
is harmful.

What you need to do is adding systemd to your kiwi config, so that
systemd-mini isn't even pulled in.

Greetings, Stephan

--
Ma muaß weiterkämpfen, kämpfen bis zum Umfalln, a wenn die
ganze Welt an Arsch offen hat, oder grad deswegn.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: OBS: nothing provides this-is-only-for-build-envs

Linux Kamarada
Em Dom, 2017-12-03 às 08:12 +0100, Stephan Kulow escreveu:

> Am 03.12.2017 um 03:58 schrieb Linux Kamarada:
> >
> > Hi, everyone! Again, I'm talking about OBS...
> >
> > I am moving to the next generation KIWI (https://suse.github.io/kiwi/), but when
> > I try to build, I get unresolvable:
> >
> > nothing provides this-is-only-for-build-envs needed by libsystemd0-mini, nothing
> > provides this-is-only-for-build-envs needed by systemd-mini
> >
> > Googling, I found this message:
> >
> > https://lists.opensuse.org/opensuse-buildservice/2016-03/msg00003.html
> >
> > >
> > > Add these lines to your prjconf:
> > >  
> > > Ignore: systemd-mini:this-is-only-for-build-envs
> > > Ignore: libsystemd0-mini:this-is-only-for-build-envs
> > > Ignore: udev-mini:this-is-only-for-build-envs
> > > Ignore: libudev-mini1:this-is-only-for-build-envs
> >
> This is to ignore it for normal package builds - for product builds this
> is harmful.
>
> What you need to do is adding systemd to your kiwi config, so that
> systemd-mini isn't even pulled in.
>
> Greetings, Stephan
>
> --
> Ma muaß weiterkämpfen, kämpfen bis zum Umfalln, a wenn die
> ganze Welt an Arsch offen hat, oder grad deswegn.

Thank you, Stephan Kulow. I deleted those lines from my prjconf and added systemd to config.kiwi. It worked.

But now, I get a different error:

[   81s] [ INFO    ]: Processing: [                                        ] 0%[ DEBUG   ]: 12:41:27 | system: Loading repository data...
[   81s] [ DEBUG   ]: 12:41:27 | system: Reading installed packages...
[   81s] [ DEBUG   ]: 12:41:27 | system: 'systemd' is already installed.
[   81s] [ DEBUG   ]: 12:41:27 | system: No update candidate for 'systemd-228-38.1.x86_64'. The highest available version is already installed.
[   81s] [ INFO    ]: Processing: [########################################] 100%
[   81s] [ ERROR   ]: 12:41:27 | KiwiInstallPhaseFailed: System package installation failed: Package 'dracut-kiwi-live' not found.
[   81s] Package 'yast2-live-installer' not found.

I don't understand, because here is my config.kiwi:

https://build.opensuse.org/package/view_file/home:livesuse:dev/LiveSUSE-Leap-KDE/config.kiwi

My repository configuration:

  <repository alias="kiwi-next-generation" priority="1" type="rpm-md">
    <source path="obs://Virtualization:Appliances:Builder/openSUSE_Leap_42.3"/>
  </repository>
  <repository alias="repo-update" imageinclude="true" priority="2" type="rpm-md">
    <source path="obs://openSUSE:Leap:42.3:Update/standard"/>
  </repository>
  <repository alias="repo-oss" imageinclude="true" priority="3" type="rpm-md">
    <source path="obs://openSUSE:Leap:42.3/standard"/>
  </repository>

dracut-kiwi-live is available on the kiwi-next-generation repo.

yast2-live-installer is available on the repo-oss repo.

Why are those packages not found? Do you have any ideas?

I'm using the following images as examples to move mine to the next generation KIWI:

https://github.com/SUSE/kiwi-descriptions/tree/master/suse/x86_64/suse-leap-42.3-JeOS

https://build.opensuse.org/package/view_file/Virtualization:Appliances:Images:Testing_x86/test-image-iso/

https://build.opensuse.org/package/view_file/home:probono:branches:KDE:Medias/openSUSE-Argon/ 


Antonio
The Linux Kamarada Project
https://kamarada.github.io/


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]