Quantcast

OBS 2.7: Packages are unresolvable 'Have choice for i586' or 'Nothing provides'

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

OBS 2.7: Packages are unresolvable 'Have choice for i586' or 'Nothing provides'

Till Dörges
Hello all,

I just upgraded a private OBS instance from 2.6 to 2.7. The openSUSE 13.1 update
repository was a local repository under 2.6 and was converted to a download on demand
repository for 2.7.


I have configured a project, roughly like so:

--- snip ---
<project name="P">
  <title>T</title>
[...]
  <repository name="openSUSE_13.1">
    <path project="openSUSE.org:13.1" repository="standard"/>
    <path project="openSUSE.org:13.1:Update" repository="standard"/>
    <arch>i586</arch>
    <arch>x86_64</arch>
  </repository>
</project>
--- snap ---

Unfortunately I get 'unresolvable' for all i586 packages. The tool tip shows
something like "Have choice for libelf.so.1 needed bei rpm: libelf1 libelf1-32-bit, ...."

x86_64 is building fine.


If I change the order of the <path> entries the state still stays 'unresolvable' for
all i586 packages. But the tool tips change to "Nothing provides
libpopt.so.0()(64bit) needed by rpm-build, ...."

Again, x86_64 is building fine.


The repositories openSUSE.org:13.1 and openSUSE.org:13.1:Update look like this:

--- snip ---
<project name="openSUSE.org:13.1">
  <title>openSUSE 13.1 (lokal)</title>
  <description>D</description>
  <person userid="Admin" role="bugowner"/>
  <person userid="Admin" role="maintainer"/>
  <publish>
    <disable/>
  </publish>
  <repository name="standard">
    <arch>i586</arch>
    <arch>x86_64</arch>
  </repository>
</project>

<project name="openSUSE.org:13.1:Update" kind="maintenance_release">
  <title>openSUSE 13.1 Updates (DoD)</title>
  <description>D</description>
  <link project="openSUSE.org:13.1"/>
  <person userid="Admin" role="bugowner"/>
  <person userid="Admin" role="maintainer"/>
  <publish>
    <disable/>
  </publish>
  <repository name="standard">
    <download arch="x86_64" url="http://internal.host/opensuse/live/update/13.1/"
repotype="rpmmd"/>
    <download arch="i586" url="http://internal.host/opensuse/live/update/13.1/"
repotype="rpmmd"/>
    <arch>x86_64</arch>
    <arch>i586</arch>
  </repository>
</project>
--- snap ---


Obviously something is wrong but I have no idea what and where to debug next.


Any hint would be greatly appreciated!


Thanks and regards -- Till
--
Dipl.-Inform. Till Dörges                  [hidden email]
PRESENSE Technologies GmbH            Sachsenstr. 5, D-20097 HH
Geschäftsführer/Managing Directors       AG Hamburg, HRB 107844
Till Dörges, Jürgen Sander               USt-IdNr.: DE263765024
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OBS 2.7: Packages are unresolvable 'Have choice for i586' or 'Nothing provides'

Adrian Schröter
On Donnerstag, 16. Februar 2017, 22:41:34 CET wrote Till Dörges:
> Hello all,
>
> I just upgraded a private OBS instance from 2.6 to 2.7. The openSUSE 13.1 update
> repository was a local repository under 2.6 and was converted to a download on demand
> repository for 2.7.

We do not ship OBS 2.7 for i586 anymore. Please use an x86_64 system.


> I have configured a project, roughly like so:
>
> --- snip ---
> <project name="P">
>   <title>T</title>
> [...]
>   <repository name="openSUSE_13.1">
>     <path project="openSUSE.org:13.1" repository="standard"/>
>     <path project="openSUSE.org:13.1:Update" repository="standard"/>
>     <arch>i586</arch>
>     <arch>x86_64</arch>
>   </repository>
> </project>
> --- snap ---
>
> Unfortunately I get 'unresolvable' for all i586 packages. The tool tip shows
> something like "Have choice for libelf.so.1 needed bei rpm: libelf1 libelf1-32-bit, ...."
>
> x86_64 is building fine.
>
>
> If I change the order of the <path> entries the state still stays 'unresolvable' for
> all i586 packages. But the tool tips change to "Nothing provides
> libpopt.so.0()(64bit) needed by rpm-build, ...."
>
> Again, x86_64 is building fine.
>
>
> The repositories openSUSE.org:13.1 and openSUSE.org:13.1:Update look like this:
>
> --- snip ---
> <project name="openSUSE.org:13.1">
>   <title>openSUSE 13.1 (lokal)</title>
>   <description>D</description>
>   <person userid="Admin" role="bugowner"/>
>   <person userid="Admin" role="maintainer"/>
>   <publish>
>     <disable/>
>   </publish>
>   <repository name="standard">
>     <arch>i586</arch>
>     <arch>x86_64</arch>
>   </repository>
> </project>
>
> <project name="openSUSE.org:13.1:Update" kind="maintenance_release">
>   <title>openSUSE 13.1 Updates (DoD)</title>
>   <description>D</description>
>   <link project="openSUSE.org:13.1"/>
>   <person userid="Admin" role="bugowner"/>
>   <person userid="Admin" role="maintainer"/>
>   <publish>
>     <disable/>
>   </publish>
>   <repository name="standard">
>     <download arch="x86_64" url="http://internal.host/opensuse/live/update/13.1/"
> repotype="rpmmd"/>
>     <download arch="i586" url="http://internal.host/opensuse/live/update/13.1/"
> repotype="rpmmd"/>
>     <arch>x86_64</arch>
>     <arch>i586</arch>
>   </repository>
> </project>
> --- snap ---
>
>
> Obviously something is wrong but I have no idea what and where to debug next.
>
>
> Any hint would be greatly appreciated!
>
>
> Thanks and regards -- Till
>


--

Adrian Schroeter
email: [hidden email]

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
 
Maxfeldstraße 5                        
90409 Nürnberg
Germany


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OBS 2.7: Packages are unresolvable 'Have choice for i586' or 'Nothing provides'

Till Dörges
Am 17.02.2017 um 09:36 schrieb Adrian Schröter:

>> I just upgraded a private OBS instance from 2.6 to 2.7. The openSUSE 13.1 update
>> repository was a local repository under 2.6 and was converted to a download on demand
>> repository for 2.7.
>
> We do not ship OBS 2.7 for i586 anymore. Please use an x86_64 system.


Does this mean, I can't build for i586 with OBS 2.7 anymore?


Our OBS instance (all services including 2 workers) runs on a single x86_64 host.


Regards -- Till


>> I have configured a project, roughly like so:
>>
>> --- snip ---
>> <project name="P">
>>   <title>T</title>
>> [...]
>>   <repository name="openSUSE_13.1">
>>     <path project="openSUSE.org:13.1" repository="standard"/>
>>     <path project="openSUSE.org:13.1:Update" repository="standard"/>
>>     <arch>i586</arch>
>>     <arch>x86_64</arch>
>>   </repository>
>> </project>
>> --- snap ---
>>
>> Unfortunately I get 'unresolvable' for all i586 packages. The tool tip shows
>> something like "Have choice for libelf.so.1 needed bei rpm: libelf1 libelf1-32-bit, ...."
>>
>> x86_64 is building fine.
>>
>>
>> If I change the order of the <path> entries the state still stays 'unresolvable' for
>> all i586 packages. But the tool tips change to "Nothing provides
>> libpopt.so.0()(64bit) needed by rpm-build, ...."
>>
>> Again, x86_64 is building fine.
>>
>>
>> The repositories openSUSE.org:13.1 and openSUSE.org:13.1:Update look like this:
>>
>> --- snip ---
>> <project name="openSUSE.org:13.1">
>>   <title>openSUSE 13.1 (lokal)</title>
>>   <description>D</description>
>>   <person userid="Admin" role="bugowner"/>
>>   <person userid="Admin" role="maintainer"/>
>>   <publish>
>>     <disable/>
>>   </publish>
>>   <repository name="standard">
>>     <arch>i586</arch>
>>     <arch>x86_64</arch>
>>   </repository>
>> </project>
>>
>> <project name="openSUSE.org:13.1:Update" kind="maintenance_release">
>>   <title>openSUSE 13.1 Updates (DoD)</title>
>>   <description>D</description>
>>   <link project="openSUSE.org:13.1"/>
>>   <person userid="Admin" role="bugowner"/>
>>   <person userid="Admin" role="maintainer"/>
>>   <publish>
>>     <disable/>
>>   </publish>
>>   <repository name="standard">
>>     <download arch="x86_64" url="http://internal.host/opensuse/live/update/13.1/"
>> repotype="rpmmd"/>
>>     <download arch="i586" url="http://internal.host/opensuse/live/update/13.1/"
>> repotype="rpmmd"/>
>>     <arch>x86_64</arch>
>>     <arch>i586</arch>
>>   </repository>
>> </project>
>> --- snap ---
>>
>>
>> Obviously something is wrong but I have no idea what and where to debug next.
>>
>>
>> Any hint would be greatly appreciated!
>>
>>
>> Thanks and regards -- Till
>>
>
>


--
Dipl.-Inform. Till Dörges                  [hidden email]
                                  Tel. +49 - 40 - 244 2407 - 14
                                  Fax  +49 - 40 - 244 2407 - 24
PRESENSE Technologies GmbH            Sachsenstr. 5, D-20097 HH
Geschäftsführer/Managing Directors       AG Hamburg, HRB 107844
Till Dörges, Jürgen Sander               USt-IdNr.: DE263765024
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OBS 2.7: Packages are unresolvable 'Have choice for i586' or 'Nothing provides'

Adrian Schröter
On Freitag, 17. Februar 2017, 11:03:16 CET wrote Till Dörges:

> Am 17.02.2017 um 09:36 schrieb Adrian Schröter:
>
> >> I just upgraded a private OBS instance from 2.6 to 2.7. The openSUSE 13.1 update
> >> repository was a local repository under 2.6 and was converted to a download on demand
> >> repository for 2.7.
> >
> > We do not ship OBS 2.7 for i586 anymore. Please use an x86_64 system.
>
>
> Does this mean, I can't build for i586 with OBS 2.7 anymore?

You can still build for any architecture and distribution OBS supports, including i586.

Just the OBS server instance itself needs to run on a x86_64 system.

>
> Our OBS instance (all services including 2 workers) runs on a single x86_64 host.

x86_64 workers are fine, they will use either personality switching (chroot) or booting
a 32bit kernel and user land for i586 builds.

>
> Regards -- Till
>
>
> >> I have configured a project, roughly like so:
> >>
> >> --- snip ---
> >> <project name="P">
> >>   <title>T</title>
> >> [...]
> >>   <repository name="openSUSE_13.1">
> >>     <path project="openSUSE.org:13.1" repository="standard"/>
> >>     <path project="openSUSE.org:13.1:Update" repository="standard"/>
> >>     <arch>i586</arch>
> >>     <arch>x86_64</arch>
> >>   </repository>
> >> </project>
> >> --- snap ---
> >>
> >> Unfortunately I get 'unresolvable' for all i586 packages. The tool tip shows
> >> something like "Have choice for libelf.so.1 needed bei rpm: libelf1 libelf1-32-bit, ...."
> >>
> >> x86_64 is building fine.
> >>
> >>
> >> If I change the order of the <path> entries the state still stays 'unresolvable' for
> >> all i586 packages. But the tool tips change to "Nothing provides
> >> libpopt.so.0()(64bit) needed by rpm-build, ...."
> >>
> >> Again, x86_64 is building fine.
> >>
> >>
> >> The repositories openSUSE.org:13.1 and openSUSE.org:13.1:Update look like this:
> >>
> >> --- snip ---
> >> <project name="openSUSE.org:13.1">
> >>   <title>openSUSE 13.1 (lokal)</title>
> >>   <description>D</description>
> >>   <person userid="Admin" role="bugowner"/>
> >>   <person userid="Admin" role="maintainer"/>
> >>   <publish>
> >>     <disable/>
> >>   </publish>
> >>   <repository name="standard">
> >>     <arch>i586</arch>
> >>     <arch>x86_64</arch>
> >>   </repository>
> >> </project>
> >>
> >> <project name="openSUSE.org:13.1:Update" kind="maintenance_release">
> >>   <title>openSUSE 13.1 Updates (DoD)</title>
> >>   <description>D</description>
> >>   <link project="openSUSE.org:13.1"/>
> >>   <person userid="Admin" role="bugowner"/>
> >>   <person userid="Admin" role="maintainer"/>
> >>   <publish>
> >>     <disable/>
> >>   </publish>
> >>   <repository name="standard">
> >>     <download arch="x86_64" url="http://internal.host/opensuse/live/update/13.1/"
> >> repotype="rpmmd"/>
> >>     <download arch="i586" url="http://internal.host/opensuse/live/update/13.1/"
> >> repotype="rpmmd"/>
> >>     <arch>x86_64</arch>
> >>     <arch>i586</arch>
> >>   </repository>
> >> </project>
> >> --- snap ---
> >>
> >>
> >> Obviously something is wrong but I have no idea what and where to debug next.
> >>
> >>
> >> Any hint would be greatly appreciated!
> >>
> >>
> >> Thanks and regards -- Till
> >>
> >
> >
>
>
>


--

Adrian Schroeter
email: [hidden email]

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
 
Maxfeldstraße 5                        
90409 Nürnberg
Germany


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OBS 2.7: Packages are unresolvable 'Have choice for i586' or 'Nothing provides'

Till Dörges
Am 17.02.2017 um 11:05 schrieb Adrian Schröter:

> On Freitag, 17. Februar 2017, 11:03:16 CET wrote Till Dörges:
>> Am 17.02.2017 um 09:36 schrieb Adrian Schröter:
>>
>>>> I just upgraded a private OBS instance from 2.6 to 2.7. The openSUSE 13.1 update
>>>> repository was a local repository under 2.6 and was converted to a download on demand
>>>> repository for 2.7.
>>>
>>> We do not ship OBS 2.7 for i586 anymore. Please use an x86_64 system.
>>
>>
>> Does this mean, I can't build for i586 with OBS 2.7 anymore?
>
> You can still build for any architecture and distribution OBS supports, including i586.
>
> Just the OBS server instance itself needs to run on a x86_64 system.
>
>>
>> Our OBS instance (all services including 2 workers) runs on a single x86_64 host.
>
> x86_64 workers are fine, they will use either personality switching (chroot) or booting
> a 32bit kernel and user land for i586 builds.

Perfect, that was my understanding, too.


But it brings me back to my original question. ;-)

What is wrong/missing in our setup so that x86_64 builds are fine, but i586 build
give 'unresolvable' with either 'Have choice for i586' or 'Nothing provides'?


Regards -- Till


>>>> I have configured a project, roughly like so:
>>>>
>>>> --- snip ---
>>>> <project name="P">
>>>>   <title>T</title>
>>>> [...]
>>>>   <repository name="openSUSE_13.1">
>>>>     <path project="openSUSE.org:13.1" repository="standard"/>
>>>>     <path project="openSUSE.org:13.1:Update" repository="standard"/>
>>>>     <arch>i586</arch>
>>>>     <arch>x86_64</arch>
>>>>   </repository>
>>>> </project>
>>>> --- snap ---
>>>>
>>>> Unfortunately I get 'unresolvable' for all i586 packages. The tool tip shows
>>>> something like "Have choice for libelf.so.1 needed bei rpm: libelf1 libelf1-32-bit, ...."
>>>>
>>>> x86_64 is building fine.
>>>>
>>>>
>>>> If I change the order of the <path> entries the state still stays 'unresolvable' for
>>>> all i586 packages. But the tool tips change to "Nothing provides
>>>> libpopt.so.0()(64bit) needed by rpm-build, ...."
>>>>
>>>> Again, x86_64 is building fine.
>>>>
>>>>
>>>> The repositories openSUSE.org:13.1 and openSUSE.org:13.1:Update look like this:
>>>>
>>>> --- snip ---
>>>> <project name="openSUSE.org:13.1">
>>>>   <title>openSUSE 13.1 (lokal)</title>
>>>>   <description>D</description>
>>>>   <person userid="Admin" role="bugowner"/>
>>>>   <person userid="Admin" role="maintainer"/>
>>>>   <publish>
>>>>     <disable/>
>>>>   </publish>
>>>>   <repository name="standard">
>>>>     <arch>i586</arch>
>>>>     <arch>x86_64</arch>
>>>>   </repository>
>>>> </project>
>>>>
>>>> <project name="openSUSE.org:13.1:Update" kind="maintenance_release">
>>>>   <title>openSUSE 13.1 Updates (DoD)</title>
>>>>   <description>D</description>
>>>>   <link project="openSUSE.org:13.1"/>
>>>>   <person userid="Admin" role="bugowner"/>
>>>>   <person userid="Admin" role="maintainer"/>
>>>>   <publish>
>>>>     <disable/>
>>>>   </publish>
>>>>   <repository name="standard">
>>>>     <download arch="x86_64" url="http://internal.host/opensuse/live/update/13.1/"
>>>> repotype="rpmmd"/>
>>>>     <download arch="i586" url="http://internal.host/opensuse/live/update/13.1/"
>>>> repotype="rpmmd"/>
>>>>     <arch>x86_64</arch>
>>>>     <arch>i586</arch>
>>>>   </repository>
>>>> </project>
>>>> --- snap ---
>>>>
>>>>
>>>> Obviously something is wrong but I have no idea what and where to debug next.
>>>>
>>>>
>>>> Any hint would be greatly appreciated!
>>>>
>>>>
>>>> Thanks and regards -- Till
--
Dipl.-Inform. Till Dörges                  [hidden email]
                                  Tel. +49 - 40 - 244 2407 - 14
                                  Fax  +49 - 40 - 244 2407 - 24
PRESENSE Technologies GmbH            Sachsenstr. 5, D-20097 HH
Geschäftsführer/Managing Directors       AG Hamburg, HRB 107844
Till Dörges, Jürgen Sander               USt-IdNr.: DE263765024
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OBS 2.7: Packages are unresolvable 'Have choice for i586' or 'Nothing provides'

Adrian Schröter
On Freitag, 17. Februar 2017, 11:13:16 CET wrote Till Dörges:

> Am 17.02.2017 um 11:05 schrieb Adrian Schröter:
> > On Freitag, 17. Februar 2017, 11:03:16 CET wrote Till Dörges:
> >> Am 17.02.2017 um 09:36 schrieb Adrian Schröter:
> >>
> >>>> I just upgraded a private OBS instance from 2.6 to 2.7. The openSUSE 13.1 update
> >>>> repository was a local repository under 2.6 and was converted to a download on demand
> >>>> repository for 2.7.
> >>>
> >>> We do not ship OBS 2.7 for i586 anymore. Please use an x86_64 system.
> >>
> >>
> >> Does this mean, I can't build for i586 with OBS 2.7 anymore?
> >
> > You can still build for any architecture and distribution OBS supports, including i586.
> >
> > Just the OBS server instance itself needs to run on a x86_64 system.
> >
> >>
> >> Our OBS instance (all services including 2 workers) runs on a single x86_64 host.
> >
> > x86_64 workers are fine, they will use either personality switching (chroot) or booting
> > a 32bit kernel and user land for i586 builds.
>
> Perfect, that was my understanding, too.
>
>
> But it brings me back to my original question. ;-)
>
> What is wrong/missing in our setup so that x86_64 builds are fine, but i586 build
> give 'unresolvable' with either 'Have choice for i586' or 'Nothing provides'?

I understood you that you build against OBS:Server:2.7 project. That one has no i586
definition in the repos so it is not finding any rpms there.

sorry, but I can not really help without to know more about your setup ..

--

Adrian Schroeter
email: [hidden email]

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
 
Maxfeldstraße 5                        
90409 Nürnberg
Germany


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OBS 2.7: Packages are unresolvable 'Have choice for i586' or 'Nothing provides'

Till Dörges
Am 17.02.2017 um 11:17 schrieb Adrian Schröter:

>> What is wrong/missing in our setup so that x86_64 builds are fine, but i586 build
>> give 'unresolvable' with either 'Have choice for i586' or 'Nothing provides'?
>
> I understood you that you build against OBS:Server:2.7 project. That one has no i586
> definition in the repos so it is not finding any rpms there.
>
> sorry, but I can not really help without to know more about your setup ..

Sure. I'll try to explain again. And I'm also happy to provide more information/logs.


I'm trying to build packages for x86_64 and i586 against the repos openSUSE.org:13.1
and openSUSE.org:13.1:Update. So nothing fancy.

openSUSE.org:13.1 is a local repository.

openSUSE.org:13.1:Update is a download on demand repository.


The project with the packages I'm trying to build is quite simple:

--- snip ---
<project name="P">
  <title>...
  <description>...
  <person userid="Admin" role="maintainer"/>
  <repository name="openSUSE_13.1">
    <path project="openSUSE.org:13.1" repository="standard"/>
    <path project="openSUSE.org:13.1:Update" repository="standard"/>
    <arch>i586</arch>
    <arch>x86_64</arch>
  </repository>
</project>
--- snap ---

The packages typically look like this:

--- snip ---
<package name="package" project="P">
  <title>...
  <description/>
</package>
--- snap ---


And the packages in this project should be built for both i586 and x86_64. x68_64 is
working smoothly. For the architecture i586 the state is 'unresolvable' with either
'Have choice for i586 ...' or 'Nothing provides ...'.


Does this make more sense?


Thanks and regards -- Till
--
Dipl.-Inform. Till Dörges                  [hidden email]
                                  Tel. +49 - 40 - 244 2407 - 14
                                  Fax  +49 - 40 - 244 2407 - 24
PRESENSE Technologies GmbH            Sachsenstr. 5, D-20097 HH
Geschäftsführer/Managing Directors       AG Hamburg, HRB 107844
Till Dörges, Jürgen Sander               USt-IdNr.: DE263765024
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OBS 2.7: Packages are unresolvable 'Have choice for i586' or 'Nothing provides'

Till Dörges
Am 17.02.2017 um 12:01 schrieb Till Dörges:


>>> What is wrong/missing in our setup so that x86_64 builds are fine, but i586 build
>>> give 'unresolvable' with either 'Have choice for i586' or 'Nothing provides'?


> --- snip ---
> <project name="P">
>   <title>...
>   <description>...
>   <person userid="Admin" role="maintainer"/>
>   <repository name="openSUSE_13.1">
>     <path project="openSUSE.org:13.1" repository="standard"/>
>     <path project="openSUSE.org:13.1:Update" repository="standard"/>
>     <arch>i586</arch>
>     <arch>x86_64</arch>
>   </repository>
> </project>
> --- snap ---

FTR, builds for both i586 and x86_64 RPMs work if I change the above config as
follows, i.e. if I remove the "openSUSE.org:13.1:Update" line:

--- snip ---
  <repository name="openSUSE_13.1">
    <path project="openSUSE.org:13.1" repository="standard"/>
    <arch>x86_64</arch>
    <arch>i586</arch>
  </repository>
--- snap ---


I still would like to understand why I can't use *both* "openSUSE.org:13.1" and
"openSUSE.org:13.1:Update" for i586, but at least it seems to be working.


Regards -- Till
--
Dipl.-Inform. Till Dörges                  [hidden email]
                                  Tel. +49 - 40 - 244 2407 - 14
                                  Fax  +49 - 40 - 244 2407 - 24
PRESENSE Technologies GmbH            Sachsenstr. 5, D-20097 HH
Geschäftsführer/Managing Directors       AG Hamburg, HRB 107844
Till Dörges, Jürgen Sander               USt-IdNr.: DE263765024
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Loading...