New Tumbleweed snapshot 20180117 released!

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

New Tumbleweed snapshot 20180117 released!

Dominique Leuenberger

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180117

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
  akonadi-calendar (17.12.0 -> 17.12.1)
  akonadi-calendar-tools (17.12.0 -> 17.12.1)
  akonadi-contact (17.12.0 -> 17.12.1)
  akonadi-import-wizard (17.12.0 -> 17.12.1)
  akonadi-mime (17.12.0 -> 17.12.1)
  akonadi-notes (17.12.0 -> 17.12.1)
  akonadi-search (17.12.0 -> 17.12.1)
  akonadi-server (17.12.0 -> 17.12.1)
  akregator (17.12.0 -> 17.12.1)
  ark (17.12.0 -> 17.12.1)
  audacity (2.2.0 -> 2.2.1)
  autoyast2 (3.3.3 -> 4.0.22)
  baloo5-widgets (17.12.0 -> 17.12.1)
  calendarsupport (17.12.0 -> 17.12.1)
  cim-schema (2.49.0 -> 2.50.0)
  claws-mail (3.15.1 -> 3.16.0)
  cmpi-provider-register (1.0.1 -> 1.1.0)
  coreutils (8.28 -> 8.29)
  digikam (5.7.0 -> 5.8.0)
  dolphin (17.12.0 -> 17.12.1)
  dpdk
  dragonplayer (17.12.0 -> 17.12.1)
  epiphany
  eventviews (17.12.0 -> 17.12.1)
  grantleetheme (17.12.0 -> 17.12.1)
  gwenview5 (17.12.0 -> 17.12.1)
  gzip (1.8 -> 1.9)
  incidenceeditor (17.12.0 -> 17.12.1)
  installation-images-Kubic
  irssi (1.0.6 -> 1.1.0)
  kaccounts-integration (17.12.0 -> 17.12.1)
  kaccounts-providers (17.12.0 -> 17.12.1)
  kaddressbook (17.12.0 -> 17.12.1)
  kalarmcal (17.12.0 -> 17.12.1)
  kamera (17.12.0 -> 17.12.1)
  kate (17.12.0 -> 17.12.1)
  kcalc (17.12.0 -> 17.12.1)
  kcalcore (17.12.0 -> 17.12.1)
  kcalutils (17.12.0 -> 17.12.1)
  kcharselect (17.12.0 -> 17.12.1)
  kcolorchooser (17.12.0 -> 17.12.1)
  kcontacts (17.12.0 -> 17.12.1)
  kdav (17.12.0 -> 17.12.1)
  kdenetwork4-filesharing (17.12.0 -> 17.12.1)
  kdepim-addons (17.12.0 -> 17.12.1)
  kdepim-apps-libs (17.12.0 -> 17.12.1)
  kdepim-runtime (17.12.0 -> 17.12.1)
  kdialog (17.12.0 -> 17.12.1)
  kget (17.12.0 -> 17.12.1)
  kgpg (17.12.0 -> 17.12.1)
  khelpcenter5 (17.12.0 -> 17.12.1)
  kholidays (17.12.0 -> 17.12.1)
  kidentitymanagement (17.12.0 -> 17.12.1)
  kimap (17.12.0 -> 17.12.1)
  kio-extras5 (17.12.0 -> 17.12.1)
  kio_audiocd (17.12.0 -> 17.12.1)
  kldap (17.12.0 -> 17.12.1)
  kleopatra (17.12.0 -> 17.12.1)
  kmag (17.12.0 -> 17.12.1)
  kmail (17.12.0 -> 17.12.1)
  kmail-account-wizard (17.12.0 -> 17.12.1)
  kmailtransport (17.12.0 -> 17.12.1)
  kmbox (17.12.0 -> 17.12.1)
  kmime (17.12.0 -> 17.12.1)
  kmousetool (17.12.0 -> 17.12.1)
  knotes (17.12.0 -> 17.12.1)
  kompare (17.12.0 -> 17.12.1)
  konqueror (17.12.0 -> 17.12.1)
  konsole (17.12.0 -> 17.12.1)
  kontact (17.12.0 -> 17.12.1)
  kontactinterface (17.12.0 -> 17.12.1)
  korganizer (17.12.0 -> 17.12.1)
  kpimtextedit (17.12.0 -> 17.12.1)
  kqtquickcharts (17.12.0 -> 17.12.1)
  krdc (17.12.0 -> 17.12.1)
  krfb (17.12.0 -> 17.12.1)
  kruler (17.12.0 -> 17.12.1)
  ksmtp (17.12.0 -> 17.12.1)
  ktnef (17.12.0 -> 17.12.1)
  kwalletmanager5 (17.12.0 -> 17.12.1)
  libgooglepinyin
  libgravatar (17.12.0 -> 17.12.1)
  libkcddb (17.12.0 -> 17.12.1)
  libkcompactdisc (17.12.0 -> 17.12.1)
  libkdcraw (17.12.0 -> 17.12.1)
  libkdepim (17.12.0 -> 17.12.1)
  libkexiv2 (17.12.0 -> 17.12.1)
  libkgapi (17.12.0 -> 17.12.1)
  libkgeomap (17.12.0 -> 17.12.1)
  libkipi (17.12.0 -> 17.12.1)
  libkleo (17.12.0 -> 17.12.1)
  libkomparediff2 (17.12.0 -> 17.12.1)
  libksane (17.12.0 -> 17.12.1)
  libksieve (17.12.0 -> 17.12.1)
  libxcb
  llvm4
  llvm5
  mailcommon (17.12.0 -> 17.12.1)
  mailimporter (17.12.0 -> 17.12.1)
  marble (17.12.0 -> 17.12.1)
  messagelib (17.12.0 -> 17.12.1)
  mobipocket (17.12.0 -> 17.12.1)
  okular (17.12.0 -> 17.12.1)
  patterns-base
  patterns-media
  patterns-yast (20170319 -> 20180105)
  perl
  pimcommon (17.12.0 -> 17.12.1)
  spectacle (17.12.0 -> 17.12.1)
  sweeper (17.12.0 -> 17.12.1)
  syndication (17.12.0 -> 17.12.1)
  systemd
  tomcat
  virt-manager
  yast2 (4.0.11 -> 4.0.35)
  yast2-add-on (4.0.4 -> 4.0.5)
  yast2-bootloader (3.3.0 -> 4.0.13)
  yast2-country (4.0.6 -> 4.0.16)
  yast2-firewall (3.2.0 -> 4.0.8)
  yast2-installation (3.3.5 -> 4.0.22)
  yast2-mail (3.1.10 -> 4.0.0)
  yast2-multipath (3.2.1 -> 4.0.0)
  yast2-network (3.3.6 -> 4.0.13)
  yast2-nfs-client (3.1.17 -> 4.0.0)
  yast2-ntp-client (4.0.0 -> 4.0.6)
  yast2-packager (3.3.2 -> 4.0.29)
  yast2-update (3.2.2 -> 4.0.8)
  yast2-x11 (3.1.5 -> 4.0.0)

=== Details ===

==== akonadi-calendar ====
Version update (17.12.0 -> 17.12.1)
Subpackages: akonadi-calendar-lang libKF5AkonadiCalendar5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Use the chosen organizer identity when emailing attendees

==== akonadi-calendar-tools ====
Version update (17.12.0 -> 17.12.1)
Subpackages: akonadi-calendar-tools-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== akonadi-contact ====
Version update (17.12.0 -> 17.12.1)
Subpackages: akonadi-contact-lang libKF5AkonadiContact5 libKF5ContactEditor5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== akonadi-import-wizard ====
Version update (17.12.0 -> 17.12.1)
Subpackages: akonadi-import-wizard-lang libKPimImportWizard5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Fix rename categories

==== akonadi-mime ====
Version update (17.12.0 -> 17.12.1)
Subpackages: akonadi-mime-lang libKF5AkonadiMime5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== akonadi-notes ====
Version update (17.12.0 -> 17.12.1)
Subpackages: akonadi-notes-lang libKF5AkonadiNotes5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== akonadi-search ====
Version update (17.12.0 -> 17.12.1)
Subpackages: akonadi-search-lang libKF5AkonadiSearch

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== akonadi-server ====
Version update (17.12.0 -> 17.12.1)
Subpackages: akonadi-server-lang akonadi-server-sqlite libKF5AkonadiAgentBase5 libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Give more details in the LLCONFLICT error.
  * Make conflict dialog much bigger, it's unusable otherwise.
  * ErrorOverlay: don't show by mistake if called with Running twice. (kde#379997)

==== akregator ====
Version update (17.12.0 -> 17.12.1)
Subpackages: akregator-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== ark ====
Version update (17.12.0 -> 17.12.1)
Subpackages: ark-lang libkerfuffle17

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Set transient parent to extraction dialog

==== audacity ====
Version update (2.2.0 -> 2.2.1)
Subpackages: audacity-lang

- Update to maintenance release version 2.2.1
- Upstream changes and fixes:
  * Waveform colorways:
  You can optionally change the colorway of the waveforms
  displayed in your project. The setting is per track and not per
  project so you can have multiple colorways in the same project.
  * "Save Other" reverts to "Export" in the File menu:
  When we made the menu changes for 2.2.0 we introduced an entry
  into the File menu called "Save Other" which led to a sub-menu
  for exporting various audio formats.
  Many users were confused by this change and found it hard to
  find where they could export.
  * Bug #1770 - Crash applying certain chain files
  * Bug #1783 - Preview fails when selection extends before zero
  * Bug #1787 - Auto-scroll stopped working in 2.2.0
  * Bug #1765 - Using File > Open to import audio gives wrong zoom
  level and no scroll bar slider.

==== autoyast2 ====
Version update (3.3.3 -> 4.0.22)
Subpackages: autoyast2-installation

- adapt to yast2 changes in overlays (related to bsc#1070726)
- 4.0.22
- Upgrade: Adapting to new product handling.
  (bnc#1075744)
- 4.0.21
- Fixed merging issues due to bnc#1075182 and bsc#1075334.
- 4.0.20
- Merging products before package evaluation starts.
  (bnc#1075182)
- 4.0.19
- Fix initialization to copy the profile to /tmp/profile again
  (bsc#1075334)
- 4.0.18
- always upgrade system via equivalent of 'zypper dup', removing
  respective control from the profile (bsc#1071708)
- 4.0.17
- AutoYaST: fix btrfs_set_default_subvolume_name handling
  (bsc#1073548)
- 4.0.16
- Warn the user if the infrastructure is not available for running
  the second stage (bnc#1061754)
- 4.0.15
- Reinitialize the storage manager when the profile is modified
  by a pre-script (bsc#1071739)
- 4.0.14
- adapt to new schema of ntp-client (FATE#323432)
- 4.0.13
- Drop using ntpdate and instead use NtpClient module for one time
  sync (FATE#323432)
- 4.0.12
- Do not ignore start_multipath setting (bsc#1070343).
- 4.0.11
- Replace references to /var/adm/fillup-templates with new
  %_fillupdir macro (boo#1069468).
- 4.0.10
- Added subvolumes_prefix to schema definition file.
  (bsc#1013047)
- Exporting base products in list format. (fate323450)
- 4.0.9
- Bring back handling of device=ask (bsc#1069965)
- Use a 1-based index when showing partitioning issues
- 4.0.8
- Cleanup spec file.
- Code cleanup (removing old libstorage code).
- Adapting rules to storage-ng.
- partition_alignment removed because it is not needed
  anymore by storage-ng.
- 4.0.7
- Add storage data to ayast_probe client (bsc#1065668)
- Handle storage proposal exceptions in a proper way
- 4.0.6
- When reporting issues with the partition plan, add in which
  section of the profile were they found (related to bsc#1060637).
- 4.0.5
- Do not mangle partitioning information coming from
  yast2-storage-ng when cloning a system (related to bsc#1064875).
- 4.0.4
- Add basic support for error handling when creating the
  partition plan (fate#318196).
- 4.0.3
- Add missing require of Y2Package::Product class (bsc#1064396)
- fate#323450
  - implemented product selection
- 4.0.2
- Removed the remains of Kickstart import (bsc#1061620).
- 4.0.1
- AutoinstConfig: added network_before_proposal flag that will be
  enable if the network is configured during the first stage.
  (bsc#1054400)
- 4.0.0
- ayast_setup: Restarting autoyast-initscripts.service in order
  to run init-scripts too. (bnc#1057597)
- 3.3.9
- Rename "y2storage_probed" to "probed". (bnc#1056656)
- 3.3.8
- fate323450
  - export product name when cloning a profile
- 3.3.7
- Handle packages that are missing a PGP signature although
  digests are valid (bsc#1054969)
- 3.3.6
- AY runs in installed system: Writing init scripts again
  to /var/adm/autoinstall/init.d in order to initilaize init
  scripts correctly. This is needed for AY runs which do not
  have an first installation stage (e.g. AY run in KIWI,
  ayast_setup). (bnc#1052145)
- 3.3.5
- Merged storage-ng branch (fate#318196).
- Note: all changes below with this date belong to the merge.
- 3.3.4
- storage-ng: refac class StorageProposal and create a new guided
  proposal by changing settings if it is necessary.
- Use the new storage-ng layer to export the current system to the
  corresponding <partitioning> section of the AutoYaST profile
  (fate#318196).
- Add basic support for customized partitioning using the new
  storage-ng layer. Currently, only plain partitions are supported
  (bsc#1044697).
- Allow overriding of product's storage partitioning options
  (bsc#1039481)
- storage-ng: commented several Yast.import for the old storage
  lib. Affected modules not adapted to storage-ng so far.
- storage-ng: Enable storage-ng proposal for AutoYaST installation.
- storage-ng: fix AutoInstallRules to not use old storage lib.
  Tests are commented. Removed dependency from (old) yast2-storage,
  even if it breaks some functionality.
- Removed yast2-update as build dependency and added before
  version (2.18.3) as install dependency. It is only needed for
  file_from_url.

==== baloo5-widgets ====
Version update (17.12.0 -> 17.12.1)
Subpackages: baloo5-widgets-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Added 'Comment' option to  metadata config-dialog (kde#365620)

==== calendarsupport ====
Version update (17.12.0 -> 17.12.1)
Subpackages: calendarsupport-lang libKF5CalendarSupport5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== cim-schema ====
Version update (2.49.0 -> 2.50.0)

- Upgrade to 2.50.0
  As part of CIM 2.50.0, a number of enhancements and additions are
  introduced throughout the Schema, including ongoing improvements to
  support product and alliance partners and to support DMTF Profiles and
  Management Initiatives.  Examples include updates to BIOS, printers,
  standard messages, operating system state, modern power management
  paradigms, virtualization and security.
  See https://www.dmtf.org/sites/default/files/cim/cim_schema_v2500/releasenotes.html

==== claws-mail ====
Version update (3.15.1 -> 3.16.0)
Subpackages: claws-mail-lang

- Drop imap-Fix-use-after-free.patch: upstreamed
- Update to 3.16.0:
  * Reworked Preferences dialogs, adding new options
  * Compose: more UTF-8 list-item characters have been added
  * GPG: full key/signature fingerprints are now shown instead of the
    short versions
  * SSL Certificate Manager: added support for ipv6 addresses
  * CLI: the --insert option has been added to --compose, to allow
    inserting files from the command line
  * The HTML parser now supports all entities
  * Tools: a simple bash completion helper has been added,
    tools/bash_completion/claws-mail
  * Updated and added translations
  * Many bug fixes. For complete list please view ChangeLog file

==== cmpi-provider-register ====
Version update (1.0.1 -> 1.1.0)

- Fix upgrade paths from SLE11 (bnc#1072564)
  + Adapt cmpi-provider-register to continue to function and
    maintain sblim-sfcb's providers irrespective if sblim-sfcb is
    present or not. This prevents dangling symlinks and subsequent
    failures in registration/deregistration RPM scriptlets.
  + Adapt sfcb_init_script to function with all supported
    codestreams.
- Adapt to python3

==== coreutils ====
Version update (8.28 -> 8.29)
Subpackages: coreutils-lang

- Update to 8.29:
  * Noteworthy changes in release 8.29 (2017-12-27) [stable]
  * * Bug fixes
  b2sum no longer crashes when processing certain truncated check files.
  [bug introduced with b2sum coreutils-8.26]
  dd now ensures the correct cache ranges are specified for the "nocache"
  and "direct" flags.  Previously some pages in the page cache were not
  invalidated.  [bug introduced for "direct" in coreutils-7.5,
  and with the "nocache" implementation in coreutils-8.11]
  df no longer hangs when given a fifo argument.
  [bug introduced in coreutils-7.3]
  ptx -S no longer infloops for a pattern which returns zero-length matches.
  [the bug dates back to the initial implementation]
  shred --remove will again repeatedly rename files with shortening names
  to attempt to hide the original length of the file name.
  [bug introduced in coreutils-8.28]
  stty no longer crashes when processing settings with -F also specified.
  [bug introduced in fileutils-4.0]
  tail --bytes again supports non seekable inputs on all systems.
  On systems like android it always tried to process as seekable inputs.
  [bug introduced in coreutils-8.24]
  timeout will again notice its managed command exiting, even when
  invoked with blocked CHLD signal, or in a narrow window where
  this CHLD signal from the exiting child was missed.  In each case
  timeout would have then waited for the time limit to expire.
  [bug introduced in coreutils-8.27]
  * * New features
  timeout now supports the --verbose option to diagnose forced termination.
  * * Improvements
  dd now supports iflag=direct with arbitrary sized files on all file systems.
  tail --bytes=NUM will efficiently seek to the end of block devices,
  rather than reading from the start.
  Utilities which do not support long options (other than the default --help
  and --version), e.g. cksum and sleep, now use more consistent error diagnostic
  for unknown long options.
  * * Build-related
  Default man pages are now distributed which are used if perl is
  not available on the build system, or when cross compiling.
- Refresh patches (line number changes only):
  * coreutils-i18n.patch
  * coreutils-remove_hostname_documentation.patch
  * coreutils-remove_kill_documentation.patch
  * coreutils-tests-shorten-extreme-factor-tests.patch

==== digikam ====
Version update (5.7.0 -> 5.8.0)
Subpackages: kipi-plugins kipi-plugins-lang

- Update to 5.8.0:
  * https://www.digikam.org/news/2018-01-14-5.8.0_release_announcement/
- New features (from NEWS):
  General      : Add support to OpenCV 3.4.x.
  General      : Updated internal Libraw to last 0.18.6.
  General      : New Upnp/Dlna media server to share collections on local network.
  Image Editor : New clone tool to replace old CImg in-painting tool.
  DropBox : tool ported AuthO2 API.
- 231 bugs fixed
- Remove unneeded libkface-devel build requirement, it's not used
  anymore since over 2 years
- Add 0001-Revert-replace-obsolete-qSort-function.patch and
  0002-Revert-replace-obsolete-qSort-function.patch to fix build
  with gcc 4.8 on Leap 42
- Add fix-italian-docs-with-older-kdoctools.patch to make it build
  on Leap 42.2
- Pass --without-kde to %find_lang to prevent the docs being added
  to the lang package, we have a separate docs subpackage
  (it supports the KF5 docs location starting with rpm 4.14.0, and
  that would break the build)
- Drop upstream patches:
  * Adapt-to-KCalCore-API-changes.patch
  * fix-Qt-5.9.3-empty-album-problem.patch

==== dolphin ====
Version update (17.12.0 -> 17.12.1)
Subpackages: dolphin-part libdolphinvcs5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * infopanel fully resizable
  * Revive folderpanel when outside $HOME
  * Ignore baloo urls created from new KIO model (kde#387888)

==== dpdk ====

- Enable(disabled by default) MLX4 and MLX5 pmd(fate#322609)

==== dragonplayer ====
Version update (17.12.0 -> 17.12.1)
Subpackages: dragonplayer-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== epiphany ====
Subpackages: epiphany-lang gnome-shell-search-provider-epiphany

- Add epiphany-search-provider-fix.patch: Fix typos in
  serviceprovider, make it actually work (bgo#792502).
- Add epiphany-fix-download-of-blob-URIs.patch: Fix download of
  blob URIs. Epiphany doesn't recognize blob as a web scheme,
  causing it to try opening it in an external URI handler in it's
  policy decision callback (bgo#788576).
- Pass explicit developer_mode=false, https_everywhere=false and
  unit_tests=false options to meson, ensure we build the features
  we want.

==== eventviews ====
Version update (17.12.0 -> 17.12.1)
Subpackages: eventviews-lang libKF5EventViews5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * agendaview.cpp - in loadDecorations(), don't add failed decos to the list if unable to load the decoration associated with the specified plugin name

==== grantleetheme ====
Version update (17.12.0 -> 17.12.1)
Subpackages: grantleetheme-lang libKF5GrantleeTheme5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== gwenview5 ====
Version update (17.12.0 -> 17.12.1)
Subpackages: gwenview5-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Fix failing PlaceTreeModelTest autotest (kde#387824)
  * Respect custom filename for Copy/Move/Link To operations (kde#388144)
  * Fix displaying RW2 files with shared-mime-info 1.9
  * Fix expanding of baloo URLs in folders sidebar tree view
  * Revert changes caused by mistake from previous commit
  * Fixed places side panel for baloo urls
  * Update titlebar after image modification (kde#345980)
  * Correct margin for left sidebar (kde#381535)

==== gzip ====
Version update (1.8 -> 1.9)

- license is GPL-3.0+
- Update to 1.9
  * Fix suffix handling
  * Fix bug when handling pack format while decompressing
  * Fix time handling bug
  * Improve exit code handling for shell scripts
- remove gzip-1.8-fix_unpack_EOB_check.patch as it is included
  upstream now
- refresh manpage-no-date.patch
- spec file cleanups
- add gzip-1.8-deprecate_netstat.patch to get rid of deprecated
  'netstat -n' command in tests/init.sh script

==== incidenceeditor ====
Version update (17.12.0 -> 17.12.1)
Subpackages: incidenceeditor-lang libKF5IncidenceEditor5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== installation-images-Kubic ====

- Switch openSUSE and Kubic to storage-ng.

==== irssi ====
Version update (1.0.6 -> 1.1.0)

- update to 1.1.0
  * Changes
    + Colour is now re-set when reaching a comma, matching mIRC
    behaviour
    + Irssi now shows the initial nick and name on first start
    + lynx is no longer required to run autogen.sh
    + The command history no longer permits wrapping around
    + /foreach now correctly sends arguments as commands, stopping
    you from embarassing AMSGs
    + /server does not connect to servers anymore, use /server
    connect to change servers
    + The net_ip_compare API function is now deprecated, and the
    previously deprecated net_connect has been removed
  * Additions
    + Add an option to ignore all channels or ignore all queries
    using /set activity_hide_targets
    + Add a startup warning if the TERM var is wrong inside tmux /
    screen
    + Add option to hide certain levels from the textbuffer using /
    window hidelevel
    + Irssi now has its first unit test (for mode parsing)
    + Added access to global command history when using window
    history, and a binding to erase entries from the command
    history (erase_history_entry)
    + -alternate_nick is now available as a network specific
    property
    + On FreeBSD, Irssi now supports Capsicum sandbox (/capsicum
    enter)
    + Filenames (directories) ending with a / now tab-complete
    + UTF-8 should now work in regular expressions when using
    GRegex (the default)
    + Nicks are now properly escaped on completion
    + /server add -port now works
    + Add a setting key_timeout to make key sequences
    automatically re-set when not finished
    + Warn users about expired client certificates, as servers
    may refuse them
    + Add a new net_start_ssl function for StartTLS. This is
    available from ABI 8 and can be used by protocol modules
    + The %# code is now stored in the textbuffer, so for example
    web scripts can make use of it
    + Add new setting break_wide which can be used to enable
    breaking of wide characters (for east-asian users)
    + Add fuzzing code
  * Fixes
    + Netsplits show properly again
    + Do not error on blank lines when using /exec -o
    + Detect used nickname as reported by server
    + Prevent use after free error during the execution of some
    commands
    + Fix MODE parameter parsing when colon was used at a place
    Irssi didn't expect
    + Fixed code to compile with -Werror=declaration-after-statement
    + Clang-format is now supported for git-clang-format
    + Fix use after free when changing the network of hilights
    + Fix positioning error when tab-completing non-ascii strings
    + In-development issues
    + Clarify Alis in /help list
    + Improve /lastlog performance from O(N^2) to O(N)
    + Fix a segfault on "script destroyed" signal
    + Fix early ISON error
    + Documentation improvements
    + Minor cleanups
    + Fix space issue in glib-2.0.m4
- cleanup with spec-cleaner
- drop regex-patch-653.patch
  * fixed upstream in 79bbca4644cad7f2dee89c7ac6b8f9acc2c8b427

==== kaccounts-integration ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kaccounts-integration-lang libkaccounts1

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kaccounts-providers ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kaccounts-providers-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kaddressbook ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kaddressbook-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kalarmcal ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kalarmcal-lang libKF5AlarmCalendar5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kamera ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kamera-lang kio_kamera

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kate ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kate-lang kate-plugins

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Clear konsole command-line before directory change

==== kcalc ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kcalc-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kcalcore ====
Version update (17.12.0 -> 17.12.1)

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Fix a porting bug when persing timezones

==== kcalutils ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kcalutils-lang libKF5CalendarUtils5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kcharselect ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kcharselect-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kcolorchooser ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kcolorchooser-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kcontacts ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kcontacts-lang libKF5Contacts5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kdav ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKPimKDAV5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kdenetwork4-filesharing ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kdenetwork4-filesharing-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kdepim-addons ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kdepim-addons-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * We still need it as a slot.

==== kdepim-apps-libs ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kdepim-apps-libs-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kdepim-runtime ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kdepim-runtime-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * DAV: fix Next button not enabled when typing password.
  * Add Sasl2_INCLUDE_DIRS to the inlclude directories of kdexoauth2
  * cmake: Strip comments from else()/endif()
  * Use ecm_install_icons instead of a loop
  * Use KDE_INSTALL_ICONDIR instead of CMAKE_INSTALL_PREFIX

==== kdialog ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kdialog-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kget ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kget-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Simplify and fix "Download again?" dialog
  * Fix path/Url issues in checksumsearch plugin
  * [metalink] Don't duplicate slash
  * Fix Transfer::directory()
  * Fix MMS downloads
  * [newtransferdialog] Use "Save Mode" for the destination file dialog
  * Simplify transfer history dialog and save correct its size.

==== kgpg ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kgpg-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== khelpcenter5 ====
Version update (17.12.0 -> 17.12.1)
Subpackages: khelpcenter5-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kholidays ====
Version update (17.12.0 -> 17.12.1)

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kidentitymanagement ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kidentitymanagement-lang libKF5IdentityManagement5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kimap ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kimap-lang libKF5IMAP5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kio-extras5 ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kio-extras5-lang libkioarchive5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kio_audiocd ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kio_audiocd-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kldap ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kldap-lang libKF5Ldap5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kleopatra ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kleopatra-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Fix signature guessing
  * Fix S/MIME CSR Creation

==== kmag ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kmag-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kmail ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kmail-application-icons kmail-lang ktnef

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kmail-account-wizard ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kmail-account-wizard-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kmailtransport ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kmailtransport-lang libKF5MailTransport5 libKF5MailTransportAkonadi5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kmbox ====
Version update (17.12.0 -> 17.12.1)

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kmime ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kmime-lang libKF5Mime5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kmousetool ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kmousetool-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== knotes ====
Version update (17.12.0 -> 17.12.1)
Subpackages: knotes-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kompare ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kompare-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== konqueror ====
Version update (17.12.0 -> 17.12.1)
Subpackages: konqueror-devel konqueror-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== konsole ====
Version update (17.12.0 -> 17.12.1)
Subpackages: konsole-part

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kontact ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kontact-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kontactinterface ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kontactinterface-lang libKF5KontactInterface5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== korganizer ====
Version update (17.12.0 -> 17.12.1)
Subpackages: korganizer-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kpimtextedit ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kpimtextedit-lang libKF5PimTextEdit5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Remove duplicate line

==== kqtquickcharts ====
Version update (17.12.0 -> 17.12.1)

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Mark Label and LineLabel types as internal
  * Add missing types to qmldir
- Dropped patches, now upstream:
  * Add-missing-types-to-qmldir.patch

==== krdc ====
Version update (17.12.0 -> 17.12.1)
Subpackages: krdc-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Don't use qCritical for debug output, that's what qCDebug is for.

==== krfb ====
Version update (17.12.0 -> 17.12.1)
Subpackages: krfb-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kruler ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kruler-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== ksmtp ====
Version update (17.12.0 -> 17.12.1)
Subpackages: ksmtp-lang libKPimSMTP5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Send the correct hostname with the HELO/EHLO command (kde#387926)
  * Fix duplicate authentication (kde#387926, kde#388068)
  * Add .arcconfig
  * show error string instead error number
  * do not cancel send job after 10s timeout (kde#387613)
- Dropped patches, now upstream:
  * 0001-Fix-duplicate-authentication.patch
  * 0002-Send-the-correct-hostname-with-the-HELO-EHLO-command.patch

==== ktnef ====
Version update (17.12.0 -> 17.12.1)
Subpackages: ktnef-lang libKF5Tnef5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kwalletmanager5 ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kwalletmanager5-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libgooglepinyin ====

- fix build
- Fix ibus-googlepinyin working in 64bit for openSUSE
- fix builds on fedora.
- Update Source to latest git
  Fix builds, merge changelog
- first build

==== libgravatar ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKF5Gravatar5 libgravatar-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libkcddb ====
Version update (17.12.0 -> 17.12.1)

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libkcompactdisc ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKF5CompactDisc5 libkcompactdisc-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libkdcraw ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKF5KDcraw5 libkdcraw-devel

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libkdepim ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libkexiv2 ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKF5KExiv2-15_0_0 libkexiv2-devel

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libkgapi ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5 libKPimGAPITasks5 libkgapi-lang

- Add Fix-token-page-URL.patch to make authentification with
  Google services work again after a change by Google (kde#388483)
- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libkgeomap ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKF5KGeoMap10_0_0 libkgeomap-devel

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libkipi ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKF5Kipi32_0_0 libkipi-data libkipi-devel

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libkleo ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKF5Libkleo5 libkleo-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Fix sorting in KeyRearrangeColumnsProxyModel

==== libkomparediff2 ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libkomparediff2-5 libkomparediff2-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libksane ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKF5Sane5 libksane-devel libksane-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libksieve ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libksieve-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * We just need address header not all
  * Fix Bug 381714 - Cancelling sieve management operation has no effect (kde#381714)

==== libxcb ====
Subpackages: libxcb-composite0 libxcb-damage0 libxcb-devel libxcb-dpms0 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0 libxcb-randr0 libxcb-record0 libxcb-render0 libxcb-render0-32bit libxcb-res0 libxcb-screensaver0 libxcb-shape0 libxcb-shm0 libxcb-shm0-32bit libxcb-sync1 libxcb-xf86dri0 libxcb-xfixes0 libxcb-xinerama0 libxcb-xkb1 libxcb-xtest0 libxcb-xv0 libxcb-xvmc0 libxcb1 libxcb1-32bit

- Enable xinput extension. (bnc#1074249)
- U_add-support-for-eventstruct.patch
  * Update xinput to the state when it was enabled by default
    upstream.
- n_If-auth-with-credentials-for-hostname-fails-retry-with-XAUTHLOCALHOSTNAME.patch
  * Prevent infinite loop also in case DISPLAY is non-local.
- Use spaces instead of tabs in the patches (as does the original
  source code) to avoid confusion.
- n_If-auth-with-credentials-for-hostname-fails-retry-with-XAUTHLOCALHOSTNAME.patch
  * If authentication (with *stage == 0) failed and the variable
    XAUTHLOCALHOSTNAME wasn't set, we were never getting to stage 2
    in the original patch, causing calls to xcb_connect_to_display
    to be stuck in an infinite loop.
    Now we also go to stage 2 if the variable isn't set.

==== llvm4 ====
Subpackages: clang4-checker libLLVM4 libclang4

- Place gold plugin to the right directory. (bnc#1073210)
  * It must be in /usr/lib/bfd-plugins on all architectures.
  * Remove llvm5-gold from baselibs.conf - nothing needs a 32bit
    version of it and it would now conflict with the 64bit one.
- Reduce _constraints requirements on 32bit architectures.
  * Since we had to disable debuginfo on them, they require much
    less.
- disable debuginfo for arm as well

==== llvm5 ====
Subpackages: clang5 libLLVM5 libLTO5 libc++-devel libc++1 libc++abi-devel libc++abi1 libclang5 libomp5-devel

- Place gold plugin to the right directory. (bnc#1073210)
  * It must be in /usr/lib/bfd-plugins on all architectures.
  * Remove llvm5-gold from baselibs.conf - nothing needs a 32bit
    version of it and it would now conflict with the 64bit one.
- Reduce _constraints requirements on 32bit architectures.
  * Since we had to disable debuginfo on them, they require much
    less.
- ignore make check error for PowerPC as bypass
  https://bugs.llvm.org/show_bug.cgi?id=35871
- disable debuginfo build for ARM as well

==== mailcommon ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKF5MailCommon5 mailcommon-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== mailimporter ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKF5MailImporter5 libKF5MailImporterAkonadi5 mailimporter-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== marble ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libastro1 libmarblewidget-qt5-28 marble-devel

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== messagelib ====
Version update (17.12.0 -> 17.12.1)
Subpackages: messagelib-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Repair Page Down with Qt 5.9, there documentElement.scrollTop doesn't work.
  * Fix Bug 388440 - scrolling in KMail: "page down" only works once (kde#388440)
  * Add the values of the Inotify find call to the appropriate lists
  * Not necessary to use private class here
  * Hide widget when we change message
- Dropped patches, now upstream:
  * 0001-Fix-Bug-388440-scrolling-in-KMail-page-down-only-wor.patch

==== mobipocket ====
Version update (17.12.0 -> 17.12.1)

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== okular ====
Version update (17.12.0 -> 17.12.1)
Subpackages: okular-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * remove deprecated Encoding key from desktop files
  * Fix testSaveAsUndoStackAnnotations autotest
  * Don't call m_formsMessage->setVisible( true ) on unsetDummyMode

==== patterns-base ====
Subpackages: patterns-base-apparmor patterns-base-apparmor_opt patterns-base-base patterns-base-basesystem patterns-base-console patterns-base-enhanced_base patterns-base-enhanced_base_opt patterns-base-minimal_base patterns-base-minimal_base_conflicts patterns-base-sw_management patterns-base-x11 patterns-base-x11_opt patterns-base-x86

- Remove finger from enahnced_base_opt as functionality already
  provided by pinky in coreutils.
- Replace SuSEfirewall2 with firewalld in enhanced_base
  (fate#323460).
- Switch ntp-client from ntp to chrony: replace corresponding
  recommends in console and enhanced_base pattern (FATE#323432).

==== patterns-media ====
Subpackages: patterns-media-rest_cd_core patterns-media-rest_dvd

- Replace yast2-storage with yast2-storage-ng in rest_cd_core.

==== patterns-yast ====
Version update (20170319 -> 20180105)
Subpackages: patterns-yast-x11_yast patterns-yast-yast2_basis patterns-yast-yast2_install_wf

- Added yast2-registration to the "yast2_basis" pattern (SLE only)
  (bsc#1073332)
- 20180105
- yast2_theme not yast2-theme
- Do branding seperately for SLE vs openSUSE
- Require current yast2-branding-openSUSE rather then
  yast2-theme-openSUSE
- 20171005
- Update the YaST development pattern to install the Ruby gems
  used in development, removed dropped *-devel-doc packages
  (bsc#1020033)
- Tidy up for SLE 15
  * Drop the following (removed from Factory)
  * yast2-kerberos-client
  * yast2-packager-webpin
  * yast2-product-creator
  * yast2-autofs
  * yast2-mail-plugins
  * yast2-phone-services
  * yast2-theme-openSUSE-Crystal
  * yast2-fingerprint-reader
  * yast2-tv
  * Drop the following (Dependency dropped)
  * inst-source-utils
  * createrepo
  * star
  * ivtv
  * alevt
  * kradio
  * motv
  * nxtvepg
  * v4l-tools
  * Re order some things to alphabetical order
- Recommend ntp here rather then in patterns-base as a work around
  for boo#936378
- replace yast2-storage by yast2-storage-ng (fate#318196)

==== perl ====
Subpackages: perl-base perl-doc

- ignore make check transient errors for PowerPC
  that are reported since 20170907
  bypass boo#1063176
  new patch: perl_skip_flaky_tests_powerpc.patch

==== pimcommon ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKF5PimCommon5 libKF5PimCommonAkonadi5 pimcommon-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== spectacle ====
Version update (17.12.0 -> 17.12.1)
Subpackages: spectacle-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== sweeper ====
Version update (17.12.0 -> 17.12.1)
Subpackages: sweeper-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== syndication ====
Version update (17.12.0 -> 17.12.1)

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== systemd ====
Subpackages: libsystemd0 libsystemd0-32bit libudev-devel libudev1 libudev1-32bit systemd-32bit systemd-bash-completion systemd-logger systemd-sysvinit udev

- Import commit cc94ce8513221061898c83f57862544b16021f0e
  aa3eba828 delta: don't ignore PREFIX when the given argument is PREFIX/SUFFIX
  b1ea0173a delta: extend skip logic to work on full directory paths (prefix+suffix) (bsc#1070428)
  77c5065f9 delta: check if a prefix needs to be skipped only once
  db32866d1 Fix parsing of features in detect_vm_xen_dom0 (#7890) (bsc#1048510)
  11d40461a sd-bus: use -- when passing arguments to ssh (#6706)
  1148d99f6 tmpfiles: consider /etc uninitialized also when /etc/machine-id is present but empty (#7849) (bsc#1075179)
  3a95f69bf tmpfiles: downgrade warning about duplicate line
- Edit scripts-systemd-fix-machines-btrfs-subvol.sh
  We shouldn't be creating a /var/lib/machines subvolume if /var is
  already a seperate partition or subvolume. /var/lib/machines will
  already be excluded from snapper & similar tooling in this case.

==== tomcat ====
Subpackages: tomcat-admin-webapps tomcat-el-3_0-api tomcat-jsp-2_3-api tomcat-lib tomcat-servlet-4_0-api tomcat-webapps

- Modified patch:
  * tomcat-9.0-javadoc.patch
    + Don't append to javadoc --add-modules since we are building
    with source=8
    + Avoid accessing Internet URLs from build environment

==== virt-manager ====
Subpackages: virt-install virt-manager-common

- Fix a python3 UnboundLocalError (bsc#1075622)
  c174b550-connection-Another-py3-exception-variable-fix.patch

==== yast2 ====
Version update (4.0.11 -> 4.0.35)

- fix having some roles without description when choosing
  different extensions during installation (bsc#1070726)
- 4.0.35
- Firewalld export: Return empty hash if the package has not
  been installed. (fate#323460)
- 4.0.34
- Adding a workflow from other products: If there are no modules
  have beed defined we are using the modules defined in
  append_modules. (bnc#1075182)
- 4.0.33
- Firewalld: Allow to modify default zone and export configuration
  (fate#323460).
- 4.0.32
- bnc#1073727
  - ignored some of typical backup extensions (like .bak, .orig)
    when loading ifcfg files
- 4.0.31
- Firewalld: Extend handling of zones for AutoYaST configuration
  (fate#323460).
- 4.0.30
- Firewalld API: Use string command with all api methods which
  expect string outputs (bsc#1070559)
- 4.0.29
- Firewalld API: Added convenient methods for query commands and
  string expected output commands (bnc#1070559).
- 4.0.28
- Warn the user if the infrastructure is not available for running
  the second stage (bnc#1061754)
- 4.0.27
- Improve tests for CWM::Pager (part of fate#318196).
- 4.0.26
- Recognize CTC devices named like slc600 (bsc#1058227).
- Stopped treating old-style hotplug devices specially.
- 4.0.25
- save_y2logs: save also /linuxrc.config and /etc/os-release files
  for easier debugging
- CWM: make method Pager#current_page public.
- Necessary for fate#318196.
- 4.0.24
- bnc#1061306
  - provided new function for querying net device configuration to
    avoid internal errors when querying cached devices
    inconsistently
- 4.0.23
- Replace references to /var/adm/fillup-templates with new
  %_fillupdir macro (boo#1069468).
- 4.0.22
- Added missing y2firewall/firewalld/zone.rb file to the Makefile
  (fate#323460).
- 4.0.21
- Fixed a bug selecting rows programmatically for CWM::Table
  (bsc#1070287).
- 4.0.20
- Add new Yast2::Popup class providing nicer API for invoking
  popups (hackweek project)
- 4.0.19
- bnc#956755, bnc#1061306 (mfilka)
  - fixed storing device information to avoid incorrect "not found"
    states when querying NetworkInterfaces subsequently
- 4.0.18
- Network:
  - Do not depent on SuSEFirewall to list the known zones anymore.
  - NetworkInterfaces: Remove ZONE attribute if it is empty when
    writing.
- 4.0.17
- Added RSpec shared example for CWM::CheckBox (bsc#1068354).
- 4.0.16
- SuSEFirewall: Export minimal firewalld configuration until the
  AY firewall schema is adapted (bsc#1067193)
- 4.0.15
- fate#323460
  - Firewalld API: added change_interface method
- 4.0.14
- Firewalld API: running? return false if the package is not
  installed (fate#323460)
- 4.0.13
- Network (Firewall):
  - Added support for firewalld offline command
  - Dropped SuSEFirewall (module) support for SuSEFirewall2 backend
  - Adapted some SuSEFirewalldClass methods to work properly during
    installation.
  - Skipped some tests to make it build properly (should be
    replaced by new ones with a new API design)
  (fate#323460)
- 4.0.12
- Adapted SuSEFirewallIsInstalled() to return true only when the
  package is already installed or checked and installed in normal
  mode.
- Added SuSEFirewallIsSelectedOrInstalled() which behaves as the
  old SuSEFirewallIsInstalled() method.
  (bnc#1037214)
- Adapted calls to use SuSEFirewallIsSelectedOrInstalled() when
  the methods can be called even with just Pkg selection.

==== yast2-add-on ====
Version update (4.0.4 -> 4.0.5)

- Fixed a crash when when adding an addon (bsc#1074766)
- 4.0.5

==== yast2-bootloader ====
Version update (3.3.0 -> 4.0.13)

- fix crash for getting partition to activate when stage1 device
  is disk (bsc#1076121)
- 4.0.13
- fix typo in function name (bsc#1075725)
- 4.0.12
- Rely on the new Y2Storage::Devicegraph#find_by_any_name when
  matching udev names to their corresponding kernel device names
  (bsc#1073254).
- 4.0.11
- Legacy (non-EFI) x86: Fixed multi-device booting problems
  (mostly RAID, also LVM and multipath). Now the boot loader is
  written to ALL physical devices that host the boot partition
  (or the MBR). Before, only one of them was picked and the BIOS
  could pick a different one to boot from. (bsc#1072908)
- Related UI change: "Boot Loader Location" has been simplified. We
  kept the option "Boot from Master Boot Record", but the remaining
  three options, for booting from the Boot, Root, or
  Extended partitions, have been unified to a single option
  "Boot from Partition".
- 4.0.10
- fix invalidation of cache causing crash (bsc#1071931)
- 4.0.9
- improve detection of md raids devices (bsc#1063957)
- 4.0.8
- Prevent crash when doing backup of boot sector (bsc#1067131)
- 4.0.7
- Do not propose boot from partition for md raids (bsc#1063957)
- 4.0.6
- use correct function to detect devices (bsc#1059757)
- improve dialog to add devices in bootloader order (bsc#1060172)
- 4.0.5
- merge SLE12 SP3 fixes:
- Fix detection of upgrade of grub2 (bsc#1059603)
- Fallback to default when default section does not exists. It can
  happen during upgrade, when sections are renamed.(bsc#1059603)
- Find correct mbr device to  install grub (bsc#1039712,
  bsc#1052006)
- 4.0.4
- AutoYaST: Do not export stage1 settings anymore (boot_boot,
  boot_custom,...) (bnc#1063975)
- 4.0.3
- Use always kernel name for underlaying devices detection
  (caused by fix for bsc#1057604)
- 4.0.2
- fix regression to udev mapping introduced by new storage-ng
  (bsc#1057604)
- 4.0.1
- make disk order dialog wider to improve readability (bsc#1055647)
- 4.0.0
- Do not propose to stage1 to be installed to encrypted partition
  (bsc#1056862)
- 3.3.3
- Allow installation of system without grub if it will not be
  used (bsc#1014167)
- 3.3.2
- merge storage-ng branch to master
- note: all changes below with this date belong to the merge
- 3.3.1
- not everything is a disk, use libstorage's partitionable instead
- storage-ng: adapted calls to temporary y2storage_* methods, since
  they were finally removed from Y2Storage::StorageManager.
- storage-ng: adapt detection of PReP partition
- Merged master to storage-ng branch
- Adapt the module to use the new storage-ng during system cloning
  (bsc#1047245)
- storage-ng:
- implement detection of encrypted boot
- storage-ng: use new wrapper API
- storage-ng: fixed proposal to not try to install to LVM
  partition
- storage-ng: avoid call to old libstorage
- storage-ng: fixed proposal to work with LVM and encrypted LVM
- storage-ng: simplify code by using a new query function in
  yast2-storage-ng (#with_name_or_partition)
- storage-ng: fixed minimal legacy proposal to work with GPT
- storage-ng: fixed minimal EFI proposal
- storage-ng: made minimal legacy proposal work
- make simple EFI proposal work with storage-ng
- storage-ng: removed dependency from (old) yast2-storage, even
  if it breaks some functionality.

==== yast2-country ====
Version update (4.0.6 -> 4.0.16)
Subpackages: yast2-country-data

- drop writting and reading keys KEYTABLE and COMPOSETABLE in
  /etc/sysconfig/keyboard (bsc#1075828, fate#319454)
- 4.0.16
- adjust calling systemd-firstboot for keyboard setting
  (bsc#1074481)
- 4.0.15
- adapt handling of console and time zone settings (fate#319454)
- 4.0.14
- AutoYaST upgrade fix: Writing keyboard settings defined in the
  AutoYaST configuration file (bnc1070305).
- 4.0.13
- install chrony instead of ntp when ntp is enabled (fate#323432)
- 4.0.12
- do not touch variables in sysconfig/language, which are used for
  default console settings (not system locale) (fate#319454)
- 4.0.11
- Move the y2country/language_dbus.rb file to the
  yast2-country-data subpackage where it is needed by Language.rb
  (bsc#1069119)
- 4.0.10
- Fixed testcase dependencies. (Fix for previous change
  for fate#319454).
- 4.0.9
- fix building depending packages after adaptation of locale
  handling (fix for previous change for fate#319454)
- 4.0.8
- adapted the locale handling (fate#319454)
- removed root-specific locale setting
- 4.0.7

==== yast2-firewall ====
Version update (3.2.0 -> 4.0.8)

- AutoYaST: Added support to set the default zone and export the
  configuration. (fate#323460)
- 4.0.8
- AutoYaST: Reading settings only if the firewalld is installed.
  (fate#323460)
- 4.0.7
- AutoYaST: Firewalld schema is now the default but SuSEFirewall2
  based profiles will still work although not all the properties
  are supported (#fate#323460)
- 4.0.6
- Proposal: When the Firewall is disabled, open/close port links
  are not shown in the proposal and are disabled in the specific
  proposal dialog (bsc#1068354).
- 4.0.5
- Do not touch firewalld services if it is not enabled in the
  proposal (bsc#1067915)
- Fixed a SuSEFirewallCmdLine firewalld api call.
- 4.0.4
- ProposalSettings: fixed an attribute name error when trying to
  block vnc port (bsc#1067320)
- 4.0.3
- ProposalSettings: fixed method name when vnc is enable by Linuxrc
  (bsc#1067320)
- 4.0.2
- Added missing require (bsc#1067180)
- 4.0.1
- Remove support for SuSEFirewall2 in firewall client supporting
  only firewalld (fate#323460)
- 4.0.0

==== yast2-installation ====
Version update (3.3.5 -> 4.0.22)

- Fix initialization to copy the profile to /tmp/profile again
  (bsc#1075334)
- 4.0.22
- Fixed popup layout for bnc#1061754.
- 4.0.21
- Warn the user if the infrastructure is not available for running
  the second stage (bnc#1061754)
- 4.0.20
- Removal of SYSTEMCTL_OPTIONS environment variable (fate#323393)
- 4.0.19
- drop copy_to_system support (FATE#320873)
- 4.0.18
- Log the system name at start to see which system is running
  in the inst-sys (for easier debugging)
- Replaced Remote module by the new y2remote/remote class
  (bsc#1070582)
- Updated yast2-network dependency.
- 4.0.17
- Filter out modules extensions based on product, using white list
  approach (fate#324198)
- 4.0.16
- Break autoyast2 and yast2-installation dependency cycle
  (bsc#1070996)
- 4.0.15
- Do not ignore start_multipath setting (bsc#1070343).
- 4.0.14
- Replace references to /var/adm/fillup-templates with new
  %_fillupdir macro (boo#1069468).
- Unify firewall proposals and finish clients replacing
  firewall_stage1_finish by firewall_finish. (fate#323460)
- 4.0.13
- Cleanup old registration attempts before starting Installer. This
  is needed for restarted installation after it has been aborted
  earlier (bsc#1065167).
- 4.0.12
- Always show the license agreement on single product media,
  even during upgrade (bsc#1065172)
- 4.0.11
- Less eager inst-sys cleanup, libzypp actually needs some cached
  files during package installation, remove only the white listed
  known files (bsc#1063459)
- 4.0.10
- umount efivars properly (bsc#1063063)
- 4.0.9
- Write polkit settings even if no desktop is selected
  (bsc#1062788)
- 4.0.8
- Adapted complex welcome client allowing to continue with the
  installation when there are no products available. (bsc#1059070)
- 4.0.7
- Dropped call of dasd_reload which caused renumbering of disks and
  user got confused.(FATE#318138)
- 4.0.6
- AY: Warn the user if an remote installation is not completely
  possible because there are not all needed packages availble in
  the installed system. (bnc#1055279, bnc#1058071)
- 4.0.5
- Add support to read release notes from an RPM in the
  repository (fate#323273)
- 4.0.4
- Add support for system roles ordering (related to bsc#1049297)
- Do not allow changing the selected base product on an already
  registered system (bsc#1060252)
- Re-activated the step to search for system files (users and SSH
  keys) in existing systems. It was temporarily disabled during the
  migration to storage-ng (part of fate#323837).
- 4.0.3
- Removed obsolete inst_info client which is not used anymore.
  (bsc#1047060)
- 4.0.2
- Adapt to new yast2-country changes (needed for FATE#323837)
- 4.0.1
- Download release notes only for the selected products (if any
  product is already selected) (bsc#1056872)
- 4.0.0
- Fix license confirmation handling on single product medias
  (fate#322276)
- 3.3.13
- Configure Snapper at the end of installation if requested
  (part of fate#318196).
- 3.3.12
- On multi-product installation medias, the product selection
  happens in the welcome screen (fate#322276)
- 3.3.11
- Skip complex welcome module in auto mode.
- 3.3.10
- Show README.BETA if it exists (bsc#1047060)
- 3.3.9
- Show the product's license from libzypp in the welcome screen
  (FATE#322276)
- 3.3.8
- Replace Installation::Product and Installation::ProductReader
  classes by Y2Packager::Product and Y2Packager::ProductReader
  (related to FATE#322276)
- 3.3.7
- Merged storage-ng branch to master (fate#318196)
- Note: all changes below with this date belong to the merge.
- 3.3.6
- storage-ng: adapted to the new Y2Storage::StorageManager API
  and improved probing and activation of storage devices.
- adapted inst_disks_activate.rb to storage-ng
- storage-ng: Taking /usr/bin/findmnt in order to evaluate mount
  points. Floppy support removed.
- storage-ng: use the new library for storage hardware probing
  (devicegraph) instead of the old one (targetmap)
- storage-ng: removed dependency from (old) yast2-storage, even
  if it breaks some functionality.
- storage-ng: commented installation-related code relying on the
  old yast2-storage

==== yast2-mail ====
Version update (3.1.10 -> 4.0.0)

- Replace references to /var/adm/fillup-templates with new
  %_fillupdir macro (boo#1069468).
- 4.0.0
- bnc#1022360 Crash during E-Mail-Server setup, when outgoing mailserver is empty
- bnc#994317 yast2 mailserver does not preserve startup setting
- 3.1.11

==== yast2-multipath ====
Version update (3.2.1 -> 4.0.0)

- fate#323526, support python3 and change indentation to 8 spaces.
- 4.0.0
- Use yast2-storage-ng instead of yast2-storage (part of
  fate#318196)
- 3.3.0

==== yast2-network ====
Version update (3.3.6 -> 4.0.13)

- Remote: reimplemented the module dialogs and clients under
  y2remote libdir.
- Fixed restart of xvnc as it is now a socket instead of a service
  (bsc#1070582).
- 4.0.13
- bnc#1061306
  - use API for accessing device's sysconfig to avoid internal
    errors
- 4.0.12
- Switched VNC service from xinetd to systemd.
- VNC over HTTP service can be enabled/disabled separately.
  (fate#323880, bnc#1058460)
- 4.0.11
- Do not depend on SuSEFirewall for zone interface change. The zone
  is now written in the ifcfg-file and wicked takes care of calling
  firewalld commandline. (fate#323460)
- 4.0.10
- AutoYaST: Do not display a warning about second stage being
  disabled when importing the DNS configuration (added in 3.3.1)
  once  the network configuration is done during the first stage
  (since version 3.3.3) (bsc#1069761)
- 4.0.9
- bnc#1066982
  - Removed an unnecesary SuSEFirewall.Write call when storing the
    Firewall remote client configuration.
- 4.0.8
- bnc#1066982
  - fixed initialization and storing of firewall widget
- 4.0.7
- Fixed a method name typo and removed SuSEFirewall from Routing
  module (bsc#572202)
- 4.0.6
- bnc#1052042
  - properly update canonical name and aliases in /etc/hosts when
    FQDN is provided as a hostname
- 4.0.5
- Do not depend on SuSEfirewall2 anymore for writing IPv4
  forwarding as Firewalld will be the default FW in SLE15.
  (fate#323460, bsc#572202)
- 4.0.4
- Remote settings: Only reading firewall settings if we are really
  in an installed system. (bnc#1055279, bnc#1058071)
- 4.0.3
- AutoYaST: Do not display a warning about disabled second stage
  when if network is configured before the proposal (bsc#1054400)
- 4.0.2
- Do not blank out /etc/hosts when no <host> section is defined
  (bsc#1058396)
- 4.0.1
- Preload the global DHCLIENT_SET_HOSTNAME option based on linuxrc
  sethostname option if given or based in control file default if
  not. (bsc#1054933)
- Do not override the configuration with the default defined in
  the control file at the end of the first stage (bsc#1056633)
- 4.0.0
- Moved wrap_text method to yast2 UI::TextHelpers (bsc#1055643)
- 3.3.12
- AutoYaST: Do not display a warning about disabled second stage
  when the hostname setting is read out of profile (bsc#1054400)
- 3.3.11
- bnc#1039656
  - do not clear /etc/hosts when installing virtual Host
- restored part of version 3.3.3 (bnc#1049814) which was
  accidentaly dropped in subsequent versions
- 3.3.10
- use storage-ng code to determine if "/" is on a network filesystem
- 3.3.9
- merge storage-ng branch to master (fate#318196)
- note: all changes below with this date belong to the merge
- 3.3.8
- storage-ng: adapted calls to temporary y2storage_* methods, since
  they were finally removed from Y2Storage::StorageManager.
- Added support to storage-ng so it can verify if a disk is in
  network.
- Updated dependencies to include storage-ng.
- Merged master to storage-ng branch
- Version temporarily bumped to 3.3.x to prioritize the
  storage-ng branch
- storage-ng: commented remaining code relying on the old
  yast2-storage
- Removed yast2-storage dependency
- storage-ng: commented installation-related code relying on the
  old yast2-storage
- Version temporarily bumped to 3.2.x to prioritize this branch
- bnc#1047615
  - check if /etc/hosts exists before loading its content
- 3.3.7

==== yast2-nfs-client ====
Version update (3.1.17 -> 4.0.0)

- Fix teststuite once SuSEFirewall2 is being replaced by Firewalld
  (fate#323460)
- 4.0.0

==== yast2-ntp-client ====
Version update (4.0.0 -> 4.0.6)

- Do minimal modification to default chrony.conf in autoyast
  when chrony is not specified explicitly in packages section of
  profile (bsc#1072595)
- 4.0.6
- Improve AutoYaST error message adaptation when too many
  unsupported keys are found (related to bsc#1072407)
- 4.0.5
- Adapt AutoYaST error message to 80x25 screens (bsc#1072407)
- 4.0.4
- support also autoyast for chrony (FATE#323432)
  NOTE: autoyast profile is not backward compatible
- 4.0.3
- fix crash with missing method ntp_selected (bsc#1071735)
- 4.0.2
- Switch ntp-client from ntp to chrony (FATE#323432)
- 4.0.1

==== yast2-packager ====
Version update (3.3.2 -> 4.0.29)

- Added a new client for displaying the product license at upgrade
  (bsc#1069124)
- 4.0.29
- Decrease the priority of the initial DVD installation repository
  to prefer the packages from the other DVD media (avoid media
  changes between the "Packages" and the "Installer" DVDs)
  (bsc#1071742)
- 4.0.28
- Space check: ignore the partitions mounted before the installer
  is started, e.g. ignore the HDD installation source or the user
  mounts for remote logging (bsc#1073696)
- 4.0.27
- Improved disk usage check - check the parent directory if the
  target directory does not exist (yet) (bsc#1073696)
- 4.0.26
- Allow different handling handling of addons without
  installation.xml file (related to bsc#1074766)
- Display the installation summary tab by default in the package
  manager when adding addons
- 4.0.25
- Warn the user if the infrastructure is not available for running
  the second stage (bnc#1061754)
- 4.0.24
- Do not take into account non-installed products when deciding
  which local repositories should be disabled after the
  installation (bsc#1072595 and also related to bsc#1071702).
- 4.0.23
- Make the dialog for selecting modules from DVD look similar
  to the module selection dialog in registration (bsc#1071771)
- 4.0.22
- Do not cache products status (related to bsc#1072063)
- 4.0.21
- Consider only installed products when deciding whether to disable
  or not local repositories (bsc#1071702).
- 4.0.20
- Allowing AutoYaST to add initialize add-on products provided
  by the repository in order to add DriverUpdate. (bnc#1070804)
- 4.0.19
- VNC does not depend on xinetd anymore. (bsc#1058820)
- 4.0.18
- On single product media, select the available product during
  upgrade (bsc#1066709 and bsc#1065172).
- 4.0.17
- Do not install all available products (like SLED on SLES) during
  upgrade (bsc#1065485)
- 4.0.16
- Fixed spelling. (bnc#1055279, bnc#1058071)
- 4.0.15
- added dependency to yast2-storage-ng (bsc#1062009)
- 4.0.14
- Use `nil` for the default "display_addon_checkbox" value
  to distinguish between the default and a changed value
  to possibly hide the "I would like to install an additional Add On
  Product" check box from the external code (FATE#323163)
- 4.0.13
- Cleaning up DefaultDesktop as its usage is now reduced even for
  SLE (bsc#1057538)
- 4.0.12
- Display a confirmation popup when no add-on is selected from
  a multi-repository medium (bsc#1062356)
- 4.0.11
- Do not abort installation when no add-on product is selected from
  a multi-repository medium (bsc#1062356)
- 4.0.10
- Disable vpn, ssh,... and inform the user if the needed packages
  are not available. (bnc#1055279, bnc#1058071)
- 4.0.9
- Bring back support to read release notes from an URL
  on non-registered systems and as fallback mechanism
  for registered ones (related to fate#323273)
- 4.0.8
- Report error when the repository URL cannot be expanded by
  libzypp (e.g. it is invalid) (bsc#1059744)
- 4.0.7
- Display a product selection dialog when the add-on medium
  contains multiple products (fate#323886)
- 4.0.6
- Add support to read release notes from an RPM in the
  repository (fate#323273)
- 4.0.5
- Display beta info even if the license is not present
  (bsc#1047060).
- 4.0.4
- Do not show license agreement twice for multi product media
  (bsc#1058503)
- 4.0.3
- do not warn that url is already used for multi modules media
  (fate#323450)
- 4.0.2
- show product path in url for multi product media
- for multi product media add product path to repository name
  (fate#323450)
- 4.0.1
- Replace /info.txt by /README.BETA as beta file to be shown
  (bsc#1047060).
- 4.0.0
- Do not copy passwd, group and shadow from ins-sys anymore
  (bsc#1057367).
- 3.3.12
- Product's detection on single product media does not require
  the 'system-installation()' tag anymore (fate#322276)
- 3.3.11
- Report an error when no available base products are found
- Add support to skip validations in the product license widget
  (fate#322276)
- 3.3.10
- Add widgets to show/confirm product licenses (fate#322276)
- 3.3.9
- Do not report an error for optional resolvable patterns
  (bsc#1054670).
- 3.3.8
- Moved repositories and product related classes to this module
- Extended repositories and product related API (FATE#322276)
- Added clients and dialogs to handle products licenses using
  the new yast2-pkg-bindings API
- 3.3.7
- Fixed a bug introduced during the code refactoring associated to
  bsc#1047060
- 3.3.6
- fix typo in storage_include.rb
- 3.3.5
- Merged storage-ng branch (fate#318196).
- Note: all changes below with this date belong to the merge.
- 3.3.4
- storage-ng: adapted to the new Y2Storage::StorageManager API
- Merged master to storage-ng branch
- Synced storage-ng and master branches. See changes below.
- Synced storage-ng and master branches. See changes below.
- Use storage-ng during installation (to check the available space
  and whether the software proposal needs to be re-calculated).
- Removed the client wrapper_storage (obsolete with storage-ng).
- storage-ng: removed yast2-storage buildrequire.
- commented unit tests code relying on the old yast2-storage so
  the package can be built without it.
- prevent crash from add-on workflow (bsc#1053536)
- 3.3.3

==== yast2-update ====
Version update (3.2.2 -> 4.0.8)

- remove obsolete rootpart_check_keyboard client that allows having
  different keyboard in update env and on target disk (related to
  bsc#1075828)
- 4.0.6
- When matching partitions, rely on the new
  Y2Storage::Devicegraph#find_by_any_name (bsc#1073254).
- 4.0.5
- upgrade the system always via equivalent of 'zypper dup'
  (bsc#1071708)
- 4.0.4
- When matching partitions, also use udev names that have been
  discarded by libstorage-ng (bsc#1073254).
- 4.0.3
- Use udev names, in addition to kernel device names, to match
  partitions (part of the fix for bsc#1073254).
- 4.0.2
- Display warning if system uses cryptconfig encrypted home
  directories (fate#323541)
- 4.0.1
- Filter upgradable products in the partition selector already
  (FATE#323163).
- 4.0.0
- Show legacy root filesystems in the list of systems to upgrade
  from (fate#323394).
- 3.3.4
- Use translatable and human-friendly format to display the
  partition id during a system upgrade (part of fate#318196).
- 3.3.3
- Fixed a typo calling a Logger method (bsc#1054236).
- 3.3.2
- Do not allow to upgrade if the target system uses reiserfs
  (fate#323394).
- 3.3.1
- Merged storage-ng branch (fate#318196).
- Note: all changes below with this date belong to the merge.
- 3.3.0
- storage-ng: adapted calls to temporary y2storage_* methods, since
  they were finally removed from Y2Storage::StorageManager.
- Merged master to storage-ng branch
- storage-ng: add detection of previous systems using lvm.
- storage-ng: detection of previous systems partially adapted.

==== yast2-x11 ====
Version update (3.1.5 -> 4.0.0)

- drop note about KEYTABLE (bsc#1075828, fate#319454)
- 4.0.0


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

new requirement bundle-lang-common-ar, re: New Tumbleweed snapshot 20180117 released!

Patrick Shanahan-2
* Dominique Leuenberger <[hidden email]> [01-19-18 15:00]:

>
> Please note that this mail was generated by a script.
> The described changes are computed based on the x86_64 DVD.
> The full online repo contains too many changes to be listed here.
>
> Please check the known defects of this snapshot before upgrading:
> https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180117
>
> When you reply to report some issues, make sure to change the subject.
> It is not helpful to keep the release announcement subject in a thread
> while discussing a specific problem.
>
> Packages changed:

why is bundle-lang-common-ar now required for packages (on my system):

  GimpResourcesThumbnailer           2.1.2-1.346      
  amarok                             2.8.0-97.2      
  autoyast2                          4.0.22-1.1      
  autoyast2-installation             4.0.22-1.1      
  baloo_kcm                          0.1+20141112-2.46
  bluedevil                          2.1.1-27.45      
  breeze4-style                      5.11.5-1.1      
  bundle-lang-common-ar              13.2-65.1        
  kate4-parts                        4.14.3-17.15    
  kde4-kgreeter-plugins              4.11.22-14.1    
  kdebase4-runtime                   17.08.3-4.18    
  kdebase4-workspace-addons          4.11.22-14.1    
  kdebase4-workspace-liboxygenstyle  4.11.22-14.1    
  kdebase4-workspace-libs            4.11.22-14.1    
  kdelibs4                           4.14.38-59.17    
  kdelibs4-branding-openSUSE         13.2-9.11        
  kdelibs4-core                      4.14.38-59.17    
  kdepimlibs4                        4.14.10-27.3    
  kdm                                4.11.22-14.1    
  kio_mtp                            0.75-6.8        
  knutclient                         1.0.5-6.14      
  knutclient-doc                     1.0.5-6.14      
  konsole4-part                      4.14.3-22.17    
  kopete                             17.08.3-1.3      
  krandr                             4.11.22-14.1    
  krename                            4.0.9-20.27      
  kscd                               17.08.3-60.3    
  kvkbd                              0.7.2-30.45      
  kwalletmanager                     15.04.3-2.53    
  kwin                               4.11.22-14.1    
  libakonadi4                        4.14.10-27.3    
  libkatepartinterfaces4             4.14.3-17.15    
  libkcddb4                          16.08.3-1.26    
  libkcompactdisc4                   16.08.3-1.28    
  libkde4                            4.14.38-59.17    
  libkdegames6                       14.12.3-10.10    
  libkdepimlibs4                     4.14.10-27.3    
  libkmahjongglib4                   14.12.3-9.13    
  libkscreen                         1.0.5-2.11      
  libksuseinstall1                   4.14.38-59.17    
  libstorage-ng-ruby                 3.3.112-1.1      
  libstorage-ng1                     3.3.112-1.1      
  plasmoid-cwp                       1.12.0-16.63    
  yast2-add-on                       4.0.5-1.1        
  yast2-bootloader                   4.0.13-1.1      
  yast2-country                      4.0.16-1.1      
  yast2-inetd                        4.0.0-1.1        
  yast2-inetd-doc                    4.0.0-1.1        
  yast2-installation                 4.0.22-1.1      
  yast2-iscsi-client                 3.1.30-1.2      
  yast2-ldap                         3.1.14-1.3      
  yast2-mail                         4.0.0-1.1        
  yast2-metapackage-handler          3.1.4-2.5        
  yast2-network                      4.0.13-1.1      
  yast2-nis-client                   4.0.0-1.2        
  yast2-ntp-client                   4.0.6-1.1        
  yast2-online-update                3.1.11-1.5      
  yast2-online-update-frontend       3.1.11-1.5      
  yast2-packager                     4.0.29-1.1      
  yast2-samba-server                 3.2.2-1.1        
  yast2-storage-ng                   4.0.69-1.1      
  yast2-sudo                         3.1.2-1.4        
  yast2-tune                         4.0.0-1.1        
  yast2-update                       4.0.8-1.1        
  yast2-users                        4.0.1-1.2        
  yast2-vm                           3.2.4-1.2        


rpm -e bundle-lang-common-ar
error: Failed dependencies:
        libstorage-ng-lang is needed by (installed)
        libstorage-ng1-3.3.112-1.1.x86_64
       

--
(paka)Patrick Shanahan       Plainfield, Indiana, USA          @ptilopteri
http://en.opensuse.org    openSUSE Community Member    facebook/ptilopteri
Registered Linux User #207535                    @ http://linuxcounter.net
Photos: http://wahoo.no-ip.org/piwigo                    paka @ IRCnet freenode
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: new requirement bundle-lang-common-ar, re: New Tumbleweed snapshot 20180117 released!

Andrei Borzenkov
20.01.2018 01:11, Patrick Shanahan пишет:

> * Dominique Leuenberger <[hidden email]> [01-19-18 15:00]:
>>
>> Please note that this mail was generated by a script.
>> The described changes are computed based on the x86_64 DVD.
>> The full online repo contains too many changes to be listed here.
>>
>> Please check the known defects of this snapshot before upgrading:
>> https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180117
>>
>> When you reply to report some issues, make sure to change the subject.
>> It is not helpful to keep the release announcement subject in a thread
>> while discussing a specific problem.
>>
>> Packages changed:
>
> why is bundle-lang-common-ar now required for packages (on my system):
>
>   GimpResourcesThumbnailer           2.1.2-1.346      
>   amarok                             2.8.0-97.2      
>   autoyast2                          4.0.22-1.1      
>   autoyast2-installation             4.0.22-1.1      
>   baloo_kcm                          0.1+20141112-2.46
>   bluedevil                          2.1.1-27.45      
>   breeze4-style                      5.11.5-1.1      
>   bundle-lang-common-ar              13.2-65.1        
>   kate4-parts                        4.14.3-17.15    
>   kde4-kgreeter-plugins              4.11.22-14.1    
>   kdebase4-runtime                   17.08.3-4.18    
>   kdebase4-workspace-addons          4.11.22-14.1    
>   kdebase4-workspace-liboxygenstyle  4.11.22-14.1    
>   kdebase4-workspace-libs            4.11.22-14.1    
>   kdelibs4                           4.14.38-59.17    
>   kdelibs4-branding-openSUSE         13.2-9.11        
>   kdelibs4-core                      4.14.38-59.17    
>   kdepimlibs4                        4.14.10-27.3    
>   kdm                                4.11.22-14.1    
>   kio_mtp                            0.75-6.8        
>   knutclient                         1.0.5-6.14      
>   knutclient-doc                     1.0.5-6.14      
>   konsole4-part                      4.14.3-22.17    
>   kopete                             17.08.3-1.3      
>   krandr                             4.11.22-14.1    
>   krename                            4.0.9-20.27      
>   kscd                               17.08.3-60.3    
>   kvkbd                              0.7.2-30.45      
>   kwalletmanager                     15.04.3-2.53    
>   kwin                               4.11.22-14.1    
>   libakonadi4                        4.14.10-27.3    
>   libkatepartinterfaces4             4.14.3-17.15    
>   libkcddb4                          16.08.3-1.26    
>   libkcompactdisc4                   16.08.3-1.28    
>   libkde4                            4.14.38-59.17    
>   libkdegames6                       14.12.3-10.10    
>   libkdepimlibs4                     4.14.10-27.3    
>   libkmahjongglib4                   14.12.3-9.13    
>   libkscreen                         1.0.5-2.11      
>   libksuseinstall1                   4.14.38-59.17    
>   libstorage-ng-ruby                 3.3.112-1.1      
>   libstorage-ng1                     3.3.112-1.1      
>   plasmoid-cwp                       1.12.0-16.63    
>   yast2-add-on                       4.0.5-1.1        
>   yast2-bootloader                   4.0.13-1.1      
>   yast2-country                      4.0.16-1.1      
>   yast2-inetd                        4.0.0-1.1        
>   yast2-inetd-doc                    4.0.0-1.1        
>   yast2-installation                 4.0.22-1.1      
>   yast2-iscsi-client                 3.1.30-1.2      
>   yast2-ldap                         3.1.14-1.3      
>   yast2-mail                         4.0.0-1.1        
>   yast2-metapackage-handler          3.1.4-2.5        
>   yast2-network                      4.0.13-1.1      
>   yast2-nis-client                   4.0.0-1.2        
>   yast2-ntp-client                   4.0.6-1.1        
>   yast2-online-update                3.1.11-1.5      
>   yast2-online-update-frontend       3.1.11-1.5      
>   yast2-packager                     4.0.29-1.1      
>   yast2-samba-server                 3.2.2-1.1        
>   yast2-storage-ng                   4.0.69-1.1      
>   yast2-sudo                         3.1.2-1.4        
>   yast2-tune                         4.0.0-1.1        
>   yast2-update                       4.0.8-1.1        
>   yast2-users                        4.0.1-1.2        
>   yast2-vm                           3.2.4-1.2        
>
>
> rpm -e bundle-lang-common-ar
> error: Failed dependencies:
>         libstorage-ng-lang is needed by (installed)
>         libstorage-ng1-3.3.112-1.1.x86_64
>        
>

If you look at "zypper info --provides bundle-lang-common-XX" you will
see that *every* bundle-lang-common provides the same language components:

or@10:~> zypper info --provides bundle-lang-common-ar
Loading repository data...
Reading installed packages...


Information for package bundle-lang-common-ar:
----------------------------------------------
Repository     : openSUSE-20170729-0
Name           : bundle-lang-common-ar
Version        : 13.2-65.1
Arch           : noarch
Vendor         : openSUSE
Installed Size : 689.2 KiB
Installed      : No
Status         : not installed
Source package : bundle-lang-common-13.2-65.1.src
Summary        : Translations for a Group of Programs
Description    :
    This package groups translations for a dozen of programs which are both
    on the GNOME and KDE CD into languages, not split out into extra
    packages.
Provides       : [115]
...
    libsoup-lang = 2.60.2
    libstorage-ng-lang = 3.3.112
    parted-lang = 3.2
    psmisc-lang = 23.0
...
bor@10:~> zypper info --provides bundle-lang-common-ca
Loading repository data...
Reading installed packages...


Information for package bundle-lang-common-ca:
----------------------------------------------
Repository     : openSUSE-20170729-0
Name           : bundle-lang-common-ca
Version        : 13.2-65.1
Arch           : noarch
Vendor         : openSUSE
Installed Size : 2.0 MiB
Installed      : No
Status         : not installed
Source package : bundle-lang-common-13.2-65.1.src
Summary        : Translations for a Group of Programs
Description    :
    This package groups translations for a dozen of programs which are both
    on the GNOME and KDE CD into languages, not split out into extra
    packages.
Provides       : [115]
...
    libsoup-lang = 2.60.2
    libstorage-ng-lang = 3.3.112
    parted-lang = 3.2
    psmisc-lang = 23.0
...

bor@10:~> zypper se --requires libstorage-ng-lang
Loading repository data...
Reading installed packages...

S | Name           | Summary                        | Type
--+----------------+--------------------------------+--------
  | libstorage-ng1 | Library for storage management | package
bor@10:~>


So zypper picks /some/ package providing libstorage-ng-lang which
happened to be bundle-common-lang-ar.

You can workaround it by pre-installing the "correct"
bundle-common-lang-XX (probably XX == en). But this also means there is
no indication what language user prefers. Do we have any place where
locales user wants to have on the system are recorded?
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: new requirement bundle-lang-common-ar, re: New Tumbleweed snapshot 20180117 released!

Andrei Borzenkov
20.01.2018 09:24, Andrei Borzenkov пишет:
> 20.01.2018 01:11, Patrick Shanahan пишет:
>
> You can workaround it by pre-installing the "correct"
> bundle-common-lang-XX (probably XX == en). But this also means there is
> no indication what language user prefers. Do we have any place where
> locales user wants to have on the system are recorded?
>

Looking at my TW VM I have bundle-lang-common-en which apparently comes
via Supplements namespace:language(en). Are you running with
no-recommends by default?

But anyway, this sounds wrong. Requires does not offer any means to
select the right package so the whole still relies on the correct
package being selected by Supplements; but then what is the print of
using Requires in the first place?
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: new requirement bundle-lang-common-ar, re: New Tumbleweed snapshot 20180117 released!

Thorsten Kukuk
On Sat, Jan 20, Andrei Borzenkov wrote:

> But anyway, this sounds wrong. Requires does not offer any means to
> select the right package so the whole still relies on the correct
> package being selected by Supplements; but then what is the print of
> using Requires in the first place?

Where is a Requires for bundle-lang-*?

I can only find Supplements, Recommends and Conflicts.

  Thorsten

--
Thorsten Kukuk, Distinguished Engineer, Senior Architect SLES & CaaSP
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nuernberg, Germany
GF: Felix Imendoerffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nuernberg)
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: new requirement bundle-lang-common-ar, re: New Tumbleweed snapshot 20180117 released!

Andrei Borzenkov
20.01.2018 11:47, Thorsten Kukuk пишет:

> On Sat, Jan 20, Andrei Borzenkov wrote:
>
>> But anyway, this sounds wrong. Requires does not offer any means to
>> select the right package so the whole still relies on the correct
>> package being selected by Supplements; but then what is the print of
>> using Requires in the first place?
>
> Where is a Requires for bundle-lang-*?
>
> I can only find Supplements, Recommends and Conflicts.
>
>   Thorsten
>

libstorage-ng1 Requires libstorage-ng-lang
Each bundle-lang-common-XX Priovides libstorage-ng-lang

and so on for several dozens xxx-lang
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: new requirement bundle-lang-common-ar, re: New Tumbleweed snapshot 20180117 released!

Patrick Shanahan-2
In reply to this post by Andrei Borzenkov
* Andrei Borzenkov <[hidden email]> [01-20-18 01:46]:

> 20.01.2018 09:24, Andrei Borzenkov пишет:
> > 20.01.2018 01:11, Patrick Shanahan пишет:
> >
> > You can workaround it by pre-installing the "correct"
> > bundle-common-lang-XX (probably XX == en). But this also means there is
> > no indication what language user prefers. Do we have any place where
> > locales user wants to have on the system are recorded?
> >
>
> Looking at my TW VM I have bundle-lang-common-en which apparently comes
> via Supplements namespace:language(en). Are you running with
> no-recommends by default?

yes
 
> But anyway, this sounds wrong. Requires does not offer any means to
> select the right package so the whole still relies on the correct
> package being selected by Supplements; but then what is the print of
> using Requires in the first place?

since en/english is default, there is no need or I have failed for years
to find a need to install "lang" packages and have none on my system(s).
therefore I was somewhat confused by the install of bundle-lang-common-ar
and have since removed it, rm -e --nodef bundle-lang-common-ar, and have
still noticed no problem and made a point to use several of the many apps
zypper wants to remove with bundle-lang-common-ar.

--
(paka)Patrick Shanahan       Plainfield, Indiana, USA          @ptilopteri
http://en.opensuse.org    openSUSE Community Member    facebook/ptilopteri
Registered Linux User #207535                    @ http://linuxcounter.net
Photos: http://wahoo.no-ip.org/piwigo                    paka @ IRCnet freenode
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: new requirement bundle-lang-common-ar, re: New Tumbleweed snapshot 20180117 released!

Andrei Borzenkov
20.01.2018 15:41, Patrick Shanahan пишет:

> * Andrei Borzenkov <[hidden email]> [01-20-18 01:46]:
>> 20.01.2018 09:24, Andrei Borzenkov пишет:
>>> 20.01.2018 01:11, Patrick Shanahan пишет:
>>>
>>> You can workaround it by pre-installing the "correct"
>>> bundle-common-lang-XX (probably XX == en). But this also means there is
>>> no indication what language user prefers. Do we have any place where
>>> locales user wants to have on the system are recorded?
>>>
>>
>> Looking at my TW VM I have bundle-lang-common-en which apparently comes
>> via Supplements namespace:language(en). Are you running with
>> no-recommends by default?
>
> yes
>  
>> But anyway, this sounds wrong. Requires does not offer any means to
>> select the right package so the whole still relies on the correct
>> package being selected by Supplements; but then what is the print of
>> using Requires in the first place?
>
> since en/english is default, there is no need or I have failed for years
> to find a need to install "lang" packages and have none on my system(s).

Yes, that's why I think this Requires is wrong. Message catalogs hardly
can be considered mandatory.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: new requirement bundle-lang-common-ar, re: New Tumbleweed snapshot 20180117 released!

Mykola Krachkovsky
In reply to this post by Patrick Shanahan-2
субота, 20 січня 2018 р. 14:41:09 EET Patrick Shanahan написано:
> since en/english is default, there is no need or I have failed for years
> to find a need to install "lang" packages and have none on my system(s).
> therefore I was somewhat confused by the install of bundle-lang-common-ar
> and have since removed it, rm -e --nodef bundle-lang-common-ar, and have
> still noticed no problem and made a point to use several of the many apps
> zypper wants to remove with bundle-lang-common-ar.

Due to problems with bundles and *-lang packages [1][2] I've locked all of
them:
zypper ll

# | Name                 | Type    | Repository
--+----------------------+---------+-----------
1 | gnome-keyring        | package | (any)    
2 | bundle-lang-other    | package | (any)    
3 | bundle-lang-kde-*    | package | (any)    
4 | bundle-lang-common-* | package | (any)    
5 | bundle-lang-gnome-*  | package | (any)    

long time age. And have no issues with that. Installing libstorage-ng1 and
libstorage-ng-lang doesn't require it for me.

[1] https://bugzilla.opensuse.org/show_bug.cgi?id=1050970
[2] https://lists.opensuse.org/opensuse-factory/2017-07/msg00414.html

--
Kind regards,
Mykola Krachkovsky
--
Найкращі побажання,
Микола Крачковський

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: new requirement bundle-lang-common-ar, re: New Tumbleweed snapshot 20180117 released!

Andreas Schwab-2
In reply to this post by Andrei Borzenkov
On Jan 20 2018, Andrei Borzenkov <[hidden email]> wrote:

> 20.01.2018 11:47, Thorsten Kukuk пишет:
>> On Sat, Jan 20, Andrei Borzenkov wrote:
>>
>>> But anyway, this sounds wrong. Requires does not offer any means to
>>> select the right package so the whole still relies on the correct
>>> package being selected by Supplements; but then what is the print of
>>> using Requires in the first place?
>>
>> Where is a Requires for bundle-lang-*?
>>
>> I can only find Supplements, Recommends and Conflicts.
>>
>>   Thorsten
>>
>
> libstorage-ng1 Requires libstorage-ng-lang
> Each bundle-lang-common-XX Priovides libstorage-ng-lang

I think the issue can happen if there is an inconsistency between what
the *-lang package provides and what the bundle-lang-* packages
provide.  The NVR they provide should always match.

Andreas.

--
Andreas Schwab, SUSE Labs, [hidden email]
GPG Key fingerprint = 0196 BAD8 1CE9 1970 F4BE  1748 E4D4 88E3 0EEA B9D7
"And now for something completely different."
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]