New Tumbleweed snapshot 20171022 released!

classic Classic list List threaded Threaded
47 messages Options
123
Reply | Threaded
Open this post in threaded view
|

New Tumbleweed snapshot 20171022 released!

Dominique Leuenberger

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171022

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
  cpupower
  curl (7.55.0 -> 7.56.0)
  dos2unix (7.3.5 -> 7.4.0)
  eog
  gdm
  glibc
  glibc
  gnome-control-center
  gnome-session
  gnome-shell
  gnome-vfs2
  gtk3
  installation-images-Kubic (14.336 -> 14.339)
  kernel-firmware (20170906 -> 20171009)
  kernel-source (4.13.6 -> 4.13.8)
  libXfont2 (2.0.1 -> 2.0.2)
  libXres (1.0.7 -> 1.2.0)
  libgnome
  libid3tag
  libidl
  libreoffice (5.4.1.2 -> 5.4.2.2)
  libsoup (2.60.0 -> 2.60.1)
  libvirt
  libzypp (16.17.1 -> 16.17.3)
  mutter
  polkit-default-privs
  postfix
  python-certifi
  python-numpy
  rdma-core
  sddm
  shadow
  shared-mime-info
  texlive-specs-m
  unbound (1.6.6 -> 1.6.7)
  vala (0.38.1 -> 0.38.2)
  xdm
  xf86-input-mouse
  xkeyboard-config

=== Details ===

==== cpupower ====
Subpackages: libcpupower0

fate#321274
- Provide rapl domain info (cpupower powercap-info cmd)
  * Add: cpupower_rapl.patch
- Provide rapl power monitoring
  * Add: rapl_monitor.patch

==== curl ====
Version update (7.55.0 -> 7.56.0)
Subpackages: libcurl-devel libcurl4

- Update to 7.56.0 [bsc#1061876, CVE-2017-1000254]
  Changes:
  * curl: enable compression for SCP/SFTP with --compressed-ssh
  * libcurl: enable compression for SCP/SFTP with CURLOPT_SSH_COMPRESSION
  * vtls: added dynamic changing SSL backend with curl_global_sslset()
  * new MIME API, curl_mime_init() and friends
  * openssl: initial SSLKEYLOGFILE implementation
  Security fixes:
  * CVE-2017-1000254 FTP PWD response parser out of bounds read
  Bugfixes:
  * FTP: zero terminate the entry path even on bad input
  * examples/ftpuploadresume.c: use portable code
  * runtests: match keywords case insensitively
  * strtoofft: reduce integer overflow risks globally
  * zsh.pl: produce a working completion script again
  * cmake: remove dead code for CURL_DISABLE_RTMP
  * progress: Track total times following redirects
  * configure: fix --disable-threaded-resolver
  * configure: fix clang version detection
  * darwinssi: fix error: variable length array used
  * configure: check for __builtin_available() availability
  * http_proxy: fix build error for CURL_DOES_CONVERSIONS
  * examples/ftpuploadresume: checksrc compliance
  * ftp: fix CWD when doing multicwd then nocwd on same connection
  * system.h: remove all CURL_SIZEOF_* defines
  * http: Don't wait on CONNECT when there is no proxy
  * system.h: check for __ppc__ as well
  * http2_recv: return error better on fatal h2 errors
  * tftp: fix memory leak on too long filename
  * system.h: fix build for hppa
  * cmake: enable picky compiler options with clang and gcc
  * makefile.m32: add support for libidn2
  * curl: shorten and clean up CA cert verification error message
  * imap: support PREAUTH
  * CURLOPT_USERPWD.3: see also CURLOPT_PROXYUSERPWD
  * examples/threaded-ssl: mention that this is for openssl before 1.1
  * tests: Make sure libtests & unittests call curl_global_cleanup()
  * system.h: include sys/poll.h for AIX
  * darwinssl: handle long strings in TLS certs
  * strtooff: fix build for systems with long long but no strtoll
  * asyn-thread: Improved cleanup after OOM situations
  * curl.h: CURLSSLBACKEND_WOLFSSL used wrong value
  * unit1301: fix error message on first test
  * ossfuzz: moving towards the ideal integration
  * http: fix a memory leakage in checkrtspprefix()
  * examples/post-callback: stop returning one byte at a time
  * schannel: return CURLE_SSL_CACERT on failed verification
  * http-proxy: treat all 2xx as CONNECT success
  * openssl: use OpenSSL's default ciphers by default
  * runtests.pl: support attribute "nonewline" in part verify/upload
  * configure: remove --enable-soname-bump and SONAME_BUMP
  * vtls: fix WolfSSL 3.12 build problems
  * http-proxy: when not doing CONNECT, that phase is done immediately
  * configure: fix curl_off_t check's include order
  * configure: use -Wno-varargs on clang 3.9[.X] debug builds
  * rtsp: do not call fwrite() with NULL pointer FILE *
  * mbedtls: enable CA path processing
  * checksrc: verify more code style rules
  * HTTP proxy: on connection re-use, still use the new remote port
  * tests: add initial gssapi test using stub implementation
  * rtsp: Segfault when using WRITEDATA
  * docs: clarify the CURLOPT_INTERLEAVE* options behavior
  * non-ascii: use iconv() with 'char **' argument
  * server/getpart: provide dummy function to build conversion enabled
  * conversions: fix several compiler warnings
  * openssl: add missing includes
  * schannel: Support partial send for when data is too large
  * socks: fix incorrect port number in SOCKS4 error message
  * curl: fix integer overflow in timeout options
  * cookies: reject oversized cookies instead of truncating
  * cookies: use lock when using CURLINFO_COOKIELIST
  * curl: check fseek() return code and bail on error
  * examples/post-callback: use long for CURLOPT_POSTFIELDSIZE
  * openssl: only verify RSA private key if supported
  * tests: make the imap server not verify user+password
  * imap: quote atoms properly when escaping characters
  * tests: fix a compiler warning in test 643
  * file_range: avoid integer overflow when figuring out byte range
  * reuse_conn: don't copy flags that are known to be equal
  * http: fix adding custom empty headers to repeated requests
  * docs: link CURLOPT_CONNECTTIMEOUT and CURLOPT_CONNECTTIMEOUT_MS
  * connect: fix race condition with happy eyeballs timeout
  * cookie: fix memory leak if path was set twice in header
  * vtls: compare and clone ssl configs properly
  * proxy: read the "no_proxy" variable only if necessary
- Refreshed patches:
  * libcurl-ocloexec.patch
- Removed patches fixed upstream:
  * curl-man3.patch
  * ppc-build.patch
  * curl-http-Don-t-wait-on-CONNECT-when-there-is-no-proxy.patch
  * curl-disable-test1427-i586.patch

==== dos2unix ====
Version update (7.3.5 -> 7.4.0)

- Update to 7.3.5
  * New option --allow-chown to allow file ownership change
    in old file mode.

==== eog ====
Subpackages: eog-lang

- Add eog-spanish-translations.patch: Fix build with new itstool.

==== gdm ====
Subpackages: gdm-lang gdmflexiserver libgdm1 typelib-1_0-Gdm-1_0

- Add gdm-ignore-duplicate-session.patch: Fix gdm session entries
  duplicate (bsc#1060627).
- Have update-alternatives handle Xinit's integration of the
  displaymanager, replacing /etc/sysconfig/displaymanager
  (boo#1053863).
- Drop usage of glib2_gsettings_schema_* and icon_theme_cache_*
  scriptlets, since this is handled by file triggers now.

==== glibc ====
Subpackages: glibc-32bit glibc-locale-32bit

- nscd-libnsl.patch: Remove reference to libnsl from nscd (bsc#1062244)
- Drop glibc-obsolete
- glibc-2.3.90-noversion.diff: remove
- reinitialize-dl_load_write_lock.patch: remove

==== glibc ====
Subpackages: glibc-devel glibc-extra glibc-info glibc-locale nscd

- nscd-libnsl.patch: Remove reference to libnsl from nscd (bsc#1062244)
- Drop glibc-obsolete
- glibc-2.3.90-noversion.diff: remove
- reinitialize-dl_load_write_lock.patch: remove

==== gnome-control-center ====
Subpackages: gnome-control-center-color gnome-control-center-goa gnome-control-center-lang gnome-control-center-user-faces

- Add control-center-network-add-domain-suffix-match.patch:
  wifi: Add domain-suffix-match entry (bgo#787882, bsc#1047509).
- Rebase gnome-control-center-disable-error-message-for-NM.patch
  on 3.26.1.

==== gnome-session ====
Subpackages: gnome-session-core gnome-session-default-session gnome-session-lang

- Make default.desktop session working on wayland.
  Add default.desktop file in '{_datadir}/wayland-sessions/'
  (bsc#1062196).

==== gnome-shell ====
Subpackages: gnome-shell-browser-plugin gnome-shell-calendar gnome-shell-lang

- Add
  gnome-shell-unset-primary-and-bottom-monitor-when-headless.patch:
  fixes a crash when the monitor is turned off (bgo#788607).
- Add gnome-shell-osk-dont-popup-when-not-needed.patch: Stop the
  on-screen keyboard from showing up when touchscreen use doesn't
  activate a text field; patch taken from upstream bug report
  (bgo#788188).
- Update gs-sle-classic-ext.patch to version 3.26.1

==== gnome-vfs2 ====
Subpackages: gnome-vfs2-devel gnome-vfs2-lang

- Add gnome-vfs2-openssl11.patch: Fixed the openssl build by
  replacing the private->ctx usage with a one working for all
  openssl (bsc#1042650).

==== gtk3 ====
Subpackages: gtk3-data gtk3-immodule-amharic gtk3-immodule-inuktitut gtk3-immodule-thai gtk3-immodule-vietnamese gtk3-immodule-xim gtk3-lang gtk3-tools libgtk-3-0 typelib-1_0-Gtk-3_0

- Add gtk3-restore-filechooser-click-behavior.patch: The
  clicking behavior introduced by commit#fb0a13b has confused many
  users in the past 2 years. By reverting the commit, the patch
  makes the primary button clicking behave as consistent as most
  users has been used to (bgo#758065 bsc#1057471).

==== installation-images-Kubic ====
Version update (14.336 -> 14.339)

- Update suse_version check to exclude in ix86 for Leap 15.0.
- merge gh#openSUSE/installation-images#209
- etc: update module.config to match 4.13
- 14.339
- merge gh#openSUSE/installation-images#208
- use skelcd-control-leanos for SLES & co
- 14.338
- merge gh#openSUSE/installation-images#207
- fix typo preventing the adding of control.xml
- adjust package name: skelcd-casp.rpm -> skelcd-caasp.rpm
- 14.337

==== kernel-firmware ====
Version update (20170906 -> 20171009)
Subpackages: ucode-amd

- Update to version 20171009 (bsc#1024476, bnc#1052392):
  * cxgb4: update firmware to revision 1.16.63.0
  * ath10k: QCA6174 hw3.0: update firmware-6.bin to WLAN.RM.4.4.1-00051-QCARMSWP-1
  * ath10k: QCA6174 hw3.0: update board-2.bin
  * Revert "ath10k: QCA988X hw2.0: update firmware to 10.2.4.70.63-2"

==== kernel-source ====
Version update (4.13.6 -> 4.13.8)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs kernel-macros kernel-syms

- Linux 4.13.8 (bnc#1012628).
- USB: dummy-hcd: Fix deadlock caused by disconnect detection
  (bnc#1012628).
- MIPS: math-emu: Remove pr_err() calls from fpu_emu()
  (bnc#1012628).
- MIPS: bpf: Fix uninitialised target compiler error
  (bnc#1012628).
- mei: always use domain runtime pm callbacks (bnc#1012628).
- dmaengine: edma: Align the memcpy acnt array size with the
  transfer (bnc#1012628).
- dmaengine: ti-dma-crossbar: Fix possible race condition with
  dma_inuse (bnc#1012628).
- NFS: Fix uninitialized rpc_wait_queue (bnc#1012628).
- nfs/filelayout: fix oops when freeing filelayout segment
  (bnc#1012628).
- HID: usbhid: fix out-of-bounds bug (bnc#1012628).
- crypto: skcipher - Fix crash on zero-length input (bnc#1012628).
- crypto: shash - Fix zero-length shash ahash digest crash
  (bnc#1012628).
- KVM: MMU: always terminate page walks at level 1 (bnc#1012628).
- KVM: nVMX: fix guest CR4 loading when emulating L2 to L1 exit
  (bnc#1012628).
- usb: renesas_usbhs: Fix DMAC sequence for receiving zero-length
  packet (bnc#1012628).
- pinctrl/amd: Fix build dependency on pinmux code (bnc#1012628).
- iommu/amd: Finish TLB flush in amd_iommu_unmap() (bnc#1012628).
- device property: Track owner device of device property
  (bnc#1012628).
- Revert "vmalloc: back off when the current task is killed"
  (bnc#1012628).
- fs/mpage.c: fix mpage_writepage() for pages with buffers
  (bnc#1012628).
- ALSA: usb-audio: Kill stray URB at exiting (bnc#1012628).
- ALSA: seq: Fix copy_from_user() call inside lock (bnc#1012628).
- ALSA: caiaq: Fix stray URB at probe error path (bnc#1012628).
- ALSA: line6: Fix NULL dereference at podhd_disconnect()
  (bnc#1012628).
- ALSA: line6: Fix missing initialization before error path
  (bnc#1012628).
- ALSA: line6: Fix leftover URB at error-path during probe
  (bnc#1012628).
- drm/atomic: Unref duplicated drm_atomic_state in
  drm_atomic_helper_resume() (bnc#1012628).
- drm/i915/edp: Get the Panel Power Off timestamp after panel
  is off (bnc#1012628).
- drm/i915: Read timings from the correct transcoder in
  intel_crtc_mode_get() (bnc#1012628).
- drm/i915/bios: parse DDI ports also for CHV for HDMI DDC pin
  and DP AUX channel (bnc#1012628).
- drm/i915: Use crtc_state_is_legacy_gamma in intel_color_check
  (bnc#1012628).
- usb: gadget: configfs: Fix memory leak of interface directory
  data (bnc#1012628).
- usb: gadget: composite: Fix use-after-free in
  usb_composite_overwrite_options (bnc#1012628).
- PCI: aardvark: Move to struct pci_host_bridge IRQ mapping
  functions (bnc#1012628).
- Revert "PCI: tegra: Do not allocate MSI target memory"
  (bnc#1012628).
- direct-io: Prevent NULL pointer access in submit_page_section
  (bnc#1012628).
- fix unbalanced page refcounting in bio_map_user_iov
  (bnc#1012628).
- more bio_map_user_iov() leak fixes (bnc#1012628).
- bio_copy_user_iov(): don't ignore ->iov_offset (bnc#1012628).
- perf script: Add missing separator for "-F ip,brstack" (and
  brstackoff) (bnc#1012628).
- genirq/cpuhotplug: Enforce affinity setting on startup of
  managed irqs (bnc#1012628).
- genirq/cpuhotplug: Add sanity check for effective affinity mask
  (bnc#1012628).
- USB: serial: ftdi_sio: add id for Cypress WICED dev board
  (bnc#1012628).
- USB: serial: cp210x: fix partnum regression (bnc#1012628).
- USB: serial: cp210x: add support for ELV TFD500 (bnc#1012628).
- USB: serial: option: add support for TP-Link LTE module
  (bnc#1012628).
- USB: serial: qcserial: add Dell DW5818, DW5819 (bnc#1012628).
- USB: serial: console: fix use-after-free on disconnect
  (bnc#1012628).
- USB: serial: console: fix use-after-free after failed setup
  (bnc#1012628).
- RAS/CEC: Use the right length for "cec_disable" (bnc#1012628).
- x86/microcode: Do the family check first (bnc#1012628).
- x86/alternatives: Fix alt_max_short macro to really be a max()
  (bnc#1012628).
- KVM: nVMX: update last_nonleaf_level when initializing nested
  EPT (bnc#1012628).
- commit 569e26e
- xfs: handle error if xfs_btree_get_bufs fails (bsc#1059863).
- commit a1a185d
- futex: Remove duplicated code and fix undefined behaviour
  (bnc#1005915).
- commit b17692d
- Linux 4.13.7 (bnc#1012628).
- commit 031d6da

==== libXfont2 ====
Version update (2.0.1 -> 2.0.2)

- Update to version 2.0.2:
  A collection of minor fixes since 2.0.1, including fixes for CVE 2017-13720
  and CVE 2017-13722.

==== libXres ====
Version update (1.0.7 -> 1.2.0)

- added COPYING to %doc
- mention baselibs.conf as source in specfile
- Update to version 1.2:
  Version 1.2 of the X-Resource extension (added in xserver 1.13) added some
  new requests allowing inspection of every resource for a client, the bytes
  used per resource, and the PIDs of local clients.
  This is the release for the corresponding client library.

==== libgnome ====
Subpackages: libgnome-devel libgnome-lang

- Drop forgotten and obsolete libesd-devel Requires in devel
  sub-package, we already pass --disable-esd to configure.

==== libid3tag ====

- dont BuildRequire zypper to avoid unecessary dependency chain.
  Check for %suse_version instead.

==== libidl ====
Subpackages: libIDL-2-0 libidl-devel

- Replace deprecated PreReq: with Requires(post): and Requires(postun):
- Explicitly remove %{_infodir}/dir before creating package to
  allow builds on RHEL and derived Linux distributions
- Use %{ext_info} to allow build on Mageia
- Enable configure option --disable-dependency-tracking to
  allow build on Mageia

==== libreoffice ====
Version update (5.4.1.2 -> 5.4.2.2)
Subpackages: libreoffice-base libreoffice-base-drivers-mysql libreoffice-branding-upstream libreoffice-calc libreoffice-draw libreoffice-filters-optional libreoffice-gnome libreoffice-gtk3 libreoffice-icon-theme-breeze libreoffice-icon-theme-galaxy libreoffice-icon-theme-hicontrast libreoffice-icon-theme-sifr libreoffice-icon-theme-tango libreoffice-impress libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de libreoffice-l10n-el libreoffice-l10n-en libreoffice-l10n-es libreoffice-l10n-fr libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl libreoffice-l10n-pt_BR libreoffice-l10n-ru libreoffice-l10n-zh_CN libreoffice-l10n-zh_TW libreoffice-mailmerge libreoffice-math libreoffice-pyuno libreoffice-writer libreofficekit

- Make sure now plasma5 gets gtk3 UI not the generic one
- Disable kde4 integration on Tumbleweed as libqt4 is build with
  openssl-1.0 while we need openssl-1.1
- Removed patch:
  * 0001-tdf-100501-Adapt-to-Java-9-at-least-on-Linux-x86-64.patch
    + Integrated upstream
- The commons-codec, commons-lang and commons-httpclient are not
  actually needed
- Version update to 5.4.2.1:
  * Various bugfixes on 5.4 branch

==== libsoup ====
Version update (2.60.0 -> 2.60.1)
Subpackages: libsoup-2_4-1 libsoup-lang typelib-1_0-Soup-2_4

- Update to version 2.60.1:
  + Fallback to another authentication type if the current failed
    (bgo#788238).
  + Fix unbalanced G_GNUC_BEGIN_IGNORE_DEPRECATIONS use in
    soup-session.c (bgo#787166).
  + SoupCache: fix setting default value for cache dir
    (bgo#788452).
  + Updated translations.
- Update Url to https://wiki.gnome.org/LibSoup: current LibSoup's
  web page.

==== libvirt ====
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-config-network libvirt-daemon-config-nwfilter libvirt-daemon-driver-interface libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc libvirt-daemon-driver-network libvirt-daemon-driver-nodedev libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu libvirt-daemon-driver-secret libvirt-daemon-driver-storage libvirt-daemon-driver-storage-core libvirt-daemon-driver-storage-disk libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-logical libvirt-daemon-driver-storage-mpath libvirt-daemon-driver-storage-rbd libvirt-daemon-driver-storage-scsi libvirt-daemon-driver-uml libvirt-daemon-driver-vbox libvirt-daemon-lxc libvirt-daemon-qemu libvirt-daemon-xen libvirt-libs

- qemu: ensure TLS clients always verify the server certificate
  CVE-2017-1000256
  441d3eb6-qemu-tls-client-verify-server-cert.patch
  bsc#1062563
- Do not ignore errors from useradd/groupadd.
- Invoke/expand %service_* just once per scriptlet.
- Replace some old macros.
- spec: libvirt-daemon-qemu requires libvirt-daemon-driver-storage
  bsc#1062620
- spec: reload libvirtd Apparmor profile in %post
  bsc#1060860

==== libzypp ====
Version update (16.17.1 -> 16.17.3)

- Fix media handling in presence of a repo path prefix (bsc#1062561)
- version 16.17.3 (0)
- Fix RepoProvideFile ignoring a repo path prefix (bsc#1062561)
- version 16.17.2 (0)

==== mutter ====
Subpackages: libmutter-1-0 mutter-data mutter-lang

- Add mutter-handle-no-to-no-monitor.patch: fix possible crash when
  turning monitor off and on while logged in (bgo#788607).
- Add mutter-preferred-mode.patch: fix a crash on some ATI (radeon)
  configurations (bgo#789153).
- Add mutter-wayland-dma-buf-modifiers-fix.patch: Don't send
  modifiers to old clients (bgo#788558).
- Add  mutter-x11-Protect-XChangeProperty-call.patch: Protect
  XChangeProperty call with error traps (bgo#788666).

==== polkit-default-privs ====

- polkit-default-privs: adding deja-dup (bsc#1058935)

==== postfix ====
Subpackages: postfix-doc

- bnc#1059512 L3: Postfix Problem
  The applied changes breaks existing postfix configurations because
  daemon_directory was not adapted to the new value.
- fix build for SLE
  * nothing provides libnsl-devel
  * add bcond_with libnsl
- bnc#1059512 L3: Postfix Problem
  To manage multiple Postfix instances on a single host requires
  that daemon_directory and shlib_directory is different to
  avoid use of the shared directories also as per-instance directories.
  For this reason daemon_directory was set to /usr/lib/postfix/bin/.
  shlib_directory stands /usr/lib/postfix/.

==== python-certifi ====
Subpackages: python2-certifi python3-certifi

- fix macros to support not having python2

==== python-numpy ====
Subpackages: python2-numpy python3-numpy

- Add magic to limit the number of flavors built in the OBS ring
  to non-HPC builds.
- Convert to multibuild: Add support for HPC environment modules
  (FATE#321709).

==== rdma-core ====
Subpackages: libibcm1 libibumad3 libibverbs libibverbs1 libmlx4-1 libmlx5-1 librdmacm1 rdma-core-devel rsocket

- Backport patches from upstream:
  * ibacm-Incorrect-usage-of-BE-byte-order-of-MLID-attach-detach_mcast.patch
    Fixes a byte order issue which causes ibacm to fail to join a multicast
    group on recent on recent kernels. (bsc#1063639, bsc#1063697)
  * ibacm-Incorrect-list-used-for-subnet-list-causes-a-segfault.patch
    Fixes a sefgault of ibacm when a provider other than default
    is set (bsc#1063642, bsc#1063698)

==== sddm ====
Subpackages: sddm-branding-openSUSE

- Have update-alternatives handle Xinit's integration of the
  displaymanager, replacing /etc/sysconfig/displaymanager
  (boo#1053863).

==== shadow ====

- Revert accidentalied prerequisites.
- Prequire group(shadow), group(root), user(root)
- bsc#1061838:
  Add Requires for group(mail)

==== shared-mime-info ====
Subpackages: shared-mime-info-lang

- Drop obsolete mime-info-to-mime (boo#1062631).

==== texlive-specs-m ====

- Use chkfont.c compiled as vffont to add mapfont tfm files to
  required files as well (boo#1063771)

==== unbound ====
Version update (1.6.6 -> 1.6.7)
Subpackages: libunbound2 unbound-anchor

- update to 1.6.7
  Features:
- Set trust-anchor-signaling default to yes
- Fix #1440: [dnscrypt] client nonce cache.
- Fix #1435: Please allow UDP to be disabled separately upstream and
  downstream.
  Bug fixes:
- Fix that looping modules always stop the query, and don't pass
  control.
- Fix unbound-host to report error for DNSSEC state of failed lookups.
- Spelling fixes, from Josh Soref.
- Fix #1400: allowing use of global cache on ECS-forwarding unless
  always-forward.
- use a cachedb answer even if it's "expired" when serve-expired is yes
  (patch from Jinmei Tatuya).
- trigger refetching of the answer in that case (this will bypass
  cachedb lookup)
- allow storing a 0-TTL answer from cachedb in the in-memory message
  cache when serve-expired is yes
- Fix DNSCACHE_STORE_ZEROTTL to be bigger than 0xffff.
- Log name of looping module
- Fix #1450: Generate again patch contrib/aaaa-filter-iterator.patch
  (by Danilo G. Baio).
- Fix param unused warning for windows exportsymbol compile.
- Use RCODE from A query on DNS64 synthesized answer.
- Fix trust-anchor-signaling works in libunbound.
- Fix spelling in unbound-control man page.

==== vala ====
Version update (0.38.1 -> 0.38.2)
Subpackages: libvala-0_38-0

- Update to version 0.38.2:
  + Various bindings updates:
  - gstreamer-1.0, gtk+-3.0, gtk+-4.0: Update from git master.
  - gnutls: Fix free_function ccode-attribute of Certificate
    (bgo#788181).
- Update Url to https://wiki.gnome.org/Projects/Vala: current Vala
  web page.

==== xdm ====
Subpackages: xdm-xsession

- reintroduced /etc/X11/xdm/keytable script and the hook-up in
  /usr/lib/X11/display-manager to setup X11 keymaps, since YaST
  is not able to use localectl already during installation due to
  dbus and appropriate systemd services not running :-(
  (bsc#1046436)
- Have update-alternatives handle Xinit's integration of the
  displaymanager, replacing /etc/sysconfig/displaymanager.
- Add a dummy entry for 'console' - which is special-cased in the
  display-manager script to 'exit early'. In order for it to become
  an option for update-alternatives, the target needs to exist.
- Update /usr/lib/X11/display-manager to get the
  default-displaymanager from the update-alternative setting
  instead of reading it from /etc/sysconfig/displaymanager.
- Remove DISPLAYMANAGER from displaymanager.sysconfig template.
- Add xdm-with-update-alternative.patch so the needed changes can
  be applied for suse_version >= 1330 only, not breaking Leap 42.x.
- All that together solves boo#1053863.

==== xf86-input-mouse ====

- Add patch U_adapt-to-removal-of-xf86GetOS.patch
  This patch is in preparation of the upcoming XServer release

==== xkeyboard-config ====
Subpackages: xkeyboard-config-lang

- n_suse-ctrl-alt-bksp-terminate.patch
  * removed the hunk, which made Shift-RCTL and Shift-RALT the
    default Compose key (bsc#1059438)


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171022 (Error on key for oss and non-oss)

Bruno Friedmann-2
On mardi, 24 octobre 2017 15.15:26 h CEST Dominique Leuenberger wrote:
> Please note that this mail was generated by a script.
> The described changes are computed based on the x86_64 DVD.
> The full online repo contains too many changes to be listed here.
>
> Please check the known defects of this snapshot before upgrading:
> https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version
> =Tumbleweed&build=20171022
>

I'm seeing those errors with zypper -vv ref -f

Forcing raw metadata refresh
Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/media.1/media 
[done]
Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/content.asc 
[done]
Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/content.key 
[done]
Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/content 
[done]
  Repository:       oss
  Key Name:         openSUSE Project Signing Key <[hidden email]>
  Key Fingerprint:  22C07BA5 34178CD0 2EFE22AA B88B2FD4 3DBDC284
  Key Created:      Mon May  5 10:37:40 2014
  Key Expires:      Thu May  2 10:37:40 2024
  Rpm Name:         gpg-pubkey-3dbdc284-53674dd4
Signature verification failed for file 'content' from repository 'oss'.

    Note: Signing data enables the recipient to verify that no modifications
occurred after the data
    were signed. Accepting data with no, wrong or unknown signature can lead
to a corrupted system
    and in extreme cases even to a system compromise.

    Note: File 'content' is the repositories master index file. It ensures the
integrity of the
    whole repo.

    Warning: This file was modified after it has been signed. This may have
been a malicious change,
    so it might not be trustworthy anymore! You should not continue unless you
know it's safe.

Signature verification failed for file 'content' from repository 'oss'.
Continue? [yes/no] (no): no

Transient ?


--

Bruno Friedmann
 Ioda-Net Sàrl www.ioda-net.ch
 Bareos Partner, openSUSE Member, fsfe fellowship
 GPG KEY : D5C9B751C4653227
 irc: tigerfoot



--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171022 (Error on key for oss and non-oss)

Bruno Friedmann-2
On mardi, 24 octobre 2017 17.58:08 h CEST Bruno Friedmann wrote:

> On mardi, 24 octobre 2017 15.15:26 h CEST Dominique Leuenberger wrote:
> > Please note that this mail was generated by a script.
> > The described changes are computed based on the x86_64 DVD.
> > The full online repo contains too many changes to be listed here.
> >
> > Please check the known defects of this snapshot before upgrading:
> > https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&versi
> > on =Tumbleweed&build=20171022
>
> I'm seeing those errors with zypper -vv ref -f
> Signature verification failed for file 'content' from repository 'oss'.
> Continue? [yes/no] (no): no
>
> Transient ?

ok found a transparent sick proxy in this network :-)


--

Bruno Friedmann
 Ioda-Net Sàrl www.ioda-net.ch
 Bareos Partner, openSUSE Member, fsfe fellowship
 GPG KEY : D5C9B751C4653227
 irc: tigerfoot


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

gtk-kde borks, re: New Tumbleweed snapshot 20171022 released!

Patrick Shanahan-2
In reply to this post by Dominique Leuenberger

this update really has messed the display of libreoffice, gtk vs
kde/plasma fighting.  more and more gtk appears to be on an lsd trip.


--
(paka)Patrick Shanahan       Plainfield, Indiana, USA          @ptilopteri
http://en.opensuse.org    openSUSE Community Member    facebook/ptilopteri
Registered Linux User #207535                    @ http://linuxcounter.net
Photos: http://wahoo.no-ip.org/piwigo                    paka @ IRCnet freenode
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: gtk-kde borks

Felix Miata-3
Patrick Shanahan composed on 2017-10-24 12:59 (UTC-0400):

> this update really has messed the display of libreoffice, gtk vs
> kde/plasma fighting.

https://bugs.mageia.org/show_bug.cgi?id=17185
Scrollbar behavior is not consistent between GTK+3 apps and the rest

It's a bit noisy, but could be of use WRT GTK3 impacts on non-Gnome openSUSE
users, particularly Plasma with LibreOffice, and Firefox.

> more and more gtk appears to be on an lsd trip.

+1
--
"Wisdom is supreme; therefore get wisdom. Whatever else you
get, get wisdom." Proverbs 4:7 (New Living Translation)

 Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***  http://fm.no-ip.com/
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171022 released! - Login Manager changed from KDM to SSDM

ianseeks-4
In reply to this post by Dominique Leuenberger
On Tuesday, 24 October 2017 14:15:26 BST Dominique Leuenberger wrote:

> Please note that this mail was generated by a script.
> The described changes are computed based on the x86_64 DVD.
> The full online repo contains too many changes to be listed here.
>
> Please check the known defects of this snapshot before upgrading:
> https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171022
>
> When you reply to report some issues, make sure to change the subject.
> It is not helpful to keep the release announcement subject in a thread
> while discussing a specific problem.
>
> Packages changed:
>   cpupower
>   curl (7.55.0 -> 7.56.0)
>   dos2unix (7.3.5 -> 7.4.0)
>   eog
>   gdm
>   glibc
>   glibc
>   gnome-control-center
>   gnome-session
>   gnome-shell
>   gnome-vfs2
>   gtk3
>   installation-images-Kubic (14.336 -> 14.339)
>   kernel-firmware (20170906 -> 20171009)
>   kernel-source (4.13.6 -> 4.13.8)
>   libXfont2 (2.0.1 -> 2.0.2)
>   libXres (1.0.7 -> 1.2.0)
>   libgnome
>   libid3tag
>   libidl
>   libreoffice (5.4.1.2 -> 5.4.2.2)
>   libsoup (2.60.0 -> 2.60.1)
>   libvirt
>   libzypp (16.17.1 -> 16.17.3)
>   mutter
>   polkit-default-privs
>   postfix
>   python-certifi
>   python-numpy
>   rdma-core
>   sddm
>   shadow
>   shared-mime-info
>   texlive-specs-m
>   unbound (1.6.6 -> 1.6.7)
>   vala (0.38.1 -> 0.38.2)
>   xdm
>   xf86-input-mouse
>   xkeyboard-config
>

This update has changed my login manager to "ssdm" with the Maldives theme from "kdm" which is what it has been set to for years, its also set my keyboard to US even though all my locale settings are still English-UK.  Yast is still reporting kdm as the display manager and keyboard as UK.

Any ideas?  I am going to shutdown and reboot to see if its just a freak situation.


--
opensuse:tumbleweed:20171022
Qt: 5.9.1
KDE Frameworks: 5.38.0
KDE Plasma: 5.11.0
kwin 5.11.0
kmail2 5.6.1
akonadiserver 5.6.1
Kernel:  4.13.8-1-default
Nouveau:  1.0.15_1.2

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: gtk-kde borks, re: New Tumbleweed snapshot 20171022 released!

Daniele
In reply to this post by Patrick Shanahan-2
Il 24/10/2017 18:59, Patrick Shanahan ha scritto:
>
> this update really has messed the display of libreoffice, gtk vs
> kde/plasma fighting.  more and more gtk appears to be on an lsd trip.
>
>

It's fine if you look at the openqa tests.. So, why ?

Daniele.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171022 released! - Login Manager changed from KDM to SSDM

Roger Whittaker-2
In reply to this post by ianseeks-4
On Tue, Oct 24, 2017 at 06:27:10PM +0100, ianseeks wrote:

[...]

> This update has changed my login manager to "ssdm" with the Maldives
> theme from "kdm" which is what it has been set to for years, its
> also set my keyboard to US even though all my locale settings are
> still English-UK.  Yast is still reporting kdm as the display
> manager and keyboard as UK.

> Any ideas?  I am going to shutdown and reboot to see if its just a
> freak situation.

It seems that /etc/sysconfig/displaymanager is no longer honoured and
that you will need to make a symbolic link default-displaymanager in
/etc/alternatives to /usr/lib/X11/displaymanagers/kdm.



--
============================
Roger Whittaker
[hidden email]
============================
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [SPAM] Re: [opensuse-factory] New Tumbleweed snapshot 20171022 released! - Login Manager changed from KDM to SSDM

ianseeks-4
In reply to this post by ianseeks-4
On Tuesday, 24 October 2017 18:27:10 BST ianseeks wrote:

> On Tuesday, 24 October 2017 14:15:26 BST Dominique Leuenberger wrote:
> > Please note that this mail was generated by a script.
> > The described changes are computed based on the x86_64 DVD.
> > The full online repo contains too many changes to be listed here.
> >
> > Please check the known defects of this snapshot before upgrading:
> > https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171022
> >
> > When you reply to report some issues, make sure to change the subject.
> > It is not helpful to keep the release announcement subject in a thread
> > while discussing a specific problem.
> >
> > Packages changed:
> >   cpupower
> >   curl (7.55.0 -> 7.56.0)
> >   dos2unix (7.3.5 -> 7.4.0)
> >   eog
> >   gdm
> >   glibc
> >   glibc
> >   gnome-control-center
> >   gnome-session
> >   gnome-shell
> >   gnome-vfs2
> >   gtk3
> >   installation-images-Kubic (14.336 -> 14.339)
> >   kernel-firmware (20170906 -> 20171009)
> >   kernel-source (4.13.6 -> 4.13.8)
> >   libXfont2 (2.0.1 -> 2.0.2)
> >   libXres (1.0.7 -> 1.2.0)
> >   libgnome
> >   libid3tag
> >   libidl
> >   libreoffice (5.4.1.2 -> 5.4.2.2)
> >   libsoup (2.60.0 -> 2.60.1)
> >   libvirt
> >   libzypp (16.17.1 -> 16.17.3)
> >   mutter
> >   polkit-default-privs
> >   postfix
> >   python-certifi
> >   python-numpy
> >   rdma-core
> >   sddm
> >   shadow
> >   shared-mime-info
> >   texlive-specs-m
> >   unbound (1.6.6 -> 1.6.7)
> >   vala (0.38.1 -> 0.38.2)
> >   xdm
> >   xf86-input-mouse
> >   xkeyboard-config
> >
>
> This update has changed my login manager to "ssdm" with the Maldives theme from "kdm" which is what it has been set to for years, its also set my keyboard to US even though all my locale settings are still English-UK.  Yast is still reporting kdm as the display manager and keyboard as UK.
>
> Any ideas?  I am going to shutdown and reboot to see if its just a freak situation.
>
>
>

Seems the introduction of something called iBus overrides the settings in systemsettings5 for the keyboard, not sure where that came from.
With SSDM, it starts with a US keyboard and i have to sit and wait until it finally sets the keyboard to UK - can it not start with the configuration setting as default? I'd sooner get back to KDM though

--
opensuse:tumbleweed:20171022
Qt: 5.9.1
KDE Frameworks: 5.38.0
KDE Plasma: 5.11.0
kwin 5.11.0
kmail2 5.6.1
akonadiserver 5.6.1
Kernel:  4.13.8-1-default
Nouveau:  1.0.15_1.2

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171022 released! - Login Manager changed from KDM to SSDM

ianseeks-4
In reply to this post by Roger Whittaker-2
On Tuesday, 24 October 2017 18:50:15 BST Roger Whittaker wrote:

> On Tue, Oct 24, 2017 at 06:27:10PM +0100, ianseeks wrote:
>
> [...]
>
> > This update has changed my login manager to "ssdm" with the Maldives
> > theme from "kdm" which is what it has been set to for years, its
> > also set my keyboard to US even though all my locale settings are
> > still English-UK.  Yast is still reporting kdm as the display
> > manager and keyboard as UK.
>
> > Any ideas?  I am going to shutdown and reboot to see if its just a
> > freak situation.
>
> It seems that /etc/sysconfig/displaymanager is no longer honoured and
> that you will need to make a symbolic link default-displaymanager in
> /etc/alternatives to /usr/lib/X11/displaymanagers/kdm.
>
Thanks.  That should have been done automatically by the install process, check whats set and set the link accordingly.  Imagine the fuss if that happened at someone's work place.

--
opensuse:tumbleweed:20171022
Qt: 5.9.1
KDE Frameworks: 5.38.0
KDE Plasma: 5.11.0
kwin 5.11.0
kmail2 5.6.1
akonadiserver 5.6.1
Kernel:  4.13.8-1-default
Nouveau:  1.0.15_1.2

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171022 released! - Login Manager changed from KDM to SSDM

ianseeks-4
In reply to this post by Roger Whittaker-2
On Tuesday, 24 October 2017 18:50:15 BST Roger Whittaker wrote:

> On Tue, Oct 24, 2017 at 06:27:10PM +0100, ianseeks wrote:
>
> [...]
>
> > This update has changed my login manager to "ssdm" with the Maldives
> > theme from "kdm" which is what it has been set to for years, its
> > also set my keyboard to US even though all my locale settings are
> > still English-UK.  Yast is still reporting kdm as the display
> > manager and keyboard as UK.
>
> > Any ideas?  I am going to shutdown and reboot to see if its just a
> > freak situation.
>
> It seems that /etc/sysconfig/displaymanager is no longer honoured and
> that you will need to make a symbolic link default-displaymanager in
> /etc/alternatives to /usr/lib/X11/displaymanagers/kdm.
>
>
>
>

This is how my system looks.... Any known reason for both of these links being needed?

ls -l /usr/lib/X11/displaymanagers/ | grep display
lrwxrwxrwx 1 root root  40 Oct 20 16:13 default-displaymanager -> /etc/alternatives/default-displaymanager

ls -l /etc/alternatives | grep display
lrwxrwxrwx 1 root root 33 Oct 24 15:25 default-displaymanager -> /usr/lib/X11/displaymanagers/sddm


--
opensuse:tumbleweed:20171022
Qt: 5.9.1
KDE Frameworks: 5.38.0
KDE Plasma: 5.11.0
kwin 5.11.0
kmail2 5.6.1
akonadiserver 5.6.1
Kernel:  4.13.8-1-default
Nouveau:  1.0.15_1.2

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171022 released! - Login Manager changed from KDM to SSDM

Adam Mizerski
W dniu 24.10.2017 o 20:09, ianseeks pisze:

> On Tuesday, 24 October 2017 18:50:15 BST Roger Whittaker wrote:
>> On Tue, Oct 24, 2017 at 06:27:10PM +0100, ianseeks wrote:
>>
>> [...]
>>
>>> This update has changed my login manager to "ssdm" with the Maldives
>>> theme from "kdm" which is what it has been set to for years, its
>>> also set my keyboard to US even though all my locale settings are
>>> still English-UK.  Yast is still reporting kdm as the display
>>> manager and keyboard as UK.
>>
>>> Any ideas?  I am going to shutdown and reboot to see if its just a
>>> freak situation.
>>
>> It seems that /etc/sysconfig/displaymanager is no longer honoured and
>> that you will need to make a symbolic link default-displaymanager in
>> /etc/alternatives to /usr/lib/X11/displaymanagers/kdm.
>>
>>
>>
>>
>
> This is how my system looks.... Any known reason for both of these links being needed?
>
> ls -l /usr/lib/X11/displaymanagers/ | grep display
> lrwxrwxrwx 1 root root  40 Oct 20 16:13 default-displaymanager -> /etc/alternatives/default-displaymanager
>
> ls -l /etc/alternatives | grep display
> lrwxrwxrwx 1 root root 33 Oct 24 15:25 default-displaymanager -> /usr/lib/X11/displaymanagers/sddm
>
>
That's how 'alternatives' work
https://linux.die.net/man/8/update-alternatives

--
Adam Mizerski


signature.asc (484 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171022 released! - Login Manager changed from KDM to SSDM

ianseeks-4
On Tuesday, 24 October 2017 19:25:00 BST Adam Mizerski wrote:

> W dniu 24.10.2017 o 20:09, ianseeks pisze:
> > On Tuesday, 24 October 2017 18:50:15 BST Roger Whittaker wrote:
> >> On Tue, Oct 24, 2017 at 06:27:10PM +0100, ianseeks wrote:
> >>
> >> [...]
> >>
> >>> This update has changed my login manager to "ssdm" with the Maldives
> >>> theme from "kdm" which is what it has been set to for years, its
> >>> also set my keyboard to US even though all my locale settings are
> >>> still English-UK.  Yast is still reporting kdm as the display
> >>> manager and keyboard as UK.
> >>
> >>> Any ideas?  I am going to shutdown and reboot to see if its just a
> >>> freak situation.
> >>
> >> It seems that /etc/sysconfig/displaymanager is no longer honoured and
> >> that you will need to make a symbolic link default-displaymanager in
> >> /etc/alternatives to /usr/lib/X11/displaymanagers/kdm.
> >>
> >>
> >>
> >>
> >
> > This is how my system looks.... Any known reason for both of these links being needed?
> >
> > ls -l /usr/lib/X11/displaymanagers/ | grep display
> > lrwxrwxrwx 1 root root  40 Oct 20 16:13 default-displaymanager -> /etc/alternatives/default-displaymanager
> >
> > ls -l /etc/alternatives | grep display
> > lrwxrwxrwx 1 root root 33 Oct 24 15:25 default-displaymanager -> /usr/lib/X11/displaymanagers/sddm
> >
> >
>
> That's how 'alternatives' work
> https://linux.die.net/man/8/update-alternatives
>
>

Thanks for the link.  I think the choice of login manager should still be a config option in something like Yast/systemsettings5, seems like a backward step to go back to the cli to change things.

--
opensuse:tumbleweed:20171022
Qt: 5.9.1
KDE Frameworks: 5.38.0
KDE Plasma: 5.11.0
kwin 5.11.0
kmail2 5.6.1
akonadiserver 5.6.1
Kernel:  4.13.8-1-default
Nouveau:  1.0.15_1.2

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171022 released! - Login Manager changed from KDM to SSDM

Dominique Leuenberger / DimStar
On Tue, 2017-10-24 at 23:29 +0100, ianseeks wrote:
>
> Thanks for the link.  I think the choice of login manager should
> still be a config option in something like Yast/systemsettings5,
> seems like a backward step to go back to the cli to change things.

You can use the yast module 'alternatives' to select one of the
registered display managers. If a DM does not register it yet as an
option, then that's a bug.

Cheers,
Dominique

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171022 released! - Login Manager changed from KDM to SSDM

Roger Whittaker-2
On Wed, Oct 25, 2017 at 09:11:14AM +0200, Dominique Leuenberger / DimStar wrote:
> On Tue, 2017-10-24 at 23:29 +0100, ianseeks wrote:
> >
> > Thanks for the link.  I think the choice of login manager should
> > still be a config option in something like Yast/systemsettings5,
> > seems like a backward step to go back to the cli to change things.
>
> You can use the yast module 'alternatives' to select one of the
> registered display managers. If a DM does not register it yet as an
> option, then that's a bug.

So am I right in thinking that /etc/sysconfig/displaymanager is now
obsolete?

If so, what about the other configuration choices in that file, like
DISPLAYMANAGER_REMOTE_ACCESS ?

Similarly for the keyboard settings - it seems we should now be using
the ibus tool and no longer (for instance) the item in KDE's
systemsetting5 - is that correct?


--
============================
Roger Whittaker
[hidden email]
============================
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171022 released! - Login Manager changed from KDM to SSDM

Dominique Leuenberger / DimStar
On Wed, 2017-10-25 at 08:24 +0100, Roger Whittaker wrote:

> So am I right in thinking that /etc/sysconfig/displaymanager is now
> obsolete?

Not completely, but the selection of the DM needed to be moved out.
Mainly due to the new desktop selection model, where all DEs are
installed based on patterns: YaST simply does not have sufficient
information in all cases what DM to use, based on package selection. As
a result, DMs register themselves now with u-a.

> If so, what about the other configuration choices in that file, like
> DISPLAYMANAGER_REMOTE_ACCESS ?

At least for now they stay in place. I did not (yet) hear about plans
to changing that. Note though that not all DMs read this file!

> Similarly for the keyboard settings - it seems we should now be using
> the ibus tool and no longer (for instance) the item in KDE's
> systemsetting5 - is that correct?

I have to leave that one up to answer by somebody else. I don't know.

Cheers
Dominique

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171022 released! - Login Manager changed from KDM to SSDM

Bjoern Voigt
In reply to this post by ianseeks-4
ianseeks wrote:
> On Tuesday, 24 October 2017 18:50:15 BST Roger Whittaker wrote:
> It seems that /etc/sysconfig/displaymanager is no longer honoured and
> that you will need to make a symbolic link default-displaymanager in
> /etc/alternatives to /usr/lib/X11/displaymanagers/kdm.
>
> Thanks.  That should have been done automatically by the install process, check whats set and set the link accordingly.  Imagine the fuss if that happened at someone's work place.
My desktop was upgraded from KDM to GDM. An automatic upgrade to KDM
(with update-alternatives) currently does not work, because KDM does not
register with upgrade-alternatives. This is probably a bug.

Now I changed to SDDM.

mybox:~ # update-alternatives --config default-displaymanager
There are 4 choices for the alternative default-displaymanager
(providing /usr/lib/X11/displaymanagers/default-displaymanager).

  Selection    Path                                  Priority   Status
------------------------------------------------------------
  0            /usr/lib/X11/displaymanagers/sddm      25        auto mode
  1            /usr/lib/X11/displaymanagers/console   5         manual mode
  2            /usr/lib/X11/displaymanagers/gdm       25        manual mode
* 3            /usr/lib/X11/displaymanagers/sddm      25        manual mode
  4            /usr/lib/X11/displaymanagers/xdm       10        manual mode

Press <enter> to keep the current choice[*], or type selection number:

mybox:~ # which kdm
/usr/bin/kdm
mybox:~ # rpm -qf /usr/bin/kdm
kdm-4.11.22-9.1.x86_64

Greetings,
Björn
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171022 released! - Login Manager changed from KDM to SSDM

Dominique Leuenberger / DimStar
On Wed, 2017-10-25 at 09:41 +0200, Bjoern Voigt wrote:
> My desktop was upgraded from KDM to GDM. An automatic upgrade to KDM
> (with update-alternatives) currently does not work, because KDM does
> not
> register with upgrade-alternatives. This is probably a bug.

I've seen the fix for KDM fly by for Snapshot 1023 - Just a bit too
late to not cause you headaches. But at least it's underway already

After that, you can switch to KDM just as you did switch to sddm (or by
using the YaST alternatives module)

Cheers,
Dominique

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171022 released! - Login Manager changed from KDM to SSDM

Wolfgang Bauer
In reply to this post by Roger Whittaker-2
Am Mittwoch, 25. Oktober 2017, 08:24:56 schrieb Roger Whittaker:
> Similarly for the keyboard settings - it seems we should now be using
> the ibus tool and no longer (for instance) the item in KDE's
> systemsetting5 - is that correct?

Not really.

But if you installed and use ibus, you have to use its settings obviously, as
it overrides the "standard" keyboard settings.

There hasn't been a change in the KDE packages/paterns in this regard AFAIK,
i.e. no KDE package should automatically install ibus.

Apparently it gets pulled in by libreoffice-gnome though (which replaces
libreoffice-kde4 now that has been dropped), as the ibus package contains
this:
#Fix cursor following problem in KDE4 for libreoffice.
%if 0%{?suse_version} != 1315
Supplements:    packageand(libreoffice:libreoffice-gnome)
%endif

But you should be able to uninstall ibus if you prefer, personally I tabooed
it years ago as I have no need for it.

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171022 released! - Login Manager changed from KDM to SSDM

Wolfgang Bauer
In reply to this post by Bjoern Voigt
Am Mittwoch, 25. Oktober 2017, 09:41:29 schrieb Bjoern Voigt:
> My desktop was upgraded from KDM to GDM. An automatic upgrade to KDM
> (with update-alternatives) currently does not work, because KDM does not
> register with upgrade-alternatives. This is probably a bug.

As Dominique wrote already, the new kdm package didn't make it into this
snapshot unfortunately.
But even if, your displaymanager would have been changed, because there's no
migration of the old DISPLAYMANAGER setting (and gdm/sddm have the highest
priority).

To be able to set kdm via update-alternatives, you should be able to run this
manually (as root) though to register it:
/usr/sbin/update-alternatives --install /usr/lib/X11/displaymanagers/default-
displaymanager default-displaymanager /usr/lib/X11/displaymanagers/kdm 15

Or wait for the update, that's what the updated package will do on
installation.

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

123