New Tumbleweed snapshot 20171003 released!

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

New Tumbleweed snapshot 20171003 released!

Dominique Leuenberger

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171003

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
  FastCGI
  NetworkManager
  NetworkManager-applet
  NetworkManager-openvpn
  acl
  bash
  biosdevname (0.7.2 -> 0.7.3)
  corosync
  epiphany (3.26.0 -> 3.26.1)
  gnome-user-docs (3.26.0 -> 3.26.0.1)
  hwdata (0.304 -> 0.305)
  i4l-base
  intltool
  krita (3.2.1 -> 3.3.0)
  latex2html
  libdrm (2.4.82 -> 2.4.83)
  libgda
  libraw (0.18.4 -> 0.18.5)
  libssh
  libzypp-plugin-appdata
  mono-core
  opal
  oprofile
  perl (5.24.1 -> 5.26.1)
  perl-Crypt-SSLeay
  perl-Encode-HanExtra
  perl-FileHandle-Unget
  perl-Module-Signature
  perl-Task-Weaken
  perl-Term-ReadKey (2.32 -> 2.37)
  perl-ldap (0.64 -> 0.65)
  pesign-obs-integration
  postfix (3.2.2 -> 3.2.3)
  python-cryptography
  python-libvirt-python
  python-pyxdg
  python-requests (2.18.2 -> 2.18.4)
  python3
  python3-base
  quilt
  speech-dispatcher (0.8.4 -> 0.8.7)
  tcl
  tigervnc
  tracker
  tracker-miners
  webkitgtk
  xournal
  xterm (327 -> 330)

=== Details ===

==== FastCGI ====
Subpackages: libfcgi0 perl-FastCGI

- add FastCGI-perl526.patch as perl 5.26 no longer has . in @INC

==== NetworkManager ====
Subpackages: NetworkManager-devel NetworkManager-lang libnm-glib-vpn1 libnm-glib4 libnm-util2 libnm0 typelib-1_0-NM-1_0 typelib-1_0-NMClient-1_0 typelib-1_0-NetworkManager-1_0

- Modify nm-dont-overwrite-resolv-conf.patch: make netconfig call
  an atomic action, don't kill it after 2000ms (bsc#960153).

==== NetworkManager-applet ====
Subpackages: NetworkManager-applet-lang NetworkManager-connection-editor libnm-gtk0 libnma0 nma-data typelib-1_0-NMGtk-1_0

- Obsolete also debuginfo subpackages of the packages marked as
  Obsoletes in this specfile (bsc#1045678)

==== NetworkManager-openvpn ====
Subpackages: NetworkManager-openvpn-gnome NetworkManager-openvpn-lang

- Add NetworkManager-openvpn-config.patch: fix unusable config
  imports (certificate config was wrongly written out, causing the
  VPN profile not be be functional).

==== acl ====
Subpackages: libacl1 libacl1-32bit

- refresh acl-2.2.52-tests.patch to work with perl 5.26

==== bash ====
Subpackages: bash-doc libreadline7 readline-devel readline-doc

- Modify patch bash-4.4.dif to let bashline.h install as well as
  this header file is included by general.h due to the same patch
  (boo#1060069)

==== biosdevname ====
Version update (0.7.2 -> 0.7.3)

- Update to version 0.7.3
  * Shipping and future Dell EMC systems support consistent network
    device naming feature.
  [fate#332490]

==== corosync ====
Subpackages: libcmap4 libcorosync_common4

- wrong "service_del_postun corosync.service"(bsc#1060767)
    Modified: corosync.spec, remove service_del_postun in postun of corosync

==== epiphany ====
Version update (3.26.0 -> 3.26.1)
Subpackages: epiphany-lang gnome-shell-search-provider-epiphany

- Update to version 3.26.1:
  + Fix search engine dialog, which has been borked since 3.24.3
    (bgo#787458).
  + Allow overriding autofilled username in password forms
    (bgo#787498).
  + Fix non-HTML/MHTML files being saved as MHTML (bgo#788111).
  + Don't disable navigation actions when history is cleared
    (bgo#788329).
  + Fix bookmarks import crash when there's no Firefox profile.

==== gnome-user-docs ====
Version update (3.26.0 -> 3.26.0.1)
Subpackages: gnome-user-docs-lang

- Update to version 3.26.0.1:
  + Updates to GNOME Help.
  + Updated translations.

==== hwdata ====
Version update (0.304 -> 0.305)

- Update to version 0.305

==== i4l-base ====
Subpackages: i4l-isdnlog libcapi20-3

- add isdn4k-utils-perl526.diff to compile with perl 5.26

==== intltool ====

- extend intltool-perl-5.22.patch to fix one more perl 5.26 issue

==== krita ====
Version update (3.2.1 -> 3.3.0)
Subpackages: krita-lang

- Update to 3.3.0:
  * Some visual glitches when using hi-dpi screens are fixed
    (remember: on Windows and Linux, you need to enable this in the
    settings dialog).
  * If you create a new image from clipboard, the image will have a
    title
  * Favorite blending modes and favorite brush presets are now
    loaded correctly on startup
  * GMIC
    + the plugin has been updated to the latest version for Windows
    and Linux.
    + the configuration for setting the path to the plugin has been
    removed. Krita looks for the plugin in the folder where the
    krita executable is, and optionally inside a folder with a
    name that starts with ?gmic? next to the krita executable.
    + there are several fixes for handling layers and communication
    between Krita and the plugin
  * Some websites save jpeg images with a .png extension: that used
    to confuse Krita, but Krita now first looks inside the file to
    see what kind of file it really is.
  * PNG:
    + 16 and 32 bit floating point images are now converted to 16
    bit integer when saving the images as PNG.
    + It?s now possible to save the alpha channel to PNG images
    even if there are no (semi-) transparent pixels in the image
  * When hardware accelerated display is disabled, the color picker
    mode of the brush tool showed a broken cursor; this has been
    fixed.
  * The Reference Images docker now only starts loading images when
    it is visible, instead on Krita startup. Note: the reference
    images docker uses Qt?s imageio plugins to load images. If you
    are running on Linux, remove all Deepin desktop components.
    Deepin comes with severely broken qimageio plugins that will
    crash any Qt application that tries to display images.
  * File layers now correctly reload on change again
  * Add several new commandline options:
    + ?nosplash to start Krita without showing the splash screen
    + ?canvasonly to start Krita in canvas-only mode
    + ?fullscreen to start Krita full-screen
    + ?workspace Workspace to start Krita with the given workspace
  * Selections
    + The Select All action now first clears the selection before
    selecting the entire image
    + It is now possible to extend selections outside the canvas
    boundary
  * Performance improvements: in several places superfluous reads
    from the settings were eliminated, which makes generating a layer
    thumbnail faster and improves painting if display acceleration is
    turned off.
  * The smart number input boxes now use the current locale to follow
    desktop settings for numbers
  * The system information dialog for bug reports is improved
  * See also https://krita.org/en/item/krita-3-3-0/

==== latex2html ====

- add latex2html-perl526.patch to work with perl 5.26

==== libdrm ====
Version update (2.4.82 -> 2.4.83)
Subpackages: libdrm-devel libdrm2 libdrm_amdgpu1 libdrm_intel1 libdrm_nouveau2 libdrm_radeon1

- Remove --with-pic which has no effect on shared-only builds.
  Rectify SRPM group.
- Update to version 2.4.83
  + amdgpu: Add FX-9800P Bristol Ridge iGPU id
  + amdgpu: fix missing mutex unlock before return
  + amdgpu: fix race issue between two bo functions(v2)
  + amdgpu: merge and cleanup amdgpu_bo_free
  + android: add rules to build amdgpu.ids
  + android: amdgpu: fix build break
  + drm: Pull new modifier uapi into drm_fourcc and drm_mode
  + drmsltest: Check expected neighbours
  + etnaviv: fix etna_bo_from_name
  + freedreno: remove dead error path
  + freedreno: prevent deadlock in error path
  + freedreno/msm: remove dead error path
  + radeon: add fallthrough annotation
  + test/amdgpu: fix test failure for SI
  + tests/amdgpu: bypass UVD CS tests on raven
  + tests/amdgpu: bypass VCE tests on raven
  + tests/amdgpu: add uvd encode unit tests
  + xf86drm: continue with next device if drmProcessUsbDevice fails
  + xf86drm: continue after drmProcessPlatformDevice failure

==== libgda ====
Subpackages: libgda-5_0-4 libgda-5_0-4-lang libgda-5_0-bdb libgda-5_0-sqlite libgda-ui-5_0-4 libgda-ui-5_0-plugins

- Remove leftover dependency on gcc-java

==== libraw ====
Version update (0.18.4 -> 0.18.5)
Subpackages: libraw-devel libraw16

- updated to 0.18.5:
    Fix for possible buffer overrun in kodak_65000 decoder
    Fix for possible heap overrun in Canon makernotes parser
    Fix for CVE-2017-13735
    CVE-2017-14265: Additional check for X-Trans CFA pattern data
- remove upstreamed libraw-out-of-bounds-kodak.patch

==== libssh ====
Subpackages: libssh-devel libssh4

- add support for building with OpenSSL 1.1 (bsc#1055266)
  * added patches:
  * 0001-cmake-Use-configure-check-for-CRYPTO_ctr128_encrypt.patch
  * 0001-libcrypto-Introduce-a-libcrypto-compat-file.patch
  * 0001-libcrypto-Remove-AES_ctr128_encrypt.patch
  * 0001-libcrypto-Use-a-pointer-for-EVP_MD_CTX.patch
  * 0001-libcrypto-Use-a-pointer-for-EVP_CIPHER_CTX.patch
  * 0001-libcrypto-Use-newer-API-for-HMAC.patch
  * 0001-pki_crypto-Use-getters-and-setters-for-opaque-keys-a.patch
  * 0001-threads-Use-new-API-call-for-OpenSSL-CRYPTO-THREADID.patch

==== libzypp-plugin-appdata ====

- Do not consider appdata-ignore.xml.gz as appdata to be installed.

==== mono-core ====
Subpackages: libmono-2_0-1 libmono-2_0-devel libmonosgen-2_0-1 libmonosgen-2_0-devel mono-data mono-data-sqlite mono-extras mono-mvc mono-wcf mono-web mono-winforms mono-winfxcore

- Update to version 5.2.0.224 (5.2.0 SR4)
- Changes:
  * Mono cecil source updated (more info at https://github.com/jbevain/cecil/commit/44e4d344d674195b4d2950c48fd1cb55fe42a1ef)
- Bugfixes:
  * bxc#44027 - Chunked HTTP PUT times out
  * bxc#57919 - dynamic object is not supported
  * bxc#58829 - Application Output Window being flooded with "[Mono] worker parking, [Mono] worker unparking" messages when debugging agasint Android Emulator.

==== opal ====

- No longer build capi4linux support on openSUSE, but leave in
  place becond, so it will be easy for users that wants to build
  this support on their own.

==== oprofile ====
Subpackages: libopagent1

- Rectify RPM groups. Update summary of -devel subpackage.
  Do not ignore errors from useradd/groupadd.
  Avoid running fdupes across partitions.

==== perl ====
Version update (5.24.1 -> 5.26.1)
Subpackages: perl-base perl-doc

- update to perl-5.26.1
  * [CVE-2017-12837] Heap buffer overflow in regular expression compiler
  * [CVE-2017-12883] Buffer over-read in regular expression parser
  * tons of bug fixes
- update list of obsoletes
- update to perl-5.26.0
  * "." no longer in @INC
  * "do" may now warn
  * regexp: a literal left brace "{" should be escaped
  * lexical subroutines are no longer experimental
  * indented Here-documents
  * new regular expression modifier /xx
  * declaring a reference to a variable
  * unicode 9.0 is now supported
  * new Hash Function For 64-bit Builds
- rename perl-5.24.0.dif to perl-5.26.0.dif
- remove obsolete perl-avoid-warnings.patch
- remove obsolete Compress-Raw-Zlib-2.071-zlib-1.2.11.patch

==== perl-Crypt-SSLeay ====

- add no-dot-inc.patch inherited from gentoo to build with perl 5.26
- remove Crypt-SSLeay-0.58.patch not applied for a long time

==== perl-Encode-HanExtra ====

- compile with perl 5.26 by patching the Makefile

==== perl-FileHandle-Unget ====

- patch the Makefile to build with perl 5.26

==== perl-Module-Signature ====

- patch the Makefile to build with perl 5.26

==== perl-Task-Weaken ====

- patch the Makefile to build with perl 5.26

==== perl-Term-ReadKey ====
Version update (2.32 -> 2.37)

- update to 2.37
  * Better support parallel builds by making 'dynamic' a dependency of the ReadKey.pm
  * Add a package declaration to the ReadKey_pm.PL to aid indexing
  * Use FULLPERLRUNINST to run the ReadKey_pm.PL to get the 'blib'
  * Fix GetTerminalSize() argument handling
  * Fix miniperl build on Win32
  * Remove unused Cwd
  * Fix TAP output
  * Fix warnings in XS file
  * Don't attempt some tests if STDIN is not a terminal
  * Generate ReadKey.pm from  ReadKey_pm.PL to expand blockoptions
  * demand-load Carp,
  * remove unneeded AutoLoader,
  * Improve genchars.pl, support make -s silence.
  * Improve Makefile.PL add SIGN, fix pure_site_install, support dual-life, fix realclean

==== perl-ldap ====
Version update (0.64 -> 0.65)

- add perl526.patch to build with perl 5.26
- remove ssl subpackage without files
- update to 0.65
  Enhancements:
  * t/74matchedvalues.t: more tests
  * {ASN,Extension}.pm: update ExtendedResponse to RFC 4511
  * Constant.pm: add LDAP_NOTICE_OF_DISCONNECTION
  * Control/DontUseCopy.pm: new
  * Control/ProxyAuth.pm: make sure criticality does not get changed
  * Control/Relax.pm: make sure value & criticality do not get changed
  * Control/ManageDsaIT.pm: make sure value never gets set
  Bug Fixes
  * LDAP.pm: do not set default sslversion for start_tls() & LDAPS
    Instead of second-guessing a default sslversion for start_tls() and LDAPS,
    rely on the - known to be sane - default value used by IO::Socket::SSL.
  * RT#100151: LDAP.pm: localize $SIG{__DIE__} in IPv6 support check
    Thanks to Troy Loveday <[hidden email]> for the detailed bug report and patch.
  * FAQ.pod: fix error in search() example
  * RFC.pod: typo fix

==== pesign-obs-integration ====

- escape regexp in pesign-gen-repackage-spec for perl 5.26

==== postfix ====
Version update (3.2.2 -> 3.2.3)
Subpackages: postfix-doc

- bnc#1016491 postfix raported to log "warning: group or other writable:"
  on each symlink in config.
  * Add fix-postfix-script.patch
- update to 3.2.3
  * Extension propagation was broken with "recipient_delimiter = .".
  This change reverts a change that was trying to be too clever.
  * The postqueue command would abort with a panic message after it
  experienced an output write error while listing the mail queue.
  This change restores a write error check that was lost with the
  Postfix 3.2 rewrite of the vbuf_print formatter.
  * Restored sanity checks for dynamically-specified width and precision
  in format strings (%*, %.*, and %*.*). These checks were lost with
  the Postfix 3.2 rewrite of the vbuf_print formatter.

==== python-cryptography ====
Subpackages: python2-cryptography python3-cryptography

- Fix cffi version requirement.

==== python-libvirt-python ====

- Rectify RPM group. Adjust descriptions for neutrality and
  OS relevance.

==== python-pyxdg ====
Subpackages: python2-pyxdg python3-pyxdg

- drop test-icon test that fails because its standard is too old
- drop hicolor-icon-theme requirement which was needed for that test

==== python-requests ====
Version update (2.18.2 -> 2.18.4)
Subpackages: python2-requests python3-requests

- update to version 2.18.4:
  * Improvements
    + Error messages for invalid headers now include the header name
    for easier debugging
  * Dependencies
    + We now support idna v2.6.
- changes from version 2.18.3:
  * Improvements
    + Running $ python -m requests.help now includes the installed
    version of idna.
  * Bugfixes
    + Fixed issue where Requests would raise ConnectionError instead
    of SSLError when encountering SSL problems when using urllib3
    v1.22.

==== python3 ====
Subpackages: python3-curses python3-dbm python3-tk

- drop python-2.7-libffi-aarch64.patch: this patches the intree
  copy of libffi which is unused/deleted in the line afterwards

==== python3-base ====
Subpackages: libpython3_6m1_0 python3-idle

- drop python-2.7-libffi-aarch64.patch: this patches the intree
  copy of libffi which is unused/deleted in the line afterwards
- fix build against system libffi: include flags weren't set
  so it actually used the in-tree libffi headers.

==== quilt ====

- add perl-526.patch to work with perl 5.26

==== speech-dispatcher ====
Version update (0.8.4 -> 0.8.7)
Subpackages: libspeechd-devel libspeechd2 python3-speechd speech-dispatcher-configure speech-dispatcher-module-espeak

- Update to version 0.8.7:
  + Further fixes to spd-conf, which should now work properly.
  + Split the espeak-ng driver code into its own source file.
  + Add a work-around to the espeak-ng driver to account for spaces
    in voice names which recently appeared in espeak-ng git master.
    This will properly be fixed in 0.9.
  + Voice names are not forced to lower case, due to espeak-ng
    git master now having multi-case voice names.
  + Fix stripped audio output from the flite module.
  + Further code and build improvements.
- Changes from version 0.8.6:
  + Various internal code improvements.
  + Fix more compiler warnings.
  + Python bug fixes with thanks to Sebastian Humenda.
- Changes from version 0.8.5:
  + Use GLib main loop for the main server thread
  + Implement a shutdown timer in the server
  + Add support for espeak-ng.
  + Document an ibmtts configuration option
  + Removal of configuration options in the code that were not
    actually being used.
  + Added a command-line argument to allow for custom modules
    location.
- Add ANNOUNCE; remove ChangeLog (no longer shipped)

==== tcl ====

- Whiltelist known-failing tests. Further investigation needed.

==== tigervnc ====

- u_Unset-pixel-buffer-when-x0vncserver-client-disconnect.patch
  * Fixes crash in x0vncserver after client disconnects.
    (bnc#1058587)
- Add tigervnc-x11vnc wrapper for x0vncserver that replaces x11vnc.
  (fate#323207)
- Replace java applet with novnc as web-based VNC viewer.
  (fate#323880)
- Convert xinetd services to systemd socket activated services.
  (bnc#1058460)

==== tracker ====
Subpackages: libtracker-common-2_0 libtracker-control-2_0-0 libtracker-miner-2_0-0 libtracker-sparql-2_0-0 tracker-lang typelib-1_0-Tracker-2_0 typelib-1_0-TrackerControl-2_0

- Add tracker-libtracker-fixes.patch: Fix various bugs in
  libtracker (bgo#787452).
- Move AUTHORS ChangeLog README and NEWS to devel sub-package, only
  developers care about these anyway, silences rpmlint.

==== tracker-miners ====
Subpackages: tracker-miner-files tracker-miners-lang

- Add tracker-miners-tracker-extract-fixes.patch: Fix various bugs
  in tracker-extract (bgo#785853, bgo#787774).

==== webkitgtk ====
Subpackages: libjavascriptcoregtk-1_0-0 libwebkitgtk-1_0-0 libwebkitgtk2-lang

- Drop webkitgtk3 linked sub package:
  + Remove libwebkitgtk-3_0-0 and libjavascriptcoregtk-3_0-0 from
    baselibs.conf.
  + Drop conditional build for gtk3 defines from spec.
  + Drop conditional pkgconfig(gail), pkgconfig(gail-3.0),
    pkgconfig(gtk+-2.0),   pkgconfig(gtk+-3.0) and
    pkgconfig(gtk+-unix-print-3.0) BuildRequires: No longer needed.
  + Drop no longer needed pre_checkin.sh: No longer needed.

==== xournal ====

- Add xournal-fix-strokes-on-Lenovo-active-pen.patch: Fix strokes
  with Lenovo active pen 2; patches taken from upstream git.

==== xterm ====
Version update (327 -> 330)
Subpackages: xterm-bin

- Patch #330 - 2017/06/20
  * updates for ReGIS (Ross Combs):
    + remove redundant text command error check which broke
    T(B) and T(E).
    + retain the loading alphabet number across multiple ?L?
    commands.
    + add S(T) delay handler.
    + fix some color handling error messages.
    + add stubbed-out macrograph handling.
    + use fragment_remaining() and fragment_consumed() instead
    of manually checking position / length in various places.
    + rename some local variables in string / extent / option
    parsing
    + wrap some long lines.
    + move macrograph command handling out of the top-level.
  * add a summary of the italic fonts loaded to -report-fonts
    option.
  * modify the font-lookup for italics to allow for ?-i-? if no
    match is found with slant ?-o-? (prompted by patch by Ben
    Wong).
  * change default values for mkSamplePass and mkSampleSize to
    reflect generally-improved locale support in various
    operating systems (FreeBSD #219800).
  * modify wcwidth.c to return -1 for non-Unicode values, and
    adjust a couple of blocks to better match assumptions about
    ambiguous-width characters in other implementations. Also
    modify wcwidth.c to support configurable soft-hyphen, so
    there is no drawback to using this version rather than a
    system wcwidth.
  * amend change made in patch #328 for cursor-visibility to
    handle case where an application is updating the
    reverse-video state (FreeBSD #219800).
  * update tables of combining and ambiguous-width characters in
    wcwidth.c based on Unicode 10.0.0.
  * build-fix for --enable-sixel-graphics without
  - -enable-regis-graphics (reports by Sven Joachim, FreeBSD
    [#219945]).
- Patch #329 - 2017/06/12
  * add control sequences for reading the Sixel and ReGIS
    graphics sizes (suggested by Ben Wong).
  * add a workaround for wcwidth returning -1 for characters
    which should have been printable (FreeBSD #219800).
  * fix a bug in font initialization from patch #328 (FreeBSD
    [#219800]).
  * fix a special case in HideCursor which assigned a bold font
    to the slot used for normal font in changes for italics in
    patch #307 (Debian #858304).
  * updates for ReGIS (Ross Combs):
    + Strings specified with no command are used as "comments".
    Print these in the log when tracing.
    + Catch attempts to use "alternate display" mode (AKA
    "blink") from the GIGI, but do not implement it.
    + The T(M) command should only multiply the height by 10,
    not 20.
    + Make the S(E) command reset more state than just the
    screen contents.
    + Remove two rotation variables which were only being
    printed.
    + Numerous minor fixes and comment updates in the R
    command.
    + Unknown R command option names trigger an empty response.
    + Fix the output position after printing rotated text (it
    was missing the the sign before).
    + Fix the position change with pixelvectors and rotated
    text (the rotation transform was not being applied).
    + Update the TODO list and remove a verification FIXME
    (slanted text positioning is correct as is).
    + Emulate the approximately 1.4x enlargement for text which
    isn't rotated at right angles.
    + Only update the color planes specified in the plane mask
    (the W command's F option).
  * fix a bug introduced by the changes to font information in
    patch #328. When processing the "checkfont" option of the
    locale resource, the program referred to the request data, to
    an array which was only allocated in the new/result widget
    (report by H Merijn Brand).
  * fix a missing assignment initialization to make the utf8
    resource control whether escape sequences to enable/disable
    UTF-8 mode are allowed.
- Patch #328 - 2017/06/01
  * revise parser for charClass resource, making these
    improvements:
    + accept octal and hexadecimal values
    + allow embedded whitespace
    + allow the class after colon to be optional, e.g., to
    clear class settings for a range of characters.
  * add command-line option -report-charclass.
  * fix most lintian warnings about test-package
  * add eraseSavedLines resource.
  * document DECSED 3 in ctlseqs.ms (report by Ben Longmans).
  * improve integration between configure-events and updates for
    reported screensize, in particular when switching between
    vt100 and tek4014 modes.
  * modify selection-highlighting of reverse-video text to keep
    that distinct, e.g., by reversing the selection foreground
    and background colors as one would expect. This fixes a
    "useless" case in the description of highlightColorMode.
  * improve fix for Debian #759734, addressing a case where
    non-colored cursor would be invisible against reverse-video
    (see patch #311).
  * updates for ReGIS (Ross Combs):
    + the "H" option of the "T" command should multiply by 10,
    not 20.
    + display unknown glyphs as a solid block.
    + given a succession of text-direction options, use the
    last.
    + fix the direction of ReGIS slanted text so that negative
    values produce oblique output .
    + fix the ReGIS text direction option to only rotate
    characters when no following size option is used.
  * update terminfo to better match corresponding entries in
    ncurses, e.g., u8 pattern to match the VT220, VT420, etc.,
    primary responses, as well as adding smxx and rmxx.
  * fixes from Jörg Sommer:
    + corrected a trace-message regarding maximum
    graphics-size; it used the similar ReGIS maximum size
    which might not be configured.
    + in do_select_regex, clear selection if there is no match.
    If the regex does not match anything around the cursor,
    the selection returned must be empty, otherwise the whole
    line is treated as a match. This way the command defined
    by exec-selectable will not be executed if there is no
    match.
    + modify limit in do_select_regex to include the character
    at the cursor in the match, making it easier to type
    something and then hit the key to trigger
    exec-selectable.
    + If exec-selectable or insert-selection is triggered by a
    mouse button click, the position of the mouse pointer
    should be used. This makes it easier to address any
    position on the window and it makes it possible to use
    the mouse, e.g., for applications such as mutt where you
    cannot move the cursor.
  * modify DECRC to save/restore xterm's last-column flag used to
    control wrapping behavior rather than manipulating DECAWM
    (report/analysis by Mattias Engdegård).
  * add configure option --enable-terminfo-env to use the value
    set by --with-own-terminfo for the $TERMINFO environment
    variable. That variable was set automatically for HPUX, but
    would be useful in other systems, e.g., for Solaris (request
    by Jeff Wieland).
  * fix a race condition when setting up a signal handler to
    timeout if opening /dev/tty hangs (patch by Tobias
    Stoeckmann).
  * review/cleanup resources which were not in the manual page
    (report by Maxwell Anselm):
    + add manual page description as needed.
    + drop resource name for menuBar, as unnecessary.
    + modify fallback numeric value for regisScreenSize
    resource to match that for maxGraphicSize.
  * updated configure macros CF_ADD_CFLAGS, CF_CC_ENV_FLAGS,
    CF_GNU_SOURCE, CF_MATH_LIB, and CF_XOPEN_SOURCE from other
    program-changes.
  * update config.guess, config.sub
  * change ?maximum screensize? assumed by resize to 9999x9999,
    to accommodate people using the Unreadable font.
  * drop Utility from default value of --with-desktop-category
    (Debian #780176).
  * widen the configure script pattern used for finding related
    ".desktop" files, including ?Terminal?
  * several minor improvements to font utility functions:
    + provide for later modification to implement font-sets by
    parsing the font resources as comma-separated lists.
    + parse -fn and -fa similarly, using ?x:? and ?xft:?
    prefixes for font name/family strings to distinguish
    between XLFD and Xft font specifications.
    + use loops to iterate over font classes
    + use getters/setters for font data to allow for on-demand
    lookups.
    + make the debugging trace for missing glyph less verbose
    since that interferes with the -report-fonts option.
    + refactor xtermLoadFont to make it clearer how some fonts
    are derived from others, e.g., bold, wide.
    + make the triggering and suppressing of font-warnings more
    consistent by storing the last state in the widget.
    + reduce font-warnings by checking for repeated warnings.
  * add vttests/query-status.pl
  * add vttests/closest-rgb
  * add special case for displaying soft-hyphen if it happens to
    fall at the right margin, and omitting similar case such as
    the BIDI markers, where a zero-width character is neither a
    control character nor a combining character (Debian #844325).
  * modify logic for OSC 52, manipulate selection data, to update
    the selection-time to include the latest X events. This fixes
    some cases where the selection was invalid, e.g., after an
    event due to focus-follows-mouse (report/testcase by Stephane
    Chauveau).
  * revise macro CastMallocN as new macro TextAlloc to make
    explicit use of sizeof(char) (prompted by patch by Cade
    Foster).
  * add ?Mouse Ops? menu entry and related resources to allow
    runtime disabling/enabling of the mouse protocol escape
    sequences (discussion with Bob Proulx).
  * improve discussion of mouse actions versus protocol in the
    manual (discussion with Bob Proulx).
  * improve discussion of environment variables in the manual,
    pointing out where some features (such as termcap and the
    System5 COLUMNS and LINES variables) are used rarely, mainly
    to support legacy applications.
  * add examples of translations resource for select/paste, and
    for font-size changes to the manual.
  * minor reordering of some entries in ctlseqs.ms for
    consistency (report by Arran Ubels).
  * add -s option to 256colors2.pl and 88colors2.pl, to
    demonstrate modifying the ?system? colors 0?15.
  * omit XFT_SPACING property from call to XftPatternBuild, to
    work around a bug in fontconfig for handling Google Go fonts,
    whose names sort in an order not expected by fontconfig,
    causing the request for a monospaced font to return italics,
    e.g.,
    $ fc-match 'Go Mono:spacing=monospace'
    Go-Mono-Italic.ttf: "Go Mono" "Italic"
    (report by Giacomo Boffi on Stackoverflow).
  * modify minstall.in to improve a workaround added to the
    manual page in patch #182 to avoid having the C preprocessor
    used in the imake configuration strip out the comments in the
    character classes section (reports by Ted Unangst, Anthony J
    Bentley).
- patch rebase:
  [xterm-decomposed_bitmaps.patch]
  [xterm-double_width_fonts.patch]
  [xterm-enable_libtinfo.patch]
  [xterm-forbid_window_and_font_ops.patch]
  [xterm-settings.patch]
  [xterm-sigwinch.patch]


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Digest verification failed - was New Tumbleweed snapshot 20171003 released!

Benoît Monin
Hi,

Some qemu subpackages are reported as invalid. I guess it is the same problem
that happened with TW 20170909 ?

Here is the list I got while upgrading :

Warning: Digest verification failed for file 'qemu-ipxe-1.0.0-2.2.noarch.rpm'
[/var/cache/zypp/packages/repo-oss/suse/noarch/qemu-ipxe-1.0.0-2.2.noarch.rpm]

  expected 2102558f59af6a17d106ec0d3bf602dde8b5f029
  but got  3aafade49858a0c54a885e3059dc172138c4faf5

Warning: Digest verification failed for file 'qemu-seabios-1.10.2-2.2.noarch.rpm'
[/var/cache/zypp/packages/repo-oss/suse/noarch/qemu-seabios-1.10.2-2.2.noarch.rpm]

  expected 89fd308e6a32fa7f43692c733fac5cd13363f85a
  but got  afe9583a064a6a0b03e2587db36e238c9f7f27b6

Warning: Digest verification failed for file 'qemu-sgabios-8-2.2.noarch.rpm'
[/var/cache/zypp/packages/repo-oss/suse/noarch/qemu-sgabios-8-2.2.noarch.rpm]

  expected ad6bc5cb6c3c2cf99bb2d9f45897c618f9c0c968
  but got  1f572fa93f5f1775c6bbdf25a8d3ef0eb2d8b64d

Warning: Digest verification failed for file 'qemu-vgabios-1.10.2-2.2.noarch.rpm'
[/var/cache/zypp/packages/repo-oss/suse/noarch/qemu-vgabios-1.10.2-2.2.noarch.rpm]

  expected 4c9bfeb3280ccb84e78d04e197ce14c15d898165
  but got  feb771b11d889a3890dc446b2f72190936841ecf

--
Benoît
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Digest verification failed - was New Tumbleweed snapshot 20171003 released!

Michael Ströder
Benoît Monin wrote:
> Some qemu subpackages are reported as invalid. I guess it is the same
> problem that happened with TW 20170909 ?

I also saw this. It seems it got fixed in the mean-time.

Ciao, Michael.


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Digest verification failed - was New Tumbleweed snapshot 20171003 released!

Patrick Shanahan-2
* Michael Ströder <[hidden email]> [10-05-17 16:23]:
> Benoît Monin wrote:
> > Some qemu subpackages are reported as invalid. I guess it is the same
> > problem that happened with TW 20170909 ?
>
> I also saw this. It seems it got fixed in the mean-time.

probably a mirror which was not up-to-date

--
(paka)Patrick Shanahan       Plainfield, Indiana, USA          @ptilopteri
http://en.opensuse.org    openSUSE Community Member    facebook/ptilopteri
Registered Linux User #207535                    @ http://linuxcounter.net
Photos: http://wahoo.no-ip.org/piwigo                    paka @ IRCnet freenode
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

perl-DateTime-Format-ISO8601

Maximilian Trummer
In reply to this post by Dominique Leuenberger
perl-DateTime-Format-ISO8601 needs perl(:MODULE_COMPAT_5.24.1), but the
latest version is 5.26.1 so the package has unsolved dependencies now.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: perl-DateTime-Format-ISO8601

Brüns, Stefan
On Donnerstag, 5. Oktober 2017 23:44:54 CEST Maximilian Trummer wrote:
> perl-DateTime-Format-ISO8601 needs perl(:MODULE_COMPAT_5.24.1), but the
> latest version is 5.26.1 so the package has unsolved dependencies now.

Thats not part of the TW repositories, so its expected. Any add-on
repositories may need one or two days until they have catched up, depending on
the number of packages in the repo.

Kind regards,

Stefan
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171003 released!

ianseeks-4
In reply to this post by Dominique Leuenberger
On Thursday, 5 October 2017 20:00:08 BST Dominique Leuenberger wrote:

> Please note that this mail was generated by a script.
> The described changes are computed based on the x86_64 DVD.
> The full online repo contains too many changes to be listed here.
>
> Please check the known defects of this snapshot before upgrading:
> https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171003
>
> When you reply to report some issues, make sure to change the subject.
> It is not helpful to keep the release announcement subject in a thread
> while discussing a specific problem.
>
Snip the rest
>

Is this a problem or something very new? Can i just break dependencies and install?

Problem: nothing provides libboost_filesystem.so.1.65.1 needed by liborcus-0_12-0-0.12.1-64.18.i586
        Selected: Solution 2: break liborcus-0_12-0-0.12.1-64.18.i586 by ignoring some of its dependencies
Problem: nothing provides libboost_date_time.so.1.65.1 needed by libcmis-0_5-5-0.5.1-57.17.i586
        Solution 2: break libcmis-0_5-5-0.5.1-57.17.i586 by ignoring some of its dependencies

Now I get this list of new installs - i aborted at this point...

Problem: nothing provides libboost_filesystem.so.1.65.1()(64bit) needed by liborcus-0_12-0-0.12.1-64.18.x86_64                      
 Solution 1: Following actions will be done:
  install liborcus-0_12-0-0.12.1-64.18.i586 despite the inferior architecture
  install libcdr-0_1-1-0.1.4-66.2.i586 despite the inferior architecture
  install libeot0-0.01-1.7.i586 despite the inferior architecture
  install libexttextcat-2_0-0-3.4.4-20.32.i586 despite the inferior architecture
  install libfreehand-0_1-1-0.1.2-18.3.i586 despite the inferior architecture
  install libgltf-0_1-1-0.1.0-1.1.i586 despite the inferior architecture
  install liblangtag1-0.6.1-26.15.i586 despite the inferior architecture
  install libmspub-0_1-1-0.1.2-34.18.i586 despite the inferior architecture
  install libmwaw-0_3-3-0.3.11-50.10.i586 despite the inferior architecture
  install libmythes-1_2-0-1.2.4-18.24.i586 despite the inferior architecture
  install libodfgen-0_1-1-0.1.6-37.23.i586 despite the inferior architecture
  install libpagemaker-0_0-0-0.0.3-13.15.i586 despite the inferior architecture
  install librevenge-0_0-0-0.0.4-25.16.i586 despite the inferior architecture
  install libstaroffice-0_0-0-0.0.3-10.9.i586 despite the inferior architecture
  install libvisio-0_1-1-0.1.5-31.18.i586 despite the inferior architecture
  install libwpg-0_3-3-0.3.2-35.3.i586 despite the inferior architecture
  install libxmlsec1-1-1.2.24-17.13.i586 despite the inferior architecture
  install libxmlsec1-nss1-1.2.24-17.13.i586 despite the inferior architecture
  install libzmf-0_0-0-0.0.2-13.1.i586 despite the inferior architecture
  install libGeneratedSaxParser0_3-1.6.51-1.2.i586 despite the inferior architecture
  install libOpenCOLLADABaseUtils0_3-1.6.51-1.2.i586 despite the inferior architecture
  install libOpenCOLLADAFramework0_3-1.6.51-1.2.i586 despite the inferior architecture
  install libOpenCOLLADASaxFrameworkLoader0_3-1.6.51-1.2.i586 despite the inferior architecture
  install libclucene-contribs-lib1-2.3.3.4-16.2.i586 despite the inferior architecture
  install libwpd-0_10-10-0.10.2-25.4.i586 despite the inferior architecture
  install libMathMLSolver0_3-1.6.51-1.2.i586 despite the inferior architecture
  install libUTF0_3-1.6.51-1.2.i586 despite the inferior architecture
  install libetonyek-0_1-1-0.1.6-41.11.i586 despite the inferior architecture
  install liblpsolve55-0-5.5.2.0-49.39.i586 despite the inferior architecture
  install libwps-0_4-4-0.4.6-40.12.i586 despite the inferior architecture
  install libmysqlcppconn7-1.1.9-1.1.i586 despite the inferior architecture
  install libabw-0_1-1-0.1.1-33.18.i586 despite the inferior architecture
  install libe-book-0_1-1-0.1.2-25.19.i586 despite the inferior architecture
  install librevenge-stream-0_0-0-0.0.4-25.16.i586 despite the inferior architecture
 Solution 2: install liborcus-0_12-0-0.12.1-1.4.x86_64 (with vendor change)
  obs://build.opensuse.org/LibreOffice  -->  openSUSE
 Solution 3: break liborcus-0_12-0-0.12.1-64.18.x86_64 by ignoring some of its dependencies

Regards

Ian

--
opensuse:tumbleweed:20171001
Qt: 5.9.1
KDE Frameworks: 5.38.0
KDE Plasma: 5.10.5
kwin 5.10.5
kmail2 5.6.1
akonadiserver 5.6.1
Kernel:  4.13.4-1-default
Nouveau:  1.0.15_1.2

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171003 released!

Robert Munteanu
Hi,

>  Solution 2: install liborcus-0_12-0-0.12.1-1.4.x86_64 (with vendor change)
>   obs://build.opensuse.org/LibreOffice  -->  openSUSE

Unless you have a very specific need to get that package from another
repo, this is the solution you should be looking for.

Robert
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

perl provides broken [was: New Tumbleweed snapshot 20171003 released!]

Jiri Slaby-6
In reply to this post by Dominique Leuenberger
On 10/05/2017, 09:00 PM, Dominique Leuenberger wrote:
>   perl (5.24.1 -> 5.26.1)
>   perl-Crypt-SSLeay
>   perl-Encode-HanExtra
>   perl-FileHandle-Unget
>   perl-Module-Signature
>   perl-Task-Weaken
>   perl-Term-ReadKey (2.32 -> 2.37)
>   perl-ldap (0.64 -> 0.65)

Something is broken with perl provides, it seems:

BuildRequires:  perl(Locale::TextDomain)

installs perl-Text-Unidecode-1.30-9.9, which does *not* contain the
module. perl-libintl-perl contains that module, but that one is not
installed via the BuildRequires.

So there is a difference in these two wrt to build success/failure of
some packages:
BuildRequires:  perl(Locale::TextDomain)
BuildRequires:  perl-libintl-perl

Ideas?

thanks,
--
js
suse labs
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: perl provides broken [was: New Tumbleweed snapshot 20171003 released!]

Stephan Kulow-3
Am 06.10.2017 um 11:16 schrieb Jiri Slaby:

> On 10/05/2017, 09:00 PM, Dominique Leuenberger wrote:
>>   perl (5.24.1 -> 5.26.1)
>>   perl-Crypt-SSLeay
>>   perl-Encode-HanExtra
>>   perl-FileHandle-Unget
>>   perl-Module-Signature
>>   perl-Task-Weaken
>>   perl-Term-ReadKey (2.32 -> 2.37)
>>   perl-ldap (0.64 -> 0.65)
>
> Something is broken with perl provides, it seems:
>
> BuildRequires:  perl(Locale::TextDomain)
>
> installs perl-Text-Unidecode-1.30-9.9, which does *not* contain the
> module. perl-libintl-perl contains that module, but that one is not
> installed via the BuildRequires.
>
> So there is a difference in these two wrt to build success/failure of
> some packages:
> BuildRequires:  perl(Locale::TextDomain)
> BuildRequires:  perl-libintl-perl
>
makeinfo provides that - and requires Text-Unicode. and texinfo provides
that because it bundles libintl -> there is your bug.

Greeting, Stephan

--
Ma muaß weiterkämpfen, kämpfen bis zum Umfalln, a wenn die
ganze Welt an Arsch offen hat, oder grad deswegn.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171003 released!

ianseeks-4
In reply to this post by Robert Munteanu
On Friday, 6 October 2017 08:03:06 BST Robert Munteanu wrote:

> Hi,
>
> >  Solution 2: install liborcus-0_12-0-0.12.1-1.4.x86_64 (with vendor change)
> >   obs://build.opensuse.org/LibreOffice  -->  openSUSE
>
> Unless you have a very specific need to get that package from another
> repo, this is the solution you should be looking for.
>
> Robert
>

Thanks.  I have no idea what its for at all but i'll do the vendor change bit.

Ian

--
opensuse:tumbleweed:20171001
Qt: 5.9.1
KDE Frameworks: 5.38.0
KDE Plasma: 5.10.5
kwin 5.10.5
kmail2 5.6.1
akonadiserver 5.6.1
Kernel:  4.13.4-1-default
Nouveau:  1.0.15_1.2

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171003 released!

Olaf Hering-2
On Fri, Oct 06, ianseeks wrote:

> Thanks.  I have no idea what its for at all ...

How can that be?
The LibreOffice devel project was most likely not added by accident to
the list of enabled/available repositories on the affected system.


Olaf

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: New Tumbleweed snapshot 20171003 released!

ianseeks-4
On Friday, 6 October 2017 16:53:27 BST Olaf Hering wrote:

> On Fri, Oct 06, ianseeks wrote:
>
> > Thanks.  I have no idea what its for at all ...
>
> How can that be?
> The LibreOffice devel project was most likely not added by accident to
> the list of enabled/available repositories on the affected system.
>
>
> Olaf
>

I was referring to the specific modules being installed.

--
opensuse:tumbleweed:20171001
Qt: 5.9.1
KDE Frameworks: 5.38.0
KDE Plasma: 5.10.5
kwin 5.10.5
kmail2 5.6.1
akonadiserver 5.6.1
Kernel:  4.13.4-1-default
Nouveau:  1.0.15_1.2

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]