New Tumbleweed snapshot 20170616 released!

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

New Tumbleweed snapshot 20170616 released!

Dominique Leuenberger

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20170616

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
  aaa_base (13.2+git20170512.8fa87a3 -> 13.2+git20170612.37ff18e)
  bluedevil5 (5.10.1 -> 5.10.2)
  bluez
  breeze (5.10.1 -> 5.10.2)
  breeze-gtk (5.10.1 -> 5.10.2)
  breeze4-style (5.10.1 -> 5.10.2)
  ceph (12.0.3+git.1495798013.23dd2b67dc -> 12.0.3+git.1496909744.9f667dc335)
  cmake (3.8.1 -> 3.8.2)
  crash
  dbus-1-glib
  dd_rescue
  dialog
  gnutls (3.5.11 -> 3.5.13)
  gpm
  icewm
  installation-images-Kubic (14.317 -> 14.318)
  installation-images-openSUSE (14.317 -> 14.318)
  kactivitymanagerd (5.10.1 -> 5.10.2)
  kcm_sddm (5.10.1 -> 5.10.2)
  kde-cli-tools5 (5.10.1 -> 5.10.2)
  kde-gtk-config5 (5.10.1 -> 5.10.2)
  kde-user-manager (5.10.1 -> 5.10.2)
  kgamma5 (5.10.1 -> 5.10.2)
  khotkeys5 (5.10.1 -> 5.10.2)
  kinfocenter5 (5.10.1 -> 5.10.2)
  kmenuedit5 (5.10.1 -> 5.10.2)
  kscreen5 (5.10.1 -> 5.10.2)
  kscreenlocker (5.10.1 -> 5.10.2)
  ksshaskpass5 (5.10.1 -> 5.10.2)
  ksysguard5 (5.10.1 -> 5.10.2)
  kwin5 (5.10.1 -> 5.10.2)
  libXdmcp
  libkdecoration2 (5.10.1 -> 5.10.2)
  libkscreen2 (5.10.1 -> 5.10.2)
  libksysguard5 (5.10.1 -> 5.10.2)
  libtasn1 (4.9 -> 4.12)
  man-pages-ja (20161115 -> 20170515)
  milou5 (5.10.1 -> 5.10.2)
  netpbm (10.76.0 -> 10.78.5)
  obs-service-tar_scm (0.7.0.1492101301.747de50 -> 0.7.0.1496831936.d960322)
  oxygen5 (5.10.1 -> 5.10.2)
  plasma-nm5 (5.10.1 -> 5.10.2)
  plasma5-addons (5.10.1 -> 5.10.2)
  plasma5-desktop (5.10.1 -> 5.10.2)
  plasma5-integration (5.10.1 -> 5.10.2)
  plasma5-openSUSE
  plasma5-pa (5.10.1 -> 5.10.2)
  plasma5-session (5.10.1 -> 5.10.2)
  plasma5-workspace (5.10.1 -> 5.10.2)
  plymouth (0.9.2+git20161215.18dd755 -> 0.9.2+git20170424.6fd5c6b)
  polkit-kde-agent-5 (5.10.1 -> 5.10.2)
  poppler
  poppler-qt5
  powerdevil5 (5.10.1 -> 5.10.2)
  powertop
  samba (4.6.3+git.25.0c154becb13 -> 4.6.5+git.27.6afd48b1083)
  systemsettings5 (5.10.1 -> 5.10.2)
  thin-provisioning-tools (0.6.3 -> 0.7.0)
  tigervnc
  wxWidgets-3_0 (3.0.2 -> 3.0.3)
  wxWidgets-3_0-nostl (3.0.2 -> 3.0.3)
  yast2-firewall (3.1.7 -> 3.2.0)

=== Details ===

==== aaa_base ====
Version update (13.2+git20170512.8fa87a3 -> 13.2+git20170612.37ff18e)
Subpackages: aaa_base-extras

- Fix copy+paste error in /etc/csh.login boo#1043560
- Support changing PS1 even for mksh and user root (bsc#1036895)

==== bluedevil5 ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== bluez ====
Subpackages: bluez-cups bluez-devel libbluetooth3

- add bluez-auto-enable-devices subpackage with main.conf which
  auto-enables all devices (boo#1039476)

==== breeze ====
Version update (5.10.1 -> 5.10.2)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style breeze5-wallpapers

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * use fontMetrics.height() rather than boundingRect(...).height() the height of the title bar should not depend on the caption content.

==== breeze-gtk ====
Version update (5.10.1 -> 5.10.2)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== breeze4-style ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * use fontMetrics.height() rather than boundingRect(...).height() the height of the title bar should not depend on the caption content.

==== ceph ====
Version update (12.0.3+git.1495798013.23dd2b67dc -> 12.0.3+git.1496909744.9f667dc335)
Subpackages: librados2 librbd1

- Update to version 12.0.3+git.1496909744.9f667dc335:
  + build/ops: rpm: one License line to rule them all
- up memory _constraint for ceph-test to address ppc64le OOM seen in IBS
- Update to version 12.0.3+git.1496902753.b18dc53186:
  + build/ops: rpm, COPYING: drop GPL 2.0 with Autoconf Exception
    (autoconf no longer used)
- Update to version 12.0.3+git.1496754880.35cb2861ce:
  + merge upstream master (b1d06a6b54)
- Update to version 12.0.3+git.1496494491.ba3c561a92:
  + merge upstream master (97d6e150e5)
- Update to version 12.0.3+git.1496306960.2db336d85e:
  + merge upstream master (b19352eec3), fixes bsc#1041492
- Update to version 12.0.3+git.1496147556.f1d6115861:
  + cmake: build boost::context and coroutine only with rgw Beast frontend
  + build/ops: rpm: reverse s390 bcond conditional block
  + build/ops: rpm: no rgw Beast frontend on s390x
  + build/ops: deb: no rgw Beast frontend on s390x
  + cmake: delete excidentail reintroduced line.
  + cmake: link radosgw with boost libraries
  (bsc#1040119)
- Update to version 12.0.3+git.1495849076.4457d36178:
  + rgw: remove fastcgi from default rgw frontends
  + RGW: Turn off fcgi as a frontend
  + build/ops: drop libfcgi build dependency
  + build/ops: rpm: apply epoch only if %epoch macro is defined

==== cmake ====
Version update (3.8.1 -> 3.8.2)

- Update to version 3.8.2:
  * FindDevIL: Restore IL_FOUND result variable
  * FindOpenSSL: Restore support for crypto-only result
  * source_group: Restore TREE support for relative paths
  * VS: Fix debugging of C++ executables if CSharp is enabled
- Use system rhash

==== crash ====

- crash-xen_add_support_for_domU_with_linux_kernel_from_3.19.patch:
  Since linux kernel 3.19 crash readmem() can't be used to read
  xen_p2m_addr associate memory directly during m2p translation.
  PV domU p2m mapping is also stored at xd->xfd + xch_index_offset
  and organized as struct xen_dumpcore_p2m. This patch implements
  a special reading function read_xc_p2m() to extract the mfns
  from xd->xfd + xch_index_offset and makes and crash support Xen
  PV domU dumpfiles for kernel 3.19 and later (bsc#1043501).
  - add crash-xen_add_support_for_domU_with_linux_kernel_from_3.19.patch

==== dbus-1-glib ====
Subpackages: dbus-1-glib-32bit dbus-1-glib-devel dbus-1-glib-tool

- remove CFLAGS setting, -fstack-protector is default and -fPIC
  will be auto-selected.

==== dd_rescue ====
Subpackages: dd_rescue-crypt dd_rescue-lzo

- Cleanup a bit the dependencies
  * Run %configure as separate comand properly in build phase
- Remove support for < 12.0
- Add condition for openSSL to build with verison 1.0.0 on Factory

==== dialog ====
Subpackages: libdialog14

- Update to version 1.3-20170509:
  * improved configure macros CF_ADD_CFLAGS, CF_CC_ENV_FLAGS, and
  CF_SHARED_OPTS.
  * updated hu.po and tr.po from
  http://translationproject.org/latest/dialog/
  * update config.guess, config.sub

==== gnutls ====
Version update (3.5.11 -> 3.5.13)
Subpackages: libgnutls-dane0 libgnutls-devel libgnutls-openssl27 libgnutls30 libgnutls30-32bit

- GnuTLS 3.5.13:
  * libgnutls: fixed issue with AES-GCM in-place encryption and
    decryption in aarch64
  * libgnutls: no longer parse the ResponseID field of the status
    response TLS extension. The field is not used by GnuTLS nor is
    made available to calling applications. That addresses a null
    pointer dereference on server side caused by packets containing
    the ResponseID field. GNUTLS-SA-2017-4, bsc#1043398
  * libgnutls: tolerate certificates which do not have strict DER
    time encoding. It is possible using 3rd party tools to generate
    certificates with time fields that do not conform to DER
    requirements. Since 3.4.x these certificates were rejected and
    cannot be used with GnuTLS, however that caused problems with
    existing private certificate infrastructures, which were
    relying on such certificates. Tolerate reading and using these
    certificates.
  * minitasn1: updated to libtasn1 4.11.
  * certtool: allow multiple certificates to be used in --p7-sign
    with the --load-certificate option
- GnuTLS 3.5.12:
  * libgnutls: gnutls_x509_crt_check_hostname2() no longer matches
    IP addresses against DNS fields of certificate (CN or DNSname).
    The previous behavior was to tolerate some misconfigured
    servers, but that was non-standard and skipped any IP
    constraints present in higher level certificates.
  * libgnutls: when converting to IDNA2008, fallback to IDNA2003
    (i.e., transitional encoding) if the domain cannot be converted.
    That provides maximum compatibility with browsers like firefox
    that perform the same conversion.
  * libgnutls: fix issue in RSA-PSK client callback which resulted
    in no username being sent to the peer
  * libgnutls: fix regression causing stapled extensions in trust
    modules not to be considered.
  * certtool: introduced the email_protection_key option.  This
    option was introduced in documentation for certtool without an
    implementation of it. It is a shortcut for option
  'key_purpose_oid = 1.3.6.1.5.5.7.3.4'.
  * certtool: made printing of key ID and key PIN consistent
    between certificates, public keys, and private keys. That is
    the private key printing now uses the same format as the rest.
  * gnutls-cli: introduced the --sni-hostname option. This allows
    overriding the hostname advertised to the peer.

==== gpm ====
Subpackages: libgpm2

- synced SLE .changes into devel project (bnc#1041340)

==== icewm ====
Subpackages: icewm-config-upstream icewm-default icewm-lite

- Fix the updates-alternatives code
- Use update-alternatives to create default.desktop xsession (boo#1030873)

==== installation-images-Kubic ====
Version update (14.317 -> 14.318)

- merge gh#openSUSE/installation-images#187
- leap-42.3: include video drivers from drm-kmp (bsc#1043146)
- 14.318

==== installation-images-openSUSE ====
Version update (14.317 -> 14.318)

- merge gh#openSUSE/installation-images#187
- leap-42.3: include video drivers from drm-kmp (bsc#1043146)
- 14.318

==== kactivitymanagerd ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== kcm_sddm ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== kde-cli-tools5 ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== kde-gtk-config5 ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== kde-user-manager ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== kgamma5 ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== khotkeys5 ====
Version update (5.10.1 -> 5.10.2)
Subpackages: khotkeys5-devel

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== kinfocenter5 ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== kmenuedit5 ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== kscreen5 ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== kscreenlocker ====
Version update (5.10.1 -> 5.10.2)
Subpackages: libKScreenLocker5

- Fix the kscreenlocker_greet restart in %post
- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== ksshaskpass5 ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== ksysguard5 ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== kwin5 ====
Version update (5.10.1 -> 5.10.2)
Subpackages: kwin5-devel

- Revert upstream commit to disable a 1px window obstructing the
  left edge of the screen (kde#380476):
  * 0001-Revert-Make-WindowSwitching-Alt-Tab-the-default-left.patch
- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== libXdmcp ====
Subpackages: libXdmcp-devel libXdmcp6

- U_Use-getentropy-if-arc4random_buf-is-not-available.patch
  * Use getentropy() if arc4random_buf() is not available
    (bsc#1025046, CVE-2017-2625)
- U_Fix-compilation-error-when-arc4random_buf-is-not-ava.patch
  * Fix compilation error when arc4random_buf is not available

==== libkdecoration2 ====
Version update (5.10.1 -> 5.10.2)
Subpackages: libkdecoration2-devel libkdecorations2-5 libkdecorations2private5

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== libkscreen2 ====
Version update (5.10.1 -> 5.10.2)
Subpackages: libKF5Screen7 libkscreen2-devel libkscreen2-plugin

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * let's continue in debug code instead of returning from XRandRConfig::applyKScreenConfig

==== libksysguard5 ====
Version update (5.10.1 -> 5.10.2)
Subpackages: libksysguard5-devel libksysguard5-helper

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== libtasn1 ====
Version update (4.9 -> 4.12)
Subpackages: libtasn1-6 libtasn1-6-32bit libtasn1-devel

- libtasn1 4.12:
  * Corrected so-name version
- includes changes in 4.11:
  * Introduce the ASN1_TIME_ENCODING_ERROR error code to indicate
    an invalid encoding in the DER time fields.
  * Introduced flag ASN1_DECODE_FLAG_ALLOW_INCORRECT_TIME. This flag
    allows decoding errors in time fields even when in strict DER mode.
    That is introduced in order to allow toleration of invalid times in
    X.509 certificates (which are common) even though strict DER adherence
    is enforced in other fields.
  * Added safety check in asn1_find_node(). That prevents a crash
    when a very long variable name is provided by the developer.
    Note that this to be exploited requires controlling the ASN.1
    definitions used by the developer, i.e., the 'name' parameter of
    asn1_write_value() or asn1_read_value(). The library is
    not designed to protect against malicious manipulation of the
    developer assigned variable names
- includes changes from 4.10:
  * Updated gnulib
  * Removed -Werror from default compiler flags
    (drop patch 0001-configure-don-t-add-Werror-to-build-flags.patch)
  * Fixed undefined behavior when negating integers in _asn1_ltostr().
  * Pass the correct length to _asn1_get_indefinite_length_string in
    asn1_get_length_ber. This addresses reading 1-byte past the end
    of data.

==== man-pages-ja ====
Version update (20161115 -> 20170515)

- Update to 20170515
  * added and improved manual pages

==== milou5 ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== netpbm ====
Version update (10.76.0 -> 10.78.5)
Subpackages: libnetpbm-devel libnetpbm11

- updated to 10.78.5
  * pamgauss: Fix skewed output with even dimension.
  * bmptopnm: fix crash when input is a Windows BMP with negative
    number for width.
- updated to 10.78.4
  * pamcrater: fix incorrect output with non-square image.
  * libnetpbm: fix bug: pm_system_XXX closes Standard Input if you
    supply a Standard Output accepter but not a Standard Input
    feeder.
  * fix incorrect output with -mixtransparency.
  * pamcomp: remove debug trace message with -mixtransparency.
  * pnmtojpeg: fix array bounds violation in argument list.
  * ppmpat: Add -color.
  * ppmpat: Add -argyle1, -argyle2.
  * pnmtotiff: Fail with -miniswhite or -minisblack on color image
    rather than produce an invalid TIFF.
  * tifftopnmcmyk: Default rows per strip to the TIFF library
    default instead of whatever yields 8K strips.
  * tifftonm: Fix incorrect PBM output with two-color paletted TIFF
    image.
  * tifftopnm: Fix memory corruption when image is more pixels than
    can be represented as a C unsigned integer.
  * tifftopnmcmyk: Fix bug: fails with very wide images and no
  - rowsperstrip.
  * svgtopam: Fix crash when out of memory.
  * pnmcrop: Add -closeness
  * libnetpbm: ppmd_fill_path: remove debug trace.
  * pnmpad: Fix bug: incorrect output width.
- removed netpbm-no-build-date.patch: not needed since:
  * --version global option: with SOURCE_DATE_EPOCH environment
    variable, display source code datetime instead of build
    datetime.

==== obs-service-tar_scm ====
Version update (0.7.0.1492101301.747de50 -> 0.7.0.1496831936.d960322)
Subpackages: obs-service-obs_scm-common

- Update to version 0.7.0.1496831936.d960322:
  * fix for nonexistant build section in appimage.yml
  * [lint] improve inline doc in TarSCM/tasks.py
  * [lint] refactor attribute dataMap in TarSCM.tasks
  * [lint] refactor invalid variable names in TarSCM.tasks
  * [lint] remove variable helpers from TarSCM.tasks
  * [lint] rename variable changes -> detected_changes in TarSCM.tasks
  * [lint] fixed 'line-to-long' error in TarSCM.tasks
  * more documentation for README.md
  * Update control
- add python-yaml for debian distros

==== oxygen5 ====
Version update (5.10.1 -> 5.10.2)
Subpackages: oxygen5-cursors oxygen5-decoration oxygen5-devel oxygen5-lang oxygen5-sounds oxygen5-style

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * Fixed calculation of top border.

==== plasma-nm5 ====
Version update (5.10.1 -> 5.10.2)
Subpackages: plasma-nm5-openconnect plasma-nm5-openvpn plasma-nm5-pptp plasma-nm5-vpnc

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * Openconnect: make sure the UI fits into the password dialog (kde#380399)

==== plasma5-addons ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== plasma5-desktop ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * Fix warning: Typo in enum notation.
  * Fix warning: Not all models implement AppPid.
  * Fix warning: x has no RESET, and this is unnecessary.

==== plasma5-integration ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== plasma5-openSUSE ====
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to 5.10.2

==== plasma5-pa ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * Revert "Make the applet DBus activated" (kde#381010)

==== plasma5-session ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2

==== plasma5-workspace ====
Version update (5.10.1 -> 5.10.2)
Subpackages: drkonqi5 plasma5-workspace-devel plasma5-workspace-libs

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * [Icon Applet] Repopulate if URL didn't change (kde#380922)
  * Fix binding loop in ClipboardItemDelegate
  * Squelch warning.

==== plymouth ====
Version update (0.9.2+git20161215.18dd755 -> 0.9.2+git20170424.6fd5c6b)
Subpackages: libply-boot-client4 libply-splash-core4 libply-splash-graphics4 libply4 plymouth-dracut plymouth-plugin-label plymouth-plugin-label-ft plymouth-plugin-script plymouth-scripts

- Update plymouth.spec: Add COPYING file in plymouth package file
  list, This is for the law requirement (bsc#1043834).
- Update to version 0.9.2+git20170424.6fd5c6b:
  * main: Look for config in runtime dir first
  * main: Look for theme in runtime dir first
  * Revert "Recreate boot log at each boot instead of appending"
  * x11: implement get_display_name
  * drm: implement get_display_name
  * configure: don't look for libudev when --without-udev is passed
  * renderer: export device name from plugin
  * device-manager: handle NULL renderer better
- Remove 0001-device-manager-handle-NULL-renderer-better.patch
  (upstreamed).

==== polkit-kde-agent-5 ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== poppler ====
Subpackages: libpoppler-cpp0 libpoppler-devel libpoppler-glib8 libpoppler67 poppler-tools

- Add poppler-pdfunite-fix-crash-with-broken-documents.patch:
  pdfunite: Fix crash with broken documents. Sometimes we can't
  parse pages so check before accessing them (bsc#1043088,
  bsc#1041783, CVE-2017-7515, CVE-2017-7511, fdo#101153,
  fdo#101149).

==== poppler-qt5 ====
Subpackages: libpoppler-qt5-1 libpoppler-qt5-devel

- Add poppler-pdfunite-fix-crash-with-broken-documents.patch:
  pdfunite: Fix crash with broken documents. Sometimes we can't
  parse pages so check before accessing them (bsc#1043088,
  bsc#1041783, CVE-2017-7515, CVE-2017-7511, fdo#101153,
  fdo#101149).

==== powerdevil5 ====
Version update (5.10.1 -> 5.10.2)

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== powertop ====
Subpackages: powertop-lang

- Sync .changes file from SLE -> OBS devel project (bnc#1041572)

==== samba ====
Version update (4.6.3+git.25.0c154becb13 -> 4.6.5+git.27.6afd48b1083)
Subpackages: libdcerpc-binding0 libdcerpc-binding0-32bit libdcerpc0 libdcerpc0-32bit libndr-krb5pac0 libndr-krb5pac0-32bit libndr-nbt0 libndr-nbt0-32bit libndr-standard0 libndr-standard0-32bit libndr0 libndr0-32bit libnetapi0 libnetapi0-32bit libsamba-credentials0 libsamba-credentials0-32bit libsamba-errors0 libsamba-errors0-32bit libsamba-hostconfig0 libsamba-hostconfig0-32bit libsamba-passdb0 libsamba-passdb0-32bit libsamba-util0 libsamba-util0-32bit libsamdb0 libsamdb0-32bit libsmbclient-devel libsmbclient0 libsmbconf0 libsmbconf0-32bit libsmbldap0 libsmbldap0-32bit libtevent-util0 libtevent-util0-32bit libwbclient0 libwbclient0-32bit samba-client samba-client-32bit samba-doc samba-libs samba-libs-32bit samba-winbind samba-winbind-32bit

- Update to 4.6.5; (bsc#1040157)
  + Specifying CTDB_LOGGING=syslog:nonblocking causes ctdbd to crash at
    startup; (bso#12814).
  + vfs_expand_msdfs tries to open the remote address as a file path;
    (bso#12687).
  + PANIC (pid 1096): assert failed: lease_type_is_exclusive(e_lease_type);
    (bso#12798).
  + With clustering get update_num_read_oplocks failed and PANIC:
    num_share_modes == 1 assertion failure; (bso#11844).
  + contend_level2_oplocks_begin_default oplock optimisation doesn't carry
    over to leases; (bso#12766).
  + `ctdb nodestatus` incorrectly displays status for all nodes with wrong
    exit code; (bso#12802).
  + CTDB can spin hard on revoking readonly delegations if a node becomes
    disconnected; (bso#12697).
  + Printing a share mode entry with leases can crash in the ndr code;
    (bso#12793).
  + Fix flakey unit tests for eventd; (bso#12792).
  + CTDB daemon crashes if built with clang; (bso#12770).
  + smbcacls fails if no password is specified; (bso#12765).
  + idmap_rfc2307: Lookup of more than two SIDs fails; (bso#12757).
  + samba-tool user syncpasswords doesn't trigger the script when a user gets
    removed; (bso#12767).
  + systemd: fix detection of libsystemd; (bso#12764).
  + Notify subsystem only maps first inotify mask to Windows notify filter;
    (bso#12760).
  + Allow passing trusted domain password as plain-text to PASSDB layer;
    (bso#12751).
  + Can't case-rename files with vfs_fruit; (bso#12749).
  + wrong sid->uid mapping for SIDs residing in sIDHistory; (bso#12702).
  + vfs_acl_common should force "create mask = 0777", not 0666; (bso#12562).
  + Ordering of notify responses broken; (bso#12756).

==== systemsettings5 ====
Version update (5.10.1 -> 5.10.2)
Subpackages: systemsettings5-devel

- Update to 5.10.2
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.10.2.php
- Changes since 5.10.1:
  * None

==== thin-provisioning-tools ====
Version update (0.6.3 -> 0.7.0)

- Update to version 0.7.0:
  * boo#1043043 gh#jthornber/thin-provisioning-tools#79
  * Needed for working with latest lvm2

==== tigervnc ====

- Require java-deve >= 1.6.0 to avoid bootstrap fail

==== wxWidgets-3_0 ====
Version update (3.0.2 -> 3.0.3)
Subpackages: libwx_baseu-suse3 libwx_baseu_net-suse3 libwx_baseu_xml-suse3 libwx_gtk2u_adv-suse3 libwx_gtk2u_aui-suse3 libwx_gtk2u_core-suse3 libwx_gtk2u_gl-suse3 libwx_gtk2u_html-suse3 libwx_gtk2u_media-suse3 libwx_gtk2u_propgrid-suse3 libwx_gtk2u_qa-suse3 libwx_gtk2u_richtext-suse3 libwx_gtk2u_stc-suse3 libwx_gtk2u_webview-suse3 libwx_gtk2u_xrc-suse3

- update to 3.0.3
  See: https://github.com/wxWidgets/wxWidgets/blob/v3.0.3/docs/changes.txt#L583-L632
- change source url to github
- rebase patch soversion.diff
- remove following patches, because they are now in upstream:
  0001-avoid-passing-invalid-rect-to-Refresh-closes-16819.patch
  0001-Ensure-the-PangoFontFace-type-is-loaded.patch
  0001-Fix-wxPrintDialog-when-used-directly-see-16821.patch
  0001-set-transient-parent-for-about-dialog-closes-16823.patch
  0001-Avoid-refreshing-not-currently-visible-items-in-gene.patch
  0001-Avoid-Gtk-Message-GtkDialog-mapped-without-a-transie.patch
  0001-Fix-wxSpinButton-best-size-for-GTK-3.12-and-later-se.patch
  0001-Fix-drawing-checkbox-and-radiobutton-in-checked-stat.patch
  0001-Provide-trivial-GDK_IS_X11_DISPLAY-definition-for-GT.patch
  0001-Fix-spurious-assert-in-wxGTK-wxDataViewCtrl-EditItem.patch
  0002-Don-t-defer-wxTLW-initialization-in-wxGTK-when-not-u.patch
  0003-Don-t-use-frame-extents-when-not-using-X11-in-wxGTK.patch
  0004-Don-t-crash-when-switching-to-full-screen-in-non-X11.patch
  0005-Don-t-use-X11-only-functions-when-not-using-X11-in-w.patch
  abs.diff
  wxWidgets-3_0-gstreamer-1.0.patch

==== wxWidgets-3_0-nostl ====
Version update (3.0.2 -> 3.0.3)
Subpackages: libwx_baseu-suse-nostl3 libwx_baseu_net-suse-nostl3 libwx_baseu_xml-suse-nostl3 libwx_gtk2u_adv-suse-nostl3 libwx_gtk2u_core-suse-nostl3 libwx_gtk2u_html-suse-nostl3 libwx_gtk2u_qa-suse-nostl3

- update to 3.0.3
  See: https://github.com/wxWidgets/wxWidgets/blob/v3.0.3/docs/changes.txt#L583-L632
- change source url to github
- rebase patch soversion.diff
- remove following patches, because they are now in upstream:
  0001-avoid-passing-invalid-rect-to-Refresh-closes-16819.patch
  0001-Ensure-the-PangoFontFace-type-is-loaded.patch
  0001-Fix-wxPrintDialog-when-used-directly-see-16821.patch
  0001-set-transient-parent-for-about-dialog-closes-16823.patch
  0001-Avoid-refreshing-not-currently-visible-items-in-gene.patch
  0001-Avoid-Gtk-Message-GtkDialog-mapped-without-a-transie.patch
  0001-Fix-wxSpinButton-best-size-for-GTK-3.12-and-later-se.patch
  0001-Fix-drawing-checkbox-and-radiobutton-in-checked-stat.patch
  0001-Provide-trivial-GDK_IS_X11_DISPLAY-definition-for-GT.patch
  0001-Fix-spurious-assert-in-wxGTK-wxDataViewCtrl-EditItem.patch
  0002-Don-t-defer-wxTLW-initialization-in-wxGTK-when-not-u.patch
  0003-Don-t-use-frame-extents-when-not-using-X11-in-wxGTK.patch
  0004-Don-t-crash-when-switching-to-full-screen-in-non-X11.patch
  0005-Don-t-use-X11-only-functions-when-not-using-X11-in-w.patch
  abs.diff
  wxWidgets-3_0-gstreamer-1.0.patch

==== yast2-firewall ====
Version update (3.1.7 -> 3.2.0)

- bnc#1044045
  - do not raise an internal error when pushing Add button when
    "Service to Allow" list is empty
- 3.2.0


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Keyboard and mouse unresponsive

Javier Llorente-2
El sábado, 17 de junio de 2017 15:23:23 (CEST) Dominique Leuenberger escribió:

> Please note that this mail was generated by a script.
> The described changes are computed based on the x86_64 DVD.
> The full online repo contains too many changes to be listed here.
>
> Please check the known defects of this snapshot before upgrading:
> https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version
> =Tumbleweed&build=20170616
>
> When you reply to report some issues, make sure to change the subject.
> It is not helpful to keep the release announcement subject in a thread
> while discussing a specific problem.
>
[...]

I have just upgraded to TW 20170616-1.2 and my USB keyboard and mouse are
unresponsive for several seconds after SDDM is loaded, so I have to wait until
I can type my password. This didn't happen with TW 20170602-1.1.

This is what I have seen so far;

 usb 3-10: device descriptor read/64, error -11
 usb 3-10: device not accepting address 6, error -62
 usb 3-10: new high-speed USB device number 7 using xhci_hcd
xhci_hcd 0000:00:14.0: Timeout while waiting for setup device command
usb 3-10: device not accepting address 7, error -62
usb usb3-port10: unable to enumerate USB device

More bits at http://paste.opensuse.org/3a0d1790

Any ideas why this is happening?

Greetings,
--
Javier Llorente

signature.asc (201 bytes) Download Attachment