New Tumbleweed snapshot 20161125 released!

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

New Tumbleweed snapshot 20161125 released!

Dominique Leuenberger

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20161125

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
  ImageMagick (6.9.5.10 -> 6.9.6.5)
  aspell-en (2015.04.24 -> 2016.11.20)
  bluedevil5 (5.8.3 -> 5.8.4)
  breeze (5.8.3 -> 5.8.4)
  breeze-gtk (5.8.3 -> 5.8.4)
  breeze4-style (5.8.3 -> 5.8.4)
  cairomm (1.12.0 -> 1.12.2)
  epiphany (3.22.2 -> 3.22.3)
  fltk (1.3.3 -> 1.3.4)
  gfxboot (4.5.19 -> 4.5.20)
  gpgme
  graphite2 (1.3.8 -> 1.3.9)
  gssdp (1.0.0 -> 1.0.1)
  gtk3 (3.22.3 -> 3.22.4)
  gupnp (1.0.0 -> 1.0.1)
  gupnp-av (0.12.8 -> 0.12.10)
  kactivitymanagerd (5.8.3 -> 5.8.4)
  kcm_sddm (5.8.3 -> 5.8.4)
  kde-cli-tools5 (5.8.3 -> 5.8.4)
  kde-gtk-config5 (5.8.3 -> 5.8.4)
  kde-user-manager (5.8.3 -> 5.8.4)
  kgamma5 (5.8.3 -> 5.8.4)
  khelpcenter5
  khotkeys5 (5.8.3 -> 5.8.4)
  kinfocenter5 (5.8.3 -> 5.8.4)
  kmenuedit5 (5.8.3 -> 5.8.4)
  kmod
  kscreen5 (5.8.3 -> 5.8.4)
  kscreenlocker (5.8.3 -> 5.8.4)
  ksshaskpass5 (5.8.3 -> 5.8.4)
  ksysguard5 (5.8.3 -> 5.8.4)
  kwin5 (5.8.3 -> 5.8.4)
  latex2html (2015 -> 2016)
  libkdecoration2 (5.8.3 -> 5.8.4)
  libkscreen2 (5.8.3 -> 5.8.4)
  libksysguard5 (5.8.3 -> 5.8.4)
  libproxy
  libproxy-plugins
  libsolv (0.6.23 -> 0.6.24)
  libsrtp
  llvm3_8
  lxpanel (0.8.1 -> 0.9.0)
  milou5 (5.8.3 -> 5.8.4)
  netpbm (10.75.1 -> 10.76.0)
  ntp (4.2.8p8 -> 4.2.8p9)
  openal-soft
  openmpi
  oxygen5 (5.8.3 -> 5.8.4)
  par (1.1 -> 0.6.14)
  perl-XML-Twig (3.49 -> 3.52)
  plasma-nm5 (5.8.3 -> 5.8.4)
  plasma5-addons (5.8.3 -> 5.8.4)
  plasma5-desktop (5.8.3 -> 5.8.4)
  plasma5-integration (5.8.3 -> 5.8.4)
  plasma5-openSUSE
  plasma5-pa (5.8.3 -> 5.8.4)
  plasma5-session (5.8.3 -> 5.8.4)
  plasma5-workspace (5.8.3 -> 5.8.4)
  polkit-kde-agent-5 (5.8.3 -> 5.8.4)
  poppler (0.48.0 -> 0.49.0)
  poppler-qt (0.48.0 -> 0.49.0)
  poppler-qt5 (0.48.0 -> 0.49.0)
  powerdevil5 (5.8.3 -> 5.8.4)
  python-numpy
  python-zope.interface (4.1.2 -> 4.3.1)
  rpcbind
  scons (2.5.0 -> 2.5.1)
  systemsettings5 (5.8.3 -> 5.8.4)
  virtualbox (5.1.8_k4.8.10_1 -> 5.1.10_k4.8.10_1)
  xf86-input-joystick (1.6.2 -> 1.6.3)
  xf86-input-keyboard (1.8.1 -> 1.9.0)
  xf86-input-mouse (1.9.1 -> 1.9.2)
  xf86-input-synaptics (1.8.3 -> 1.9.0)
  xf86-video-amdgpu (1.1.2 -> 1.2.0)
  xf86-video-ati (7.7.1 -> 7.8.0)
  xf86-video-vmware (13.1.0 -> 13.2.1)
  xterm (326 -> 327)
  yast2 (3.2.5 -> 3.2.6)
  yast2-country (3.2.1 -> 3.2.2)
  yast2-dns-server (3.1.24 -> 3.2.0)
  yast2-network (3.2.9 -> 3.2.11)
  zypper (1.13.13 -> 1.13.14)

=== Details ===

==== ImageMagick ====
Version update (6.9.5.10 -> 6.9.6.5)
Subpackages: ImageMagick-devel ImageMagick-extra libMagick++-6_Q16-6 libMagickCore-6_Q16-2 libMagickWand-6_Q16-2 perl-PerlMagick

- Updated to 6.9.6-5
  * Web pages were broken when we moved to HTTPS protocol.
  * Restore -sharpen / -convolve options to work with CMYK (reference
    https://github.com/ImageMagick/ImageMagick/issues/299).
  * Off by one memory allocation (reference
    https://github.com/ImageMagick/ImageMagick/issues/296).
  * Prevent fault in MSL interpreter (reference
    https://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=30797).
  * Added layer ZIP compression to the PSD encoder.
  * Unit test pass again after small SUN image patch.
  * Fixed incorrect RLE decoding when reading a DCM image that contains
    multiple segments.
  * Fixed incorrect RLE decoding when reading an SGI image (reference
    https://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=30514)

==== aspell-en ====
Version update (2015.04.24 -> 2016.11.20)

- updated to 2016.11.20:
  * various new words (see SCOWL-README for other changes)

==== bluedevil5 ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php
- Correct terminology

==== breeze ====
Version update (5.8.3 -> 5.8.4)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style breeze5-wallpapers

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php
- Introduce new _plasma5_bugfix global for more fine-tuned dependencies

==== breeze-gtk ====
Version update (5.8.3 -> 5.8.4)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== breeze4-style ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== cairomm ====
Version update (1.12.0 -> 1.12.2)

- Update to version 1.12.2:
  + Remove new API that was not meant to be added in 1.12.1.
- Changes from version 1.12.1:
  + C++11:
  - Use nullptr instead of 0.
  - Use override keyword on destructors.
  - Make operator bool() explicit.

==== epiphany ====
Version update (3.22.2 -> 3.22.3)
Subpackages: epiphany-lang gnome-shell-search-provider-epiphany

- Update to version 3.22.3:
  + Rework key event handling to fix events received twice
    (bgo#764653).
  + Add missing F1 keyboard shortcut to open help.

==== fltk ====
Version update (1.3.3 -> 1.3.4)

- updated to 1.3.4: see CHANGES
- remove fltk-1.3.3-do-not-use-internal-ABI.patch (upstreamed)

==== gfxboot ====
Version update (4.5.19 -> 4.5.20)

- merge pr gh#openSUSE/gfxboot#22
- update git2log script
- adjust keymap names to be consistent again (bsc#1009914)
- 4.5.20

==== gpgme ====
Subpackages: libgpgme-devel libgpgme11 libgpgmepp6

- Add remove-a-forgotten-instance-of-libsuffix.diff: fix CMake
  files for gpgmepp (or they won't work with KDE software)

==== graphite2 ====
Version update (1.3.8 -> 1.3.9)
Subpackages: graphite2-devel libgraphite2-3 libgraphite2-3-32bit

- Version update to 1.3.9: fixes some bugs in the collision
  avoidance and may give slightly improved results in some cases.

==== gssdp ====
Version update (1.0.0 -> 1.0.1)

- Update to version 1.0.1:
  + Fix some compiler/c89 issues with recent mingw.
  + Use proper ssize_t modifier in printf.
  + Make documentation point to itself by declaring it stable.
  + Use correct FSF address in documentation text.

==== gtk3 ====
Version update (3.22.3 -> 3.22.4)
Subpackages: gtk3-data gtk3-immodule-amharic gtk3-immodule-inuktitut gtk3-immodule-thai gtk3-immodule-vietnamese gtk3-immodule-xim gtk3-tools libgtk-3-0 typelib-1_0-Gtk-3_0

- Update to version 3.22.4:
  + Bugs fixed: bgo#767713, bgo#768081, bgo#768531, bgo#772075,
    bgo#772202, bgo#773587, bgo#773916, bgo#773979, bgo#774046,
    bgo#774066, bgo#774097, bgo#774185, bgo#774352.
  + Updated translations.
- Drop gtk3-startupfix-wayland.patch: fixed upstream.

==== gupnp ====
Version update (1.0.0 -> 1.0.1)

- Update to version 1.0.1:
  + Connman CM: Various fixes.
  + Linux CM: Fix compiler warning about negative shift.
  + Documentation:
  - Fix FSF address.
  - Fix references.
  + Build: Update ax_append_link_flags.
  + Bugs fixed: bgo#770318.

==== gupnp-av ====
Version update (0.12.8 -> 0.12.10)
Subpackages: libgupnp-av-1_0-2

- Update to version 0.12.10:
  + Remove unneeded dependency on GSSDP-1.0.gir.
- Update to version 0.12.9:
  + Drop dependency on GUPnP.
- Drop pkgconfig(gupnp-1.0) BuildRequires following upstreams
  changes.
- Add explicit pkgconfig(gobject-2.0) and pkgconfig(libxml-2.0)
  BuildRequires, previously pulled in by gupnp.

==== kactivitymanagerd ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== kcm_sddm ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== kde-cli-tools5 ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== kde-gtk-config5 ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== kde-user-manager ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== kgamma5 ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== khelpcenter5 ====

- Require kdoctools which contains some images and stylesheets used
  by khelpcenter5 (boo#1011094)

==== khotkeys5 ====
Version update (5.8.3 -> 5.8.4)
Subpackages: khotkeys5-devel

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== kinfocenter5 ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== kmenuedit5 ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== kmod ====
Subpackages: kmod-compat libkmod2

- 0002-depmod-ignore-related-modules-in-depmod_report_cycle.patch:
  Fix buffer overflow when printing modules in cyclic dependency
  chain (boo#1008186)

==== kscreen5 ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== kscreenlocker ====
Version update (5.8.3 -> 5.8.4)
Subpackages: libKScreenLocker5

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== ksshaskpass5 ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== ksysguard5 ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== kwin5 ====
Version update (5.8.3 -> 5.8.4)
Subpackages: kwin5-devel

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== latex2html ====
Version update (2015 -> 2016)

- updated to 2016:
  * longtable: fix duplicate caption
  * pstoimg: fix pstoimg -depth 24 -flip cw

==== libkdecoration2 ====
Version update (5.8.3 -> 5.8.4)
Subpackages: libkdecoration2-devel libkdecorations2-5 libkdecorations2private5

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== libkscreen2 ====
Version update (5.8.3 -> 5.8.4)
Subpackages: libKF5Screen7 libkscreen2-devel libkscreen2-plugin

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== libksysguard5 ====
Version update (5.8.3 -> 5.8.4)
Subpackages: libksysguard5-devel libksysguard5-helper

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== libproxy ====
Subpackages: libproxy-devel libproxy1

- Add libproxy-cmake-3.7.patch: Fix build with cmake 3.7.

==== libproxy-plugins ====
Subpackages: libproxy1-config-gnome3 libproxy1-config-kde libproxy1-networkmanager libproxy1-pacrunner-webkit

- Add libproxy-cmake-3.7.patch: Fix build with cmake 3.7.

==== libsolv ====
Version update (0.6.23 -> 0.6.24)
Subpackages: libsolv-devel libsolv-tools perl-solv python-solv

- make testcase_str2solvid work with ignored packages
- improve checks against corrupt rpm
- add SOLVER_FLAG_FOCUS_BEST solver flag
- rework susetags multi-line handling [bnc#1007273]
- build both for python2 and python3
- bump version to 0.6.24

==== libsrtp ====

- Update descriptions

==== llvm3_8 ====
Subpackages: libLLVM3_8 libLLVM3_8-32bit

- require libLTO in llvm-devel. Otherwise, when I use
  find_package(LLVM REQUIRED CONFIG), I see:
  CMake Error at /usr/share/llvm/cmake/LLVMExports.cmake:555 (message):
    The imported target "LTO" references the file
    "/usr/lib64/libLTO.so.3.8.1"
    but this file does not exist.

==== lxpanel ====
Version update (0.8.1 -> 0.9.0)
Subpackages: liblxpanel0 lxpanel-lang

- Update to 0.9.0:
  * Added support for laptops with multiple batteries.
  * Added a way to scroll through workspaces by using the scroll wheel over the deskno plugin.
  * Bunch of fixes for GTK+ 3.0 compatibility.
  * Fixed outdated lxpanel man page.
  * Fixed weather locations query (since YQL was changed recently).
  * Converted space plugin into internal PanelSpace widget in liblxpanel.
  * Converted task button into widget class to avoid ambiguous code.
  * Added support for third-party plugins localized descriptions.
  * Implemented ?lxpanelctl command ?? to send message to panel plugin.
  * Added APIs for PanelIconGrid to draw focus on drop.
  * Converted launch button into widget class for more easy management.
  * Adjusted PanelIconGrid: min spacing is now 1, no_window flag is now left unset by default, spacing is taken into account on overall size to be consistent on chosen orientation.
  * Implemented dropping file or folder onto launch bar to create launcher.
  * Implemented dragging launchers around launchbars (between panels too).
  * Implemented dropping file or folder onto free panel space to create launcher.
  * Implemented dragging launchers from launchbar to some free panel space.
  * Added stripping scheme from URI menu://applications/? when a launcher is created, only menu-id itself should be used.
  * Implemented moving plugins across panel by means of middle button drag and drop, i.e. middle-click it then drag, and plugin will follow the mouse until middle button is released.
  * Merged ?volume? and ?volumealsa? plugins into single plugin which uses the same interface but different driver, in dependency on how it was built ? either OSS or ALSA interface is used. Name ?volume? is used for simplicity while ?volumealsa? is supported for compatibility.
  * Made default channel in ?volume? plugin definable in config. If there is no config statement then plugin finds first usable one, the same as before.
  * Made clicks for Toggle Mute, Show Slider and Open Mixer actions of the ?volume? plugin configurable. Defaults are the same: left-click shows slider, middle-click toggles mute state.
  * Added support for ?PCM? and ?Headphone? channels for OSS mixer.
  * Added support for other (not default one) ALSA cards in ?volume? plugin via ?CardNumber? setting.
  * Added hotkey support into ?volume? plugin to be able to use multimedia keys for volume changing directly by plugin.
  * Fixed missing libkeybinder initialization (keybinding did not work).
  * Fixed check for attempt to add a binding for the same hotkey which is already bound elsewhere.
  * Added a configuration dialog to the ?volume? plugin with all the new settings available to choose and set, including preset of discovered mixers, with ability to type own command as well.
  * Fixed crash on action on task window which was deleted while task menu is still opened.
  * Fixed ?dynamic? panel width allocation.
  * Fixed PanelIconGrid allocation in rigth-to-left languages, it was wrong so some icons might be invisible or placed under other plugins.
  * Removed call to gtk_widget_set_style() from volume slider to fix colors of current theme.
  * Changed icon size handling on task bar ? it may now maintain the same size as rest of icons. It may affect users who are used to have thems maller, it?s why this feature was made configurable, corresponding config variable is UseSmallerIcons and default is 1 (old behavior).
  * Changed volume slider popup behavior ? it now hides when loses focus.
  * Fixed invalid memory access in weather plugin.
  * Fixed incorrect reporting units on ?Feel? value in weather plugin. YQL always reports Fahrenheit degrees there.
  * Added a safeguard on menu cache returning items with empty Exec line.
  * Fixed maximizing windows using task bar, GDK functions not always work.
  * Fixed wrong bind of preferences dialog to the panel, which resulted in other dialogs appear on the same workspace where preferences was.
  * Expanded launch buttons active area to launchbar borders so if clicked even into desktop corner, it should activate button at that corner.
  * Fixed few memory leaks in ?batt? plugin.
  * Removed unwanted conversions with energy for charge in ?batt? plugin which will mess up tooltip indications, and may make rate/percentage calculations invalid.
  * Replaced Xclimsg() with Xclimsgx() to be screen aware with X11 message.
  * Added a workaround for WM like MWM which does not properly resize down widgets of panel kind. It still leaves artefacts but is better now.
  * Added a workaround on GtkBox behavior which does not send allocation requests to children in some cases, so resizing of launchtaskbar on panel height change was broken.
  * Fixed PanelIconGrid layout on vertical panels with more than 1 column.
- Remove upstreamed patches:
  * lxpanel-0.8.1-Do-not-load-indicators-in-the-constructor.patch
  * lxpanel-0.8.1-Fix-crash-with-invalid-size-of-icon.patch
  * lxpanel-0.8.1-Fix-incorrect-panel-geometry-initialization.patch
  * lxpanel-0.8.1-Fix-lxpanel.pc-dependencies.patch
  * lxpanel-0.8.1-Fix-taskbar-plugin-crash.patch

==== milou5 ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== netpbm ====
Version update (10.75.1 -> 10.76.0)
Subpackages: libnetpbm-devel libnetpbm11

- updated to 10.76.0
  * pnmquantall: Fix failure when temporary file location is
    not the same filesystem as the output file.
  * pnmquantall: Fix incorrect handling of when the Pnmremap or
    the final rename fails.
  * giftopnm: Fix bug: crash on little-endian computers that can't
    toleration unaligned memory access.  Thanks Ignatios Souvatzis
    ([hidden email]).  Broken in Netpbm 10.47 (June 2009).
  * cmuwmtopbm: fix trivial memory leak.  Always broken (cmuwmtopbm
    was in primordial Pbmplus, in 1988).
  * Build: tifftopnm.c: fix undefined WIFSIGNALED, etc.

==== ntp ====
Version update (4.2.8p8 -> 4.2.8p9)
Subpackages: ntp-doc

- Update to 4.2.8p9:
  * CVE-2016-9311: Trap crash.
  * CVE-2016-9310: Mode 6 unauthenticated trap information
    disclosure and DDoS vector.
  * CVE-2016-7427: Broadcast Mode Replay Prevention DoS.
  * CVE-2016-7428: Broadcast Mode Poll Interval Enforcement DoS.
  * CVE-2016-7431: Regression: 010-origin: Zero Origin Timestamp
    Bypass.
  * CVE-2016-7434: Null pointer dereference in
    _IO_str_init_static_internal().
  * CVE-2016-7429: Interface selection attack.
  * CVE-2016-7426: Client rate limiting and server responses.
  * CVE-2016-7433: Reboot sync calculation problem.
  * Fix a spurious error message (obsoletes ntp-sigchld.patch).
  * Other bugfixes, see /usr/share/doc/packages/ntp/ChangeLog.
- Fix a regression in "trap" (bsc#981252, ntp-trap.patch).
- Reduce the number of netlink groups to listen on for changes to
  the local network setup (bsc#992606, ntp-netlink.patch).
- Fix segfault in "sntp -a" (bnc#1009434, ntp-sntp-a.patch).
- Silence an OpenSSL version warning (bsc#992038,
  ntp-openssl-version.patch).

==== openal-soft ====
Subpackages: libopenal1 libopenal1-32bit openal-soft-devel

- Add missing dependency for JACK backend

==== openmpi ====

- Fix creation of environment module in spec (bsc#1011484).

==== oxygen5 ====
Version update (5.8.3 -> 5.8.4)
Subpackages: oxygen5-cursors oxygen5-decoration oxygen5-devel oxygen5-lang oxygen5-sounds oxygen5-style

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php
- Remove upstream patches:
  * Fix-broken-kcfgc-files.patch

==== par ====
Version update (1.1 -> 0.6.14)

- Change upstream source to more active one
  * This includes change of version from 1.1 to 0.6.15
- Update to version 0.6.14:
  * For comprehensive list of changes see ChangeLog
- Enable tests
- Drop par.diff

==== perl-XML-Twig ====
Version update (3.49 -> 3.52)

- updated to 3.52
  see /usr/share/doc/packages/perl-XML-Twig/Changes
  3.52 - 2016-11-23  - minor maintenance release
  - fixed: the previous fix was buggy...
  3.51 - 2016-11-23  - minor maintenance release
  - fixed: failing tests when XML::XPathEngine and XML::XPath not available
- updated to 3.50
  see /usr/share/doc/packages/perl-XML-Twig/Changes

==== plasma-nm5 ====
Version update (5.8.3 -> 5.8.4)
Subpackages: plasma-nm5-openconnect plasma-nm5-openvpn plasma-nm5-pptp plasma-nm5-vpnc

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== plasma5-addons ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== plasma5-desktop ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== plasma5-integration ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== plasma5-openSUSE ====
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== plasma5-pa ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== plasma5-session ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== plasma5-workspace ====
Version update (5.8.3 -> 5.8.4)
Subpackages: drkonqi5 plasma5-workspace-devel plasma5-workspace-libs

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php
- Remove patches, now upstream:
  * 0001-taskmanagerrulesrc-Add-Rewrite-Rule-for-Google-chrom.patch
  * 0002-make-sure-all-outputs-are-known.patch
  * 0003-Sync-app-config-in-sync-with-applets-config.patch
  * 0004-Avoid-connecting-to-screen-changed-signals-twice.patch
  * 0005-Load-screenpool-at-the-same-time-as-we-connect-to-sc.patch
  * Look-for-both-json-and-desktop-metadata.patch
  * keep-wallpaper-aspect-ratio-wallpaper-on-screen-resolution-change.diff
  * plasma5-workspace.spec
  * use-nearest-aspect-ratio-available-wallpaper.diff

==== polkit-kde-agent-5 ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== poppler ====
Version update (0.48.0 -> 0.49.0)
Subpackages: libpoppler-cpp0 libpoppler-devel libpoppler-glib8 poppler-tools

- Update to version 0.49.0:
  + core:
  - Merge type3 glyph handling from xpdf 3.04 (fdo#96667).
  - Continue rendering in case of 'Singular matrix in shading
    pattern fill (bgo#98623).
  - Fix memory leak in parametrized gouraudTriangleShadedFill.
  - Fix crash on broken files.
  - PDFDoc::setDocInfoStringEntry(): treat value consisting of
    just the unicode marker as an empty string.
  - Fix UBSAN warning.
  - Misc compile fixes.
  + utils: pdfseparate: remove extra '%' in error message.
  + build system: configure: Fix typo in disable nss help string.

==== poppler-qt ====
Version update (0.48.0 -> 0.49.0)

- Update to version 0.49.0:
  + core:
  - Merge type3 glyph handling from xpdf 3.04 (fdo#96667).
  - Continue rendering in case of 'Singular matrix in shading
    pattern fill (bgo#98623).
  - Fix memory leak in parametrized gouraudTriangleShadedFill.
  - Fix crash on broken files.
  - PDFDoc::setDocInfoStringEntry(): treat value consisting of
    just the unicode marker as an empty string.
  - Fix UBSAN warning.
  - Misc compile fixes.
  + utils: pdfseparate: remove extra '%' in error message.
  + build system: configure: Fix typo in disable nss help string.

==== poppler-qt5 ====
Version update (0.48.0 -> 0.49.0)
Subpackages: libpoppler-qt5-1 libpoppler-qt5-devel

- Update to version 0.49.0:
  + core:
  - Merge type3 glyph handling from xpdf 3.04 (fdo#96667).
  - Continue rendering in case of 'Singular matrix in shading
    pattern fill (bgo#98623).
  - Fix memory leak in parametrized gouraudTriangleShadedFill.
  - Fix crash on broken files.
  - PDFDoc::setDocInfoStringEntry(): treat value consisting of
    just the unicode marker as an empty string.
  - Fix UBSAN warning.
  - Misc compile fixes.
  + utils: pdfseparate: remove extra '%' in error message.
  + build system: configure: Fix typo in disable nss help string.

==== powerdevil5 ====
Version update (5.8.3 -> 5.8.4)

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== python-numpy ====

- Fix cblas handling for SLES 12.

==== python-zope.interface ====
Version update (4.1.2 -> 4.3.1)

- update to 4.3.1:
- Support Components subclasses that are not hashable.
  (https://github.com/zopefoundation/zope.interface/issues/53)
- Add the ability to sort the objects returned by ``implementedBy``.
  This is compatible with the way interface classes sort so they can
  be used together in ordered containers like BTrees.
  (https://github.com/zopefoundation/zope.interface/issues/42)
- Make ``setuptools`` a hard dependency of ``setup.py``.
- Change a linear algorithm (O(n)) in ``Components.registerUtility`` and
  ``Components.unregisterUtility`` into a dictionary lookup (O(1)) for
  hashable components. This substantially improves the time taken to
  manipulate utilities in large registries at the cost of some
  additional memory usage. (https://github.com/zopefoundation/zope.interface/issues/46)

==== rpcbind ====

- Add 0012-Move-default-state-dir-to-a-subdirectory-of-var-run.patch
  from upstream, replacing systemd tmpfile solution.

==== scons ====
Version update (2.5.0 -> 2.5.1)

- SCons 2.5.1:
  * Add scons-configure-cache.py to packaging. It was omitted
  * Use memoization to optimize PATH evaluation across all
    dependencies per node

==== systemsettings5 ====
Version update (5.8.3 -> 5.8.4)
Subpackages: systemsettings5-devel

- Update to 5.8.4
  * New bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.8.4.php

==== virtualbox ====
Version update (5.1.8_k4.8.10_1 -> 5.1.10_k4.8.10_1)
Subpackages: virtualbox-guest-kmp-default virtualbox-guest-tools virtualbox-guest-x11

- Version bump to 5.1.10 (released 2016-11-21 by Oracle)
  This is a maintenance release. The following items were fixed and/or added:
    GUI: the USB filter settings dialog should allow to specify the USB revision in hexadecimal format (bug #15400)
    GUI: fixed crash on certain hosts when pressing certain key combinations (Windows hosts only; bug #15719)
    GUI: fixed issue with updating the available-geometry on host-screen work-area resize
    GUI: don't crash / hang on certain environments if accessibility support is enabled
    GUI: fixed various issues in Unscaled HiDPI Output mode (bug #15707)
    GUI: extend the VM Input menu with Print Screen-related actions
    GUI: improved handling of inserting the Guest Additions ISO image by trying all available optical drives rather than only the first one and by not asking the user if he wants to force unmounting (which doesn't work in most cases anyway)
    API: default to RTC using UTC for Solaris 11 guests
    Settings: be less restrictive when reading a VM configuration containing a host-only adapter without an interface name
    Storage: fixed resizing VDI images resulting in an unbootable image under certain circumstances (bug #15983)
    NAT: fixed several 5.1.8 regressions on Mac OS X and Windows hosts (bug #16084)
    Audio: fixed a few 5.1.x regressions by using the audio code from 5.0.x until the audio overhaul is completed
    VBoxManage: fixed documentation of the storagectl command (bug #15971)
    Build system: another fix for building VirtualBox on systems which default to Python 3
    Windows hosts: hardening fix for Windows 10 build 14971 (bug #16202)
    Windows Additions: properly start the VirtualBox guest services even if the guest user name contains special characters (bug #15982)
    Solaris Additions: fixed preemptible mouse notification callback being executed under a spinlock for Solaris guests
    Linux hosts / guests: Linux 4.9 fixes (bugs #16155 and #16064)
    Linux Additions: fixed Linux kernel module override rule (thanks Mark Furneaux)

==== xf86-input-joystick ====
Version update (1.6.2 -> 1.6.3)

- Update to version 1.6.3:
  This release supports the X server 1.19.

==== xf86-input-keyboard ====
Version update (1.8.1 -> 1.9.0)

- Update to version 1.9.0:
  This release supports the X server 1.19
- Remove upstream patch U_Use-xf86AddEnabledDevice-with-threaded-input.patch

==== xf86-input-mouse ====
Version update (1.9.1 -> 1.9.2)

- Update to version 1.9.2:
  This release supports the X server 1.19.

==== xf86-input-synaptics ====
Version update (1.8.3 -> 1.9.0)

- Update to version 1.9.0:
  This release supports the X server 1.19.
- Update to version 1.8.99.2:
  + Remove upstream patch U_conf-rename-to-70-synaptics.conf.patch
  + Adapt n_xf86-input-synaptics-wait.diff

==== xf86-video-amdgpu ====
Version update (1.1.2 -> 1.2.0)

- update to 1.2.0
  * Use pAMDGPUEnt to find both screens of a GPU in amdgpu_mode_hotplug
  * Refactor amdgpu_mode_hotplug
  * Check Xorg version at runtime instead of build time in two places
  * Require xserver 1.10 or newer
  * present: Check tiling info for flips
  * Consume all available udev events at once
  * PRIME: Fix swapping of provider sink / source capabilities
  * Always call PixmapStopDirtyTracking in drmmode_set_scanout_pixmap
  * Don't rely on randr_crtc->scanout_pixmap in drmmode_set_scanout_pixmap
  * Say?nara, AM_MAINTAINER_MODE!
  * Order unique chipsets according to first appearance in ati_pciids.csv
  * Enable HW cursor support with PRIME slave output & Xorg > 1.18.99.901
  * Rotate and reflect cursor hotspot position for drmModeSetCursor2
  * Add support for ScreenPtr::SyncSharedPixmap
  * Untangle HAS_XORG_CONF_DIR / --with-xorg-conf-dir lines in configure.ac

==== xf86-video-ati ====
Version update (7.7.1 -> 7.8.0)

- Update to version 7.8.0:
  This release supports xserver versions 1.10-1.19.
  Highlights:
  + Significant 2D compositing performance increase, in particular with
    glamor enabled.
  + Option "TearFree" can now prevent tearing in all possible display
    configurations (with current versions of Xorg). Specifically, it's
    now also effective with arbitrary RandR transforms and with RandR 1.4
    slave output.
  + DRI3 is now enabled by default if the Xorg version is >= 1.18.3 and
    glamor is enabled.
  + DRI3/Present asynchronous page flips are now supported (requires
    corresponding kernel driver support, available in current versions of
    the Linux kernel). This can increase performance of fullscreen
    applications with sync-to-vblank disabled.
  + The HW cursor can now be used with RandR 1.4 slave output or with
    TearFree & rotation.
  + Performance improvements with RandR 1.4 slave output.
  + The list of supported GPUs in the Xorg log file has been slightly
    tidied up.
  + RandR 1.4 provider capabilities are now advertised more accurately.
- Remove upstream patches:
  + U_01-dri3-Return-NULL-from-radeon_dri3_pixmap_from_fd-if-calloc-fails.patch
  + U_02-Add-support-for-async-flips-to-radeon_do_pageflip.patch
  + U_03-present-Support-async-flips.patch
  + U_04-Enable-DRI3-by-default-when-building-for-Xorg-1.18.3.patch
  + U_05-EXA-6xx-7xx-fast-solid-pixmap-support.patch
  + U_06-EXA-6xx-7xx-accelerate-PictOpOver-with-component-alpha.patch
  + U_07-Adapt-to-XF86_CRTC_VERSION-7.patch
  + U_08-Add-explicit-RADEON_DRM_QUEUE_ERROR-define.patch
  + U_09-Don-t-enable-DRI3-by-default-with-EXA.patch
  + U_10-Use-EventCallback-to-avoid-flushing-every-time-in-the-FlushCallback.patch
  + U_11-Keep-track-of-damage-event-related-flushes-per-client-v2.patch
  + U_12-Use-drmmode_crtc_scanout_-helpers-for-RandR-1.4-scanout-pixmaps.patch
  + U_13-Handle-RandR-1.4-slave-dirty-updates-via-radeon_drm_queue.patch
  + U_14-Track-damage-accurately-for-RandR-1.4-slave-scanout.patch
  + U_15-Fix-build-against-xserver-1.13.patch
  + U_16-Only-copy-from-screen-pixmap-to-shared-pixmap-on-demand-for-slave-scanout.patch
  + U_17-Factor-out-transform_region-helper.patch
  + U_18-Move-up-radeon_scanout_extents_intersect.patch
  + U_19-Synchronize-scanout-pixmaps-for-TearFree.patch
  + U_20-Make-TearFree-effective-with-PRIME-slave-scanout.patch
  + U_21-Refactor-radeon_mode_hotplug.patch
  + U_22-Use-pRADEONEnt-to-find-both-screens-of-a-GPU-in-radeon_mode_hotplug.patch

==== xf86-video-vmware ====
Version update (13.1.0 -> 13.2.1)

- Update to version 13.2.1:
  This release provides support for adapting to a desktop configuration (read
  VMware GUI configuration) exposed using drm connectors rather than using
  RandR12+. Since this is the way gnome-shell/Wayland adapts to a desktop
  configuration this driver can coexist with an auto-fit multimonitor VMware
  gnome-shell/Wayland configuration and therefore enables future open-vm-tools
  versions to expose GUI configuration changes through drm connectors at system
  start-up time without using the xorg driver as a proxy.
  It also contains a compilation fix for ABI 23 (Xserver 1.19).

==== xterm ====
Version update (326 -> 327)
Subpackages: xterm-bin

- Patch #327 - 2016/10/07
  * add a check in the function which handles end-of-line
  wrapping to ensure that C1 controls are allocated one column
  when allowC1Printable is set (Debian #738794).
  * use consistent error-checking after strtol calls, fixes a
  case where a query with OSC 6 did not ensure there was a
  valid color number (report by Alex Smith).
  * add -baudrate option, for testing ncurses.
  * always generate the CASE_xxx symbols in VTparse.h and
  Tekparse.h, as part of a change to improve debug-logging.
  This makes the build always depend upon awk.
  * modify allowC1Printable to disallow codes 160-254 as being
  equivalent to codes 32-126 when parsing escape sequences
  (Debian #839220).
  * amend fix from patch #326 for TrueType fonts to exclude the
  hidden character used for double-width cells (report by Grady
  Martin).
  * fix a typo in ctlseqs.ms

==== yast2 ====
Version update (3.2.5 -> 3.2.6)

- Fix replacement of workflow modules (bsc#1011869)
- 3.2.6

==== yast2-country ====
Version update (3.2.1 -> 3.2.2)
Subpackages: yast2-country-data

- Language has not been set. Taking language from zypp.
  But libzypp can also returns languages which we do not support
  (e.g. default "en"). So we are checking and changing it to
  default if needed (without showing an error (bnc#1009508))
- 3.2.2

==== yast2-dns-server ====
Version update (3.1.24 -> 3.2.0)

- Remove dead code regarding help messages (bsc#1012048)
- 3.2.0

==== yast2-network ====
Version update (3.2.9 -> 3.2.11)

- Do not crash when removing an entry from the /etc/hosts file
  (bsc#1010994)
- 3.2.11
- do not crash when on command line is passed non-number id
  (bsc#1003908)
- 3.2.10

==== zypper ====
Version update (1.13.13 -> 1.13.14)
Subpackages: zypper-aptitude zypper-log

- Properly escape patch script output in xml mode (bsc#1010712)
- version 1.13.14

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Removal of several KDE *-lang packages (was: New Tumbleweed snapshot 20161125 released!)

Christian Boltz-5
Hello,

Am Sonntag, 27. November 2016 schrieb Dominique Leuenberger:
> Packages changed:
[lots of kde / plasma packages updated to 5.8.4]

zypper dup proposes to remove 26 *-lang packages (see below), while not
adding any package that would replace them.

I had a similar proposal some weeks ago (I don't remember exactly, but
I'd guess it was the previous plasma update), and after accepting it,
for example KMail ended up as a wild mix of english and german.
Re-installing the *-lang packages fixed it (and didn't cause any warnings
or file conflicts), so I'm a bit worried about the proposal to remove
them again.

So - is the removal of those *-lang packages expected or will I end up
with a half-translated KDE again?


The full zypper output is:

# zypper dup
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories
are compatible before you continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

The following 2035 items are locked and will not be changed by any action:
 Available:
  ColPack-devel-32bit DirectFB-devel-32bit ImageMagick-devel-32bit Mesa-32bit Mesa-libEGL-devel-32bit Mesa-libEGL1-32bit Mesa-libGL-devel-32bit
  Mesa-libGL1-32bit Mesa-libGLESv1_CM-devel-32bit Mesa-libGLESv1_CM1-32bit Mesa-libGLESv2-2-32bit Mesa-libGLESv2-devel-32bit
  Mesa-libOpenCL-32bit Mesa-libd3d-32bit Mesa-libd3d-devel-32bit Mesa-libglapi-devel-32bit Mesa-libglapi0-32bit NetworkManager-devel-32bit
  VirtualGL-32bit aalib-devel-32bit adolc-devel-32bit allegro-dga2-plugin-32bit allegro-jack-plugin-32bit alsa-devel-32bit
  alsa-oss-32bit alsa-plugins-32bit alsa-plugins-jack-32bit alsa-plugins-maemo-32bit alsa-plugins-pulse-32bit alsa-plugins-samplerate-32bit
  anthy-32bit appmenu-qt5-32bit apulse-32bit armadillo-devel-32bit arpack-ng-devel-32bit arts-32bit at-spi2-core-devel-32bit
  atk-devel-32bit atkmm-devel-32bit attica-qt5-devel-32bit audiofile-devel-32bit audit-devel-32bit augeas-devel-32bit avogadro-devel-32bit
  bind-devel-32bit binutils-devel-32bit bison-32bit blas-devel-32bit bluez-devel-32bit boost_1_62-devel-32bit cairo-devel-32bit
  cairomm-devel-32bit canna-libs-32bit capi4linux-32bit capi4linux-devel-32bit cblas-devel-32bit cg-32bit chmlib-devel-32bit
  clang3_8-devel-32bit cracklib-devel-32bit cryptconfig-32bit cups-devel-32bit cups-libs-32bit cyrus-sasl-32bit cyrus-sasl-crammd5-32bit
  cyrus-sasl-devel-32bit cyrus-sasl-digestmd5-32bit cyrus-sasl-gssapi-32bit cyrus-sasl-ldap-auxprop-32bit cyrus-sasl-otp-32bit
  cyrus-sasl-plain-32bit cyrus-sasl-sqlauxprop-32bit dante-devel-32bit dapl-devel-32bit dbus-1-devel-32bit dbus-1-glib-32bit
  dbus-1-glib-devel-32bit dbus-1-qt3-32bit device-mapper-devel-32bit dirac-devel-32bit ecryptfs-utils-32bit ecryptfs-utils-devel-32bit
  enchant-voikko-32bit enchant-zemberek-32bit evolution-data-server-32bit f2c-32bit fcitx-gtk2-32bit fcitx-gtk3-32bit fcitx-qt4-32bit
  fcitx-qt5-32bit file-devel-32bit flac-devel-32bit flex-32bit fltk-devel-32bit fontconfig-32bit fontconfig-devel-32bit fprintd-pam-32bit
  frameworkintegration-devel-32bit frameworkintegration-plugin-32bit freeglut-devel-32bit ... and 1935 more items.
 Run 'zypper locks -s' to see the complete list of locked items.

The following NEW package is going to be installed:
  kdoctools-lang

The following application is going to be REMOVED:
  "KDE Plasma Desktop"

The following 26 packages are going to be REMOVED:
  bluedevil5-lang breeze5-style-lang gpg2-lang kcm_sddm-lang kde-cli-tools5-lang kde-gtk-config5-lang kgamma5-lang khotkeys5-lang
  kinfocenter5-lang kmenuedit5-lang kscreen5-lang kscreenlocker-lang ksshaskpass5-lang ksysguard5-lang kwin5-lang libgphoto2-6-lang
  libksysguard5-lang milou5-lang plasma-nm5-lang plasma5-addons-lang plasma5-desktop-lang plasma5-pa-lang plasma5-workspace-lang
  polkit-kde-agent-5-lang powerdevil5-lang systemsettings5-lang

The following 60 packages are going to be upgraded:
  apache2-mod_apparmor apparmor-abstractions apparmor-docs apparmor-parser apparmor-parser-lang apparmor-utils bluedevil5 breeze
  breeze5-style bundle-lang-common-de bundle-lang-common-en bundle-lang-kde-de bundle-lang-kde-en gpg2 inkscape-lang kactivitymanagerd
  kactivitymanagerd-lang kcm_sddm kde-cli-tools5 kde-gtk-config5 kde-user-manager kde-user-manager-lang kgamma5 khotkeys5 kinfocenter5
  kmenuedit5 kscreen5 kscreenlocker ksshaskpass5 ksysguard5 kwallet-tools-lang kwalletd5-lang kwin5 libapparmor-devel libapparmor1
  libgphoto2-6 libksysguard5 milou5 patch2mail perl-MIME-EncWords perl-apparmor php5-ZendFramework plasma-nm5 plasma-nm5-openvpn
  plasma-nm5-pptp plasma-nm5-vpnc plasma5-addons plasma5-desktop plasma5-integration-plugin plasma5-integration-plugin-lang plasma5-pa
  plasma5-session plasma5-workspace plasma5-workspace-branding-openSUSE plasma5-workspace-libs polkit-kde-agent-5 postfixadmin
  powerdevil5 python3-apparmor systemsettings5

The following package is going to be downgraded:
  apparmor-profiles

The following 2 packages are going to be reinstalled:
  squirrelmail-beta squirrelmail-beta-lang

The following 14 packages are going to change vendor:
  apache2-mod_apparmor   openSUSE -> obs://build.opensuse.org/home:cboltz            
  apparmor-abstractions  openSUSE -> obs://build.opensuse.org/home:cboltz            
  apparmor-docs          openSUSE -> obs://build.opensuse.org/home:cboltz            
  apparmor-parser        openSUSE -> obs://build.opensuse.org/home:cboltz            
  apparmor-parser-lang   openSUSE -> obs://build.opensuse.org/home:cboltz            
  apparmor-utils         openSUSE -> obs://build.opensuse.org/home:cboltz            
  libapparmor-devel      openSUSE -> obs://build.opensuse.org/home:cboltz            
  libapparmor1           openSUSE -> obs://build.opensuse.org/home:cboltz            
  patch2mail             openSUSE -> obs://build.opensuse.org/home:cboltz            
  perl-MIME-EncWords     openSUSE -> obs://build.opensuse.org/home:cboltz            
  perl-apparmor          openSUSE -> obs://build.opensuse.org/home:cboltz            
  php5-ZendFramework     openSUSE -> obs://build.opensuse.org/server:php:applications
  postfixadmin           openSUSE -> obs://build.opensuse.org/home:cboltz            
  python3-apparmor       openSUSE -> obs://build.opensuse.org/home:cboltz            


60 packages to upgrade, 1 to downgrade, 1 new, 2 to reinstall, 26 to remove, 14  to change vendor.
Overall download size: 51.4 MiB. Already cached: 0 B. After the operation, 65.2 MiB will be freed.


Notes:
- I have a lock on *-32bit to keep those packages out, so the locked
  items are expected (actually 78 *-32bit packages would be installed,
  but zypper seems to count _all_ packages matching a lock instead of
  only those that would be installed, changed or removed)
- my home repo would cause some vendor changes for the packages living
  there, also not a surprise
- when using "zypper up" instead of "zypper dup", I get a similar result
  for the *-lang packages


Regards,

Christian Boltz
--
<dragotin> yes, so whenever you have the feeling a booster is disturbing
your work, beat him up and than tell me and I do it even harder
<dragotin> ...except if its me ;_)
<suseROCKs> dragotin,   you hae to promise to videotape that!
[from #opensuse-project]

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Removal of several KDE *-lang packages

opensuse.lietuviu.kalba
I suggest, that *-lang packages replaced by these packages:
> bundle-lang-common-de bundle-lang-common-en bundle-lang-kde-de bundle-lang-kde-en


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]