Missing the obvious - pkgconfig(libyara) not working?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing the obvious - pkgconfig(libyara) not working?

gregfreemyer
I guess I need someone to hit me with a cluestick.

I have libyara3-3.5.0  in this package:
https://build.opensuse.org/package/show/home:gregfreemyer:Tools-for-forensic-boot-cd/yara

I'm trying to build the python bindings for it in:
https://build.opensuse.org/package/show/home:gregfreemyer:Tools-for-forensic-boot-cd/python-yara

I'm trying to use:
BuildRequires:    pkgconfig(libyara) = %{version}

In the bindings package, but I'm being told "nothing provides
pkgconfig(libyara) = 3.5.0"

Thanks
Greg
--
Greg Freemyer
Upset at the Hillary/Trump choice
So are Utah voters, Evan McMullin is leading there among voters age 25-34
Vote Evan McMullin for President
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Missing the obvious - pkgconfig(libyara) not working?

Cristian Rodríguez-2
On Fri, Sep 30, 2016 at 8:43 PM, Greg Freemyer <[hidden email]> wrote:

> In the bindings package, but I'm being told "nothing provides
> pkgconfig(libyara) = 3.5.0"

As expected.. ;)

pkgconfig(libyara) is not provided..  pkgconfig(yara)  is.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Missing the obvious - pkgconfig(libyara) not working?

gregfreemyer
Thanks.  That is exactly the clue stick I needed.  Thanks for not
hitting me around the head and shoulders with it.

Greg
--
Greg Freemyer
Upset at the Hillary/Trump choice
So are Utah voters, Evan McMullin is leading there among voters age 25-34
Vote Evan McMullin for President


On Fri, Sep 30, 2016 at 8:12 PM, Cristian Rodríguez
<[hidden email]> wrote:
> On Fri, Sep 30, 2016 at 8:43 PM, Greg Freemyer <[hidden email]> wrote:
>
>> In the bindings package, but I'm being told "nothing provides
>> pkgconfig(libyara) = 3.5.0"
>
> As expected.. ;)
>
> pkgconfig(libyara) is not provided..  pkgconfig(yara)  is.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]