Missing Ruby dependency

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing Ruby dependency

Axel Braun-2
Hi,

I ran into problems with one nodejs package using nodejs-packaging.
https://build.opensuse.org/package/show/Application:ERP:Tryton:4.2/tryton-sao

It cant resolve the requirement
rubygem(ruby:2.1.0:mini_portile2:2.2) >= 2.2 needed by ruby2.1-rubygem-
nokogiri

I find a rubygem-mini_portile  e.g. in Factory but this is Version 0.6.2....

Any idea where to look for?
Thanks
Axel
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Missing Ruby dependency

Oliver Kurz-2
On Tuesday, 11 July 2017 17:35:11 CEST Axel Braun wrote:

> Hi,
>
> I ran into problems with one nodejs package using nodejs-packaging.
> https://build.opensuse.org/package/show/Application:ERP:Tryton:4.2/tryton-sa
> o
>
> It cant resolve the requirement
> rubygem(ruby:2.1.0:mini_portile2:2.2) >= 2.2 needed by ruby2.1-rubygem-
> nokogiri
>
> I find a rubygem-mini_portile  e.g. in Factory but this is Version 0.6.2....
>
> Any idea where to look for?

This package links to the project
https://build.opensuse.org/project/show/devel:languages:ruby:extensions
so I guess you can look there to update the package or ask someone to do it.

Btw,
https://build.opensuse.org/project/show/devel:languages:nodejs
is the development project for nodejs packages.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Missing Ruby dependency

Jordi Massaguer Pla-2
In reply to this post by Axel Braun-2


On 07/11/2017 05:35 PM, Axel Braun wrote:

> Hi,
>
> I ran into problems with one nodejs package using nodejs-packaging.
> https://build.opensuse.org/package/show/Application:ERP:Tryton:4.2/tryton-sao
>
> It cant resolve the requirement
> rubygem(ruby:2.1.0:mini_portile2:2.2) >= 2.2 needed by ruby2.1-rubygem-
> nokogiri
>
> I find a rubygem-mini_portile  e.g. in Factory but this is Version 0.6.2....

The package you want is rubygem-mini_portile2 which contains 2.2.0 . You
can find this package in Factory and in devel:languages:ruby:extensions.
Factory builds for ruby2.2 and newer, so I guess you need the one from
d:l:r:e

regards

jordi

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]