Mageia:Cauldron prjconf needs updating (unresolvables everywhere!)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Mageia:Cauldron prjconf needs updating (unresolvables everywhere!)

Neal Gompa
Hey,

I'm seeing a lot of unresolvable states here...

Mageia Cauldron on i586:

have choice for devel(libcrypto) needed by librpm-devel:
libcompat-openssl10-devel libopenssl-devel, have choice for
devel(liblua) needed by librpm-devel: liblua-devel liblua5.1-devel
liblua5.3-devel

Mageia Cauldron on x86_64:

have choice for devel(libcrypto) needed by lib64rpm-devel:
lib64compat-openssl10-devel lib64openssl-devel, nothing provides
lib64bzip2_1, nothing provides lib64icu58


The following is needed for openssl:

%ifarch x86_64
Prefer: lib64openssl-devel
%else
Prefer: libopenssl-devel
%endif


As for the librpm lua thing, it should Prefer: liblua-devel

For the bzip2 and icu breakages, the libraries are now:

i586: libbz2_1 libicu59
x86_64: lib64bz2_1 lib64icu59

Could these adjustments be made?

Thanks in advance.


--
真実はいつも一つ!/ Always, there's only one truth!
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]