Lots of OpenGL errors in Chrome/Chromium since today

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Lots of OpenGL errors in Chrome/Chromium since today

Aaron Digulla
Hi Everyone,

After updating security patches and rebooting, I get a ton of OpenGL
related errors in Google Chrome 64 and Chromium 63.

Since two versions of the browser are affected, I assume that one of
these updates caused that but I don't see which change could have cause
this.

The errors look like this:

[5649:5649:0203/130206.305780:ERROR:gles2_cmd_decoder.cc(16370)]
Offscreen context lost via ARB/EXT_robustness. Reset status =
GL_GUILTY_CONTEXT_RESET_KHR
[5649:5649:0203/130206.305817:ERROR:gles2_cmd_decoder.cc(4482)]  
GLES2DecoderImpl: Context reset detected after MakeCurrent.
[5649:5649:0203/130206.305833:ERROR:gpu_channel_manager.cc(200)] Exiting
GPU process because some drivers cannot recover from problems.
[5649:5649:0203/130206.305887:ERROR:gpu_channel_manager.cc(200)] Exiting
GPU process because some drivers cannot recover from problems.
[4101:4101:0203/130206.378644:ERROR:gpu_process_transport_factory.cc(1009)]
Lost UI shared context.

[5471:5471:0203/130043.486187:ERROR:gles2_cmd_decoder.cc(10008)]
[.DisplayCompositor-0xadb5491a00]RENDER WARNING: texture bound to
texture unit 0 is not renderable. It maybe non-power-of-2 and have
incompatible texture filtering.
[5471:5471:0203/130043.486218:ERROR:gles2_cmd_decoder.cc(18162)]
[.DisplayCompositor-0xadb5491a00]GL ERROR :GL_INVALID_OPERATION :
glCreateAndConsumeTextureCHROMIUM: invalid mailbox name

What I am seeing since the last reboot is a lot of errors like this:

NVRM: Xid (PCI:0000:01:00): 8, Channel 00000008

and once, I saw this:

NVRM: Xid (PCI:0000:01:00): 31, Ch 00000001, engmask 00000101, intr 10000000

The error codes (8 and 31) indicate user program errors
(https://docs.nvidia.com/deploy/xid-errors/).

Any ideas? Anyone else get these (try to start google-chrome in a
terminal window to see the messages or use journalctl -b)?

As far as I can tell, the NVIDIA drivers haven't changed since two
weeks. The only relevant change seems to be a new version of Google Chrome:

exfat-utils-1.2.7-5.2.x86_64                  Sa 03 Feb 2018 11:26:34 CET
fpm2-0.79-5.6.x86_64                          Sa 03 Feb 2018 11:26:34 CET
fuse-exfat-1.2.7-6.2.x86_64                   Sa 03 Feb 2018 11:26:35 CET
gd-2.1.0-24.1.x86_64                          Sa 03 Feb 2018 11:26:35 CET
gd-32bit-2.1.0-24.1.x86_64                    Sa 03 Feb 2018 11:26:35 CET
google-chrome-stable-64.0.3282.140-1.x86_64   Sa 03 Feb 2018 11:26:33 CET
gpg-pubkey-aa3e7f5e-5a4e2e3e                  Sa 03 Feb 2018 11:58:23 CET
handbrake-cli-1.0.7-3.17.x86_64               Sa 03 Feb 2018 11:26:34 CET
handbrake-gtk-1.0.7-3.17.x86_64               Sa 03 Feb 2018 11:26:34 CET
kpartx-0.7.1+71+suse.632dbce970c0-6.1.x86_64  Sa 03 Feb 2018 11:26:35 CET
libjavascriptcoregtk-4_0-18-2.18.5-8.1.x86_64 Sa 03 Feb 2018 11:26:35 CET
libre2-0-20180101-9.1.x86_64                  Sa 03 Feb 2018 11:26:35 CET
libsystemd0-228-41.1.x86_64                   Sa 03 Feb 2018 11:26:36 CET
libsystemd0-32bit-228-41.1.x86_64             Sa 03 Feb 2018 11:26:36 CET
libudev1-228-41.1.x86_64                      Sa 03 Feb 2018 11:26:36 CET
libudev1-32bit-228-41.1.x86_64                Sa 03 Feb 2018 11:26:36 CET
libwebkit2gtk-4_0-37-2.18.5-8.1.x86_64        Sa 03 Feb 2018 11:26:37 CET
libwebkit2gtk3-lang-2.18.5-8.1.noarch         Sa 03 Feb 2018 11:26:39 CET
logrotate-3.11.0-15.2.x86_64                  Sa 03 Feb 2018 11:26:39 CET
systemd-228-41.1.x86_64                       Sa 03 Feb 2018 11:26:38 CET
systemd-32bit-228-41.1.x86_64                 Sa 03 Feb 2018 11:26:36 CET
systemd-bash-completion-228-41.1.noarch       Sa 03 Feb 2018 11:26:36 CET
systemd-logger-228-41.1.x86_64                Sa 03 Feb 2018 11:26:39 CET
systemd-sysvinit-228-41.1.x86_64              Sa 03 Feb 2018 11:26:39 CET
udev-228-41.1.x86_64                          Sa 03 Feb 2018 11:26:38 CET
webkit2gtk-4_0-injected-bundles-2.18.5-8.1.x86_64 Sa 03 Feb 2018
11:26:38 CET
youtube-dl-2018.01.27-1.2.noarch              Sa 03 Feb 2018 11:26:34 CET

(unless they started to use libwebkit2gtk to render ...).

Regards,

--
Aaron "Optimizer" Digulla a.k.a. Philmann Dark
"It's not the universe that's limited, it's our imagination.
Follow me and I'll show you something beyond the limits."
http://blog.pdark.de/


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Lots of OpenGL errors in Chrome/Chromium since today [SOLVED]

Aaron Digulla
Am 03.02.2018 um 15:44 schrieb Aaron Digulla:
> What I am seeing since the last reboot is a lot of errors like this:
>
> NVRM: Xid (PCI:0000:01:00): 8, Channel 00000008
>
> and once, I saw this:
>
> NVRM: Xid (PCI:0000:01:00): 31, Ch 00000001, engmask 00000101, intr 10000000
These disappeared after a reboot. Everything now works again. Weird.

Regards,

--
Aaron "Optimizer" Digulla a.k.a. Philmann Dark
"It's not the universe that's limited, it's our imagination.
Follow me and I'll show you something beyond the limits."
http://blog.pdark.de/


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]