Leap: provider krb5 is conflicted by installed krb5-mini

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Leap: provider krb5 is conflicted by installed krb5-mini

Olaf Hering-2
Since end of last week one pkg in external buildservice is in state
unresolvable for Leap 42.1 and 42.2:

unresolvable: conflict for provider of krb5 needed by samba-libs
      (provider krb5 is conflicted by installed krb5-mini)

samba-libs links against krb5.
pkgA links against samba-libs, this one builds fine.
pkgB has pkgA in BuildRequires and it is now in state unresolvable.

Its unclear why this happens now, samba links to krb5 since forever, and
pkgA links to samba-libs also since a very long time. There is nothing
obvious in prjconf and its history.

Any idea what the reason could be?


Olaf

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Leap: provider krb5 is conflicted by installed krb5-mini

Olaf Hering-2
Am Mon, 13 Feb 2017 16:56:55 +0100
schrieb Olaf Hering <[hidden email]>:

> Since end of last week one pkg in external buildservice is in state
> unresolvable for Leap 42.1 and 42.2:
>
> unresolvable: conflict for provider of krb5 needed by samba-libs
>       (provider krb5 is conflicted by installed krb5-mini)

Why does that happen only for one pkg in the same project, but not for
others?

This one works:
BuildRequires:  fdupes
BuildRequires:  gcc-c++
BuildRequires:  gnome-common
BuildRequires:  gstreamer-0_10-devel
BuildRequires:  gstreamer-0_10-plugins-base-devel
BuildRequires:  intltool
BuildRequires:  update-desktop-files
BuildRequires:  pkgconfig(dbus-glib-1)
BuildRequires:  pkgconfig(gconfmm-2.6)
BuildRequires:  pkgconfig(giomm-2.4)
BuildRequires:  pkgconfig(gthread-2.0)
BuildRequires:  pkgconfig(gtkmm-2.4)
BuildRequires:  pkgconfig(libvlc)
BuildRequires:  pkgconfig(libxml++-2.6)
BuildRequires:  pkgconfig(sqlite3)
BuildRequires:  pkgconfig(unique-1.0)


This one does not work:
BuildRequires:  autoconf
BuildRequires:  automake
BuildRequires:  gettext-tools
BuildRequires:  intltool
BuildRequires:  libtool
BuildRequires:  pkg-config
BuildRequires:  pkgconfig(dbus-glib-1) >= 0.74
BuildRequires:  pkgconfig(gio-2.0) >= 2.26.0
BuildRequires:  pkgconfig(glib-2.0) >= 2.26.0
BuildRequires:  pkgconfig(gobject-2.0) >= 2.26.0
BuildRequires:  pkgconfig(gtk+-3.0)
BuildRequires:  pkgconfig(libcurl) >= 7.18
BuildRequires:  pkgconfig(libnotify) >= 0.4
BuildRequires:  pkgconfig(libvlc)
BuildRequires:  pkgconfig(sqlite3) >= 3.4

Removing libvlc, which links to samba, fixes the unsolvable.
Any idea how to debug it?

Olaf

attachment0 (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Leap: provider krb5 is conflicted by installed krb5-mini

Olaf Hering-2
Am Tue, 21 Feb 2017 11:41:46 +0100
schrieb Olaf Hering <[hidden email]>:

> Am Mon, 13 Feb 2017 16:56:55 +0100
> schrieb Olaf Hering <[hidden email]>:
>
> > Since end of last week one pkg in external buildservice is in state
> > unresolvable for Leap 42.1 and 42.2:
> >
> > unresolvable: conflict for provider of krb5 needed by samba-libs
> >       (provider krb5 is conflicted by installed krb5-mini)  

> Any idea how to debug it?

Doing the same in OBS does not show the issue between
curl,samba,vlc,krb5.

Why does one of these buildreq pull in krb5-mini while the others do
not?

Olaf

attachment0 (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Leap: provider krb5 is conflicted by installed krb5-mini

Andreas Schwab
In reply to this post by Olaf Hering-2
On Feb 21 2017, Olaf Hering <[hidden email]> wrote:

> Any idea how to debug it?

Does buildinfo --debug give any clues?

Andreas.

--
Andreas Schwab, [hidden email]
GPG Key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276 4ED5
"And now for something completely different."
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Leap: provider krb5 is conflicted by installed krb5-mini

Olaf Hering-2
On Tue, Feb 21, Andreas Schwab wrote:

> On Feb 21 2017, Olaf Hering <[hidden email]> wrote:
>
> > Any idea how to debug it?
>
> Does buildinfo --debug give any clues?

Not sure what the output means. In one case krb5-mini is prefered due to
curl4, on the other case samba-libs pulls in krb5.

Olaf

x.xz (22K) Download Attachment
y.xz (11K) Download Attachment
signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Leap: provider krb5 is conflicted by installed krb5-mini

Olaf Hering-2
In reply to this post by Olaf Hering-2
On Tue, Feb 21, Olaf Hering wrote:

> Am Mon, 13 Feb 2017 16:56:55 +0100
> schrieb Olaf Hering <[hidden email]>:
>
> > Since end of last week one pkg in external buildservice is in state
> > unresolvable for Leap 42.1 and 42.2:
> >
> > unresolvable: conflict for provider of krb5 needed by samba-libs
> >       (provider krb5 is conflicted by installed krb5-mini)
>
> Why does that happen only for one pkg in the same project, but not for
> others?
Why is "suddenly" this Conflict/Prefer needed to get Leap going?

Conflict: libcurl4:krb5-mini
Prefer: libcurl4:krb5

Olaf

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Leap: provider krb5 is conflicted by installed krb5-mini

Olaf Hering-2
In reply to this post by Olaf Hering-2
On Mon, Feb 13, Olaf Hering wrote:

> Since end of last week one pkg in external buildservice is in state
> unresolvable for Leap 42.1 and 42.2:
>
> unresolvable: conflict for provider of krb5 needed by samba-libs
>       (provider krb5 is conflicted by installed krb5-mini)

The same bug is in 42.3.
Is this the correct way to fix a non-OBS project?

# for freetuxtv. For some reason libcurl+libvlc+samba-libs prefers krb5-mini instead of krb5 in Leap
%if 0%{?suse_version} == 1315
%if 0%{?is_opensuse}
#
%if 0%{?sle_version} == 120200
# Leap 42.2
Conflict: libcurl4:krb5-mini
Prefer: libcurl4:krb5
%endif
#
%if 0%{?sle_version} == 120100
# Leap 42.1
Conflict: libcurl4:krb5-mini
Prefer: libcurl4:krb5
%define _without_xmms2 1
Macros:
%_without_xmms2 1
:Macros
%endif
#
%endif
%endif


Olaf

signature.asc (201 bytes) Download Attachment