Leap 42.2: some data CDs not recognized

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Leap 42.2: some data CDs not recognized

Roland Langner
Hello List,

I'm using a standard Leap 42.2 with K3B from packman. A data CD (only
some photos) burned with K3B was not recognized.
For this CD there was only one action offered "copy with K3B". Action
"Open with data manager" was missing.
Mounting in xterm was possible.
With another data CD I got 3 actions, "download with digiKam", "open
with data manager" and "copy with K3B".
The difference between the 2 CDs was that the first one was a
multisession data CD with unclosed session and the second one was a
single session CD.
It seems that K3B burns multisession by default. Anyway, KDE Plasma
should recognize also unclosed multisession data CDs.
With OpenSuse 13.2 it did. Maybe a bug?

Greetings
Roland
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Leap 42.2: some data CDs not recognized

Martin Schlander
tirsdag den 2. maj 2017 18.05.41 CEST skrev Roland Langner:

> I'm using a standard Leap 42.2 with K3B from packman. A data CD (only
> some photos) burned with K3B was not recognized.
> For this CD there was only one action offered "copy with K3B". Action
> "Open with data manager" was missing.
> Mounting in xterm was possible.
> With another data CD I got 3 actions, "download with digiKam", "open
> with data manager" and "copy with K3B".
> The difference between the 2 CDs was that the first one was a
> multisession data CD with unclosed session and the second one was a
> single session CD.
> It seems that K3B burns multisession by default. Anyway, KDE Plasma
> should recognize also unclosed multisession data CDs.
> With OpenSuse 13.2 it did. Maybe a bug?

Just today the K3b maintainer requested help with testing a multisession
related bug. Maybe it's related to your problem and you can help.

https://mail.kde.org/pipermail/release-team/2017-May/010269.html

I didn't look into it too deeply, so maybe it's completely unrelated.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Leap 42.2: some data CDs not recognized

Wolfgang Bauer
In reply to this post by Roland Langner
Am Dienstag, 2. Mai 2017, 18:05:41 schrieb Roland Langner:
> It seems that K3B burns multisession by default. Anyway, KDE Plasma
> should recognize also unclosed multisession data CDs.
> With OpenSuse 13.2 it did. Maybe a bug?

Plasma doesn't "detect" data CDs by itself, it uses udisks2 for this which in
turn uses other lower level things.

Your problem may be related to
https://bugzilla.opensuse.org/show_bug.cgi?id=1020034.
You could try to install the fixed libblkid1 package mentioned there.

Or, you could also try to install libblkid1 from openSUSE 13.2, as you say it
worked there.

Btw, there's also https://bugzilla.opensuse.org/show_bug.cgi?id=1034470 which
may be related to the above one or not, and/or might be more similar to your
particular problem.

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Leap 42.2: some data CDs not recognized

Roland Langner
> Am Dienstag, 2. Mai 2017, 18:05:41 schrieb Roland Langner:
>> It seems that K3B burns multisession by default. Anyway, KDE Plasma
>> should recognize also unclosed multisession data CDs.
>> With OpenSuse 13.2 it did. Maybe a bug?
> Plasma doesn't "detect" data CDs by itself, it uses udisks2 for this which in
> turn uses other lower level things.
>
> Your problem may be related to
> https://bugzilla.opensuse.org/show_bug.cgi?id=1020034.
> You could try to install the fixed libblkid1 package mentioned there.
>
> Or, you could also try to install libblkid1 from openSUSE 13.2, as you say it
> worked there.
>
> Btw, there's also https://bugzilla.opensuse.org/show_bug.cgi?id=1034470 which
> may be related to the above one or not, and/or might be more similar to your
> particular problem.
>
> Kind Regards,
> Wolfgang
>
Hi Wolfgang,

Many Thanks!
The fist link https://bugzilla.opensuse.org/show_bug.cgi?id=1020034 was
very helpful.
In the conversation I found the hint to install
libblkid1-2.28-12.6.1.x86_64.rpm and
libblkid-devel-2.28-12.6.1.x86_64.rpm
from<http://download.opensuse.org/repositories/home:/wolfi323:/branches:/OBS_Maintained:/util-linux/openSUSE_Leap_42.2_Update>
<http://download.opensuse.org/repositories/home:/wolfi323:/branches:/OBS_Maintained:/util-linux/openSUSE_Leap_42.2_Update>http://download.opensuse.org/repositories/home:/wolfi323:/branches:/OBS_Maintained:/util-linux/openSUSE_Leap_42.2_Update
Now the CD is recognized correctly.

Regards
Roland

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Loading...