Leap 15.0 Build 115.1 released!

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Leap 15.0 Build 115.1 released!

Ludwig Nussel

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&version=15.0&build=115.1&groupid=50
https://bugzilla.opensuse.org/buglist.cgi?product=openSUSE%20Distribution&query_format=advanced&resolution=---&version=Leap%2015.0

When you reply to discuss some issues, make sure to change the subject.
Please use the test plan at
https://docs.google.com/spreadsheets/d/1AGKijKpKiJCB616-bHVoNQuhWHpQLHPWCb3m1p6gXPc/edit#gid=168760829
to record your testing efforts and use bugzilla to report bugs.

Packages changed:
  ImageMagick (7.0.7.15 -> 7.0.7.21)
  Mesa (17.3.2 -> 17.3.3)
  Mesa-drivers (17.3.2 -> 17.3.3)
  ModemManager (1.6.8 -> 1.6.12)
  MozillaFirefox (52.5.2 -> 52.6)
  NetworkManager-applet
  SUSEConnect (0.3.3 -> 0.3.7)
  SuSEfirewall2 (3.6.376 -> 3.6.378)
  analitza (17.12.0 -> 17.12.1)
  apparmor
  audacity
  autoyast2 (4.0.20 -> 4.0.24)
  blinken (17.12.0 -> 17.12.1)
  bluez (5.47 -> 5.48)
  bovo (17.12.0 -> 17.12.1)
  brltty
  btrfsmaintenance (0.3.1 -> 0.4)
  btrfsprogs (4.13.3 -> 4.14.1)
  cairo (1.15.8 -> 1.15.10)
  coreutils (8.28 -> 8.29)
  corosync
  dpdk
  drbd (9.0.10+git.b7994aa1 -> 9.0.12+git.7eb4aef)
  drbd-utils
  e2fsprogs (1.43.7 -> 1.43.8)
  evince (3.26.0 -> 3.26.0+20171120.3955d480)
  evolution (3.26.3 -> 3.26.4)
  evolution-data-server (3.26.3 -> 3.26.4)
  evolution-ews (3.26.3 -> 3.26.4)
  ffmpegthumbs (17.12.0 -> 17.12.1)
  fluidsynth (1.1.8 -> 1.1.9)
  fontconfig
  fortune
  freerdp
  gcc7 (7.2.1+r253932 -> 7.2.1+r256737)
  gdk-pixbuf
  gegl
  ghostscript-fonts
  gimp
  gnome-session
  gnome-shell (3.26.2 -> 3.26.2+20171218.15b1810a6)
  gnome-software (3.26.3 -> 3.26.4)
  gnumeric (1.12.35 -> 1.12.38)
  gpgme
  gstreamer-plugins-base
  gtk2 (2.24.31+20171209.61d5c82f5c -> 2.24.32)
  gtk3
  gutenprint (5.2.13 -> 5.2.13pre14.2)
  gvfs
  gzip (1.8 -> 1.9)
  harfbuzz
  icewm
  ipset (6.34 -> 6.35)
  iputils
  java-10-openjdk
  juk (17.12.0 -> 17.12.1)
  kalarm (17.12.0 -> 17.12.1)
  kalgebra (17.12.0 -> 17.12.1)
  kalzium (17.12.0 -> 17.12.1)
  kanagram (17.12.0 -> 17.12.1)
  katomic (17.12.0 -> 17.12.1)
  kblackbox (17.12.0 -> 17.12.1)
  kblocks (17.12.0 -> 17.12.1)
  kbounce (17.12.0 -> 17.12.1)
  kbreakout (17.12.0 -> 17.12.1)
  kbruch (17.12.0 -> 17.12.1)
  kcron (17.12.0 -> 17.12.1)
  kde-print-manager (17.12.0 -> 17.12.1)
  kdeedu-data (17.12.0 -> 17.12.1)
  kdegraphics-thumbnailers (17.12.0 -> 17.12.1)
  kdf (17.12.0 -> 17.12.1)
  kdiamond (17.12.0 -> 17.12.1)
  keditbookmarks (17.12.0 -> 17.12.1)
  kgeography (17.12.0 -> 17.12.1)
  kgoldrunner (17.12.0 -> 17.12.1)
  khangman (17.12.0 -> 17.12.1)
  kig (17.12.0 -> 17.12.1)
  kiriki (17.12.0 -> 17.12.1)
  kiten (17.12.0 -> 17.12.1)
  kjumpingcube (17.12.0 -> 17.12.1)
  klettres (17.12.0 -> 17.12.1)
  klines (17.12.0 -> 17.12.1)
  kmahjongg (17.12.0 -> 17.12.1)
  kmines (17.12.0 -> 17.12.1)
  kmouth (17.12.0 -> 17.12.1)
  kmplot (17.12.0 -> 17.12.1)
  knavalbattle (17.12.0 -> 17.12.1)
  knetwalk (17.12.0 -> 17.12.1)
  kolf (17.12.0 -> 17.12.1)
  kollision (17.12.0 -> 17.12.1)
  kolourpaint (17.12.0 -> 17.12.1)
  konquest (17.12.0 -> 17.12.1)
  kpat (17.12.0 -> 17.12.1)
  kreversi (17.12.0 -> 17.12.1)
  kshisen (17.12.0 -> 17.12.1)
  ksirk (17.08.3 -> 17.12.1)
  kspaceduel (17.12.0 -> 17.12.1)
  ksquares (17.12.0 -> 17.12.1)
  ksudoku (17.12.0 -> 17.12.1)
  ksystemlog (17.12.0 -> 17.12.1)
  kteatime (17.12.0 -> 17.12.1)
  ktimer (17.12.0 -> 17.12.1)
  ktouch (17.12.0 -> 17.12.1)
  ktuberling (17.12.0 -> 17.12.1)
  kturtle (17.12.0 -> 17.12.1)
  kubrick (17.12.0 -> 17.12.1)
  kwordquiz (17.12.0 -> 17.12.1)
  libdrm (2.4.88 -> 2.4.89)
  libe-book (0.1.2 -> 0.1.3)
  libepoxy
  libglvnd
  libgpod
  libkdegames (17.12.0 -> 17.12.1)
  libkeduvocdocument (17.12.0 -> 17.12.1)
  libkmahjongg (17.12.0 -> 17.12.1)
  libmediaart
  libpagemaker (0.0.3 -> 0.0.4)
  libpeas
  libpwquality (1.3.0 -> 1.4.0)
  libqxp
  libreoffice (6.0.0.1 -> 6.0.0.2)
  libsamplerate
  libstorage-ng (3.3.110 -> 3.3.140)
  libteam
  libyui-ncurses (2.49.0 -> 2.50.0)
  libzypp (17.0.5 -> 17.1.1)
  llvm5
  lskat (17.12.0 -> 17.12.1)
  mariadb
  mbox-importer (17.12.0 -> 17.12.1)
  mjpegtools
  multipath-tools (0.7.3+13+suse.db431514 -> 0.7.3+31+suse.6804bb73f72d)
  mutter (3.26.2 -> 3.26.2+20171231.0bd1d7cf0)
  ncurses
  ntp
  numactl
  okteta (17.12.0 -> 17.12.1)
  openblas_pthreads
  pam-config (0.93 -> 0.94)
  parley (17.12.0 -> 17.12.1)
  patterns-kde
  perl
  php7 (7.2.0 -> 7.2.1)
  pim-data-exporter (17.12.0 -> 17.12.1)
  pim-sieve-editor (17.12.0 -> 17.12.1)
  plasma5-pa
  polkit-default-privs
  publicsuffix (20171028 -> 20171228)
  python-Pillow (4.2.1 -> 5.0.0)
  python-cffi
  python-cryptography
  python-cssselect (1.0.1 -> 1.0.3)
  python-dbus-python
  python-decorator (4.1.2 -> 4.2.1)
  python-numpy (1.13.3 -> 1.14.0)
  python3
  python3-base
  rdma-core (16 -> 16.1)
  rpm
  rsync
  rzsz
  seahorse
  serd
  speech-dispatcher
  step (17.12.0 -> 17.12.1)
  syslinux
  systemd
  systemd-presets-branding-openSUSE
  texinfo (6.4 -> 6.5)
  texlive
  texlive-filesystem (2017.132.svn41616 -> 2017.133.svn41616)
  texlive-specs-a (2017.132.0.0.3svn15878 -> 2017.133.0.0.3svn15878)
  texlive-specs-b (2017.132.svn15878 -> 2017.133.svn15878)
  texlive-specs-c (2017.132.1.05svn26477 -> 2017.133.1.05svn26477)
  texlive-specs-d (2017.132.1.0svn15878 -> 2017.133.1.0svn15878)
  texlive-specs-e (2017.132.1.0csvn15878 -> 2017.133.1.0csvn15878)
  texlive-specs-f (2017.132.svn15878 -> 2017.133.svn15878)
  texlive-specs-g (2017.132.1.5.2svn41686 -> 2017.133.1.5.2svn41686)
  texlive-specs-h (2017.132.1.07svn38419 -> 2017.133.1.07svn38419)
  texlive-specs-i (2017.132.1.3svn20641 -> 2017.133.1.3svn20641)
  texlive-specs-j (2017.132.0.0.4svn25832 -> 2017.133.0.0.4svn25832)
  texlive-specs-k (2017.132.4.8svn41714 -> 2017.133.4.8svn41714)
  texlive-specs-l (2017.132.0.0.1svn44158 -> 2017.133.0.0.1svn44158)
  texlive-specs-m (2017.132.1.0svn15878 -> 2017.133.1.0svn15878)
  texlive-specs-n (2017.132.1.62svn42296 -> 2017.133.1.62svn42296)
  texlive-specs-o (2017.132.svn15878 -> 2017.133.svn15878)
  texlive-specs-p (2017.132.svn34157 -> 2017.133.svn34157)
  texlive-specs-q (2017.132.0.0.75svn44352 -> 2017.133.0.0.75svn44352)
  texlive-specs-r (2017.132.svn21833 -> 2017.133.svn21833)
  texlive-specs-s (2017.132.2.0svn15878 -> 2017.133.2.0svn15878)
  texlive-specs-t (2017.132.0.0.07svn40873 -> 2017.133.0.0.07svn40873)
  texlive-specs-u (2017.132.1.0.3svn40415 -> 2017.133.1.0.3svn40415)
  texlive-specs-v (2017.132.1.0.0svn39074 -> 2017.133.1.0.0svn39074)
  texlive-specs-w (2017.132.4.07_gsvn31855 -> 2017.134.4.07_gsvn31855)
  texlive-specs-x (2017.132.svn35058 -> 2017.133.svn35058)
  texlive-specs-y (2017.132.1.6.0svn44308 -> 2017.133.1.6.0svn44308)
  texlive-specs-z (2017.132.1.1svn15878 -> 2017.133.1.1svn15878)
  totem
  tracker
  tracker-miners
  transmission
  ucode-intel (20180108 -> 20171117)
  update-alternatives (1.18.23 -> 1.19.0.4)
  webkit2gtk3 (2.18.4 -> 2.18.5)
  wireless-regdb (2017.03.07 -> 2017.12.23)
  wxWidgets-3_0
  wxWidgets-3_0-nostl
  xorg-x11-server (1.19.5 -> 1.19.6)
  yast2 (4.0.34 -> 4.0.38)
  yast2-bootloader (4.0.12 -> 4.0.13)
  yast2-installation (4.0.24 -> 4.0.26)
  yast2-network (4.0.13 -> 4.0.14)
  yast2-nis-client (4.0.0 -> 4.0.1)
  yast2-packager (4.0.28 -> 4.0.32)
  yast2-pkg-bindings (4.0.5 -> 4.0.6)
  yast2-storage-ng (4.0.68 -> 4.0.76)
  zypper-migration-plugin (0.10.1488806253.1c712c3 -> 0.11.1516874532.fa20262)

=== Details ===

==== ImageMagick ====
Version update (7.0.7.15 -> 7.0.7.21)
Subpackages: ImageMagick-extra libMagick++-7_Q16HDRI4 libMagickCore-7_Q16HDRI5 libMagickWand-7_Q16HDRI5

- update to 7.0.7.21
  * Fix some enum values in the OpenCL code.
  * Fixed numerous memory leaks.
  * Check for webpmux library version 0.4.4.
  * Fix heap use after free error.
  * Fix error reading multi-layer XCF image file.
  * Fix possible stack overflow in WEBP reader.

==== Mesa ====
Version update (17.3.2 -> 17.3.3)
Subpackages: Mesa-dri-devel Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 libgbm1 libwayland-egl1

- in spec file move %dir %{_libdir}/dri to avoid ppc build failure
- Update to 17.3.3
  * Fixes to radv, anv, etnaviv, swrast and radeonsi drivers.
  * Fixes for DRI3.
- Make Mesa require Mesa-dri and Mesa-gallium. This makes Mesa
  usable again for users who do not install recommended packages.
  It breaks the Mesa and Mesa-drivers split, which has to be fixed
  by ignoring it in obs.
- Add _constraints to select 6G disk for PowerPC
  to avoid cpio: write error on obs-power8-05 workers boo#1076325

==== Mesa-drivers ====
Version update (17.3.2 -> 17.3.3)
Subpackages: Mesa-dri Mesa-dri-nouveau Mesa-gallium Mesa-libva libvdpau_nouveau libvdpau_r300 libvdpau_r600 libvdpau_radeonsi libvulkan_intel libvulkan_radeon libxatracker2

- in spec file move %dir %{_libdir}/dri to avoid ppc build failure
- Update to 17.3.3
  * Fixes to radv, anv, etnaviv, swrast and radeonsi drivers.
  * Fixes for DRI3.
- Make Mesa require Mesa-dri and Mesa-gallium. This makes Mesa
  usable again for users who do not install recommended packages.
  It breaks the Mesa and Mesa-drivers split, which has to be fixed
  by ignoring it in obs.
- Add _constraints to select 6G disk for PowerPC
  to avoid cpio: write error on obs-power8-05 workers boo#1076325

==== ModemManager ====
Version update (1.6.8 -> 1.6.12)
Subpackages: ModemManager-bash-completion ModemManager-lang libmm-glib0

- Update to version 1.6.12:
  + Blacklist:
  - Ignored Pycom devices.
  - Added Microchip's VID to the greylist.
  + QMI:
  - Fixed connection state machine when built against libqmi <
    1.18.
  - Fixed connection state machine when an error is reported
    setting up WDS indications.
- Changes from version 1.6.10:
  + Blacklist:
  - Ignored Silicon Labs USB Zigbee dongles.
  - Ignored Garmin ANT+ sticks.
  - Ignored Intel coredump downloader device.
  + QMI:
  - Fixed potential user-after-free issues.
  - Fixed missing handler cleanups on network-initiated
    disconnects.
  + MBIM:
  - Fix invalid session_id and nw_error reads.
  - Avoid calling mbim_message_unref() on NULL message.
  - Fixed invalid object access due to handlers not being removed
    correctly.
  - Ensure session is disconnected before trying to connect.
  - Fixed t crash when modem doesn't send gateways.
  + udev:
  - Removed default ID_MM_PLATFORM_DRIVER_PROBE whitelist.
    Devices exposed via the 'atmel_usart' driver aren't probed
    automatically any more.
  + Core:
  - Fixed running init sequence after port flashing in
    disconnection.
  - Fixed "forbidden product strings" check in plugins.
  - Fixed multiple memory leaks and invalid memory read/writes.
  - Fixed multiple async operation completions in event handlers.
  - Fixed multiple potential NULL dereferences.
  - Fixed deadlock when trying to disconnect cancellable.
  - Fixed reporting TX/RX stats (numbers were swapped).
  - Ignored USB interface removal events.
  + libmm-glib: Fix NULL dereference on firmware unique_id checks.
  + polkit: Added missing Location interface method rules.
  + Plugins:
  - MBM: set data port for Dell DW5560.
  - Simtech: fix error reporting in 3gpp unsolicited events
    enabling.
  - Fixed multiple memory leaks.
  + systemd: Drop After=syslog.target rule.
- Drop post(un) handling of icon_theme_cache_post(un), no longer
  needed, file-triggers takes care of this now.
- Drop ModemManager-1.0.0-systemd-activation.patch: No longer
  needed.

==== MozillaFirefox ====
Version update (52.5.2 -> 52.6)

- update to Firefox 52.6esr (bsc#1077291)
  MFSA 2018-01
  * Speculative execution side-channel attack ("Spectre")
  MFSA 2018-03
  * CVE-2018-5091 (bmo#1423086)
    Use-after-free with DTMF timers
  * CVE-2018-5095 (bmo#1418447)
    Integer overflow in Skia library during edge builder allocation
  * CVE-2018-5096 (bmo#1418922)
    Use-after-free while editing form elements
  * CVE-2018-5097 (bmo#1387427)
    Use-after-free when source document is manipulated during XSLT
  * CVE-2018-5098 (bmo#1399400)
    Use-after-free while manipulating form input elements
  * CVE-2018-5099 (bmo#1416878)
    Use-after-free with widget listener
  * CVE-2018-5102 (bmo#1419363)
    Use-after-free in HTML media elements
  * CVE-2018-5103 (bmo#1423159)
    Use-after-free during mouse event handling
  * CVE-2018-5104 (bmo#1425000)
    Use-after-free during font face manipulation
  * CVE-2018-5117 (bmo#1395508)
    URL spoofing with right-to-left text aligned left-to-right
  * CVE-2018-5089
    Memory safety bugs fixed in Firefox 58 and Firefox ESR 52.6
- remove obsolete patch mozilla-ucontext.patch
- official NSS requirement is >= 3.28.6 therefore putting 3.29.5
  into an ifarch
- Escape the usage of %{VERSION} when calling out to rpm.
  RPM 4.14 has %{VERSION} defined as 'the main package's version'.
- Added additional patches and configurations to fix
  builds on s390 and PowerPC.
  * Added firefox-glibc-getrandom.patch effecting builds on
    s390 and PowerPC
  * Added mozilla-s390-bigendian.patch along with icudt58b.dat
    bigendian ICU data file for running Firefox on bigendian
    architectures (bmo#1322212 and bmo#1264836)
  * Added mozilla-s390-nojit.patch to enable atomic operations
    used by the JS engine when JIT is disabled on s390
  * Build configuration options specific to s390
  * Requires NSS >= 3.29.5
- Update to Firefox 52.5.3esr:
  * Fix a crash reporting issue that inadvertently sends background
  tab crash reports to Mozilla without user opt-in (bmo#1427111,
  bsc#1074235)

==== NetworkManager-applet ====
Subpackages: NetworkManager-applet-lang NetworkManager-connection-editor libnm-gtk0 libnma0 nma-data typelib-1_0-NMGtk-1_0

- Add
  0001-shared-compat-fix-memory-handling-of-nm_setting_vpn_.patch
  and
  0002-shared-compat-fix-memory-handling-of-nm_setting_vpn_.patch:
  fix crashes due to double frees.

==== SUSEConnect ====
Version update (0.3.3 -> 0.3.7)

- Remove unnecessary .gz files
- Update to 0.3.7
  - virt-create-rootfs connects to SMT server without breaking (bsc#914297)
- Update to 0.3.6
  - Make target_base_product parameter mandatory.
- Update to 0.3.5
  - Add YaST.system_offline_migrations
- Update to version 0.3.4:
  - Packaging improvements (bsc#964013)

==== SuSEfirewall2 ====
Version update (3.6.376 -> 3.6.378)

- Fixed a regression in setting up the final LOG/DROP/REJECT rules for IPv6 (bnc#1075251)
- Set RPC related rules also for IPv6 (bnc#1074933)

==== analitza ====
Version update (17.12.0 -> 17.12.1)
Subpackages: analitza-lang libAnalitza5

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== apparmor ====
Subpackages: apparmor-abstractions apparmor-docs apparmor-parser apparmor-parser-lang apparmor-profiles apparmor-utils apparmor-utils-lang pam_apparmor perl-apparmor python3-apparmor

- update to AppArmor 2.12
  - preserve errno across aa_*_unref() functions
  - see https://gitlab.com/apparmor/apparmor/wikis/Release_Notes_2.12
    for the detailed upstream changelog
- no longer package static libapparmor.a
- update to AppArmor 2.11.95 aka 2.12 beta1
  - no changes in libapparmor
  - see http://wiki.apparmor.net/index.php/ReleaseNotes_2_11_95
    for the detailed upstream changelog
- update to AppArmor 2.11.1
  - mostly test-related changes in libapparmor
  - see http://wiki.apparmor.net/index.php/ReleaseNotes_2_11_1 for
    upstream changelog
- Fix RPM groups
- split libapparmor into separate spec to get rid of build loop
  involving mariadb, systemd, apparmor, libapr and mariadb again
  (see the discussion in SR 448871 for details)
- libapparmor.spec is based on the AppArmor 2.11 apparmor.spec, but
  with minimum BuildRequires

==== audacity ====
Subpackages: audacity-lang

- Build with gcc7 for Leap:42.3 and -fstack-clash-protection

==== autoyast2 ====
Version update (4.0.20 -> 4.0.24)
Subpackages: autoyast2-installation

- Selecting evaluated/given product for installation.
  fate#323450
- 4.0.24
- Display more details when the package solver fails
- Using ProductFeatures.SetSection instead of
  ProductFeatures.SetOverlay in order to set product features.
  This is a follow up of bsc#1070726.
- 4.0.23
- adapt to yast2 changes in overlays (related to bsc#1070726)
- 4.0.22
- Upgrade: Adapting to new product handling.
  (bnc#1075744)
- 4.0.21

==== blinken ====
Version update (17.12.0 -> 17.12.1)
Subpackages: blinken-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== bluez ====
Version update (5.47 -> 5.48)
Subpackages: libbluetooth3

- update to version 5.48:
  This release brings many fixes and feature enhancements.
  Some notable enhancements include support for devices with the
  BLE battery service, as well as improved Mesh support in the
  meshctl tool. Several previously experimental D-Bus APIs have now
  been marked as stable, notably the Advertising Manager API as
  well as the AquireWrite & AquireNotify GATT APIs.
  As far as fixes go, these can be found in many areas of the stack,
  including A2DP, AVCTP, device discovery, Mesh, and GATT.

==== bovo ====
Version update (17.12.0 -> 17.12.1)
Subpackages: bovo-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== brltty ====
Subpackages: brltty-driver-at-spi2 brltty-driver-brlapi brltty-driver-espeak brltty-driver-speech-dispatcher brltty-driver-xwindow brltty-lang libbrlapi0_6 python3-brlapi xbrlapi

- Fix %pre, %post, and %postun: brltty.service is now
  brltty@.service (boo#1074096).

==== btrfsmaintenance ====
Version update (0.3.1 -> 0.4)

- update to version 0.4
  - add support for systemd timers and use them by default; the alternative
    cron scripts are still present (#29, #36)
  - add automatic monitoring (via systemd.path) of the config file,
    no manual updates by btrfsmaintenance-refresh.service needed (#38)
  - fix RPM database path detection
  - spec file cleanups
  - documentation updates
- removed patches:
  - btrfsmaintenance-0.3.1-fix-rpm-db-path.patch (upstream)
  - btrfsmaintenance-switch-to-timer.patch (upstream)
  - pull-request-36.patch (upstream)
- Fix systemd timers enabled even if period is set to none:
  * Micro change in pull-request-36.patch (bsc#1075884)
- Clean spec file:
  * Removed support for suse_version <= 1210.
  * Removed call to btrfsmaintenance-refresh-cron.sh upon deletion
    (not needed anymore since we use systemd timers which are
    handled by macros).
  * Ran spec-cleaner.

==== btrfsprogs ====
Version update (4.13.3 -> 4.14.1)
Subpackages: btrfsprogs-udev-rules libbtrfs0

- spec: fix distro version condition
- update to version 4.14.1
  * dump-tree: print times of root items
  * check: fix several lowmem mode bugs
  * convert: fix rollback after balance
  * other
  * new and updated tests, enabled lowmem mode in CI
  * docs updates
  * fix travis CI build
  * build fixes
  * cleanups
- update to version 4.14
  * build: libzstd now required by default
  * check: more lowmem mode repair enhancements
  * subvol set-default: also accept path
  * prop set: compression accepts no/none, same as ""
  * filesystem usage: enable for filesystem on top of a seed device
  * rescue: new command fix-device-size
  * other
  * new tests
  * cleanups and refactoring
  * doc updates
- Removed patches:
  - rollback-regression-fix.patch - upstreamed
- spec: disable static build, missing libzstd-devel-static
- spec: disable zstd support for non-Tumbleweed distros

==== cairo ====
Version update (1.15.8 -> 1.15.10)
Subpackages: libcairo-gobject2 libcairo2 libcairo2-32bit

- Update to version 1.15.10:
  + Features and Enhancements:
  - Add support for OpenGL ES 3.0 to the gl backend.
  - Use Reusable streams for forms in Level 3 Postscript.
  - Add CAIRO_MIME_TYPE_EPS mime type for embedding EPS files.
  - Add CCITT_FAX mime type for PDF and PS surfaces.
  - svg: add a new function to specify the SVG document unit
    (fdo#90166).
  - Use UTF-8 filenames on Windows.
  + API Changes: cairo_svg_surface_set_document_unit() and
    cairo_svg_surface_get_document_unit().
  + Bugs fixed:
  - Fix regression in gles version detection.
  - Fix undefined-behavior with integer math.
  - Handle SOURCE and CLEAR operators when painting color glyphs
    (fdo#102661).
  - Convert images to rgba or a8 formats when uploading with
    GLESv2.
  - Use _WIN32 instead of windows.h to check for windows build.
  - Fix sigabrt printing documents with fonts lacking the
    mandatory .nodef glyph (fdo#102922).
  - Prevent curved strokes in small ctms from being culled from
    vector surfaces (fdo#103071).
  - Fix painting an unbounded recording surface with the SVG
    backend.
  - Fix falling back to system font with PDFs using certain
    embedded fonts, due to truncated font names (fdo#103249).
  - Fix handling of truetype fonts with excessively long font
    names (fdo#103249).
  - Fix race conditions with cairo_mask_compositor_t
    (fdo#103037).
  - Fix build error with util/font-view.
  - Fix assertion hit with PDFs using Type 4 fonts rendered with
    user fonts, due to error when destroying glyph page
    (fdo#103335).
  - Set default creation date for PDFs.
  - Prevent invalid ptr access for > 4GB images (fdo#98165).
  - Prevent self-copy infinite loop in Postscript surface.
  - Fix padded image crash in Postscript surface.
  - Fix annotation bugs in PDFs and related memory leaks.
  - Fix test failures and other assorted issues in ps and pdf
    code.
  - Fix code generation when using GCC legacy atomic operations
    (fdo#103559).
  - Fix various compilation warnings and errors.
  - Fix various distcheck errors with private symbols, doxygen
    formatting etc.
- Drop cairo-image-prevent-invalid-ptr-access.patch

==== coreutils ====
Version update (8.28 -> 8.29)
Subpackages: coreutils-lang

- Update to 8.29:
  * Noteworthy changes in release 8.29 (2017-12-27) [stable]
  * * Bug fixes
  b2sum no longer crashes when processing certain truncated check files.
  [bug introduced with b2sum coreutils-8.26]
  dd now ensures the correct cache ranges are specified for the "nocache"
  and "direct" flags.  Previously some pages in the page cache were not
  invalidated.  [bug introduced for "direct" in coreutils-7.5,
  and with the "nocache" implementation in coreutils-8.11]
  df no longer hangs when given a fifo argument.
  [bug introduced in coreutils-7.3]
  ptx -S no longer infloops for a pattern which returns zero-length matches.
  [the bug dates back to the initial implementation]
  shred --remove will again repeatedly rename files with shortening names
  to attempt to hide the original length of the file name.
  [bug introduced in coreutils-8.28]
  stty no longer crashes when processing settings with -F also specified.
  [bug introduced in fileutils-4.0]
  tail --bytes again supports non seekable inputs on all systems.
  On systems like android it always tried to process as seekable inputs.
  [bug introduced in coreutils-8.24]
  timeout will again notice its managed command exiting, even when
  invoked with blocked CHLD signal, or in a narrow window where
  this CHLD signal from the exiting child was missed.  In each case
  timeout would have then waited for the time limit to expire.
  [bug introduced in coreutils-8.27]
  * * New features
  timeout now supports the --verbose option to diagnose forced termination.
  * * Improvements
  dd now supports iflag=direct with arbitrary sized files on all file systems.
  tail --bytes=NUM will efficiently seek to the end of block devices,
  rather than reading from the start.
  Utilities which do not support long options (other than the default --help
  and --version), e.g. cksum and sleep, now use more consistent error diagnostic
  for unknown long options.
  * * Build-related
  Default man pages are now distributed which are used if perl is
  not available on the build system, or when cross compiling.
- Refresh patches (line number changes only):
  * coreutils-i18n.patch
  * coreutils-remove_hostname_documentation.patch
  * coreutils-remove_kill_documentation.patch
  * coreutils-tests-shorten-extreme-factor-tests.patch

==== corosync ====
Subpackages: libcmap4 libcorosync_common4

- totemudp[u]: Drop truncated packets on receive(bsc#1075300)
    Added: 0012-totemudp-u-Drop-truncated-packets-on-receive.patch
- issue with partial packets assembly when multiple nodes are sending big packets(bsc#1074929)
    Added: 0011-libcpg-Fix-issue-with-partial-big-packet-assembly.patch

==== dpdk ====

- Enable(disabled by default) MLX4 and MLX5 pmd(fate#322609)

==== drbd ====
Version update (9.0.10+git.b7994aa1 -> 9.0.12+git.7eb4aef)
Subpackages: drbd-kmp-default

- bsc#1077318, Update to 9.0.12
  * Fix a race condition in the device_open code path that can cause an
  internal counter to go negative
- Update to 9.0.11
  * Fix bug in compat code: Without this fix large bios are not split.

==== drbd-utils ====

- bsc#1076936, from [hidden email].
  Reproducible builds support merged in upstream, but
  the changes in spec is lost.

==== e2fsprogs ====
Version update (1.43.7 -> 1.43.8)
Subpackages: libcom_err2 libcom_err2-32bit libext2fs2

- Update to 1.43.8
  * add forgotten byteswap of some new superblock fields
  * fix use-after-free in e2fsck for corrupted root inode
  * fix floating point exception due to corrupted superblock in e2fsck
  * fix resize2fs's free block sanity checks
  * updated translations

==== evince ====
Version update (3.26.0 -> 3.26.0+20171120.3955d480)
Subpackages: evince-lang evince-plugin-comicsdocument evince-plugin-djvudocument evince-plugin-dvidocument evince-plugin-pdfdocument evince-plugin-psdocument evince-plugin-tiffdocument evince-plugin-xpsdocument libevdocument3-4 libevview3-3 nautilus-evince typelib-1_0-EvinceDocument-3_0 typelib-1_0-EvinceView-3_0

- Update to version 3.26.0+20171120.3955d480:
  + Updated translations.
- Switch to git-checkout via source service.
- Following the above, add gnome-common BuildRequires, pass
  autogen.sh and pass enable-gtk doc to configure, as we need to
  bootstrap the tarball.
- Clean up spec, use modern macros.
- Drop update-desktop-files BuildRequires and stop using
  suse_update_desktop macro, no longer needed.
- Drop obsolete conditionals for no longer supported versions of
  openSUSE.
- Avoid running fdupes across hardlink boundaries.

==== evolution ====
Version update (3.26.3 -> 3.26.4)
Subpackages: evolution-lang evolution-plugin-bogofilter evolution-plugin-pst-import evolution-plugin-spamassassin

- Update to version 3.26.4:
  + Bugs fixed: bgo#791291, bgo#791341, bgo#791346, bgo#791793.
  + Updated translations.

==== evolution-data-server ====
Version update (3.26.3 -> 3.26.4)
Subpackages: evolution-data-server-lang libcamel-1_2-60 libebackend-1_2-10 libebook-1_2-19 libebook-contacts-1_2-2 libecal-1_2-19 libedata-book-1_2-25 libedata-cal-1_2-28 libedataserver-1_2-22 libedataserverui-1_2-1

- Update to version 3.26.4:
  + Prevent passing NULL ldap handle into LDAP functions.
  + [Maildir]: Correct double free when the source message file
    doesn't exist.
  + Bugs fixed: bgo#791475, bgo#791282.

==== evolution-ews ====
Version update (3.26.3 -> 3.26.4)
Subpackages: evolution-ews-lang

- Update to version 3.26.4:
  + Bugs fixed: bgo#792190.

==== ffmpegthumbs ====
Version update (17.12.0 -> 17.12.1)

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== fluidsynth ====
Version update (1.1.8 -> 1.1.9)

- Update to version 1.1.9:
  * fix building the portaudio driver on Windows
  * fix build if no MIDI drivers are available
  * fix return value of fluid_file_set_encoding_quality()
  * fix use-after-free in fluid_timer
  * fix memory leak in pulseaudio driver
  * fix memory leak in rvoice_mixer
  * fix dumptuning shell command displaying uninitialized values
  * fix a resource leak in source shell command
  * harmonize fluidsynth's output library naming with autotools on Windows
  * dont set LIB_SUFFIX when building with MinGW
  * avoid a possible deadlock when initializing fluidsynths DLL on windows
  * avoid a buffer overrun when mixing effects channels in fluid_synth_nwrite_float()
  * correctly clean up fluid_server on Windows
  * implement handling of FLUID_SEQ_ALLSOUNDSOFF events in fluid_seq_fluidsynth_callback()
  * support for registering audio drivers based on actual needs

==== fontconfig ====
Subpackages: fontconfig-32bit fontconfig-devel

- fc-query: remove redundant debug output
  + fontconfig-remove-debug-output.patch

==== fortune ====

- Add fortune-no-recode.patch.

==== freerdp ====
Subpackages: libfreerdp2 libwinpr2

- Users can connect only once wo windows sessions due to
  [#]gh/FreeRDP/FreeRDP/4348
  Therefore WITH_GSSAPI has been disabled until that issue has been
  solved

==== gcc7 ====
Version update (7.2.1+r253932 -> 7.2.1+r256737)
Subpackages: cpp7 gcc7-info gcc7-locale libasan4 libatomic1 libcilkrts5 libgcc_s1 libgcc_s1-32bit libgfortran4 libgomp1 libitm1 liblsan0 libmpx2 libmpxwrappers2 libobjc4 libquadmath0 libstdc++6 libstdc++6-32bit libstdc++6-locale libtsan0 libubsan0

- Update to gcc-7-branch head (r256737)
  * Includes gcc7-pr81481.diff
  * Adds backport of retpoline support via -mindirect-branch=,
  - mfunction-return= and friends.  [bnc#1074621]
- Handle new debug sources filelist variant debugsourcefiles.list.
- Prune libstdc++ includes for crosses.
- Do not install target parts of cross compilers into the sysroot
  but instead fixup manually (once required).
- Update to gcc-7-branch head (r256067).
- Deal with C++ being disabled for crosses.
- For crosses that have a target triplet not matching that of binutils
  create symlinks to as and ld in the GCC private directory.
- Split cross-avr into -bootstrap and non-bootstrap variant for avr-libc
  integration.
- Add gcc7-avoid-fixinc-error.diff to avoid install-host aborting
  on non-existing target include directory.  Remove --with-build-sysroot=/
  hack from icecream cross configs, no longer prune include-fixed for
  them to retain a GCC provided limits.h.  Remove installed install-tools.

==== gdk-pixbuf ====
Subpackages: gdk-pixbuf-lang gdk-pixbuf-query-loaders gdk-pixbuf-query-loaders-32bit gdk-pixbuf-thumbnailer libgdk_pixbuf-2_0-0 libgdk_pixbuf-2_0-0-32bit typelib-1_0-GdkPixbuf-2_0

- Add gdk-pixbuf-bgo779012-ico-overflow.patch: fix a potential
  integer overflow (boo#1027026 CVE-2017-6312).
- Add gdk-pixbuf-gif-negative-array-indexes.patch and
  gdk-pixbuf-gif-uninitialized-variable.patch: protect against
  access to negative array indexes (BGO#778584).
- Add gdk-pixbuf-tiff-overflow.patch: avoid overflow during size
  computation (bgo#779020).
- Add gdk-pixbuf-icns-handle-short-blocklen.patch: protect against
  short block length when reading icns (boo#1027024
  CVE-2017-6313).

==== gegl ====
Subpackages: gegl-0_2 gegl-0_2-lang libgegl-0_2-0

- Replace liberation-fonts BuildRequires with liberation2-fonts:
  the new set works as well.

==== ghostscript-fonts ====
Subpackages: ghostscript-fonts-other ghostscript-fonts-std

- Revert last change: reconfigure_post_* does not know a -n
  parameter, which in turn results in warnings (rpm < 4.14) or
  errors (rpm >= 4.14).
  > reconfigure_fonts_post: invalid option -- 'n'
  > error: Unknown option n in reconfigure_fonts_post(c)

==== gimp ====
Subpackages: gimp-lang gimp-plugins-python libgimp-2_0-0 libgimpui-2_0-0

- Run spec-cleaner, modernize spec, drop Obsoletes for versions
  no longer supported.
- Don't build with webkit1, as it is no longer maintained and has
  plenty of security bugs.  This disables the GIMP's built-in help
  browser; it will use an external browser when configured this way.
  This works around a number of security vulnerabilities in Webkit1:
  https://bugzilla.suse.com/show_bug.cgi?id=923223
  https://bugzilla.suse.com/show_bug.cgi?id=906375
  https://bugzilla.suse.com/show_bug.cgi?id=906374
  https://bugzilla.suse.com/show_bug.cgi?id=906373
  https://bugzilla.suse.com/show_bug.cgi?id=1034856
  https://bugzilla.suse.com/show_bug.cgi?id=871792
  https://bugzilla.suse.com/show_bug.cgi?id=879607
  https://bugzilla.suse.com/show_bug.cgi?id=892084

==== gnome-session ====
Subpackages: gnome-session-core gnome-session-default-session gnome-session-lang

- Add gnome-session-nb-translation.patch: Update Norwegian bokmål
  translations.

==== gnome-shell ====
Version update (3.26.2 -> 3.26.2+20171218.15b1810a6)
Subpackages: gnome-shell-calendar gnome-shell-lang

- Add gnome-shell-network-fix-visibility-VPN.patch: network: Fix
  visibility of VPN section (bgo#787845).
- Own directories
  {_datadir}/gnome-shell/extensions|search-providers|modes again,
  seems a lot of packages depended on this beeing true.
- Update to version 3.26.2+20171218.15b1810a6:
  + background: don't leak wall clock when background changes.
  + dateMenu:
  - Fix possible crash with unknown locations.
  - Ignore malformed world-clocks settings.
  + dash:
  - Do not shadow ClutterActor's destroy().
  - Make sure item labels are only destroyed once.
  + status/keyboard: Reset menuItems and Label objects on change.
  + overview: Protect ::drag-end handlers.
  + Updated translations.
- Switch to git-checkout via source services.
- Pass enable-browser-plugin=true, enable-documentation=true,
  enable-man=true, enable-networkmanager=yes and
  enable-systemd=yes to meson, ensure we build the features we
  want.
- Following the above, add gtk-doc BuildRequires and build
  documentation again.
- Run spec-cleaner, modernize spec.
- Drop update-desktop-files BuildRequires and stop using the
  suse_update_desktop_file macro.
- Drop conditional libaccountsservice0, libcaribou0 and
  libgdmgreeter1 Requires needed for no longer supported versions
  of openSUSE.
- Add fdupes BuildRequires and pass fdupes macro, remove duplicate
  files.
- Drop gnome-shell-wayland Obsoletes: No currently supported
  version of openSUSE have ever had this binary, so this is no
  longer needed.
- Stop exporting BROWSER_PLUGIN_DIR=%%{_libdir}/browser-plugins,
  does not work as we are using meson buildsystem.

==== gnome-software ====
Version update (3.26.3 -> 3.26.4)
Subpackages: gnome-software-lang

- Update to version 3.26.4:
  + Fix crashes in the repos plugin due to missing locking.
  + Work around Firefox deleting rpm/deb files downloaded to /tmp
    when closing.
  + Do not require the user to keep clicking 'More reviews' after
    each click.
  + Fix a critical when updating (flatpak) packages live.
  + fwupd: Prepend the vendor name to the device name if not
    included.
  + Improve SPDX ID parsing when working out if it is 'free'.
  + packagekit: Do not crash when getting an invalid ID from
    PackageKit.
  + Do not crash when closing the source dialog while it is
    loading.
  + Updated translations.
- Drop gs-add-locking-to-the-repos-plugin.patch: Fixed upstream.

==== gnumeric ====
Version update (1.12.35 -> 1.12.38)
Subpackages: gnumeric-lang

- Update to version 1.12.38:
  + Avoid large stack use here and there.
  + Test suite improvements.
  + Improve sylk writer.  Don't ask.
  + Teach ssdiff about column/row sizes.
  + Teach ssdiff about defined names.
  + Fix a few ssdiff crashes.
  + Fix crash on text import.
- Use plain make call again, fix build for old versions of
  openSUSE.
- Update to version 1.12.37:
  + Improvements in:
  - Test suite.
  - Format guessing for newly entered formulas.
  - PERMUTATIONA for unusual arguments (bgo#790742).
  - xlsx export of cell comments (bgo#790756).
  + Fixes:
  - Combo object icon.
  - Potential crash:
    . On exit.
    . in gtk scroll bar bug workaround.
  + Speed-up number theory functions.
  + Avoid large stack use here and there.
  + Extend range of NT_PI.
  + Plug leaks.
- Point fdupes to the data directory instead of build root, which
  is a practice that must be avoided.
- Adopt the use of %make_build macro instead of raw make command,
  following the best practices.
- Add gnumeric-rpmlintrc to filter the following warnings:
  + hidden-file-or-dir: some .category files are not meant to be
    edited.
  + shlib-policy-missing-suffix: spliting the package into a libfoo
    subpackage are not desired at the moment.
  + script-without-shebang: some python scripts under
    /usr/lib(64)/gnumeric/$version/plugins/foo/foo.py are not meant
    to be used in command line.
- Update to version 1.12.36:
  + Improvements in:
  - Contour plot:
    . Export/import to/from ODF (bgo#788728).
    . Import of Excel generated ODF (bgo#788801).
  - Surface plot export to ODF (bgo#788447).
  + Fixes:
  - Export/import of CONCATENATE and minor axis divisors to and
    from ODF.
  - Import of affine trendline from ODF (bgo#789538).
  - Background of multiple selection (bgo#789411).
  - Error on xlsx files with bogus Print_Area.
  - xlsx:
    . Export of trend line equation.
    . Import and export of trend line affine flag.
  - VDB for partial periods (bgo#790299).
  + Workaround for gtk scroll bar bug (bgo#789412).
  + Convert all xpm files to png.
  + Avoid to-pixdata options for resources. It's going away.
  + Minor CORREL improvement.
  + xlsx import and export improvements for contour graphs.
  + Avoid critical on exporting unnamed xlsx trend line.
- Drop %glib2_gsettings_schema_*, %desktop_database_* and
  %icon_theme_cache_* post/postun scriptlets: they are no longer
  needed since RPM file triggers.
- Drop --disable-scrollkeeper and --enable-ssindex configure
  parameters: no longer available.
- Add gio-2.0, gmodule-2.0, gobject-2.0 and gthread-2.0 pkgconfig
  BuildRequires: note that they already were being pulled with
  pkgconfig(glib-2.0) and used since they live in the same devel
  package.
- Change Group of devel package to Development/Libraries/GNOME
  since it's where the package belongs.
- Split package into a -doc subpackage: more than half the size of
  the package was documentation.

==== gpgme ====
Subpackages: libgpgme11 libgpgmepp6 libqgpgme7

- Tweak up the python conditional to allow us finegraining and
  selecting only py2 or py3 if needed

==== gstreamer-plugins-base ====
Subpackages: gstreamer-plugins-base-lang libgstallocators-1_0-0 libgstapp-1_0-0 libgstaudio-1_0-0 libgstfft-1_0-0 libgstpbutils-1_0-0 libgstriff-1_0-0 libgstrtp-1_0-0 libgstrtsp-1_0-0 libgstsdp-1_0-0 libgsttag-1_0-0 libgstvideo-1_0-0 typelib-1_0-GstAudio-1_0 typelib-1_0-GstPbutils-1_0 typelib-1_0-GstTag-1_0 typelib-1_0-GstVideo-1_0

- Add gst-pb-playbin3-fix-accessing-invalid-index.patch: playbin3:
  Fix accessing invalid index in GstStream when received
  select-stream event (bgo#791638).
- Clean up spec with spec-cleaner.

==== gtk2 ====
Version update (2.24.31+20171209.61d5c82f5c -> 2.24.32)
Subpackages: gtk2-data gtk2-immodule-amharic gtk2-immodule-inuktitut gtk2-immodule-thai gtk2-immodule-vietnamese gtk2-lang gtk2-tools gtk2-tools-32bit libgtk-2_0-0 libgtk-2_0-0-32bit

- Update to version 2.24.32:
  + Fix abicheck.
- Use the release version as revision and set versionformat to
  PARENT_TAG, ensure we build the upstream released tag.

==== gtk3 ====
Subpackages: gtk3-data gtk3-immodule-amharic gtk3-immodule-inuktitut gtk3-immodule-thai gtk3-immodule-vietnamese gtk3-lang gtk3-schema gtk3-tools libgtk-3-0 typelib-1_0-Gtk-3_0

- Sync summaries with gtk4.

==== gutenprint ====
Version update (5.2.13 -> 5.2.13pre14.2)

- Version upgrade to 5.2.13pre14.2 which is the
  second pre-release of Gutenprint 5.2.14.
  Major changes in this release (compared to 5.2.12):
  * The PCL driver now supports color laser printers
    that use PCL 5c natively (as opposed to emulation).
    The support is considered to be preliminary at this time.
    Tons of PCL printers have been added with color support.
    Please report success or failure with PCL color laser printers
    using the Generic PCL Color drivers.
    Based on feedback from this pre-release, some or all of these
    printers may be removed from the list prior to 5.2.14 release.
  * Support for the Brother HL-2030 and HL-2035 has been removed
    because these printers do not support standard PCL.
  * A crash that affected certain dyesub printers when used with
    simplified PPD files has been fixed.
  * Enhanced support for some dye-sublimation printers.
  For details see the NEWS file.

==== gvfs ====
Subpackages: gvfs-backend-afc gvfs-backend-samba gvfs-backends gvfs-fuse gvfs-lang

- Enable libnfs support also on SLE: BuildRequire pkgconfig(libnfs)
  unconditionally (bsc#1074978).

==== gzip ====
Version update (1.8 -> 1.9)

- license is GPL-3.0+
- Update to 1.9
  * Fix suffix handling
  * Fix bug when handling pack format while decompressing
  * Fix time handling bug
  * Improve exit code handling for shell scripts
- remove gzip-1.8-fix_unpack_EOB_check.patch as it is included
  upstream now
- refresh manpage-no-date.patch
- spec file cleanups
- add gzip-1.8-deprecate_netstat.patch to get rid of deprecated
  'netstat -n' command in tests/init.sh script

==== harfbuzz ====
Subpackages: libharfbuzz-icu0 libharfbuzz0 libharfbuzz0-32bit

- harfbuzz-devel hb-ft.h requires pkgconfig(freetype2) but it is
  not automatically added by the dependency generator.

==== icewm ====
Subpackages: icewm-default icewm-lang

- Change the recommend xlockmore to xscreensaver( bsc#1074932 ).

==== ipset ====
Version update (6.34 -> 6.35)

- Update to new upstream release 6.35
  * Userspace revision handling is reworked
  * Backport patch: netfilter: ipset: use nfnl_mutex_is_locked
  * Missing nfnl_lock()/nfnl_unlock() is added to
    ip_set_net_exit()
  * netfilter: ipset: add resched points during set listing
  * Fix "don't update counters" mode when counters used at the
    matching
  * netfilter: ipset: Fix race between dump and swap

==== iputils ====

- Backport iputils-ping-fix-pmtu-for-ipv6.patch from upstream
  to fix PMTU discovery in ping6. (bsc#1072460)

==== java-10-openjdk ====
Subpackages: java-10-openjdk-headless

- Modified patch:
  * JDK-8195685-aarch64.patch
    + Incorporate S8196136: AArch64: Correct register use in patch
    for JDK-8195685
- Removed patch:
  * revert-8174962-for-zero.patch
    + a proper fix for ZERO exists
- Added patch:
  * JDK-8194739-zero.patch
    + S8194739: Zero port of 8174962: Better interface invocations
- Removed patch:
  * revert-8174962-for-aarch64.patch
    + a proper fix for aarch64 exists
- Added patches:
  * JDK-8195685-aarch64.patch
    + S8195685, AArch64 cannot build with JDK-8174962
  * revert-8174962-for-zero.patch
    + revert "S8174962, CVE-2018-2582: Better interface invocations"
    for ZERO. The patch misses ZERO parts and causes crash
  during build.

==== juk ====
Version update (17.12.0 -> 17.12.1)
Subpackages: juk-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kalarm ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kalarm-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kalgebra ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kalgebra-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kalzium ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kalzium-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kanagram ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kanagram-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== katomic ====
Version update (17.12.0 -> 17.12.1)
Subpackages: katomic-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kblackbox ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kblackbox-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kblocks ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kblocks-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kbounce ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kbounce-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kbreakout ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kbreakout-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kbruch ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kbruch-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kcron ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kcron-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kde-print-manager ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kde-print-manager-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kdeedu-data ====
Version update (17.12.0 -> 17.12.1)

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kdegraphics-thumbnailers ====
Version update (17.12.0 -> 17.12.1)

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kdf ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kdf-lang kwikdisk

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kdiamond ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kdiamond-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== keditbookmarks ====
Version update (17.12.0 -> 17.12.1)
Subpackages: keditbookmarks-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kgeography ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kgeography-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kgoldrunner ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kgoldrunner-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== khangman ====
Version update (17.12.0 -> 17.12.1)
Subpackages: khangman-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kig ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kig-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kiriki ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kiriki-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kiten ====
Version update (17.12.0 -> 17.12.1)
Subpackages: fonts-KanjiStrokeOrders kiten-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kjumpingcube ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kjumpingcube-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== klettres ====
Version update (17.12.0 -> 17.12.1)
Subpackages: klettres-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== klines ====
Version update (17.12.0 -> 17.12.1)
Subpackages: klines-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kmahjongg ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kmahjongg-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Update action state properly after undo/redo

==== kmines ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kmines-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kmouth ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kmouth-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kmplot ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kmplot-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== knavalbattle ====
Version update (17.12.0 -> 17.12.1)
Subpackages: knavalbattle-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== knetwalk ====
Version update (17.12.0 -> 17.12.1)
Subpackages: knetwalk-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kolf ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kolf-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kollision ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kollision-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kolourpaint ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kolourpaint-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== konquest ====
Version update (17.12.0 -> 17.12.1)
Subpackages: konquest-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kpat ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kpat-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kreversi ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kreversi-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kshisen ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kshisen-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== ksirk ====
Version update (17.08.3 -> 17.12.1)

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None
- Update to 17.12.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.0.php
- Changes since 17.11.90:
  * None
- Update to 17.11.90
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12-rc.php
- Changes since 17.11.80:
  * None
- Update to 17.11.80
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12-beta.php
- Changes since 17.08.3:
  * Too many changes to list here

==== kspaceduel ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kspaceduel-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== ksquares ====
Version update (17.12.0 -> 17.12.1)
Subpackages: ksquares-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== ksudoku ====
Version update (17.12.0 -> 17.12.1)
Subpackages: ksudoku-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== ksystemlog ====
Version update (17.12.0 -> 17.12.1)
Subpackages: ksystemlog-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kteatime ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kteatime-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== ktimer ====
Version update (17.12.0 -> 17.12.1)
Subpackages: ktimer-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== ktouch ====
Version update (17.12.0 -> 17.12.1)
Subpackages: ktouch-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== ktuberling ====
Version update (17.12.0 -> 17.12.1)
Subpackages: ktuberling-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kturtle ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kturtle-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kubrick ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kubrick-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== kwordquiz ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kwordquiz-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libdrm ====
Version update (2.4.88 -> 2.4.89)
Subpackages: libdrm-devel libdrm2 libdrm_amdgpu1 libdrm_intel1 libdrm_nouveau2 libdrm_radeon1

- U_intel-Add-more-Coffeelake-PCI-IDs.patch
  * Add more Coffeelake PCI IDs (request by Intel)
- Update to version 2.4.89:
  libdrm release with leasing and syncobj api updates, updated amdgpu marketing
  ids, amdgpu tests, updated uapi headers & etnaviv updates.

==== libe-book ====
Version update (0.1.2 -> 0.1.3)

- Cure linguistic problem in descriptions.
- Update to 0.1.3:
  * Fix various problems when reading broken files, found with the help of
    american-fuzzy-lop and oss-fuzz.
  * Fix build with boost >= 1.59.
  * Set default page margins. (tdf#94162)
  * Make output of ebook2* --help more compatible with help2man.
  * Check for librevenge-stream if tests are enabled. (gentoo#603098)
  * Require C++11 for build.
  * Drop outdated MSVC project files.
  * Fix several issues found by Coverity.
  * FictionBook v.2:
  * Use document language as default language for text.
  * Use note title as footnote mark.
  * Handle subscript and superscript.
  * Output content of <code> in monospace font.

==== libepoxy ====

- -devel package requires pkgconfig(x11), pkgconfig(egl)
  but those deps are not generated automatically.

==== libglvnd ====
Subpackages: libglvnd-32bit

- Make sure to use only python3 for the build and do not rely
  on env calls for python

==== libgpod ====
Subpackages: libgpod-lang libgpod-tools libgpod4

- Fix groups of SRPM and documentation. Make doc noarch.
  Trim bias from description.
- Conditionalize python2 module build as it is not compatible with
  python3 at all and we do not need it by default
  * This allows to build in python3 only enviroment
- Run over a bit with spec-cleaner

==== libkdegames ====
Version update (17.12.0 -> 17.12.1)
Subpackages: kdegames-carddecks-default libkdegames-lang libkf5kdegames6

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libkeduvocdocument ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKEduVocDocument5 libkeduvocdocument-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libkmahjongg ====
Version update (17.12.0 -> 17.12.1)
Subpackages: libKF5KMahjongglib5 libkmahjongg-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== libmediaart ====
Subpackages: libmediaart-2_0-0 typelib-1_0-MediaArt-2_0

- Add meson-Introspection-fix.patch: The meson build did not add
  the extractdummy.c to the sources, which contains introspection
  annotations (bgo#792272, bgo#791586).

==== libpagemaker ====
Version update (0.0.3 -> 0.0.4)

- Cure linguistic problem in descriptions.
- Update to 0.0.4:
  * Add a command line tool for conversion to plain text, called pmd2text.
  * Require C++11 for build.
  * Drop outdated MSVC project files.
  * Fix parsing of page dimensions and shape coordinates in Mac documents.
    That makes the output at least somewhat useful, but more work is needed
    to handle big endian files properly.
  * Fix parsing of color tint in Mac documents. (tdf#109126)
  * Fix parsing of text formatting attributes in Mac documents.
  * Properly handle all caps and small caps.
  * Parse more text formatting attributes.
  * Parse more paragraph attributes.

==== libpeas ====
Subpackages: libpeas-1_0-0 libpeas-gtk-1_0-0 libpeas-lang libpeas-loader-python libpeas-loader-python3 typelib-1_0-Peas-1_0 typelib-1_0-PeasGtk-1_0

- Use make_build macro.
- Avoid running fdupes across hardlink boundaries.
- Update URL to reflect current web, old was 404.
- Run spec-cleaner.
- Fix typo on parallel build command call.
- Conditionalize py2 and py3 build to allow us building of the
  one we desire based on codestream.

==== libpwquality ====
Version update (1.3.0 -> 1.4.0)
Subpackages: libpwquality-lang libpwquality1

- Update RPM groups and summaries.
- Switch url to https://github.com/libpwquality/libpwquality/
- Update to release 1.4.0:
  * Fix possible buffer overflow with data from /dev/urandom
    in pwquality_generate().
  * Do not try to check presence of too short username in password.
    (thanks to Nikos Mavrogiannopoulos)
  * Make the user name check optional (via usercheck option).
  * Add an 'enforcing' option to make the checks to be warning-only
    in PAM.
  * The difok = 0 setting will disable all old password similarity
    checks except new and old passwords being identical.
  * Updated translations from Zanata.
- Add patch libpwquality-pythons.patch to avoid duping pythondir
- Make python3 default and enable py2 only when needed

==== libqxp ====

- Cure linguistic problem in descriptions.

==== libreoffice ====
Version update (6.0.0.1 -> 6.0.0.2)
Subpackages: libreoffice-base libreoffice-base-drivers-mysql libreoffice-branding-upstream libreoffice-calc libreoffice-draw libreoffice-filters-optional libreoffice-gnome libreoffice-gtk3 libreoffice-icon-themes libreoffice-impress libreoffice-kde4 libreoffice-l10n-en libreoffice-mailmerge libreoffice-math libreoffice-pyuno libreoffice-writer libreofficekit

- Disable 2 db tests that are really flaky in OBS
- Fix the lo-provides filtering to allow proper provides to be generated
- Version update to 6.0.0.2:
  * More fixes in RC2 of 6.0.0 release
- Add requires on kdelibs4 to avoid crashes

==== libsamplerate ====

- Add libsamplerate-0.1.9-reproducible.patch to disable throughput
  test to make builds reproducible in spite of Profile Guided Optimizations

==== libstorage-ng ====
Version update (3.3.110 -> 3.3.140)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- merge gh#openSUSE/libstorage-ng#436
- added sanity check
- propagate exception to ruby
- 3.3.140
- merge gh#openSUSE/libstorage-ng#435
- propagate exception to ruby
- 3.3.139
- Translated using Weblate (Slovak)
- 3.3.138
- Translated using Weblate (Slovak)
- Translated using Weblate (Slovak)
- 3.3.137
- Translated using Weblate (Spanish)
- 3.3.136
- Translated using Weblate (Polish)
- 3.3.135
- Translated using Weblate (Polish)
- 3.3.134
- Translated using Weblate (Slovak)
- 3.3.133
- Translated using Weblate (Slovak)
- Translated using Weblate (Slovak)
- 3.3.132
- Translated using Weblate (Slovak)
- 3.3.131
- Translated using Weblate (Slovak)
- 3.3.130
- Translated using Weblate (Slovak)
- 3.3.129
- Translated using Weblate (Slovak)
- Translated using Weblate (Slovak)
- Translated using Weblate (Slovak)
- 3.3.128
- Translated using Weblate (Slovak)
- 3.3.127
- Translated using Weblate (Slovak)
- 3.3.126
- Translated using Weblate (Slovak)
- Translated using Weblate (Slovak)
- 3.3.125
- merge gh#openSUSE/libstorage-ng#431
- Update libstorage-ng.spec.in
- 3.3.124
- merge gh#openSUSE/libstorage-ng#434
- find crypttab entries by correct block device
- coding style
- removed unused parameters
- Translated using Weblate (German)
- 3.3.123
- merge gh#openSUSE/libstorage-ng#433
- added helper function
- improved probing of LUKs
- added unit test
- allow to find unused mockups
- removed unused mockups
- use name from crypttab when activating LUKS
- allow to include more information in graphviz output
- removed unused parser
- 3.3.122
- Translated using Weblate (German)
- 3.3.121
- Translated using Weblate (Slovak)
- 3.3.120
- Translated using Weblate (German)
- 3.3.119
- merge gh#openSUSE/libstorage-ng#432
- updated
- 3.3.118
- merge gh#openSUSE/libstorage-ng#430
- Revert "Add libstorage-ng-lang Recommends"
- 3.3.117
- merge gh#openSUSE/libstorage-ng#429
- Add libstorage-ng-lang Recommends
- 3.3.116
- merge gh#openSUSE/libstorage-ng#428
- use /etc/fstab and /proc/mounts for probing NFS
- added NFS unit test
- 3.3.115
- merge gh#openSUSE/libstorage-ng#427
- extended integration test
- 3.3.114
- merge gh#openSUSE/libstorage-ng#426
- fixed alignment calculations
- added unit test
- 3.3.113
- merge gh#openSUSE/libstorage-ng#425
- added new align policy KEEP_START_ALIGN_END
- updated unit tests
- updated integration tests
- 3.3.112
- merge gh#openSUSE/libstorage-ng#424
- propagate exception
- 3.3.111

==== libteam ====

- Drop /pkg/ subpart from includedir
- Remove defattr that is not really needed
- Add condition around python bindings, they are really based on
  swig code that would need to be rewritten to support python3

==== libyui-ncurses ====
Version update (2.49.0 -> 2.50.0)

- Removed is_linetouched() function that clashes with a macro of
  the same name of newer NCurses libs (bsc#1074600)
- 2.50.0

==== libzypp ====
Version update (17.0.5 -> 17.1.1)

- Adapt rpm package verification to changes in rpm-4.14 (bsc#1076018)
- version 17.1.1 (0)
- plugin: don't reject header values containing a ':' (bsc#1074687)
- Locks: Don't store duplicate locks (bsc#969569)
- version 17.1.0 (0)

==== llvm5 ====

- Place gold plugin to the right directory. (bnc#1073210)
  * It must be in /usr/lib/bfd-plugins on all architectures.
  * Remove llvm5-gold from baselibs.conf - nothing needs a 32bit
    version of it and it would now conflict with the 64bit one.
- Reduce _constraints requirements on 32bit architectures.
  * Since we had to disable debuginfo on them, they require much
    less.
- ignore make check error for PowerPC as bypass
  https://bugs.llvm.org/show_bug.cgi?id=35871
- disable debuginfo build for ARM as well

==== lskat ====
Version update (17.12.0 -> 17.12.1)
Subpackages: lskat-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Add missing categories files

==== mariadb ====
Subpackages: libmysqld19 mariadb-client mariadb-errormessages

- change owner of mysql-test directory from root to mysql. It also
  fixes sys_vars.secure_file_priv running under mysql user (e.g.
  if ít's started via suse-test-run script) that needs to be able
  to create a test file there during its run [bsc#1012075]

==== mbox-importer ====
Version update (17.12.0 -> 17.12.1)
Subpackages: mbox-importer-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== mjpegtools ====
Subpackages: libmjpegutils-2_0-0

- Add conditional post(un) handling for libmpeg2encpp-2_0-0.

==== multipath-tools ====
Version update (0.7.3+13+suse.db431514 -> 0.7.3+31+suse.6804bb73f72d)
Subpackages: kpartx multipath-tools-rbd

- Update to version 0.7.3+31+suse.6804bb73f72d:
  * libmultipath: hwtable: no_path_retry="queue" for NetApp NVMe
  (bsc#1073319)
- Update to version 0.7.3+30+suse.6b5ed839:
  * multipath.rules: temporary rule to obtain ID_WWN for NVMe
  (bsc#1076828)
  * libmultipath: ignore natively multipathed NVME devices
  (bsc#1076828)
  * multipath.rules: handle NVME devices (bsc#1076828)
  * FIX "libmultipath: hwtable: multibus for NetApp NVMe-FC"
  (bsc#1073319)
  * libmultipath: increase path product_id/rev field size for NVMe
  (bsc#1073319)
- Update to version 0.7.3+25+suse.7c9920e2:
  * assemble_map: no newline at end of params string (bsc#1072253)
- Update to version 0.7.3+24+suse.703a61d5:
  * multipathd.service: drop Before=lvm2-lvmetad.service (bsc#1070427)
  * libmultipath: hwtable: multibus for NetApp NVMe-FC
  (bsc#1073319)
  * libmultipath/propsel: select ALUA prioritizer for RDAC arrays only
  (bsc#1075539)
  * libmultipath: get_vpd_sgio: support VPD 0xc9 (bsc#1055949)
  * libmultipath: sgio_get_vpd: add page argument (bsc#1055949)
  * libmultipath: fix return code of sgio_get_vpd() (bsc#1055949)
- Update to version 0.7.3+19+suse.0fd18bdd:
  * multipathd.socket: add WantedBy=sockets.target (bsc#1072253)
- Update to version 0.7.3+18+suse.8c97f433:
  * multipath -C: decrease log level (bsc#1072504)
- Update to version 0.7.3+17+suse.cac42e6f:
  * test-kpartx: add test for mapping without UUID
  (bsc#1074013)
- Update to version 0.7.3+15+suse.570d5938:
  * kpartx.rules: fix by-id/scsi-* for user_friendly_names
  (bsc#1066893)
- Update to version 0.7.3+14+suse.da06e7f3:
  * libmultipath: fix return code of sysfs_get_timeout (bsc#1069037)

==== mutter ====
Version update (3.26.2 -> 3.26.2+20171231.0bd1d7cf0)
Subpackages: libmutter-1-0 mutter-data mutter-lang

- Update to version 3.26.2+20171231.0bd1d7cf0:
  + Revert "window: Raise and lower tile match in tandem".
  + wayland: Only send full sequences of touch events to clients.
  + stage: Push framebuffer before setting up viewport.
  + keybindings: Only add multiple keycodes from the same level.
  + wayland-outputs: Delay wl_output destruction.
  + monitor-manager-kms:
  - Fix recently introduced build issue.
  - poll() on KMS fd on EAGAIN.
  + compositor: reset top_window_actor and remove it from windows
    when destroyed.
  + monitor-manager: Compare keys when checking whether a config is
    complete.
  + Updated translations.
- Switch to git-checkout via source services.
- Following the above, add intltool and libtool BuildRequires and
  pass autogen.sh to bootstrap the generated tarball.
- Pkgconfigy the BuildRequires, replace:
  gobject-introspection-devel, libSM-devel, libX11-devel and
  libXinerama-devel with pkgconfig(gobject-introspection-1.0),
  pkgconfig(sm), pkgconfig(x11) and pkgconfig(xinerama).
- Drop update-desktop-files BuildRequires and stop using
  suse_update_desktop_file macro, no longer needed.
- Drop pkgconfig(gbm) BuildRequires listed twice.
- Run spec-cleaner, modernize spec, use make_build macro.

==== ncurses ====
Subpackages: libncurses6 ncurses-utils terminfo terminfo-base

- Add ncurses patch 20180106
  + fixes for writing extended color pairs in putwin.
  + modify test/savescreen.c to add test patterns that exercise 88-,
    256-, etc., colors.
  + modify configure option --with-build-cc, adding clang, c89 and c99
    as possible default values.
  + modify ncurses-examples configure script to use pkg-config for the
    extra form/menu/panel libraries, to be more consistent with the
    handling of the curses/ncurses library.
  + modify test-packages for mingw to supply "pc" files.
  + modify gen-pkgconfig.in to list -lpthread as a private library when
    configured to access it via weak symbols.
  + simplify gen-pkgconfig.in, adding -ltinfo without the special linker
    checks because some versions of the linker simply hard-code the
    behavior.
  + update URLs for ncurses website to use https.
  + modify CF_CURSES_LIBS to fill in $cf_nculib_root in case the
    ncurses-examples are built with a system ncurses that lacks the
    standard "curses" symbolic link, as done by SuSE.  The symbol is
    needed to make a followup check for the pthread library work, and
    would be set properly using the options "--with-screen", etc.
  + generate misc/*.pc with "all" rule, as done for "sources" rule
    (report by Jeffrey Walton).
- Add ncurses patch 20171230
  + build-fix for ncurses-examples with Fedora27, adding check for
    reset_color_pairs() -- not yet in Fedora's package.
  + consistently add $CFLAGS to $MK_SHARED_LIB symbol in configure
    script when the latter happens to use the C compiler rather than
    directly using the loader (report by Jeffrey Walton).
  + set ABI for upcoming 6.1 release in "*.map" files.  While there are
    some remaining internals to apply, no ABI-related changes are
    anticipated.
  + add configure --with-config-suffix option to work around filename
    conflict with Redhat packages versus test-packages.
- Add ncurses patch 20171223
  + modify ncurses-examples to quiet const-warnings when building with
    PDCurses.
  + modify toe to not exit if unable to read a terminal description,
    e.g., if there is a permission problem.
  + minor fix for progs/toe.c, using _nc_free_termtype2.
  + assign 0 to pointer in _nc_tgetent_leak() after freeing it. Also
    avoid reusing pointer from previous successful call to tgetent
    if the latest call is unsuccessful (patch by Michael Schroeder,
    OpenSuSE #1070450).
  + minor fix for test/tracemunch, initialize $awaiting variable.
- Disable memory leak checking (boo#1070450)
- Add ncurses patch 20171216
  + repair template in test/package/ncurses-examples.spec (cf: 20171111).
  + improve tic's warning about the number of parameters tparm might use
    for u1-u9 by making a special case for u6.
  + improve curs_attr.3x discussion of color pairs.
- Add ncurses patch 20171209
  + modify misc/ncurses-config.in to make output with --includedir
    consistent with --cflags, i.e., when --disable-overwrite option was
    configured the output should show the subdirectory where headers
    are.
  + modify MKlib_gen.sh to suppress macros when calling an "implemented"
    function in link_test.c
  + updated ftp-url used in test-packages, etc.
  + modify order of -pie/-shared options in configure script in case
    LDFLAGS uses "-pie", working around a defect or limitation in the GNU
    linker (prompted by patch by Yogesh Prasad, forwarded by Jay Shah).
  + add entry in man_db.renames for user_caps.5
- Add ncurses patch 20171125
  + modify MKlib_gen.sh to avoid tracing result from getstr/getnstr
    before initialized.
  + add "-a" aspect-ratio option to picsmap.
  + add configure check for default path of rgb.txt, used in picsmap.
  + modify _nc_write_entry() to truncate too-long filename (report by
    Hosein Askari, Debian #882620).
  + build-fix for ncurses-examples with NetBSD curses:
    + it lacks the use_env() function.
    + it lacks libpanel; a recent change used the wrong ifdef symbol.
  + add a macro for is_linetouched() and adjust the function's return
    value to make it possible for most applications to check for an
    error-return (report by Midolikawa H).
  + additional manpage cleanup.
  + update config.guess, config.sub from
    http://git.savannah.gnu.org/cgit/config.git

==== ntp ====
Subpackages: ntp-doc

- Add ntp-reproducible.patch to make build reproducible (boo#1047218)
- Restart nptd if failed or aborted (FATE#315133).
- Do not try to set the HW clock when adding a server at runtime
  to avoid blocking systemd.

==== numactl ====
Subpackages: libnuma1

- Disable building at 32-bit ARM.
  NUMA is not supported by 32-bit ARM Linux Kernel, so build failed
  with
  [#]error "Add syscalls for your architecture or update kernel headers"

==== okteta ====
Version update (17.12.0 -> 17.12.1)
Subpackages: okteta-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * Fix StringDataInformation::setEncoding() logic on UTF16 endianess change
  * Fix crash on shutdown due to mTerminalPart trying to recover (kde#384993)
  * Bump version to 0.24.1

==== openblas_pthreads ====

- Switch from gcc6 to gcc7 as additional compiler flavor for HPC on SLES.
- Fix library package requires - use HPC macro (boo#1074890).
- Fix unexpanded rpm macro in environment module file for HPC (boo#1074897).

==== pam-config ====
Version update (0.93 -> 0.94)

- Update to version 0.94: add support for keyinit [bsc#1045886]

==== parley ====
Version update (17.12.0 -> 17.12.1)
Subpackages: parley-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== patterns-kde ====
Subpackages: patterns-kde-kde patterns-kde-kde_edutainment patterns-kde-kde_games patterns-kde-kde_imaging patterns-kde-kde_internet patterns-kde-kde_multimedia patterns-kde-kde_office patterns-kde-kde_plasma patterns-kde-kde_utilities patterns-kde-kde_utilities_opt patterns-kde-kde_yast

- Recommend plasma5-session-wayland to install it by default
- Don't recommend kde-gtk-config5, replaced by supplements

==== perl ====
Subpackages: perl-base perl-doc

- ignore make check transient errors for PowerPC
  that are reported since 20170907
  bypass boo#1063176
  new patch: perl_skip_flaky_tests_powerpc.patch

==== php7 ====
Version update (7.2.0 -> 7.2.1)
Subpackages: apache2-mod_php7 php7-ctype php7-dom php7-gd php7-gettext php7-iconv php7-json php7-mbstring php7-mysql php7-pdo php7-pear php7-pear-Archive_Tar php7-pgsql php7-sqlite php7-tokenizer php7-xmlreader php7-xmlwriter php7-zlib

- updated to 7.2.1: Several security bugs were fixed in this release.
  http://php.net/ChangeLog-7.php#7.2.1
- build against newer webp [bsc#1074121]
- build with SLE12*

==== pim-data-exporter ====
Version update (17.12.0 -> 17.12.1)
Subpackages: pim-data-exporter-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== pim-sieve-editor ====
Version update (17.12.0 -> 17.12.1)
Subpackages: pim-sieve-editor-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== plasma5-pa ====
Subpackages: plasma5-pa-lang

- Add patch to fix channel drag-and-drop:
  * 0001-Fix-moving-streams-by-drag-and-drop.patch

==== polkit-default-privs ====

- polkit-default-privs: adding new udisks2 rules (bsc#1073216)

==== publicsuffix ====
Version update (20171028 -> 20171228)

- Update to version 20171228:
  * Add Paris region (#579)
  * Fixed alwaysdata.net. (#555)
  * Add Combell domains (#565)
  * Adding scrysec.com (#528)
  * Add Fedora Openshift app domains (#533)
  * Add resin.io device domains to list (#499)
  * Add nh-serv.co.uk to list file (#491)
  * Add 1Password domains (#562)
  * Add s5y.io (#572)
  * Add social domains - NIC.bo (#467)

==== python-Pillow ====
Version update (4.2.1 -> 5.0.0)
Subpackages: python2-Pillow python3-Pillow

- Fix build fails on i586 and ppc and others:
  * pillow-non-iterable.patch
- Add freetype-2.9.patch to fix tests with FreeType 2.9 gh#2954
- Remove other distro conditions as they can't use singlespec really
- Version update to 5.0.0:
  * Docs: Added docstrings from documentation #2914 [radarhere]
  * Test: Switch from nose to pytest #2815 [hugovk]
  * Rework Source directory layout, preventing accidental import of PIL. #2911 [wiredfool]
  * Dynamically link libraqm #2753 [wiredfool]
  * Removed scripts directory #2901 [wiredfool]
  * TIFF: Run all compressed tiffs through libtiff decoder #2899 [wiredfool]
  * GIF: Add disposal option when saving GIFs #2902 [linnil1, wiredfool]
  * EPS: Allow for an empty line in EPS header data #2903 [radarhere]
  * PNG: Add support for sRGB and cHRM chunks, permit sRGB when no iCCP chunk present #2898 [wiredfool]
  * Dependencies: Update Tk Tcl to 8.6.8 #2905 [radarhere]
  * Decompression bomb error now raised for images 2x larger than a decompression bomb warning #2583 [wiredfool]
  * Test: avoid random failure in test_effect_noise #2894 [hugovk]
  * Increased epsilon for test_file_eps.py:test_showpage due to Arch update. #2896 [wiredfool]
  * Removed check parameter from _save in BmpImagePlugin, PngImagePlugin, ImImagePlugin, PalmImagePlugin, and PcxImagePlugin. #2873 [radarhere]
  * Make PngImagePlugin.add_text() zip argument type bool #2890 [jdufresne]
  * Depends: Updated libwebp to 0.6.1 #2880 [radarhere]
  * Remove unnecessary bool() calls in Image.registered_extensions and skipKnownBadTests #2891 [jdufresne]
  * Fix count of BITSPERSAMPLE items in broken TIFF files #2883 [homm]
  * Fillcolor parameter for Image.Transform #2852 [wiredfool]
  * Test: Display differences for test failures #2862 [wiredfool]
  * Added executable flag to file with shebang line #2884 [radarhere]
  * Setup: Specify compatible Python versions for pip #2877 [hugovk]
  * Dependencies: Updated libimagequant to 2.11.4 #2878 [radarhere]
  * Setup: Warn if trying to install for Py3.7 on Windows #2855 [hugovk]
  * Doc: Fonts can be loaded from a file-like object, not just filename #2861 [robin-norwood]
  * Add eog support for Ubuntu Image Viewer #2864 [NafisFaysal]
  * Test: Test on 3.7-dev on Travis.ci #2870 [hugovk]
  * Dependencies: Update libtiff to 4.0.9 #2871 [radarhere]
  * Setup: Replace deprecated platform.dist with file existence check #2869 [wiredfool]
  * Build: Fix setup.py on Debian #2853 [wiredfool]
  * Docs: Correct error in ImageDraw documentation #2858 [meribold]
  * Test: Drop Ubuntu Precise, Fedora 24, Fedora 25, add Fedora 27, Centos 7, Amazon v2 CI Support #2854, #2843, #2895, #2897 [wiredfool]
  * Dependencies: Updated libimagequant to 2.11.3 #2849 [radarhere]
  * Test: Fix test_image.py to use tempfile #2841 [radarhere]
  * Replace PIL.OleFileIO deprecation warning with descriptive ImportError #2833 [hugovk]
  * WebP: Add support for animated WebP files #2761 [jd20]
  * PDF: Set encoderinfo for images when saving multi-page PDF. Fixes #2804. #2805 [ixio]
  * Allow the olefile dependency to be optional #2789 [jdufresne]
  * GIF: Permit LZW code lengths up to 12 bits in GIF decode #2813 [wiredfool]
  * Fix unterminiated string and unchecked exception in _font_text_asBytes. #2825 [wiredfool]
  * PPM: Use fixed list of whitespace, rather relying on locale, fixes #272. #2831 [markmiscavage]
  * Added support for generators when using append_images #2829, #2835 [radarhere]
  * Doc: Correct PixelAccess.rst #2824 [hasahmed]
  * Depends: Update raqm to 0.3.0 #2822 [radarhere]
  * Docs: Link to maintained version of aggdraw #2809 [hugovk]
  * Include license file in the generated wheel packages #2801 [jdufresne]
  * Depends: Update openjpeg to 2.3.0 #2791 [radarhere]
  * Add option to Makefile to build and install with C coverage #2781 [hugovk]
  * Add context manager support to ImageFile.Parser and PngImagePlugin.ChunkStream #2793 [radarhere]
  * ImageDraw.textsize: fix zero length error #2788 [wiredfool, hugovk]
  * Fix warning on pointer cast in isblock #2775, #2778 [cgohlke]
  * Doc: Added macOS High Sierra tested Pillow version #2777 [radarhere]
  * Use correct Windows handle type on 64 bit in imagingcms #2774 [cgohlke]
  * 64 Bit Windows fix for block storage #2773 [cgohlke]
  * Fix "expression result unused" warning #2764 [radarhere]
  * Add 16bit Read/Write and RLE read support to SgiImageFile #2769 [jbltx, wiredfool]
  * Block & array hybrid storage #2738 [homm]
  * Common seek frame position check #1849 [radarhere]
  * Doc: Add note about aspect ratio to Image thumbnail script #2281 [wilsonge]
  * Fix ValueError: invalid version number '1.0.0rc1' in scipy release candidate #2771 [cgohlke]
  * Unfreeze requirements.txt #2766 [hugovk]
  * Test: ResourceWarning tests #2756 [hugovk]
  * Use n_frames to determine is_animated if possible #2315 [radarhere]
  * Doc: Corrected parameters in documentation #2768 [radarhere]
  * Avoid unnecessary Image operations #1891 [radarhere]
  * Added register_extensions method #1860 [radarhere]
  * Fix TIFF support for I;16S, I;16BS, and I;32BS rawmodes #2748 [wiredfool]
  * Fixed doc syntax in ImageDraw #2752 [radarhere]
  * Fixed support for building on Windows/msys2. Added Appveyor CI coverage for python3 on msys2 #2476 [wiredfool]
  * Fix ValueError in Exif/Tiff IFD #2719 [wiredfool]
  * Use pathlib2 for Path objects on Python < 3.4 #2291 [asergi]
  * Export only required properties in unsafe_ptrs #2740 [homm]
  * Alpha composite fixes #2709 [homm]
  * Faster Transpose operations, added 'Transverse' option #2730 [homm]
  * Deprecate ImageOps undocumented functions gaussian_blur, gblur, unsharp_mask, usm and box_blur in favor of ImageFilter implementations #2735 [homm]
  * Dependencies: Updated freetype to 2.8.1 #2741 [radarhere]
  * Bug: Player skipped first image #2742 [radarhere]
  * Faster filter operations for Kernel, Gaussian, and Unsharp Mask filters #2679 [homm]
  * EPS: Add showpage to force rendering of some EPS images #2636 [kaplun]
  * DOC: Fix type of palette parameter in Image.quantize. #2703 [kkopachev]
  * DOC: Fix Ico docs to match code #2712 [hugovk]
  * Added file pointer save to SpiderImagePlugin #2647 [radarhere]
  * Add targa version 2 footer #2713 [jhultgre]
  * Removed redundant lines #2714 [radarhere]
  * Travis CI: Use default pypy/pypy3 #2721 [hugovk]
  * Fix for SystemError when rendering an empty string, added in 4.2.0 #2706 [wiredfool]
  * Fix for memory leaks in font handling added in 4.2.0 #2634 [wiredfool]
  * Tests: cleanup, more tests. Fixed WMF save handler #2689 [radarhere]
  * Removed debugging interface for Image.core.grabclipboard #2708 [radarhere]
  * Doc syntax fix #2710 [radarhere]
  * Faster packing and unpacking for RGB, LA, and related storage modes #2693 [homm]
  * Use RGBX rawmode for RGB JPEG images where possible #1989 [homm]
  * Remove palettes from non-palette modes in _new #2702 [wiredfool]
  * Delete transparency info when convert'ing RGB/L to RGBA #2633 [olt]
  * Code tweaks to ease type annotations #2687 [neiljp]
  * Fixed incorrect use of 's#' to byteslike object #2691 [wiredfool]
  * Fix JPEG subsampling labels for subsampling=2 #2698 [homm]
  * Region of interest (box) for resampling #2254 [homm]
  * Basic support for Termux (android) in setup.py #2684 [wiredfool]
  * Bug: Fix Image.fromarray for numpy.bool type. #2683 [wiredfool]
  * CI: Add Fedora 24 and 26 to Docker tests [wiredfool]
  * JPEG: Fix ZeroDivisionError when EXIF contains invalid DPI (0/0). #2667 [vytisb]
  * Depends: Updated openjpeg to 2.2.0 #2669 [radarhere]
  * Depends: Updated Tk Tcl to 8.6.7 #2668 [radarhere]
  * Depends: Updated libimagequant to 2.10.2 #2660 [radarhere]
  * Test: Added test for ImImagePlugin tell() #2675 [radarhere]
  * Test: Additional tests for SGIImagePlugin #2659 [radarhere]
  * New Image.getchannel method #2661 [homm]
  * Remove unused im.copy2 and core.copy methods #2657 [homm]
  * Fast Image.merge() #2677 [homm]
  * Fast Image.split() #2676 [homm]
  * Fast image allocation #2655 [homm]
  * Storage cleanup #2654 [homm]
  * FLI: Use frame count from FLI header #2674 [radarhere]
  * Test: Test animated FLI file #2650 [hugovk]
  * Bug: Fixed uninitialized memory in bc5 decoding #2648 [ifeherva]
  * Moved SgiImagePlugin save error to before the start of write operations #2646 [radarhere]
  * Move createfontdatachunk.py so isn't installed globally #2645 [hugovk]
  * Bug: Fix unexpected keyword argument 'align' #2641 [hugovk]
  * Add newlines to error message for clarity #2640 [hugovk]
  * Docs: Updated redirected URL #2637 [radarhere]
  * Bug: Fix JPEG DPI when EXIF is invalid #2632 [wiredfool]
  * Bug: Fix for font getsize on empty string #2624 [radarhere]
  * Docs: Improved ImageDraw documentation #2626 [radarhere]
  * Docs: Corrected alpha_composite args documentation #2627 [radarhere]
  * Docs: added the description of the filename attribute to images.rst #2621 [dasdachs]
  * Dependencies: Updated libimagequant to 2.10.1 #2616 [radarhere]
  * PDF: Renamed parameter to not shadow built-in dict #2612 [kijeong]

==== python-cffi ====

- Add patch cffi-loader.patch to fix bsc#1070737
- Sort out with spec-cleaner

==== python-cryptography ====

- Add proper conditional for the python2, the ifpython works only
  for the requires/etc
- add missing dependency on python ssl

==== python-cssselect ====
Version update (1.0.1 -> 1.0.3)

- specfile:
  * update copyright year
- update to version 1.0.3:
  * Fix artifact uploads to pypi
- changes from version 1.0.2:
  * Drop support for Python 2.6 and Python 3.3.
  * Fix deprecation warning in Python 3.6.
  * Minor cleanups.

==== python-dbus-python ====
Subpackages: python2-dbus-python python3-dbus-python

- drop unneeded epydoc requirement properly

==== python-decorator ====
Version update (4.1.2 -> 4.2.1)
Subpackages: python2-decorator python3-decorator

- specfile:
  - updated copyright year
- updated to version 4.2.1:
  * Fixed a regression breaking IPython reported by
    https://github.com/spapini .
- changes from version 4.2.0 :
  * Added a facility to define families of decorators (aka decorators
    with arguments) as requested by several users. Accepted a pylint
    patch by David Allouche.

==== python-numpy ====
Version update (1.13.3 -> 1.14.0)
Subpackages: python2-numpy python3-numpy

- add s390 to the ifarch conditional to build without openblas
- update to version 1.14.0
  Changes documented in release notes:
  https://github.com/numpy/numpy/blob/master/doc/release/1.14.0-notes.rst
- Switch from gcc6 to gcc7 as additional compiler flavor for HPC on SLES.
- Fix library package requires - use HPC macro (boo#1074890).

==== python3 ====
Subpackages: python3-curses python3-dbm python3-tk

- move XML modules and python3-xml provide to python3-base
  (fixes bsc#1077230)
- move ensurepip to base
- Add skip_random_failing_tests.patch only for PowerPC

==== python3-base ====
Subpackages: libpython3_6m1_0 python3-idle

- move XML modules and python3-xml provide to python3-base
  (fixes bsc#1077230)
- move ensurepip to base
- Add skip_random_failing_tests.patch only for PowerPC

==== rdma-core ====
Version update (16 -> 16.1)
Subpackages: libibverbs libibverbs1 libmlx4-1 libmlx5-1

- Add Remove-the-obsolete-libibcm-library.patch to drop obsolete libibcm.
  * Official upstream drop will be in v17
  * Drop now to avoid submitting libibcm to SLE15
- Update to rdma-core v16.1:
  * Backport fixes:
  * srp_daemon: Don't create async_ev_thread if only run once
  * srp_daemon: handle SM lid change
  * srp_daemon: fix CQ handling
- Drop srp_daemon-Don-t-create-async_ev_thread-if-only-run-once.patch,
  srp_daemon-fix-CQ-handling.patch, and
  srp_daemon-handle-SM-lid-change.patch as they were merged upstream.

==== rpm ====
Subpackages: rpm-32bit

- update to rpm-4.11.1
- Update to 4.10.2
- fix build
- Update for rpm 4.10.0
- Spec file cleanup:
  * Don't rm -rf %{buildroot}
  * Removed %clean section
  * Removed authors from description
- Initial package

==== rsync ====

- Security fix: Ignore --protect-args when already sent by client
  [bsc#1076503, CVE-2018-5764]
  * Added patch rsync-3.1.2-CVE-2018-5764.patch
- Fix: Stop file upload after errors [bsc#1062063]
- Added patches:
  * rsync-send_error_to_sender.patch
  * rsync-avoid-uploading-after-error.patch

==== rzsz ====

- add lrzsz-0.12.20-fix-lsz-getopt.patch: fix for boo#1076576
- Run spec-cleaner

==== seahorse ====
Subpackages: gnome-shell-search-provider-seahorse seahorse-lang

- Add seahorse-gpg-ignore-key-considered.patch: ignore new
  key_considered line (bgo#779607).
- Add seahorse-new-gnupg.patch: Mark gnupg 2.2.x as supported, so
  that our builds enable gpg again (bsc#1075928).
- Drop seahorse-allow-deprecated.patch: seahorse builds without it.

==== serd ====

- Tweak a bit more py3 dep to not pull whole python but just base
- Fix group on one of the subpkgs
- Remove python-base dependency and change headers in python scripts
  to python3

==== speech-dispatcher ====
Subpackages: libspeechd2 python3-speechd speech-dispatcher-configure speech-dispatcher-module-espeak

- Add baselibs.conf: create libspeechd2-32bit, required by
  libQt5TextToSpeech5-32bit.

==== step ====
Version update (17.12.0 -> 17.12.1)
Subpackages: step-lang

- Update to 17.12.1
  * New bugfix release
  * For more details please see:
  * https://www.kde.org/announcements/announce-applications-17.12.1.php
- Changes since 17.12.0:
  * None

==== syslinux ====

- syslinux-4.04-python3.diff: switch to python3 (bsc#1075769)

==== systemd ====
Subpackages: libsystemd0 libsystemd0-32bit libudev-devel libudev1 libudev1-32bit systemd-32bit systemd-bash-completion systemd-sysvinit udev

- Import commit c2ed2c6dc3aed4b3c22cfcd4b8fd28da01f6471e
  aa3eba828 delta: don't ignore PREFIX when the given argument is PREFIX/SUFFIX
  b1ea0173a delta: extend skip logic to work on full directory paths (prefix+suffix) (bsc#1070428)
  77c5065f9 delta: check if a prefix needs to be skipped only once
  db32866d1 Fix parsing of features in detect_vm_xen_dom0 (#7890) (bsc#1048510)
  11d40461a sd-bus: use -- when passing arguments to ssh (#6706)
- Edit scripts-systemd-fix-machines-btrfs-subvol.sh
  We shouldn't be creating a /var/lib/machines subvolume if /var is
  already a seperate partition or subvolume. /var/lib/machines will
  already be excluded from snapper & similar tooling in this case.

==== systemd-presets-branding-openSUSE ====

- Enable new kbdsettings.service (boo#1010880).

==== texinfo ====
Version update (6.4 -> 6.5)

- Update to version 6.5:
  * info:
    + some bugs fixed:
    a bug where a segfault could happen in the regex search, for
    example when the user entered a single \ as the search string
    + another bug which could make nodes inaccessible in long
    "split" info files
    + a bug where it was not possible to follow a cross-reference
    that was split across more than one line has been fixed
    + do not fall back to a man page if following a cross-reference
    in an info file failed
    + if looking for a file failed, do not convert the name of a
    file to lower-case and look for it again
  * texinfo.tex
    + some faulty definitions for Unicode characters have been
    changed or removed
    + fix indentation in table of contents for entries that are
    split across multiple lines
  * texi2dvi
    + a bug that broke the processing of LaTeX files that did not
    use BibTeX has been fixed
  * texi2any
    + output the encoding declaration of a HTML file earlier so it
    will always occur within first 1024 bytes of file
    + `INLINE_INSERTCOPYING' removed as a customization variable

==== texlive ====
Subpackages: libkpathsea6 libsynctex1 libtexlua52-5 libtexluajit2 texlive-a2ping-bin texlive-accfonts-bin texlive-adhocfilelist-bin texlive-afm2pl-bin texlive-amstex-bin texlive-arara-bin texlive-asymptote-bin texlive-bibtex-bin texlive-bibtex8-bin texlive-bibtexu-bin texlive-bundledoc-bin texlive-checkcites-bin texlive-checklistings-bin texlive-chktex-bin texlive-context-bin texlive-cslatex-bin texlive-csplain-bin texlive-ctanify-bin texlive-ctanupload-bin texlive-ctie-bin texlive-cweb-bin texlive-de-macro-bin texlive-detex-bin texlive-dosepsbin-bin texlive-dtl-bin texlive-dtxgen-bin texlive-dviasm-bin texlive-dvicopy-bin texlive-dvidvi-bin texlive-dviinfox-bin texlive-dviljk-bin texlive-dvipdfmx-bin texlive-dvipng-bin texlive-dvipos-bin texlive-dvips-bin texlive-dvisvgm-bin texlive-epstopdf-bin texlive-findhyph-bin texlive-fontinst-bin texlive-fontools-bin texlive-fontware-bin texlive-fragmaster-bin texlive-gsftopk-bin texlive-kpathsea-bin texlive-lacheck-bin texlive-latex-bin-bin
 texlive-latex-git-log-bin texlive-latex-papersize-bin texlive-latex2man-bin texlive-latex2nemeth-bin texlive-latexdiff-bin texlive-latexfileversion-bin texlive-latexindent-bin texlive-latexmk-bin texlive-latexpand-bin texlive-lcdftypetools-bin texlive-listings-ext-bin texlive-ltxfileinfo-bin texlive-ltximg-bin texlive-lua2dox-bin texlive-luaotfload-bin texlive-luatex-bin texlive-lwarp-bin texlive-make4ht-bin texlive-makeindex-bin texlive-match_parens-bin texlive-metafont-bin texlive-metapost-bin texlive-mex-bin texlive-mf2pt1-bin texlive-mflua-bin texlive-mfware-bin texlive-mkjobtexmf-bin texlive-mptopdf-bin texlive-patgen-bin texlive-pdfbook2-bin texlive-pdfcrop-bin texlive-pdfjam-bin texlive-pdflatexpicscale-bin texlive-pdftex-bin texlive-pdftools-bin texlive-pdfxup-bin texlive-pfarrei-bin texlive-pkfix-bin texlive-pkfix-helper-bin texlive-ps2pk-bin texlive-pst-pdf-bin texlive-pstools-bin texlive-purifyeps-bin texlive-pygmentex-bin texlive-pythontex-bin texlive-seetexk-bin texlive
 -srcredact-bin texlive-sty2dtx-bin texlive-synctex-bin texlive-tetex-bin texlive-tex-bin texlive-tex4ebook-bin texlive-tex4ht-bin texlive-texconfig-bin texlive-texcount-bin texlive-texdef-bin texlive-texdiff-bin texlive-texdirflatten-bin texlive-texdoc-bin texlive-texfot-bin texlive-texliveonfly-bin texlive-texloganalyser-bin texlive-texosquery-bin texlive-texware-bin texlive-thumbpdf-bin texlive-tie-bin texlive-tpic2pdftex-bin texlive-ttfutils-bin texlive-typeoutfileinfo-bin texlive-ulqda-bin texlive-vlna-bin texlive-web-bin texlive-xdvi-bin texlive-xetex-bin

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-filesystem ====
Version update (2017.132.svn41616 -> 2017.133.svn41616)
Subpackages: texlive-collection-basic texlive-collection-binextra texlive-collection-context texlive-collection-fontsrecommended texlive-collection-fontutils texlive-collection-langczechslovak texlive-collection-langenglish texlive-collection-langeuropean texlive-collection-langfrench texlive-collection-langgerman texlive-collection-langitalian texlive-collection-langpolish texlive-collection-langportuguese texlive-collection-langspanish texlive-collection-latex texlive-collection-latexrecommended texlive-collection-luatex texlive-collection-mathscience texlive-collection-metapost texlive-collection-plaingeneric texlive-collection-xetex texlive-extratools texlive-scheme-medium

- Add debug and force mode to the TeXLive update script which
  might help to fix broken systems as well as might show some
  debug messages as well.
- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-a ====
Version update (2017.132.0.0.3svn15878 -> 2017.133.0.0.3svn15878)
Subpackages: texlive-12many texlive-12many-doc texlive-FAQ-en texlive-MemoirChapStyles texlive-SIstyle texlive-SIstyle-doc texlive-SIunits texlive-SIunits-doc texlive-Type1fonts texlive-a0poster texlive-a0poster-doc texlive-a2ping texlive-a2ping-doc texlive-a4wide texlive-a4wide-doc texlive-abbr texlive-abbr-doc texlive-abstyles texlive-abstyles-doc texlive-accfonts texlive-accfonts-doc texlive-adhocfilelist texlive-adhocfilelist-doc texlive-adjustbox texlive-adjustbox-doc texlive-advdate texlive-advdate-doc texlive-ae texlive-ae-doc texlive-aeguill texlive-aeguill-doc texlive-afm2pl texlive-afm2pl-doc texlive-alg texlive-alg-doc texlive-algorithm2e texlive-algorithm2e-doc texlive-algorithmicx texlive-algorithmicx-doc texlive-algorithms texlive-algorithms-doc texlive-amscls texlive-amscls-doc texlive-amsfonts texlive-amsfonts-doc texlive-amsfonts-fonts texlive-amslatex-primer texlive-amsldoc-it texlive-amsmath texlive-amsmath-doc texlive-amsmath-it texlive-amstex texlive-amstex-doc t
 exlive-amsthdoc-it texlive-anysize texlive-anysize-doc texlive-apalike-german texlive-apalike-german-doc texlive-apnum texlive-apnum-doc texlive-apprends-latex texlive-apxproof texlive-apxproof-doc texlive-arabxetex texlive-arabxetex-doc texlive-arara texlive-arara-doc texlive-armtex texlive-armtex-doc texlive-armtex-fonts

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-b ====
Version update (2017.132.svn15878 -> 2017.133.svn15878)
Subpackages: texlive-around-the-bend texlive-arphic texlive-arphic-doc texlive-arphic-fonts texlive-arydshln texlive-arydshln-doc texlive-ascii-chart texlive-asymptote texlive-asymptote-doc texlive-autoaligne texlive-autoaligne-doc texlive-autobreak texlive-autobreak-doc texlive-automata texlive-automata-doc texlive-avantgar texlive-avantgar-fonts texlive-awesomebox texlive-awesomebox-doc texlive-axodraw2 texlive-axodraw2-doc texlive-babel texlive-babel-albanian texlive-babel-albanian-doc texlive-babel-basque texlive-babel-basque-doc texlive-babel-bosnian texlive-babel-bosnian-doc texlive-babel-breton texlive-babel-breton-doc texlive-babel-catalan texlive-babel-catalan-doc texlive-babel-croatian texlive-babel-croatian-doc texlive-babel-czech texlive-babel-czech-doc texlive-babel-danish texlive-babel-danish-doc texlive-babel-doc texlive-babel-dutch texlive-babel-dutch-doc texlive-babel-english texlive-babel-english-doc texlive-babel-estonian texlive-babel-estonian-doc texlive-babel-fi
 nnish texlive-babel-finnish-doc texlive-babel-french texlive-babel-french-doc texlive-babel-friulan texlive-babel-friulan-doc texlive-babel-galician texlive-babel-galician-doc texlive-babel-german texlive-babel-german-doc texlive-babel-hebrew texlive-babel-hebrew-doc texlive-babel-hungarian texlive-babel-hungarian-doc texlive-babel-icelandic texlive-babel-icelandic-doc texlive-babel-irish texlive-babel-irish-doc texlive-babel-italian texlive-babel-italian-doc texlive-babel-kurmanji texlive-babel-kurmanji-doc texlive-babel-latin texlive-babel-latin-doc texlive-babel-latvian texlive-babel-latvian-doc texlive-babel-macedonian texlive-babel-macedonian-doc texlive-babel-norsk texlive-babel-norsk-doc texlive-babel-occitan texlive-babel-occitan-doc texlive-babel-piedmontese texlive-babel-piedmontese-doc texlive-babel-polish texlive-babel-polish-doc texlive-babel-portuges texlive-babel-portuges-doc texlive-babel-romanian texlive-babel-romanian-doc texlive-babel-romansh texlive-babel-romansh
 -doc texlive-babel-samin texlive-babel-samin-doc texlive-babel-scottish texlive-babel-scottish-doc texlive-babel-slovak texlive-babel-slovak-doc texlive-babel-slovenian texlive-babel-slovenian-doc texlive-babel-spanglish texlive-babel-spanglish-doc texlive-babel-spanish texlive-babel-spanish-doc texlive-babel-swedish texlive-babel-swedish-doc texlive-babel-turkish texlive-babel-turkish-doc texlive-babel-welsh texlive-babel-welsh-doc texlive-babelbib texlive-babelbib-doc texlive-background texlive-background-doc texlive-backnaur texlive-backnaur-doc texlive-barr texlive-barr-doc texlive-basque-book texlive-basque-book-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-c ====
Version update (2017.132.1.05svn26477 -> 2017.133.1.05svn26477)
Subpackages: texlive-basque-date texlive-basque-date-doc texlive-bbcard texlive-bbcard-doc texlive-bbding texlive-bbding-doc texlive-beamer texlive-beamer-doc texlive-beamer-tut-pt texlive-begriff texlive-begriff-doc texlive-bera texlive-bera-doc texlive-bera-fonts texlive-beton texlive-beton-doc texlive-bezos texlive-bezos-doc texlive-bguq texlive-bguq-doc texlive-bguq-fonts texlive-bib-fr texlive-bib-fr-doc texlive-biblatex texlive-biblatex-cheatsheet texlive-biblatex-doc texlive-bibleref texlive-bibleref-doc texlive-bibleref-french texlive-bibleref-french-doc texlive-bibleref-german texlive-bibleref-german-doc texlive-bibtex texlive-bibtex-doc texlive-bibtex8 texlive-bibtex8-doc texlive-bibtexu texlive-bibunits texlive-bibunits-doc texlive-bidi texlive-bidi-atbegshi texlive-bidi-atbegshi-doc texlive-bidi-doc texlive-bidicontour texlive-bidicontour-doc texlive-bidipagegrid texlive-bidipagegrid-doc texlive-bidipresentation texlive-bidipresentation-doc texlive-bidishadowtext texlive-
 bidishadowtext-doc texlive-bigfoot texlive-bigfoot-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-d ====
Version update (2017.132.1.0svn15878 -> 2017.133.1.0svn15878)
Subpackages: texlive-binomexp texlive-binomexp-doc texlive-biocon texlive-biocon-doc texlive-bitelist texlive-bitelist-doc texlive-bitpattern texlive-bitpattern-doc texlive-blockdraw_mp texlive-blockdraw_mp-doc texlive-bohr texlive-bohr-doc texlive-boldtensors texlive-boldtensors-doc texlive-bookman texlive-bookman-fonts texlive-booktabs texlive-booktabs-de texlive-booktabs-doc texlive-booktabs-fr texlive-borceux texlive-borceux-doc texlive-bosisio texlive-bosisio-doc texlive-boxedminipage texlive-boxedminipage-doc texlive-bpchem texlive-bpchem-doc texlive-bpolynomial texlive-bpolynomial-doc texlive-braket texlive-braket-doc texlive-breakcites texlive-breakcites-doc texlive-breakurl texlive-breakurl-doc texlive-bredzenie texlive-bredzenie-doc texlive-breqn texlive-breqn-doc texlive-bropd texlive-bropd-doc texlive-bundledoc texlive-bundledoc-doc texlive-bytefield texlive-bytefield-doc texlive-c-pascal texlive-c-pascal-doc texlive-calculation texlive-calculation-doc texlive-cancel texl
 ive-cancel-doc texlive-caption texlive-caption-doc texlive-carlisle texlive-carlisle-doc texlive-catcodes texlive-catcodes-doc texlive-cc-pl texlive-cc-pl-doc texlive-cc-pl-fonts texlive-ccaption texlive-ccaption-doc texlive-ccfonts texlive-ccfonts-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-e ====
Version update (2017.132.1.0csvn15878 -> 2017.133.1.0csvn15878)
Subpackages: texlive-changepage texlive-changepage-doc texlive-charter texlive-charter-doc texlive-charter-fonts texlive-checkcites texlive-checkcites-doc texlive-checklistings texlive-checklistings-doc texlive-chemarrow texlive-chemarrow-doc texlive-chemarrow-fonts texlive-chemcompounds texlive-chemcompounds-doc texlive-chemcono texlive-chemcono-doc texlive-chemexec texlive-chemexec-doc texlive-chemfig texlive-chemfig-doc texlive-chemformula texlive-chemformula-doc texlive-chemgreek texlive-chemgreek-doc texlive-chemmacros texlive-chemmacros-doc texlive-chemnum texlive-chemnum-doc texlive-chemschemex texlive-chemschemex-doc texlive-chemstyle texlive-chemstyle-doc texlive-chickenize texlive-chickenize-doc texlive-chktex texlive-chktex-doc texlive-chngcntr texlive-chngcntr-doc texlive-chronosys texlive-chronosys-doc texlive-cite texlive-cite-doc texlive-cjk texlive-cjk-doc texlive-cjk-ko texlive-cjk-ko-doc texlive-cloze texlive-cloze-doc texlive-clrscode texlive-clrscode-doc texlive-c
 lrscode3e texlive-clrscode3e-doc texlive-cm texlive-cm-doc texlive-cm-super texlive-cm-super-doc texlive-cm-super-fonts texlive-cmap texlive-cmap-doc texlive-cmarrows texlive-cmarrows-doc texlive-cmexb texlive-cmexb-doc texlive-cmexb-fonts texlive-cmextra texlive-cnbwp texlive-cnbwp-doc texlive-cns texlive-cns-doc texlive-codicefiscaleitaliano texlive-codicefiscaleitaliano-doc texlive-collectbox texlive-collectbox-doc texlive-colorsep texlive-colortbl texlive-colortbl-doc texlive-combofont texlive-combofont-doc texlive-commath texlive-commath-doc texlive-comment texlive-comment-doc texlive-complexity texlive-complexity-doc texlive-components-of-TeX texlive-comprehensive texlive-computational-complexity texlive-computational-complexity-doc texlive-concmath texlive-concmath-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-f ====
Version update (2017.132.svn15878 -> 2017.133.svn15878)
Subpackages: texlive-concrete texlive-concrete-doc texlive-conteq texlive-conteq-doc texlive-context texlive-context-account texlive-context-account-doc texlive-context-algorithmic texlive-context-animation texlive-context-animation-doc texlive-context-annotation texlive-context-annotation-doc texlive-context-bnf texlive-context-bnf-doc texlive-context-chromato texlive-context-chromato-doc texlive-context-cmscbf texlive-context-cmscbf-doc texlive-context-cmttbf texlive-context-cmttbf-doc texlive-context-construction-plan texlive-context-construction-plan-doc texlive-context-cyrillicnumbers texlive-context-cyrillicnumbers-doc texlive-context-degrade texlive-context-degrade-doc texlive-context-doc texlive-context-fancybreak texlive-context-fancybreak-doc texlive-context-filter texlive-context-filter-doc texlive-context-fonts texlive-context-french texlive-context-french-doc texlive-context-fullpage texlive-context-fullpage-doc texlive-context-gantt texlive-context-gantt-doc texlive-con
 text-gnuplot texlive-context-gnuplot-doc texlive-context-inifile texlive-context-inifile-doc texlive-context-layout texlive-context-layout-doc texlive-context-letter texlive-context-letter-doc texlive-context-lettrine texlive-context-lettrine-doc texlive-context-mathsets texlive-context-mathsets-doc texlive-context-notes-zh-cn texlive-context-rst texlive-context-rst-doc texlive-context-ruby texlive-context-ruby-doc texlive-context-simplefonts texlive-context-simplefonts-doc texlive-context-simpleslides texlive-context-simpleslides-doc texlive-context-title texlive-context-title-doc texlive-context-transliterator texlive-context-transliterator-doc texlive-context-typearea texlive-context-typearea-doc texlive-context-typescripts texlive-context-typescripts-doc texlive-context-vim texlive-context-vim-doc texlive-context-visualcounter texlive-context-visualcounter-doc texlive-coollist texlive-coollist-doc texlive-coolstr texlive-coolstr-doc texlive-correctmathalign texlive-correctmathal
 ign-doc texlive-courier texlive-courier-fonts texlive-courier-scaled texlive-courier-scaled-doc texlive-crop texlive-crop-doc texlive-cryptocode texlive-cryptocode-doc texlive-cs texlive-cs-fonts texlive-csbulletin texlive-csbulletin-doc texlive-cslatex texlive-csplain texlive-csquotes texlive-csquotes-de texlive-csquotes-doc texlive-cstex texlive-cstypo texlive-cstypo-doc texlive-ctable texlive-ctable-doc texlive-ctablestack texlive-ctablestack-doc texlive-ctan_chk texlive-ctanify texlive-ctanify-doc texlive-ctanupload texlive-ctanupload-doc texlive-ctie texlive-currfile texlive-currfile-doc texlive-cursolatex texlive-curves texlive-curves-doc texlive-cweb texlive-cweb-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-g ====
Version update (2017.132.1.5.2svn41686 -> 2017.133.1.5.2svn41686)
Subpackages: texlive-datetime2 texlive-datetime2-doc texlive-de-macro texlive-de-macro-doc texlive-dehyph-exptl texlive-dehyph-exptl-doc texlive-delim texlive-delim-doc texlive-delimseasy texlive-delimseasy-doc texlive-delimset texlive-delimset-doc texlive-detex texlive-dhua texlive-dhua-doc texlive-dickimaw texlive-diffcoeff texlive-diffcoeff-doc texlive-digiconfigs texlive-digiconfigs-doc texlive-dinat texlive-dinat-doc texlive-dingbat texlive-dingbat-doc texlive-dirtree texlive-dirtree-doc texlive-docbytex texlive-docbytex-doc texlive-docsurvey texlive-dosepsbin texlive-dosepsbin-doc texlive-dot2texi texlive-dot2texi-doc texlive-dowith texlive-dowith-doc texlive-draftcopy texlive-draftcopy-doc texlive-drawmatrix texlive-drawmatrix-doc texlive-drawstack texlive-drawstack-doc texlive-droit-fr texlive-droit-fr-doc texlive-drv texlive-drv-doc texlive-dtl

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-h ====
Version update (2017.132.1.07svn38419 -> 2017.133.1.07svn38419)
Subpackages: texlive-dtxgen texlive-dtxgen-doc texlive-dtxtut texlive-dviasm texlive-dviasm-doc texlive-dvicopy texlive-dvidvi texlive-dviincl texlive-dviincl-doc texlive-dviinfox texlive-dviinfox-doc texlive-dviljk texlive-dvipdfmx texlive-dvipdfmx-doc texlive-dvipng texlive-dvipos texlive-dvips texlive-dvips-doc texlive-dvipsconfig texlive-dvisvgm texlive-dyntree texlive-dyntree-doc texlive-e-french texlive-e-french-doc texlive-ebproof texlive-ebproof-doc texlive-ec texlive-ec-doc texlive-econometrics texlive-econometrics-doc texlive-eepic texlive-eepic-doc texlive-efbox texlive-efbox-doc texlive-eijkhout texlive-einfuehrung texlive-einfuehrung2 texlive-elements texlive-elements-doc texlive-ellipsis texlive-ellipsis-doc texlive-elocalloc texlive-elocalloc-doc texlive-eltex texlive-eltex-doc texlive-emf texlive-emf-doc texlive-emp texlive-emp-doc texlive-enctex texlive-enctex-doc texlive-encxvlna texlive-encxvlna-doc texlive-endfloat texlive-endfloat-doc texlive-endiagram texlive-en
 diagram-doc texlive-engrec texlive-engrec-doc texlive-engtlc texlive-engtlc-doc texlive-enigma texlive-enigma-doc texlive-enumitem texlive-enumitem-doc texlive-environ texlive-environ-doc texlive-epigram texlive-epsf texlive-epsf-doc texlive-epsf-dvipdfmx texlive-epsf-dvipdfmx-doc texlive-epsincl texlive-epsincl-doc texlive-epslatex-fr texlive-epstopdf texlive-epstopdf-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-i ====
Version update (2017.132.1.3svn20641 -> 2017.133.1.3svn20641)
Subpackages: texlive-eqnarray texlive-eqnarray-doc texlive-es-tex-faq texlive-eso-pic texlive-eso-pic-doc texlive-esvect texlive-esvect-doc texlive-esvect-fonts texlive-etdipa texlive-etex texlive-etex-doc texlive-etex-pkg texlive-etex-pkg-doc texlive-etextools texlive-etextools-doc texlive-etoolbox texlive-etoolbox-de texlive-etoolbox-doc texlive-euenc texlive-euenc-doc texlive-euler texlive-euler-doc texlive-euro texlive-euro-ce texlive-euro-ce-doc texlive-euro-doc texlive-eurosym texlive-eurosym-doc texlive-eurosym-fonts texlive-everyhook texlive-everyhook-doc texlive-everypage texlive-everypage-doc texlive-expressg texlive-expressg-doc texlive-extarrows texlive-extarrows-doc texlive-exteps texlive-exteps-doc texlive-extpfeil texlive-extpfeil-doc texlive-extsizes texlive-extsizes-doc texlive-facture texlive-facture-doc texlive-faktor texlive-faktor-doc texlive-fancybox texlive-fancybox-doc texlive-fancyhdr texlive-fancyhdr-doc texlive-fancyhdr-it texlive-fancylabel texlive-fancyla
 bel-doc texlive-fancyref texlive-fancyref-doc texlive-fancyvrb texlive-fancyvrb-doc texlive-featpost texlive-featpost-doc texlive-fenixpar texlive-fenixpar-doc texlive-feupphdteses texlive-feupphdteses-doc texlive-feynmf texlive-feynmf-doc texlive-feynmp-auto texlive-feynmp-auto-doc texlive-fifinddo-info texlive-fifinddo-info-doc texlive-figflow texlive-figflow-doc texlive-filecontents texlive-filecontents-doc texlive-filehook texlive-filehook-doc texlive-finbib texlive-findhyph texlive-findhyph-doc texlive-finstrut texlive-finstrut-doc texlive-first-latex-doc texlive-fix2col texlive-fix2col-doc texlive-fixlatvian texlive-fixlatvian-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-j ====
Version update (2017.132.0.0.4svn25832 -> 2017.133.0.0.4svn25832)
Subpackages: texlive-fixltxhyph texlive-fixltxhyph-doc texlive-fixpdfmag texlive-float texlive-float-doc texlive-floatrow texlive-floatrow-doc texlive-fltpoint texlive-fltpoint-doc texlive-fmtcount texlive-fmtcount-doc texlive-fnpara texlive-fnpara-doc texlive-fnspe texlive-fnspe-doc texlive-fntproof texlive-fntproof-doc texlive-font-change texlive-font-change-doc texlive-font-change-xetex texlive-font-change-xetex-doc texlive-fontaxes texlive-fontaxes-doc texlive-fontbook texlive-fontbook-doc texlive-fontch texlive-fontch-doc texlive-fontinst texlive-fontinst-doc texlive-fontname texlive-fontname-doc texlive-fontools texlive-fontools-doc texlive-fonts-tlwg texlive-fonts-tlwg-doc texlive-fonts-tlwg-fonts texlive-fontspec texlive-fontspec-doc texlive-fontware texlive-fontwrap texlive-fontwrap-doc texlive-footmisc texlive-footmisc-doc texlive-forest texlive-forest-doc texlive-forest-quickstart texlive-forloop texlive-forloop-doc texlive-formation-latex-ul texlive-formation-latex-ul-doc
  texlive-fouridx texlive-fouridx-doc texlive-fp texlive-fp-doc texlive-fpl texlive-fpl-doc texlive-fpl-fonts texlive-fragmaster texlive-fragmaster-doc texlive-framed texlive-framed-doc texlive-frletter texlive-frletter-doc texlive-frontespizio texlive-frontespizio-doc texlive-functan texlive-functan-doc texlive-fvextra texlive-fvextra-doc texlive-galois texlive-galois-doc texlive-garrigues texlive-garrigues-doc texlive-garuda-c90 texlive-gastex texlive-gastex-doc texlive-gates texlive-gates-doc texlive-gene-logic texlive-gene-logic-doc texlive-genmisc texlive-gentle texlive-geometry texlive-geometry-de texlive-geometry-doc texlive-german texlive-german-doc texlive-germbib texlive-germbib-doc texlive-germkorr texlive-germkorr-doc texlive-getoptk texlive-getoptk-doc texlive-gfnotation texlive-gfnotation-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-k ====
Version update (2017.132.4.8svn41714 -> 2017.133.4.8svn41714)
Subpackages: texlive-ghsystem texlive-ghsystem-doc texlive-gloss-occitan texlive-gloss-occitan-doc texlive-glyphlist texlive-gmp texlive-gmp-doc texlive-gobble texlive-gobble-doc texlive-gotoh texlive-gotoh-doc texlive-graphics texlive-graphics-cfg texlive-graphics-cfg-doc texlive-graphics-def texlive-graphics-def-doc texlive-graphics-doc texlive-graphics-pln texlive-graphics-pln-doc texlive-greek-fontenc texlive-greek-fontenc-doc texlive-grundgesetze texlive-grundgesetze-doc texlive-gsftopk texlive-gsftopk-doc texlive-gtl texlive-gtl-doc texlive-gu texlive-gu-doc texlive-guide-to-latex texlive-gustlib texlive-gustlib-doc texlive-gustprog texlive-happy4th texlive-hatching texlive-hatching-doc texlive-hausarbeit-jura texlive-hausarbeit-jura-doc texlive-helvetic texlive-helvetic-fonts texlive-hep texlive-hep-doc texlive-hepnames texlive-hepnames-doc texlive-hepparticles texlive-hepparticles-doc texlive-hepthesis texlive-hepthesis-doc texlive-hepunits texlive-hepunits-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-l ====
Version update (2017.132.0.0.1svn44158 -> 2017.133.0.0.1svn44158)
Subpackages: texlive-hlist texlive-hlist-doc texlive-hook-pre-commit-pkg texlive-hrlatex texlive-hrlatex-doc texlive-hyperref texlive-hyperref-doc texlive-hyph-utf8 texlive-hyph-utf8-doc texlive-hyphen-ancientgreek texlive-hyphen-base texlive-hyphen-basque texlive-hyphen-catalan texlive-hyphen-croatian texlive-hyphen-czech texlive-hyphen-danish texlive-hyphen-dutch texlive-hyphen-english texlive-hyphen-estonian texlive-hyphen-finnish texlive-hyphen-french texlive-hyphen-friulan texlive-hyphen-galician texlive-hyphen-german texlive-hyphen-greek texlive-hyphen-greek-doc texlive-hyphen-hungarian texlive-hyphen-hungarian-doc texlive-hyphen-icelandic texlive-hyphen-irish texlive-hyphen-italian texlive-hyphen-kurmanji texlive-hyphen-latin texlive-hyphen-latvian texlive-hyphen-lithuanian texlive-hyphen-norwegian texlive-hyphen-occitan texlive-hyphen-piedmontese texlive-hyphen-polish texlive-hyphen-portuguese texlive-hyphen-romanian texlive-hyphen-romansh texlive-hyphen-slovak texlive-hyphen
 -slovenian texlive-hyphen-spanish texlive-hyphen-spanish-doc texlive-hyphen-swedish texlive-hyphen-turkish texlive-hyphen-uppersorbian texlive-hyphen-welsh texlive-hyphenat texlive-hyphenat-doc texlive-hyphenex texlive-hyplain texlive-hyplain-doc texlive-ifetex texlive-ifetex-doc texlive-ifluatex texlive-ifluatex-doc texlive-ifmtarg texlive-ifmtarg-doc texlive-ifoddpage texlive-ifoddpage-doc texlive-ifplatform texlive-ifplatform-doc texlive-iftex texlive-iftex-doc texlive-ifxetex texlive-ifxetex-doc texlive-impatient texlive-impatient-fr texlive-impnattypo texlive-impnattypo-doc texlive-index texlive-index-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-m ====
Version update (2017.132.1.0svn15878 -> 2017.133.1.0svn15878)
Subpackages: texlive-inlinedef texlive-inlinedef-doc texlive-insbox texlive-insbox-doc texlive-interchar texlive-interchar-doc texlive-interpreter texlive-interpreter-doc texlive-interval texlive-interval-doc texlive-intro-scientific texlive-ionumbers texlive-ionumbers-doc texlive-isomath texlive-isomath-doc texlive-itnumpar texlive-itnumpar-doc texlive-jknapltx texlive-jknapltx-doc texlive-jmn texlive-jmn-fonts texlive-js-misc texlive-js-misc-doc texlive-jurabib texlive-jurabib-doc texlive-juramisc texlive-juramisc-doc texlive-kantlipsum texlive-kantlipsum-doc texlive-karnaugh texlive-karnaugh-doc texlive-karnaugh-map texlive-karnaugh-map-doc texlive-karnaughmap texlive-karnaughmap-doc texlive-kastrup texlive-kastrup-doc texlive-knuth texlive-knuth-doc texlive-knuth-lib texlive-knuth-local texlive-koma-script texlive-koma-script-doc texlive-koma-script-examples texlive-kotex-utf texlive-kotex-utf-doc texlive-kpathsea texlive-kpathsea-doc texlive-l2picfaq texlive-l2tabu texlive-l2tab
 u-english texlive-l2tabu-french texlive-l2tabu-italian texlive-l2tabu-spanish texlive-l3experimental texlive-l3experimental-doc texlive-l3kernel texlive-l3kernel-doc texlive-l3packages texlive-l3packages-doc texlive-lacheck texlive-lambda-lists texlive-lambda-lists-doc texlive-langcode texlive-langcode-doc texlive-latex texlive-latex-bib-ex texlive-latex-bib2-ex texlive-latex-bin texlive-latex-brochure texlive-latex-course texlive-latex-doc texlive-latex-doc-ptr texlive-latex-fonts texlive-latex-fonts-doc texlive-latex-git-log texlive-latex-git-log-doc texlive-latex-graphics-companion

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-n ====
Version update (2017.132.1.62svn42296 -> 2017.133.1.62svn42296)
Subpackages: texlive-latex-papersize texlive-latex-papersize-doc texlive-latex-referenz texlive-latex-tabellen texlive-latex-veryshortguide texlive-latex-web-companion texlive-latex2e-help-texinfo texlive-latex2e-help-texinfo-fr texlive-latex2e-help-texinfo-spanish texlive-latex2man texlive-latex2man-doc texlive-latex2nemeth texlive-latex2nemeth-doc texlive-latex4wp texlive-latex4wp-it texlive-latexbug texlive-latexbug-doc texlive-latexcheat texlive-latexcheat-de texlive-latexcheat-esmx texlive-latexcheat-ptbr texlive-latexconfig texlive-latexcourse-rug texlive-latexdiff texlive-latexdiff-doc texlive-latexfileinfo-pkgs texlive-latexfileinfo-pkgs-doc texlive-latexfileversion texlive-latexfileversion-doc texlive-latexindent texlive-latexindent-doc texlive-latexmk texlive-latexmk-doc texlive-latexmp texlive-latexmp-doc texlive-latexpand texlive-latexpand-doc texlive-layaureo texlive-layaureo-doc texlive-lcdftypetools texlive-lecturer texlive-lecturer-doc texlive-lettrine texlive-lettrin
 e-doc texlive-librarian texlive-librarian-doc texlive-lineno texlive-lineno-doc texlive-lipsum texlive-lipsum-doc texlive-listings texlive-listings-doc texlive-listings-ext texlive-listings-ext-doc texlive-listofitems texlive-listofitems-doc texlive-lithuanian texlive-lithuanian-doc texlive-lm texlive-lm-doc texlive-lm-fonts texlive-lm-math texlive-lm-math-doc texlive-lm-math-fonts texlive-logicproof texlive-logicproof-doc texlive-logreq texlive-logreq-doc texlive-longdivision texlive-longdivision-doc texlive-lpform texlive-lpform-doc texlive-lplfitch texlive-lplfitch-doc texlive-lshort-czech texlive-lshort-dutch texlive-lshort-english texlive-lshort-estonian texlive-lshort-finnish texlive-lshort-french texlive-lshort-german

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-o ====
Version update (2017.132.svn15878 -> 2017.133.svn15878)
Subpackages: texlive-lshort-italian texlive-lshort-polish texlive-lshort-portuguese texlive-lshort-slovak texlive-lshort-slovenian texlive-lshort-spanish texlive-lshort-turkish texlive-lstbayes texlive-lstbayes-doc texlive-ltxfileinfo texlive-ltxfileinfo-doc texlive-ltximg texlive-ltximg-doc texlive-ltxmisc texlive-lua-alt-getopt texlive-lua-alt-getopt-doc texlive-lua-check-hyphen texlive-lua-check-hyphen-doc texlive-lua-visual-debug texlive-lua-visual-debug-doc texlive-lua2dox texlive-lua2dox-doc texlive-luabibentry texlive-luabibentry-doc texlive-luabidi texlive-luabidi-doc texlive-luacode texlive-luacode-doc texlive-luahyphenrules texlive-luahyphenrules-doc texlive-luaindex texlive-luaindex-doc texlive-luainputenc texlive-luainputenc-doc texlive-luaintro texlive-lualatex-doc texlive-lualatex-doc-de texlive-lualatex-math texlive-lualatex-math-doc texlive-lualibs texlive-lualibs-doc texlive-luamplib texlive-luamplib-doc texlive-luaotfload texlive-luaotfload-doc texlive-luapackageloa
 der texlive-luapackageloader-doc texlive-luasseq texlive-luasseq-doc texlive-luatex texlive-luatex-doc texlive-luatex85 texlive-luatex85-doc texlive-luatexbase texlive-luatexbase-doc texlive-luatexko texlive-luatexko-doc texlive-luatextra texlive-luatextra-doc texlive-luatodonotes texlive-luatodonotes-doc texlive-luaxml texlive-luaxml-doc texlive-lwarp texlive-lwarp-doc texlive-macros2e texlive-mafr texlive-mafr-doc texlive-make4ht texlive-make4ht-doc texlive-makecmds texlive-makecmds-doc texlive-makeindex texlive-makeindex-doc texlive-manfnt texlive-manfnt-font texlive-manfnt-font-fonts texlive-marginnote texlive-marginnote-doc texlive-marvosym texlive-marvosym-doc texlive-marvosym-fonts texlive-match_parens texlive-match_parens-doc texlive-math-e texlive-math-into-latex-4 texlive-mathcomp texlive-mathcomp-doc texlive-mathdots texlive-mathdots-doc texlive-mathpartir texlive-mathpartir-doc texlive-mathpazo texlive-mathpazo-doc texlive-mathpazo-fonts texlive-mathpunctspace texlive-ma
 thpunctspace-doc texlive-maths-symbols texlive-mathspec texlive-mathspec-doc texlive-mathtools texlive-mathtools-doc texlive-matlab-prettifier texlive-matlab-prettifier-doc texlive-mattens texlive-mattens-doc texlive-mcf2graph texlive-mcf2graph-doc texlive-mdframed texlive-mdframed-doc texlive-mdwtools texlive-mdwtools-doc texlive-media9 texlive-media9-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-p ====
Version update (2017.132.svn34157 -> 2017.133.svn34157)
Subpackages: texlive-memdesign texlive-memoir texlive-memoir-doc texlive-metafont texlive-metafont-beginners texlive-metafont-doc texlive-metago texlive-metago-doc texlive-metalogo texlive-metalogo-doc texlive-metaobj texlive-metaobj-doc texlive-metaplot texlive-metaplot-doc texlive-metapost texlive-metapost-doc texlive-metapost-examples texlive-metapost-fonts texlive-metatex texlive-metatex-doc texlive-metatype1 texlive-metauml texlive-metauml-doc texlive-mex texlive-mex-doc texlive-mf2pt1 texlive-mf2pt1-doc texlive-mflogo texlive-mflogo-doc texlive-mflogo-font texlive-mflogo-font-doc texlive-mflogo-font-fonts texlive-mflua texlive-mfnfss texlive-mfnfss-doc texlive-mfpic texlive-mfpic-doc texlive-mfpic4ode texlive-mfpic4ode-doc texlive-mfware texlive-mfware-doc texlive-mgltex texlive-mgltex-doc texlive-mhchem texlive-mhchem-doc texlive-mhequ texlive-mhequ-doc texlive-microtype texlive-microtype-de texlive-microtype-doc texlive-midnight texlive-midnight-doc texlive-miller texlive-mil
 ler-doc texlive-milog texlive-milog-doc texlive-minitoc texlive-minitoc-doc texlive-mkjobtexmf texlive-mkjobtexmf-doc texlive-mkpattern texlive-mkpattern-doc texlive-morefloats texlive-morefloats-doc texlive-moreverb texlive-moreverb-doc texlive-movie15 texlive-movie15-doc texlive-mp3d texlive-mp3d-doc texlive-mparhack texlive-mparhack-doc texlive-mparrows texlive-mparrows-doc texlive-mpattern texlive-mpattern-doc texlive-mpcolornames texlive-mpcolornames-doc texlive-mpgraphics texlive-mpgraphics-doc texlive-mptopdf texlive-mptopdf-doc texlive-mptrees texlive-mptrees-doc texlive-ms texlive-ms-doc texlive-msg texlive-msg-doc texlive-multido texlive-multido-doc texlive-multiobjective texlive-multiobjective-doc texlive-multirow texlive-multirow-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-q ====
Version update (2017.132.0.0.75svn44352 -> 2017.133.0.0.75svn44352)
Subpackages: texlive-mwcls texlive-mwcls-doc texlive-mweights texlive-mweights-doc texlive-mychemistry texlive-mychemistry-doc texlive-nag texlive-nag-doc texlive-natbib texlive-natbib-doc texlive-natded texlive-natded-doc texlive-nath texlive-nath-doc texlive-navigator texlive-navigator-doc texlive-ncctools texlive-ncctools-doc texlive-ncntrsbk texlive-ncntrsbk-fonts texlive-needspace texlive-needspace-doc texlive-nevelok texlive-nevelok-doc texlive-newsletr texlive-newsletr-doc texlive-newunicodechar texlive-newunicodechar-doc texlive-nodetree texlive-nodetree-doc texlive-norasi-c90 texlive-notoccite texlive-notoccite-doc texlive-ntgclass texlive-ntgclass-doc texlive-ntheorem texlive-ntheorem-doc texlive-nuc texlive-nuc-doc texlive-nucleardata texlive-nucleardata-doc texlive-numprint texlive-numprint-doc texlive-oberdiek texlive-oberdiek-doc texlive-objectz texlive-objectz-doc texlive-ocgx2 texlive-ocgx2-doc texlive-odsfile texlive-odsfile-doc texlive-ofs texlive-ofs-doc texlive-ol
 sak-misc texlive-olsak-misc-doc texlive-oplotsymbl texlive-oplotsymbl-doc texlive-optional texlive-optional-doc texlive-ordinalpt texlive-ordinalpt-doc texlive-ot-tableau texlive-ot-tableau-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-r ====
Version update (2017.132.svn21833 -> 2017.133.svn21833)
Subpackages: texlive-oubraces texlive-oubraces-doc texlive-palatino texlive-palatino-fonts texlive-paralist texlive-paralist-doc texlive-parallel texlive-parallel-doc texlive-parskip texlive-parskip-doc texlive-patgen texlive-patgen2-tutorial texlive-path texlive-path-doc texlive-pbox texlive-pbox-doc texlive-pdf-trans texlive-pdf-trans-doc texlive-pdfbook2 texlive-pdfbook2-doc texlive-pdfcrop texlive-pdfcrop-doc texlive-pdfjam texlive-pdfjam-doc texlive-pdflatexpicscale texlive-pdflatexpicscale-doc texlive-pdfpages texlive-pdfpages-doc texlive-pdftex texlive-pdftex-doc texlive-pdftex-fonts texlive-pdftools texlive-pdftools-doc texlive-pdfxup texlive-pdfxup-doc texlive-perfectcut texlive-perfectcut-doc texlive-pfarrei texlive-pfarrei-doc texlive-pgf texlive-pgf-doc texlive-pgfgantt texlive-pgfgantt-doc texlive-pgfopts texlive-pgfopts-doc texlive-pgfplots texlive-pgfplots-doc texlive-philokalia texlive-philokalia-doc texlive-philokalia-fonts texlive-physics texlive-physics-doc texlive
 -pict2e texlive-pict2e-doc texlive-pictexsum texlive-piechartmp texlive-piechartmp-doc texlive-pitex texlive-pitex-doc texlive-pkfix texlive-pkfix-doc texlive-pkfix-helper texlive-pkfix-helper-doc texlive-pl texlive-pl-doc texlive-pl-fonts texlive-placeat texlive-placeat-doc texlive-placeins texlive-placeins-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-s ====
Version update (2017.132.2.0svn15878 -> 2017.133.2.0svn15878)
Subpackages: texlive-placeins-plain texlive-plain texlive-plain-doc texlive-plainpkg texlive-plainpkg-doc texlive-plipsum texlive-plipsum-doc texlive-plnfss texlive-plnfss-doc texlive-plstmary texlive-plstmary-doc texlive-polski texlive-polski-doc texlive-polyglossia texlive-polyglossia-doc texlive-powerdot texlive-powerdot-doc texlive-present texlive-present-doc texlive-presentations texlive-presentations-en texlive-preview texlive-preview-doc texlive-prftree texlive-prftree-doc texlive-printlen texlive-printlen-doc texlive-proba texlive-proba-doc texlive-prooftrees texlive-prooftrees-doc texlive-przechlewski-book texlive-przechlewski-book-doc texlive-ps2pk texlive-pseudocode texlive-pseudocode-doc texlive-psfrag texlive-psfrag-doc texlive-psfrag-italian texlive-pslatex texlive-psnfss texlive-psnfss-doc texlive-pspicture texlive-pspicture-doc texlive-pst-3d texlive-pst-3d-doc texlive-pst-blur texlive-pst-blur-doc texlive-pst-coil texlive-pst-coil-doc texlive-pst-eps texlive-pst-eps-
 doc texlive-pst-fill texlive-pst-fill-doc texlive-pst-grad texlive-pst-grad-doc texlive-pst-math texlive-pst-math-doc texlive-pst-node texlive-pst-node-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-t ====
Version update (2017.132.0.0.07svn40873 -> 2017.133.0.0.07svn40873)
Subpackages: texlive-pst-ovl texlive-pst-ovl-doc texlive-pst-pdf texlive-pst-pdf-doc texlive-pst-plot texlive-pst-plot-doc texlive-pst-slpe texlive-pst-slpe-doc texlive-pst-text texlive-pst-text-doc texlive-pst-tree texlive-pst-tree-doc texlive-pstools texlive-pstools-doc texlive-pstricks texlive-pstricks-add texlive-pstricks-add-doc texlive-pstricks-doc texlive-ptext texlive-ptext-doc texlive-purifyeps texlive-purifyeps-doc texlive-pxfonts texlive-pxfonts-doc texlive-pxfonts-fonts texlive-pygmentex texlive-pygmentex-doc texlive-pythonhighlight texlive-pythonhighlight-doc texlive-pythontex texlive-pythontex-doc texlive-qpxqtx texlive-qpxqtx-doc texlive-qstest texlive-qstest-doc texlive-quran texlive-quran-doc texlive-r_und_s texlive-r_und_s-doc texlive-randomlist texlive-randomlist-doc texlive-rcs texlive-rcs-doc texlive-realscripts texlive-realscripts-doc texlive-rec-thy texlive-rec-thy-doc texlive-regexpatch texlive-regexpatch-doc texlive-relsize texlive-relsize-doc texlive-repere
 texlive-repere-doc texlive-resumemac texlive-resumemac-doc texlive-revquantum texlive-revquantum-doc texlive-ribbonproofs texlive-ribbonproofs-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-u ====
Version update (2017.132.1.0.3svn40415 -> 2017.133.1.0.3svn40415)
Subpackages: texlive-rmathbr texlive-rmathbr-doc texlive-roex texlive-roundrect texlive-roundrect-doc texlive-rsfs texlive-rsfs-doc texlive-rsfs-fonts texlive-ruhyphen texlive-sansmath texlive-sansmath-doc texlive-sasnrdisplay texlive-sasnrdisplay-doc texlive-sauerj texlive-sauerj-doc texlive-scalerel texlive-scalerel-doc texlive-schemata texlive-schemata-doc texlive-sciposter texlive-sciposter-doc texlive-sclang-prettifier texlive-sclang-prettifier-doc texlive-section texlive-section-doc texlive-sectsty texlive-sectsty-doc texlive-seetexk texlive-selnolig texlive-selnolig-doc texlive-seminar texlive-seminar-doc texlive-sepnum texlive-sepnum-doc texlive-sesamanuel texlive-sesamanuel-doc texlive-setspace texlive-setspace-doc texlive-sfg texlive-sfg-doc texlive-shade texlive-shade-doc texlive-shadow texlive-shadow-doc texlive-shapes texlive-shapes-doc texlive-showexpl texlive-showexpl-doc texlive-showhyphens texlive-showhyphens-doc texlive-shuffle texlive-shuffle-doc texlive-simple-res
 ume-cv texlive-simple-resume-cv-doc texlive-simple-thesis-dissertation texlive-simple-thesis-dissertation-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-v ====
Version update (2017.132.1.0.0svn39074 -> 2017.133.1.0.0svn39074)
Subpackages: texlive-simpler-wick texlive-simpler-wick-doc texlive-simplewick texlive-simplewick-doc texlive-simplified-latex texlive-siunitx texlive-siunitx-doc texlive-skmath texlive-skmath-doc texlive-slideshow texlive-slideshow-doc texlive-soul texlive-soul-doc texlive-sourcecodepro texlive-sourcecodepro-doc texlive-sourcecodepro-fonts texlive-spalign texlive-spalign-doc texlive-spanish-mx texlive-spanish-mx-doc texlive-spelling texlive-spelling-doc texlive-splines texlive-splines-doc texlive-srcredact texlive-srcredact-doc texlive-stanli texlive-stanli-doc texlive-statex texlive-statex-doc texlive-statex2 texlive-statex2-doc texlive-steinmetz texlive-steinmetz-doc texlive-stmaryrd texlive-stmaryrd-doc texlive-stmaryrd-fonts texlive-struktex texlive-struktex-doc texlive-sty2dtx texlive-sty2dtx-doc texlive-suanpan texlive-suanpan-doc texlive-subdepth texlive-subdepth-doc texlive-subfig texlive-subfig-doc texlive-subfigure texlive-subfigure-doc texlive-substances texlive-substances
 -doc texlive-subsupscripts texlive-subsupscripts-doc texlive-susy texlive-susy-doc texlive-svg-inkscape texlive-svn-prov texlive-svn-prov-doc texlive-swebib texlive-swebib-doc texlive-syllogism texlive-syllogism-doc texlive-symbol texlive-symbol-fonts texlive-sympytexpackage texlive-sympytexpackage-doc texlive-synctex texlive-synproof texlive-synproof-doc texlive-systeme texlive-systeme-doc texlive-t-angles texlive-t-angles-doc texlive-t2 texlive-t2-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-w ====
Version update (2017.132.4.07_gsvn31855 -> 2017.134.4.07_gsvn31855)
Subpackages: texlive-tablor texlive-tablor-doc texlive-tabto-generic texlive-tabulars-e texlive-tabulary texlive-tabulary-doc texlive-tabvar texlive-tabvar-doc texlive-tabvar-fonts texlive-tamethebeast texlive-tap texlive-tap-doc texlive-tds texlive-tdsfrmath texlive-tdsfrmath-doc texlive-templates-fenn texlive-templates-sommer texlive-tensor texlive-tensor-doc texlive-termmenu texlive-termmenu-doc texlive-tetex texlive-tetex-doc texlive-tex texlive-tex-ewd texlive-tex-ewd-doc texlive-tex-font-errors-cheatsheet texlive-tex-gyre texlive-tex-gyre-doc texlive-tex-gyre-fonts texlive-tex-gyre-math texlive-tex-gyre-math-doc texlive-tex-gyre-math-fonts texlive-tex-ini-files texlive-tex-ini-files-doc texlive-tex-overview texlive-tex-ps texlive-tex-ps-doc texlive-tex-refs texlive-tex-virtual-academy-pl texlive-tex4ebook texlive-tex4ebook-doc texlive-tex4ht texlive-tex4ht-doc texlive-texapi texlive-texapi-doc texlive-texbytopic texlive-texconfig texlive-texconfig-doc texlive-texcount texlive-t
 excount-doc texlive-texdef texlive-texdef-doc texlive-texdiff texlive-texdiff-doc texlive-texdirflatten texlive-texdirflatten-doc texlive-texdoc texlive-texdoc-doc texlive-texfot texlive-texfot-doc texlive-texinfo texlive-texlive-common texlive-texlive-cz texlive-texlive-de texlive-texlive-en texlive-texlive-es texlive-texlive-fr texlive-texlive-it texlive-texlive-pl texlive-texlive.infra texlive-texlive.infra-doc texlive-texliveonfly texlive-texliveonfly-doc texlive-texloganalyser texlive-texloganalyser-doc texlive-texosquery texlive-texosquery-doc texlive-textcase texlive-textcase-doc texlive-textgreek texlive-textgreek-doc texlive-textopo texlive-textopo-doc texlive-textpath texlive-textpath-doc texlive-texware texlive-thmbox texlive-thmbox-doc texlive-threeddice texlive-threeddice-doc texlive-thumbpdf texlive-thumbpdf-doc texlive-tie

- Avoid nasty warning about missing batchmode in ENVironment
- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-x ====
Version update (2017.132.svn35058 -> 2017.133.svn35058)
Subpackages: texlive-times texlive-times-fonts texlive-timetable texlive-tipa texlive-tipa-de texlive-tipa-doc texlive-tipa-fonts texlive-titlepages texlive-titlesec texlive-titlesec-doc texlive-titling texlive-titling-doc texlive-tkz-tab texlive-tkz-tab-doc texlive-tlc2 texlive-tocbibind texlive-tocbibind-doc texlive-tools texlive-tools-doc texlive-tpic2pdftex texlive-tracklang texlive-tracklang-doc texlive-translation-array-fr texlive-translation-arsclassica-de texlive-translation-biblatex-de texlive-translation-chemsym-de texlive-translation-dcolumn-fr texlive-translation-ecv-de texlive-translation-enumitem-de texlive-translation-europecv-de texlive-translation-filecontents-de texlive-translation-moreverb-de texlive-translation-natbib-fr texlive-translation-tabbing-fr texlive-translations texlive-translations-doc texlive-treetex texlive-treetex-doc texlive-trigonometry texlive-trigonometry-doc texlive-trimspaces texlive-trimspaces-doc texlive-ttfutils texlive-ttfutils-doc texlive-
 turkmen texlive-turkmen-doc texlive-turnstile texlive-turnstile-doc texlive-txfonts texlive-txfonts-doc texlive-txfonts-fonts texlive-type1cm texlive-type1cm-doc texlive-typehtml texlive-typehtml-doc texlive-typeoutfileinfo texlive-typeoutfileinfo-doc texlive-ucharcat texlive-ucharcat-doc texlive-ucharclasses texlive-ucharclasses-doc texlive-ucs texlive-ucs-doc

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-y ====
Version update (2017.132.1.6.0svn44308 -> 2017.133.1.6.0svn44308)
Subpackages: texlive-udesoftec texlive-udesoftec-doc texlive-uhc texlive-uhc-doc texlive-uhc-fonts texlive-uhrzeit texlive-uhrzeit-doc texlive-ukrhyph texlive-ukrhyph-doc texlive-ulem texlive-ulem-doc texlive-ulqda texlive-ulqda-doc texlive-umlaute texlive-umlaute-doc texlive-undergradmath texlive-underscore texlive-underscore-doc texlive-unicode-bidi texlive-unicode-bidi-doc texlive-unicode-data texlive-unicode-data-doc texlive-unicode-math texlive-unicode-math-doc texlive-unisugar texlive-unisugar-doc texlive-units texlive-units-doc texlive-unitsdef texlive-unitsdef-doc texlive-upca texlive-upca-doc texlive-updmap-map texlive-upquote texlive-upquote-doc texlive-url texlive-url-doc texlive-utf8mex texlive-utf8mex-doc texlive-utopia texlive-utopia-doc texlive-utopia-fonts texlive-variations texlive-variations-doc texlive-varisize texlive-varisize-doc texlive-varwidth texlive-varwidth-doc texlive-venn texlive-venn-doc texlive-visualfaq texlive-visualtikz texlive-vlna texlive-voss-math
 col texlive-wadalab texlive-wadalab-doc texlive-wadalab-fonts texlive-was texlive-was-doc texlive-wasy texlive-wasy-doc texlive-wasy2-ps texlive-wasy2-ps-doc texlive-wasy2-ps-fonts texlive-wasysym texlive-wasysym-doc texlive-web texlive-webguide

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== texlive-specs-z ====
Version update (2017.132.1.1svn15878 -> 2017.133.1.1svn15878)
Subpackages: texlive-xargs texlive-xargs-doc texlive-xcolor texlive-xcolor-doc texlive-xdvi texlive-xdvi-doc texlive-xebaposter texlive-xebaposter-doc texlive-xecjk texlive-xecjk-doc texlive-xecolor texlive-xecolor-doc texlive-xecyr texlive-xecyr-doc texlive-xeindex texlive-xeindex-doc texlive-xesearch texlive-xesearch-doc texlive-xespotcolor texlive-xespotcolor-doc texlive-xetex texlive-xetex-doc texlive-xetex-itrans texlive-xetex-itrans-doc texlive-xetex-pstricks texlive-xetex-pstricks-doc texlive-xetex-tibetan texlive-xetex-tibetan-doc texlive-xetexconfig texlive-xetexfontinfo texlive-xetexfontinfo-doc texlive-xetexko texlive-xetexko-doc texlive-xetexref texlive-xevlna texlive-xevlna-doc texlive-xifthen texlive-xifthen-doc texlive-xii texlive-xkeyval texlive-xkeyval-doc texlive-xlop texlive-xlop-doc texlive-xltxtra texlive-xltxtra-doc texlive-xpatch texlive-xpatch-doc texlive-xstring texlive-xstring-doc texlive-xunicode texlive-xunicode-doc texlive-xymtex texlive-xymtex-doc texliv
 e-xypic-tut-pt texlive-yax texlive-yax-doc texlive-yhmath texlive-yhmath-doc texlive-yhmath-fonts texlive-youngtab texlive-youngtab-doc texlive-ytableau texlive-ytableau-doc texlive-zapfchan texlive-zapfchan-fonts texlive-zapfding texlive-zapfding-fonts

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

==== totem ====
Subpackages: nautilus-totem totem-lang totem-plugins

- Add totem-thumbnailer-blacklist-fixes.patch: Fixes to the
  thumbnailer blacklists plugins (bgo#790491).

==== tracker ====
Subpackages: libtracker-common-2_0 libtracker-control-2_0-0 libtracker-miner-2_0-0 libtracker-sparql-2_0-0 tracker-lang typelib-1_0-Tracker-2_0 typelib-1_0-TrackerControl-2_0

- Add tracker-nb-translations.patch: Update Norwegian bokmål
  translations.

==== tracker-miners ====
Subpackages: tracker-miner-files tracker-miners-lang

- Add tracker-miners-nb-translations.patch: Update Norwegian Bokmål
  translations.

==== transmission ====
Subpackages: transmission-common transmission-gtk transmission-gtk-lang

- Add CVE-2018-5072.patch (backported from
  gh#transmission/transmission#468):  Mitigate dns rebind attacks
  against daemon (boo#1075921, CVE-2018-5072).
- Conditionalize usage of desktop_database_post/postun macros to
  suse_version < 1500: recent versions use file triggers.
- Add %check session: run make check.

==== ucode-intel ====
Version update (20180108 -> 20171117)

- Update to microcode version: 20171117 (bsc#1068839)
  - - New Platforms --
  CFL U0 (06-9e-0a:22) 70
  CFL B0 (06-9e-0b:2) 72
  SKX H0 (06-55-04:b7) 2000035
  GLK B0 (06-7a-01:1) 1e
  APL Bx (06-5c-09:3) 2c
  - - Updates --
  KBL Y0 (06-8e-0a:c0) 66->70
- Remove code in intel-microcode2ucode.c that refers to
  GenuineIntel.bin , previously in binary blob package.
- Remove binary blob package again. This was intended to be used
  by linuxrc, but the firmware files can simply be concatenated.
- Update to version 20170707 (bsc#1048133, bsc#1043358):
  KBL H0 (06-8e-09:c0) 62
  KBL Y0 (06-8e-0a:c0) 66
  KBL B0 (06-9e-09:2a) 5e
  SKX H0 (06-55-04:97) 2000022
- Update to version 20170511:
  BDX-ML B0/M0/R0 (06-4f-01:ef) b00001f->b000021
  Skylake D0 (06-4e-03:c0) 9e->ba
  Broadwell ULT/ULX E/F-step (06-3d-04:c0) 24->25
  ULT Cx/Dx (06-45-01:72) 1f->20
  Crystalwell Cx (06-46-01:32) 16->17
  Broadwell Halo E/G-step (06-47-01:22) 16->17
  HSX EX E0 (06-3f-04:80) d->f
  Skylake R0 (06-5e-03:36) 9e->ba
  Haswell Cx/Dx (06-3c-03:32) 20->22
  HSX C0 (06-3f-02:6f) 39->3a
- Update to version 20161104.
- Update to version 20160714.
- Should fix bsc#987358, a bug which got introduced with the last
  release.
- Should finally fix "Intel Skylake bug" (bnc#993639), previous
  releases since Jan 2016 may or may not have completely fixed it.
- Update to version 20160607, no changelog available
- Fix dependency on coreutils for initrd macros (boo#958562)
- Call missing initrd macro at postun (boo#958562)
- Fix Url and Source0
- Add GenuineIntel.bin to ucode-intel-blob
- Update to version 20151106
  * No changelog available
- Use download Url as source
- Add ucode-intel-blob subpackage to get the full microcode.dat
    directly
- Update to microcode 20150121.
- Pre require coreutils (bnc#914169).
- Do not try to reload/update microcode at runtime after package
  installation. Only supported way of updating microcode is via
  early microcode update via initrd. bnc#896736
- Update to Intel microcode version 20140624 (bnc#896736, fate#317896)
  This microcode disables lock elision on CPUs which are known to
  not work reliable with this feature
- Update to Intel microcode version 20140624 (bnc#885213)
- Delete mkinitrd scripts. This is done via %rpm regenerate_initrd_* macros
  (bnc#894160)
- Update to Intel microcode version 20140430 (bnc#876073)
- Regenerate the initrd in %posttrans (fate#313506)
- ucode 20140122, no changelog available.
- Loading firmware needs udev to be running
- Add mkinitrd script to add Intel microcode to initrd.
  This is needed because microcode driver is built in or gets loaded
  automatically via udev early. Therefore the microcode has to be available
  in initrd already.
  This must not be mixed up with early micorcode loading. This feature will
  not be implemented via mkinitrd. Dracut is doing early microcode loading.
- bnc#847158
- mkinitrd scripts:
  - mkinitrd_setup-intel_microcode.sh
    Adding microcode to the initrd
  - mkinitrd_boot-intel_microcode.sh
    Triggering the reload at boot
- Correct Supplements string so that the package gets correctly installed
  on machines with Intel CPUs
  bnc#847158
- ucode 20130906, no changelog available.
- ucode 20130808, as usual, no changelog available.
- Run spec-cleaner
- Initial packaging. Moved microcode from microctl_ctl package.

==== update-alternatives ====
Version update (1.18.23 -> 1.19.0.4)

- Update to 1.19.0.4:
  * No changes in update-alternatives just match step with dpkg
- Drop patch 0001-In-case-of-equal-priority-rather-update.patch
  * Causes issues on too eagerly regenerating stuff bsc#1075971
  * Reason for this patch should no longer be needed as all python
    packages are singlespec
  * Also drop the post override

==== webkit2gtk3 ====
Version update (2.18.4 -> 2.18.5)
Subpackages: libjavascriptcoregtk-4_0-18 libwebkit2gtk-4_0-37 libwebkit2gtk3-lang typelib-1_0-JavaScriptCore-4_0 typelib-1_0-WebKit2-4_0 webkit2gtk-4_0-injected-bundles

- Update to version 2.18.5:
  + Disable SharedArrayBuffers from Web API.
  + Reduce the precision of ?high? resolution time to 1ms.
  + Fix API documentation generation with newer gtk-doc.
  + bsc#1075419 - Security fixes: includes improvements to mitigate
    the effects of Spectre (CVE-2017-5753 and CVE-2017-5715).

==== wireless-regdb ====
Version update (2017.03.07 -> 2017.12.23)

- Update to version 2017.12.23 (boo#1074838):
  * update regulatory database based on preceding changes
  * Document regulatory.db in the manual page
  * Install regulatory.db and regulatory.db.p7s to /lib/firmware
  * Better support for generating public certificates
  * Add sforshee's x509 certificate
  * Restore generation of old format database files
  * regdb: write firmware file format (version code 20)

==== wxWidgets-3_0 ====
Subpackages: libwx_baseu-suse3 libwx_baseu_net-suse3 libwx_baseu_xml-suse3 libwx_gtk2u_adv-suse3 libwx_gtk2u_aui-suse3 libwx_gtk2u_core-suse3 libwx_gtk2u_gl-suse3 libwx_gtk2u_html-suse3 libwx_gtk2u_media-suse3 libwx_gtk2u_propgrid-suse3 libwx_gtk2u_richtext-suse3 libwx_gtk2u_stc-suse3 libwx_gtk2u_xrc-suse3 wxWidgets-lang

- Rework provides/conflicts between -devel variants.

==== wxWidgets-3_0-nostl ====
Subpackages: libwx_baseu-suse-nostl3 libwx_baseu_net-suse-nostl3 libwx_baseu_xml-suse-nostl3 libwx_gtk2u_adv-suse-nostl3 libwx_gtk2u_core-suse-nostl3 libwx_gtk2u_html-suse-nostl3 libwx_gtk2u_qa-suse-nostl3

- Rework provides/conflicts between -devel variants.

==== xorg-x11-server ====
Version update (1.19.5 -> 1.19.6)
Subpackages: xorg-x11-server-extra xorg-x11-server-sdk

- Added u_xfree86-add-default-modes-for-16-9-and-16-10.patch (boo#1075249)
  Improve user experience for users with 16:9 or 16:10 screens
- Update to version 1.19.6:
  Another collection of fixes from master. There will likely be at east one more
  1.19.x release in 2018.

==== yast2 ====
Version update (4.0.34 -> 4.0.38)

- CWM: Add possibility to define abort handler for CWM.show
  (needed for expert partitioner fate#318196)
- 4.0.38
- Firewalld: Added missing firewalld service file to the Makefile
  (fate#323460).
- 4.0.37
- CWMFirewallInterfaces: Replaced SuSEFirewall2 by firewalld.
  (fate#323460)
- 4.0.36
- fix having some roles without description when choosing
  different extensions during installation (bsc#1070726)
- 4.0.35

==== yast2-bootloader ====
Version update (4.0.12 -> 4.0.13)

- fix crash for getting partition to activate when stage1 device
  is disk (bsc#1076121)
- 4.0.13

==== yast2-installation ====
Version update (4.0.24 -> 4.0.26)

- Start performing real installation with as much memory as
  possible  (bsc#1076768)
- 4.0.26
- Read the root_subvolume_read_only setting from its new location
  (moved by libstorage-ng) in the control file (boo#1077047).
- 4.0.25

==== yast2-network ====
Version update (4.0.13 -> 4.0.14)

- bnc#1056109
  - improved device name collision recognition when applying device
    renaming according to the AY profile
- 4.0.14

==== yast2-nis-client ====
Version update (4.0.0 -> 4.0.1)

- Link ypserv agent against libtirpc, sunrpc is deprecated and does
  not support IPv6 (bsc#1076566)
- 4.0.1

==== yast2-packager ====
Version update (4.0.28 -> 4.0.32)

- Display a correct product license and release notes at upgrade
  from SLE12, correctly filter out the old installed products
  (fate#1076513)
- 4.0.32
- Hot fix for big memory consumption during NET installer with
  whole TW repo (bsc#1076768)
- 4.0.31
- Do not display the license again when going back (bsc#1069124)
- 4.0.30
- Added a new client for displaying the product license at upgrade
  (bsc#1069124)
- 4.0.29

==== yast2-pkg-bindings ====
Version update (4.0.5 -> 4.0.6)

- Log more details in PkgQueryProvides call
  (related to bsc#1072634)
- 4.0.6

==== yast2-storage-ng ====
Version update (4.0.68 -> 4.0.76)

- Properly detect snapshots subvolumes (bsc#1076321 and
  bsc#1076335).
- 4.0.76
- Partitioner: allow to resize LVM volume groups.
- Part of fate#318196.
- 4.0.75
- Partitioner: consider all sizes entered by the user as base of 2
  despite the units not being consistent with the International
  System. Thus, 1KB (which in the IS actually means 1000 bytes)
  becomes equivalent to 1KiB (which is 1024 bytes).
- fix proposal dialog error when there are no disks (bsc#1057430)
- Avoid partitioning checks error when using old settings format.
- Needed for bsc#1059160, bsc#1055747 and bsc#1063957.
- Partitioner: button to resize LVM logical volumes now works as
  expected (part of fate#31896).
- 4.0.74
- Consider all free spaces when deciding which partitions
  distribution is better (bsc#1077051).
- Fix TODOs labels in partitioner (bsc#1058652).
- 4.0.73
- Fix subtracting arrays of devices (fixes multipath wires
  detection for bsc#1076766)
- 4.0.72
- Partitioner: when creating partitions they are now aligned to
  hardware requirements (indispensable for DASD) and when possible
  also for optimal performance (bsc#1069860 and bsc#1072011).
- Partitioner: adjusted alignment logic during resizing to match
  the new logic used during creation.
- Partitioner: skip validation of disabled widgets in the dialog
  to select the size of a new partition.
- Partitioner: fixed a crash and one inconsistency in the dialog
  to resize an existing partition.
- 4.0.71
- Correctly open the expert partitioner when called from the
  Kubic/CaaSP summary screen (bsc#1076732)
- 4.0.70
- Added sanity checks for partitioning setup.
- Partitioner: setup issues are shown to the user before continue.
  Mandatory product volumes are required according to control file.
- Part of fate#31896 and fix for bsc#1059160, bsc#1055747 and
  bsc#1063957.
- 4.0.69
- Some code reorganization regarding alignment and resizing.
- Added to several places in the API the possibilty of using other
  alignment types, in addition to the optimal one.
- Added a (temporary) workaround to a possible bug in libstorage-ng
  regarding alignment.

==== zypper-migration-plugin ====
Version update (0.10.1488806253.1c712c3 -> 0.11.1516874532.fa20262)

- add --no-snapshots and --root options
- version 0.11


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Leap 15.0 Build 115.1 released!

Andrei Borzenkov
31.01.2018 23:02, Ludwig Nussel пишет:
>   SUSEConnect (0.3.3 -> 0.3.7)

For openSUSE?

>   SuSEfirewall2 (3.6.376 -> 3.6.378)

So what will Leap 15 have - SFW2 or firewalld?

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Leap 15.0 Build 115.1 released!

Simon Lees-3


On 01/02/18 13:46, Andrei Borzenkov wrote:
> 31.01.2018 23:02, Ludwig Nussel пишет:
>>   SUSEConnect (0.3.3 -> 0.3.7)
>
> For openSUSE?
>
>>   SuSEfirewall2 (3.6.376 -> 3.6.378)
>
> So what will Leap 15 have - SFW2 or firewalld?
>

firewalld, sfw2 is either still there for testing compatibility or
because a bot added it automatically and no one removed it yet.

--

Simon Lees (Simotek)                            http://simotek.net

Emergency Update Team                           keybase.io/simotek
SUSE Linux                           Adelaide Australia, UTC+10:30
GPG Fingerprint: 5B87 DB9D 88DC F606 E489 CEC5 0922 C246 02F0 014B


signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Leap 15.0 Build 115.1 released!

Per Jessen
In reply to this post by Andrei Borzenkov
Andrei Borzenkov wrote:

> 31.01.2018 23:02, Ludwig Nussel пишет:
>>   SUSEConnect (0.3.3 -> 0.3.7)
>
> For openSUSE?
>
>>   SuSEfirewall2 (3.6.376 -> 3.6.378)
>
> So what will Leap 15 have - SFW2 or firewalld?

In what I installed yesterday - firewalld is installed by default, SFW2
is not.



--
Per Jessen, Zürich (2.9°C)
http://www.cloudsuisse.com/ - your owncloud, hosted in Switzerland.

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

XFCE Splash screen is a joke? (was: Leap 15.0 Build 115.1 released!)

Stefan Seyfried
In reply to this post by Ludwig Nussel
Am I right in assuming that the current Leap 15 splash screen is a joke
and will be reverted to what's in tumbleweed?
--
Stefan Seyfried

"For a successful technology, reality must take precedence over
 public relations, for nature cannot be fooled." -- Richard Feynman

xfce4-splash-openSUSE.png (63K) Download Attachment