KED:Qt58 repo builds for Leap 42.2 broken; missing 'python-rpm-macros' dep

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

KED:Qt58 repo builds for Leap 42.2 broken; missing 'python-rpm-macros' dep

PGNet Dev-2
KDE Qt58 repo

        https://build.opensuse.org/project/show/KDE:Qt58

builds for Leap 42.2 have been broken for days.

Could someone with privs please fix the repo deps to get KDE:Qt58 building again?

In particular, @

        https://build.opensuse.org/project/show/KDE:Qt58

for

        python3-qt5
        https://build.opensuse.org/package/show?project=KDE%3AQt58&package=python-qt5

         "nothing provides python3-sip-devel >= 4.19.1, nothing provides python-rpm-macros"


        python3-sip
        https://build.opensuse.org/package/show?project=KDE%3AQt58&package=python-sip

         "nothing provides python-rpm-macros"


I'd already contacted maintainer directly; no response so far.

And I'd already contacted most-recet committer(s); suggested that it's not their issue, better to contact 'the list'.

Thanks
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KED:Qt58 repo builds for Leap 42.2 broken; missing 'python-rpm-macros' dep

Luca Beltrame
In data lunedì 3 aprile 2017 19:58:26 CEST, PGNet Dev ha scritto:

> I'd already contacted maintainer directly; no response so far.

Although the repo has a maintainer, the KDE: hierarchy is usually
"collectively" maintained by the KDE team.

> And I'd already contacted most-recet committer(s); suggested that it's not
> their issue, better to contact 'the list'.

This is due to the recent switch to Python single spec packages, which require
a package that's (not yet? but I don't know) available in Leap. We'll see what
can be done.

--
Luca Beltrame - KDE Forums team
GPG key ID: A29D259B

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: KED:Qt58 repo builds for Leap 42.2 broken; missing 'python-rpm-macros' dep

Bruno Friedmann-2
On lundi, 3 avril 2017 20.09:08 h CEST Luca Beltrame wrote:

> In data lunedì 3 aprile 2017 19:58:26 CEST, PGNet Dev ha scritto:
> > I'd already contacted maintainer directly; no response so far.
>
> Although the repo has a maintainer, the KDE: hierarchy is usually
> "collectively" maintained by the KDE team.
>
> > And I'd already contacted most-recet committer(s); suggested that it's not
> > their issue, better to contact 'the list'.
>
> This is due to the recent switch to Python single spec packages, which
> require a package that's (not yet? but I don't know) available in Leap.
> We'll see what can be done.

You should be able to linkpac it from d:l:p I guess since the merge is
happening there.


--

Bruno Friedmann
 Ioda-Net Sàrl www.ioda-net.ch
 Bareos Partner, openSUSE Member, fsfe fellowship
 GPG KEY : D5C9B751C4653227
 irc: tigerfoot


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KED:Qt58 repo builds for Leap 42.2 broken; missing 'python-rpm-macros' dep

Luca Beltrame
In data lunedì 3 aprile 2017 21:15:34 CEST, Bruno Friedmann ha scritto:

> You should be able to linkpac it from d:l:p I guess since the merge is
> happening there.

Fixed now.

--
Luca Beltrame - KDE Forums team
KDE Science supporter
GPG key ID: A29D259B

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: KED:Qt58 repo builds for Leap 42.2 broken; missing 'python-rpm-macros' dep

PGNet Dev-2
> Fixed now.

All better here, thanks/appreciated.

just fyi, pkg libqt5-qtdoc is having a build issue; easily ignored 4 now.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KED:Qt58 repo builds for Leap 42.2 broken; missing 'python-rpm-macros' dep

Luca Beltrame
In data mercoledì 5 aprile 2017 15:38:36 CEST, PGNet Dev ha scritto:

> just fyi, pkg libqt5-qtdoc is having a build issue; easily ignored 4 now.

Known breakage: we're not sure how to fix it at the moment.

--
Luca Beltrame - KDE Forums team
KDE Science supporter
GPG key ID: A29D259B

signature.asc (499 bytes) Download Attachment