KDE repos for Leap 15.2

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

KDE repos for Leap 15.2

Luiz Fernando Ranghetti-2
Hi,

It's really necessary to add all 3 repos (Qt5, Frameworks and
Applications) on Leap 15.2? For 15.1 I understand, Qt was at a lower
version which is not the case anymore.

Regards,

Luiz
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for Leap 15.2

Wolfgang Bauer
Am Dienstag, 21. Juli 2020, 10:20:44 schrieb Luiz Fernando Ranghetti:
> It's really necessary to add all 3 repos (Qt5, Frameworks and
> Applications) on Leap 15.2?
Yes, if you want to have the latest KDE packages. (it's not really *necessary*
to add any repo, you can just use what's shipped in the distribution itself
;-) )

Actually you may need 4, there's also KDE:Extra which contains KDE
applications that are released separately. And some of those applications
won't be installable with newer Qt or KDE packages (so you need KDE:Extra
built against the latest Qt/KDE packages if you want to install them).

See https://en.opensuse.org/SDB:KDE_repositories .

> For 15.1 I understand, Qt was at a lower
> version which is not the case anymore.
Of course it's still the case.

Leap 15.2 comes with Qt 5.12 LTS, while the latest version is 5.15.0 (which
will also be LTS)...

The latest KDE packages cannot even be built anymore with 5.12.
(well, some of them can, but Plasma e.g. requires 5.14 meanwhile, and KDEPIM
5.13)

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for Leap 15.2

Vojtěch Zeisek-2
Dne středa 22. července 2020 10:11:19 CEST, Wolfgang Bauer napsal(a):

> Am Dienstag, 21. Juli 2020, 10:20:44 schrieb Luiz Fernando Ranghetti:
> > It's really necessary to add all 3 repos (Qt5, Frameworks and
> > Applications) on Leap 15.2?
>
> Yes, if you want to have the latest KDE packages. (it's not really
> *necessary* to add any repo, you can just use what's shipped in the
> distribution itself ;-) )
>
> Actually you may need 4, there's also KDE:Extra which contains KDE
> applications that are released separately. And some of those applications
> won't be installable with newer Qt or KDE packages (so you need KDE:Extra
> built against the latest Qt/KDE packages if you want to install them).
>
> See https://en.opensuse.org/SDB:KDE_repositories .
>
> > For 15.1 I understand, Qt was at a lower
> > version which is not the case anymore.
>
> Of course it's still the case.
>
> Leap 15.2 comes with Qt 5.12 LTS, while the latest version is 5.15.0 (which
> will also be LTS)...
>
> The latest KDE packages cannot even be built anymore with 5.12.
> (well, some of them can, but Plasma e.g. requires 5.14 meanwhile, and KDEPIM
> 5.13)
>
> Kind Regards,
> Wolfgang
...and then You realise it's easier to use TW... :-)


--
Vojtěch Zeisek
https://trapa.cz/

Komunita openSUSE GNU/Linuxu
Community of the openSUSE GNU/Linux
https://www.opensuse.org/

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for Leap 15.2

Luiz Fernando Ranghetti-2
In reply to this post by Wolfgang Bauer
Em qua., 22 de jul. de 2020 às 05:12, Wolfgang Bauer <[hidden email]> escreveu:
>
> Am Dienstag, 21. Juli 2020, 10:20:44 schrieb Luiz Fernando Ranghetti:
> > It's really necessary to add all 3 repos (Qt5, Frameworks and
> > Applications) on Leap 15.2?
> Yes, if you want to have the latest KDE packages. (it's not really *necessary*
> to add any repo, you can just use what's shipped in the distribution itself
> ;-) )

Sure, the question was mostly rhetorical right now, but say, for
example, that a user wants that LTS stuff (Qt and Plasma) and just
wants to update the Applications when 20.11 is available.

Regards,

Luiz
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for Leap 15.2

Wolfgang Bauer
Am Mittwoch, 22. Juli 2020, 10:47:30 schrieb Luiz Fernando Ranghetti:
> Sure, the question was mostly rhetorical right now, but say, for
> example, that a user wants that LTS stuff (Qt and Plasma) and just
> wants to update the Applications when 20.11 is available.
That won't be possible.

As I wrote, KDEPIM e.g. already requires Qt 5.13 now (as of 20.08 beta), but
Leap 15.2 only has 5.12.7.

The other problem is that newer application versions may also need newer KDE
Frameworks versions (which in turn may need newer Qt versions, as they will
stop supporting Qt 5.12 LTS in November).
E.g. KDEPIM now needs KDE Frameworks 5.72 in master (what will become 20.12),
but Leap 15.2 has 5.71.

Even if it would be possible to build some newer applications with older
Qt5/KF5:
The KDE:Applications repo is built against KDE:Qt5 and KDE:Frameworks5, also
for Leap 15.2. So if you want to use it, you *need* the other two as well.

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]