KDE repos for 42.2

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|

KDE repos for 42.2

Vadym Krevs
Is there a problem with KDE repos for 42.2 at the moment?

Most but not all (e.g. kwayland) packages in
http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.2/ 
appear to require Qt 5.8 but
http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.2/ 
seems to contain a weird mixture of Qt 5.7.1 and Qt 5.8.

As a result zypper dup offers to downgrade the world.

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for 42.2

Fabian Vogt-2
Hi,

Am Dienstag, 16. Mai 2017, 11:01:46 CEST schrieb Vadym Krevs:
> Is there a problem with KDE repos for 42.2 at the moment?
>
> Most but not all (e.g. kwayland) packages in
> http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.2/ 
> appear to require Qt 5.8 but
> http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.2/ 
> seems to contain a weird mixture of Qt 5.7.1 and Qt 5.8.
>
> As a result zypper dup offers to downgrade the world.

Yes, this is known and will fix itself in a few hours after the 5.10 beta is built.

Plasma 5.9 contains a (upstream) build loop which made it unbuildable after the
KDE:Qt5 downgrade.

Cheers,
Fabian


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for 42.2

Luca Beltrame
In reply to this post by Vadym Krevs
In data martedì 16 maggio 2017 11:01:46 CEST, Vadym Krevs ha scritto:

> http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.2/
> seems to contain a weird mixture of Qt 5.7.1 and Qt 5.8.

KDE:Qt5 has been rolled back to 5.7.1 due to 5.8 being unsuitable (and being
de facto a throwaway release by the Qt Project). Please report which packages
are still on 5.8 so we can adjust, if need be.

--
Luca Beltrame - KDE Forums team
KDE Science supporter
GPG key ID: A29D259B

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for 42.2

Vadym Krevs
On 16/05/17 10:07, Luca Beltrame wrote:
> In data martedì 16 maggio 2017 11:01:46 CEST, Vadym Krevs ha scritto:
>
>> http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.2/
>> seems to contain a weird mixture of Qt 5.7.1 and Qt 5.8.
> KDE:Qt5 has been rolled back to 5.7.1 due to 5.8 being unsuitable (and being
> de facto a throwaway release by the Qt Project). Please report which packages
> are still on 5.8 so we can adjust, if need be.
>
Any package with the word "chart" in it - e.g.
libQt5Charts5-5.8.0-3.1.x86_64.rpm .

--
Regards,
Vadym Krevs

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for 42.2

Vadym Krevs
In reply to this post by Luca Beltrame
On 16/05/17 10:07, Luca Beltrame wrote:
> In data martedì 16 maggio 2017 11:01:46 CEST, Vadym Krevs ha scritto:
>
>> http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.2/
>> seems to contain a weird mixture of Qt 5.7.1 and Qt 5.8.
> KDE:Qt5 has been rolled back to 5.7.1 due to 5.8 being unsuitable (and being
> de facto a throwaway release by the Qt Project). Please report which packages
> are still on 5.8 so we can adjust, if need be.
>
Broken again ...

# zypper -v dup -d
Verbosity: 1
Warning: You are about to do a distribution upgrade with all enabled
repositories. Make sure these repositories are compatible before you
continue. See 'man zypper' for more information about this command.
...
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
Force resolution: No
Computing upgrade...
17 Problems:
Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
libAppStreamQt2-0.10.5-30.4.x86_64
Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
libKF5DocTools5-5.34.0-141.2.x86_64
Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
libKF5NewStuffCore5-5.34.0-118.2.x86_64
Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
libKF5Prison5-5.34.0-19.2.x86_64
Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
libKF5SyntaxHighlighting5-5.34.0-33.8.x86_64
Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
syntax-highlighting-5.34.0-33.8.x86_64
Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
kio-5.34.0-181.2.x86_64
Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
kwin5-5.10.0-190.5.x86_64
Problem: pim-sieve-editor-17.04.1-18.1.x86_64 requires
libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot be provided
Problem: pim-data-exporter-17.04.1-21.5.x86_64 requires
libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot be provided
Problem: mbox-importer-17.04.1-19.1.x86_64 requires
libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot be provided
Problem:
libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-18.1.x86_64
requires libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot be
provided
Problem: kmail-account-wizard-17.04.1-20.1.x86_64 requires
libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot be provided
Problem: kleopatra-17.04.1-22.1.x86_64 requires
libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot be provided
Problem: akonadi-import-wizard-17.04.1-19.1.x86_64 requires
libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot be provided
Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
kio-5.34.0-181.2.x86_64
Problem: libKF5CompactDisc5-17.04.1-22.1.x86_64 requires
libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot be provided

Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
libAppStreamQt2-0.10.5-30.4.x86_64
  Solution 1: keep obsolete libAppStreamQt2-0.10.5-30.3.x86_64
  Solution 2: break libAppStreamQt2-0.10.5-30.4.x86_64 by ignoring some
of its dependencies

Choose from above solutions by number or skip, retry or cancel
[1/2/s/r/c] (c):

--
Regards,
Vadym Krevs

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for 42.2

Mathias Homann-2
...and the person who gets automatically assigned on bugs referring to
KDE:Qt5, KDE:Applications does not react.


I wish we could somehow arrive back at the unstable stuff being in
KDE:Unstable...


FFS, there are actually people USING these repos!


</rant>


Am 30.05.2017 um 12:01 schrieb Vadym Krevs:

> On 16/05/17 10:07, Luca Beltrame wrote:
>> In data martedì 16 maggio 2017 11:01:46 CEST, Vadym Krevs ha scritto:
>>
>>> http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.2/
>>> seems to contain a weird mixture of Qt 5.7.1 and Qt 5.8.
>> KDE:Qt5 has been rolled back to 5.7.1 due to 5.8 being unsuitable
>> (and being
>> de facto a throwaway release by the Qt Project). Please report which
>> packages
>> are still on 5.8 so we can adjust, if need be.
>>
> Broken again ...
>
> # zypper -v dup -d
> Verbosity: 1
> Warning: You are about to do a distribution upgrade with all enabled
> repositories. Make sure these repositories are compatible before you
> continue. See 'man zypper' for more information about this command.
> ...
> Loading repository data...
> Reading installed packages...
> Computing distribution upgrade...
> Force resolution: No
> Computing upgrade...
> 17 Problems:
> Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
> libAppStreamQt2-0.10.5-30.4.x86_64
> Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
> libKF5DocTools5-5.34.0-141.2.x86_64
> Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
> libKF5NewStuffCore5-5.34.0-118.2.x86_64
> Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
> libKF5Prison5-5.34.0-19.2.x86_64
> Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
> libKF5SyntaxHighlighting5-5.34.0-33.8.x86_64
> Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
> syntax-highlighting-5.34.0-33.8.x86_64
> Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
> kio-5.34.0-181.2.x86_64
> Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
> kwin5-5.10.0-190.5.x86_64
> Problem: pim-sieve-editor-17.04.1-18.1.x86_64 requires
> libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot be provided
> Problem: pim-data-exporter-17.04.1-21.5.x86_64 requires
> libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot be provided
> Problem: mbox-importer-17.04.1-19.1.x86_64 requires
> libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot be provided
> Problem:
> libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-18.1.x86_64
> requires libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot
> be provided
> Problem: kmail-account-wizard-17.04.1-20.1.x86_64 requires
> libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot be provided
> Problem: kleopatra-17.04.1-22.1.x86_64 requires
> libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot be provided
> Problem: akonadi-import-wizard-17.04.1-19.1.x86_64 requires
> libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot be provided
> Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
> kio-5.34.0-181.2.x86_64
> Problem: libKF5CompactDisc5-17.04.1-22.1.x86_64 requires
> libQt5Core.so.5(Qt_5.7)(64bit), but this requirement cannot be provided
>
> Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by
> libAppStreamQt2-0.10.5-30.4.x86_64
>  Solution 1: keep obsolete libAppStreamQt2-0.10.5-30.3.x86_64
>  Solution 2: break libAppStreamQt2-0.10.5-30.4.x86_64 by ignoring some
> of its dependencies
>
> Choose from above solutions by number or skip, retry or cancel
> [1/2/s/r/c] (c):
>

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for 42.2

Luca Beltrame
Il 30 maggio 2017 19:57:32 CEST, Mathias Homann <[hidden email]> ha scritto:
>...and the person who gets automatically assigned on bugs referring to
>KDE:Qt5, KDE:Applications does not react.

It's not a person, it's a group of people.


>I wish we could somehow arrive back at the unstable stuff being in
>KDE:Unstable...

It is. That's why I'm able to report bugs before the distro even sees it (not just me, but anyone using them). KU* was on Qt 5.9 for quite a while.

>FFS, there are actually people USING these repos!

That is why publishing got disabled​. Bear in mind that at some point we would have to upload "stable" tars and a fallout would've occurred anyway...



--
Luca Beltrame
GPG key ID: 6E1A4E79
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for 42.2

Daniele
Il 30/05/2017 20:06, Luca Beltrame ha scritto:

>> FFS, there are actually people USING these repos!
>
> That is why publishing got disabled​. Bear in mind that at some point we would have to upload "stable" tars and a fallout would've occurred anyway...

I know that you do your best in your spare time but I relly hope that
you rethink the way you handle these repos..
For me are almost unuseable..

Daniele.
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for 42.2

Fabian Vogt-2
Hi,

Am Dienstag, 30. Mai 2017, 20:42:24 CEST schrieb Daniele:
> Il 30/05/2017 20:06, Luca Beltrame ha scritto:
>
> >> FFS, there are actually people USING these repos!
> >
> > That is why publishing got disabled​. Bear in mind that at some point we would have to upload "stable" tars and a fallout would've occurred anyway...
>
> I know that you do your best in your spare time but I relly hope that
> you rethink the way you handle these repos..
> For me are almost unuseable..

KDE:Qt5 is not supposed to be usable, except for KDE:Frameworks5/openSUSE_Leap_42.2.
It does not make sense to use it for anything else, as Plasma and KF5 parts depend on
the private API, which won't match.

Its sole purpose is to be a devel prj for factory, where we will add RCs and maybe even
Beta releases to submit them for testing.

Note that tomorrow Qt 5.9.0 will be released and checked in to KDE:Qt5, but as that's
a relatively minor change it should go a bit smoother.

Cheers,
Fabian

>
> Daniele.
>


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for 42.2

Patrick Shanahan-2
In reply to this post by Vadym Krevs
* Vadym Krevs <[hidden email]> [05-30-17 12:02]:

> On 16/05/17 10:07, Luca Beltrame wrote:
> >In data martedì 16 maggio 2017 11:01:46 CEST, Vadym Krevs ha scritto:
> >
> >>http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.2/
> >>seems to contain a weird mixture of Qt 5.7.1 and Qt 5.8.
> >KDE:Qt5 has been rolled back to 5.7.1 due to 5.8 being unsuitable (and being
> >de facto a throwaway release by the Qt Project). Please report which packages
> >are still on 5.8 so we can adjust, if need be.
> >
> Broken again ...
>
> # zypper -v dup -d
> Verbosity: 1
> Warning: You are about to do a distribution upgrade with all enabled
> repositories. Make sure these repositories are compatible before you
> continue. See 'man zypper' for more information about this command.


you do realize you shouldn't be using "dup" for Leap.  and it may be
contributing to your continuing problems, re: "Broken again ..."

--
(paka)Patrick Shanahan       Plainfield, Indiana, USA          @ptilopteri
http://en.opensuse.org    openSUSE Community Member    facebook/ptilopteri
Registered Linux User #207535                    @ http://linuxcounter.net
Photos: http://wahoo.no-ip.org/piwigo                    paka @ IRCnet freenode
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for 42.2

Vadym Krevs
On 30/05/17 20:58, Patrick Shanahan wrote:

> * Vadym Krevs <[hidden email]> [05-30-17 12:02]:
>> On 16/05/17 10:07, Luca Beltrame wrote:
>>> In data martedì 16 maggio 2017 11:01:46 CEST, Vadym Krevs ha scritto:
>>>
>>>> http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.2/
>>>> seems to contain a weird mixture of Qt 5.7.1 and Qt 5.8.
>>> KDE:Qt5 has been rolled back to 5.7.1 due to 5.8 being unsuitable (and being
>>> de facto a throwaway release by the Qt Project). Please report which packages
>>> are still on 5.8 so we can adjust, if need be.
>>>
>> Broken again ...
>>
>> # zypper -v dup -d
>> Verbosity: 1
>> Warning: You are about to do a distribution upgrade with all enabled
>> repositories. Make sure these repositories are compatible before you
>> continue. See 'man zypper' for more information about this command.
>
> you do realize you shouldn't be using "dup" for Leap.  and it may be
> contributing to your continuing problems, re: "Broken again ..."
>
Is there an actual technical reason for your recommendation?

--
Regards,
Vadym

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for 42.2

Patrick Shanahan-2
* Vadym Krevs <[hidden email]> [05-31-17 03:59]:

> On 30/05/17 20:58, Patrick Shanahan wrote:
> >* Vadym Krevs <[hidden email]> [05-30-17 12:02]:
> >>On 16/05/17 10:07, Luca Beltrame wrote:
> >>>In data martedì 16 maggio 2017 11:01:46 CEST, Vadym Krevs ha scritto:
> >>>
> >>>>http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.2/
> >>>>seems to contain a weird mixture of Qt 5.7.1 and Qt 5.8.
> >>>KDE:Qt5 has been rolled back to 5.7.1 due to 5.8 being unsuitable (and being
> >>>de facto a throwaway release by the Qt Project). Please report which packages
> >>>are still on 5.8 so we can adjust, if need be.
> >>>
> >>Broken again ...
> >>
> >># zypper -v dup -d
> >>Verbosity: 1
> >>Warning: You are about to do a distribution upgrade with all enabled
> >>repositories. Make sure these repositories are compatible before you
> >>continue. See 'man zypper' for more information about this command.
> >
> >you do realize you shouldn't be using "dup" for Leap.  and it may be
> >contributing to your continuing problems, re: "Broken again ..."
> >
> Is there an actual technical reason for your recommendation?



from the opensuse list:

 Date: Tue, 25 Apr 2017 15:20:34 -0700
 From: Fraser_Bell <[hidden email]>
 To: [hidden email]
 Subject: Re: [opensuse] zypper dup Question
 
 On 04/25/2017 01:04 PM, Bryon Adams wrote:
 > Running Leap 42.2 on my pi and out of curiosity I ran zypper dup to see
 > what would show up. It looks like it wants to install a bunch of
 > graphical
 > applications and I'm not sure why, could someone explain this to me?
 >
 > This is a minimal install from the JeOS image. I pasted the output on
 > susepaste here: http://susepaste.org/16775081
 >
 > Regards,
 >    Bryon
 >
 >
 >

 zypper dup is for a distribution upgrade (that is, say from openSUSE 42.1
 to 42.2, or 42.2 to 42.3).

 The only exception is Tumbleweed, since it is a rolling release, each
 release is effectively a "distribution upgrade", in a way, so zypper dup
 is used for updating Tumbleweed.

 If you do a zypper dup, it will want to switch all packages back to the
 main repos when there is a higher version number, among other things, and
 it can also give you unexpected results if you have other repos enabled.

 Your only use of zypper dup, in Leap, would be if the system is messed up
 and you want to return it to a closer state to the original install.  But,
 then, your best bet would be to use the install DVD and choose and
 "Upgrade".

 Hope that explains it sufficiently for you.
 --
 -Gerry Makaro
 aka Fraser_Bell on the forums, IRC, and mail at openSUSE.org

the best explanation I have seen.

and there is also "man zypper"
and zypper dup --help
    zypper up --help

and google.    
 --
 (paka)Patrick Shanahan       Plainfield, Indiana, USA          @ptilopteri
 http://en.opensuse.org    openSUSE Community Member    facebook/ptilopteri
 Registered Linux User #207535                    @ http://linuxcounter.net
 Photos: http://wahoo.no-ip.org/piwigo                    paka @ IRCnet freenode

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for 42.2

Vadym Krevs
On 31/05/17 12:44, Patrick Shanahan wrote:
> ...
>   If you do a zypper dup, it will want to switch all packages back to the
>   main repos when there is a higher version number, among other things, and
>   it can also give you unexpected results if you have other repos enabled.
>
> ...
That is precisely why we actually *have* to use zypper dup on Leap
considering the pace of change inside Leap-specific KDE repos.

--
Regards,
Vadym

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for 42.2

Mathias Homann-2
Am Mittwoch, 31. Mai 2017, 08:19:49 EDT schrieb Vadym Krevs:

> On 31/05/17 12:44, Patrick Shanahan wrote:
> > ...
> >
> >   If you do a zypper dup, it will want to switch all packages back to the
> >   main repos when there is a higher version number, among other things,
> >   and
> >   it can also give you unexpected results if you have other repos enabled.
> >
> > ...
>
> That is precisely why we actually *have* to use zypper dup on Leap
> considering the pace of change inside Leap-specific KDE repos.
and I am using zypper dup *all the time* on Leap 42.2 with no problems
whatsoever... that is what repo priorities are for after all.

Cheers
MH

--
gpg key fingerprint: 5F64 4C92 9B77 DE37 D184  C5F9 B013 44E7 27BD 763C

signature.asc (650 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: KDE repos for 42.2

Martin Schlander
In reply to this post by Patrick Shanahan-2
tirsdag den 30. maj 2017 15.58.47 CEST skrev Patrick Shanahan:

> * Vadym Krevs <[hidden email]> [05-30-17 12:02]:
> > On 16/05/17 10:07, Luca Beltrame wrote:
> > >In data martedì 16 maggio 2017 11:01:46 CEST, Vadym Krevs ha scritto:
> > >>http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.2/
> > >>seems to contain a weird mixture of Qt 5.7.1 and Qt 5.8.
> > >
> > >KDE:Qt5 has been rolled back to 5.7.1 due to 5.8 being unsuitable (and
> > >being de facto a throwaway release by the Qt Project). Please report
> > >which packages are still on 5.8 so we can adjust, if need be.
> >
> > Broken again ...
> >
> > # zypper -v dup -d
> > Verbosity: 1
> > Warning: You are about to do a distribution upgrade with all enabled
> > repositories. Make sure these repositories are compatible before you
> > continue. See 'man zypper' for more information about this command.
>
> you do realize you shouldn't be using "dup" for Leap.  and it may be
> contributing to your continuing problems, re: "Broken again ..."

At the very least use 'zypper dup --from' to limit the vendor ping-pong going
on between all kinds of packages from different repos/vendors.

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]