KDE:Frameworks5 now hosts the Plasma 5.10 beta

classic Classic list List threaded Threaded
18 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

KDE:Frameworks5 now hosts the Plasma 5.10 beta

Luca Beltrame
Hello,

On the heels from the latest beta release from KDE[1], KDE:Frameworks5 now
contains the Plasma 5.10 beta (currently under review for Tumbleweed inclusion
once the final version is out) and KDE Frameworks 5.34 (already submitted to
Tumbleweed).

The final version of Plasma 5.10 is scheduled to be released upstream on May
30th.

Testing, both for packaging problems (report to bugs.opensuse.org) and
upstream issues (report to bugs.kde.org) is very welcome!

[1] https://www.kde.org/announcements/plasma-5.9.95.php

--
Luca Beltrame - KDE Forums team
KDE Science supporter
GPG key ID: A29D259B

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

Vadym Krevs
On 16/05/17 14:27, Luca Beltrame wrote:

> Hello,
>
> On the heels from the latest beta release from KDE[1], KDE:Frameworks5 now
> contains the Plasma 5.10 beta (currently under review for Tumbleweed inclusion
> once the final version is out) and KDE Frameworks 5.34 (already submitted to
> Tumbleweed).
>
> The final version of Plasma 5.10 is scheduled to be released upstream on May
> 30th.
>
> Testing, both for packaging problems (report to bugs.opensuse.org) and
> upstream issues (report to bugs.kde.org) is very welcome!
>
> [1] https://www.kde.org/announcements/plasma-5.9.95.php
>

Still not upgradeable to via zypper dup - at least for  me.

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

Vadym Krevs
On 16/05/17 15:31, Vadym Krevs wrote:

> On 16/05/17 14:27, Luca Beltrame wrote:
>> Hello,
>>
>> On the heels from the latest beta release from KDE[1],
>> KDE:Frameworks5 now
>> contains the Plasma 5.10 beta (currently under review for Tumbleweed
>> inclusion
>> once the final version is out) and KDE Frameworks 5.34 (already
>> submitted to
>> Tumbleweed).
>>
>> The final version of Plasma 5.10 is scheduled to be released upstream
>> on May
>> 30th.
>>
>> Testing, both for packaging problems (report to bugs.opensuse.org) and
>> upstream issues (report to bugs.kde.org) is very welcome!
>>
>> [1] https://www.kde.org/announcements/plasma-5.9.95.php
>>
>
> Still not upgradeable to via zypper dup - at least for  me.
>
Most likely because everything in
http://download.opensuse.org/repositories/KDE:/Applications/KDE_Frameworks5_openSUSE_Leap_42.2/ 
still wants Qt 5.8.

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

Luca Beltrame
In reply to this post by Vadym Krevs
In data martedì 16 maggio 2017 16:31:55 CEST, Vadym Krevs ha scritto:
 
> Still not upgradeable to via zypper dup - at least for  me.

What is the error you are getting?

--
Luca Beltrame - KDE Forums team
KDE Science supporter
GPG key ID: A29D259B

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

Vadym Krevs
On 16/05/17 15:38, Luca Beltrame wrote:
> In data martedì 16 maggio 2017 16:31:55 CEST, Vadym Krevs ha scritto:
>  
>> Still not upgradeable to via zypper dup - at least for  me.
> What is the error you are getting?
>
zypper -v dup
Verbosity: 1
Warning: You are about to do a distribution upgrade with all enabled
repositories. Make sure these repositories are compatible before you
continue. See 'man zypper' for more information about this command.
Initializing Target
Checking whether to refresh metadata for ACE
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for KDE:Applications_openSUSE_Leap_42.2
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for KDE:Extra_openSUSE_Leap_42.2
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for KDE:Frameworks5_openSUSE_Leap_42.2
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for KDE:Qt5_openSUSE_Leap_42.2
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Retrieving: media
......................................................................................................................................................................................................................................................[error]
Retrieving: repomd.xml.asc
..............................................................................................................................................................................................................................................[done]
Retrieving: repomd.xml.key
..............................................................................................................................................................................................................................................[done]
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
   Repository:       KDE:Qt5_openSUSE_Leap_42.2
   Key Name:         KDE OBS Project <[hidden email]>
   Key Fingerprint:  4E8E6DE2 961F3083 EAC50086 27C07017 6F88BB2F
   Key Created:      Mon Nov  7 14:39:08 2016
   Key Expires:      Wed Jan 16 14:39:08 2019
   Rpm Name:         gpg-pubkey-6f88bb2f-5820920c
Retrieving:
093099d5dd8e89f4424331214ace769d9685d98f8eda46dd3487a68ccdc62d06-primary.xml.gz
................................................................................................................................................................[done
(26.4 KiB/s)]
Retrieving repository 'KDE:Qt5_openSUSE_Leap_42.2' metadata
.............................................................................................................................................................................................................[done]
Building repository 'KDE:Qt5_openSUSE_Leap_42.2' cache
..................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for LibreOffice:5.3_openSUSE_42.2
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for M17N:fonts
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for Packman Repository
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for openSUSE-Leap_42.2-NonOss-Source
Retrieving: content
.....................................................................................................................................................................................................................................................[done]
Retrieving: media
.......................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for openSUSE BuildService - GNOME:Apps
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for google-chrome
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for google-earth
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for google-musicmanager
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for google-talkplugin
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for openSUSE-Leap_42.2-Oss_Debug
Retrieving: content
.....................................................................................................................................................................................................................................................[done]
Retrieving: media
.......................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for openSUSE-Leap_42.2-Update-Non-Oss
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for openSUSE-Leap_42.2-Update-Debug-Oss
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for openSUSE-Leap_42.2-Update-Oss
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for openSUSE BuildService - Mozilla
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Checking whether to refresh metadata for VirtualBox for openSUSE 13.2
Retrieving: repomd.xml
..................................................................................................................................................................................................................................................[done]
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
Force resolution: No
Computing upgrade...
65 Problems:
Problem:
libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-18.1.x86_64
requires libQt5Core.so.5(Qt_5.7.1_PRIVATE_API)(64bit), but this
requirement cannot be provided
Problem: libQtQuick5-5.8.0-9.2.x86_64 requires
libQt5Gui.so.5(Qt_5.8.0_PRIVATE_API)(64bit), but this requirement cannot
be provided
Problem: mbox-importer-17.04.0-17.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libmarblewidget-qt5-27-17.04.0-5.9.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libkerfuffle17-17.04.0-4.10.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libQt5Charts5-5.8.0-8.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKPimKDAV5-17.04.0-3.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKPimGAPITasks5-17.04.0-23.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKPimGAPICore5-17.04.0-23.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKPimGAPIContacts5-17.04.0-23.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKPimGAPICalendar5-17.04.0-23.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5PimCommonAkonadi5-17.04.0-52.2.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5MailTransportAkonadi5-17.04.0-61.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5MailTransport5-17.04.0-61.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5MailImporterAkonadi5-17.04.0-48.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5LibkdepimAkonadi5-17.04.0-41.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5Kipi32_0_0-17.04.0-3.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5CompactDisc5-17.04.0-19.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5Cddb5-17.04.0-21.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kmail-account-wizard-17.04.0-17.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kleopatra-17.04.0-19.2.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: akonadi-import-wizard-17.04.0-17.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: akonadi-calendar-tools-17.04.0-18.10.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: akonadi-calendar-tools-17.04.0-18.10.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: spectacle-17.04.0-48.8.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: okular-17.04.0-4.9.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: messagelib-17.04.0-44.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: mbox-importer-17.04.0-17.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: marble-17.04.0-5.9.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libksieve-17.04.0-50.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libkomparediff2-5-17.04.0-5.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libkdepim-17.04.0-41.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5Mime5-17.04.0-56.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5KontactInterface5-17.04.0-55.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5IdentityManagement5-17.04.0-56.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5IMAP5-17.04.0-56.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5Contacts5-17.04.0-53.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5CompactDisc5-17.04.0-19.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5AkonadiNotes5-17.04.0-28.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5AkonadiCalendar5-17.04.0-67.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kwalletmanager5-17.04.0-52.10.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libKF5Tnef5-17.04.0-57.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kruler-17.04.0-4.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: krfb-17.04.0-4.10.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: krdc-17.04.0-4.10.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kpat-17.04.0-4.10.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: korganizer-17.04.0-19.11.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kontact-17.04.0-18.8.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: konsole-17.04.0-5.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: konqueror-17.04.0-19.10.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kompare-17.04.0-5.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kolourpaint-17.04.0-4.10.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: knotes-17.04.0-19.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kmines-17.04.0-4.10.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kmailtransport-17.04.0-61.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kmail-account-wizard-17.04.0-17.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kmail-17.04.0-24.10.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kmahjongg-17.04.0-4.8.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kleopatra-17.04.0-19.2.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kldap-17.04.0-61.1.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kio_kamera-17.04.0-5.7.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: kio_audiocd-17.04.0-4.10.x86_64 requires
libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
Problem: libQt5Core-devel-5.8.0-32.1.x86_64 requires
libqt5-qtbase-common-devel = 5.8.0, but this requirement cannot be provided
Problem: libqt5-qttools-5.8.0-8.2.x86_64 requires libQt5Help5 = 5.8.0,
but this requirement cannot be provided
Problem: libqt5-qttools-5.8.0-8.2.x86_64 requires libQt5Help5 = 5.8.0,
but this requirement cannot be provided

Problem:
libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-18.1.x86_64
requires libQt5Core.so.5(Qt_5.7.1_PRIVATE_API)(64bit), but this
requirement cannot be provided
   uninstallable providers:
libQt5Core5-5.7.1-287.1.x86_64[KDE:Qt55_openSUSE_Leap_42.2]
  Solution 1: Following actions will be done:
   deinstallation of libQt5Charts5-5.8.0-8.1.x86_64
   deinstallation of kgpg-lang-17.04.0-4.9.noarch
   deinstallation of keditbookmarks-lang-17.04.0-17.1.noarch
   deinstallation of kdialog-lang-17.04.0-17.1.noarch
   deinstallation of kdepim-runtime-lang-17.04.0-84.1.noarch
   deinstallation of kdepim-apps-libs-lang-17.04.0-43.1.noarch
   deinstallation of kdepim-addons-lang-17.04.0-45.1.noarch
   deinstallation of kdenetwork4-filesharing-lang-17.04.0-4.1.noarch
   deinstallation of kde-print-manager-lang-17.04.0-70.1.noarch
   deinstallation of kcron-lang-17.04.0-4.8.noarch
   deinstallation of kcolorchooser-lang-17.04.0-4.1.noarch
   deinstallation of kcharselect-lang-17.04.0-4.8.noarch
   deinstallation of kcalutils-lang-17.04.0-61.1.noarch
   deinstallation of kcalc-lang-17.04.0-4.8.noarch
   deinstallation of kate-lang-17.04.0-5.8.noarch
   deinstallation of kaddressbook-lang-17.04.0-19.1.noarch
   deinstallation of kaccounts-providers-lang-17.04.0-69.1.noarch
   deinstallation of kaccounts-integration-lang-17.04.0-73.1.noarch
   deinstallation of gwenview5-lang-17.04.0-64.11.noarch
   deinstallation of grantleetheme-lang-17.04.0-39.1.noarch
   deinstallation of dragonplayer-lang-17.04.0-5.8.noarch
   deinstallation of dolphin-lang-17.04.0-89.8.noarch
   deinstallation of baloo5-widgets-lang-17.04.0-55.1.noarch
   deinstallation of ark-lang-17.04.0-4.10.noarch
   deinstallation of akregator-lang-17.04.0-19.10.noarch
   deinstallation of kdepim-runtime-17.04.0-84.1.x86_64
   deinstallation of akonadi-server-lang-17.04.0-99.10.noarch
   deinstallation of akonadi-search-lang-17.04.0-64.1.noarch
   deinstallation of akonadi-import-wizard-lang-17.04.0-17.1.noarch
   deinstallation of akonadi-contact-lang-17.04.0-32.1.noarch
   deinstallation of libkgeomap-lang-17.04.0-79.1.noarch
  Solution 2: keep obsolete
libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-12.1.x86_64
  Solution 3: break
libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-18.1.x86_64
by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/c] (c):

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

Luca Beltrame
In reply to this post by Vadym Krevs
In data martedì 16 maggio 2017 16:38:05 CEST, Vadym Krevs ha scritto:

> Most likely because everything in
> http://download.opensuse.org/repositories/KDE:/Applications/KDE_Frameworks5_
> openSUSE_Leap_42.2/ still wants Qt 5.8.

The reason is that KDE:Applications is still publishing disabled. Now that
kf5-filesystem is in, I could enable it, but only for TW, because a few
packages (3) don't build when using the latest Frameworks (5.34 in K:F5).

This has been already fixed in 17.04.1, but there are still some non-ring
packages that need to be accepted in TW before I update everything.

--
Luca Beltrame - KDE Forums team
KDE Science supporter
GPG key ID: A29D259B

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

Vadym Krevs
On 16/05/17 16:13, Luca Beltrame wrote:

> In data martedì 16 maggio 2017 16:38:05 CEST, Vadym Krevs ha scritto:
>
>> Most likely because everything in
>> http://download.opensuse.org/repositories/KDE:/Applications/KDE_Frameworks5_
>> openSUSE_Leap_42.2/ still wants Qt 5.8.
> The reason is that KDE:Applications is still publishing disabled. Now that
> kf5-filesystem is in, I could enable it, but only for TW, because a few
> packages (3) don't build when using the latest Frameworks (5.34 in K:F5).
>
> This has been already fixed in 17.04.1, but there are still some non-ring
> packages that need to be accepted in TW before I update everything.
>
So, what are we to do in the meantime? Anyone on 42.2 who had enabled
KDE:Qt5, KDE:Frameworks5 and KDE:Applications is effectively stuffed.

<rant on>I fully realize that anyone who enables these non-defaults
repos does it at their own peril, but if you want us to actually be able
to test new KDE plasma/frameworks/apps releases, then these 3 repos need
to be always updated/published in sync. And the Qt repo should not jump
from one release to the next one and then back at random.</rant off>



--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

Luca Beltrame
In data martedì 16 maggio 2017 17:22:24 CEST, Vadym Krevs ha scritto:
 
> to test new KDE plasma/frameworks/apps releases, then these 3 repos need
> to be always updated/published in sync. And the Qt repo should not jump
> from one release to the next one and then back at random.</rant off>

Actually, the Qt revert was planned since a long time. It didn't even get
submitted to TW. There were just more important things in the queue first.

Secondly, getting Applications in shape for this cycle was quite complex (also
due to change in infrastructure and review) and due to that, it took a while
before it got accepted. In the mean time Frameworks 5.34 were out and this
uncovered the problems with those 3 packages I mentioned earlier.

An unfortunate timing. Nothing more than that.

--
Luca Beltrame - KDE Forums team
KDE Science supporter
GPG key ID: A29D259B

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

Wolfgang Bauer
In reply to this post by Luca Beltrame
Am Dienstag, 16. Mai 2017, 17:13:02 schrieb Luca Beltrame:
> The reason is that KDE:Applications is still publishing disabled. Now that
> kf5-filesystem is in, I could enable it, but only for TW, because a few
> packages (3) don't build when using the latest Frameworks (5.34 in K:F5).

I don't think this is a problem though, nor a reason to not enable publishing.

AFAICS, those 3 packages have been built against Qt 5.7.1 before the KF5
update, and the already built binaries should not get broken by that update
either.

There is (still) a different problem too though: libqt5-qtcharts in KDE:Qt5
has not been downgraded to 5.7.1 and is still at 5.8.0.
And that's also mentioned in the posted conflicts list.
It could probably just be uninstalled for now though, I don't think any KDE
package needs it (I don't have it installed here, and it is not in Tumbleweed
yet either).

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

Luca Beltrame
In data martedì 16 maggio 2017 17:41:31 CEST, Wolfgang Bauer ha scritto:

> I don't think this is a problem though, nor a reason to not enable
> publishing.

It will certainly lead to breakage, although no different than this one (ark
won't install, for one).

> AFAICS, those 3 packages have been built against Qt 5.7.1 before the KF5
> update, and the already built binaries should not get broken by that update

They're actually suffering from a different problem, because the release
script inject some CMake magic in the CmakeLists of these for translations and
KF 5.34 had some changes in the ki18n_install macro: these packages  were
doing it already, causing a double CMake target to get generated (to be more
precise, there are double ki18n_install calls), and so build fails at
configuration.

I just got told how to fix it, though (remove the duplicate ki18n_install
call), so I can either push a 17.04.1 update, or patch it.

--
Luca Beltrame - KDE Forums team
KDE Science supporter
GPG key ID: A29D259B

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

ianseeks-4
In reply to this post by Vadym Krevs
On Tuesday, 16 May 2017 15:40:46 BST Vadym Krevs wrote:

> On 16/05/17 15:38, Luca Beltrame wrote:
> > In data martedì 16 maggio 2017 16:31:55 CEST, Vadym Krevs ha scritto:
> >> Still not upgradeable to via zypper dup - at least for  me.
> >
> > What is the error you are getting?
>
> zypper -v dup
> Verbosity: 1
> Warning: You are about to do a distribution upgrade with all enabled
> repositories. Make sure these repositories are compatible before you
> continue. See 'man zypper' for more information about this command.
> Initializing Target
> Checking whether to refresh metadata for ACE
> Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for
> KDE:Applications_openSUSE_Leap_42.2 Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for
> KDE:Extra_openSUSE_Leap_42.2 Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for
> KDE:Frameworks5_openSUSE_Leap_42.2 Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for
> KDE:Qt5_openSUSE_Leap_42.2 Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Retrieving: media
> ............................................................................
> ............................................................................
> ............................................................................
> ..................[error] Retrieving: repomd.xml.asc
> ............................................................................
> ............................................................................
> ............................................................................
> ..........[done] Retrieving: repomd.xml.key
> ............................................................................
> ............................................................................
> ............................................................................
> ..........[done] Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Repository:       KDE:Qt5_openSUSE_Leap_42.2
>    Key Name:         KDE OBS Project <[hidden email]>
>    Key Fingerprint:  4E8E6DE2 961F3083 EAC50086 27C07017 6F88BB2F
>    Key Created:      Mon Nov  7 14:39:08 2016
>    Key Expires:      Wed Jan 16 14:39:08 2019
>    Rpm Name:         gpg-pubkey-6f88bb2f-5820920c
> Retrieving:
> 093099d5dd8e89f4424331214ace769d9685d98f8eda46dd3487a68ccdc62d06-primary.xml
> .gz
> ...........................................................................
> ............................................................................
> .........[done (26.4 KiB/s)]
> Retrieving repository 'KDE:Qt5_openSUSE_Leap_42.2' metadata
> ............................................................................
> ............................................................................
> .....................................................[done] Building
> repository 'KDE:Qt5_openSUSE_Leap_42.2' cache
> ............................................................................
> ............................................................................
> ..........................................................[done] Checking
> whether to refresh metadata for LibreOffice:5.3_openSUSE_42.2 Retrieving:
> repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for M17N:fonts
> Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for Packman
> Repository
> Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for
> openSUSE-Leap_42.2-NonOss-Source Retrieving: content
> ............................................................................
> ............................................................................
> ............................................................................
> .................[done] Retrieving: media
> ............................................................................
> ............................................................................
> ............................................................................
> ...................[done] Checking whether to refresh metadata for openSUSE
> BuildService - GNOME:Apps Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for google-chrome
> Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for google-earth
> Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for
> google-musicmanager
> Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for
> google-talkplugin
> Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for
> openSUSE-Leap_42.2-Oss_Debug Retrieving: content
> ............................................................................
> ............................................................................
> ............................................................................
> .................[done] Retrieving: media
> ............................................................................
> ............................................................................
> ............................................................................
> ...................[done] Checking whether to refresh metadata for
> openSUSE-Leap_42.2-Update-Non-Oss Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for
> openSUSE-Leap_42.2-Update-Debug-Oss Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for
> openSUSE-Leap_42.2-Update-Oss Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for openSUSE
> BuildService - Mozilla Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Checking whether to refresh metadata for VirtualBox for
> openSUSE 13.2 Retrieving: repomd.xml
> ............................................................................
> ............................................................................
> ............................................................................
> ..............[done] Loading repository data...
> Reading installed packages...
> Computing distribution upgrade...
> Force resolution: No
> Computing upgrade...
> 65 Problems:
> Problem:
> libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-18.1.x86_64
> requires libQt5Core.so.5(Qt_5.7.1_PRIVATE_API)(64bit), but this
> requirement cannot be provided
> Problem: libQtQuick5-5.8.0-9.2.x86_64 requires
> libQt5Gui.so.5(Qt_5.8.0_PRIVATE_API)(64bit), but this requirement cannot
> be provided
> Problem: mbox-importer-17.04.0-17.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libmarblewidget-qt5-27-17.04.0-5.9.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libkerfuffle17-17.04.0-4.10.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libQt5Charts5-5.8.0-8.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKPimKDAV5-17.04.0-3.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKPimGAPITasks5-17.04.0-23.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKPimGAPICore5-17.04.0-23.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKPimGAPIContacts5-17.04.0-23.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKPimGAPICalendar5-17.04.0-23.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5PimCommonAkonadi5-17.04.0-52.2.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5MailTransportAkonadi5-17.04.0-61.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5MailTransport5-17.04.0-61.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5MailImporterAkonadi5-17.04.0-48.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5LibkdepimAkonadi5-17.04.0-41.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5Kipi32_0_0-17.04.0-3.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5CompactDisc5-17.04.0-19.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5Cddb5-17.04.0-21.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kmail-account-wizard-17.04.0-17.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kleopatra-17.04.0-19.2.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: akonadi-import-wizard-17.04.0-17.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: akonadi-calendar-tools-17.04.0-18.10.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: akonadi-calendar-tools-17.04.0-18.10.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: spectacle-17.04.0-48.8.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: okular-17.04.0-4.9.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: messagelib-17.04.0-44.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: mbox-importer-17.04.0-17.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: marble-17.04.0-5.9.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libksieve-17.04.0-50.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libkomparediff2-5-17.04.0-5.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libkdepim-17.04.0-41.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5Mime5-17.04.0-56.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5KontactInterface5-17.04.0-55.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5IdentityManagement5-17.04.0-56.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5IMAP5-17.04.0-56.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5Contacts5-17.04.0-53.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5CompactDisc5-17.04.0-19.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5AkonadiNotes5-17.04.0-28.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5AkonadiCalendar5-17.04.0-67.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kwalletmanager5-17.04.0-52.10.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libKF5Tnef5-17.04.0-57.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kruler-17.04.0-4.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: krfb-17.04.0-4.10.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: krdc-17.04.0-4.10.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kpat-17.04.0-4.10.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: korganizer-17.04.0-19.11.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kontact-17.04.0-18.8.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: konsole-17.04.0-5.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: konqueror-17.04.0-19.10.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kompare-17.04.0-5.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kolourpaint-17.04.0-4.10.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: knotes-17.04.0-19.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kmines-17.04.0-4.10.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kmailtransport-17.04.0-61.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kmail-account-wizard-17.04.0-17.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kmail-17.04.0-24.10.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kmahjongg-17.04.0-4.8.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kleopatra-17.04.0-19.2.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kldap-17.04.0-61.1.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kio_kamera-17.04.0-5.7.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: kio_audiocd-17.04.0-4.10.x86_64 requires
> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
> Problem: libQt5Core-devel-5.8.0-32.1.x86_64 requires
> libqt5-qtbase-common-devel = 5.8.0, but this requirement cannot be provided
> Problem: libqt5-qttools-5.8.0-8.2.x86_64 requires libQt5Help5 = 5.8.0,
> but this requirement cannot be provided
> Problem: libqt5-qttools-5.8.0-8.2.x86_64 requires libQt5Help5 = 5.8.0,
> but this requirement cannot be provided
>
> Problem:
> libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-18.1.x86_64
> requires libQt5Core.so.5(Qt_5.7.1_PRIVATE_API)(64bit), but this
> requirement cannot be provided
>    uninstallable providers:
> libQt5Core5-5.7.1-287.1.x86_64[KDE:Qt55_openSUSE_Leap_42.2]
>   Solution 1: Following actions will be done:
>    deinstallation of libQt5Charts5-5.8.0-8.1.x86_64
>    deinstallation of kgpg-lang-17.04.0-4.9.noarch
>    deinstallation of keditbookmarks-lang-17.04.0-17.1.noarch
>    deinstallation of kdialog-lang-17.04.0-17.1.noarch
>    deinstallation of kdepim-runtime-lang-17.04.0-84.1.noarch
>    deinstallation of kdepim-apps-libs-lang-17.04.0-43.1.noarch
>    deinstallation of kdepim-addons-lang-17.04.0-45.1.noarch
>    deinstallation of kdenetwork4-filesharing-lang-17.04.0-4.1.noarch
>    deinstallation of kde-print-manager-lang-17.04.0-70.1.noarch
>    deinstallation of kcron-lang-17.04.0-4.8.noarch
>    deinstallation of kcolorchooser-lang-17.04.0-4.1.noarch
>    deinstallation of kcharselect-lang-17.04.0-4.8.noarch
>    deinstallation of kcalutils-lang-17.04.0-61.1.noarch
>    deinstallation of kcalc-lang-17.04.0-4.8.noarch
>    deinstallation of kate-lang-17.04.0-5.8.noarch
>    deinstallation of kaddressbook-lang-17.04.0-19.1.noarch
>    deinstallation of kaccounts-providers-lang-17.04.0-69.1.noarch
>    deinstallation of kaccounts-integration-lang-17.04.0-73.1.noarch
>    deinstallation of gwenview5-lang-17.04.0-64.11.noarch
>    deinstallation of grantleetheme-lang-17.04.0-39.1.noarch
>    deinstallation of dragonplayer-lang-17.04.0-5.8.noarch
>    deinstallation of dolphin-lang-17.04.0-89.8.noarch
>    deinstallation of baloo5-widgets-lang-17.04.0-55.1.noarch
>    deinstallation of ark-lang-17.04.0-4.10.noarch
>    deinstallation of akregator-lang-17.04.0-19.10.noarch
>    deinstallation of kdepim-runtime-17.04.0-84.1.x86_64
>    deinstallation of akonadi-server-lang-17.04.0-99.10.noarch
>    deinstallation of akonadi-search-lang-17.04.0-64.1.noarch
>    deinstallation of akonadi-import-wizard-lang-17.04.0-17.1.noarch
>    deinstallation of akonadi-contact-lang-17.04.0-32.1.noarch
>    deinstallation of libkgeomap-lang-17.04.0-79.1.noarch
>   Solution 2: keep obsolete
> libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-12.1.x86_64
>   Solution 3: break
> libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-18.1.x86_64
> by ignoring some of its dependencies
>
> Choose from above solutions by number or skip, retry or cancel
> [1/2/3/s/r/c] (c):

You are lucky.. :)
I get 84 errors with tumbleweed if i do  zypper dup --no-allow-vendor-change -
l

--
opensuse:tumbleweed:20170510
Qt: 5.7.1
KDE Frameworks: 5.33.0
KDE Plasma: 5.9.5
kwin 5.9.5
kmail2 5.5.0
akonadiserver 5.5.0
Kernel:  4.10.13-1-default
Nouveau:  1.0.15_1.1

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

Vadym Krevs
On 16/05/17 17:17, ianseeks wrote:

> On Tuesday, 16 May 2017 15:40:46 BST Vadym Krevs wrote:
>> On 16/05/17 15:38, Luca Beltrame wrote:
>>> In data martedì 16 maggio 2017 16:31:55 CEST, Vadym Krevs ha scritto:
>>>> Still not upgradeable to via zypper dup - at least for  me.
>>> What is the error you are getting?
>> zypper -v dup
>> Verbosity: 1
>> Warning: You are about to do a distribution upgrade with all enabled
>> repositories. Make sure these repositories are compatible before you
>> continue. See 'man zypper' for more information about this command.
>> Initializing Target
>> Checking whether to refresh metadata for ACE
>> Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for
>> KDE:Applications_openSUSE_Leap_42.2 Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for
>> KDE:Extra_openSUSE_Leap_42.2 Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for
>> KDE:Frameworks5_openSUSE_Leap_42.2 Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for
>> KDE:Qt5_openSUSE_Leap_42.2 Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Retrieving: media
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..................[error] Retrieving: repomd.xml.asc
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..........[done] Retrieving: repomd.xml.key
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..........[done] Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Repository:       KDE:Qt5_openSUSE_Leap_42.2
>>     Key Name:         KDE OBS Project <[hidden email]>
>>     Key Fingerprint:  4E8E6DE2 961F3083 EAC50086 27C07017 6F88BB2F
>>     Key Created:      Mon Nov  7 14:39:08 2016
>>     Key Expires:      Wed Jan 16 14:39:08 2019
>>     Rpm Name:         gpg-pubkey-6f88bb2f-5820920c
>> Retrieving:
>> 093099d5dd8e89f4424331214ace769d9685d98f8eda46dd3487a68ccdc62d06-primary.xml
>> .gz
>> ...........................................................................
>> ............................................................................
>> .........[done (26.4 KiB/s)]
>> Retrieving repository 'KDE:Qt5_openSUSE_Leap_42.2' metadata
>> ............................................................................
>> ............................................................................
>> .....................................................[done] Building
>> repository 'KDE:Qt5_openSUSE_Leap_42.2' cache
>> ............................................................................
>> ............................................................................
>> ..........................................................[done] Checking
>> whether to refresh metadata for LibreOffice:5.3_openSUSE_42.2 Retrieving:
>> repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for M17N:fonts
>> Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for Packman
>> Repository
>> Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for
>> openSUSE-Leap_42.2-NonOss-Source Retrieving: content
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> .................[done] Retrieving: media
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ...................[done] Checking whether to refresh metadata for openSUSE
>> BuildService - GNOME:Apps Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for google-chrome
>> Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for google-earth
>> Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for
>> google-musicmanager
>> Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for
>> google-talkplugin
>> Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for
>> openSUSE-Leap_42.2-Oss_Debug Retrieving: content
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> .................[done] Retrieving: media
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ...................[done] Checking whether to refresh metadata for
>> openSUSE-Leap_42.2-Update-Non-Oss Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for
>> openSUSE-Leap_42.2-Update-Debug-Oss Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for
>> openSUSE-Leap_42.2-Update-Oss Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for openSUSE
>> BuildService - Mozilla Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Checking whether to refresh metadata for VirtualBox for
>> openSUSE 13.2 Retrieving: repomd.xml
>> ............................................................................
>> ............................................................................
>> ............................................................................
>> ..............[done] Loading repository data...
>> Reading installed packages...
>> Computing distribution upgrade...
>> Force resolution: No
>> Computing upgrade...
>> 65 Problems:
>> Problem:
>> libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-18.1.x86_64
>> requires libQt5Core.so.5(Qt_5.7.1_PRIVATE_API)(64bit), but this
>> requirement cannot be provided
>> Problem: libQtQuick5-5.8.0-9.2.x86_64 requires
>> libQt5Gui.so.5(Qt_5.8.0_PRIVATE_API)(64bit), but this requirement cannot
>> be provided
>> Problem: mbox-importer-17.04.0-17.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libmarblewidget-qt5-27-17.04.0-5.9.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libkerfuffle17-17.04.0-4.10.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libQt5Charts5-5.8.0-8.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKPimKDAV5-17.04.0-3.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKPimGAPITasks5-17.04.0-23.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKPimGAPICore5-17.04.0-23.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKPimGAPIContacts5-17.04.0-23.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKPimGAPICalendar5-17.04.0-23.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5PimCommonAkonadi5-17.04.0-52.2.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5MailTransportAkonadi5-17.04.0-61.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5MailTransport5-17.04.0-61.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5MailImporterAkonadi5-17.04.0-48.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5LibkdepimAkonadi5-17.04.0-41.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5Kipi32_0_0-17.04.0-3.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5CompactDisc5-17.04.0-19.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5Cddb5-17.04.0-21.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kmail-account-wizard-17.04.0-17.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kleopatra-17.04.0-19.2.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: akonadi-import-wizard-17.04.0-17.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: akonadi-calendar-tools-17.04.0-18.10.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: akonadi-calendar-tools-17.04.0-18.10.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: spectacle-17.04.0-48.8.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: okular-17.04.0-4.9.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: messagelib-17.04.0-44.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: mbox-importer-17.04.0-17.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: marble-17.04.0-5.9.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libksieve-17.04.0-50.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libkomparediff2-5-17.04.0-5.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libkdepim-17.04.0-41.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5Mime5-17.04.0-56.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5KontactInterface5-17.04.0-55.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5IdentityManagement5-17.04.0-56.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5IMAP5-17.04.0-56.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5Contacts5-17.04.0-53.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5CompactDisc5-17.04.0-19.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5AkonadiNotes5-17.04.0-28.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5AkonadiCalendar5-17.04.0-67.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kwalletmanager5-17.04.0-52.10.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libKF5Tnef5-17.04.0-57.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kruler-17.04.0-4.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: krfb-17.04.0-4.10.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: krdc-17.04.0-4.10.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kpat-17.04.0-4.10.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: korganizer-17.04.0-19.11.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kontact-17.04.0-18.8.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: konsole-17.04.0-5.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: konqueror-17.04.0-19.10.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kompare-17.04.0-5.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kolourpaint-17.04.0-4.10.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: knotes-17.04.0-19.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kmines-17.04.0-4.10.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kmailtransport-17.04.0-61.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kmail-account-wizard-17.04.0-17.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kmail-17.04.0-24.10.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kmahjongg-17.04.0-4.8.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kleopatra-17.04.0-19.2.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kldap-17.04.0-61.1.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kio_kamera-17.04.0-5.7.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: kio_audiocd-17.04.0-4.10.x86_64 requires
>> libQt5Core.so.5(Qt_5.8)(64bit), but this requirement cannot be provided
>> Problem: libQt5Core-devel-5.8.0-32.1.x86_64 requires
>> libqt5-qtbase-common-devel = 5.8.0, but this requirement cannot be provided
>> Problem: libqt5-qttools-5.8.0-8.2.x86_64 requires libQt5Help5 = 5.8.0,
>> but this requirement cannot be provided
>> Problem: libqt5-qttools-5.8.0-8.2.x86_64 requires libQt5Help5 = 5.8.0,
>> but this requirement cannot be provided
>>
>> Problem:
>> libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-18.1.x86_64
>> requires libQt5Core.so.5(Qt_5.7.1_PRIVATE_API)(64bit), but this
>> requirement cannot be provided
>>     uninstallable providers:
>> libQt5Core5-5.7.1-287.1.x86_64[KDE:Qt55_openSUSE_Leap_42.2]
>>    Solution 1: Following actions will be done:
>>     deinstallation of libQt5Charts5-5.8.0-8.1.x86_64
>>     deinstallation of kgpg-lang-17.04.0-4.9.noarch
>>     deinstallation of keditbookmarks-lang-17.04.0-17.1.noarch
>>     deinstallation of kdialog-lang-17.04.0-17.1.noarch
>>     deinstallation of kdepim-runtime-lang-17.04.0-84.1.noarch
>>     deinstallation of kdepim-apps-libs-lang-17.04.0-43.1.noarch
>>     deinstallation of kdepim-addons-lang-17.04.0-45.1.noarch
>>     deinstallation of kdenetwork4-filesharing-lang-17.04.0-4.1.noarch
>>     deinstallation of kde-print-manager-lang-17.04.0-70.1.noarch
>>     deinstallation of kcron-lang-17.04.0-4.8.noarch
>>     deinstallation of kcolorchooser-lang-17.04.0-4.1.noarch
>>     deinstallation of kcharselect-lang-17.04.0-4.8.noarch
>>     deinstallation of kcalutils-lang-17.04.0-61.1.noarch
>>     deinstallation of kcalc-lang-17.04.0-4.8.noarch
>>     deinstallation of kate-lang-17.04.0-5.8.noarch
>>     deinstallation of kaddressbook-lang-17.04.0-19.1.noarch
>>     deinstallation of kaccounts-providers-lang-17.04.0-69.1.noarch
>>     deinstallation of kaccounts-integration-lang-17.04.0-73.1.noarch
>>     deinstallation of gwenview5-lang-17.04.0-64.11.noarch
>>     deinstallation of grantleetheme-lang-17.04.0-39.1.noarch
>>     deinstallation of dragonplayer-lang-17.04.0-5.8.noarch
>>     deinstallation of dolphin-lang-17.04.0-89.8.noarch
>>     deinstallation of baloo5-widgets-lang-17.04.0-55.1.noarch
>>     deinstallation of ark-lang-17.04.0-4.10.noarch
>>     deinstallation of akregator-lang-17.04.0-19.10.noarch
>>     deinstallation of kdepim-runtime-17.04.0-84.1.x86_64
>>     deinstallation of akonadi-server-lang-17.04.0-99.10.noarch
>>     deinstallation of akonadi-search-lang-17.04.0-64.1.noarch
>>     deinstallation of akonadi-import-wizard-lang-17.04.0-17.1.noarch
>>     deinstallation of akonadi-contact-lang-17.04.0-32.1.noarch
>>     deinstallation of libkgeomap-lang-17.04.0-79.1.noarch
>>    Solution 2: keep obsolete
>> libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-12.1.x86_64
>>    Solution 3: break
>> libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-18.1.x86_64
>> by ignoring some of its dependencies
>>
>> Choose from above solutions by number or skip, retry or cancel
>> [1/2/3/s/r/c] (c):
> You are lucky.. :)
> I get 84 errors with tumbleweed if i do  zypper dup --no-allow-vendor-change -
> l
>
That was just the first choice presented by zypper dup. I've tried
stepping through the solver conflicts, but after pressing single digits
about 200 times I gave up.

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

Wolfgang Bauer
In reply to this post by Luca Beltrame
Am Dienstag, 16. Mai 2017, 17:57:51 schrieb Luca Beltrame:
> In data martedì 16 maggio 2017 17:41:31 CEST, Wolfgang Bauer ha scritto:
> > I don't think this is a problem though, nor a reason to not enable
> > publishing.
>
> It will certainly lead to breakage, although no different than this one (ark
> won't install, for one).

And why do you think that?
The dependency list in OBS for the lastly built ark package looks quite sane
(and installable) to me...

https://build.opensuse.org/package/binary/KDE:Applications/ark?arch=x86_64&filename=ark-17.04.0-4.12.x86_64.rpm&repository=KDE_Frameworks5_openSUSE_Leap_42.2
https://build.opensuse.org/package/binary/KDE:Applications/ark?arch=x86_64&filename=libkerfuffle17-17.04.0-4.12.x86_64.rpm&repository=KDE_Frameworks5_openSUSE_Leap_42.2

(and the other two as well)

> They're actually suffering from a different problem, because the release
> script inject some CMake magic in the CmakeLists of these for translations
> and KF 5.34 had some changes in the ki18n_install macro: these packages
> were doing it already, causing a double CMake target to get generated (to
> be more precise, there are double ki18n_install calls), and so build fails
> at configuration.

Yes, but that only breaks the build, not the existing/already built binary
package.

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

Patrick Shanahan-2
In reply to this post by Vadym Krevs
* Vadym Krevs <[hidden email]> [05-16-17 12:26]:
> On 16/05/17 17:17, ianseeks wrote:

 [...]

> >>libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-12.1.x86_64
> >>   Solution 3: break
> >>libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-18.1.x86_64
> >>by ignoring some of its dependencies
> >>
> >>Choose from above solutions by number or skip, retry or cancel
> >>[1/2/3/s/r/c] (c):
> >You are lucky.. :)
> >I get 84 errors with tumbleweed if i do  zypper dup --no-allow-vendor-change -
> >l
> >
> That was just the first choice presented by zypper dup. I've tried stepping
> through the solver conflicts, but after pressing single digits about 200
> times I gave up.

I suppose it would be wrong of me to ask that either or both of you be a
little more considerate and trim your replies, but I still have to ask.

please trim your replies.  most of us will appreciate this small effort.

--
(paka)Patrick Shanahan       Plainfield, Indiana, USA          @ptilopteri
http://en.opensuse.org    openSUSE Community Member    facebook/ptilopteri
Registered Linux User #207535                    @ http://linuxcounter.net
Photos: http://wahoo.no-ip.org/piwigo                 
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

Fabian Vogt-2
In reply to this post by Wolfgang Bauer
Am Dienstag, 16. Mai 2017, 17:41:31 CEST schrieb Wolfgang Bauer:

> Am Dienstag, 16. Mai 2017, 17:13:02 schrieb Luca Beltrame:
> > The reason is that KDE:Applications is still publishing disabled. Now that
> > kf5-filesystem is in, I could enable it, but only for TW, because a few
> > packages (3) don't build when using the latest Frameworks (5.34 in K:F5).
>
> I don't think this is a problem though, nor a reason to not enable publishing.
>
> AFAICS, those 3 packages have been built against Qt 5.7.1 before the KF5
> update, and the already built binaries should not get broken by that update
> either.
>
> There is (still) a different problem too though: libqt5-qtcharts in KDE:Qt5
> has not been downgraded to 5.7.1 and is still at 5.8.0.

For some reason it's not in openSUSE:Factory, so the script doing the downgrade
didn't pick it up.

I reverted it manually now and submitted it to oS:F.

Cheers,
Fabian

> And that's also mentioned in the posted conflicts list.
> It could probably just be uninstalled for now though, I don't think any KDE
> package needs it (I don't have it installed here, and it is not in Tumbleweed
> yet either).
>
> Kind Regards,
> Wolfgang
>
>


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

Luca Beltrame
In reply to this post by Wolfgang Bauer
Il 16 maggio 2017 18:25:57 CEST, Wolfgang Bauer <[hidden email]> ha scritto:

>The dependency list in OBS for the lastly built ark package looks quite
>sane
>(and installable) to me...

Fair enough. I've enabled publishing now.

--
Luca Beltrame
GPG key ID: 6E1A4E79
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

Vadym Krevs
On 16/05/17 17:34, Luca Beltrame wrote:
> Il 16 maggio 2017 18:25:57 CEST, Wolfgang Bauer <[hidden email]> ha scritto:
>
>> The dependency list in OBS for the lastly built ark package looks quite
>> sane
>> (and installable) to me...
> Fair enough. I've enabled publishing now.
>
Thanks a lot - all sorted now.

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 now hosts the Plasma 5.10 beta

ianseeks-4
In reply to this post by Patrick Shanahan-2
On Tuesday, 16 May 2017 17:33:26 BST Patrick Shanahan wrote:
> * Vadym Krevs <[hidden email]> [05-16-17 12:26]:
> > On 16/05/17 17:17, ianseeks wrote:
>  [...]
>

>
> I suppose it would be wrong of me to ask that either or both of you be a
> little more considerate and trim your replies, but I still have to ask.
>
> please trim your replies.  most of us will appreciate this small effort.
ok

--
opensuse:tumbleweed:20170510
Qt: 5.7.1
KDE Frameworks: 5.33.0
KDE Plasma: 5.9.5
kwin 5.9.5
kmail2 5.5.0
akonadiserver 5.5.0
Kernel:  4.10.13-1-default
Nouveau:  1.0.15_1.1

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Loading...