KDE:Frameworks5 and current 5.33.0

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

KDE:Frameworks5 and current 5.33.0

Martin Koller
Hi,

https://build.opensuse.org/project/show/KDE:Frameworks5

is it planned to update this repo (esp. for leap 42.2) to current 5.33 ?

--
Best regards/Schöne Grüße

Martin
A: Because it breaks the logical sequence of discussion
Q: Why is top posting bad?

()  ascii ribbon campaign - against html e-mail
/\                        - against proprietary attachments

Geschenkideen, Accessoires, Seifen, Kulinarisches: www.lillehus.at
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 and current 5.33.0

Luca Beltrame
In data venerdì 14 aprile 2017 17:48:07 CEST, Martin Koller ha scritto:

> is it planned to update this repo (esp. for leap 42.2) to current 5.33 ?

Yes, I plan to do so in the next few days. One feature (authorization to edit
file as root with kedit or kate) will not be present, because for now the
security team is against it (I plan on opening a new discussion upstream soon
for a proper fix).

--
Luca Beltrame - KDE Forums team
GPG key ID: A29D259B

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 and current 5.33.0

Martin Koller
Hi,

On Samstag, 15. April 2017 00:15:14 CEST Luca Beltrame wrote:
> In data venerdì 14 aprile 2017 17:48:07 CEST, Martin Koller ha scritto:
>
> > is it planned to update this repo (esp. for leap 42.2) to current 5.33 ?
>
> Yes, I plan to do so in the next few days. One feature (authorization to edit
> file as root with kedit or kate) will not be present, because for now the
> security team is against it (I plan on opening a new discussion upstream soon
> for a proper fix).

I'm puzzled. Hope you can help me understand things

I see that http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.2/x86_64/?C=M;O=A
the last change was
 libqgpgme7-debuginfo-1.9.0-120.2.x86_64.rpm                        18-Apr-2017 16:37
however
https://build.opensuse.org/package/binary/KDE:Frameworks5/kio?arch=x86_64&filename=kio-5.33.0-176.5.x86_64.rpm&repository=openSUSE_Leap_42.2
this was built yesterday.

Id did update everything today and now I can now longer use e.g. sftp:// man:// etc.
since kio is too old (I assume that's the reason)

--
Best regards/Schöne Grüße

Martin
A: Because it breaks the logical sequence of discussion
Q: Why is top posting bad?

()  ascii ribbon campaign - against html e-mail
/\                        - against proprietary attachments

Geschenkideen, Accessoires, Seifen, Kulinarisches: www.lillehus.at
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 and current 5.33.0

Wolfgang Bauer
Am Freitag, 21. April 2017, 14:23:47 schrieb Martin Koller:
> Id did update everything today and now I can now longer use e.g. sftp://
> man:// etc. since kio is too old (I assume that's the reason)

The likely reason is that KDE Frameworks5 currently contains a mixture of
5.32.0 and 5.33.0.
Publishing is still disabled for the repo, but apparently some 5.33 packages
got built and published already before it was disabled.

Also that means that you cannot install some packages from KDE:Applications
currently on 42.2, because they have been built against and require KDE
Frameworks 5.33 already (dolphin in particular).

So, I'd like to ask:
Can we re-enable publishing in KDE:Frameworks5?
Or is there a specific reason why it is still disabled?

Btw, the new feature that ktexteditor will allow saving root-owned files after
authorization (with Kate and KWrite e.g.) is not yet in 5.33.0 anyway, it will
only be part of 5.34.0...

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 and current 5.33.0

Luca Beltrame
Il 23 aprile 2017 19:51:48 CEST, Wolfgang Bauer <[hidden email]> ha scritto:

>Can we re-enable publishing in KDE:Frameworks5?
>Or is there a specific reason why it is still disabled?

No reason, I simply had some offline issues to sort out and I forgot about it. Originally it had been disabled to fix some dependency issues.

--
Luca Beltrame
GPG key ID: 6E1A4E79
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE:Frameworks5 and current 5.33.0

Wolfgang Bauer
Am Sonntag, 23. April 2017, 21:17:26 schrieb Luca Beltrame:
> No reason

Good. I re-enabled it then...

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

KDE Applications repository publishing disabled ( was Re: [opensuse-kde] KDE:Frameworks5 and current 5.33.0)

Luca Beltrame
In data lunedì 24 aprile 2017 13:42:43 CEST, Wolfgang Bauer ha scritto:

> Good. I re-enabled it then...

On that topic, KDE:Applications will stay disabled as most packages are
uninstallable until an updated kf5-filesystem hits Tumbleweed.

--
Luca Beltrame - KDE Forums team
GPG key ID: A29D259B

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE Applications repository publishing disabled ( was Re: [opensuse-kde] KDE:Frameworks5 and current 5.33.0)

ianseeks-4
On Monday, 24 April 2017 12:53:25 BST Luca Beltrame wrote:
> In data lunedì 24 aprile 2017 13:42:43 CEST, Wolfgang Bauer ha scritto:
> > Good. I re-enabled it then...
>
> On that topic, KDE:Applications will stay disabled as most packages are
> uninstallable until an updated kf5-filesystem hits Tumbleweed.
And any idea when that might happen?

--
opensuse:tumbleweed:20170419
Qt: 5.7.1
KDE Frameworks: 5.32.0
KDE Plasma: 5.9.4
kwin 5.9.4
kmail2 5.4.3
akonadiserver 5.4.3
Kernel:  4.10.9-1-default
Nouveau:  1.0.14_2.1

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE Applications repository publishing disabled ( was Re: [opensuse-kde] KDE:Frameworks5 and current 5.33.0)

Luca Beltrame
In data lunedì 24 aprile 2017 17:43:32 CEST, ianseeks ha scritto:

> And any idea when that might happen?

As I just resent the whole Applications 17.04 release for inclusion, my guess
is that once it lands into Tumbleweed.

--
Luca Beltrame - KDE Forums team
GPG key ID: A29D259B

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: KDE Applications repository publishing disabled ( was Re: [opensuse-kde] KDE:Frameworks5 and current 5.33.0)

ianseeks-4
On Monday, 24 April 2017 16:57:03 BST Luca Beltrame wrote:
> In data lunedì 24 aprile 2017 17:43:32 CEST, ianseeks ha scritto:
> > And any idea when that might happen?
>
> As I just resent the whole Applications 17.04 release for inclusion, my
> guess is that once it lands into Tumbleweed.
thanks

--
opensuse:tumbleweed:20170420
Qt: 5.7.1
KDE Frameworks: 5.32.0
KDE Plasma: 5.9.4
kwin 5.9.4
kmail2 5.4.3
akonadiserver 5.4.3
Kernel:  4.10.10-1-default
Nouveau:  1.0.14_2.1

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Loading...